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Measurement 

Measurement 

This chapter provides information related to the measurements done 
through E5061B. 

 Setting Measurement Conditions 

 Calibration 

 Making Measurements 

 Data Analysis 

 Data Output 

 Optimizing Measurements 

 Measurement Examples 
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Setting Measurement Conditions 

 Setting Measurement Conditions 

 Initializing Parameters 

 Setting the System Z0 

 Setting Channels and Traces 

 Selecting Measurement Parameters 

 Setting Stimulus Conditions 

 Applying DC bias 

 Selecting a Data Format 

 Setting the Scales 

 Setting Window Displays 

 Setting Port Coupling 
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Initializing Parameters 

The E5061B has three different initial settings as shown below. 

Initial setting Restore method 

Preset state Press Preset > OK the front panel or Execute the 
:SYST:PRES command 

*RST state Execute the *RST command 

Factory default 
setting 

E5061B factory (default) settings 

The user can set items to be preset freely. For more information, see 
Setting the user preset function. 

Other topics about Setting Measurement Conditions 
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Setting the System Z0 

The procedure for setting the system characteristic impedance (Z0) is as 
follows: 

1. Press Cal key. 

2. Click Set Z0, then input the system Z0. 

Other topics about Setting Measurement Conditions 
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Setting Channels and Traces 

 Overview of Channel and Trace 

 Number of Channels Traces 

 Setting Channel Display (Layout of Channels) 

 Setting Trace Display 

 Active Channel 

Other topics about Setting Measurement Conditions 

Overview of Channel and Trace 

The E5061B allows you to setup multiple channels to perform 
measurement under different stimulus conditions. 

As multiple traces (measurement parameters) can be displayed for each 
channel, no feature is provided to link the stimulus conditions between 
channels, and each channel is always independent of the others. In other 
words, you need to set the measurement conditions and execute 
calibration for each channel you use for measurement. 

When you set items whose setting target is channels/traces (refer to 
Parameter setting for each setup item), the target is the selected (active) 
channel/trace. You can specify only the displayed channels/traces as active 
channels/traces. Therefore, set the display of channels/traces before 
setting the measurement conditions. 

Setting Parameter for each Setup Item (Analyzer, Channel, Trace) 

The following table lists the setting parameters and indicates the setup 
item (analyzer, channel, or trace) that each parameter controls along with 
the applicable setup key(s). 

Parameter Controlled Setup Items Setup Key(s) 

Analyzer Channel Trace 

Stimulus Settings   

Sweep range   x   Start, Stop, Center, 
Span 

Power, CW frequency   x   Sweep Setup > 
Power 

Sweep time/Sweep 
delay time 

  x   Sweep Setup > 
Sweep Time, Sweep 
Delay 



E5061B 

104 

Number of points   x   Sweep Setup > 
Points 

Segment sweep   x 

  

  Sweep Setup > 
Sweep Type, Edit 
Segment Table, 
Segment Display 

DC Bias   x   Sweep Setup > 
Sweep Type 

Trigger Settings   

Trigger mode   x   Trigger > 
Hold/Single/ 
Continuous 

  x      Hold All 
Channels/Continuous 
Disp Channels 

Trigger source, Trigger 
Event, Trigger Scope 

x      Trigger > 
Trigger Source, 
Trigger Event, 
Trigger Scope 

Trigger x     Trigger > 
Restart/Trigger 

Ext Trigger Input, 
Trigger Delay 

x     Trigger > Ext Trig 
Input, Trigger Delay 

Ext Trigger Output, 
Polarity, Position, Pulse 
Width 

x     Trigger > Ext Trig 
Output, Polarity, 
Position, Pulse Width 

Response Settings   

Measurement parameter     x Meas 

Data format     x   Format 

Scale, Electrical delay, 
Phase offset 

    x Scale 

  

Memory trace and data 
math 

    x Display > 
Display/Data-> Mem/ 
Data Math 
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Equation Editor   x   Display > Equation 
Editor/Equation 
 (ON/OFF) 

Window title   x    Display > Edit Title 
Label/ 
Title Label (ON/OFF) 

Graticule label in 
rectangular form 

  x    Display > Graticule 
Label (ON/OFF) 

Color inversion x     Display > Invert 
Color 

Frequency display x       Display > Frequency 
(ON/OFF) 

Display update x       Display > Update 
(ON/OFF) 

Averaging   x   Avg > 
Averaging Restart/ 
Avg Factor/Averaging 
(ON/OFF) 

Averaging Trigger x     Avg > Avg Trigger 
 (ON/OFF) 

Smoothing     x Avg > Smo Aperture/ 
 Smoothing (ON/OFF) 

IF bandwidth, IF BW 
Auto, IF BW Auto Limit 

  x   Avg > IF Bandwidth, 
IFBW Auto, IFBW 
Auto Limit 

Calibration   x   Cal 

System Impedance x     Cal > Set Z0 

Marker     x Marker, Marker 
Search, Maker Fctn 

Market Table x     Maker Fctn > Maker 
Table 

Analysis   

Time domain, Fault 
Location, 

    x Analysis > Gating, 
Fault Location 



E5061B 

106 

SRL   x   Analysis > SRL 

Parameter conversion     x Analysis > 
Conversion 

Limit test, Ripple Test, 
Bandwidth Test 

    x Analysis > Limit 
Test, Ripple Test, 
Bandwidth Limit 

Saving and recalling 
data 

x     Save/Recall 

Macro x     Macro Setup, Macro 
Run, Macro Break 

System   

Printing/Saving display 
Screen/Beeper/GPIB 
settings/Network 
Settings/Date & 
Time/Key 
Lock/Backlight/Firmware 
Revision/Service menu 

x     System 

Preset x     Preset 

Number of Channels/Traces 

The number of channels and the number of traces are 4. The maximum 
number of points is 1601. 

Setting Channel Display (Layout of Channels) 

The measurement result for each channel is displayed in its dedicated 
window (channel window). You cannot have a single window to display the 
measurement results from more than one channel. This means that the 
setting of the window layout determines the number of channels displayed 
on screen. 

 The execution of measurement for each channel does not 
depend on how the channel is displayed (channels that are not 
displayed can be measured). For information on executing 
measurement for each channel (trigger mode and trigger source), refer 
to Making Measurements. 

The procedure for setting the window layout is as follows: 

1.  Press Display > Allocate Channels. 

2.   Press the desired softkey to select the window layout. 

Setting Trace Display 
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Setting the number of traces 

Depending on the measurement parameters of the traces displayed for 
each channel, the sweep necessary for each channel is executed. For more 
information, refer to Sweep Order in Each Channel. 

You specify the trace display by setting the number of traces (upper limit 
of displayed trace numbers). For example, if you set the number of traces 
to 3, traces 1 through 3 are displayed. 

The procedure for setting the number of traces is as follows: 

1.    Press Channel Next (or Channel Prev) to select the channel for which 
you want to set the number of traces. 

2.    Press Display > Number of Traces. 

3.    Press the desired softkey to set the number of traces. 
Setting trace layout (graph layout) 

Traces are laid out and displayed in the order of the trace number from 
graph 1 according to the graph layout in the channel window. 

You can select the graph layout from the windows layout. 

If the number of traces is less than the number of graphs, nothing is 
displayed in the remaining area. If the number of traces you set exceeds 
the number of graphs, excess traces are superimposed from the first 

graph. For example, if you select  as the graph layout and set 
the number of traces to 4, graph 1 (Gr1 in Graph layout) display traces 1 
and 4, respectively, by superimposing, and graph 2 (Gr2 in Graph layout) 
and graph 3 (Gr3 in Graph layout) displays trace 2 and trace 3 as shown in 
the figure below. 
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The procedure for setting the graph layout is as follows: 

1. Press Channel Next (or Channel Prev) to select the channel for which 
you want to set the graph layout. 

2. Press Display > Allocate Traces. 

3. Press the desired softkey to select the graph layout shown below. 

Graph Layout 
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Active Channel 

The active channel is the one whose settings can currently be changed. 
The window frame of the active channel is displayed brighter than the 
window frames of the other channels. To change the settings specific to a 
certain channel, you must first activate the channel. 

To change the active channel, use the following hardkeys: 

Hardkey Function 

Channel 
Next 

Change the active channel to the next channel with the larger 
channel number. 

Channel 
Prev  

Change the active channel to the previous channel with the 
smaller channel number. 

Active trace 

The active trace is the one whose settings can currently be changed. The 
trace name on the screen (for example, Tr2) of the current active trace is 
highlighted and indicated with  to the left. To change the settings specific 
to a certain trace, you must first activate the trace. 

To select the active trace, use the following hardkeys: 
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Hardkey Function 

Trace 
Next 

Change the active trace to the next trace with the larger trace 
number. 

Trace 
Prev  

Change the active trace to the previous trace with the smaller 
trace number. 
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Selecting Measurement Parameters 

The E5061B allows users to evaluate the DUT (device under test) 
characteristics by using the following measurement parameters. 

 Select Measurement Port 

 S-parameters 

 Absolute 

 Gain-Phase 

Other topics about Setting Measurement Conditions 

Select Measurement Port (Option 3L5 Only) 

For each channel, the measurement should select either S-parameter or 
Gain-Phase. This function is available only in option 3L5 (Gain-Phase).   

1. Press Meas > Measurement Port. 

2. Select S-Parameter or Gain-Phase. 

3. All traces in the selected channel are set to either S11 or T/R, 
respectively. 

 By using the commands, the parameters of S-parameters 
(Sxx) and Gain-Phase (T/R, T, R) can exist in one channel. The 
Measurement Port softkey has no equivalent SCPI command. 

S-parameters 

S-parameters (scattering parameters) are used to evaluate how signals are 
reflected by and transferred through the DUT. An S-parameter is defined 
by the ratio of two complex numbers and contains information on the 
magnitude and phase of the signal. S-parameters are typically expressed 
as follows: 

Sout in 

out: port number of the DUT from which the signal is output 

in: port number of the DUT to which the signal is input 
  

For example, S-parameter S21 is the ratio of the output signal of port 2 on 
the DUT with the input signal of port 1 on the DUT, both expressed in 
complex numbers. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace. 
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2. Select a softkey that corresponds to the desired measurement 
parameter. If the desired softkey is gray out, press Meas > 
Measurement Port > S-Parameter. 

Absolute 

Absolute shows the absolute power for reference and received signals on 
the port. 

Softkey Description 

A (n) Absolute measurement in Port 1, test receiver 

B (n) Absolute measurement in Port 2, test receiver 

R1 (n) Absolute measurement in Port 1, reference receiver 

R2 (n) Absolute measurement in Port 2, reference receiver 

where n in the parentheses is the stimulus port number. For example, 
R1(1) means the reference level while the signal is output from the port 1, 
and A(2) means the received signal level into port 1 while the signal is 
output from the port 2. 

 
1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 

to select the trace. 

2. Press Meas > Absolute. If Absolute is gray out, press Meas > 
Measurement Port > S-Parameter. 

3. Select a softkey that corresponds to the desired measurement 
parameter. 

Gain-Phase (Option 3L5 Only) 

1. Press Channel Next (or Channel Prev) to select the channel. 

2. Press Meas > Measurement Port > Gain-Phase. 

3. Press Trace Next (or Trace Prev) to select the trace. 
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4. Press Meas > Gain-Phase. Then select a softkey that corresponds to 
the desired measurement parameter. 

Input Impedance 

The input impedance can be selected from 50 Ω or 1 MΩ. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace. 

2. Press Meas > Gain-Phase Setup > Input Impedance > R Input Z (or T 
Input Z). 

3. Select 50 Ω or 1 MΩ. 
Input Attenuator 

The input attenuator can be selected from 0 dB or 20 dB. When your input 
signal exceeds the signal over -5 dBm (50 Ω input) or 0.18 Vpeak (1 MΩ 
input), the attenuator should be set at 20 dB. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace. 

2. Press Meas > Gain-Phase Setup > Input Attenuator > R Attenuator (or 
T Attenuator). 

3. Select 0 dB or 20 dB. 
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Setting Stimulus Conditions 

You can set the stimulus condition for each channel independently. 

 Setting Sweep Type 

 Setting Sweep Range 

 Enable Stimulus Signal Output 

 Setting Power Level 

 Setting Fixed Frequency at Power/DC Bias Sweep 

 Setting Number of Measurement Points 

 Setting Sweep Delay and Sweep Time 

 Measuring in Time Series (Time Sweep) 

Other topics about Setting Measurement Conditions 

Setting Sweep Type 

You can select the sweep type from the following four types. 

SoftKey Description 

Linear 
Freq 

Sweeps frequencies in linear scale. 

Log Freq Sweeps frequencies in logarithmic scale. 

Segment Performs a sweep with linear sweep conditions (segments) 
combined. For more information, refer to Performing a 
Segment-by-Segment Sweep (segment sweep). 

Power 
Sweep 

Sweeps power levels in linear scale. 

DC Bias 
Sweep 

Sweeps DC bias levels. This is available only when option is 
3L5. 

The procedure for selecting the sweep type is as follows: 

1. Press Channel Next (or Channel Prev) to select the channel for which 
you want to set the sweep type. 

2. Press Sweep Setup > Sweep Type. 

3. Press the desired softkey to select the sweep type. 

 The time sweep is shown in Measuring in Time Series. This 
allows you to display the measurement parameter versus time. 



Measurement 

115 

Setting Sweep Range 

There are two ways to set the sweep range: by specifying the lowest and 
the highest values and by specifying the center value and a span. Once the 
sweep range is set, it is possible to change the range by substituting the 
lowest value, the highest value, or the center value with a value (stimulus 
value) represented by a marker on the trace. 

 
  

Setting the Sweep Range with the Lowest and Highest Values 

1. Press Channel Next (or Channel Prev) to select the channel of which 
sweep range will be set. 

2. Click Start, then input the lowest value. 

3. Click Stop, then input the highest value. 
Setting the Sweep Range with the Center Value and a Span 

1. Press Channel Next (or Channel Prev) to select the channel of which 
sweep range will be set. 

2. Click Center, then input the center value. 

3. Click Span, then input the span value. 
Setting Sweep Range Using the Marker 

1. In the channel window of which range must be set, place the active 
marker on the active trace to a position that corresponds to the new 
range (to the lowest, highest, or center value). 

2. Press Marker Fctn. 

3. Click the softkey that corresponds to each value. 

 If the reference marker is on and the stimulus value of the 
active marker is expressed by a value relative to the reference 
marker, the absolute stimulus value will be used to set the new 
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sweep rang. 
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Enable Stimulus Signal Output 

You can turn on/off the stimulus signal output, but this prevents you from 
performing the measurement. Therefore, normally this feature will not be 
used. This feature is mainly used to turn the output ON back after it has 
been turned OFF by the power trip feature. 

Follow these steps to turn the stimulus signal output on/off: 

1. Press Sweep Setup. 

2. Click Power > RF Out (Each press toggles between on/off). 

When set to OFF, "RF OFF" is displayed in Instrument Status Bar. 
Power trip 

The power trip is a feature that the instrument uses to automatically turn 
OFF the output of the stimulus signal to protect the instrument when a 
signal of which level exceeds the upper limit is inputted to the test port. 

If the power output is automatically turned off by the power trip feature, 
remove the cause of the over-input and turn ON the power output 
according to the above steps to restart the measurement. 

Setting Power Level 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup key. 

3. Click Power > Port Couple, then select the on/off setting of the 
level coupling for all the ports. 

 The power level of port 1 is coupled with the power 
level for all ports. 

 If you change the on/off setting of the level coupling, 
all ports are automatically changed to the same level value as 
that of port 1. 

4. Follow the procedure below according to the Port Couple. 

 When setting level for all ports (Port Couple ON) 

a. Click Power, then enter the power level. 

 When setting level for each port (Port Couple OFF) 

a. Press Port Power, then click the softkey corresponding to each 
port (Port 1 Power, Port 2 Power, LF OUT Power) 

b. Enter the power level. 
Correcting attenuation of power level (using power slope feature) 

You can use the power slope feature to correct the attenuation of a power 
level so that it is simply proportional to the frequency (attenuation due to 
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cables and so on), which improves the accuracy of the level actually 
applied to the DUT. 

Turning power slope feature on/off 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup key. 

3. Click Power > Slope [OFF] (Slope [ON]). Each press toggles between 
on/off. 

Setting correction coefficient (correction amount per 1 GHz) 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup key. 

3. Click Power > Slope [xxx dB/GHz] ("xxx" represents the current set 
value.). 

4. Enter the correction coefficient using the ENTRY block keys on the 
front panel. 

Setting Fixed Frequency at Power/DC Bias Sweep 

The procedure for setting the fixed frequency (CW frequency) at the power 
sweep and DC Bias sweep (Option 3L5 only) is as follows: 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup key. 

3. Click CW Freq, then enter the fixed frequency. 

Setting Number of Measurement Points 

The number of points is the number of data items collected in one sweep. 
It can be set to any number from 2 to 1601 for each channel 
independently. 

 To obtain a higher trace resolution against the stimulus value, 
choose a larger value for the number of points. 

 To obtain higher throughput, keep the number of points to a smaller 
value within an allowable trace resolution. 

 To obtain higher measurement accuracy after calibration, perform 
calibration using the same number of points as in actual 
measurements. 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup key. 

3. Click Points, then input the desired number of points. 

Setting Sweep Delay and Sweep Time 
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Sweep time is the time taken to complete a sweep for each stimulus 
(source) port. Two modes are available for setting the sweep time: manual 
sweep time mode and automatic sweep time mode. 

Sweep Time 
Mode 

Description 

Manual In this mode, the sweep time is set manually. Once 
the sweep time is set, changes in the measurement 
conditions do not affect the sweep time as long as it 
is within the analyzer's capability. If the sweep time 
becomes lower than the analyzer's lower sweep time 
limit, the sweep time is reset to the shortest time 
within the conditions. If the sweep time exceeds the 
analyzer's upper sweep time limit, the sweep time is 
reset to the longest time within the conditions. 

Auto (Default) The sweep time is always kept to the shortest time 
possible with the current measurement conditions. 

The following figure shows the definitions of the sweep time and the sweep 
delay time. 

Sweep delay is time before starting a sweep for each stimulus (source) 
port. Sweep time does not include the sweep delay. 

Timing Chart for Sweep 

When the trigger mode is set at "On Sweep". 
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When the trigger mode is set at "On Point". 

 
 Trigger delay is available when the trigger source is 

set at external. 
Sweep time is the total of point delay and measurement time in 
all measurement points when the trigger mode set at "On 
Point". 

Setting Sweep Delay Time 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup > Sweep Delay. 

3. Using the ENTRY block keys on the front panel, input the desired 
sweep delay time (in seconds). 

Setting Up Sweep Time (Manual Sweep Time Mode) 

1. Press Channel Next (or Channel Prev) to select the desired channel. 

2. Press Sweep Setup > Sweep Time Auto to turn OFF. 

3. The softkey named Sweep Time is activated. Press Sweep Time. 

4. Using the ENTRY block keys on the front panel, input the desired 
sweep time (in seconds). 

 The sweep time is not correctly displayed in DC Bias 
sweep at 90 kHz and above when there are the traces for both 
Gain-Phase and S-Parameter measurements in one channel. 

Measuring in Time-Series (Time Sweep) 

The following procedure allows you to time sweep and the measurement 
parameter is displayed versus time. 



E5061B 

122 

1. Press Channel Next (or Channel Prev) to select the channel of which 
sweep range will be set. 

2. Press Span > 0 > x1 to set the span value to 0 (zero span). 

3. Press Center, then input the desired value (frequency, power, or DC 
bias). 

4. Press Sweep Setup > Sweep Time Auto to turn OFF. 

5. Press Sweep Time, then input the duration of the sweep which is 
displayed on X-axis. 

6. Press Marker to display the marker 1. The time at the marker shows 
as the marker position value at the upper left corner on the screen. 
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Applying DC bias and DC Source (Option 3L5 only) 

 Overview 

 Setting DC Bias 

 Applying DC Bias 

 Using as DC Source 

Other topics about Setting Measurement Conditions 

Overview 

E5061B option 3L5 allows you to apply the DC bias on the source signal of 
Port 1 or LF output port. The range of DC bias is -40 V to +40 V. 

DC Source 

When you make S-parameter measurements, the LF output port can be 
used as the DC supply. 

 
Setting DC Bias 

1. Press Sweep Setup > DC Bias Port, then select LF Out or Port 1 which 
you want to output the DC bias to. 

2. Press DC Bias Level, then enter the DC bias level. 

Applying DC Bias 

1. Press Sweep Setup > DC Bias to turn it ON. 

When an ECal is connected to the E5061B USB port or Cal > Calibrate is 
pressed, DC Bias is turned OFF in order to avoiding the calibration kit 
having damage. 

Using as DC Source 

1. Setup the S-Parameter measurements. 

2. Press Sweep Setup > DC Bias Port > LF Out. 
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3. Press DC Bias Level, then enter the DC level. 

4. Press DC Bias to turn ON. 

5. Make the S-Parameter measurements. 
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 Selecting a Data Format 

The E5061B allows you to display the measured S-parameters by using the 
following data formats. The data format can be preset to factory settings 
using the Preset option. 

 Rectangular display formats 

 Polar format 

 Smith chart format 

Other topics about Setting Measurement Conditions 

Rectangular display formats 

Rectangular display formats draw traces by assigning stimulus values 
(linear scale) to the X-axis and response values to the Y-axis. Eight 
different formats are available depending on the selection of data for the Y-
axis. 

 

Type Y-axis Data Type Y-axis 
Unit 

Application Examples 

Log 
magnitude 
format 

Magnitude dB  Return loss 
measurement 

 Insertion loss 
measurement (or 
gain measurement) 

Phase Phase (displayed in 
range from -180 ° 

Degrees ( Measurement of deviation 
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format   to +180 °  ) ° ) from linear phase 

Expanded 
phase 
format 

Phase (can be 
displayed above 
+180 °   and below 
-180 °  ) 

Degrees ( 
° ) 

Measurement of deviation 
from linear phase 

Positive 
phase 
format 

Phase (displayed in 
range from 0 ° to 
+360 °  ) 

Degrees ( 
° ) 

Measurement of deviation 
from linear phase 

Group delay 
format 

Signal transfer 
delays within the 
DUT 

Seconds 
(s) 

Group delay measurement 

Linear 
magnitude 
format 

Magnitude (Abstract 
number) 

Reflection coefficient 
measurement 

SWR format 

 
(ρ: reflection 
coefficient) 

(Abstract 
number) 

Measurement of standing 
wave ratio 

Real format 

  

Real part of 
measured complex 
parameter 

(Abstract 
number) 

  

Imaginary 
format 

Imaginary part of 
the measured 
complex parameter 

(Abstract 
number) 

  

Polar format 

In the polar format, traces are drawn by expressing the magnitude as a 
displacement from the origin (linear) and phase in an angle 
counterclockwise from the positive X-axis. This data format does not have 
a stimulus axis, so frequencies must be read by using the marker. The 
polar format allows users to select one of the following three data groups 
to display the marker response values. 

 Linear magnitude and phase ( ° ) 

 Log magnitude and phase ( ° ) 
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 Real and imaginary parts 

 
Smith chart format 

The Smith chart format is used to display impedances based on reflection 
measurement data of the DUT. In this format, traces are plotted at the 
same spots as in the polar format. The Smith chart format allows users to 
select one of the following five data groups to display the marker response 
values. 

 Linear magnitude and phase ( ° ) 

 Log magnitude and phase ( ° ) 

 Real and imaginary parts 

 Resistance (ohm), Reactance (ohm), and inductance (H) or 
capacitance (F) 

 Conductance (S), susceptance (S), and capacitance (F) or inductance 
(H) 
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Use the following procedure to select a data format: 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace for which the data format will be set. 

2.  Press Format. 

3. Press the softkey that corresponds to the desired data format. 

Softkey Function 

Log Mag Selects the log magnitude format 

Phase Selects the phase format 

Group Delay Selects the group delay format 

Smith > Lin / 
Phase 

Selects the Smith chart format (with linear 
magnitude and phase as the marker response 
values) 

Smith > Log / 
Phase 

Selects the Smith chart format (with log 
magnitude and phase as the marker response 
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values) 

Smith > Real / 
Imag 

Selects the Smith chart format (with the real and 
imaginary parts as the marker response values) 

Smith > R + 
jX 

Selects the Smith chart format (with resistance 
and reactance as the marker response values) 

Smith > G + 
jB 

Selects the Smith chart format (with conductance 
and susceptance as the marker response values) 

Polar > Lin / 
Phase 

Selects the polar format (with linear magnitude 
and phase as the marker response values) 

Polar > Log / 
Phase 

Selects the polar format (with log magnitude and 
phase as the marker response values) 

Polar > Real / 
Imag 

Selects the polar format (with the real and 
imaginary parts as the marker response values) 

Lin Mag Selects the linear magnitude format 

SWR Selects the SWR (standing wave ratio) format 

Real Selects the real format 

Imaginary Selects the imaginary format 

Expand Phase Selects the expanded phase format 

Positive 
Phase 

Selects the positive phase format 
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Setting the Scales 

 Auto Scale 

 Manual Scale Adjustment 

 Setting Reference Line Value Using Marker 

Other topics about Setting Measurement Conditions 

Auto Scale 

The auto scale function is used to tailor each scale (scale/division and the 
reference line value) automatically in such a way that traces will appear at 
the proper size on the screen for easy observation. 

 The scale data can be preset to factory settings using the Preset 
option. 

Single Trace Auto Scale 

Follow the procedure below to perform the auto scale function on a specific 
trace. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace of which the auto scale function will be performed. 

2. Press Scale > Auto Scale. 

Auto Scale on All Traces Within a Channel 

1.  Press Channel Next (or Channel Prev) to select the channel of which 
the auto scale function will be performed. 

2.  Press Scale > Auto Scale All. 

Manual Scale Adjustment 
Manual scale adjustment on the rectangular display format 

For a rectangular display format, four parameters are used to manually 
adjust the scales. 

Adjustable 
feature 

Description 

Divisions Defines the number of divisions on the Y-axis. An even 
number from 4 to 30 must be used. Once set, it is 
commonly applied to all traces displayed in any rectangular 
format within that channel. 

Scale/Division 
(Scale/Div) 

Defines the number of increments per division on the Y-
axis. The value applies only to the active trace. 

Reference Defines the position of the reference line. The position must 



Measurement 

131 

position be specified using the number assigned to each division on 
the Y-axis starting at 0 (the least significant) running up to 
the number of divisions being used (the most significant). 
The position applies only to the active trace. 

Reference line 
value 
(Reference 
Value) 

Defines the value corresponding to the reference line. It 
must be set using the unit on the Y-axis. The reference line 
value applies only to the active trace. 

 
1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 

to select the trace of which scale features will be adjusted. 

2.  Press Scale. 

3. Select the softkey that corresponds to the particular feature that 
needs to be adjusted. 

  It is also possible to turn off the display of graticule labels. 
For details, refer to Turning off the display of graticule labels. 

Manual scale adjustment on the Smith chart/polar format 

Manual scale adjustment on the Smith chart format or the polar format is 
done by using the displacement (Scale/Div of the outermost circle). 
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1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace for which the scale will be adjusted. 

2. Press Scale. 

3. Click Scale/Div, then input the displacement of the outermost circle. 

Setting Reference Line Value using Marker 

When using a rectangular display format, it is possible to change the 
reference line value to be equal to the response value of the active marker 
on the active trace. 

1. Place the active marker on the active trace on the position that 
corresponds to the new reference line value. 

2. Press Scale or Marker Fctn. 

3. Click Marker -> Reference to change the reference line value to the 
marker response value. 

 If the reference marker is ON and the stimulus value 
of the active marker is expressed using a value relative to the 
reference marker, the absolute stimulus value is used to set the 
new reference line value. 
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Setting Window Displays 

 Maximizing the specified window trace display 

 Turning off the display of graticule labels 

 Hiding Frequency Information 

 Labeling a Window 

 Setting display colors 

 Setting display magnification 

 Resizing the screen 

Other topics about Setting Measurement Conditions 

Maximizing the specified window/trace display 

When using multiple channels, it is possible to maximize a specific channel 
window on the screen. When multiple traces are displayed in a channel 
window, it is also possible to maximize a specific trace displayed within 
that channel window. 

 The Window/Trace Display data can be preset to factory settings 
using the Preset option 

Maximizing a window 

1. Press Channel Next  (or Channel Prev) to select the channel of which 
window will be maximized. 

2. Press Channel Max to maximize the channel window. 

3. Press Channel Max one more time to reduce the window to its 
previous size. 

Maximizing a trace display 

1. Press Channel Next  (or Channel Prev) to select the channel to which 
the trace belongs. 

2. Press Trace Next (or Trace Prev) to select the trace of which display 
will be maximized. 

3. Press Trace Max to maximize the trace display. 

4. Press Trace Max one more time to reduce the display to its previous 
size. 

Turning off the display of graticule labels 

When using a rectangular display format, the graph area can be expanded 
to the left by turning OFF the display of graticule labels. 

Turning OFF graticule label display 
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1.  Press Channel Next (or Channel Prev) to select the channel of which 
graticule label display will be turned ON or OFF. 

2.  Press Display. 

3. Click Graticule Label to turn graticule label display ON or OFF. 

Hiding frequency information 

You can hide the frequency information from the screen in order to ensure 
its confidentiality or for other reasons. 

Hiding Frequency Information on the Screen 

Follow the steps below to hide frequency information on the measurement 
screen. 

1.  Press Display key. 

2.  Click Frequency to turn OFF the frequency display. 

 Turning OFF the frequency display using Display > 
Frequency key does not erase the frequency display within the 
Stimulus softkey, which is turned on by pressing Start, Stop, 
Center, and Span. The display of the softkey bar itself can be 
switched ON or OFF by pressing Softkey On/Off. 

Hiding Softkey's Frequency Information 

You can delete the frequency information from the measurement screen, 
which changes the frequency information displayed in the Stimulus softkey 
and the data entry area for Hz unit to asterisks (***). 

1. Press System key. 

2. Click Service Menu, then click Security Level and select any of the 
following options for the frequency display. 
  

Softkey Function 

None Displays the frequency information. 

Low Hides the frequency information with a series of asterisks. 

Save/Recall > Save Trace Data and Save SnP  are inactive. 

This can be turned OFF by the Security Level menu. 

High Hides the frequency information with a series of asterisks. 

Save/Recall > Save Trace Data and Save SnP are inactive. 

This cannot be turned OFF by the Security Level menu. 

Resetting to OFF is only possible by executing Preset or 
Recall. 
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Labeling a window 

It is possible to assign a unique name to a channel and display it on the 
screen. This feature is useful in saving and/or printing measurement 
results for future reference. 

Labeling a window 

1. Press Channel Next (or Channel Prev) to select the channel to be 
labeled. 

2. Press Display > Edit Title Label, and the title label input dialog box 
appears. 
 

 
3. Using the keys in the dialog box, type a label and click Enter. 

4. Click Title Label to turn ON the title display. The title appears within a 
frame at the top of the channel window. 
 

 
Setting display colors 
Selecting display mode 

You can select the display mode of the LCD display from two modes: 
normal display (background: black) or inverted display (background: 
white). In normal display, the colors of items are preset so that you can 
recognize them easily on the display of the instrument. On the other hand, 
in inverted display, they are preset to colors obtained by inverting the 
default settings to the normal display so that you can use data easily when 
storing it into a graphic file. 

The selection procedure is as follows: 

1. Press Display. 
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2. Click Invert Color to select the display color. OFF indicates the normal 
display; ON the inverted display. 

Setting display color for each item 

You can set the display color to the normal display or inverted display 
separately for each of the following items: 

 Data/memory trace 

 Labels and lines of graphs 

 File display of the limit test and limit lines 

 Background 

Set the color of each item by specifying the amounts of red (R), green (G), 
and blue (B) contained in the color. You can specify each level of R, G, and 
B in 6 steps (0 to 5). Therefore, total of 216 colors are available by 
combining them. The table below shows the R, G, and B values for the 
main colors as a reference. 

  R G B   R G B   R G B 

White 5 5 5 Gray 2 2 2 Black 0 0 0 

Light 
red 

5 3 3 Red 5 0 0 Dark 
Red 

2 0 0 

Light 
yellow 

5 5 3 Yellow 5 5 0 Dark 
Yellow 

2 2 0 

Light 
green 

3 5 3 Green 0 5 0 Dark 
Green 

0 2 0 

Light 
cyan 

3 5 5 Cyan 0 5 5 Dark 
cyan 

0 2 2 

Light 
blue 

3 3 5 Blue 0 0 5 Dark 
Blue 

0 0 2 

Light 
magen
ta 

5 3 5 Magen
ta 

5 0 5 Dark 
Magen
ta 

2 0 2 

The setting procedure is as follows: 

1. Press System > Misc Setup > Display Setup > Color Setup. 

2. Click Normal (for normal display) or Invert (for inverted display). 

3. Click the softkey corresponding to the item of which you want to set 
the display color. 



Measurement 

137 

4. Click Red (or, Green, or Blue). 

5.  Select the amount of the selected color from 0 to 5. 
Resetting the display colors to the factory state 

You can reset the display colors in normal display and inverted display to 
the preset factory state. 

The selection procedure is as follows: 

1. Press System > Misc Setup > Display Setup > Color Setup. 

2. Click Normal (for normal display) or Invert (for inverted display). 

3. Click Reset Color  > OK. 

Setting display magnification 

You can reset the display magnification to Small, Normal or Large. 

The selection procedure is as follows: 

1. Press System > Misc Setup > Display Setup > Magnification. 

2. Click Normal,Small or Large. 

Resizing the screen 

You can resize the E5061B screen by minimizing, maximizing or restoring 
it to its original size. 

The resizing procedure is as follows: 

1. Click Resize E5061B at the top right corner of the screen. 

 
2. A drop-down menu prompts and the available options are: 

Softkey Function 

Restore Restores the screen to its default size. 

Minimize Minimizes the screen. 

Maximize Displays the screen in full page size. 
  

3. Click Restore,Minimize or Maximize. 
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4. When the screen is resized according to an option, its the related 
softkey is disabled. For example, when the screen is displayed in full 
page size, Maximize is disabled. 

Another option to minimize the E5061B screen is by using the Menu Bar 
and the procedure is as follows: 

1. Press Display. 

2. Click Minimize E5061B. 

You can also hide and restore the title bar of the E5061B screen and the 
procedure is as follows: 

1. Press Display. 

2. Click E5061B Title bar. 

3. Click ON to restore the title bar. 

4. Click OFF to hide the title bar. 
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Setting Port Coupling (Option 3L5 only) 

In Option 3L5, Port 1 and 2 can be selectively AC or DC coupled. DC 
coupling (Default setting) allows both DC and AC signals through, while AC 
coupling accepts only AC signal. In DC coupling, the port 1 and 2 has 50 Ω 
input impedance. In AC coupling, a blocking capacitor is inserted at the 
ports 1 and 2. It may cause the signal level difference between AC and DC 
coupling at lower frequency. 

1. Press System > S-Param Port Couple, then select AC or DC. 

When the port coupling is set at AC, there are limitations as follows: 

 DC bias can not be turned ON for the port 1. 

 The minimum frequency is 100 kHz. 

 When the port coupling is set at AC and the 
frequency is set below 100 kHz, the trigger becomes hold state. 
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Calibration 

Calibration 
Overview 

 Measurement Errors and their Characteristics 

 Calibration Types and Characteristics 

 Checking Calibration Status 

 Clear Calibration 

Basic Calibration 

 Selecting Calibration Kit 

 OPEN/SHORT Response Calibration (reflection test) 

 THRU Response Calibration (transmission test) 

 Enhanced Response Calibration 

 1-Port Calibration (reflection test) 

 Full 2-Port Calibration 

Calibration with ECal (Electronic Calibration) 

 ECal (Electronic Calibration) 

 ECal Driver Installation 

 Calibration Using ECal Module 
Advanced Calibration with ECal 

 Improving Calibration Accuracy along with ECal 

 Confidence Check on Calibration Coefficients Using ECal 

 Turning off ECal Auto-detect Function 

 User-characterized ECal 

Advanced Calibration 

 Modifying Calibration Kit Definition 

 Partial Overwrite 

 Adapter Removal-Insertion 
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Measurement Errors and their Characteristics 

 Overview 

 Drift Errors 

 Random Errors 

 Systematic Errors 

Other topics about Calibration 

Overview 

It is important to understand the factors contributing to measurement 
errors in order to determine the appropriate measures that should be 
taken to improve accuracy. Measurement errors are classified into three 
categories: 

Drift Errors 

Drift errors are caused by deviations in the performance of the measuring 
instrument (measurement system) that occur after calibration. Major 
causes are the thermal expansion of connecting cables and thermal drift of 
the frequency converter within the measuring instrument. These errors 
may be reduced by carrying out frequent calibrations as the ambient 
temperature changes or by maintaining a stable ambient temperature 
during the course of a measurement. 

Random Errors 

Random errors occur irregularly in the course of using the instrument. 
Since random errors are unpredictable, they cannot be eliminated by 
calibration. These errors are further classified into the following sub-
categories depending on their causes: 

  Instrument noise errors 

  Switch repeatability errors 

  Connector repeatability errors 
Instrument noise errors 

Instrument noise errors are caused by electric fluctuations within 
components used in the measuring instrument. These errors may be 
reduced by increasing the power of the signal supplied to the DUT, 
narrowing the IF bandwidth, or enabling sweep averaging. 

Switch repeatability errors 

Switch repeatability errors occur due to the fact that the electrical 
characteristics of the mechanical RF switch used in the measuring 
instrument change every time it is switched on. These errors may be 
reduced by carrying out measurements under conditions in which no 
switching operation takes place. 
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Connector repeatability errors 

Connector repeatability errors are caused by fluctuations in the electrical 
characteristics of connectors due to wear. These errors may be reduced by 
handling connectors with care. 

Systematic Errors 

Systematic errors are caused by imperfections in the measuring instrument 
and the test setup (cables, connectors, fixtures, etc.). Assuming that these 
errors are repeatable (i.e., predictable) and their characteristics do not 
change over time, it is possible to eliminate them mathematically at the 
time of measurement by determining the characteristics of these errors 
through calibration. There are six types of systematic errors, as follows. 

Errors caused by signal leaks in the measuring system: 

 Directivity 

 Isolation (cross-talk) 

Errors caused by reflections in the measuring system: 

 Source match 

 Load match 

Errors caused by the frequency response of the receiver within the 
measuring instrument: 

 Reflection tracking 

 Transmission tracking 

The E5061B has two receivers for each S-parameter test port: the 
reference receiver and the test receiver (transmission measurement or 
reflection measurement). You can perform measurements with both of 
these receivers at the same time. 

E5061B port architecture and systematic errors in S-parameter 
Measurement 
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The ports T and R are receivers and LF out supplies the source signal. 

E5061B port architecture and systematic errors in Gain-Phase 
Measurement 
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Directivity error (Ed) 

Directivity errors are caused by the fact that, in a reflection measurement, 
signals other than the reflection signal from the DUT are received by the 
receiver through the directivity coupler. When a certain port is a stimulus 
port, this error can be defined as a constant value for each stimulus port 
because the state of the termination at the other ports does not change. 
The number of directivity errors of the E5061B is the number of stimulus 
ports you use. 

Isolation error (Ex) 

An isolation error (crosstalk error) is caused by signals other than the 
transmission signal of the DUT leaking to the test receiver of the 
transmission measurement port in transmission measurements. When a 
certain port is a stimulus port, an isolation error is defined for each of the 
ports. Therefore, the number of isolation errors for the E5061B is the total 
number of combinations of stimulus ports and response ports. 
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Source match error (Es) 

A source match error is caused when the reflection signal of the DUT 
reflects at the signal source and enters the DUT again. When a certain port 
is a stimulus port, this error can be defined as a constant value for each 
stimulus port because the state of the signal source switch does not 
change. The number of source match errors in the E5061B is equivalent to 
the number of stimulus ports you use. 

Load match error (El) 

A load match error is caused when part, but not all, of the signal 
transmitted in the DUT reflects at a response port is measured by the 
receiver of the response port. When a certain port is a stimulus port, a load 
match error is defined for each of the ports. Therefore, the number of load 
match errors for the E5061B is the total number of combinations of 
stimulus ports and response ports. 

Reflection tracking error (Er) 

A reflection tracking error is caused by the differences in frequency 
response between the test receiver and the reference receiver of a 
stimulus port in reflection measurements. This error can be defined as a 
constant value for each stimulus port because the combination of the test 
receiver and the reference receiver of a stimulus port is always the same. 
The number of reflection tracking errors for the E5061B is simply the 
number of stimulus ports you use. 

Transmission tracking error (Et) 

A transmission tracking error is caused by the differences in frequency 
response between the test receiver of a response port and the reference 
receiver of a stimulus port in transmission measurements. When a certain 
port is a stimulus port, a transmission tracking error is defined for each of 
the ports. Therefore, the number of transmission tracking errors for the 
E5061B is the total number of combinations of stimulus ports and response 
ports. 
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Calibration Types and Characteristics 

The table shows different types of calibrations and features of each 
method. 

Calibrati
on 
Method 

Standard 
(s) Used 

Corrected Error 
Factor 

Measurement 
Parameters 

Characteristics 

No 
calibrati
on 

None None All parameters 
 Low accuracy 

 Calibration not 
required 

Respons
e 
Calibrati
on 

 OPEN 
or SHORT 

 LOAD 
(Optional) 

Following 2 error 
terms: 

 Reflection Tracking 
(Er) 

 Directivity (Ed) 

S11(Reflection 
characteristics at 1 
port) 

T/R (reflection 
setting) 

  

 Medium-level 
accuracy 

 Quick calibration 

 Isolation calibration 
improves the accuracy 
in a reflection 
measurement of a 
DUT with high return 
loss 

 THRU 

 LOAD 
(Optional) 

Following 2 error 
terms: 

 Transmission 
Tracking (Et) 

 Isolation (Ex) 

S21 
(1 direction 
transmission 
characteristics at 2 
ports) 

T/R (Transmission 
setting) 

 Medium-level 
accuracy 

 Quick calibration 

 Isolation calibration 
improves the accuracy 
in a transmission 
measurement of a 
device with high 
insertion loss 

1-Port 
Calibrati
on 

ECal 
module 
(2-port/4-
port) 

Following 3 error 
terms: 

 Directivity (Ed) 

 Source Match (Es) 

 Reflection Tracking 
(Er) 

S11 
(Reflection 
characteristics at 1 
port) 

T/R 

 1-port 
measurement with the 
highest degree of 
accuracy 

 Quick calibration 
with low chance of 
operator error 

 OPEN 

 SHORT 

 LOAD 

 Highly accurate 1-
port measurement 

Enhance
d 
Respons
e 

Ecal 
module 
(2-port) 

Following 5 error 
terms: 

 Directivity (Ed1) 

S11, S21 (1 direction 
transmission/Reflecti
on characteristics at 
2 ports) 

 Highly accurate 2-
port measurement 
(higher than response 
calibration) 
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Calibrati
on 

 Isolation (Ex21) 

 Source Match (Es1) 

 Transmission 
Tracking (Et21) 

 Reflection Tracking 
(Er1) 

 Quick calibration 
with low chance of 
operator error 

 OPEN 

 SHORT 

 LOAD 

 THRU 

 Highly accurate 2-
port measurement 
(higher than response 
calibration) 

Full 2-
Port 
Calibrati
on 

ECal 
module 
(2-port/4-
port) 

Following 12 error 
terms: 

 Directivity 
(Ed1,Ed2) 

 Isolation 
(Ex21,Ex12) 

 Source Match 
(Es1,Es2) 

 Load Match 
(El12,El21) 

 Transmission 
Tracking (Et21,Et12) 

 Reflection Tracking 
(Er1,Er2) 

S11,S21,S12,S22 
(All S-parameters at 
2 ports) 

 Highly accurate 2-
port measurement 

 Quick calibration 
with low chance of 
operator error 

 OPEN 

 SHORT 

 LOAD 

 THRU 

 Highly accurate 2-
port measurement 
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Checking Calibration Status 

 Execution Status of Error Correction for Each Channel 

 Execution Status of Error Correction for Each Trace 

 Acquisition Status of Calibration Coefficient for Each Channel 

Other topics about Calibration 

Execution Status of Error Correction for Each Channel 

You can check the execution status of error correction for each channel 
with the error correction status. 

The error correction status is indicated in the channel status bar at the 
lower part of the window by the symbols shown in the below table. 

Symbol Execution status of error correction 

Cor (displayed in 
blue) 

Error correction: On (enabled for all traces) 

Cor (displayed in 
gray) 

Error correction: On (enabled for some traces) 

Off (displayed in 
gray) 

Error correction: Off 

--- (displayed in 
gray) 

Error correction: On (no calibration data) 

C? (displayed in 
blue) 

Error correction: On 

(Interpolation is being executed or the IF bandwidth, 
power level, power range, sweep time, sweep delay 
time, or sweep type is different from that when the 
calibration was executed.) 

 When the attenuator value of T/R port is 
changed after executing calibration, this symbol is 
displayed. 

C! (displayed in 
blue) 

Error correction: On (Extrapolation is being executed.) 

 When the T/R input Z value is changed 
after executing calibration, this symbol is displayed. 

 When one of the trace is set as DC monitor, COR status does 
not change even if the sweep time is changed. 

Execution Status of Error Correction for Each Trace 



Measurement 

149 

You can check the status of the error correction actually executed for each 
trace with the trace status area. 

For a trace of which error correction is executed, the applied calibration 
type is indicated in the trace status area by the symbols in the table below. 

If none of the symbols described above is displayed, error correction is not 
executed for the trace. 

Acquisition Status of Calibration Coefficient for Each Channel 

You can check the acquisition status of the calibration coefficient for each 
channel with the calibration property. 

The calibration property displays the acquisition status of the calibration 
coefficient between test ports for each channel in matrix format. The 
following example shows 2 port full calibration which is done on ports 1 
and 2, and one of the response calibration is done on the ports for gain-
phase measurement.  

For impedance calibration in option 005, see Acquisition Status of 
Calibration Coefficient in the impedance measurement section. 

 Example of calibration property display 

 
Procedure to turn on/off calibration property display 

Follow these steps to turn on/off the calibration property display. 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to turn on/off the calibration property display. 

2. Press Cal > Property. Each press toggles the on/off setting. 
Conditions for clearing the calibration coefficients which are already acquired 

In the following cases, the calibration coefficients which are already 
acquired are cleared. 
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  Executing preset clears all the calibration coefficients. 

  If S parameters are required to calculate the calibration coefficient 
for the specified calibration type and test ports and those required 
for the existing calibration coefficient overlap, executing the 
acquisition of the calibration coefficient (measuring necessary data 
and then clicking the Done softkey) clears the calibration coefficient 
of which necessary S parameters overlap. Taking the Example of 
calibration property display as an example, if you acquire the 
calibration coefficient of the response calibration for test port 1, 
calibration coefficients for s-parameters are cleared. 
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Clear Calibration 

This softkey clears the user calibration data. When Calibration is done for a 
particular DUT, the data get stored in the E5061B. To clear this data, Clear 
Calibration can be used which removes the User calibration data from the 
E5061B. 

Other topics about Calibration 
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Basic Calibrations 
Selecting Calibration Kit 

 Overview 

 Procedure 

Other topics about Basic Calibration 
Overview 

Before performing calibration, you need to select a calibration kit. 

If you use a calibration kit other than a predefined one, you need to define 
it. If the connector type of the standard calibration kit you use has polarity 
(the distinction between male and female), you need to change the 
standard class definition of the calibration kit depending on the standard 
you actually use. For more information, see Modifying Calibration Kit 
Definition. 

 If you select a predefined calibration kit, (m) and (f) 
in the name (label) of the standard displayed in the softkey 
indicate male (m) and female (f) for the analyzer's connector, 
respectively. 

Procedure 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to select the calibration kit. 

2. Press Cal > Cal Kit, then select the calibration kit. 

  If the name (label) of the calibration kit has been 
changed, the label is displayed as the softkey. 

  An asterisk (*) on the upper right of the softkey 
corresponding to a predefined calibration kit indicates that its 
definition value has been changed from the factory setting by 
the user. 



Measurement 

153 

OPEN/SHORT Response Calibration (reflection test) 

 Overview 

 S-Parameter Measurement 

 Gain-Phase Measurement 

Other topics about Basic Calibration 
Overview 

In OPEN or SHORT response calibration, calibration data are measured by 
connecting an OPEN or SHORT standard, respectively, to the desired test 
port. For frequency response, these calibrations effectively eliminate the 
reflection tracking error from the test setup reflection test using that port. 

 1-Port error model (OPEN/SHORT response) 

 
It is also possible to carry out isolation calibration with a LOAD standard 
during OPEN/SHORT response calibration. An isolation calibration 
eliminates the directivity error from the test setup in a reflection test using 
that port. 

1-Port error model (OPEN/SHORT response + isolation) 

 
S-Parameter Measurement 

1. Press Channel Next (or Channel Prev) to select the channel for which 
you want to perform the calibration. Confirm if your required setup is 
set to the channel. 

2. Press Cal > Calibrate. 



E5061B 

154 

3. Select Response (Open) or Response (Short) calibration. 

4. Click Select Port. 

5. Select the test port upon which you will perform OPEN/SHORT 
response calibration. 

6. Connect a calibration standard (OPEN or SHORT) to the selected test 
port (connector to which the DUT is to be connected). 

7. Click Open or Short to start the calibration measurement. 

8. If an isolation calibration must be performed using a LOAD standard, 
follow the procedure below. 

9.  Connect a LOAD standard to the selected test port (connector to 
which the DUT is to be connected). 

10. Click Load (Optional) to start the measurement on the LOAD 
standard. 

11. Click Done to terminate the response calibration (and the LOAD 
isolation calibration) process. Upon pressing this key, calibration 
coefficients are calculated and saved. The error correction function is 
also enabled automatically. 

  Connecting standards in OPEN/SHORT Response calibration 

 
Gain-Phase Measurement 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to perform the calibration. Confirm if your required setup is 
set to the channel. 

2. Press Cal > Calibrate. 
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3. Select Response (Open) or Response (Short) calibration. 

4. Click Select Port > GP Port. 

5. Connect a calibration standard (OPEN or SHORT) with the position 
specified in the figure below. 

6. Click Open or Short to start the calibration measurement. 

7. If an isolation calibration is required, follow the procedure below: 

a. Connect a LOAD standard with the position specified in the 
figure below. 

b. Click Load (Optional) to start the measurement on the LOAD 
standard. 

8. Click Done to terminate the response calibration process. Upon 
pressing this key, calibration coefficients are calculated and saved. 
The error correction function is also enabled automatically. 

Connection standards in Open/Short response calibration (Gain-
Phase measurement) 
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THRU Response Calibration (transmission test) 

 Overview 

 S-Parameter Measurement 

 Gain-Phase Measurement 

Other topics about Basic Calibration 
Overview 

In THRU response calibration, calibration data are measured by connecting 
a THRU standard to the desired test port. This calibration effectively 
eliminates the frequency response transmission tracking error from the 
test setup in a transmission test using that port. 

2-Port error model (THRU response) 

 
   

It is also possible to carry out an isolation calibration using a LOAD 
standard in the process of THRU response calibration. An isolation 
calibration eliminate sisolation error (crosstalk error) from the test setup in 
a transmission test using that port. 

2-Port Error model (THRU response + isolation) 

 
  

S-Parameter Measurement 

1. Press Channel Next (or Channel Prev) to select the channel for which 
you want to perform the calibration. Confirm if your required setup is 
set at the channel. 

2. Press Cal > Calibrate > Response (Thru) > Select Ports. 

3. Select the test ports (and corresponding S parameters) upon which a 
THRU response calibration is performed.   
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4. Make a  connection between the selected test ports (between the 
connectors to which the DUT will be connected). 

 
  

5. Click Thru to start the calibration measurement. 

6. If an isolation calibration must be performed using a LOAD standard, 
follow the procedure below: 

a. Connect a LOAD standard to each of the two selected test ports 
(connectors to which the DUT is to be connected). 
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b. Click Isolation (Optional) to start the calibration measurement. 

7. Click Done to terminate the response calibration (and the LOAD 
isolation calibration) process. Upon pressing this key, calibration 
coefficients are calculated and saved. The error correction function is 
also enabled automatically. 

Gain-Phase Measurement 

1. Press Channel Next (or Channel Prev) to select the channel for which 
you want to perform the calibration. Confirm if your required setup is 
set at the channel. 

2. Press Cal > Calibrate > Response (Thru) > Select Ports > GP Ports. 
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3. Connect the cable according to following figure. 
 

 
4. Click Thru to start the calibration measurement. 

5. If an isolation calibration is required, follow the procedure below: 

a. Connect the LOAD standards in the position specified in the 
figure below. 
 

 
b. Click Isolation (Optional) to start the calibration measurement. 

6. Click Done to terminate the response calibration (and the LOAD 
isolation calibration) process. Upon pressing this key, calibration 
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coefficients are calculated and saved. The error correction function 
are also enabled automatically. 
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Enhanced Response Calibration 

 Overview 

 Procedure 

Other topics about Basic Calibration 
Overview 

In enhanced response calibration, calibration data are measured by 
connecting an OPEN standard, a SHORT standard, or a LOAD standard to 
the output port (or a THRU standard between two ports). This calibration 
effectively eliminates the directivity error, crosstalk, source match error, 
frequency response reflection tracking error, and frequency response 
transmission tracking error from the test setup in a transmission or 
reflection test that uses those ports . 

2-Port Error Model (Enhanced Response) 

  

 
Procedure 

Connecting the Standard at Enhanced Response Calibration 
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1. Press Channel Next (or Channel Prev) to select the channel of which 

you want to perform the calibration. Confirm if your required setup is 
set to the channel. 

2. Press Cal > Calibrate > Enhanced Response > Ports to select the test 
ports on which an enhanced response calibration is performed. 

3. Connect an OPEN calibration standard to the output port. 

4. Click Open to start the calibration measurement. 

5. Disconnect the OPEN calibration standard and replace it with a 
SHORT calibration standard. 

6. Click Short to start the calibration measurement. 

7. Disconnect the SHORT calibration standard and replace it with a 
LOAD standard. 

8. Click Load to start the calibration measurement. 

9. Make a THRU connection between the two ports. 

10. Click Thru to start the calibration measurement. 

11. If an isolation calibration must be performed using a LOAD 
standard, follow the procedure below: 

a. Connect a LOAD standard to the two test ports. 

b. Click Isolation (Optional) to start the calibration measurement. 

12. Click Done to terminate the enhanced response calibration 
process. Upon pressing the key, calibration coefficients are calculated 
and saved. The error correction function is also enabled 
automatically. 
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1-Port Calibration (reflection test) 

 Overview 

 S Parameter Measurement 

 Gain-Phase Measurement 

Other topics about Basic Calibration 
Overview 

In 1-port calibration, calibration data are measured by connecting an OPEN 
standard, a SHORT standard, and a LOAD standard to the desired test 
port. This calibration effectively eliminates the frequency response 
reflection tracking error, directivity error, and source match error from the 
test setup in a reflection test using that port. 

 
1-Port error model (1-port calibration) 

S-Parameter Measurement 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to perform the calibration. Confirm if your required setup is 
set to the channel. 

2. Press Cal > Calibrate > 1-Port Cal > Select Port. 

3. Select a test port (and corresponding S parameter) on which 1-port 
calibration will be performed. 

4. Connect an OPEN calibration standard to the selected test port 
(connector to which the DUT is to be connected). 

5. Click Open to start the calibration measurement. 

6. Connect a SHORT calibration standard to the selected test port 
(connector to which the DUT is to be connected). 

7. Click Short to start the calibration measurement. 

8. Connect a LOAD calibration standard to the selected test port 
(connector to which the DUT is to be connected). 

9. Click Load to start the calibration measurement. 
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10. Click Done to terminate the 1-port calibration process. Upon 
pressing this key, calibration coefficients are calculated and saved. 
The error correction function is also enabled automatically. 

Connecting the standard for 1-port calibration 

 
Gain-Phase Measurement 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to perform the calibration. Confirm if your required setup is 
set to the channel. 

2. Press Cal > Calibrate > 1-Port Cal > Select Port > GP Port. 

3. Connect an OPEN calibration standard in the position specified in the 
figure below. 

4. Click Open to start the calibration measurement. 

5. Connect a SHORT calibration standard in the position specified in the 
figure below. 

6. Click Short to start the calibration measurement. 

7. Connect a LOAD calibration standard in the position specified in the 
figure below. 

8. Click Load to start the calibration measurement. 

9. Click Done to terminate the 1-port calibration process. Upon pressing 
this key, calibration coefficients are calculated and saved. The error 
correction function is also enabled automatically. 
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Connecting the standard for 1-port calibration (Gain-Phase 
Measurement) 
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Full 2-Port Calibration 

 Overview 

 Procedure 

Other topics about Basic Calibration 
Overview 

In full 2-port calibration, calibration data are measured by connecting an 
OPEN standard, a SHORT standard, or a LOAD standard on ports 1 and 2 
for S-parameter (or a THRU standard between two ports).This calibration 
effectively eliminates the directivity error, crosstalk, source match error, 
frequency response reflection tracking error, and frequency response 
transmission tracking error from the test setup in a transmission or 
reflection test tat uses those ports. This calibration makes it possible to 
perform measurements with the highest possible accuracy. A total of 
twelve error terms, six each in the forward direction and the reverse 
direction, are used in the calibration. 

  

 
Procedure 

1. Press Channel Next (or Channel Prev) to select the channel fof which 
you want to perform the calibration. 

2. Press Cal >  Calibrate > 2-Port Cal. 

3. Click Reflection. 
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4. Connect an OPEN calibration standard to test port x (the connector 
to which the DUT is to be connected). 

5. Click Port x Open to start the calibration measurement (x denotes the 
test port to which the standard is connected). 

6. Disconnect the OPEN calibration standard and replace it with a 
SHORT calibration standard. 

7. Click Port x Short to start the calibration measurement (x denotes the 
test port to which the standard is connected). 

8. Disconnect the SHORT calibration standard and replace it with a 
LOAD standard. 

9. Click Port x Load to start the calibration measurement (x denotes the 
test port to which the standard is connected). 

10. Repeat the above procedure for port y. 

11. Click Return. 

12. Click Transmission. 

13. Make a THRU connection between ports x and y (between the 
connectors to which the DUT is to be connected). 

14. Click Port 1-2 Thru to start the calibration measurement. 

15. Click Return. 

16. If an isolation calibration must be performed using a LOAD 
standard, follow the procedure below. 

17. Click Isolation (Optional). 

18. Connect a LOAD standard to each of the two test ports 
(connectors to which the DUT is to be connected). 

19. Click Port 1-2 Isol to start the calibration measurement. 

20. Click Return. 

21. Click Done to terminate the full 2-port calibration process. Upon 
pressing this key, calibration coefficients are calculated and saved. 
The error correction function is also enabled automatically. 

  Connecting standards in full 2-port calibration 
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Calibration with ECal (Electronic Calibration) 
ECal (electronic calibration) 

ECal is a calibration method that uses solid-state circuit technology. ECal 
offers the following advantages: 

 Simplified calibration process. 

 Shorter time required for calibration. 

 Reduced chance of erroneous operation. 

 Little degradation of performance due to wear ad tear because the 
ECal module employs PIN diodes and FET switches. 

 If the frequency sweep range exceeds the frequency 
range of the ECal, the calibration data for the minimum 
frequency or maximum frequency is used for the exceeding 
frequency range and extrapolation is executed. 

Refer the following section for ECal calibration. 

 ECal Driver Installation 

 Calibration Using Ecal Module 

 Improving Calibration Accuracy along with ECal 

 Confidence Check on Calibration Coefficients Using ECal 

 Turning off ECal auto-detect function 

 User-characterized ECal 

Other topics about Calibration with ECal 
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ECal Driver Installation 

When the ECal is connected t USB ports at the first time, ECal driver 
installation is required. 

1. Connect an Ecal to the USB port of the E5061B. 

2. Select No, not this time, then click Next. 
 

 
3. Select Install the software automatically (Recommended), then click 

Next. 
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4. Click Finish. 
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 Even if you install the driver on a USB port, you will 
be asked to install the driver again if you connect the ECal with 
a different USB port. 
  

Other topics about Calibration with ECal 
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Calibration Using Ecal Module 

 Overview 

 Procedure 

Other topics about Calibration with ECal 
Overview 

The E5061B allows you to perform calibration using the 2 or 4-port ECal 
module in S-parameter measurement. ECal cannot be used for Gain-Phase 
measurement. 

Procedure 

1. Connect the USB cable between the USB port of the 2 or 4-port ECal 
module and the USB port of the E5061B. You can make this 
connection while the E5061B's power is on. 

2. Allows the ECal module to warm up for 20 minutes until the module 
indicator changes from WAIT to READY. 

3. Connect the ports of the ECal module to the test ports you want to 
calibrate. 

4. If you don't use all of the ECal module's ports, connect terminations 
to the unused ports. 

5. Press Channel Next (or Channel Prev) to select the channel of which 
you want to perform the calibration. 

6. Press Cal > Ecal. 

7. Select the calibration type. 

8. If you must select a port, the softkey for making this selection is 
displayed. Select a port and start calibration. If you do not have to 
select a port, skip this step. 

9.  The E5061B detects the test ports connected to the ECal and then 
measurement starts. If the test ports to be calibrated are not 
connected to the ECal module, error occurs. 

Connecting 4-port ECal module (for full 2-port calibration) 
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 You can connect the ports of the ECal and the test 
ports of the E5061B arbitrarily. Connected ports can be 
manually specified although they are automatically detected 
before the data measurement. For more information, see 
Turning off ECal auto-detect function. 
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Improving Calibration Accuracy along with ECal 

Inaccuracy caused by thru calibration in the ECal can be reduced by the 
using the following method: 

 Partial Overwrite 

Other topics about Calibration with ECal 
Partial Overwrite 

Using the partial overwrite function allows you to improve the calibration 
accuracy.  For example, follow these steps for full 2-port calibration: 

1.   Execute full 2-port calibration with ECal and save the calibration 
coefficients. 

2.   Execute the procedure of Partial overwrite with the thru standard of 
the calibration kit. 
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Confidence Check on Calibration Coefficients Using ECal 

 Overview 

 Procedure 

Other topics about Calibration with ECal 
Overview 

By using the ECal module, the E5061B allows you to verify the obtained 
calibration coefficients to determine whether correct measurement is 
possible with them. 

The E5061B is able to set ECal to the state used to verify the measurement 
parameters and then copy the appropriate characteristics of that 
verification state to the memory trace from the ECal's built-in memory. 
This is done according to the measurement parameters of the active trace 
of the active channel. While measuring ECal in this specified state, you can 
compare the measurement results with those of the E5061B and with the 
appropriate measurement results stored in ECal in several different ways. 
These include simultaneously displaying the data and memory traces or 
displaying the math operation results between the data and memory 
traces. This enables you to verify the correctness of measurement for each 
measurement parameter when the obtained calibration coefficients are 
used. 

Procedure 

1. Connect the USB cable between the USB port of the ECal module and 
that of the E5061B. You can make this connection while the 
E5061B's power is ON. 

2. Allows the ECal module to warm up for 15 to 20 minutes until the 
module indicator changes from WAIT to READY. 

3. Press Channel Next (or Channel Prev) to select the channel of which 
you want to perform the verification. 

4. Press Meas key. 

5.  Select the S-parameter you want to verify. You cannot verify the 
mixed mode S-parameter. 

6. Connect the test ports of the E5061B corresponding to the selected 
S-parameter (for example, ports 1 and 2 when the S-parameter is 
S21) and the ports of the ECal module. 

7. If you do not use all of the ECal module's ports, terminate 
connections to the unused ports. 

8. Press Cal > ECal. 
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9. When using an adapter to the ECal, click Characterization and then 
press the softkey corresponding to the characterization of the 
adapter you are using. 

10. Click Confidence Check. 

11. Compare the data trace and memory trace and verify whether 
measurement is correct. 

12. The following is the procedure for comparison when 
simultaneously displaying the data trace and the memory trace. 

a. Press Display > Display > Data & Mem. 

b. Press Scale > Auto Scale. 

c. Determine whether the differences between the traces are 
acceptable. The differences should be read in terms of linear 
values instead of dB error. If you compare the magnitude of 
the linear error with the dB delta, the value is very small. So to 
evaluate the difference between the traces, a linear error scale 
should be used for comparison instead of the dB error scale. 

13. For all of the parameters you want to verify, repeat the 
procedure. 

Connecting ECal module (for verification of S21) 
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Turning off ECal auto-detect function 

The ECal module automatically detects the connection between E5061B's 
test ports and ECal module's ports. You can turn off this function to set 
ports manually. 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to turn off the auto-detect function. 

2. Press Cal > ECal > Orientation  > Manual. 

3. Specify a test port of the E5061B. 

4. Specify an Ecal port for the port of the E5061B you specified. 

 If the auto-detect function is turned off,  no error is 
displayed even if the connection is wrong. 

Other topics about Calibration with ECal 
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User-characterized ECal 

 Overview 

 Precautions to take in using VBA macros 

 Storing user characteristics to the ECal module 

 Backup/recovery of ECal module's built in flash memory 

 Executing User characterized ECal 

Other topics about Calibration with ECal 
Overview 

The E5061B allows you to execute ECal calibration with user-defined 
characteristics instead of the ECal characteristics defined as the factory 
default. This feature is called User-characterized ECal, and it is used to 
execute ECal calibration when an adapter is connected to the ECal module. 

Before executing the User-characterized ECal, you have to measure data, 
such as characteristics when the adapter is connected to the ECal module, 
and store them to the built-in flash memory of the ECal module as the user 
characteristics. 

Use the following VBA macro to acquire user characteristics and store them 
to the ECal module's built-in memory. 

 The User-characterized VBA macro does not support 
4-port ECal modules. Use 2 port ECal modules. 

Storage folder VBA macro name (project name) 

D:\Agilent EcalCharacterization.vba 
Precautions to take in using VBA macros 

 Never connect/disconnect the USB cable while executing the VBA 
macro. 

  In particular, the above precaution must always be 
observed while the VBA macro is storing data to the ECal 
module's built-in flash memory; disconnecting the USB cable at 
this time may damage the ECal module. 

  Back up the flash memory contents. 
The VBA macro provides a feature to back up the contents of the 
ECal module's built-in flash memory. Before storing user 
characteristics to the ECal module, be sure to use this feature to 
back up the flash memory's current contents. 

Storing user characteristics to the ECal module 
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Follow these steps to measure the characteristics while an adapter is 
connected to the ECal module and then to store them to the ECal module's 
built-in flash memory as user characteristics. 

1. Connecting ECal Module 

Connect the USB cable between the USB port of the ECal module and that 
of the E5061B. You can make this connection while the E5061B's power is 
ON. 

2. Setting Stimulus Condition 

Set the stimulus condition of the channel for which you want to measure 
the user characteristics. For optimal accuracy, set the IF bandwidth to 1 
kHz or less. 

3. Executing Calibration 

For the channel of which you have set the stimulus condition, execute full 
2-port calibration with a mechanical calibration kit when characterizing 2-
port ECal. Define the calibration surface as the connector surface 
connected to each port of the ECal module in the state used to measure 
the characteristics. 

 
4. Starting the VBA MACRO 

a. Press Macro Setup > Load Project. 

b. The Open dialog box appears. Specify the file name 
"D:\Agilent\EcalCharacterization.vba" and click Open. 

c. Press Macro Run key to start the macro. 

d. The ECal (1 in the figure below) displays the information of the ECal 
module connected to the E5061B. 

e. Click Refresh (2 in the figure below) to update the information if you 
have connected another ECal module after the macro has been 
started. 
  

5. Measuring User Characteristics 
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a. Select Characterize ECAL (3 in the figure below) to display the User 
Characteristic Measurement screen. 

 
b.  After connecting the adapter to the ECal module as necessary, 

connect each port of the ECal module and the test port of the 
E5061B. 
 

 
 
  

c. Click Measure (4 in the figure) to start measurement. 

  You can select any port of the ECal module and any 
test port of the E5061B for connection; the E5061B 
automatically recognizes the connected ports before 
measurement. 

6. Storing the User Characteristics to the Memory 
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a. When the measurement is complete, the User Characterization Info 
screen appears. 
  

b. Enter the following information. 
  

Designation Category Description 

1 Number Specify a user number (a location 
number in the memory where 
you want to store the user 
characteristics) . If the specified 
location number is not used for 
storage, the parts 
Characterization, Connectors, and 
Adapter Description are left 
blank; if already used, the stored 
contents are displayed. 

2 Characterization Enter the information (operator, 
used analyzer, and so on) when 
measuring user characteristics as 
necessary. 

3 Connectors Select the connector types of the 
adapters for the ECal module's 
test ports. Male and female in the 
list of connected types indicate 
male and female adapter, 
respectively. Select "No adapter" 
if no adapter is used on a port. 

4 Adapter 
Description 

Enter the detailed information on 
the adapters connected to each 
port as necessary. 

The information you have entered is displayed when checking the user 
characteristics information by using the key strokes: Cal > Ecal > 
Characterization Info. 

d. Click Write. 

e. At this time, if user characteristics are already stored for the 
specified user number, a dialog appears to confirm the overwrite. 
Click OK. 
  

 Although the maximum number of user characteristics 
stored in the ECal's memory is usually five, this number may be 
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limited by the memory size because the size of user-characteristics 
data is not fixed and increases in proportion to the number of 
measurement points. An error occurs when the Write button is 
pressed if the total size added to the new user characteristics 
exceeds this limitation due to memory size. 

f. The following dialog box is displayed to confirm execution. Click OK 
to start storing the user characteristics. 

 
  

 Do not disconnect the USB cable or terminate the VBA 
macro by force while the VBA macro is storing data to the ECal's 
built-in flash memory. Doing so may damage the ECal module. 

g. The following dialog box appears while the VBA macro is storing data 
to memory. Storing the user characteristics takes a few minutes 
depending on the amount of data. 

 
  

h. Another dialog box is displayed to notify completion of data storage. 
Click OK. 
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8. Closing the VBA macro 

a. Click Close (No. 5 in Figure) to close the macro. 
Backup and recovery of ECal module's built-in flash memory 

Follow these steps to back up the contents of the ECal module's built-in 
flash memory. 

1. Connect the USB cable between the USB port of the ECal module and 
that of the E5061B. You can make this connection while the 
E5061B's power is ON. 

2. Start the VBA macro according to Starting the VBA MACRO 

3. Select Backup Flash ROM (No. 1 in the following figure) to display the 
Backup screen. 

 

Recovery 

1. Click Recover (No. 2 in the figure above.). 

2. The Open dialog box appears. Enter the file name of the contents 
you want to recover and Click Open. If the serial number information 
stored in the file does not match that of the ECal module connected 
to the E5061B, a confirmation dialog box appears. Click OK to 
continue the recovery only if a mismatch between these serial 
numbers is allowed. 

3. The dialog box is displayed to confirm execution. Click OK to start 
the recovery of the flash memory. The dialog box appears while the 
VBA macro is storing data to the memory. The recovery of the flash 
memory takes a few minutes depending on the amount of data. 

4. The Completion screen appears. Click OK. 

Backup 

1. Click backup. 

2. The Save As dialog box appears. Enter the name of the file you want 
to save and press Save. 

3. Click Close to close the macro. 
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Executing User-characterized ECal 

The execution procedure for the User-characterized ECal is the same as for 
normal ECal except that it requires the user characteristics to be selected 
in advance. 

1. Press Channel Next/Channel Prev to select the channel of which you 
want to execute calibration. 

2. Press Cal > ECal > Characterization. 

3. Select a user characteristic which is specified by User 
Characterization Info screen. 

4. To check the information on the user characteristics you have 
selected, click  Characterization Info. The following dialog box 
appears. 

 
  

1: The date when the user characteristics are measured 

2: The information you entered in Characterization ( 1 of User 
Characterization Info screen) 

3: The stimulus conditions when the user characteristics are 
measured 

4: The information you entered in Adapter Description ( 4 of User 
Characterization Info screen) 

5: The information you entered in Connectors ( 3 of User 
Characterization Info screen) 
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Advanced Calibrations 
Modifying Calibration Kit Definition 

 Definition of Terms 

 Defining Parameters for Standards 

 Redefining a Calibration Kit 

Other topics about Advanced Calibration 

In most measurements, the user can use pre-defined calibration kits as 
they are. However, it may be necessary to change the definition of a 
calibration kit (or create a new one) when changing the pre-defined 
connector between male and female (e.g. from OPEN (f) to OPEN (m)) or 
when a special standard is used or a high degree of accuracy is demanded. 
When it is necessary to change the definition of a calibration kit that 
contains a calibration device but no calibration kit model, the user must 
fully understand error correction and the system error model. 

A user-defined calibration kit may be used in the following circumstances: 

 When the user wants to use connectors other than those pre-defined 
in the calibration kits for the E5061B (e.g., a SMA connector). 

 When the user wants to use different standards in place with one or 
more standards pre-defined in the E5061B. For example, when three 
offset SHORT standards are used instead of OPEN, SHORT, and LOAD 
standards. 

 When the user wants to modify the standard model of a pre-defined 
calibration kit and turn it into a more accurate model. It is possible to 
perform better calibration if the performance of the actual standard 
is better reflected in the standard model. For example, you may need 
to define the 7-mm LOAD standard as 50.4 Ω instead of 50.0 Ω. 

Definition of Terms 

The terms used in this section are defined as follows: 

Standard 

An accurate physical device, for which the model is clearly defined, used to 
determine system errors. With the E5061B, the user may define up to 21 
standards per calibration kit. Each standard is numbered from 1 to 21. For 
example, standard 1 for the 85033E 3.5-mm calibration kit is a SHORT 
standard. 

Standard type 
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The type of standard used to classify a standard model based on its form 
and construction. Five standard types are available: SHORT, OPEN, LOAD, 
delay/THRU, and arbitrary impedance. 

Standard coefficient 

The numeric characteristics of the standard used in the selected model. For 
example, the offset delay (32 ps) of the SHORT standard in the 3.5-mm 
calibration kit is a standard coefficient. 

Standard class 

A group of standards are used in a calibration process. Class allows you to 
use the different standard for each port. For each class, the user must 
select the standards to use from the available standards.  

Defining Parameters for Standards 

The following figures show the parameters used in defining the standards. 

 Reflection Standard Model (SHORT, OPEN, or LOAD) 

 
  

Transmission Standard Model (THRU) 
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Z0 

The offset impedance between the standard to be defined and the actual 
measurement plane. Normally, this is set to the system's characteristic 
impedance. 

Delay 

The delay that occurs depending on the length of the transmission line 
between the standard to be defined and the actual measurement plane. In 
an OPEN, SHORT, or LOAD standard, the delay is defined as one-way 
propagation time (sec.) from the measurement plane to the standard. In a 
THRU standard, it is defined as one-way propagation time (sec.) from one 
measurement plane to the other. The delay can be determined through 
measurement or by dividing the exact physical length of the standard by 
the velocity coefficient. 

Loss 

This is used to determine the energy loss caused by the skin effect along 
the length (one-way) of the coaxial cable. Loss is defined using the unit of 
ohm/s at 1 GHz. In many applications, using the value 0 for the loss 
should not result in significant error. The loss of a standard is determined 
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by measuring the delay (sec.) and the loss at 1 GHz and then substituting 
them in the formula below. 

 

C0, C1, C2, C3 

It is extremely rare for an OPEN standard to have perfect reflection 
characteristics at high frequencies. This is because the fringe capacitance of 
the standard causes a phase shift that varies along with the frequency. For 
internal calculation of the analyzer, an OPEN capacitance model is used. This 
model is described as a function of frequency, which is a polynomial of the 
third degree. Coefficients in the polynomial may be defined by the user. The 
formula for the capacitance model is shown below: 

 

F: measurement frequency 
C0 unit: (Farads) (constant in the polynomial) 
C1 unit: (Farads/Hz) 
C2 unit: (Farads/Hz2) 
C3 unit: (Farads/Hz3) 

L0, L1, L2, L3 

It is extremely rare for a SHORT standard to have perfect reflection 
characteristics at high frequencies. This is because the residual inductance 
of the standard causes a phase shift that varies along with the frequency. 
It is not possible to eliminate this effect. For internal calculation of the 
analyzer, a short-circuit inductance model is used. This model is described 
as a function of frequency, which is a polynomial of the third degree. 
Coefficients in the polynomial may be defined by the user. The formula for 
the inductance model is shown below: 

 

   

F: Measurement frequency 
L0 unit: [Henry] (the constant in the polynomial) 
L1 unit: [Henry/Hz] 
L2 unit: [Henry/Hz2] 
L3 unit: [Henry/Hz3] 

In most existing calibration kits, THRU standards are defined as "zero-
length THRU," i.e., the delay and loss are both "0". Such THRU standard 
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does not exist, however, calibration must be done with two test ports 
interconnected directly. 

  The measurement accuracy depends on the conformity of the 
calibration standard to its definition. If the calibration standard has been 
damaged or worn out, the accuracy will decrease. 

Redefining a Calibration Kit 

This section provides the procedure to change the definition of a calibration 
kit. 

a. Select and define a calibration kit 

1. Press Cal > Cal Kit, then select the calibration kit to be redefined. 

2. Click Modify Kit. 

3. If necessary ,click Label Kit and type a new label for the calibration 
kit. 

b. Select the standard type and define standard coefficient 

4. Click Define STDs and select the standard number to be redefined. 

5. If necessary, click Label, then type your desired name for the 
selected standard. 

6. Click STD Type, then select the type of standard. 

7. Set the standard coefficient. 

8. Repeat steps 4 to 7 to redefine all standards for which changes are 
necessary, then click Return. 

c. Define standard class 

9. Click Specify CLSs, then select the class. 

10. Select the test port. Select Set All to use the same standard for 
all test ports. 

11. Select the standards to be registered in the class from the 
standard number to be redefined. Define classes for all test ports 
that need to be redefined, then click Return. 

12. Repeat the steps 9 to 12 to redefine all classes that need to be 
modified, then click  Return. 

Preset the definition for calibration kits 

1. Press Cal key. 

2. Click Cal Kit, then select a calibration kit. 

3. Click Modify Cal Kit > Restore Cal Kit to preset the selected kit 
definition at the factory setting. 
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Partial Overwrite Calibration 

 Overview 

 Procedure 

Other topics about Advanced Calibration 
Overview 

The partial overwrite function is used to perform partial measurement after 
the execution of calibration, and it overwrites the calibration coefficients. 

There are three types of calibration coefficients: Er, Es, Ed for reflection, Et 
for transmission, and Ex for isolation. If some of them do not provide 
satisfactory calibration, you can use this function to re-calculate the 
calibration coefficients by measuring an applicable standard only instead of 
measuring all the standards again. 

 When the calibration coefficients become 
inappropriate over time or the status on the E5061B side from 
the calibration surface changes due to replacement of a cable or 
connector, you also need to perform thru measurement when 
partial overwrite is required for reflection or isolation 
measurement. 

  The adapter removal and partial overwrite function 
is only available when calibration status is [Cor] and not for 
[C?] or [C!]. 
 
Partial overwrite is not available if no calibration has been done. 
You cannot append calibration coefficients to previous 
calibrations. For example, you cannot realize 2-port calibration 
by performing additional calibration for 1 port after the 
execution of full 1-port calibration. The partial overwrite 
function is used to make measurements for previous calibration 
coefficients and overwrite them. 

Procedure 

Follow these steps to execute the partial overwrite function. The example 
demonstrates re-calibration thru calibration only for exiting 2 port full 
calibration: 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you already have performed full 2 port calibration. 

2. Press Cal >Calibrate > 2-Port Cal. 

3. Click Transmission. 

4. Make a thru connection between the ports 1 and 2. 
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5. Click Port 1-2 Thru. 

6. Click Return. 

7. Click Overwrite to finish the re-calibration for the full 2-port 
calibration. At this point, the calibration coefficients are re-calculated 
with the new thru calibration and saved. 

. 
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Adapter Removal-Insertion 

 About Adapter Removal 

 About Adapter Insertion 

 Procedure for Adapter Removal/Insertion 

 Difference between Traditional Network Analyzer & E5061B Adapter 
Calibration 

Other topics about Advanced Calibration 
About Adapter Removal 

Adapter Removal is a technique used to remove any adapter 
characteristics from the calibration plane. The E5061B uses the following 
adapter removal process to remove the adapter characteristics: 

1. Perform calibration with the adapter in use. 

2. Remove the adapter from the port and measure Open, Short, and 
Load values to determine the adapter's characteristics. 

3. Remove the obtained adapter characteristics from the error 
coefficients in a de-embedding fashion. 

Open, Short, and Load values measured with the adapter removed 

 
 The adapter removal and partial overwrite function is 

only available when the calibration status is [Cor] and not for 
[C?] or [C!]. 

About Adapter Insertion 
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The above described method also makes it possible to add adapter 
characteristics to a port with n-port full calibration. This allows you to 
make a measurement with the adapter. E5061B uses the following adapter 
insertion process to insert the adapter characteristics: 

1. Perform calibration without adapter in use. 

2. Insert the adapter to the port and measure Open, Short, and Load 
values to determine the adapter's characteristics. 

3. Insert the obtained adapter characteristics to the error coefficients in 
an embedding fashion. 

Open, Short, and Load values measured with adapter attached 

 
  

In order to determine the adapter characteristics (with four unknown 
parameters) by making three measurements (Open, Short, and Load), the 
adapter must satisfy the following requirements: 

1. Adapter must be Reciprocal (with S21 and S12 equal) in nature. It 
should have a consistent behavior, and independent of the direction 
from which it is used. 

2. The electrical length of Adapter should be known with the accuracy of 
±1/4 of wavelength. 

Adapter removal and insertion is not available in Gain-Phase measurement. 
Procedure for Adapter Removal/Insertion 

The S parameter of a reciprocal adapter can be determined when the 
following data is available: 
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 Open, Short, and Load measurements. 

 Actual values derived from the CalKit definitions. 

 An approximate length of the adapter. 

 Nature of the intended operation: removal or insertion. 

To use Adapter Removal/Insertion, follow the below procedure: 

1. Perform a full n-Port calibration using your calibration kit so that the 
port used to conduct adapter insertion/removal is calibrated. 

 When you need to remove an adapter from the calibration 
plane (adapter removal) to connect your DUT, perform the 
calibration with an adapter so that you can make a calibration with 
your calibration kit. When you need to add an adapter into the 
calibration plane (adapter insertion) to connect your DUT, perform 
the calibration without an adapter. 

2. Press Cal > Calibrate > Adapter Removal. 

3. Select a proper standard Calkit you need to use from CalKit (e.g. 
85033E) to characterize the adapter. The calibration kit is used at 
the plane from which the adapter is removed (adapter removal), or 
the plane in which adapter is inserted (adapter insertion). 

4. Select Port 1 or Port 2 which you want to insert/remove Adapter 
characteristics from/to.  A * sign appears in front of the port is the 
valid port to conduct adapter removal/insertion as the full n-port 
calibration has been performed on the port. 

5. Connect Open, Short, and Load of the selected Calkit (e.g. 85033E) 
with the selected port respectively and click/press Open, Short, and 
Load respectively. ENA measures the cal kit standard, calculates the 
adapter characteristics, and then conducts adapter 
removal/insertion. 

 A checkmark appears in (Open, Short, and Load) menu 
after each type of calibration is completed. 

7. Click Done to complete the process. 

8. In cases where the auto phase fails, select Rotate Adapter to move 
the adapter's phase (which is removed or inserted) to 180 degrees. 

9. When you want to set the adapter length manually, press Length 
then input the value. Input 0s set at the Auto mode. 

Difference between Traditional Network Analyzer & E5061B Adapter Calibration 

Usually, two-port network analyzers remove the adapter characteristics by 
performing two sets of Full 2 Port Calibration as shown below: 

Calibration performed with the adapter connected to Port2 
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Calibration performed with the adapter connected to Port1 

 
Removing adapter characteristics using two (above) sets of 
calibration 
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However, this method is not suitable for a multi-port network analyzer 
because it requires Full 2 Port Calibration as many as twice the number of 
port combinations. Therefore, the E5061B uses an advanced method to 
remove the Adapter characteristics described in About Adapter Insertion. 
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Making Measurements 

Making Measurements 

 Setting Up Trigger 

 Making Averaging Measurement with Single Trigger 

 Distributing Trigger to External Device 

 Making Trigger 

 Making One Time DC Measurement 

 

Setting Up Trigger 

 Overview 

 Selecting Trigger Source 

 Setting Trigger Mode (Single/Continuous) 

 Making Trigger to Active Channel Only (Trigger Scope) 

 Making One Point Measurement with Single Trigger (Point Trigger) 

 Setting Trigger Delay 

Other topics about Making Measurement 

Overview 

The E5061B has one trigger source. When this trigger source detects a 
trigger signal that has occurred, a sweep or point measurement is 
performed for channels. 

The execution of measurement for each channel does not depend on 
whether the channel is displayed. Channels that have been activated can 
be measured even if they are not displayed. 

For each channel, a sweep is performed only for the stimulus ports 
required to update the parameters of the displayed trace. 
  

Selecting Trigger Source 

The trigger source generates a cue signal that initiates a measurement 
process. Four types of trigger sources are available: 

1. Press Trigger > Trigger Source, then select the desired trigger 
source. 

2. When External is selected as a trigger source, click Ext Trig Input to 
select trigger polarity. 
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 The setting for trigger polarity is NOT valid for the 
external trigger from the 24 Bit I/O (Hander). 

Setting Trigger Mode (Single/Continuous) 

You can set the trigger mode for each channel independently. This allows 
you to control the operation of each channel after a trigger signal is 
detected by setting the channel's status with the trigger mode. 

1. Press Channel Next (or Channel Prev) to select the channel for which 
the trigger mode will be set. 

2. Press Trigger, then select the desired trigger mode. 

3. Repeat the procedure until each channel is set to its trigger mode. 

Making Trigger to Active Channel Only (Trigger Scope) 

The trigger scope specifies the scope of the triggering, whether it is for all 
channels or for the active channel. 

For example, when Trigger > Continuous  is selected for all the channels 
and the trigger scope is set to active channel, a measurement channel is 
automatically changed by changing an active channel. 

1. Press Trigger > Trigger Scope, then select the desired trigger scope. 

Making One Point Measurement with Single Trigger (Point Trigger) 

The point trigger provides a point measurement at every trigger, and it can 
be used to change the trigger event to point trigger mode. 

1. Press Trigger > Trigger Event, then select the desired trigger event. 

 When the trigger source is the internal trigger, the 
point trigger does not work. 

Setting Trigger Delay 

Set the external trigger delay time at each point. The trigger delay works 
when the trigger source is set to external. 

1. Press Trigger > Trig Delay. 

2. Enter an external trigger delay time. 

See the timing chart for sweep. 
Trigger Delay Time and Point Trigger Interval 

External trigger pulses which are supplied until the next measurement 
becomes ready after the start of a one-point measurement, are ignored, 
and the next trigger is generated by a pulse supplied after the completion 
of the one-point measurement. 

The time until the next trigger can be accepted after the start of a one-
point measurement depends on the IFBW and other settings of the 
analyzer. For example, in the case of a frequency's zero-span 
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measurement, the time until the next measurement is ready after the start 
of a one-point measurement is obtained by dividing the time required for a 
single sweep in On Sweep mode, instead of On Point mode, by the number 
of measurement points. If you use the point trigger function with external 
trigger pulses that are wider than this time, point trigger measurement is 
performed at each pulse input. 

The figure below shows the timing chart of an external trigger when the 
point trigger function is on. 

Timing chart of external trigger (trigger source = external) 

 
The table below describes signals and time as shown in the above figure. 

Signal, 
time 

Description 

External 
Trig 

External trigger signal to be supplied. 

Sampling Time while the E5061B is actually performing 
measurement. 

Index Index signal of the handler I/O port. When the point 
trigger function is ON, it goes to the High level only before 
starting the measurement of the first sweep point and 
returns to the Low level after completing the measurement 
of all the measurement points. 
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Point 
Trigger 
Period 

Time until the E5061B is ready to accept a trigger for the 
next measurement point. The value depends on the 
measurement conditions and the settings of the E5061B. 

td1 Time set as the external trigger delay time. 

td2 Time for sweep delay 
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Making Averaging Measurement with Single Trigger 

 Overview 

 Averaging Trigger Function 

Other topics about Making Measurement 

Overview 

The averaging trigger function is used to execute the sweep the number of 
times specified by the averaging factor with a single trigger when the 
sweep averaging function is ON. 

Averaging 
Trigger 

Function 

ON Performs the sweep the number of times specified 
by the averaging factor with a single trigger. 

OFF Performs the sweep once with a single trigger. 

The averaging factor is cleared before the start of measurement. 

 When the point trigger function is ON, its setting has priority, 
and you need to generate triggers based on "(number of measurement 
points) × (averaging factor)". 

 When the sweep averaging function is OFF, sweep is performed 
only once even if the averaging trigger function is set to ON. 

 The averaging trigger function is valid for all the channels. Note 
that you can set the sweep averaging function for each channel. 

Averaging Trigger Function 
Setting Averaging Trigger Function 

When the sweep averaging function is ON, follow these steps to set the 
averaging trigger function. 

1. Press Avg > Avg Trigger. 

2. Click ON to activate the averaging trigger. 
Executing Averaging Measurement 

1. Press Trigger. 

2. Click Single. The averaging factor is cleared before the start of 
measurement, the sweep is executed the number of times specified 
by the averaging factor, and then the instrument waits for the next 
trigger. 
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Distributing Trigger to External Device 

 Overview 

 Setting External Trigger Output 

Other topics about Making Measurement 

Overview 

The External Trigger Output port (located at the rear panel) can be used to 
provide trigger to an external device. This is useful in cases where an 
external device needs to be triggered through the E5061B. 

Setting External Trigger Output 

1. Press Trigger key, and then set the value of Ext Trig Output as ON.  

2. Click Polarity, and then select polarity. 

3. Click Position, and then select position. 

4. Click Pulse Width to define the pulse width of the signal. 

Difference between After and Before Point Settings 

External trigger output function displays the difference in results by setting 
the Point trigger as follows: 

 
   



E5061B 

204 

 

Making Trigger 

 Generating the Trigger 

 Sweep Order in Each Channel 

Other topics about Making Measurement 

Generating the Trigger 

To make a measurement, it is necessary to generate a trigger by using the 
selected trigger source. Once the internal trigger is selected, a series of 
triggers is continuously generated as soon as the setting becomes 
effective. 

Pressing Trigger > Restart during a sweep forces the analyzer to abort the 
sweep. 

Sweep Order in Each Channel 

In a channel, each test port is set to a stimulus port in the order of port 
number, and updates each trace accordingly. 

Sweep Order Stimulus Port Updated Trace 

1 Port 1 S11, S21 

2 Port 2 S12, S22 

3 LF Out T/R, R, T 

 If full 2-port error correction is in effect, no trace between 
calibrated ports is updated until the last calibrated port is swept as the 
stimulus port. 

 Sweep is not executed for stimulus ports that are not required 
for updating traces. 
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Making DC Measurement at Sweep End (Option 3L5 only) 

 DC Measurement at end of sweep 

 Clear the DC measurement Data 

Other topics about Making Measurement 

DC Measurement at end of sweep 

E5061B option 3L5 allows you to measure DC level at the end of 
measurement sweep. When this function is turned on, after the sweep is 
finished, the DC level is measured in the condition of the last point of 
sweep, then result is displayed at the upper right corner of the screen. 

1. Press Meas > DC Monitor Setup. 

2. Click Function to select the port for DC measurement. 

3. Click DC Monitor Sweep End > Monitor to turn ON the DC monitor 
function. 

4. The result is displayed at the upper right corner of the screen. 

Clear the DC measurement Data 

You can clear the DC measurement data. This can be used when you want 
to clear the data at the hold status. 

1. Click Meas > DC Monitor Setup > DC Monitor Sweep End > Clear to 
reset the DC measurement at sweep end. 
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Analyzing Data 

Analyzing Data 

 Analyzing Data on the Trace Using the Marker 

 Searching for Positions that Match Specified Criteria 

 Determining the Bandwidth of the Trace (Bandwidth Search) 

 Determining the Bandwidth of the Trace (Notch Search) 

 Determining the Mean, Standard Deviation, and p-p of the Trace 

 Obtaining Span, Gain, Slope, and Flatness between Markers 

 Obtaining Loss, Ripple, and Attenuation of the RF Filter 

 Comparing Traces/Performing Data Math 

 Performing Parameter Conversion of Measurement Results 

 Using Limit Test 

 Using Bandwidth Test 

 Using Ripple Test 

 Using Equation Editor 
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Analyzing Data on the Trace Using the Marker 

 About Marker Functions 

 Reading Marker Values on Trace 

 Reading Relative Value from Reference Point on Trace 

 Reading Actual Measurement Point/Value Interpolated between 
Measurement Points 

 Setting up Markers for Each Trace/Setting up Markers for Coupled 
Operation between Traces 

 Listing Marker Values in All Displayed Channels 

 Specifying Display Position of Marker Values 

 Aligning Marker Value Display 

 Displaying All Marker Values for Displayed Traces 

Other topics about Data Analysis 

About Marker Functions 

The marker can be used in the following ways: 

 Reading a measured value as numerical data (as an absolute value 
or a relative value from the reference point) 

 Moving the marker to a specific point on the trace (marker search) 

 Analyzing trace data to determine a specific parameter 

 Using the value of the marker to change the stimulus (sweep range) 
and scale (value of the reference line) 

For the procedure used to change the sweep range and scale by using the 
marker, refer to Setting the Sweep Range Using the Marker and Setting the 
value of a reference line using the marker. 

The E5061B is capable of displaying up to 10 markers including the 
reference marker on each trace. Each marker has a stimulus value (the 
value on the X-axis in rectangular display format) and a response value (the 
value on the Y-axis in rectangular display format). The Smith chart and polar 
formats have two marker response values each (log amplitude and phase). 

  

Reading Marker Values on Trace 

You can read the value of a marker displayed on the trace. 

In rectangular display format, the marker response value is always in the 
same data format as that of the Y-axis. On the contrary, one format of the 
marker response values (two values: main and auxiliary) can be selected 
from several types. The selection is performed in the data format. 
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Softkey for selecting data 
format 

Marker response value 

Main Auxiliary 

Smith > Lin / Phase 
Linear 
amplitude 

Phase 

Smith > Log / Phase Log amplitude Phase 

Smith > Real / Imag 
Real 
component 

Imaginary 
component 

Smith > R + jX Resistance Reactance 

Smith > G + jB Conductance Susceptance 

Polar > Lin / Phase 
Linear 
amplitude 

Phase 

Polar > Log / Phase Log amplitude Phase 

Polar > Real / Imag Real 
component 

Imaginary 
component 

To set up data formats, refer to Selecting a Data Format. 
Activating the marker on the Trace 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the channel on which a marker is used. 

2. Press Marker key. At this point, marker 1 is turned on and becomes 
active (you can operate the marker). When using marker 1, you can 
omit the next step. 

3. Select a marker and turn it ON. The softkey used to turn on a marker 
is also used to activate that marker. 

Moving the marker 

1. Change the marker stimulus value. This operation enables you to 
move the marker to a point on the selected trace. 
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2. Read the marker stimulus value and marker response value 
displayed in the upper-left part of the trace screen. 

Turning off the marker 

1. Press Marker key. 

2. Click Clear Marker Menu and then click one of the options. 

 In the preset configuration, the marker settings on 
traces in a channel are coupled (Marker Couple is turned on). 
For marker coupling, refer to Setting up markers for each 
trace/Setting up markers for coupled operations between traces. 

  

Reading Relative Value from Reference Point on Trace 

You can convert the marker reading into a relative value from the reference 
point. 

 
Converting From a Reference Point to a Relative Value 

1. Activate the reference marker. 

2. Move the reference marker at the point to be used as the reference. 

3. Click Ref Marker Mode to turn on the reference mode. 

4. With the reference mode turned ON, the stimulus values and 
response values are indicated in relative values referred to by the 
position of the reference marker. 

5. Activate your desired marker, then move it to your desired position. 

 Pressing Marker > Marker -> Ref Marker enables you 
to place the reference marker at the position of the currently 
active marker. The reference mode then turns ON automatically. 

Reading Actual Measurement Point/Value Interpolated between 
Measurement Points 
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The point on the trace on which a marker can be placed differs depending on 
how the discrete marker mode is set up. 

Value Description 

Turning 
on 
discrete 
mode 
(Discrete 
ON) 

A marker moves only between actual measurement points. 
When a specific marker's stimulus value is specified as a 
numerical value, the marker is placed at the measurement 
point closest to the specified value. A marker placed 
between interpolated points with the discrete mode OFF 
automatically moves to the nearest measurement point 
when the discrete mode is turned ON. 

Turning 
off 
discrete 
mode 
(Discrete 
OFF) 

The marker can move from one actual measurement point 
to another. Because it is interpolated, it can also move in 
the space between measurement points. 

 

  
Turning Discrete Mode On or Off 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace on which the discrete mode is set up. 
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2. Press Marker Fctn. 

3. Click Discrete to turn the discrete mode ON or OFF. 
  

Setting up Markers for Each Trace/Setting up Markers for Coupled 
Operation between Traces 

Makers can be set up and moved either in coupled operation for all traces in 
a channel or independently for each trace. 

 
  

Value Description 

Marker Couple 
is ON 
(Coupling ON) 

Markers are set up and moved in coupled operation on 
all the traces in a channel. 

Marker Couple 
is OFF 
(Coupling OFF) 

Markers are set up and moved independently for each 
trace. 

Turning Marker Coupling On or Off 

1. Press Channel Next (or Channel Prev) to activate the channel on which 
the marker couple is set. 

2. Press Marker Fctn. 

3. Click Couple to turn the marker coupling ON or OFF. 

Listing all Marker Values in all Displayed Channels 

You can list all of the marker values in all of the displayed channels on the 
screen. 
Turning ON the Marker Table Display 
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1. Press Marker Fctn. 

2. Click Marker Table to turn ON the marker table display. 

The marker table appears in the lower part of the screen. 

 

  

Specifying Display Position of Marker Values 

This section describes how to specify the marker value display position for 
each active trace. 
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Value Description 

Marker Info X 
Pos 

Specifies the horizontal display position by the width of 
the display area as a percentage. 

Marker Info Y 
Pos 

Specifies the vertical display position by the height of the 
display area as a percentage. 

Operational procedure 

1. Press Channel Next (or Channel Prev) to activate the channel for 
which you want to set the marker coupling. 

2. Press Marker Fctn > Annotation Options. 

3. Click Marker Info X Pos to set the horizontal display position. 

4. Click Marker Info Y Pos to set the vertical display position. 

Aligning Marker Value Display 

This section describes how to align maker value displays. 
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Value Description 

On 
(Align ON) 

Displays marker values to align to the display position of 
trace 1. 

Off 
(Align 
OFF) 

Displays marker values in the display position defined for 
each trace. 

1. Press Marker Fctn > Annotation Options. 

2. Click Align to toggle ON/OFF. 
  

Displaying All Marker Values for Displayed Traces 

This section describes how to display all marker values for the displayed 
traces. 
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Value Description 

Displays all 
(Active Only OFF) 

Displays all marker values for displayed 
traces. 

Displays active 
markers 
(Active Only ON) 

Displays markers for the active trace only. 

1. Press Marker Fctn > Annotation Options. 

2. Click Active Only to toggle ON/OFF. 
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Searching for Positions that Match Specified Criteria 

 Overview 

 Setting Search Range 

 Automatically Executing a Search (Search Tracking) 

 Searching for Maximum and Minimum Values 

 Searching for the Peak 

 Searching for Multiple Peaks 

 Searching for the Target Value (Target search) 

 Searching for the Multiple Target Values (Multi-target Search) 

Other topics about Data Analysis 

Overview 

You can search for a position that matches your specified criteria by using 
the Marker Search feature. Marker Search allows you to search for a 
position that matches any of the following criteria. 

 Maximum value 

 Minimum value 

 Peak 

 Maximum peak (for a positive peak), minimum peak (for a 
negative peak) 

 Peak on the left-hand side nearest to marker position 
 Peak on the right-hand side nearest to marker position 

 Multi Peak 

 Target (a point that has a target measurement value) 

 Target nearest to the marker position 
 Target on the left-hand side nearest to marker position 
 Target on the right-hand side nearest to marker position 

 Multi Target 

Setting Search Range 

The Marker Search feature allows you to set part of the sweep range as the 
search target (Partial Search feature) as well as the entire search range. 
For the Partial Search feature, you can select whether to couple traces in 
the channel. 

Procedure to Turn ON/OFF Trace Coupling within Search Range 
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1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace for which you want to set the search range. 

2. Press Marker Search > Search Range. 

3. Click Couple to toggle ON/OFF trace coupling within the search 
range. 

Procedure to Set Search Range 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace for which you want to set the search range. 

2. Press Marker Search > Search Range. 

3. Click Search Range to turn ON the Partial Search feature. 

4. Click Start, then enter the start value (lower limit) of the search 
range. 

5. Click Stop, then enter the stop value (upper limit) of the search 
range. 

Automatically Executing a Search (Search Tracking) 

Search tracking is a function that sets a search to be repeated every time a 
sweep is done even if the execution key for the search (maximum, 
minimum, peak, and target) is not pressed. This function facilitates 
observation of measurement results such as the maximum value of traces 
(e.g., the insertion loss of a band pass filter). 

Performing Search Tracking 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace on which you want to set up the search 
tracking. 

2. Press Marker Search key. 

3. Click Tracking and turn the search tracking function ON/OFF. 

Searching for Maximum and Minimum Values 

You can search for the maximum or minimum measured value on the trace 
and move a marker to that point. 
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Search for 
maximum (Max) 

Move active marker to point on the trace where 
measured value is the greatest 

Search for 
minimum (Min) 

Move active marker to point on the trace where 
measured value is the lowest 

  

Procedure 

1. Activate the marker you are using to search for the maximum and 
minimum values. 

2. Press Marker Search key. 

3. Click the corresponding softkey to move the marker to the maximum 
or minimum measured value. 

 When the data format is in Smith chart or polar 
format, execute the search only for the main response value. 

Searching for the peak 

The peak search function enables you to move the marker to the peak on 
the trace. 

Definition of the peak 

A peak is a measurement point of which the value is greater or smaller 
than the adjoining measurement points on its right and left sides. Peaks 
are classified into the following two types depending on the differences in 
magnitude from the measurement points on either side of it. 

Positive 
peak 
(Positive) 

A peak of which the measured value is greater than the 
measurement points on either side of it (peak polarity: 
positive) 
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Negative 
peak 
(Negative) 

A peak of which the measured value is smaller than the 
measurement points on either side of it (peak polarity: 
negative) 

About Peak Excursion Value 

The peak excursion value is smaller among the differences in the measured 
values from the adjoining peaks of the opposite polarity. 

  

 
Executing a Peak Search 

The following three methods are available for executing the peak search: 
  

Peak 
search 
(Search 
Peak) 

Moves the marker to the maximum peak when peak 
polarity is Positive or Both. Moves the marker to the 
minimum peak when peak polarity is Negative. 

Left 
search 
(Search 
Left) 

Executes the search from current marker position to the 
smaller stimulus values and moves the marker to first 
peak encountered. 

Right 
search 
(Search 
Right) 

Execute the search from current marker position to the 
larger stimulus values and moves the marker to first peak 
encountered. 
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Procedure 

1. Activate the marker you are using for the peak search. 

2. Press Marker Search key. 

3. Click Peak > Peak Excursion. 

4. Enter the lower limit for the peak excursion value. This sets the peak 
search to be executed based on the definitions of the newly set lower 
limit for the peak excursion value and the currently set peak polarity. 

5. Click Peak Polarity. 

6. Select a peak polarity. This sets the peak search to be executed 
based on the definitions of the currently set lower limit for the peak 
excursion value and the newly set peak polarity. 

7. Click the corresponding softkey to move the marker to the peak. 

 When the data format is in Smith chart or polar 
format, execute the search for the main response value of the 
two marker response values. 

Searching for Multiple Peaks 

The multi-peak search function enables you to display markers on multiple 
peaks on traces. 

Definition of the Peaks 

A peak is a measurement point whose value is greater or smaller than the 
adjoining measurement points on its right and left sides. Peaks are 
classified into the following types depending on the difference in magnitude 
from the measurement points on either side of it. 



Measurement 

221 

Positive peak 
(Positive) 

A peak of which the measurement value is greater 
than the measurement points on either side of it 
(peak polarity: positive) 

Negative peak 
(Negative) 

A peak of which measurement value is smaller than 
the measurement points on either side of it (peak 
polarity: negative) 

About the Multi-peak Search Function (Search Multi Peak) 

The multi-peak search is a function that searches for peaks that match 
with pre-defined lower limit for the peak excursion value and peak polarity 
(positive or negative) and then displays the markers on the peaks being 
searched. Depending on number of detected peaks, markers 1 through 9 
are displayed from the start frequency. 

The peak excursion is the smaller of the differences in measurement values 
from the adjoining peaks of the opposite polarity. 

 When the multi-peak search is executed, search and 
tracking settings for markers 1 through 9 are ignored and the 
settings for the multi-peak search are used. Note that the 
reference marker is not affected. 

Positive Peak/Negative Peak and Peak Excursion 

Multi-peak Search (when peak polarity is positive) 
Executing a Multi-peak Search 

1. Activate the marker you are using for the multi-peak search. 

2. Press Marker Search > Multi Peak > Peak Excursion 

3. Enter the lower limit for the peak excursion value. 
 
This causes the multi-peak search to be executed based on the 
definitions of the newly set lower limit for the peak excursion value 
and currently set peak polarity. 

4. Press Peak Polarity. 

5. Select a peak polarity from positive, negative or both. 
 
This causes the multi-peak search to be executed based on the 
definitions of the currently set lower limit for the peak excursion 
value and newly set peak polarity. 

6. Press Search Multipeak to move the marker to the peak. 

 When the data format is Smith chart or polar format, 
execute the search for the main response value of the two 
marker response values. 
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Searching for the target value (target search) 

The target search is a function that searches for a target that matches the 
pre-defined target value and transition type(s) (positive, negative, or both 
positive and negative) and then moves the marker to that target. 

Target and Transition Types 

A target is a point that has a specific measured value on the trace. Targets 
can be divided into the two groups shown below depending on their 
transition type. 

Transition type: 
Positive (Positive) 

When the value of the target is larger than the 
measured value that immediately precedes it 
(on the left side) 

Transition type: 
Negative (Negative) 

When the value of the target is smaller than the 
measured value that immediately precedes it 
(on the left side) 

  

 
Executing a Target Search 

The following three methods are available for executing the target search: 

Target 
search 
(Search 
Peak) 

The marker moves to the peak with maximum 
response value if the peak polarity is Positive or Both 
or to the peak with minimum response value if the 
peak polarity is Negative. 

Search left 
(Search Left) 

Executes the search from the current marker position 
to the smaller stimulus values and moves the marker 
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to first encountered target. 

Search right 
(Search 
Right) 

Executes the search from the current marker position 
to the larger stimulus values and moves the marker to 
first encountered target. 

  

 

Procedure 

1. Activate the marker you are using for the target search. 

2. Press Marker Search key. 

3. Click Target  > Target Value 

4. Enter the target value in the entry area that appears. This causes the 
target search to be executed based on the definitions of the newly 
set target value and the currently set transition type. 

5. Click Target Transition. 

6. Select a transition type. This sets the target search to be executed 
based on the definitions of the currently set target value and the 
newly set transition type. 

7. Press the corresponding softkey to move the marker to the target. 

 When the data format is in Smith chart or polar 
format, execute the search for the main response value of the 
two marker response values. 

Searching for the Multiple Target Values (Multi-target Search) 
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The multi-target search function enables you to display a marker on each 
point having the target measurement value. 

Target and Transition Types 

A target is a point that has a specific measurement value on the trace. 
Targets can be divided into two groups shown below depending on their 
transition type. 

Positive 

  

When the value of the target is larger than the 
measurement value that immediately proceeds it (on the 
left side). 

Negative When the value of the target is smaller than the 
measurement value that immediately proceeds it (on the 
left side). 

Target and Transition Types 
About the multi-target search function (Search Multi Target) 

The multi-target search is a function that searches for targets that match 
to pre-defined target value and transition type(s) (positive, negative, or 
both of positive and negative) and displays markers on the targets being 
searched. 

Depending on the number of detected targets, markers 1 through 9 are 
displayed from the start frequency. 

 When the multi-target search is executed, search 
and tracking settings for markers 1 through 9 are ignored and 
the settings for the multi-target search are used. Note that the 
reference marker is not affected. 

Multi-target Search (when transition type is set to "both positive 
and negative") 

Procedure 

1. Activate the marker you are using for target search. 

2. Press Marker Search > Multi Target > Target Value. 

3. Enter a target value in the entry box that appears. 
 
This causes the target search to be executed based on the target 
value newly set and the transition type defined at this point. 

4. Press Target Transition. 

5. Selects a transition type from positive, negative or both. 
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This causes the target search to be executed based on the target 
value set at this point and the transition type newly set. 

6. Press Search Multi Target to move the marker to the target. 

 When the data format is in Smith chart or polar 
format, execute the search for the main response value of the 
two marker response values. 
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Determining the Bandwidth of the Trace (Bandwidth Search) 

 Overview 

 Executing a Bandwidth Search 

Other topics about Data Analysis 

Overview 

The bandwidth search is a function for determining the bandwidth of the 
trace, center frequency, cut-off points (on the higher frequency and the 
lower frequency sides), Q, and insertion loss based on the position of the 
active marker. The definitions of the parameters determined through the 
bandwidth search are shown below. 

 

Bandwidth 
Parameter 

Definition 

Insertion loss 
(loss) 

The measured value of the position of the active 
marker at the time the bandwidth search is 
executed. 

Lower frequency 
cut-off point (low) 

Lowest frequency within two measurement 
points, both separated by the defined bandwidth 
value from the active marker position. 

Higher frequency 
cut-off point 

Highest frequency within two measurement 
points, both separated by the defined bandwidth 
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(high) value from the active marker position. 

Center frequency 
(cent) 

Frequency at the midpoint between the lower 
frequency cut-off and higher frequency cut-off 
points. (high+low)/2 

Bandwidth (BW) The difference in frequency between the higher 
frequency cut-off and lower frequency cut-off 
points. (high-low) 

Q Value obtained by dividing the center frequency 
by the bandwidth.(cent/BW) 

Executing a Bandwidth Search 

1. Place the active marker at the desired point on the trace on which 
the bandwidth search is executed. The response value of this active 
marker itself is the insertion loss in the bandwidth search (loss). 

2. Press Marker Search > Bandwidth Value. 

3. Enter the defined bandwidth value in the entry area that appears. 

4. Click Bandwidth to turn ON the bandwidth search. In the upper left of 
the trace display, six bandwidth parameters are displayed. 

Bandwidth search results 
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Determining the Bandwidth of the Trace (Notch Search) 

 Overview 

 Executing a Notch Search 

Other topics about Data Analysis 

Overview 

The notch search function is used to obtain the bandwidth, center 
frequency, cutoff points (high-frequency side and low-frequency side), Q, 
and insertion loss of a trace based on the active marker position. The notch 
search function starts from the left side of the active marker position, and 
ends when the points meet the conditions. 

The figure and table below shows the definition of parameters obtained by 
notch search function. The notch value in figure below must be specified by 
the user. 

Bandwidth Parameters 

 
Definition of bandwidth parameters 

Bandwidth 
parameter 
name 

Definition 

Insertion loss 
(loss) 

Measurement value at the active marker position 
when the notch search is executed. 
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Lower cutoff 
point (low) 

Lower frequency of the 2 points on both sides that 
have the measurement value apart from the active 
marker position by the notch value. 

Higher cutoff 
point (high) 

Higher frequency of the 2 points on both sides that 
have the measurement value apart from the active 
marker position by the notch value. 

Center frequency 
(cent) 

Frequency of the middle point between the lower 
cutoff point and the higher cutoff point (high + 
low)/2. 

Bandwidth (BW) Frequency difference between the higher cutoff 
point and the lower cutoff point ( high – low ). 

Q Value obtained by dividing the center frequency by 
the bandwidth (cent/BW). 

Executing a Notch Search 

1. Place the active marker on the desired point on the trace on which 
the notch search is executed. The response value of this active 
marker itself is the insertion loss in the notch search (loss). 

2. Press Marker Search > Notch Value and enter the notch value in the 
entry area that appears. 

3. Press Notch to turn ON the notch search. In the upper left of the 
trace display, six bandwidth parameters are displayed (see the figure 
below). 
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 For more information on displaying the notch search 

result, see Notch Search 
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Determining the Mean, Standard Deviation, and p-p of the Trace 

 Overview 

 Displaying Statistical Data 

Other topics about Data Analysis 

Overview 

You can easily determine the statistics data for a trace (span, mean, 
standard deviation, and peak-to-peak). The definitions for the statistics data 
elements are shown below. It is calculated within the range of markers 1 
and 2. The markers 1 and 2 are activated automatically. 

 

Statistics 
data 
element 

Definition 

Span Span between markers 1 and 2. 

Mean (mean) 

 
(n: number of points between markers 1 and 2; xi: 
measured value at the i-th measurement point 
between markers 1 and 2.) 
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Standard 
deviation 
(s. dev) 

 
(n: number of points between markers 1 and 2; xi: 
measured value at the i-th measurement point 
between markers 1 and 2.; mean: Mean) 

Peak-to-peak (p 
- p) 

Max - Min (Max: greatest measured value between 
markers 1 and 2.; Min: smallest measured value 
between markers 1 and 2.) 

 The search range does not affect this result. 

Displaying Statistical Data 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace of which the statistical data is required. 

2. Press Marker Fctn > Statistics to turn ON the display of statistics 
data. 

3. The markers 1 and 2 are activated automatically. Move markers 1 
and 2 to the position of the measurement. 
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Obtaining Span, Gain, Slope, and Flatness between Markers 

The span, gain, slope, and flatness between marker 1 and marker 2 on a 
trace can be obtained. The following figure shows data definitions. 

Span, Gain Slope, and Flatness Parameters 

 
  

Data 
Name 

Definition 

Span Calculates the distance between marker 1 and marker 2. 

Gain Calculates the larger measurement value between marker 
1 and marker 2. 

Slope Calculates the differences in measurement value between 
marker 1 and marker 2. (marker 2 - marker 1) 

Flatness Calculates the sum of 2 maximum measurement value 
differences from the line connecting marker 1 and marker 
2 (above and below the line). 
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1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace of which you want to obtain the data. 

2. Press Marker Fctn > Flatness to show data. 

3. Markers 1 through 2 are turned ON and displayed. 

4. Set the positions of markers 1 through 2 on the trace. 
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Obtaining Loss, Ripple, and Attenuation of the RF Filter 

Specify the pass band with markers 1 and 2 on the trace and specify the 
stop band with markers 3 and 4 to obtain loss, ripple, and attenuation. The 
following figure shows data definitions. 

Loss, Ripple, and Attenuation Parameters 

 
  

Data 
Name 

Definition 

Loss (loss) Calculates the minimum value between markers 1 and 2. 

Ripple (p-
p) 

Calculates the differences between the maximum value 
and the minimum value of markers 1 and 2. 

Attenuation 
(reject) 

Calculates the differences between the maximum value 
between markers 3 and 4 and the minimum value (loss) 
between markers 1 and 2. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace of which you want to obtain the data. 

2. Press Marker Fctn > RF Filter Stats to show the data. 
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3. Markers 1 through 4 are turned ON and displayed. 

4. Set the positions of markers 1 through 4 on the trace. 
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Comparing Traces/Performing Data Math 

 Overview 

 Performing Data Math Operations 

Other topics about Data Analysis 

Overview 

Each of the traces for which measured data is displayed is provided with an 
additional trace, called a memory trace, that temporarily stores measured 
data. You can use the memory trace to compare traces on the screen or to 
perform complex data math between the memory trace and measured 
data. 

The following data math operations are available: 

Value Description 

Data / 
Memory 

Divides the measured data by the data in the memory 
trace. This function can be used to evaluate the ratio of two 
traces (e.g., evaluating gain or attenuation). 

Data * 
Memory 

Multiplies the measured data by a memory trace. 

Data -
 Memory 

Subtracts a memory trace from the measured data. This 
function can be used, for example, to subtract a vector 
error that has been measured and stored (e.g., directivity) 
from data subsequently measured on a device. 

Data + 
Memory 

Adds the measured data and the data in the memory 
trace. 

Performing Data Math Operations 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace to be stored in memory. 

2. Press Display > Data -> Mem to store the measured data in memory. 

3. Press Data Math. 

4.  Select the data math operation to perform. 

5. Press Display. 

6. Select the type of data to display ON the screen. 

7. Send the trigger to make measurements. 
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Performing Parameter Conversion of Measurement Results 

 Overview 

 Turning Conversion ON 

 Selecting Conversion Target Parameter 

Other topics about Data Analysis 

Overview 

You can use the parameter conversion function to convert the measurement 
results of the S-parameter (Sab) to the following parameters. 

  Equivalent impedance (Zr) and equivalent admittance (Yr) in 
reflection measurement 
 

 
 Equivalent impedance (Zt) and equivalent admittance (Yt) in 

transmission measurement 
 

 
 Inverse S-parameter (1/Sab) 

where: 

Z0a: Characteristic impedance of port a 

Z0b: Characteristic impedance of port b 

 Z/Y Transmission Shunt 
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 Conjugation 
 
Conjugation converts the measurement value to complex conjugate 
number. 
  

When the fixture simulator function is ON and the port impedance function is 
ON, the value set in the port impedance conversion is used. In other cases, 
the system Z0 (preset value: 50 Ω) is used. 

Turning Conversion ON 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate a trace of which you want to use the marker. 

2. Press Analysis >  Conversion. 

3. Click Conversion to turn ON the conversion function. 

Selecting Conversion Target Parameter 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate a trace of which you want to use the marker. 

2. Press Analysis > Conversion > Function. 

3. Select the parameter to which you want to convert the result. 

When the conversion function is ON, the selected parameter is displayed in 
Trace Status Area. 
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Using Limit Test 

 Overview 

 Concept of Limit Test 

 Displaying Judgement Result of Limit Test 

 Defining Limit Line 

 Changing the Limit Line Display Mode 

 Using Relative Limit Line 

 Adding Offset to Limit Line 

 Initializing the Limit Table 

Other topics about Data Analysis 

Overview 

The limit test feature allows you to set the limit line for each trace and 
then perform the pass/fail judgment for the measurement result. 

Concept of Limit Test 

The limit test is a function to perform pass/fail judgment based on the limit 
line you set with the limit table. 

In the limit test, if the upper limit or lower limit indicated by the limit line 
is not exceeded, the judgment result is pass; if it is exceeds, the judgment 
result is fail for all measurement points on the trace. Measurement points 
in a stimulus range with no limit line are judged as pass. 

 The targets of the pass/fail judgment are measurement points 
only. Parts interpolated between the measurement points are not 
judged. 

You define the limit line by specifying the stimulus value (Begin Stimulus) 
and response value (Begin Response) of the begin point, the stimulus 
value (End Stimulus) and response value (End Response) of the end point, 
and the type (lower limit/upper limit). For more information, refer to 
Defining the limit line. 

When the limit test is ON, measurement points that fail are displayed in 
red on the screen and the trace's pass/fail judgment result based on the 
results of individual measurement points (fail if one or more measurement 
points on the trace fail) is also displayed. You can check the pass/fail 
judgment result for the channel (fail if one or more traces fail in any of the 
limit test, the ripple test or the bandwidth test within the channel) on the 
screen as well. For more information, refer to Displaying judgment result of 
limit test. 
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In addition to viewing the screen, you can check the judgment result of the 
limit test with the following methods. 

 Beep that occurs when the judgment result fails. 

 Using the status register. 
  

Displaying Judgment Result of Limit Test 
Judgment result of measurement points and trace 

Measurement points that fail are displayed in red on the screen. The 
judgment result of the trace is indicated by Pass or Fail displayed in the 
upper right section of the graph. 

 
  

Judgment result of channels 

If a channel has a judgment result of fail, the message below appears on 
the screen (it will be judged as fail if one or more unsatisfactory trace exist 
in any of the limit test, the ripple test or the bandwidth test within the 
channel.) 

 
Follow these steps to turn ON/OFF the display of the channel fail message. 
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1. Press Analysis > Limit Test. 

2. Click Fail Sign. Each press toggles between ON/OFF. 
  

Defining Limit Line 

To use the limit test, you must first define the limit line. You can define a 
limit table for each trace, and you can define up to 100 limit lines 
(segments) in a limit table. 

Defining a segment 

The following steps describe how to define a segment. 

1. Press  Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace on which the limit test function is used. 

2. Press Analysis > Limit Test. 

3. Click Edit Limit Line to display the limit table. 
 

 
  

4. Using the limit table, create/edit a segment. Initially, no segments 
are entered in the limit table. At the same time, the Edit Limit Line 
menu used to create/edit the limit table is displayed. 

5. Click Add to add a segment to the limit table and then specify the 
segment parameter values shown below. 
  

Segment 
Parameter 

Description 

Type Select the type of segment from the following: 

OFF Segment not used for the limit test 

MIN Segment at which the minimum is 
specified 
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MAX Segment at which the maximum is 
specified 

Begin Stimulus Specify starting point for stimulus value on the 
limit line 

End Stimulus Specify ending point for stimulus value on the 
limit line 

Begin Response Specify starting point for response value on the 
limit line 

End Response Specify ending point for response value on the 
limit line 

 The range in which stimulus values can be specified is from 
-500 G to +500 G. When a value outside the range is entered, a 
suitable value within the range is specified. Once the stimulus value 
is specified, changing the sweep range of the E5061B does not 
affect the stimulus value. 

 The range in which response values can be specified is 
from -500 M to +500 M. When a value outside this range is 
entered, a suitable value within the range is specified. After the 
response value is specified, changing formats results in changing 
the units but not the value. 
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 You can define a limit line that is able to freely overlap the 

stimulus range of another limit line. 
 
Defining one limit line that has the same type as a second limit line 
whose stimulus range overlaps with the first one results in two or more 
limit values at the same measurement point. In this case, the limit 
value to be used in the limit test is defined as follows: 

 When two or more limit values of which the type is set to 
maximum (MAX) exist, the smallest one is used as the maximum. 

 When two or more limit values of which the type is set to 
minimum (MIN) exist, the largest one is used as the minimum. 

 Even if the span of the sweep range on the E5061B is set to 0, 
enter the two parameters of Begin Stimulus and End Stimulus. 

 When two or more response values are returned as a result of 
using the Smith or polar chart format, the first response value of the 
marker provides the object of the limit test. 

Saving/calling the limit table 

You can save the limit table to a file that you can then freely bring up on 
the screen later and use. You can import a file saved in CSV format 
(extension: *.csv) into spreadsheet software on a PC for later use (a 
numerical value is saved as strings that includes its unit). 
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1. Display the limit table. 

2. In the Edit Limit Line menu, press Export to CSV File to open the Save 
As dialog box. In this step, CSV (extension: *.csv) is selected as the 
file type. 

3. Specify the folder in which to save the file and enter the file name. 
Press Save to save the limit table displayed on the screen to the file. 

4. Conversely, to recall a saved limit table, press Import from CSV File in 
the Edit Limit Line menu to display the Open dialog box. In this step, 
CSV (extension: *.csv) is selected as the file type. 

5. After specifying the folder containing the file, select the file. Press 
Open to display the limit table on the screen. 

 The limit table can be called from any trace of any 
channel, regardless of the channel or trace. 

Limit Table Saved in CSV Format 

The limit table is saved in the following format. 

 On the first line, the channel number of the active channel that is 
valid when the saved file is the output. 
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 On the second line, the trace number of the active trace that is valid 
when the saved file is the output. 

 The third line provides the header showing the items for the 
segments to be output on the fourth and later lines. 

 Data on segments are output on the fourth and later lines. 
"# Channel 1" 

"# Trace 1" 

Type,             Begin Stimulus,             End Stimulus, Begin Response, End Response 

MAX, 200.0000000 MHz, 400.0000000 MHz, -100 dB, -100 dB 

MAX, 490.0000000 MHz, 510.0000000 MHz, -10 dB, -10 dB 

MIN, 490.0000000 MHz, 510.0000000 MHz, -20 dB, -20 dB 

MIN, 600.0000000 MHz, 800.0000000 MHz, -100 dB, -100 dB 
Turning the limit test ON/OFF 

You can set the limit test ON/OFF for each trace individually. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace on which the limit test function is used. 

2. Press Analysis > Limit Test to display the Limit Test menu. 

3. Press Limit Test to set the limit test ON/OFF. 

4. Press Limit Line to set the limit line display ON/OFF. 

Changing the Limit Line Display Mode 

You can specify the limit line display mode hide limit values that are not 
used for evaluation. 
Changing the display mode: 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the channel of which you want to use the limit test 
function. 

2. Press Analysis > Limit Test. 

3. Turn off Limit Line. 

4. Press Clip Lines to toggle ON/OFFf. 

Limit line display mode 
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Using Relative Limit Line 

If the shape is more important than the amplitude, you can make the limit 
lines relative to the peak point of the trace using the reference tracking 
function. 

In this function, the point to be tracked is set as the Y-axis reference value 
by offsetting measurement values after the sweep. Because measurement 
values are offset, marker values and limit test evaluation results change 
accordingly. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the channel/trace. 

2. Press Scale > Reference Tracking. 

3. When you want to specify a measurement value at a frequency as 
the Y-axis reference value for tracking, press Track Frequency, then 
enter the frequency. 

4. Press Tracking to select a tracking method. 

5. PTrk (Track Peak) or FTrk (Frequency) is displayed at the trace 
status area. 
  

 This function is available even when the limit test 
function is off. 

Adding Offset to Limit Line 

By adding a certain offset to the limit value, you can adjust the limit line so 
that it conforms to the device output. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the channel/trace on which the limit test function is used. 

2. Press Analysis > Limit Test to display the softkeys for the limit test. 



Measurement 

249 

3. Click Limit Line Offsets to display the limit line offset function 
menu. 

Stimulus offset 

 
  

Amplitude offset 
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Initializing the Limit Table 

The following operations initialize the limit table. 

 At power-on 

 When presetting 

 When calling a limit table with zero segments 

 When Clear Limit Table > OK is pressed in the Edit Limit Line menu 
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Using Bandwidth Test 

 Overview 

 Displaying Bandwidth Test Results 

 Bandwidth Test Setup 

 Turning Bandwidth Test and Displaying Results ON/OFF 

Other topics about Data Analysis 

Overview 

The bandwidth test function can be used to test bandwidth for the band-
pass filters. 

The bandwidth test find the peak of a signal in the passband and locates a 
point on each side of the passband at an amplitude below the peak 
specified in test setup. The frequency between these two points is the 
bandwidth of the filter. Then the obtained bandwidth is compared to 
minimum and maximum allowable bandwidth that you specify beforehand. 

 
  
  

Displaying Bandwidth Test Results 
Test Result for Trace 

The test result of the trace is indicated in the upper-right section of the 
graph for each trace, following BWn:. "n" denotes the trace number. The 
results are shown as Pass, Wide, Narrow, or >Span (Fail). You can also 
choose to display the bandwidth value. 
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For information on how to display the results, see Turning On/Off 
Bandwidth Test and Displaying Results. 

 
Test Results for Channel 

If any channel is unsatisfactory, a message is displayed as shown in 
Judgment result of channels. (It is judged as failed if one or more failed 
traces are found for the limit test, ripple test, or bandwidth test within the 
channel.) 

You can also specify this ON/OFF setting from the Fail Sign, which is 
provided in the limit test menu and ripple test menu. From the bandwidth 
test menu, follow the steps below to turn it ON/OFF. 

1. Press Analysis key. 

2. Click Bandwidth Limit. 

3. Click Fail Sign. This menu toggles between ON and OFF. 

In addition to the screen, the following features also let you confirm the 
test results: 

 Beep notifying that the result is unsatisfactory 

 Status register 

Bandwidth Test Setup 
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You must set up the bandwidth threshold and the upper and lower limits 
before you can use the bandwidth test function. You can specify the 
threshold, upper limit, and lower limit for each trace. 

Follow the steps below to set up the bandwidth test. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace for which you want to apply the bandwidth test 
function. 

2. Press Analysis key to display the Analysis menu. 

3. Click Bandwidth Limit > N dB Points to specify the bandwidth 
threshold. The unit is dB. 

4. Press Min Bandwidth to enter the lower limit for the bandwidth. 
Similarly, press Max Bandwidth to enter the upper limit for the 
bandwidth. The unit is Hz for both Min and Max bandwidths. 

 If the data format is Smith chart or polar, the limit 
test is performed for the main response value among the two 
marker response values. 

Turning Bandwidth Test and Displaying Results ON/OFF 

You can configure the ON/OFF setting of the bandwidth test function for 
each trace independently. 

Follow the steps below to configure the ON/OFF setting of the bandwidth 
test. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to activate the trace of which you want to apply the bandwidth test 
function. 

2. Press Analysis key to display the Analysis menu. 

3. Click Bandwidth Limit > BW Test  to turn ON the bandwidth test. 

4. Click BW Marker to turn ON so that the bandwidth marker is 
displayed on the screen. 

5. Click BW Display to turn ON so that the bandwidth value is displayed. 
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Using Ripple Test 

 Overview 

 Concept of Ripple Test 

 Displaying Ripple Test Results 

 Configuring Ripple Limit 

 Saving/Recalling Ripple Limit Table 

 Turning ON/OFF Ripple Test and Result Display 

 Initializing Limit Table 

Other topics about Data Analysis 

Overview 

Independent of the limit test, you can evaluate the measurement results 
on a pass/fail basis by setting a limit for the ripple. This function is called 
the ripple test. 

Concept of Ripple Test 

The ripple test is a function for evaluating the results on a pass/fail basis 
based on the ripple limit, which is set using the ripple limit table. You can 
specify up to 12 frequency bands, which permits a test for each frequency 
band. 

The ripple test judges the measurement as "Pass" when the ripple value 
specified with the ripple limit does not exceed any of the measurement 
points on the trace; otherwise, it judges the measurement as "Fail." For 
the measurement points in a stimulus range without a specified ripple 
limit, the test judges the measurement as "Pass." 

 The measurement point alone is the target of 
evaluation for pass/fail. The interpolated part between 
measurement points is not evaluated. 

The ripple limit is defined with the start point stimulus value, end point 
stimulus value, ripple limit value, and type (ON/OFF). For detailed 
information, see Configuring ripple limit. 

While the ripple test function is turned ON, the measurement points 
corresponding to a "fail" judgment is indicated in red on the screen, and 
the trace's test results based on the results of each measurement point is 
displayed (judged as "fail" if one or more red measurement point exist on 
the trace). For information on how to display the results, see Turning 
ON/OFF ripple test and displaying results. You can also confirm the channel 
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test results on the screen (judged as "fail" if one or more failed traces 
appear in the limit test, ripple test, or bandwidth test within the channel). 
  

Displaying Ripple Test Results 
Measurement point and test results 

Failed measurement points is displayed in red on the screen. The test 
result for the trace is indicated as Pass or Fail in the upper-right section of 
the graph. You can also display the ripple value at the selected frequency 
band. 

The result is displayed as Ripln:Pass (or Fail) for each trace. n denotes the 
trace number. Bn is followed by the ripple value (if the ripple display is 
turned OFF, only Bn is displayed without the ripple value). 

For example, in the following figure, Ripl1:Pass in the first line indicates 
the result for trace 1. The value following B3 is the ripple value at the third 
frequency band specified in the ripple test. Similarly, the second line 
indicates the test result for trace 2, showing the ripple value at the first 
frequency band. 

For information on how to display the results, see Turning ON/OFF ripple 
test and displaying results. 

 
Test result for channel 
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If a channel has a judgment result of "fail", the message is displayed as 
shown in Test Result for Trace. (It is judged as failed if one or more failed 
traces are found in the limit test, ripple test, or bandwidth test within the 
channel.) 

 
You can also specify the ON/OFF setting for the Fail Sign in the limit test 
menu and as well as in the bandwidth test menu. From the ripple test 
menu, follow the steps below to turn it ON/OFF. 

1. Press Analysis > Ripple Limit. 

2. Click Fail Sign. This menu toggles between ON and OFF. 

In addition to the screen, the following features also let you confirm the 
test results: 

  Beep notifying that the result is "fail" 

 Status register 

Configuring Ripple Limit 

You must configure the ripple limit before you can use the ripple test 
function. You can specify a ripple limit table for each trace, where up to 12 
ripple limit bands (frequency bands) can be configured. 

Operational procedure 

Follow the steps below to configure the ripple limits. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace on which you want to apply the ripple test 
function. 

2. Press Analysis > Ripple Limit. 
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3. Click Edit Ripple Limit to display the ripple limit table shown below. 
 

 
4. Click Add to add a frequency band to the ripple limit table and then 

specify the parameters for the frequency band. Note that no 
frequency band is provided in the ripple limit table by default. 
Click Delete to delete the selected frequency band and Clear Ripple 
Limit Table to clear the table setting. 

 Acceptable range for the stimulus value: -500G to 
+500G. If any outranging value is specified, it is reset to fall 
within the range. 

 Even if the E5061B's sweep range is changed after 
the stimulus value has been set, the stimulus value is not 
susceptible. 

  Example of ripple limit configuration 
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 The individual frequency bands for the ripple test can overlap 
each other; in this case, the ripple limit test is performed for each 
frequency band. 

 Even if the E5061B's span value is set to zero, you must enter a 
parameter for both Begin Stimulus and End Stimulus. 

 If the data format is Smith chart or polar, the limit test is 
performed for the main response value among the two marker response 
values. 

Saving/Recalling Ripple Limit Table 

The ripple limit table can be saved in a file and recalled later for use on the 
screen. The file is saved in the csv format (with the extension *.csv), and 
values are saved as a character string with the unit. The csv formatted file 
can also be reused in spreadsheet software made for PCs. 

Follow the steps below to save/recall the ripple limit table. This operation 
should be done by using the external keyboard and/or mouse. 

1. Display the ripple limit table. 

2. Click Export to CSV File from the Edit Ripple Limit menu to open the 
dialog box. At this time, CSV file (with the extension *.csv) is 
selected as the file type. 

3. Specify any folder in which you want to save the file, and enter the 
file name. Click Save to save the ripple limit table displayed on the 
screen to a file. 

4. To recall the saved ripple limit table, click Import from CSV File from 
the Edit RippleLimit menu to display the Open dialog box. At this 
time, CSV file (with the extension *.csv) is selected as the file type. 

5. Specify the folder that contains the file, and then select the file. Click 
Open to recall the saved limit table on the screen. 

 You can recall a limit table from a trace on any 
channel independently of the channel and trace that are active 
when the limit table is saved to the file. 

The ripple limit table is saved in the following format: 

 In the first line, the channel number for the active channel at the 
time of file saving will be output. 

 In the second line, the trace number for the active trace at the time 
of file saving will be output. 

 The third line is a header indicating the segment items that are 
output from the fourth line onwards. 

 From the fourth line onwards, the segment data are output. 
Operational procedure 
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"# Channel 1" 

"# Trace 1" 

Type, Begin Stimulus, End Stimulus, MaxRipple 

ON, 933.0000000 MHz, 964.0000000 MHz, 1.5 dB 

ON, 938.0000000 MHz, 953.0000000 MHz, 500 mdB 

ON, 953.0000000 MHz, 960.0000000 MHz, 300 mdB 

Turning ON/OFF Ripple Test and Result Display 

You can set the limit test ON/OFF for each trace individually. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace Prev) 
to select the trace on which you want to apply the ripple test 
function. 

2. Press Analysis > Ripple Limit. 

3. Press Ripple Limit Test to set the ripple test ON. 

4. Press Ripple Limit to display the ripple limit line. 

5. Press Ripple Value to shows how the ripple values are displayed, then 
select Absolute (difference between maximum and minimum values 
within the band), Margin (difference between absolute value of ripple 
and ripple limit), or OFF. 

6. Press Ripple Value Band to select the band for which you want to 
display the ripple value. 

Initializing Limit Table 

The following operations initialize the limit table. 

 At power-on 

 When presetting 

 When calling a Ripple table with zero segments 

 When Clear Ripple Limit Table > OK is clicked in the Edit Ripple Limit 
menu 
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Using Equation Editor 

 Overview 

 Using Equation Editor 

 Equation Editor Examples 

 Equation History 

 Functions and Constants 

 Converting S Parameters to H, Y, Z, F & T Parameters 

 Operators used in Equation Editor 

Other topics about Data Analysis 

Overview 

Equation Editor allows you to enter an algebraic equation of standard 
mathematical operators and functions, referencing data that is available in 
the E5061B. Once a valid equation is entered and enabled, the display of 
the active trace is replaced with the results of the equation, and updated in 
real-time as new data is acquired.  For equations that can be expressed 
with Equation Editor's supported functions, operators, and data, there is no 
need for off-line processing in a separate program. 

For example, on entering the equation "Example=S21/(1-S11)" in the 
E5061B Equation Editor (4 in the Figure below), the resulting trace is 
computed as each S21 data point divided by one minus the corresponding 
S11 data point. For a 201 point sweep setup, the computation is repeated 
201 times, once for each point. 

Using Equation Editor 

The step-by-step procedure of using Equation Editor is described below: 
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 The parameter of  Z is available in Ch Param Data 

when option 005 is installed. 

Equation Editor Dialog box 

1. Select a trace in which you want to enter the equation and activate 
the trace. 

 Activating a trace is required as Equation Editor 
works on traces. 

2. Follow the steps below to enter an equation: 

1. Press Display. 

2. Click Equation Editor (1 in the figure above). The Equation 
Editor dialog box appears. 

3. Enter an equation in the equation field (4 in the figure above). 

 Referring to traces in a different channel is NOT 
available with Equation Editor on the ENA. 

 The equation can be entered with the software 
keyboard enabled by selecting Keyboard... (3 and 3a in the 
figure above). 
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3. Follow the steps below to apply the defined equation. When a valid 
equation is entered, the Equation Enabled check box becomes 
available for checking. 

1. Check Equation Enabled check box (2a in the figure above). 

2. Click Apply. The equation becomes visible and annotation of 
[Equ] (2b in the figure above) is displayed in the trace title 
area. 

3. Click Close to hide the dialog box. 

 The equation can also be applied by selecting Display 
> Equation ON. 

 If error correction is not turned ON, then the raw, 
uncorrected data is used in the equation trace. 

 If an equation is NOT valid (i.e. referring to a trace 
that is not measured in the measured channel), annotation of 
[Equ!] is displayed in the trace title area instead. 

Equation Editor Examples 

The following examples may help you in getting started with Equation 
Editor. Input the equation example in the equation field (4 in Equation 
Editor dialog box).0 

Description Equation Example 

Offset each data point in trace 2 
from trace 1 by XdB 

Offset= data(1)*pow(10,X/20) 

Multiplying by X-times in log 
format 

XTimes= pow(data,X) 

Differential Return Loss Sdd11= (S11-S21-S12+S22)/2) 

CMRR of a Balanced Component CMRR =  data(2) / data (1) 

Equation History 

Equation Editor has the capability to save and recall all previously defined 
equations. All equations can be viewed in the Equation History dialog box. 

To view the equations in the list, follow this procedure: 

1. Open Equation Editor by Display > Equation Editor 

2. Enter an equation and click Apply in the Equation Editor dialog box 
to save the defined equation in the directory of the E5061B. To view 
a list of saved equations, click the ... button (5 in Equation Editor 
Dialog box) to  open the Equation History dialog box. 
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 To store an equation in the History List, the equation 
must be applied first. This can be done by clicking on the Apply 
button. 

3. To edit the equations in the list, click Edit History. The text file of 
history list is opened with Notepad. 
 

 
  

 The History List is stored as a text file 
D:\Agilent\Equation\history.txt and can save a maximum of 50 
lines (equations) with a maximum of 254 character per line 
(equation). 

Functions and Constants 

The following table describes the different functions and constant available 
in the E5061B Equation Editor. In the following table: 

 Function(scalar x) means that the function requires a scalar value. If 
a complex value is entered, it is automatically converted to a scalar 
value; complex(x,y) -> scalar(x) 



E5061B 

264 

 Function(complex x) means that the function requires a complex 
value. If a scalar value is entered, it is automatically converted to a 
complex value; scalar(x) -> complex(x, 0) 

 a,b are arguments that are used in the function. 

Basic Math Functions 

Function Description 

abs(complex a) returns the sqrt(a.re2+a.im2) 

acos(scalar a) returns the arc cosine of a in radians 

asin(scalar a) returns the arc sine of a in radians 

atan(scalar a) returns the arc tangent of a in radians 

atan2(complex a) returns the phase of a = (re, im) in radians 

atan2(scalar a, 
scalar b) 

returns the phase of (a, b) in radians 

conj(complex a) returns the conjugate of a 

cos(complex a) takes a in radians and returns the cosine 

cpx(scalar a, scalar 
b) 

returns a complex value (a+ib) from two scalar 
values 

exp(complex a) returns the exponential of a 

im(complex a) returns the imaginary part of a as the scalar part 
of the result (zeroes the imaginary part) 

ln(complex a) returns the natural logarithm of a 

log10(complex a) returns the base 10 logarithm of a 

mag(complex a) returns sqrt(a.re2+a.im2) 

phase(complex a) returns atan2(a) in degrees 

pow(complex 
a,complex b) 

returns a to the power b 

re(complex a) returns the scalar part of a (zeroes the imaginary 
part) 
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sin(complex a) takes a in radians and returns the sine 

sqrt(complex a) returns the square root of a, with phase angle in 
the half-open interval (-π/2, π/2) 

tan(complex a) takes a in radians and returns the tangent 

Constants 

e 2.71828182845904523536 

PI 3.14159265358979323846 

 
 

 Mutual transformation is automatically made for 
scalar and complex. 
 
scalar(x) -> complex(x, 0) 
complex(x, y) -> scalar(x) 

Advanced Math Functions 

In the following table: a,b,c,d are arguments of complex value that are 
used in the function. For 2-port network measurement: a,b,c,d correspond 
to Sii,Sji, Sij, Sjj respectively. 

 The functions can also be defined by scalar 
arguments with port numbers of the E5061B. For example, the 
function, kfac(1,2) returns the K-factor of 2-port measurement 
between port 1 and port 2. 

Z0 refers ti the system characteristic impedance which can be accessed 
under Cal. 

  

Function Description 

A(complex a, complex b, 
complex c, complex d) 

F11 conversion = ((1+a)×(1-d) + 
b×c)/(2×b) 

A(scalar i, scalar j) returns A(Sii, Sji, Sij, Sjj) 

B(complex a, complex b, 
complex c, complex d) 

F12 conversion = Z0 × ((1+a)×(1+d) - 
b×c)/(2×b) 

B(scalar i, scalar j) returns B(Sii, Sji, Sij, Sjj) 
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C(complex a, complex b, 
complex c, complex d) 

F21 conversion = (1/Z0)×((1-a)×(1-d) - 
b×c)/(2×b) 

C(scalar i, scalar j) returns C(Sii, Sji, Sij, Sjj) 

D(complex a, complex b, 
complex c, complex d) 

F22 conversion = ((1-a)×(1+d) + 
b×c)/(2×b) 

D(scalar i, scalar j) returns D(Sii, Sji, Sij, Sjj) 

H11(complex a, complex b, 
complex c, complex d) 

H11 conversion = Z0×((1+a)×(1+d) - 
b×c)/((1-a)×(1+d) + b*c) 

H11(scalar i, scalar j) returns H11(Sii, Sji, Sij, Sjj) 

H12(complex a, complex b, 
complex c, complex d) 

H12 conversion = 2×c/((1-a)×(1+d) + b×c) 

H12(scalar i, scalar j) returns H12(Sii, Sji, Sij, Sjj) 

H21(complex a, complex b, 
complex c, complex d) 

H21 conversion = -2×b/((1-a)×(1+d) + b×c) 

H21(scalar i, scalar j) returns H21(Sii, Sji, Sij, Sjj) 

H22(complex a, complex b, 
complex c, complex d) 

H22 conversion = (1/Z0)×((1-a)×(1-d) - 
b×c)/((1-a)×(1+d) + b×c) 

H22(scalar i, scalar j) returns H22(Sii, Sji, Sij, Sjj) 

kfac(complex a, complex b, 
complex c, complex d) 

k-factor = (1 - abs(a)2 - abs(d)2 + (abs(a×d 
- b×c)2)/(2×abs(b×c)) 

kfac(scalar i, scalar j) returns kfac(Sii, Sji, Sij, Sjj) 

MAPG(complex a, complex 
b, complex c, complex d) 

maximum available power gain = 
abs(b/c)×(kfac(a,b,c,d) - sqrt(kfac(a,b,c,d)2 
- 1)) 

MAPG(scalar i, scalar j) returns MAPG(Sii, Sji, Sij, Sjj) 

MSG(complex a, complex 
b, complex c, complex d) 

maximum stable power gain = 
abs(b)/abs(c) 
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MSG(scalar i, scalar j) returns MSG(Sii, Sji, Sij, Sjj) 

mu1(complex a, complex b, 
complex c, complex d) 

µ-factor = (1 - abs(a)2) / (abs(d - conj(a) × 
(a×d-b×c)) + abs(b×c)) 

mu1(scalar i, scalar j) returns mu1(Sii, Sji, Sij, Sjj) 

mu2(complex a, complex b, 
complex c, complex d) 

µ-factor = (1 - abs(d)2) / (abs(a - conj(d) × 
(a×d-b×c)) + abs(b×c)) 

mu2(scalar i, scalar j) returns mu2(Sii, Sji, Sij, Sjj) 

T11(complex a, complex b, 
complex c, complex d) 

T11 conversion = -(a×d - b×c)/b 

T11(scalar i, scalar j) returns T11(Sii, Sji, Sij, Sjj) 

T12(complex a, complex b, 
complex c, complex d) 

T12 conversion = a/b 

T12(scalar i, scalar j) returns T12(Sii, Sji, Sij, Sjj) 

T21(complex a, complex b, 
complex c, complex d) 

T21 conversion = -d/b 

T21(scalar i, scalar j) returns T21(Sii, Sji, Sij, Sjj) 

T22(complex a, complex b, 
complex c, complex d) 

T22 conversion = 1/b 

T22(scalar i, scalar j) returns T22(Sii, Sji, Sij, Sjj) 

Y11(complex a, complex b, 
complex c, complex d) 

Y11 conversion = (1/Z0)×((1-a)×(1+d) + 
b×c)/((1+a)×(1+d) - b×c) 

Y11(scalar i, scalar j) returns Y11(Sii, Sji, Sij, Sjj) 

Y12(complex a, complex b, 
complex c, complex d) 

Y12 conversion = (1/Z0)×(-
2×c)/((1+a)×(1+d) - b×c) 

Y12(scalar i, scalar j) returns Y12(Sii, Sji, Sij, Sjj) 

Y21(complex a, complex b, Y21 conversion = (1/Z0)×(-
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complex c, complex d) 2×b)/((1+a)×(1+d) - b×c) 

Y21(scalar i, scalar j) returns Y21(Sii, Sji, Sij, Sjj) 

Y22(complex a, complex b, 
complex c, complex d) 

Y22 conversion = (1/Z00)×((1+a)×(1-d) + 
b×c)/((1+a)×(1+d) - b×c) 

Y22(scalar i, scalar j) returns Y22(Sii, Sji, Sij, Sjj) 

Z11(complex a, complex b, 
complex c, complex d) 

Z11 conversion = Z0×((1+a)×(1-d) + 
b×c)/((1-a)×(1-d) - b×c) 

Z11(scalar i, scalar j) returns Z11(Sii, Sji, Sij, Sjj) 

Z12(complex a, complex b, 
complex c, complex d) 

Z12 conversion = Z0×(2×c)/((1-a)×(1-d) - 
b×c) 

Z12(scalar i, scalar j) returns Z12(Sii, Sji, Sij, Sjj) 

Z21(complex a, complex b, 
complex c, complex d) 

Z21 conversion = Z0×(2×b)/((1-a)×(1-d) - 
b×c) 

Z21(scalar i, scalar j) returns Z21(Sii, Sji, Sij, Sjj) 

Z22(complex a, complex b, 
complex c, complex d) 

Z22 conversion = Z0×((1-a)×(1+d) + 
b×c)/((1-a)×(1-d) - b*c) 

Z22(scalar i, scalar j) returns Z22(Sii, Sji, Sij, Sjj) 

 For both mu1 and mu2, conj is the complex 
conjugate. For scalars a and b, conj(a+ib)=(a-ib). 

Channel Parameter Data 

data corrected data 

data(scalar i) corrected data of trace i (trace number) 

mem memory data 

mem(scalar i) memory data of trace i (trace number) 

xAxis x-axis data 

xAxis(scalar i) x-axis data of trace i (trace number) 
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S11 - S22 S-parameter data 

 When a trace number is out of range, the E5061B 
indicates an error message, “Equation runtime error” and 
equation is not reflected on the trace. The maximum number of 
traces can be set by System > Misc Setup > Channel/Trace 
Setup. 

Converting S-Parameters to H, Y, Z, F & T-Parameters 

The following section provides definition of the two port parameters in 
Equation Editor. 

1. Hybrid parameters (H) 
 

 
  

2. Admittance parameters (Y) 
 

 
  

3. Impedance parameters (Z) 
 

 
  

Fundamental parameters (F) 
 

 
  

4.    
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5. Scattering transfer parameters (T) 
 

 
  

S-parameters of 2-port network can be converted to Hybrid parameters 
(H), Admittance parameters (Y), Impedance parameters (Z), Fundamental 
parameters (F) and Scattering transfer parameters (T) using the following 
functions: 

1. Converting S-parameters to H-parameters 
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2. Converting S-parameters to Y-parameters 
 

 
  

3. Converting S-parameters to Z-parameters 
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4. Converting S-parameters to F-parameters 
 

 
  

5. Converting S-parameters to T-parameters 
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Where: 
 
Ds=S11S22 - S12S21 
  

Operators used in Equation Editor 

Operator Description 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

^ Power 

( Open parenthesis 

) Close parenthesis 

, Comma - separator for arguments 

= Equal (optional) 

E Exponent (as in 23.45E6) 
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 Priority of operators is:  
 
1. ^   
2. *, / 
3. +, - 
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Outputting Data 

Outputting Data 

 Saving and Recalling Instrument State 

 Saving/Recalling Instrument State for Each Channel into/from 
Memory 

 Compatibility of State File 

 Saving Trace Data to a File 

 Saving the Screen Image to a File 

 Printing Displayed Screen 
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Saving and Recalling Instrument State 

 Overview 

 Saving Data 

 Recall Procedure 

 Recall Procedure Using "Recall by File Name" 

 Priority of Recalling Configuration File at Startup 

Other topics about Data Output 

Overview 

You can save the instrument state of the E5061B into a file on mass 
storage and then recall it later to reproduce that state. You can select the 
stored data from the following four types. 

Type Stored data and usage 

State only 
(State 
Only) 

Saves the setting of the E5061B and reproduces the state 
when it is saved by recalling it later into the E5061B. 

State and 
calibration 
data 
(State & 
Cal) 

Saves the setting of the E5061B and calibration data 
(calibration coefficient array) to reproduce the state when 
it was saved by recalling it later into the E5061B. At this 
time, you can perform error correction of measured 
values by using the recalled calibration data. 

State and 
trace 
(State & 
Trace) 

Saves the setting of the E5061B and traces (error-
corrected data array  and error-corrected memory array) 
to reproduce the state when it was saved by recalling it 
later into the E5061B. At this time, the traces are also 
recalled and displayed on the screen. 

State, 
calibration 
data, and 
traces 
(All) 

Saves the setting of the E5061B, calibration data, and 
traces to reproduce the state when it was saved by 
recalling it later into the E5061B. At this time, the 
calibration data and traces are also recalled. 

In addition, the user-preset function is provided to allow the user to freely 
set up an instrument state recalled when the preset function is executed. 

Saving Data 
Selecting Content to be Saved 
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  This setting takes effect both, when saving the 
entire instrument state into a file and when saving the 
instrument state for each channel into memory. 

1. Press Save/Recall > Save Type. 

2. Click the softkey corresponding to the content of the instrument 
state you want to save. 

Selecting Save Target Channel/Trace 

1. Press Save/Recall key. 

2. Click Channel/Trace and select the save target from all 
channels/traces (All) or displayed channel/traces only (Disp Only). 

If you specify the displayed channel/traces only as the save target, you 
can reduce the file size. However, for channels/traces that are not 
displayed, you cannot recall and reproduce the instrument state separately 
held for each channel/trace at a later time. 

Saving Instrument State 

Follow the procedure below to save internal data from the E5061B. 

1. Press Save/Recall > Save State. 

2. Click the softkey corresponding to the destination you want to save. 
  

Softkey Description 

State01 to 
 State08 

Save the instrument state into the state number. 

Autorec Save the instrument state as the auto recall setting. The 
E5061B is automatically configured with this state at the 
startup. 
  

This key saves the state into the "D:Autorec.sta". 

When Autorec.sta file is found on the D: drive at startup, 
the E5061B is automatically configured using the saved 
settings. To disable the auto recall function, delete the 
Autorec.sta files. 

User Pres Save the instrument state as user preset. The user can 
preset the analyzer at user saved status. 

File 
Dialog... 

Save the instrument state as your desired file name. You 
can enter a file name using the Input from the front panel 
buttons on the dialog box when storing a file. 
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  If D:\Autorec.sta is found on the system at startup, 
the E5061B is automatically configured using the saved 
settings. When the external floppy disk drive is connected as A: 
drive, then if A:\Autorec.sta is found at startup, the E5061B is 
also automatically configured using the saved settings. If both 
files are found, A:\Autorec.sta is recalled. To disable the auto 
recall function, delete the Autorec.sta files. 

 An asterisk (*) in the upper right of the softkey 
indicates that the corresponding file of the softkey already 
exists. If you save into the existing file, the existing file is 
copied as backup.sta and then overwritten. 

Recall Procedure 

Follow the procedure below to recall internal data from the E5061B. 

  If you recall a file that includes traces (its content 
was set to State &Trace or All when it was saved), the trigger 
source is automatically set to Manual. 

1. Press Save/Recall > Recall State. 
When you want to recall State01.sta - State08.sta, Autorec.sta 

1. Press State01 - State08 or Autorec. 
When you want to recall other files 

1. Press File Dialog... to open the Open dialog box. 

2. Select the folder and the file using the external keyboard and mouse. 

3. Click Open. 

The warning messages may appear when recall fails: 

 When a user file is used in Extending the Calibration 
Plane Using Network De-embedding, Determining 
Characteristics After Adding a Matching Circuit, or Determining 
the Characteristics that Result from Adding a Matching Circuit to 
a Differential Port and the setup status is saved, a recall error 
occurs if the user file is not located in the same folder as when 
the state is saved. 

 Pressing Save/Recall > Explorer executes Windows 
Explorer. This helps you to browse the files in the ENA hard disk 
drive. 

Recall Procedure Using "Recall by File Name" Feature 

You can use the recall feature with the Recall by File Name softkey for files 
you have named freely and save in the D:\State folder. This function lets 
you recall a file you have named freely and save by simple softkey 
operation, eliminating annoying operation using the Open dialog box. 
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 Although there is no limit to the number of files 
saved in a folder, only up to 50 files are displayed on the 
softkeys. If more than 50 files are saved in a folder, they are 
sorted in the order of numbers 0 to 9 and alphabetic characters 
A to Z and the first 50 files are displayed as softkeys. 
 
Although there is no limit to the number of characters of a file 
name, only up to 12 characters are displayed on the softkey. If 
a file name exceeds 12 characters, the first 12 characters are 
displayed on the softkey and the remaining characters are 
omitted and replaced with "...". 
  

 Different files may be displayed on softkeys with the 
same name or a saved file is not displayed on any softkey 
because of the above limitations. 

1. Press Save/Recall > Recall by File Name. 

2.  Files that have been named and saved in the D:\State folder are 
displayed on softkeys. Press the key for the file you want to recall. 

Priority of Recalling Configuration File at Startup 

If several instrument configuration files exist at the startup of the E5061B, 
only one file is recalled and set at a time in the following order of priority. 

If these files do not exist, the normal preset (factory preset) is executed. 

Priority Recalled file 

1 Configuration file for the auto-recall function in the A drive 
(If external floppy disk drive is connected.) 

2 Configuration file for the auto-recall function in the D drive 

3 Configuration file for the user-preset function in the D drive. 
Executed when the preset operation mode is User and the 
file (D:\UserPreset.sta) exists. 
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Saving/Recalling Instrument State for Each Channel into/from 
Memory 

 Overview 

 Saving Instrument State for Each Channel 

 Recalling Instrument State for Each Channel 

 Deleting Saved Instrument State (Clearing all Registers) 

Other topics about Data Output 

Overview 

The E5061B allows you to save/recall the instrument state for each 
channel independently. This function allows you to save the instrument 
state of the active channel independently into one of the four registers (A 
to D, volatile memory) and to recall the instrument state from the register 
to restore it as the state of the currently active channel. As in the case of 
saving the entire state of the instrument into a file, you can select items to 
be saved from four kinds. 

Since you can recall the instrument state for each channel that was saved 
with this function from a different channel that the one used to save it, this 
function is very useful for copying an instrument state between channels. 

 Unlike when saving the entire instrument state, the 
instrument state for each channel is saved into volatile memory 
instead of a file, so if you turn off the power, this state is lost. 

Saving Instrument State for Each Channel 

1. Press Channel Next (or Channel Prev) to activate a channel of which 
the state you want to save. 

2. Press Save/Recall > Save Channel. 

3. Click one of State & Cal A to D, Cal Only A to D to save the 
(instrument state and) calibration data of the active channel to the 
specified register. 

 For registers having saved data, the * symbol is 
displayed to the right of their softkey label. If you specify one of 
these, its content is overwritten. 

Recalling Instrument State for Each Channel 

1. Press Channel Next (or Channel Prev) to activate a channel of which 
the state you want to recall and restore. 

2. Press Save/Recall > Recall Channel. 
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3. Click the softkey of the register in which the state you want to 
restore is saved. This instrument state is recalled to the active 
channel. 

Deleting Saved Instrument State (Clearing all Registers) 

1. Press Save/Recall > Save Channel. 

2. Click Clear States. The contents of all the registers are deleted. 
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Compatibility of State File 

 Overview 

 Compatibility of Files (Saving and Recalling) 

 State File Converter 

Other topics about Data Output 

Overview 

As mentioned in Saving and Recalling Instrument State, you can save the 
instrument state of the E5061B into a file on the mass storage and then 
recall it later to reproduce that state.  

Alternatively, you can use the state file saved in E5061A and E5062A in a 
similar way.  

Compatibility of Files (Saving and Recalling) 
Compatibility from  E5061A/E5062A and other ENA series products 

State files from E5061A/E5062A can be converted to E5061B compatible 
state file. This can be performed by using the State File Converter 
Software. However, there is no compatibility of state files between E5061B 
and other ENA series products. 

Files saved with the E5061A, E5062A and the other ENA series products 
cannot be recalled with the E5061B. Similarly, files saved with the E5061B 
cannot be recalled with the E5061A and E5062A. 

 Compatibility between  different options 

 The files saved with the E5061B without Time domain/Fault Location 
option can be recalled in the E5061B with Time domain/Fault 
Location option. The files saved with the E5061B with Time 
domain/Fault Location option can be recalled with the E5061B 
without Time domain/Fault Location option. The settings for Fault 
Location/Gating/SRL are not used. 

 The files saved with the E5061B without Impedance Measurement 
option can be recalled in the E5061B with Impedance Measurement 
option. The files saved with the E5061B with Impedance 
Measurement option can be recalled with the E5061B without 
Impedance Measurement option.  

Compatibility between different frequency models 
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Save
d file 

by 
E506
1B 

No 5 5 5 5 7 7 7 7 

3L
5 

Y N N N N N N N N 

23
5 

Y Y N N N N N N N 

21
5 

Y Y Y N N N N N N 

13
5 

Y Y N Y N N N N N 

11
5 

Y Y Y Y Y N N N N 

23
7 

N N N N N Y N N N 

21
7 

N N N N N Y Y N N 

13
7 

N N N N N Y N Y N 

11
7 

N N N N N Y Y Y Y 

Y: Recall is possible, N: Recall is not possible. 
Compatibility when the Firmware revision is different 

 Files that are saved with later firmware revisions may not be recalled 
by prior firmware revisions. 

Compatibility when the system spec. version (available with ":SERV:SREV?") is different 

 When files that are saved with different system spec. versions 
include calibration data, only states and trace data are recalled. 

 If you recall an incompatible file, an error occurs and 
the device recovers to the default setting. 

State File Converter 

The State File Converter software converts the state files from 
E5061A/E5062A to E5061B compatible state file. 

Most state file settings from E5061A/E5062A can be converted to be used 
in E5061B except: 
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 User calibration data 

User calibration data cannot be converted by the State File Converter. 
Even if the E5061A/62A state file has calibration data, the calibration 
data is ignored and is not converted.  

 Multiport test set settings 

Multiport test set settings are not converted. This is because unlike 
E5061A/62A, the E5061B does not support multiport test sets. Hence, 
the below settings are not converted: 

        : SENSe [1-4]: CORRection: MULTiport: COLLect: METHod 

        : SENSe [1-4]: CORRection: MULTiport: SELF [: STATe] 

        : SENSe [1-4]: CORRection: MULTiport: SELF: TIMer 

        : SENSe [1-4]: CORRection: MULTiport [: STATe] 

        : SENSe [1-4]: MULTiport: PORT [1-2]: SELect 

        : SENSe [1-4]: MULTiport: PROPerty 

        : SENSe [1-4]: MULTiport [: STATe] 
Executing State File Converter (UI) 

The State File Converter is located in the E5061B at 
D:\Agilent\E5061A_StateFileConverter.vba. This vba software is a sort of 
user interface and  it calls the main program named 
"StateFileConverter.exe" shown below. 
 
To execute this converter file: 

1. Press Macro Setup button. 

2. Click Load Project... from the Macro Setup menu. 

3. Select D:\Agilent\E5061A_StateFileConverter.vba file and click Open. 

4. Click Select Macro from the Macro Setup menu and select Module1 main 

option.  

5. The E5061A/62A State File Converter shows. 
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6. At Input file name (E5061A/62A state file), select the state file from 

E5061A or E5062A that you want to convert. 

7. At Output file name (E5061B state file), enter the name of the new state 

file or select an existing state file to be overwritten. 

8. Once both input and output file names are selected, the Convert button 

is activated. 

9. Click Convert to execute the conversion.  

10. Once the conversion process is completed, the Recall output file 

button is activated. 

11. Click Recall output file to recall the output file. This is a shortcut 

method to recall the output file instead of Save/Recall > Recall State > 

File Dialog. 

Executing State File Converter (.exe) 

The executable file of the State File Converter is located in the E5061B at 
C:\Program 
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Files\Agilent\E5061B\StateFileConverter\StateFileConverter.exe. To 
execute this converter file using command prompt: 

1. Go to Command Prompt. 

2. Go to C:\Program Files\Agilent\E5061B\StateFileConverter location. 

3. Type StateFileConverter.exe -i:<input.sta> -o:<output.sta>. 

Mandatory Option 

-I:<input file path> (E5061/62A state file) 

-O:<output file path> (E5061B state file) 

No space after the colon 

Return code 

0: no error 

1: no error (cal data discarded) 

10: read file error 

20: write file error 

 StateFileConverter.exe should be executed from the 
original directory as it calls for other files to run successfully. 

You can create the batch file as shown below. 

Convert.bat 

@echo off 

if not exist E5061B mkdir E5061B 

for %%i in (*.sta) do ( 

echo Converting %%~fi  

"C:\Program Files\Agilent\E5061B\StateFileConverter\StateFileConverter.exe" -i:"%%~fi" -
o:"%~dp0E5061B\%%~nxi" 

if errorlevel 20 ( 

echo     Write File Error 

) else if errorlevel 10 ( 

echo     Read File Error 

) else if errorlevel 1 ( 
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echo     Convert Success without Cal Data 

) else if errorlevel 0 ( 

echo     Convert Success 

) 

)   

How to execute the batch file 

The batch file allows you to convert multiple state files at once.  

To execute the batch file: 

1. Place convert.bat and all the state files in the same folder. 

2. Go to Command Prompt. 

3. Go to the location where convert.bat and state files are stored. 

4. Type convert.bat. 

5. A sub-folder named E5061B is created automatically where all the 

converted state files are placed. 

State File Converter Messages 

Below are the messages that may prompt during state file conversion: 

 "Converting..." 

 "Conversion done" 

 "Conversion done (CAL data discarded)" 

Conversion is successfully completed and the original CAL data is 
deleted. 

 "Input file does not exist" 

 "Output file does not exist" 

 "Output file name is an existing folder" 

 "Input file error" 

The system cannot understand the file path as the folder or file name is 
in Asian characters (fonts), or the file is not a state file created by 
E5061A/62A.  

 "Output file error" 

The system cannot understand the file path as the folder or file name is 
in Asian characters (fonts). 

 "Input file name and output file name are the same" 
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Saving Trace Data to a File 

 Saving Data in CSV Format 

 Saving Data in Touchstone Format 

Other topics about Data Output 

Saving Data in CSV Format 

The E5061B allows the user to save data for the active trace on the active 
channel to a CSV file (file extension *.csv) and to load the data into PC 
application software for further processing. 

Trace data are saved in the format shown below. 
Example of saved trace data 

"# Channel 1" 

"# Trace 1" 

Frequency,                    Formatted Data,            Formatted Data 

+3.00000000000E+005, +1.41837599227E-002, +1.43446459328E-006 

+4.27985000000E+007, +1.41275293412E-002, +2.02407834551E-004 

+8.52970000000E+007, +1.41334093048E-002, +4.00643331604E-004 

+1.27795500000E+008, +1.41240661092E-002, +6.09250514670E-004 

+1.70294000000E+008, +1.41402155348E-002, +8.05620003993E-004 

The first line shows the number of the active channel at the time the data 
is saved. 

The second line shows the number of the active trace at the time the data 
is saved. 

The third line is a header line indicating the contents of each item of trace 
data written on the fourth line onward. 

The fourth line onward shows the trace data. The amount of data is 
determined by the number of points (frequency) assigned to the trace. 

Saving Trace Data 

Follow the procedure below to save trace data from the E5061B. 

1. Press Channel Next (or Channel Prev) and Trace Next (or Trace prev) 
to select the trace to be saved. 

2. Press Save/Recall > Save Trace Data to open the Save As dialog box. 

3. Select the destination folder and input a file name. 

4. Click Save to save the file. 

 This function is inactive when the security level is set 
at low/high. 
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Saving Data in Touchstone Format 

You can also save trace data of a E5061B active channel of S-parameter to 
a Touchstone format file. 

Touchstone file data format 

You can save data in "log magnitude - angle", "linear magnitude - angle", 
or "real number - imaginary number." 

When AUTO is selected, the data format is automatically set according to 
the display format of the active trace. However, when the display format of 
the active trace is set to one other than the log magnitude format 
(LogMag), linear magnitude format (LinMag), or real-imaginary number 
format (Real/Imag), the data format is automatically set to real-imaginary 
number. 

You can use data saved in Touchstone format for a circuit simulator such 
as Agilent Advanced Design System (ADS) on your PC (personal computer) 
or workstation. For more information on the ADS, refer to the operation 
manual that comes with the system. 

File types of Touchstone files 

File types of the E5061B Touchstone files are s1p and s2p. The file type 
indicates the number of ports of the data structure that is output to the 
Touchstone file. 

Data structure in Touchstone file 

Data structure of the Touchstone file consists of a header part and a data 
part. The contents of the file is text data, which is ready to be read with a 
general text editor. 

The header part consists of the returned value of *IDN?, file created date, 
calibration state, list of all S parameters of a specified port, and format 
information. 

The header parts of s1p and s2p are shown below. 

Header of s1p 

!Agilent Technologies,E5061B,<ID>,<FW Revision> 
!Date <Date> 
!Data & Calibration Information 
!Freq Syy:Method(Stat) 
# Hz S FMT R Z0 

Header of s2p 

!Agilent Technologies,E5061B,<ID>,<FW Revision> 
!Date <Date> 
!Data & Calibration Information 
!Freq Syy:Method(Stat) Syz:Method(Stat) Szy:Method(Stat) Szz:Method(Stat) 
# Hz S FMT R Z0 
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Each item has the following meaning: 

Parameter Description 

Syy to Szz S parameters of the selected test port; corresponds in 
ascending order, beginning with y to z. 

Method Calibration type applied to S parameter. 

Stat 

  

State of S parameter calibration and error correction 
setting (ON, OFF, or --) 

ON = Error correction is set to ON 
OFF =Error correction is set to OFF 
-- = Calibration is not performed 

FMT Data format 

RI = Real number - imaginary number 
MA = Linear magnitude - angle 
DB = Log magnitude - angle 

Z0 Reference impedance value 

  

The structure of the data part depends on the combination of the selected 
file type and specified port. 

  When the S parameter of a port on which calibration 
is not performed is specified, if the data measured with the S 
parameter exists, that data are output to a Touchstone file. If 
no measurement data exists, 0 (for log magnitude - angle, log 
magnitude = -200 dB) is output in the corresponding field. 

The following figures show the data structures of files saved in Touchstone 
format. 

1-port Touchstone file 
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 2-port Touchstone file 

 
 Restrictions when saving data in Touchstone format 

The following restrictions apply in saving measurement data into 
Touchstone format. 

 When both fixture simulation and port impedance conversion are ON, 
all Z0 of the ports to be saved must be set to the same value. If Z0 is 
different among the ports, no error occurs, but only the Z0 of the 
smallest port number is output to the header. 

 When the time domain function is ON, the saved data are not the 
displayed data but the data of the S parameter before conversion. 

 For data saved in touchstone format, data operation, time domain, 
parameter conversion, data format, electrical delay, equation editor, 
and smoothing are not reflected in the output data. 

Saving procedure 
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Follow the steps below to save trace data in Touchstone format. 

1. Press Channel Next  (or Channel Prev) and Trace Next (or Trace prev) 
to select the trace to be saved. 

2. Press Save/Recall > SnP > SnP Format. 

3. Click the softkey that corresponds to the data format you want to 
save. 
  

Softkey Function 

Auto Data format is automatically set according to 
the display format of the active trace. When the 
display format of the active trace is set to one 
other than log magnitude format (LogMag), 
linear magnitude format (LinMag), or real-
imaginary number format (Real/Imag), the data 
format is automatically set to real-imaginary 
number. 

LogMag/Angle Select "log magnitude - angle" data format 

LinMag/Angle Select "linear magnitude - angle" data format 

Real/Imaginary Select "real - imaginary number" data format 

5. Click the softkey for s1p or s2p according to the file type you want to 
save. 

6. Click the softkey that corresponds to the combination of ports that 
you want to save. 

7. SaveAs dialog box opens. For its operations, use an external 
keyboard and mouse. 

8. Specify the folder to which the file should be saved, enter a file 
name, and then press Save to save the file. 

 When saving data in a sweep process, the data 
during sweep is saved into a Touchstone file. That is, the 
previous sweep data is saved as data that has not been swept; 
or, if sweep was not performed previously, zero data might be 
saved. Therefore, you should set the active channel to the HOLD 
state when saving data into a Touchstone file. 

 This function is inactive when the security level is set 
at low/high. 
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Saving the Screen Image to a File 

 Overview 

 Saving Screen Image as File 

Other topics about Data Output 

Overview 

Along with printing, the E5061B allows the user to save screen images as 
bitmap (.bmp) or portable network graphics (.png) files. Saved files can be 
loaded into PC application software for further processing. 

Saving Screen Image as File 

Follow the procedure below to save a screen image to a file. 

1. Display the screen to be saved as a file. If you want to save the 
screen with a white background, set the display mode to inverted 
display before saving the screen. For details about display mode, see 
Setting Display Colors. 

2. Press System key. The screen image at the time System key is 
pressed is the image that will be saved. 

3. Press Dump Screen Image to open the Save As dialog box. 

4. Select the file type from "24-Bit Bitmap (*.bmp)" or "Portable 
Network Graphics (*.png)". 

5. Select the destination folder and type a file name. (Clicking Input 
from the front panel on the Save As dialog box activates the on 
screen keyboard.) 

6. Press Save to save the screen image of E5061B to a file. 
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Printing Displayed Screen 

 Overview 

 Printed/Saved Images 

 Print Procedure 

Other topics about Data Output 

Overview 

By connecting a printer to the USB port of the E5061B, you can print the 
displayed screen of the E5061B. 

Printed/Saved Images 

The display image saved in the volatile memory (clipboard) is 
printed/saved. If no image is saved in the clipboard, the image displayed 
at the time of print execution is printed/saved. 

Saving image to clipboard 

The System key also has a screen capture feature. When you press System 
key, the image displayed on the screen immediately before pressing is 
saved in the clipboard. 

 The image in the clipboard is cleared when you 
execute print/save. 

Print Procedure 
Preparation before printing 

Follow these steps to prepare for printing: 

1. Turns OFF the E5061B. 

2. Turn ON the printer and connect it to E5061B. 

3. Turn ON the E5061B. 

4. Press System key. 

5. Press Printer Setup. The Printers window opens. The icons of the 
printers that have been connected are displayed in the window. When 
you connect a print for the first time, it is automatically registered and 
its icon is added in the window. 

6.  The printer with the check mark ( ) on its icon is selected as the 
default printer for printing. If you want to change it, select (highlight) 
the icon of your preferred printer in the Printers window and then click 
Set as Default Printer in the File menu. 

7. Click Printing Preferences...  in the File menu. The Printing Preferences 
dialog box for the selected printer appears. Set items necessary before 
printing such as Page Size and then click the OK button . 
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8. Click Close in the File menu. 
Executing print 

Follow these steps to print the screen information: 

1. Display the screen you want to print. 

2. Press System key to save the currently displayed screen onto the 
clipboard. 

3. As necessary, press Invert Image to toggle between [OFF] for printing 
in colors close to the actually displayed screen and [ON] for printing in 
inverse colors. 

4. Click Print to start printing. 

5. To cancel the printing in progress, press Abort Printing. 

 If you start printing when the printer is not ready 
(for example, it is not turned ON) by mistake, the Printers 
Folder dialog box may appear. In this case, click Cancel to close 
the Printers Folder dialog box, prepare your printer, and then 
start printing again. 
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Optimizing Measurements 

Optimizing Measurements 

 Expanding Dynamic Range 

 Reducing Trace Noise 

 Improving Phase Measurement Accuracy 

 Improving Measurement Throughput 
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Expanding Dynamic Range 

 Overview 

 Lowering Receiver Noise Floor 

Other topics about Optimizing Measurement 

Overview 

The dynamic range is the finite difference between the maximum input 
power level and the minimum measurement power level (noise floor) of 
the analyzer. In evaluating a characteristic accompanied by a large change 
in the amplitude (the pass band and stop band of a filter, for example), it 
is important to increase the dynamic range. 

Lowering Receiver Noise Floor 

Lowering the noise floor of the receiver enables you to expand the dynamic 
range. The following methods can be used to lower the receiver noise floor. 

  Narrowing the IF bandwidth 

 Turning on Sweep Averaging 
Narrowing the IF bandwidth 

Narrowing the receiver IF bandwidth enables you to reduce the effect of 
random noise on measurements. Narrowing the IF bandwidth to 1/10 the 
original bandwidth causes the receiver noise floor to decrease by 10 dB. 



E5061B 

298 

 
To specify the IF bandwidth, follow the steps described below. 

1. Press Channel Next (or Channel Prev)  to select a channel on which to 
specify the IF bandwidth. 

2. Press Avg key. 

3. Click IF Bandwidth, then change the IF bandwidth in the data entry 
area. 
  

Setting IF Bandwidth Automatically 

The IF bandwidth auto mode helps you to improve the measurement 
speed, when the sweep mode is set at log especially. When you make a 
measurement with wide span from lower frequency and the IF bandwidth is 
set at fixed frequency, the measurement would be slow or higher noise 
floor in lower frequency.  This function allows you to measure narrower IF 
bandwidth (lower noise) in lower frequency and wider IF bandwidth (faster 
) in higher frequency. 

1. Press Avg key. 

2. Click IFBW Auto to turn ON the IF bandwidth auto mode. 

3. If you want to set an upper limit of IF bandwidth in auto mode, press 
IFBW Auto Limit, and enter the upper limit with enter keys. 
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 In IF bandwidth auto mode, the IF bandwidth is 
automatically set to equal to or less than 1/5 of each 
measurement frequency. (The E5061B does not change IFBW 
for each test points in IF BW auto mode. The E5061B divides its 
measurement span into several segments which are defined 
internally. The IFBW is set at equal to or less than 1/5 of the 
start frequency of each segment.) 

 IFBW Auto On may make the sweep time be longer 
than IFBW Auto Off. This is because IFBW auto operation 
requires some additional time. 

Turning ON Sweep Averaging 

Using sweep averaging also enables you to reduce the effects of random 
noise on the measurements. 

Sweep averaging averages data from each point (vector quantity) based 
on the exponential average of a continuous sweep weighted by the 
averaging factor specified by the user. Sweep averaging is expressed in 
the following equation. 

 
where: 

 An = Result of the calculation of sweep averaging for the nth sweep 
operation at the point in question (a vector quantity) 

 Sn = Measurement value obtained at the nth sweep operation at the 
point in question (a vector quantity) 

  F = Sweep averaging factor (an integer between 1 and 999) 
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Define the sweep averaging by following the steps below. 

1. Press Channel Next (or Channel Prev) to select the channel on which 
you want to define the sweep averaging. 

2. Press Avg > Avg Factor, then change the averaging factor in the data 
entry area. 

3. Click Averaging to turn ON the averaging. 

 Clicking Averaging Restart resets n to 1 in Sweep 
Averaging equation in Turning on Sweep Averaging 
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Reducing Trace Noise 

Any of the following methods can be used to lower the trace noise. This 
section provides the description of Turning on Smoothing. 

 Turning on Smoothing 

 Turning on Sweep Averaging 

  Narrowing IF Bandwidth 

Other topics about Optimizing Measurements 

Turning on Smoothing 

Smoothing can be used to reduce noise that has relatively small peaks. By 
turning on smoothing, the value of each point on a trace is represented by 
the moving average over the values of several nearby points. The 
smoothing aperture (percentage of sweep span) defines the range of 
points to be included in the calculation of the moving average. 

 You can define the smoothing trace by trace. 
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Setting up smoothing 

Set up the smoothing operation by following the steps below: 

1.  Press  Channel Next (or Channel Prev) and Trace Next (or Trace prev) 
to activate the trace on which smoothing will be defined. 

2. Press Avg. 

3. Click Smo Aperture, then  change the smoothing aperture (%) in the 
data entry area. 

4. Click Smoothing to turn ON smoothing. Smo is displayed at the trace 
status area. 
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Improving Phase Measurement Accuracy 

This section describes the following functions that can be used to improve 
phase measurement accuracy. 

 Electrical Delay 

 Velocity Factor 

 Phase Offset 

 Port Extensions and Loss Values 

Other topics about Optimizing Measurements 

Electrical Delay 

Electrical Delay is a function that adds or removes a pseudo-lossless 
transmission line with a variable length corresponding to the receiver 
input. Using this function enables you to improve the resolution in phase 
measurement and thereby measure the deviation from the linear phase. 
You can specify the electrical delay trace by trace. 

1. Press Channel Next (or Channel Prev)  and Trace Next (or Trace prev) 
to activate the phase trace of which you want to specify the electrical 
delay. 

2. Press Scale > Electrical Delay. 

3. Change the electrical delay (in seconds) in the data entry area. 

For how to determine the deviation from a linear phase, see Measuring the 
Deviation from a Linear Phase. 

Procedure using marker 

1. Press Channel Next (or Channel Prev)  and Trace Next (or Trace prev) 
to activate the trace of which you want to set the electrical delay. 

2. Place the active marker in an appropriate position. 

3. Press Maker Fctn. 

4. Click Marker -> Delay to set the electrical delay to the group delay 
value at the position of the active marker (a value smoothed with the 
aperture of 20% regardless of the smoothing setting). 

Phase offset 

Phase offset is a function used to add or subtract a predetermined value 
relative to the frequency to and from the trace. Using this function enables 
you to simulate the phase offset which occurs as a result of, say, adding a 
cable. 

The phase offset can be specified from -360 ° to +360 ° . 
Using the Phase Offset Function 
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1. Press Channel Next (or Channel Prev)  and Trace Next (or Trace prev) 
to activate the trace of which you want to specify the phase offset. 

2. Press Scale > Phase Offset, then enter the phase offset ( ° ) in the 
data entry area. 

Velocity factor 

The velocity factor is the ratio of the propagation velocity of a signal in a 
coaxial cable to the propagation velocity of that signal in free space. The 
velocity factor for a common cable is about 0.66. The propagation velocity 
depends on the dielectric constant (εr) of the dielectric substance the 
cable. 

 
By specifying the velocity factor, you can match the equivalent length (in 
meters) appearing in the data entry area to the actual physical length 
when using the Electrical Delay or Setting port extensions to specify the 
electrical delay (in seconds). 

You can define the velocity factor channel by channel. 
Using the velocity factor 

1.  Press Channel Next (or Channel Prev) to activate the channel for 
which you want to specify the velocity factor. 

2. Press Cal > Velocity Factor, then the velocity factor in the data entry 
area. 

Port Extensions and Loss Values 
Overview 

Port Extension is a function for moving the calibration reference plane by 
specifying the electrical delay. This function is useful, for example, when 
you cannot directly perform calibration at the DUT terminal because the 
DUT is inside the test fixture. In such a case, this function enables you to 
first perform calibration at the test fixture terminal and then move the 
calibration plane to the DUT terminal by extending the port. 

Port extension corrects the electrical delay of each test port (phase shift) 
only. It cannot remove errors caused by the loss in and incorrect matching 
of cables, adapters, or test fixtures. 

In addition to port extension, you can set loss values for each port. By 
correcting loss due to port extension, more accurate measurement results 
are obtained. 

There are two types of loss value settings: loss values at two frequency 
points for a specified port, and a DC loss value. You can make these 
settings at the same time for each port. 
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The port extension is not available for the Gain-Phase measurement. 

 You can set loss values channel by channel. Setting 
loss values for one particular channel does not affect other 
channels. 

 You can define port extension channel by channel. 
Setting port extension for one particular channel does not affect 
other channels. 

Enabling port extensions and loss values 

1. Press Channel Next (or Channel Prev) to  activate the channel for 
which you want to enable port extension. 

2. Press Cal > Port Extensions. 

3. Turn ON Extensions. 
Setting port extension and Loss values manually. 

a. Setting electrical delay 

Follow the steps below to set the delay for coaxial cable: 

1. Press Channel Next (or Channel Prev) to activate the channel for 
which you want to set port extension. 

2. Press Cal > Port Extensions.  

3. Click Extension Port 1 or Extension Port 2 to select the port. 

4. Click Extension to set the extension in sec. 

b. Setting loss values 

1. Press Channel Next (or Channel Prev) to activate the channel for 
which you want to set loss values. 

2. Press Cal > Port Extensions. 

3. Click Extension Port 1 or Extension Port 2 to select the port. 

4. Click Loss to set a loss value. 

5. Click Loss1 [OFF] to toggle to Loss1 [ON] (enabled), and enter a loss 
value (Loss1) and a frequency (Freq1). 

6. If you want to set loss at two frequency points, press Loss2 [OFF] to 
toggle to Loss [ON] (enabled), and enter a loss value (Loss2) and a 
frequency (Freq2). 
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 Expression to calculate loss using Loss 1: 
 

 
  Expression to calculate loss using Loss 1 and Loss 2: 

 

 
 When you specify two frequency points, set the 

lower frequency to Loss1, and the higher one to Loss2. 

c. Setting a DC loss value 

1. Click Cal > Port Extensions > Extension Port 1 or  Extension Port 2 to 
select the port. 

2. Click Loss > Loss1 [OFF] to toggle to Loss1 [ON] (enabled). 

3. Click Loss at DC, then enter a DC loss value. 
Using the auto port extension function 

The auto port extension function measures port extension and loss values 
for each port using the OPEN/SHORT standard connected to the port, 
automatically calculates and sets them. 

When the auto port extension function is completed, the port extensions 
and loss values are updated to the calculated values. 

 You can use both open and short measurement values in the auto port 
extension function. Note that in this case, the average value of the 
calculation results is used for updating.   

You can set the auto port extension function channel by channel. Setting 
the auto port extension function for one particular channel does not affect 
other channels. 

When the sweep type is power sweep, the auto port extension is not 
available. 
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A. Selecting a port(s) 

Select the port(s) of which you want to use the auto port extension 
function. 

1. Press Channel Next (or Channel Prev) to activate the channel of which 
you want to set auto port extension. 

2. Press Cal > Port Extensions > Auto Port Extension > Select Ports to 
select the port(s) of which you want to use the auto port extension 
function. 

B. Setting frequencies used for calculation 

Set the frequency points ofh which you want to calculate a loss value. 

1. Press Cal > Port Extensions > Auto Port Extension > Select Ports > 
Method to set the frequencies used for calculation. 

2. If you have selected User Span, use User Span Start and User Span 
Stop to set a start value and a stop value. 

 For Current Span and User Span, a frequency point at 
1/4 of the frequency range is set to Freq1; a frequency point at 
3/4 of the frequency range is set to Freq2. 

 If the setting is not made before starting 
OPEN/SHORT standard measurement, it does not affect the 
calculation result. 

 

C. Specifying a loss value as a calculation target 
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Specify whether you want to include a loss value in the calculation result. 

1. Press Cal > Port Extensions > Auto Port Extension > Select Ports > 
Include Loss to turn it ON. 

 If the setting is not made before starting the 
measurement of the OPEN/SHORT standard, it does not affect 
the calculation result. 

D. Specifying a DC loss value as a calculation target 

Specify whether you want to include a DC loss value in the calculation 
result. 

1. Press Cal > Port Extensions > Auto Port Extension > Adjust Mismatch 
to turn it ON. 

 If the setting is not made before starting the 
measurement of the OPEN/SHORT standard, it does not affect 
the calculation result. 

E. Measuring the OPEN/SHORT standard and executing calculation 

Calculate port extensions and loss values based on the calculation results 
using the OPEN/SHORT standard. 

1. Press Cal > Port Extensions > Auto Port Extension. 

2. If you use the OPEN standard, click Measure OPEN, and select the 
port(s) of which you want to execute measurement. Execution is 
restricted to ports selected in Selecting a port(s) 

3. If you use the SHORT standard, click Measure SHORT, and select the 
port(s) of which you want to execute measurement. Execution is 
restricted to ports selected in Selecting a port(s). 

 If a port extension value or loss value has been set, 
the value is updated to the calculated result. 

 If you execute both open measurement and short 
measurement, the average of the calculation results is reflected 
to the port extension and loss value. 

F. Deleting the result of open/short measurement 

When you exit from the softkey menu in the same level after open/short 
measurement, the measurement results are deleted. Note that you can use 
a GPIB command. 

  Port extension and loss values that have been 
calculated are not cleared. 
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Improving Measurement Throughput 

This section explains the methods to improve measurement throughput. 

 Turning OFF the updating of information displayed on the LCD screen 

Other topics about Optimizing Measurements 

Turning OFF the updating of information displayed on the LCD screen 

Turning OFF the updating information feature displayed on the LCD screen 
eliminates the processing time required to update displays within the 
analyzer, hence improves the measurement throughput. If it is not 
necessary to check displayed information during measurements, turning 
OFF real-time updating is an effective means of improving throughput. 

The updating of information displayed on the LCD screen can be switched 
using the following procedure: 

Turning OFF the updating of information 

1. Press Display. 

2. Click Update to switch the updating of displayed information on the 
LCD screen ON/OFF. 

When the LCD screen update is turned OFF, Update Off appears on 
Instrument Status Bar. 
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Measurement Examples 

Measurement Examples 

 Band Pass Filter Measurement (in Quick Start) 

 Loop Gain Stability Measurement 

 Performing Segment-by-Segment Sweep (segment sweep) 
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Measurement Example of a Bandpass Filter 

This section describes how to measure the transmission characteristics of a 
947.5 MHz bandpass filter. The measurement conditions for this 
measurement example are those suitable for a 947.5 MHz bandpass filter. 
To measure another device under test (DUT), change the measurement 
conditions to suit the particular DUT. 

STEP 1. Determining Measurement Conditions 

1. Preset the E5061B.  
 
Preset > OK 
  

2. Set the S-parameter to S21. 
 
Meas > S21 

 When measuring the reverse transmission 
characteristics, set the S-parameter to S12. 

3. Set the data format to the log magnitude format 
 
Format > Log Mag 
  

4. Set the center frequency to the bandpass filter center frequency. 
Next, specify the span frequency, which is set to 200 MHz in this 
measurement example. 
 
Center > 9 > 4 > 7 > . > 5 > M/m  
Span > 2 > 0 > 0 > M/m 

 When entering the frequency unit using the 
keyboard, type "G" for GHz, "M" for MHz, and "k" for kHz. 

5. Specify the number of measurement points per sweep. The number 
of measurement points in this measurement example is set to 401. 
 
Sweep Setup > Points > 4 > 0 > 1 > x1 
  

6. Specify the power level of the signal source. The power level in this 
measurement example is set to -10 dBm. 
 
Sweep Setup > Power > +/- > 1 > 0 > x1 
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7. Specify the IF bandwidth of the receiver as necessary. In this 
measurement example, the IF bandwidth is set to 10 kHz because of 
the need to lower the noise floor. 
 
Avg > IF Bandwidth > 1 > 0 > k/m 

STEP 2. Calibration 

To turn the error correction ON, set the calibration type to the full 2-port 
calibration and measure the calibration data. 

For details about calibration, see Calibration. 

1. Select the calibration kit suitable for the measurement cable. In this 
measurement example, Calibration Kit 85032F is selected. 

Cal > Cal Kit > 85032F 

2. Set the calibration type to the full 2-port calibration using the test 
port 1 and 2. 

Cal > Calibrate > 2-Port Cal 

3. Connect the OPEN standard (included in the calibration kit) to the 
other end of the measurement cable that is connected to the test 
port 1 as shown in the following figure, and measure the open 
calibration data at the test port 1. After measuring the open 

calibration data, a checkmark  is displayed to the left of the Port 1 
Open menu. 

Cal > Calibrate > 2-Port Cal > Reflection > Port1 Open 

In the same way, measure the calibration data for the SHORT/LOAD 
standards at the test port 1. 

Connecting the OPEN/SHORT/LOAD standards 
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4. In the same way as described above, measure the calibration data 

for the OPEN/SHORT/LOAD standards at the test port 2. 

5. Connect the measurement cables as shown in the figure below, and 
measure the thru calibration. After measuring the thru calibration 

data, a checkmark is displayed to the left of the Port 1-2 Thru 
button. 

Cal > Calibrate > 2-Port Cal > Transmission > Port 1-2 Thru 

Making the through calibration 

 
6. Set the full 2-port calibration measurement to DONE. The calibration 

factor is calculated based on the calibration data acquired, and the 
error correction is turned ON. 
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Cal > Calibrate > 2-Port Cal > Done 

7. Select the type in which the data is to be saved before saving the 
calibration factor (calculated based on the calibration data). 

Save/Recall > Save Type > State & Cal 

8. Store the calibration file to the disk of the E5061B. The symbol "X" 
appearing in the operations below represent the assigned numbers to 
be used when the file is saved. 

Save/Recall > Save State > State 0X 

STEP 3. Connecting the Device Under Test (DUT) 

1. Connect to the DUT to the E5061B. (See the below figure) 
 
Connecting the DUT 
 

 
  

2. Set the appropriate scale by executing the auto scale. (See the below 
figure) 
 
Scale > Auto Scale 
 
You can also adjust the scale by entering arbitrary values in the 
Scale/Div button, Reference Position button, and Reference Value. 
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S21 trace after executing the auto scale 

 
STEP 4. Analyzing Measurement Results 

This section describes how to use the marker function to read out 
important parameters for the transmission measurement of the bandpass 
filter (insertion loss, -3 dB bandwidth). 

Measuring the Insertion Loss 

1. Display a marker. 

Marker > Marker 1 

2. Using one of the following methods to move the marker to the center 
frequency of the bandpass filter. 

 On the entry bar, press 9> 4 > 7 > . > 5 > M/m  

 Turn the rotary knob  on the front panel to set it to the center 
frequency (947.5 MHz). 

3. Read the marker value displayed as shown in the figure below. In 
this example, the response value denotes the insertion loss. 

Measuring an Insertion Loss 
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Measuring the -3 dB Bandwidth 

Using the marker bandwidth search function, the bandwidth, center 
frequency between two cutoff frequency points, Q value, and insertion loss 
are all read out. These parameters are described in the following table. 

 If the two cutoff frequency points are not found, all 
data items except the insertion loss revert to zero. 
  

Parameter Description 

BW (Bandwidth) Stimulus width between two cutoff 
frequency points (low and high) 

cent (Center 
Frequency) 

Center point between cutoff frequency 
points (low and high) 

low (Left-side Cutoff 
Frequency) 

The lower frequency of the two cutoff 
frequency points 

high (Right-side Cutoff The higher frequency of the two cutoff 
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Frequency) frequency points 

Q (Q Value) Q = cent/BW  

loss (Insertion Loss) The measured value of the active 
marker. 

1. Display a marker. 

Marker > Marker 1 

2. Using one of the following methods to move the marker to the center 
frequency of the bandpass filter. 

 On the entry bar, press 9 > 4 > 7 > . > 5 > M/m  

 Turn the rotary knob  on the front panel to set it to the center 
frequency (947.5 MHz). 

3. Specify the bandwidth definition value that defines the pass band of 
the filter. In this measurement example, it is set to -3 dB. 

Marker Search > Bandwidth Value > +/- > 3  > x 1 

4. Set the bandwidth search function ON. 

Marker Search > Bandwidth 

5. The bandwidth data items (BW, cent, low, high, Q, loss) is displayed. 
(See the following figure.) 

Measuring the -3 dB Bandwidth 

STEP 5. Outputting Measurement Results (Save) 

You can save not only the internal data but also the measurement results 
such as trace data and display screens to the disk. 

Saving the Trace Data(in CSV format) 

You can save the trace data to the disk of the E5061B in CSV file format 
(extension: .csv). Since the CSV-formatted data to be saved is a text file, 
you can analyze the data using Microsoft Excel. 

Follow the step below to save the trace data: 

Save/Recall > Save Trace Data 
Saving the Display Screen 

You can save the screen displayed on the E5061B to the disk of the 
E5061B in Windows bitmap file format (extension: .bmp) or Portable 
Network Graphics format (extension: .png). 

Follow the step below to save the display screen: 

System > Dump Screen Image 
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 The image on the LCD display memorized in the 
volatile memory (clipboard) (the image on the LCD display when 
the Capture/System key is pressed) is saved. 
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Loop Gain Stability Measurement 

 Overview 

 Procedure 

Other Measurement Examples 

Overview 

This section introduces an example of how to measurement loop stability 
for low-frequency amplifier. 

Procedure 

In this example, the DUT is evaluated by following the steps. 

Step Description 

1. Setting the Measurement 
Conditions 

Set the measurement conditions. 

2. Executing Calibration Execute calibration. 

3. Connecting the DUT Connect the DUT. 

4. Scaling Adjust the scale to confirm the result 
of measurement. 

  
1. Setting the Measurement Conditions 

The measurement conditions are defined by following the steps described 
below. 

Setup 
Description 

Key Operation 

Presetting Preset > OK 

Setting trace 
number: 2 

Display > Num of Traces > 2 > Allocate Traces > 
x2 

Specifies 
measurement port: 
Gain-Phase 

Meas > Measurement Port > Gain-Phase 

 The measurement 
parameters are not specified, because 
the measurement parameters of both 
channel are T/R. 
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Specifies 
impedance of 
receiver port: 1 
MΩ 

Meas > Gain-Phase Setup > T Input Z > 1 MΩ 
Meas > Gain-Phase Setup > R Input Z > 1 MΩ 

Specifies 
attenuator of 
receiver port: 20 
dB 

Meas > Gain-Phase Setup > T Attenuator > 20 dB 
Meas > Gain-Phase Setup > R Attenuator > 20 dB 

Data format: 
Tr1:LogMag 
Tr2:Phase 

(Tr1) Format > Log Mag 
(Tr2) Format > Phase 

Sweep type: Log 
Frequency 

Sweep Setup > Sweep Type > Log Freq 

Start frequency: 
100 Hz 

Start > 1 > 0 > 0 > x1 

Stop frequency: 1 
MHz 

Stop > 1 > M/u 

IF bandwidth auto: 
ON 

Avg > IFBW Auto (Turn it ON.) 

IF bandwidth auto 
limit: 100 Hz 

Avg > IFBW Auto Limit > 1 > 0 > 0 > x1 

Power: -20 dBm Sweep Setup > Power > Power > +/- > 2 > 0 > x1 

  
2. Executing Calibration 

The THRU response calibration (Gain-Phase) is executed. 

Setup Description Key Operation or Connecting 
Operation 

Connect THRU connection Connect THRU connection. 

Executing the THRU 
response 

Cal > Calibrate > Response (Thru) > Thru 
> Done 

  
3. Connecting the DUT 

Connect the DUT as shown below. 



Measurement 

321 

 
  

4. Scaling 

Set each parameter for the scale setting. It is necessary to specify the 
trace pressing the Trace Next or Trace Prev before each parameter is 
specified. The following table is example of setting. 

Setup Description Key Operation 

Scale divisions: 10 (Tr1) Scale > Divisions > 1 > 0 > x1 
(Tr2) Scale > Divisions > 1 > 0 > x1 

Scale/Div: 10 dB/div 
(Tr1), 45 °/div (Tr2) 

(Tr1) Scale > Scale/Div > 1 > 0 > x1 
(Tr2) Scale > Scale/Div > 4 > 5 > x1 

Reference position: 5 Div (Tr1) Scale > Reference Position > 5 > x1 
(Tr2) Scale > Reference Position > 5 > x1 

Reference value: 0 dB 
(Tr1), 0 °/div (Tr2) 

(Tr1) Scale > Reference Value > 0 > x1 
(Tr2) Scale > Reference Value > 0 > x1 
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Example of the loop gain stability measurement screen 
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Performing a Segment-by-Segment Sweep 

This section describes the concept of the segment sweep and how to 
perform it. 

 Concept of Segment Sweep 

 Conditions for Setting Segment Sweep 

 Items that can be set for Each Segment 

 Sweep Delay/Sweep Time in Segment Sweep 

 Frequency/Order Base Display 

Other topics about Optimizing Measurements 

Concept of Segment Sweep 

To perform a segment sweep, you must define two or more frequency 
ranges, called segments, and then specify the number of points, IF 
bandwidth, power level, sweep delay time, and sweep time for each 
segment. All segments are swept sequentially as if swept in one sweep 
operation. 

 By skipping the frequency range, which does not need to be 
measured, you can sweep and measure only the portions you need. 

 You can define the optimum measurement conditions for each 
of the segments you designate. For example, you can specify as many 
points as possible in a segment requiring high trace resolution and as 
few points as possible in a segment not requiring high resolution. This 
shortens the measurement time, enabling you to optimize the overall 
measurement throughput by not having to perform the entire operation 
under the same measurement conditions of a particular frequency 
range. 

To evaluate a band pass filter that has the transmission characteristics 
shown in the following figure, for example, you can select the frequency 
ranges you need from A through G and determine the measurement 
conditions shown in the table below. This enables you to measure them 
simultaneously in one sweep operation. 
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Frequency ranges (segments) from the figure above and their 
measurement conditions 

  Start 
frequency 

Stop 
frequency 

Number of 
points 

IF Bandwidth 

A 440 MHz 915 MHz 50 50 kHz 

B 915 MHz 980 MHz 130 70 kHz 

C 980 MHz 1.035 GHz 60 50 kHz 

E 1.07 GHz 2 GHz 100 70 kHz 

G 2.6 GHz 3 GHz 40 70 kHz 

Conditions for Setting Segment Sweep 

The following conditions apply in setting up a segment sweep. 

 The frequency range of a segment must not overlap with that of 
another segment. (The start frequency of a segment must be higher 
than the stop frequency of the immediately preceding segment). 

 The start frequency of segment 1 must be greater than 5 Hz and the 
stop frequency of the last segment less than 3 GHz, as per the range 
of the Network Analyzer. 
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 When the start frequency and stop frequency of a segment are not 
the same, you can define from 2 to the maximum points in a 
segment. 

 When the start frequency and stop frequency of a segment are the 
same, you can define from 1 to the maximum points in a segment. 

 You can set the total number of points in the segment table from 2 
to the maximum points. 

 You can set the number of segments in the segment table to 
between 1 and 201. 

Items that can be set for Each Segment 

For the segment sweep, you can set the sweep range, the number of 
points, IF bandwidth, power level, sweep delay time, and sweep time for 
each segment. 

You can set the items in the following table to ON/OFF for each segment. If 
you enable the segment-by-segment setting, you can make the setting for 
each segment in the segment table; if you disable it, the setting in the 
following table is used. 

Item When segment-by-segment setting is disabled 

IF bandwidth For all segments, the IF bandwidth (set with Avg > IF 
Bandwidth) is set even if  IFBW AUTO is turned ON. 

Power level For all segments, the power level for the linear/log 
sweep (set with Sweep Setup > Power) is set. 

Sweep delay 
time 

For all segments, 0 is set. 

Sweep time For all segments, the auto sweep time mode is set. 

Sweep Delay/Sweep Time in Segment Sweep 

The definitions for sweep delay time and sweep time, which you can 
specify in the segment sweep, are shown in below figures. 

  

The definitions for sweep delay time and sweep time when trigger 
mode is "On Sweep". 
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The definitions for sweep delay time and sweep time when trigger 
mode is "On Point". 

 
 The segment trigger delay is not included in the 

segment sweep time. 

Frequency/Order Base Display 

You can choose between frequency-based and order-based display as the 
method of displaying traces when executing a segment sweep. 
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Procedure 
Creating a segment table 

1. Press Channel Next (or Channel Prev) to select the channel of which 
you want to create the segment table. 

2. Press Sweep Setup. 

3. Click Edit Segment Table. The segment table appears in the lower 
section of the screen. 

4. Select the softkey to change the frequency range setting mode or to 
set the IF bandwidth, power level, sweep delay time, and sweep time 
for each segment. 

 When setting the segment table using the front 
panel keys or keyboard, you need to place focus on 
(select) the operation target (segment table of softkey) 
first. You can change the focus by pressing Foc key in the 
ENTRY Block. When the focus is placed on the segment 
table, the window frame of the segment table is displayed 
as bright as the window frame of the active channel. 
When the focus is placed on the softkey menu, the softkey 
menu title area is displayed in blue. 

5. Enter each item in the following table for each added segment (line) 
to create the segment table. To create the segment table, use the 
hardkeys and softkeys. 
  

Start Sets the start value of the sweep range 

Stop Sets the stop value of the sweep range 

Center Sets the center value of the sweep range 

Span Sets the span value of the sweep range 

Points Sets the number of points 

IFBW Sets the IF bandwidth 

Power Sets the power level; the power range is common to 
the settings for the linear/log sweep (Sweep Setup > 
Power Ranges) 

Delay Sets the sweep delay time 

Time Sets the sweep time; to specify the auto setting 
(AUTO), enter 0 as the sweep time 
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Useful functions when using a mouse 

 You can copy/paste/insert/delete the cell by right-clicking on the 
selected cell. 

 In the character-by-character edit mode, you can   
undo/cut/copy/paste/delete/select all by right-clicking in the 
cell. 

Executing segment sweep 

To execute a segment sweep by using the segment table you have 
created, you must specify the sweep type for that sweep operation by 
following the steps below. 

1. Press Channel Next (or Channel Prev) to select the channel on which 
you execute the segment sweep operation. 

2. Press Sweep Setup > Sweep Type > Segment. 
Setting up the segment display 

Define the method of displaying traces when the segment sweep is 
executed by following the steps described below. 

1. Press Channel Next (or Channel Prev) to select the channel on which 
you define the segment display. 

2. Press Sweep Setup > Segment Display. 

3. Select the segment display. 
Saving a newly created segment table in CSV format 

As discussed in Creating a segment table, you can export the newly 
created segment table as a CSV (comma-separated value) formatted file 
(so it can be used easily in software that requires a different format). 

1. Press Sweep Setup. 

2. Click Edit Segment Table > Export to CSV File to open the Save As 
dialog box. Note that CSV files (*.csv) is already selected as the file 
type when the dialog box first opens. 

3. Type the file name in the File Name area and Click Save to save the 
segment table. 

Calling a segment table saved in CSV Format 

By importing a segment table file saved by E5061B, you can set up the 
segment table. 

 It is possible to recall a file from a different channel 
where it is saved. 

1. Press Sweep Setup. 
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2. Click Edit Segment Table > Import from CSV File to open the Open 
dialog box. Note that CSV files (*.csv) is already selected as the file 
type when the dialog box first opens. 

3. Select the CSV format file to be imported, and click Open to call up 
the segment table. 

 You cannot import a CSV-formatted file 
created/edited in spreadsheet software into the E5061B. 

 


