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2022 Winter Term

Communication System Simulation

Ɪntroduction

Computer simulations are commonly used to predict
the performance of modern communication systems.
These simulations can evaluate the effects of impair-
ments such as fading and complex processing such as
FEC.
Simulations of communication systems operate on

sampled signals. The simulation can apply the same
operations as an actual transmitter, channel and re-
ceiver1 to pseudo-random signal and noise samples.
The simulation can then measure the performance
(e.g. the BER) of the simulated system.
Such computer simulations are typically written in

programming languages such as C or Matlab using
libraries of functions that perform signal processing
such as signal and noise generation, filtering, modu-
lation, coding, etc.
In this lab youwill simulate the operation of a com-

munication system that uses bipolar NRZ signalling
over an AWGN channel together with a rate-1/2 con-
volutional encoder and a Viterbi decoder. You will
compare the BER vs. 𝐸b/𝑁0 curves for systems with
and without FEC and determine the coding gain at
different BERs.

GNU Radio

A “Software Defined Radio” (SDR) uses a
sufficiently-fast computer to do the necessary
signal processing:
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GNU Radio is a open-source project to develop soft-
ware for SDR. It can also be used to simulate commu-
nication systems – which is how we will use it in this
lab.

1These simulations are sometimes called “Monte-Carlo” sim-
ulations because they use randomly-chosen data.

GNU Radio Companion

GNU Radio Companion (GRC) is a graphical design
tool that lets a user create GNU Radio software with-
out having to write code. Blocks representing signal
processing functions are added to a diagram, config-
ured, and connected using a graphical user interface.
This “flowgraph” is then turned into an executable
script that executes the processing blocks in the re-
quired order to process the samples. In this lab we
will use GRC to set up and run simulations.
An example of a flowgraph created by GRC is

shown in Figure 1.
A GNU Radio flowgraph can also send/receive

samples to/from radio hardware, files, network con-
nections and other GNU Radio flowgraphs2, al-
though we will not use these features in this lab.
GNURadio and similar tools such asMathWorks’s

Simulink and National Instrument’s LabView avoid
the need to write programs and the flowgraphs
are self-documenting. However, programming lan-
guages such as Matlab (e.g. using the Communica-
tions Toolbox) are more flexible.

Dataflow Flowgraphs

It may appear from the flowgraph that the blocks op-
erate simultaneously (in parallel). However, since
the blocks are implemented in software they must
execute sequentially. Buffers between blocks allow
them to process multiple samples each time a block
executes. A scheduler determines the order of block
execution by looking at the number of samples in
these buffers.
This “dataflow” architecture means that blocks

only execute when they have data to process. As a
result we can check for errors by comparing the first
bit input to the encoder to the first bit output by the
decoder without having to compensate for the delay
through the blocks.

2Including those written in programming languages such as
Python, C++ and Matlab.
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This buffering of samples introduces delay and
may affect operation of delay-sensitive processing in-
cluding feedback control.

𝐸b/𝑁0

𝐸b/𝑁0 is the number (“metric”) used to compare the
power efficiency of communication systems operat-
ing over AWGN channels. It is the ratio of the energy
per information bit3, (𝐸𝑏) to the noise power spectral
density (𝑁0).
Comparing systems on the basis of 𝐸b/𝑁0 rather

than the signal-to-noise ratio (SNR) allows us to com-
pare systems independent of their code rate or band-
width.
Assume that both the signal and noise are strictly

bandlimited to a bandwidth 𝐵 and that we sample at
the Nyquist rate 𝑓s = 2𝐵. We can convert the signal
power 𝑆 to bit energy 𝐸𝑏 by multiplying by the infor-
mation bit period or by dividing by the information
bit rate 𝑓b. We can compute the noise power spectral
density, 𝑁0 by dividing the noise power, 𝑁, by the
bandwidth 𝐵 = 𝑓s/2. Thus:

𝐸𝑏
𝑁0

= 𝑆
𝑁 ⋅ 𝑓s

2𝑓b
For example, when one information bit is trans-

mitted per sample (𝑓b = 𝑓s), 𝐸b/𝑁0 is half of the SNR
(–3 dB). When using a rate-1/2 code the information
bit rate (𝑓b) is halved and 𝐸b/𝑁0 is equal to the SNR.
For bipolar NRZ with signal levels of ±1 the value

of 𝑆 is 1 and for AWGN the value of𝑁 is 𝜎2 (the vari-
ance).

Software

You can install GNU Radio on your own computer
instead of using the lab PCs.
For Windows, a version is packaged with “Pothos

SDR” at https://downloads.myriadrf.org/
builds/PothosSDR/. You’ll also need to install
the matching version of Python (from https:
//www.python.org/downloads/windows/)4.
The first time you run GNU Radio Companion

you’ll need to allow the program to “fix” the instal-
lation by downloading additional Python modules.

3Information bits do not include the parity bits used for FEC.
4For PothosSDR-2021.07.25 you’ll need Python3.9 ((which

can be installed at the same time as other versions).

Procedure

In this lab we will use Gnu Radio Companion to set
up and run simulations.
You will build two simulation flowgraphs. The

first generates a pseudo-random bit sequence
(PRBS), converts the 0/1-valued bits to ±1, adds
zero-mean AWGN with a configurable standard
deviation (RMS voltage), applies a threshold (at 0 V)
to the sum of the signal plus noise, and compares the
transmitted and received bits to measure the error
rate. Figure 1 shows the flowgraph.
The second flowgraph adds a convolutional FEC

encoder before the channel and a Viterbi FEC de-
coder after the channel. The decoder corrects some
errors thus reducing the BER. This can provide “cod-
ing gain” as explained in the lectures.

Predictions and Measurement Spreadsheet

Prepare a spreadsheet showing:

(A) The signal RMS voltage: 1 for NRZ with levels
of ±1: √12 = √−12 = 1.

(B) The noise RMS voltage: 𝜎, the setting of
noise_voltage.

(C) The SNR in dB: 10 log ( 1
2

𝜎2
). You can also specify

the SNR and compute 𝜎 from the SNR as was
done in the spreadsheet example below.

(D) The value of 𝐸b/𝑁0 without rate-1/2 FEC. The
conversion from SNR to 𝐸b/𝑁0 is described
above. Note that the 𝐸b/𝑁0 for rate-1/2 FEC is
numerically equal to the SNR (column C).

(E) The log of the predicted BER without FEC
as a function of SNR. You can use spread-
sheet functions log10(normdist(0,1,𝜎,1))
to compute the log of the BER.

(F) The log of themeasured error rate without FEC:
log10(BER).

(G) The log of the measured error rate with FEC:
log10(BER)5.

Include values of SNR in your spreadsheet from
about 0 to 14 dB in steps of about 1 dB6.

5There is no close-form formula for the BER.
6At lower SNR’s the BER will remain at 0.5 and at higher

SNRs the error rate will be too low to measure.
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Figure 1: GNU Radio Companion flowgraph for bipolar NRZ over AWGN channel without FEC.
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μ σ t
Vrms Vrms dB dB

1 1.000 0.0 -3.0 -0.8
1 0.891 1.0 -2.0 -0.9
1 0.794 2.0 -1.0 -1.0
1 0.708 3.0 0.0 -1.1
1 0.631 4.0 1.0 -1.2
1 0.562 5.0 2.0 -1.4
1 0.501 6.0 3.0 -1.6
1 0.447 7.0 4.0 -1.9
1 0.398 8.0 5.0 -2.2
1 0.355 9.0 6.0 -2.6
1 0.316 10.0 7.0 -3.1
1 0.282 11.0 8.0 -3.7
1 0.251 12.0 9.0 -4.5
1 0.224 13.0 10.0 -5.4
1 0.200 14.0 11.0 -6.6

Using GRC

Start GRC. Under the View menu enable the Block
Tree Panel, Console Panel and Variable Editor. Make
sure ‘Hide Variables’ is not checked.
The easiest way to add a block is to search for it

by name. Click on the magnifying glass icon ( )
on the menu bar or type Control-F then type part of
the block name and double-click on the desired block
name. You can move a block by dragging it (any con-
nections will follow).

To connect outputs to inputs: click on the output
port and then click on the input port youwant to con-
nect it to.
As in any diagram, the blocks should be arranged

so that the logical flow is left-to-right and top-to-
bottom whenever possible.
Samples can be of different types. Bits are typi-

cally transferred in the least-significant bit of a Byte
type and signal samples are typically Float or Com-
plex types. In GRC the color of the input and out-
put connectors reflects the signal type (e.g. violet for
byte, orange for float, blue for complex). If there is a
mismatch between output and input signal types the
connector will be drawn in red.
You can double-click on a block to open up its
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properties dialog box. This allows you to configure
the input and output types and other aspects of the
block’s operation. The block’s title and some of the
block’s properties are displayed inside the block in
the flowgraph.
Some blocks define data structures rather than

process samples. An example isVariable blocks that
set the value of a variable. This variable can be used
when configuring other blocks. By default a variable,
samp_rate, is included in a newflowgraph. Another
example is the FEC encoder and decoder definition
blocks. These set up data structures that define the
operation of separate encoder and decoder blocks.

Configure the First Flowgraph

Use the File▶Openmenu item to start a newQTGUI
flowgraph. Then add, configure, and connect the fol-
lowing blocks:

Variable Add a variable with ID noise_voltage.
This will be used to set the RMS voltage, the
standard deviation, of the noise (𝜎).

GLFSR Source This block generates a PRBS. Con-
figure this block as follows:

Degree is𝑁, the number of bits in the shift reg-
ister. The sequence repeats after 2𝑁−1 bits. Use
a value that is large enough to test the blocks in
your simulation. The value used here is 𝑁 =
20 which will generate a PRBS of about 1 mil-
lion bits and whose longest run of 1’s is 20 bits.
Mask defines the LFSR taps. If left as 0, a suit-
able generator polynomial for the specified de-
gree will be chosen.

Type Conversions Various conversions from bits to
floating point values will be required. For ex-
ample, the GLFSR Source is configured to out-
put bits (stored in the least-significant bit of each
byte) but these need to be converted to Float val-
ues for transmission over an AWGN channel.
Add a Char To Float block wherever this con-
version is required.

Since the input to the BER counter is packed
bytes (8 bits/byte), a block is required to pack 8
1-bit values to one 8-bit byte. Add and configure
Pack K Bits blocks with 𝐾 = 8.

Noise Source Add a Gaussian noise source with a
Float output whose amplitude is set by the vari-
able noise_voltage. It is configured as fol-
lows:

AWGN channel The AWGN channel is composed
of three blocks: Char To Float converts 0/1 val-
ues to Float values and scales by 1

2
to produce

values of 0 and 2 (the scaling value is in the de-
nominator). TheAdd Const adds -1 to produce
values of -1 and 1. TheAdd block adds the noise
to the signal. These blocks should have types set
to Float and Vec(tor) lengths of 1 sample.

Binary Slicer This block compares the input to a
threshold at 0 and outputs bits that are 0 or 1.

BER This block compares sequences of byte inputs
and computes the number of bits that differ. The
output is the log of the bit error rate as a float-
ing point number. The computation includes all
bits since the start of the simulation.

QT GUI Time Sink This block is similar to an oscil-
loscope and displays a graph of the input sam-
ple values as a function of time. These can be
used to verify that the simulation is operating
as expected. Two of these are included in the
flowgraph below. One displays the output of the
channel (signal plus noise). The second displays
the bits into the transmitter and out of the re-
ceiver.

QT GUI Number Sink This block displays a single
number while the simulation is running. It can
show the value as bar graph.
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Both GUI blocks have configuration options for
how they should be displayed in the window
that is created when the flowgraph executes. In
addition to input types, ranges, labels, etc, the
GUI Hint provides some control over the posi-
tioning of the GUI elements within tabs. For ex-
ample, a hint of [1,2]means to place that GUI
element on the first row, second column.

Measure the BER

Double-click on the noise_voltage block or that line
on the variables sub-window and set the noise RMS
voltage to the first value in your spreadsheet.
Select Run ▶ Execute, press F6, or press on the

run ( ) icon. This will convert the flowgraph to a
Python script and run it.
TheGUIwill show the bits at the input to the trans-

mitter, the output of the receiver and the output of the
channel. The GUI Number Sink will display log10 of
the BER.
Wait until the BER appears stable and record the

value. Take a screen capture of theGUIwindow, then
close the GUI window to stop the simulation.
Repeat the steps above, except for the screen cap-

ture, for the other 𝐸b/𝑁0 values in your spreadsheet
and verify that the results match your predictions.
Select File ▶ Screen Capture to save an image file

showing your flowgraph.

Add FEC

Save and copy the .grc file to a new file and modify
the flowgraph by adding the following FEC compo-
nents as shown in Figure 2.

CC Encoder/Decoder Definition These blocks
define the convolutional code used by the
encoder and decoder. You can define con-
straint length (𝐾), rate (𝑅) and the generator
polynomials used to generate the two output
bits. The current implementation is limited
to the standard rate- 1

2
convolutional encoder

described in the lecture notes.

Configure these blocks as follows:

The mode should be set to “streaming” (the
othermodes are for packet-based systemswhere
the shift-register needs to be flushed).

FEC Extended Encoder/Decoder These blocks
perform the encoding and decoding as config-
ured by the encoder and decoder definitions.
The encoder has unpacked bits as input and
ouput. The decoder expects float input (±1) and
generates unpacked bits as output. Configure
these blocks as follows:

Re‑Measure the BER

Re-measure the BER vs 𝐸b/𝑁0 and add the data to
your spreadsheet.
Select File ▶ Screen Capture to get an image file

showing your second flowchart.
Plot BER vs 𝐸b/𝑁0 with and without FEC on the

same graph. Your graph might look something like:

Lab Report

Plot themeasuredBERwith andwithout FECagainst
𝐸b/𝑁0.
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Figure 2: GNU Radio flowgraph for bipolar NRZ over AWGN channel with convolutional FEC code and
Viterbi decoder.

Use the graph to estimate the coding gains at BERs
of 10−2 and 10−6.
Submit a report in PDF format to the appropriate

dropbox on the courseweb site containing the follow-
ing:

• your two flowchart diagrams

• a screen capture of a run-time GUI window
showing the signal on the channel, the input
and output bits and the log10(BER) value

• the spreadsheet showing your data

• the plot with two curves showing BER vs 𝐸b/𝑁0
with and without FEC

• your calculations of the coding gains for BERs of
10−2 and 10−6. You can read the 𝐸b/𝑁0 values
from the plot.
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