
ELEX 4340 : Data Communications
2015 Fall Session

Signal Capture and Analysis

Introduction

epurpose of this lab is to capture waveforms with a
digital oscilloscope and analyze the captured signals
using numerical analysis soware and spreadsheets.

You’re already familiar with measurements of de-
terministic signals such as sine and square waves.
However, some signals are unpredictable (random)
and we cannot describe them as voltages or currents
as functions of time.

However, we can describe their statistics, which are
summaries of some relevant feature of the signal such
as the fraction of time it has a certain voltage (the
“probability density”) or the amount of power the sig-
nal contains at certain frequencies (the “power spec-
trum”).

Examples of these random signals include speech
and noise sources.

In this lab we will study two deterministic and one
randomsignal andmeasure someof their statistics in-
cluding the probability density.

You will measure the statistics of the three wave-
forms that can be generated by the lab’s waveform
generator: a square wave, a sine wave, and Gaussian
noise:
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You will capture these waveforms with a digital os-
cilloscope. en you will use Matlab to compute his-
tograms that estimate the probability density func-
tions of the waveforms. e histogram data will be
imported into a spreadsheet that you will use to plot
the histograms, compute the RMS powers from the
probabilities and compare them to the powers mea-
sured using an RMS voltmeter and the oscilloscope’s
measurement function.

Software

Numerical Analysis Software

Numerical analysis soware allows us to carry out a
much wider range of signal-processing and analysis
than we could do on an oscilloscope.

For this lab you we will use Matlab or the free
and largely compatible alternatives FreeMat or Oc-
tave. Many other soware packages, both commer-
cial and open-source, are also available. Some of
themost popular includeMathematica,Maple,Math-
CAD, and R1.

All of these programs have high-level language fea-
tures such as support for working with complex vec-
tors and matrices that allows us to analyze signals
with relatively little programming.

Spreadsheets

You are probably already familiar with spreadsheets
from previous courses. ey are useful for manipu-
lating and presenting limited amounts of data and for
formatting numerical data for reports.

For this lab you can use Microso Excel or Libre-
Office Calc.

CSV Files

Text files contain printable characters that form read-
able text. On the other hand, “binary” files contain
data in formats that are only meant to be read and
written by soware.

A common text file format for exchanging nu-
merical data between programs is called comma-
separated values (CSV). Each line of the file corre-
sponds to one row of a matrix or table and the values
for each column are separated by commas.

Here’s an example of a CSV file with data that could
be used to fill a table consisting of four columns and
three rows:

1See Wikipedia for a more complete list.
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2.6,2.6, 1.3, .006
9.7, 1.734e-2, 1.1, 3
-0.3, .87, 0.45, 22

Strings can also be included inCSVfiles by quoting
them although in this lab we will restrict ourselves to
CSV files with numerical values.

Procedure

Waveform Capture

As shown below, connect the output of the waveform
generator to both Channel 1 of the ’scope and the
voltmeter so you can view the waveform andmeasure
its voltage on the DMM simultaneously. e ’scope
will sample the input signal and digitize it (convert
it to a number). e RMS voltmeter will allow you
to measure the RMS voltage independently of the
’scope.

Note that the multimeters in the lab are are RMS-
responding. Some DMMs are average-responding

and only measure the average value of a signal. For
these DMMs the voltage reading only corresponds to
the RMS voltage when the signal is a sine wave.

Set up the waveform generator for a square-wave
output at a 1 kHz frequency with a 6 Vpp level and
zero offset.

Use the ’scope’s Measurement menu to add fre-
quency and Vrms (RMS), Vavg (average) and Vamp
(peak-to-peak amplitude) voltage measurements to
the display.

Use the Acquire menu to set the memory Depth to
140 kSamples. Use the Scale control in theHorizontal
controls section for a sampling rate of 1 MHz. ese
values will be visible in the status line at the top of the
display.

Press the Horizontal scale knob to switch to de-
layed trigger mode. is will show a portion of the
captured samples. Adjust the horizontal scale so you
can view a few cycles of the square wave:

Use the DMM to measure the RMS value of the
waveform. It should match the ’scope measurement
value.
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Plug a flash drive into the connector on the front
of the ’scope. Press the printer icon on the top right
of the panel to capture an image of the display. e
image file name will be displayed briefly.

Use the Storage menu to save the captured data to
your flash drive. Under “Storage” select CSV for the
file type, Channel 1 for the source, “Maximum” for
the Data Depth and enable Parameter Save.

Press Save to select the folder (directory) and file
name under which to save the file. If you wish, you
can create a new folder on the flash drive and a new
file name.

Record the date and time, the type of waveform,
the voltage shown on the DMM, the three measure-
ment values on the ’scope and the names of the image
and waveform capture files. You will need this infor-
mation for your report.

Change the signal generator to a sine-wave out-
put and check that (peak-to-peak) voltage is still 6 V.
Check that the average (DC) voltage is approximately
zero.

Repeat the steps above, saving image and wave-
form capture files and recording the various instru-
ment readings.

Now configure the waveform generator for (Gaus-
sian) noise output with a level of 1.3 Vrms and zero
offset. Again, save the image and waveform capture
files to your flash drive and record the same informa-
tion as before.

You should now have three sets of voltage readings,
three display files and three waveform files.

e rest of the lab can be done without test equip-
ment but you should try to do asmuch of it as possible
during the lab session in case you need to repeat some
of your measurements.

Import Samples intoMatlab

Run Matlab, Freemat or Octave. Use the cd com-
mand to change to the directory where you have
copied the files for this lab (e.g. a folder on your H:
network drive).

e CSV file saved by the ’scope should start with
two rows of information that we need to skip, fol-
lowed by the sample number and the voltage as shown
below:

X,CH1,Start,Increment,
Sequence,Volt,-3.5000000000e-005,5.0000000000e-010,

0,-1.520000e+00,
1,-1.760000e+00,
2,-2.040000e+00,
3,-2.240000e+00,

You can read the waveform data from the CSV
waveform sample file using the commands:

s=csvread('Newfile1.csv');
s=s(3:140002,2);

which will read the CSV file and the extract 140,000
rows from the second column starting at the third
row. You may have to prefix the file name with the
drive letter and folder name.

Plot the first 2000 samples of thewaveform tomake
sure you captured and have read the waveform cor-
rectly:

plot(s(1:2000))

Use the File->Save As menu item in the plot win-
dow or use the Windows ‘Snipping’ tool to save this
plot to an image file (.png format) so that you can
include it your report later.

Compute themean andRMSvalues of the captured
waveform:

mean(s)
std(s)

Compute the Histogram

e ’scope uses anA/D converter which quantizes the
input signal into discrete voltage levels.

e measured voltages can only have certain spe-
cific values separated by steps equal to the quantiza-
tion step size. For example if the input voltage was
1.63 volts and the step size was 0.08 volts, the ’scope
might measure this as 1.60 or 1.68 volts.

When computing the histogram of the signal we
should use a bin width equal to the step size to make
sure we include exactly one voltage range per bin.

We can find the step size by examining the voltage
levels measured by the ’scope. e Matlab function
unique() returns a sorted list of the unique values
in the input. Assuming we have at least two values
separated by the step size we can find the step size as
the minimum difference between successive unique
values:
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ssize=min(diff(unique(s)))

where the sequence of unique, diff and min opera-
tions compute the minimum difference between suc-
cessive unique measured voltages.

e step size can then be used to compute the num-
ber of histogram bins we should use:

nbin=(max(s)-min(s))/ssize + 1

Compute a histogram of the voltage waveform us-
ing the hist() function:

[n,v]=hist(s,nbin);

which will return a vector n with the number of sam-
ples values in each histogram bin and a vector v with
the voltages at the midpoints of each bin.

We can then export the histogram to a CSV file by
opening a file for writing:

fo=fopen('lab2square.csv','w')

and writing the values to the file as strings separated
by commas, two per line:

fprintf(fo,'%f, %d\n',[v;n])

and closing the file:

fclose(fo)

Repeat for the sine wave and Gaussian noise cap-
ture files, saving them to different CSV files and
recording your results for the mean and standard de-
viation (rms voltage). You can use the cursor keys
and/or the command history window to repeat pre-
vious commands and minimize typing.

Compute RMS Voltage

e RMS (root mean square) voltage of a signal is de-
fined as the square root of the mean (average) of the
square of the voltage. In cases where different volt-
ages have different probabilities we must scale each
voltage (or its corresponding power) by the proba-
bility of that power and then compute the sum. For
example, if 20% of the values had a power of 0.3W
and 80% had a power of 0.2W then the average power
would be .×.+.×. = .+. = ..

We can use a spreadsheet to do this calculation on
the histogram values stored in the CSV file.

Run Excel or LibreOffice Calc. Open the CSV file
(File->Open) which will result in a spreadsheet with
two columns, the first with the bin counts and the sec-
ond with the bin voltages. Note: Immediately save the
file in .xls format or you will lose all your work when
you exit the program!

Enter a formula at the bottom of the first column to
compute the total number of samples (this should be
140,000). Add additional cells with formulas that di-
vide by this value to convert the bin counts to proba-
bilities2. ese should sum to 1. en add additional
cells that compute the square of each bin voltagemul-
tiplied by the probability of that voltage. Compute the
sumof these scaled squared voltages. is is themean
square voltage. Finally, compute the square root of
the mean square voltage. is is the RMS voltage of
the waveform.

Here is an example showing the spreadsheet
columns containing bin voltages, bin counts, bin
probabilities and scaled squared voltages. e bot-
tom row contains sums of the bin counts, probabili-
ties, and the mean-square and RMS voltages.

Repeat using the histogram bin counts for the sine
and Gaussian noise waveforms, importing their data
into different sheets of the same document (Data-
>Get External Data or Import->Sheet from File).
Compare your results to the values read from the
’scope and DMM.

Plot Histograms

Create two line graphs (charts) with curves showing
the values of the sine wave and Gaussian noise his-
tograms. Use Insert->Chart, set the chart type to an
XY Line graph and use the voltages as the X values
and the histogram sample counts as the Y values. Add
an accurate title, sub-title andX andY axis labels. Ad-
just the chart properties so it is formatted as shown
below.

2To insert a reference to an absolute rather than relative cell,
prefix the cell and/or row with a dollar sign ($). For example,
$A$101.
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Signal Bandwidth and VoltageMeasurement

You may find that the power of the noise measured
by the DMM does not match the power measured by
the ’scope. is is because the noise power is dis-
tributed over a bandwidth ofmany tens ofMHzwhile
the DMM only responds to signals at low (audio) fre-
quencies 3. is means the DMM cannot follow the
actual input signal and measures a smaller voltage
than is present at the input.

On the other hand, the bandwidth of the ’scope
(also many tens of MHz) is close to the bandwidth of
the noise so the ’scope measurement is closer to the
actual value.

Pre-Lab Report

Submit a report containing a title, the lab number,
your name, your student number, and the answers to
the following questions:

• What are the average and RMS voltages of a
square and sine sine wave as a function of the
waveform’s peak-to-peak voltage?

3eDMMfrequency response specifications are in the Spec-
ifications chapter in the manual available on the course web site

• A signal switches randomly between two levels,
-2V and +1V. e level is +1V 30% of time and -
2V 70% of the time. What is the average voltage?
What is the RMS voltage? Draw the probability
density function (you can draw impulses whose
heights correspond to the probability of a partic-
ular voltage).

• If the ’scope has a 12-bit A/D converter, how
many different voltage levels can it resolve? If
the display was set to ±4 V, approximately what
minimum voltage difference would you expect
to see between the sampled voltages?

Lab Report

Upload three files to the dropbox folder for this lab:

1. the histogramCSV file for the sine wave input in
CSV (.csv) format

2. the Excel (or LibreOffice Calc) spreadsheet file
in Excel (.xls) format (any version) containing
the three sheets and three charts

3. your report in PDF (.pdf) format

Your report should include:
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• student and lab identification as described in the
first lab,

• plots of the first 2000 samples of each of the three
sampled waveforms,

• the two histograms created by your spreadsheet
(use copy and paste rather than the ’snip’ tool),

• a table comparing the RMS voltages measured
by the DMM, the ’scope and computed from the
histogram for each of the three waveforms
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