ELEX 3525: Data Communications
2023 Fall Term

Communication System Simulation

Hint: It’s a good idea to read and understand the instructions in full before starting a procedure.

Introduction

Computer simulations are the most practical way to
predict the performance of modern communication
systems. These simulations can include the effects
of complex processing such as FEC and impairments
such as fading.

Simulations of communication systems operate on
sampled signals. For example, we can generate ran-
dom bits and random noise samples and apply the
same operations on these signals that an actual trans-
mitter, channel and receiver would!. Then we can
measure the performance (e.g. the BER) of the simu-
lated system.

Such computer simulations are typically written
in a programming language such as C or Matlab us-
ing libraries of functions that perform various signal
processing functions such as signal and noise gener-
ation, filtering, modulation, coding, etc.

In this lab you will simulate the operation of a com-
munication system that uses bipolar NRZ signalling
over an AWGN channel together with a rate-1/2 con-
volutional encoder and a Viterbi decoder. You will
compare the BER vs. E,/N, curves for systems with
and without FEC and determine the coding gain at
different BERs.

GNU Radio

A sufficiently-fast computer can be used to imple-
ment the signal processing for wireless communica-

tions. This is known as “Software Defined Radio”
(SDR).
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GNU Radio is a open-source project to develop
software for SDR systems. GNU Radio software can

!These simulations are sometimes called “Monte-Carlo” sim-
ulations because they use randomly-chosen data.
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also be used to simulate communication systems —
which is how we will use it in this lab.

GNU Radio Companion

GNU Radio Companion (GRC) is a graphical design
tool that lets a user create GNU Radio software with-
out having to write code. Blocks representing signal
processing functions are added to a diagram, config-
ured, and interconnected using a graphical user in-
terface. This “flowgraph” is then turned into an exe-
cutable script that executes the processing blocks in
the required order to process the samples. In this lab
we will use GRC to set up and run simulations.

An example of a flowgraph created by GRC is
shown in Figure 1.

A GNU Radio flowgraph can also send/receive
samples to/from radio hardware, files, network con-
nections and other GNU Radio flowgraphs?, al-
though we will not use these features in this lab.

The advantages of GNU Radio and similar tools
such as MathWorks’s Simulink and National Instru-
ment’s LabView are that they don’t require pro-
gramming and that the flowgraphs can be self-
documenting. However, experienced users tend to
prefer programming languages such as Matlab (e.g.
using the Communications Toolbox), because they
are more flexible.

Dataflow Flowgraphs

It may appear from the flowgraph that the blocks op-
erate simultaneously (in parallel). However, since
the blocks are implemented in software they must ex-
ecute sequentially. For efficiency reasons there are
buffers between blocks that allow blocks to process
multiple samples each time the block is executed.
The order in which blocks are executed is determined
by a scheduler that examines the amount of data
available on the input ports of each block.

2Including those written in programming languages such as
Python, C++ and Matlab.
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Figure 1: GNU Radio Companion flowgraph for bipolar NRZ over AWGN channel without FEC.

This “dataflow” architecture means that blocks
only execute when they have data to process. As a
result we can compare the first bit output by the de-
coder with the first bit input to the encoder without
having to compensate for the processing delay of the
blocks.

Note that this buffering of samples increases la-
tency and can prevent proper operation of certain
delay-sensitive applications such as those using feed-
back control.

Ey/Ny

Ey /Ny is the “metric” (numerical value) used to com-
pare the power efficiency of communication systems
operating over AWGN channels. It is the ratio of the
energy per information bit®, (E},) to the noise power
spectral density (INp).

Comparing systems on the basis of E,/N, rather
than the signal-to-noise power ratio (SNR) allows us
to compare systems that may transmit at different
rates (e.g. due to using FEC or multi-level signalling)
or that use different bandwidths (e.g. due to using
different line codes or modulation).

3Information bits do not include the parity bits used for FEC.

Assume that both the signal and noise are strictly
bandlimited to a bandwidth B and that we sample at
the Nyquist rate fi = 2B. We can convert the signal
power S to bit energy E;, by multiplying by the infor-
mation bit period or by dividing by the information
bit rate f1,. We can compute the noise power spectral
density, N, by dividing the noise power, N, by the
bandwidth B = f/2. Thus:

Eb S_fs

N, N 2f,

With one sample per information bit (f, = f),
Ey/Nyishalfof the SNR (-3 dB). When using a rate-1/2
code the information bit rate (f},) is halved and E}, /N,
is equal to the SNR.

For bipolar NRZ with signal levels of +1 S = 1 and
for AWGN N = o2,

Procedure

You will build two simulation flowgraphs. The first
generates a PRBS, converts the 0,1-valued bits to +1,
adds zero-mean AWGN with a configurable standard
deviation (o, the RMS voltage), applies a threshold (at
0V) to the sum of the signal plus noise, and compares
the transmitted and received bits to measure the error
rate. The diagram in figure 1 shows the flowgraph.



The second flowgraph adds a convolutional FEC
encoder before the channel and a Viterbi FEC de-
coder after the channel. The decoder corrects some
errors thus reducing the BER. This provides a “cod-
ing gain” as explained in the lectures.

Using GRC

Start GRC. Under the View menu enable the Block
Tree Panel, Console Panel and Variable Editor. Make
sure ‘Hide Variables’ is not checked.

The easiest way to add a block is to search for it by
name. Click on the magnifying glassicon ( © ) on the
menu bar or type Control-F:

Single Pole IR Filter
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then type part of the block name and double-click on
the desired block name. You can move a block by
dragging it (any connections will follow).

To connect outputs to inputs: click on the output
port and then click on the input port you want to con-
nect it to.

As in any diagram, the blocks should be arranged
so that the logical flow is left-to-right and top-to-
bottom whenever possible.

Samples flowing between blocks can be of differ-
ent types. Bits are typically transferred in the least-
significant bit of a Byte type and signal samples are
typically Float or Complex types. In GRC the color
of the input and output connectors reflects the signal
type (e.g. orange for bytes, violet for float).

If there is a mismatch between the signal types the
connector will be drawn in red.

You can double-click on a block to open up its
properties dialog box. This allows you to configure
the input and output types and other aspects of the
block’s operation. The block’s title and some of the
block’s properties are displayed inside the block in
the flowgraph.

Some blocks define data structures rather than
process samples. An example is Variable blocks that
set the value of a variable. This variable can be used
when configuring other blocks. By default a variable,
samp_rate, isincluded in a new flowgraph. Another
example is the FEC encoder and decoder definition
blocks. These set up data structures that define the
operation of separate encoder and decoder blocks.

Configure the First Flowgraph

Use the File » Open menu item to start a new QT
GUI box. Then add, configure and connect up the
following blocks:

Variable Add a variable with ID noise_voltage.
This will be used to set the RMS voltage (which
is the standard deviation, o) of the noise.

GLFSR Source This block generates a PRBS. The
implementation is different than that described
in the lecture notes to allow more efficient im-
plementation in software, but the PRBS has the
same properties. Configure this block as fol-
lows:

Type Byte |v
Degree 20
Repeat Yes |v

Mask 0

Seed 1

Degree is N, the number of bits in the shift reg-
ister. The sequence repeats after 2V —1 bits. Use
a value that is large enough to test the blocks in
your simulation. The value used here is N =
20 which will generate a PRBS of about 1 mil-
lion bits and whose longest run of 1’s is 20 bits.
Mask defines the LFSR taps. If left as 0, a suit-
able generator polynomial for the specified de-
gree will be chosen.

Type Conversions Various conversions from bits to
floating point values will be required. For ex-
ample, the GLFSR Source is configured to out-
put bits (stored in the least-significant bit of each
byte) but these need to be converted to Float val-
ues for transmission over an AWGN channel.
Add a Char To Float block wherever this con-
version is required.



Since the input to the BER counter is packed
bytes (8 bits/byte), a block is required to pack 8
1-bit values to one 8-bit byte. Add and configure
Pack K Bits blocks with K = 8.

Noise Source Add a Gaussian noise source with a
Float output whose amplitude is set by the vari-
able noise_voltage. It is configured as fol-

lows:
Output Type Float v
Noise Type Gaussian
Amplitude noise_voltage
Seed 0

AWGN channel The AWGN channel is composed
of three blocks: Char To Float converts 0/1 val-
ues to Float values and scales by Ito produce
values of 0 and 2 (the scaling value is in the de-
nominator). The Add Const adds -1 to produce
values of -1 and 1. The Add block adds the noise
to the signal. These blocks should have types set
to Float and Vec(tor) lengths of 1 sample.

Binary Slicer This block compares the input to a
threshold at 0 and outputs bits that are 0 or 1.

BER This block compares sequences of byte inputs
and computes the number of bits that differ. The
output is the log of the bit error rate as a float-
ing point number. The computation includes all
bits since the start of the simulation.

Test Mode False v
BER Min. Errors 10
BER Limit -10.0

QT GUI Time Sink This block is similar to an oscil-
loscope and displays a graph of the input sam-
ple values as a function of time. These can be
used to verify that the simulation is operating
as expected. Two of these are included in the
flowgraph below. One displays the output of the
channel (signal plus noise). The second displays
the bits into the transmitter and out of the re-
ceiver.

QT GUI Number Sink This block displays a single
number while the simulation is running. It can
show the value as bar graph.

Both GUI blocks have configuration options for
how they should be displayed in the window
that is created when the flowgraph executes. In
addition to input types, ranges, labels, etc, the
GUI Hint provides some control over the posi-
tioning of the GUI elements within tabs. For ex-
ample, a hint of [1, 2] means to place that GUI
element on the first row, second column.

Measure the BER

Double-click on the noise_voltage block or that line
on the variables sub-window and set the noise RMS
voltage to the first value in your spreadsheet.

Select Run » Execute, press F6, or press on the
run (| =) icon. This will convert the flowgraph to a
Python script and run it.

The GUIwill show the bits at the input to the trans-
mitter, the output of the receiver and the output of the
channel. The GUI Number Sink will display log, , of
the BER.

Wait until the BER appears stable and record the
value. Take a screen capture of the GUI window, then
close the GUI window to stop the simulation.

Repeat the steps above, except for the screen cap-
ture, for the other Ey/N, values in your spreadsheet
and verify that the results match your predictions.

Select File » Screen Capture to save an image file
showing your flowgraph.

Add FEC

Save and copy the .grc file to a new file and modify
the flowgraph by adding the following FEC compo-
nents as shown in Figure 2.

CC Encoder/Decoder Definition These blocks
define the convolutional code used by the
encoder and decoder. You can define con-
straint length (K), rate (R) and the generator
polynomials used to generate the two output
bits. The current implementation is limited
to the standard rate—% convolutional encoder
described in the lecture notes.

Configure these blocks as follows:



D decoder

D encoder
Parallelism 0 |v
Parallelism 0 v
Frame Bits 2048
Frame Bits 2048

Constraint Length (K) &

Constraint Length (K) F
Rate Inverse (1/R) (1/2) |2

Rate Inverse (1/R) (1/2) 2

Polynomials _
Polynomials
m - Start State 0
Start State 0
End State -1
Streaming Behavior  Streaming & -
reaming Behavior i
Byte Padding No | 9 streaming
Byte Padding No |v

The mode should be set to “streaming” (the
other modes are for packet-based systems where
the shift-register needs to be flushed).

FEC Extended Encoder/Decoder These blocks
perform the encoding and decoding as config-
ured by the encoder and decoder definitions.
The encoder has unpacked bits as input and
ouput. The decoder expects float input (+1) and
generates unpacked bits as output. Configure
these blocks as follows:

Decoder Objects
Threading Type

Encoder Objects decoder

Threading Type

encoder

None
None

Annihilator None

Puncture Pattern
Puncture Pattern

Re-Measure the BER

Re-measure the BER vs E, /N, and add the data to
your spreadsheet.

Select File p Screen Capture to get an image file
showing your second flowgraph.

Plot BER vs E,/N, with and without FEC on the
same graph. Your graph might look something like:
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Lab Report

Prepare a spreadsheet showing:

(A) Thesignal RMS voltage: 1 for NRZ with levels of
+1. In this case 4 = +1 since \/? =vV-12=1.

(B) The noise RMS voltage:
noise_voltage.

o, the setting of

(C) The SNR in dB: 201log <E) You can also specify

ag
the SNR and compute o from the SNR as was
done here.

(D) The value of E,/N, without rate-/2 FEC. The
conversion from SNR to E,/N, is described in
the introduction. Note that the E, /N, with rate-
1/2 FEC is numerically equal to the SNR (column
O).

(E) The log of the predicted BER without FEC as a
function of SNR. You can use spreadsheet func-
tions 1log10(normdist(0,u,0,1)) to compute
the log of the BER.

(F) The log of the measured error rate - log, ,(BER)
- without FEC.

(G) The log of the measured error rate - log, ,(BER)
- with FEC*.

Include values of SNR in your spreadsheet from
about 0 to 14 dB°.

A [ B ] < o I & 1T f ] &
. . SNRand = Eb/No predicted measured measured
signal noise K log(BER) = log(BER)
voltage = voltage Fb/No without without = without '°g(BER)
with FEC FEC with FEC
. FEC FEC
Z n o t
3 Vrms Vrms dB dB
| 4 | 1 1.000 0.0 3.0 -0.8
| 5 | 1 0891 1.0 2.0 0.9
|6 | 1 079 2.0 -1.0 1.0
7] 1 0708 3.0 0.0 11
8 1 0631 4.0 1.0 1.2
9] 1 0562 5.0 20 1.4
[10] 1 0501 6.0 3.0 1.6
11 1 0447 7.0 4.0 1.9
[12] 1 0398 8.0 5.0 22
13 1 0355 9.0 6.0 2.6
14| 1 0316 10.0 7.0 3.1
|15 | 1 0282 11.0 8.0 3.7
116 | 1 0251 12.0 9.0 45
117 1 0224 13.0 10.0 5.4
[ 18] 1 0.200 14.0 11.0 6.6

Plot the predicted and measured BER without FEC
and the measured BER with FEC against E;,/N,.

Use the graph to estimate the coding gains at BERs
of 1072 and 107°.

Submit a report in PDF format to the appropriate
dropbox on the course web site containing the follow-
ing:

“There is no closed-form formula for the BER with FEC.
SAt lower SNR’s the BER will remain at 0.5, at higher SNRS
the error rate will be too low to measure.
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Figure 2: GNU Radio flowgraph for bipolar NRZ over AWGN channel with convolutional FEC code and

Viterbi decoder.

your two flowgraph diagrams

your screen capture of the run-time GUI win-

dow showing the signal on the channel, the in-
put and output bits and the log, ,(BER) value

102 and 107°.

the spreadsheet showing your data

the plot with two curves showing BER vs E;, /N,
with and without FEC

your calculations of the coding gains for BERs of
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