
ELEX 3525 : Data Communications
2022 Fall Term

Signal Capture and Analysis

Revision 2: added instructions to remove headers and save the CSV file.

Introduction

Onepurpose of this lab is to capturewaveformswith a
digital oscilloscope and analyze the captured signals
using numerical analysis software and spreadsheets.
Another is to measure a random signal. You’re

already familiar with measurements of predictable
(“deterministic”) signals such as sine and square
waves. However, some signals are unpredictable
(“random”) and we cannot predict their future volt-
ages or currents. Typical examples include noise or
speech signals.
Although we cannot predict their values, we can

often specify random signals’ statistics, which are
summaries of some relevant feature of the signal such
as the fraction of time it has a certain voltage (the
“probability density”) or the amount of power the sig-
nal contains at certain frequencies (the “power spec-
trum”).
In this lab youwill measure some statistics of three

waveforms that can be generated by the lab’s arbi-
trary waveform generator (AWG): a square wave, a
sine wave, and Gaussian noise:
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Youwill capture these waveformswith a digital os-
cilloscope. Then you will use the Octave1 software
to compute histograms that estimate the probability
density functions of the waveforms. The histogram
data will be imported into a spreadsheet that you will
use to plot the histograms, compute the RMS powers
from the probabilities and compare them to the pow-
ers measured using an RMS voltmeter and the oscil-
loscope’s measurement function.

1You should also be able to use Matlab with some minor

Software

Numerical Analysis Software

Numerical analysis software can do a wider range of
analysis than an oscilloscope.
For this lab you will use Octave. Many other soft-

ware packages, both commercial and open-source,
are also available. Some of the most popular include
Matlab (largely Octave-compatible), Mathematica,
Maple, MathCAD, and R2.
All of these languages have features, such as sup-

port for working with complex vectors and matrices
that allow you to analyze signals with little or no pro-
gramming.

Spreadsheets

You should be familiar with spreadsheets from pre-
vious courses. They are useful for manipulating and
presenting limited amounts of data and for format-
ting numerical data for reports.
For this lab you can use Microsoft Excel or Libre-

Office Calc.

CSV Files

Text files contain printable characters that form read-
able text. On the other hand, “binary” files contain
data in formats that are only meant to be read and
written by software.
A common text file format for exchanging nu-

merical data between programs is called comma-
separated values (CSV). Each line of the file corre-
sponds to one rowof a table (ormatrix) and the values
for each column are separated by commas.
Here’s an example of a CSV file with data that

could be used to fill a table consisting of four columns
and three rows:

2.6,2.6, 1.3, .006

changes to the commands.
2See Wikipedia for a more complete list.
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Figure 1: Steps in the processing of signals and data.

9.7, 1.734e-2, 1.1, 3
-0.3, .87, 0.45, 22

Strings can be included in CSV files by quoting
them but in this lab we will only use numerical val-
ues.

Voltage Measurements

AC and DC Coupling

Most DMMs and ’scopes, have an “AC” (alternating
current) setting that connects the input through a ca-
pacitor. This removes the average voltage and allows
accurate measurements of time-varying signals su-
perimposed on much larger constant (DC) voltages.

RMS and Average Voltage

An RMS voltage measurement squares the signal be-
fore averaging. Thismeasures (the square root of) the
power of the signal.
DMMs typically display the average voltage when

DC coupling is used and the RMS voltage when
AC coupling is used3. Some DMMs also have an
“AC+DC” measurement that measures the RMS
voltage with DC coupling.
Oscilloscopes can measure many statistics of a sig-

nal including average and RMS voltages with either

3If a DMM is not “true RMS,” it still measures the average
voltage andmultiplies it by 2/𝜋√2 ≈ 0.707/0.636 ≈ 1.11which is the
ratio of RMS to average voltage for sine waves. For other wave-
forms the RMS measurements will be incorrect.

AC or DC coupling as well as other statistics, such as
the peak-to-peak voltage.

Effect of Bandwidth

You will find that the power of the noise measured
by the DMM does not match the power measured by
the ’scope. This is because the noise signal’s power
is distributed over a frequency range (bandwidth) of
tens of MHz while the DMM you will be using only
responds to signals at low (audio) frequencies 4. This
means the DMM’s input circuits “smooth out” the
signal and the DMMmeasures a smaller voltage than
is present at the input. For example, the following
graph shows a noise signal before (blue) and after
(green) low-pass filtering:
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You can see that the low-pass filtered version has less
variability (lower “variance”) and thus has less power
than the unfiltered signal.

4TheDMM frequency response specifications are in the Spec-
ifications chapter in themanual available on the course web site.
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The bandwidth of the ’scope (also tens of MHz) is
close to the bandwidth of the noise so the ’scopemea-
surement is closer to the actual value.

Procedure

Connect the AWG Channel 1 output to the ’scopes’s
Channel 1 input and the voltmeter as shown below
so that you can view the waveform and measure its
voltage on the DMM simultaneously. The ’scope will
sample the input signal and quantize it (convert each
sample to a number). The RMS voltmeter will allow
you tomeasure the RMS voltage independently of the
’scope.

Square Wave

Set up the waveform generator’s Channel 1 for a
square-wave output with a 1 kHz frequency, 6 Vpp
level and +1 V offset. Turn on the output.
Set up the ’scope’s channel 1 for DC coupling with

the appropriate scale factor for your probe (typically
10X)5.
Use the ’scope’s Measurement menu to add fre-

quency, Vrms (RMS), Vavg (average) and Vamp
(peak-to-peak amplitude) voltage measurements to
the display. Don’t use the “all measurements” feature
– it will hide a large fraction of the display. Instead,
add specific measurements.
Use the Acquire menu to set the memory Depth

to 140 kSamples. Use the Scale control in the Hori-
zontal controls section for a sampling rate of 1 MHz.
These values will be visible in the status line at the
top of the display.
Press the Horizontal scale knob to switch to de-

layed trigger mode. This will show a portion of the
captured samples. Adjust the horizontal scale so you
can view a few cycles of the square wave:

5If you don’t do this all of yourmeasurements could be wrong
by a factor of 10 or 1

10

You must adjust the horizontal scale to get accu-
rate voltage measurements. The oscilloscope’s volt-
age measurements are based on the displayed, rather
than captured, samples. To get an accurate measure-
ment you should adjust the horizontal scale to obtain
an integral number of cycles of a periodic waveform
or a representative number of samples of a random
waveform.
To see this, adjust the horizontal scale and position

so the ’scope showsmostly positive ormostly negative
portions of the waveform and see how the measured
value changes.
The ’scope’s measurements will be incorrect if the

horizontal scale is too small (because the display
does not show an integral number of periods) or too
large (because each displayed point combines adja-
cent samples).
Compare the ’scope readings to the AWG settings

and the DC and AC voltages on the DMM.
Plug a flash drive into the USB connector on the

front of the ’scope. A USB icon ( ) should appear
on the bottom right of the screen. Press the printer
icon ( ) on the top right of the panel to capture
an image of the ’scope screen. The file name will be
displayed briefly.
Use the Storage menu to save the captured sam-

ple data to your flash drive. Under “Storage” se-
lect CSV for the file type, Channel 1 for the source,
“Maximum” for the Data Depth and disable Parame-
ter Save.
Press Save to select the folder (directory) and file

name under which to save the file. If you wish, you
can create a new folder on the flash drive and a new
file name (although it’s easier to do this using Win-
dows).
Take notes of the date and time, the type of wave-

form, the voltage shown on the DMM, the threemea-
sured voltages on the ’scope (RMS, average and peak-
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to-peak) and the names of the image and waveform
capture files. You will need this information for your
report.

Sine Wave

Now configure the signal generator to a sine-wave
output with (peak-to-peak) voltage of 6 V and zero
DC offset. Repeat the steps above for the sine wave,
saving both image and waveform capture files and
recording the ’scope and DMM readings.

Noise Waveform

Repeat after configuring the waveform generator for
(Gaussian) noise output with a level of 1.3 Vrms and
zero offset. Again, save the image and waveform cap-
ture files and record the same information as before.
You should now have three sets of voltage read-

ings from two instruments, three ’scope screen cap-
ture files and three waveform capture sample files.
The rest of the lab can be done without the test

equipment but I recommend you try to do asmuch of
it as possible during the lab session in case you need
to repeat some of your measurements.

Import Samples into Octave

Run Octave (GUI). Use the File Browser to change to
the folder that contains your waveform capture CSV
files. Right-click on afile and selectOpen in Text Editor.
Remove any header lines at the beginning of the file.
After removing any headers the CSV file should con-
sist of rows with the sample number and the voltage
as shown below:

0,-2.04
1e-06,-2.04
2e-06,-2.04
3e-06,-2.04
4e-06,-2.04

Save the file. Right-click on the file and select Load
Data. This will create a variable with the same name
as the file (e.g. square) and dimensions 140000×2.
The first dimension is the number of rows (samples)
and the second is the number of columns (two – sam-
ple time and sample voltage). Right-click on the vari-
able name in theWorkspace tab and selectOpen in Vari-
able Editor. In the Variable Editor, right-click on the
column header for the first column (the sample time

values) and select Delete Column to get rid of the time
data sincewewon’t use it. In the variable tab the vari-
able should now have dimensions 140000×1.
Switch to the Command Window tab and enter the

following command:

plot(square(1:2000))

to plot the first 2000 samples of thewaveform tomake
sure you captured and have read the waveform 6.
Use the File > Save As... menu item to save the plot

to an image file (e.g. square.png) so that you can
include it your report.
In the command window, use the following com-

mands to compute the mean and RMS values of the
capturedwaveform and record the results for your re-
port:

mean(square)
std(square)

Compute the Histogram

A histogram is a plot of the number of times a value
appears in a set of values. For example, a histogram
of BCIT student ages would show the number of 18-
year old students as the 𝑦-value for the 𝑥-value 18.
To obtain the histogram of a waveform we count

the number of sample values that fall into ranges
called “bins.”.
In our case the binning is actually done by the

’scope’s 8-bit analog-to-digital (A/D) converter which
quantizes the input signal into 28 = 256 discrete volt-
age levels.
The voltage levels are separated by steps called the

“quantization step size”. For example if the step size
was 0.08 volts, a particular measurement might in-
clude all voltages between 1.60 and 1.68 volts. An in-
put voltage of 1.63 volts would be counted as falling
in this range.
When computing the histogram of the signal we

should use a bin width equal to the step size to make
sure we include exactly one voltage range per bin.
We can find the step size by examining the voltage

levels measured by the ’scope. The Matlab function
unique() returns a sorted list of the unique values
in the input. Assuming we have at least two values
separated by the step size we can find the step size as

6Use the appropriate variable name instead of square.
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the minimum difference between successive unique
values. Enter the following in the command window
to do this:

ssize=min(diff(unique(square)))

where the sequence of unique, diff and min oper-
ations computes the minimum difference between
successive unique measured voltages.
The step size can then be used to compute the

number of histogram bins we should use:

nbin=(max(square)-min(square))/ssize + 1

Now we can compute a histogram of the voltage
waveform using the hist() function:

[n,v]=hist(square,nbin);

This will return a vector nwith the number of sam-
ples values in each histogram bin and a vector vwith
the voltages at the midpoints of each bin.
We can then export the histogram to a CSV file by

opening a file for writing:

fo=fopen('lab1square.csv','w')

and writing the values to the file as strings separated
by commas, two per line:

fprintf(fo,'%f, %d\n',[v;n])

and closing the file:

fclose(fo)

Note that this histogram CSV file is different than
the one containing the sample values; don’t overwrite
the data in the CSV file that contains your captured
data!
Repeat for the sine wave and Gaussian noise cap-

ture files, saving them to differently-named CSV files
and recording your results for the mean and stan-
dard deviation (rms voltage). You can use the com-
mand history window to select previous commands
and edit them to reduce typing.

Compute RMS Voltage

The DC-coupled RMS (root mean square) voltage of
a signal is defined as the square root of the mean (av-
erage) of the square of the voltage. If all voltages had
the same probability we could just add up the squares
and divide by the number of voltages.
However, in this case different voltages have dif-

ferent probabilities so we must scale each squared
voltage (normalized power) by the probability of that
power and then compute the sum. For example, if
20% of the values had a power of 0.3W and 80% had a
power of 0.2W then the average (normalized) power
would be 0.2 × 0.3 + 0.8 × 0.2 = 0.06 + 0.16 = 0.22.
We can use a spreadsheet and the histograms

stored in the CSV files to compute the RMS values
of the three waveforms. This is a another check on
the values measured by the instruments.
Run Excel or LibreOffice Calc. Open the CSV file

(File > Open) which will result in a spreadsheet with
two columns, the first with the bin counts and the
second with the bin voltages.

Note: Immediately save the file in .xlsx format
or you will lose all your work when you exit the
spreadsheet software!

Enter a formula at the bottom of the second col-
umn to compute the total number of samples (this
should be 140,000). On each row add a cell with a for-
mula that divides the count by this value. This con-
verts the bin counts to probabilities7. The probabili-
ties should sum to 1. Then add cells on each row that
compute the square of each bin voltage multiplied
by the probability of that voltage. Compute the sum
of these scaled squared voltages. This is the mean
square voltage. Finally, compute the square root of
the mean square voltage. This is the RMS voltage of
the (DC-coupled) waveform.
Here is an example showing the spreadsheet

columns containing bin voltages, bin counts, bin
probabilities and scaled squared voltages. The bot-
tom row contains sums of the bin counts, probabili-
ties, and the mean-square and RMS voltages.

7To insert a reference to an absolute rather than relative cell,
prefix the column or row with a dollar sign ($). For example,
$A$101.
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Repeat using the histogram bin counts for the sine
and Gaussian noise waveforms, importing their data
into different sheets of the same document (Data >
From Text/CSV or Import > Sheet from File). Compare
your results to the values read from the ’scope and
DMM.

Plot Histograms

Create three line graphs (called “charts” in spread-
sheets) with curves showing the values of the three
histograms. Use Insert > Chart, set the chart type to
an XY Line graph and use the voltages as the X val-
ues and the histogram sample counts as the Y values.
Add an accurate title, sub-title and X and Y axis la-
bels. Adjust the chart properties so it is formatted as
shown below:
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Pre‑Lab Report

Submit a report containing the student and lab iden-
tification as described in the course information doc-
ument and the answers to the following questions:

(1) If a waveform’s peak-to-peak voltage is 𝐴 volts
and its DC value is 0 V, what are the average and
RMS voltages of (a) a square wave and (b) a sine
wave?

(2) A sine wavewith a voltage of 3 V peak-to-peak is
superimposed on aDC voltage of -1 V.What DC,
AC and AC+DC voltages will be measured by a
(true-RMS) DMM? If a ’scope is set for DC cou-
pling, what will be the average, peak-peak and
RMS voltage measurements?

(3) A signal switches randomly between two levels,
+1V and−2V. The level is +1V 30% of time and
−2 V 70% of the time. (a) What is the average
voltage? (b)What is the (DC-coupled)RMS volt-
age? (c) Draw the probability density function
(for discrete values you can draw a line whose
height corresponds to the probability of a par-
ticular voltage).

(4) Over what range of frequencies is the accuracy
of the BK Precision Model 2831E DMM spec-
ified for AC voltage measurements on the 20 V
range? Themanual is on the courseweb site and
the specifications are in Chapter 7. There are
multiple frequency specifications; make sure
you use the right one.

(5) (a) If the ’scope had a 12-bit A/D converter, how
many different voltage levels could it resolve?
(b) If the displaywas set to±10 V, approximately
what minimum voltage difference would you
expect to see between the sampled voltages? (c)
If the maximum voltage of the input waveform
was 2 V and the minimumwas−2 V, howmany
bins would the histogram have?

Lab Report

Upload three files to the dropbox folder for this lab:

1. the histogram CSV file for the sine wave input
in CSV (.csv) format (only the sine wave file)

2. the Excel (or LibreOffice Calc) spreadsheet file
in Excel (.xls or .xlsx) format (any version)
containing the three sheets and three charts

3. your report in PDF (.pdf) format

Your report should include:

• identification information as described in the
course information handout,

• plots of the first 2000 samples of each of the
three sampled waveforms,

• ’scope screen captures for the three waveforms
including the measurement data,

• the histograms for the three waveforms created
by your spreadsheet (if possible, use copy and
paste, not a screen capture)
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• a table comparing the RMS voltages measured
by the DMM, the ’scope, Octave (or Matlab)
and computed by your spreadsheet from the his-
togram. Include one row for each waveform.

• a brief explanation for any discrepancies be-
tween the results for the different types of mea-
surements.
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