
ELEX 3525 : Data Communications
2019 Fall Term

Communication System Simulation

Introduction

Computer simulations are the most practical way to
predict the performance of modern communication
systems. These simulations can include the effects
of complex processing such as FEC and impairments
such as fading.
Simulations of communication systems operate on

sampled signals. For example, we can generate ran-
dom bits and random noise samples and apply the
same operations on these signals that an actual trans-
mitter, channel and receiver would1. Then we can
measure the performance (e.g. the BER) of the simu-
lated system.
Such computer simulations are typically written

in a programming language such as C or Matlab us-
ing libraries of functions that perform various signal
processing functions such as signal and noise gener-
ation, filtering, modulation, coding, etc.
In this lab youwill simulate the operation of a com-

munication system that uses bipolar NRZ signalling
over an AWGN channel together with a rate- 1

2
con-

volutional encoder and a Viterbi decoder. You will
compare the BER vs. 𝐸b/𝑁0 curves for systems with
and without FEC and determine the coding gain at
different BERs.

GNU Radio

A sufficiently-fast computer can be used to imple-
ment the signal processing for wireless communica-
tions. This is known as “Software Defined Radio”
(SDR).
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GNU Radio is a open-source project to develop
software for SDR systems. GNU Radio software can
also be used to simulate communication systems –
which is how we will use it in this lab.

1These simulations are sometimes called “Monte-Carlo” sim-
ulations because they use randomly-chosen data.

GNU Radio Companion

GNU Radio Companion (GRC) is a graphical design
tool that lets a user create GNU Radio software with-
out having to write code. Blocks representing signal
processing functions are added to a diagram, config-
ured, and interconnected using a graphical user in-
terface. This “flowgraph” is then turned into an exe-
cutable script that executes the processing blocks in
the required order to process the samples. In this lab
we will use GRC to set up and run simulations.
An example of a flowgraph created by GRC is

shown in Figure 1.
A GNU Radio flowgraph can also send/receive

samples to/from radio hardware, files, network con-
nections and other GNU Radio flowgraphs2, al-
though we will not use these features in this lab.
The advantages of GNU Radio and similar tools

such as MathWorks’s Simulink and National Instru-
ment’s LabView are that they don’t require pro-
gramming and that the flowgraphs can be self-
documenting. However, experienced users tend to
prefer programming languages such as Matlab (e.g.
using the Communications Toolbox), because they
are more flexible.

Dataflow Flowgraphs

It may appear from the flowgraph that the blocks op-
erate simultaneously (in parallel). However, since
the blocks are implemented in software theymust ex-
ecute sequentially. For efficiency reasons there are
buffers between blocks that allow blocks to process
multiple samples each time the block is executed.
The order inwhich blocks are executed is determined
by a scheduler that examines the amount of data
available on the input ports of each block.
This “dataflow” architecture means that blocks

only execute when they have data to process. As a
result we can compare the first bit output by the de-
coder with the first bit input to the encoder without

2Including those written in programming languages such as
Python, C++ and Matlab.
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Figure 1: GNU Radio Companion flowgraph for bipolar NRZ over AWGN channel without FEC.

having to compensate for the processing delay of the
blocks.
Note that this buffering of samples increases la-

tency and can prevent proper operation of certain
delay-sensitive applications such as those using feed-
back control.

𝐸b/𝑁0

𝐸b/𝑁0 is the “metric” (numerical value) used to com-
pare the power efficiency of communication systems
operating over AWGN channels. It is the ratio of the
energy per information bit3, (𝐸𝑏) to the noise power
spectral density (𝑁0).
Comparing systems on the basis of 𝐸b/𝑁0 rather

than the signal-to-noise power ratio (SNR) allows us
to compare systems that may transmit at different
rates (e.g. due to using FEC or multi-level signalling)
or that use different bandwidths (e.g. due to using
different line codes or modulation).
Assume that both the signal and noise are strictly

bandlimited to a bandwidth 𝐵 and that we sample at
the Nyquist rate 𝑓s = 2𝐵. We can convert the signal
power 𝑆 to bit energy 𝐸𝑏 by multiplying by the infor-
mation bit period or by dividing by the information

3Information bits do not include the parity bits used for FEC.

bit rate 𝑓b. We can compute the noise power spectral
density, 𝑁0 by dividing the noise power, 𝑁, by the
bandwidth 𝐵 = 𝑓s/2. Thus:

𝐸𝑏
𝑁0

= 𝑆
𝑁 ⋅ 𝑓s

2𝑓b
With one sample per information bit (𝑓b = 𝑓s),

𝐸b/𝑁0 is half of the SNR (–3 dB). When using a rate- 1
2

code the information bit rate (𝑓b) is halved and 𝐸b/𝑁0
is equal to the SNR.
For bipolar NRZ with signal levels of±1 𝑆 = 1 and

for AWGN 𝑁 = 𝜎2.

Procedure

You will build two simulation flowgraphs. The first
generates a PRBS, converts the 0,1-valued bits to ±1,
adds zero-mean AWGNwith a configurable standard
deviation (RMS voltage), applies a threshold (at 0 V)
to the sum of the signal plus noise, and compares the
transmitted and received bits to measure the error
rate. The diagram in figure 1 shows the flowgraph.
The second flowgraph adds a convolutional FEC

encoder before the channel and a Viterbi FEC de-
coder after the channel. The decoder corrects some
errors thus reducing the BER. This provides a “cod-
ing gain” as explained in the lectures.
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Using GRC

Start GRC. Under the View menu enable the Block
Tree Panel, Console Panel and Variable Editor. Make
sure ‘Hide Variables’ is not checked.
The easiest way to add a block is to search for it by

name. Click on themagnifying glass icon ( ) on the
menu bar or type Control-F:

then type part of the block name and double-click on
the desired block name. You can move a block by
dragging it (any connections will follow).
To connect outputs to inputs: click on the output

port and then click on the input port youwant to con-
nect it to.
As in any diagram, the blocks should be arranged

so that the logical flow is left-to-right and top-to-
bottom whenever possible.
Samples flowing between blocks can be of differ-

ent types. Bits are typically transferred in the least-
significant bit of a Byte type and signal samples are
typically Float or Complex types. In GRC the color
of the input and output connectors reflects the signal
type (e.g. orange for bytes, violet for float).
If there is a mismatch between the signal types the

connector will be drawn in red.
You can double-click on a block to open up its

properties dialog box. This allows you to configure
the input and output types and other aspects of the
block’s operation. The block’s title and some of the
block’s properties are displayed inside the block in
the flowgraph.
Some blocks define data structures rather than

process samples. An example isVariable blocks that
set the value of a variable. This variable can be used
when configuring other blocks. By default a variable,
samp_rate, is included in a newflowgraph. Another
example is the FEC encoder and decoder definition

blocks. These set up data structures that define the
operation of separate encoder and decoder blocks.

Configure the First Flowgraph

Use the File ▶ Open menu item to start a new QT
GUI box. Then add, configure and connect up the
following blocks:

Variable Add a variable with ID noise_voltage.
This will be used to set the RMS voltage (which
is the standard deviation, 𝜎) of the noise.

GLFSR Source This block generates a PRBS. The
implementation is different than that described
in the lecture notes to allow more efficient im-
plementation in software, but the PRBS has the
same properties. Configure this block as fol-
lows:

Degree is𝑁, the number of bits in the shift reg-
ister. The sequence repeats after 2𝑁−1 bits. Use
a value that is large enough to test the blocks in
your simulation. The value used here is 𝑁 =
20 which will generate a PRBS of about 1 mil-
lion bits and whose longest run of 1’s is 20 bits.
Mask defines the LFSR taps. If left as 0, a suit-
able generator polynomial for the specified de-
gree will be chosen.

Type Conversions Various conversions from bits to
floating point values will be required. For ex-
ample, the GLFSR Source is configured to out-
put bits (stored in the least-significant bit of each
byte) but these need to be converted to Float val-
ues for transmission over an AWGN channel.
Add a Char To Float block wherever this con-
version is required.

Since the input to the BER counter is packed
bytes (8 bits/byte), a block is required to pack 8
1-bit values to one 8-bit byte. Add and configure
Pack K Bits blocks with 𝐾 = 8.
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Noise Source Add a Gaussian noise source with a
Float output whose amplitude is set by the vari-
able noise_voltage. It is configured as fol-
lows:

AWGN channel The AWGN channel is composed
of three blocks: Char To Float converts 0/1 val-
ues to Float values and scales by 1

2
to produce

values of 0 and 2 (the scaling value is in the de-
nominator). TheAdd Const adds -1 to produce
values of -1 and 1. TheAdd block adds the noise
to the signal. These blocks should have types set
to Float and Vec(tor) lengths of 1 sample.

Binary Slicer This block compares the input to a
threshold at 0 and outputs bits that are 0 or 1.

BER This block compares sequences of byte inputs
and computes the number of bits that differ. The
output is the log of the bit error rate as a float-
ing point number. The computation includes all
bits since the start of the simulation.

QT GUI Time Sink This block is similar to an oscil-
loscope and displays a graph of the input sam-
ple values as a function of time. These can be
used to verify that the simulation is operating
as expected. Two of these are included in the
flowgraph below. One displays the output of the
channel (signal plus noise). The second displays
the bits into the transmitter and out of the re-
ceiver.

QT GUI Number Sink This block displays a single
number while the simulation is running. It can
show the value as bar graph.
Both GUI blocks have configuration options for
how they should be displayed in the window
that is created when the flowgraph executes. In
addition to input types, ranges, labels, etc, the

GUI Hint provides some control over the posi-
tioning of the GUI elements within tabs. For ex-
ample, a hint of [1,2]means to place that GUI
element on the first row, second column.

Measure the BER

Double-click on the noise_voltage block or that line
on the variables sub-window and set the noise RMS
voltage to the first value in your spreadsheet.
Select Run ▶ Execute, press F6, or press on the

run ( ) icon. This will convert the flowgraph to a
Python script and run it.
TheGUIwill show the bits at the input to the trans-

mitter, the output of the receiver and the output of the
channel. The GUI Number Sink will display log10 of
the BER.
Wait until the BER appears stable and record the

value. Take a screen capture of theGUIwindow, then
close the GUI window to stop the simulation.
Repeat the steps above, except for the screen cap-

ture, for the other 𝐸b/𝑁0 values in your spreadsheet
and verify that the results match your predictions.
Select File ▶ Screen Capture to save an image file

showing your flowgraph.

Add FEC

Save and copy the .grc file to a new file and modify
the flowgraph by adding the following FEC compo-
nents as shown in Figure 2.

CC Encoder/Decoder Definition These blocks
define the convolutional code used by the
encoder and decoder. You can define con-
straint length (𝐾), rate (𝑅) and the generator
polynomials used to generate the two output
bits. The current implementation is limited
to the standard rate- 1

2
convolutional encoder

described in the lecture notes.

Configure these blocks as follows:
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The mode should be set to “streaming” (the
othermodes are for packet-based systemswhere
the shift-register needs to be flushed).

FEC Extended Encoder/Decoder These blocks
perform the encoding and decoding as config-
ured by the encoder and decoder definitions.
The encoder has unpacked bits as input and
ouput. The decoder expects float input (±1) and
generates unpacked bits as output. Configure
these blocks as follows:

Re-Measure the BER

Re-measure the BER vs 𝐸b/𝑁0 and add the data to
your spreadsheet.
Select File ▶ Screen Capture to get an image file

showing your second flowchart.
Plot BER vs 𝐸b/𝑁0 with and without FEC on the

same graph. Your graph might look something like:

Pre-Lab Report

Prepare a spreadsheet showing the signal and noise
RMS voltages, the SNR, and the predicted the BER as
a function of SNR when no FEC coding is used. The
SNR can be computed as:

SNR = 𝑡2 = (±1𝜎 )
2

or −20 log10(𝜎) (dB)

As in the previous lab you can compute the BER
for bipolar NRZ without FEC using the formula:

𝑄(𝑡) = 𝑃(𝑥 < 𝑡) = 1
2erfc (

−𝑡
√2

)

Include values of SNR in your spreadsheet from
about 0 to 14 dB.
Add columns in your spreadsheet showing the cor-

responding value of 𝐸b/𝑁0 with and without rate- 1
2

FEC and for themeasured log10(BER)with andwith-
out FEC.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

A B C D E F G

signal 
voltage

noise 
voltage

SNR and 
Eb/No 

with FEC

Eb/No 
without 

FEC

predicted 
log(BER) 
without 

FEC

measured 
log(BER) 
without 

FEC

measured 
log(BER) 
with FEC

μ σ t
Vrms Vrms dB dB

1 1.000 0.0 -3.0 -0.8
1 0.891 1.0 -2.0 -0.9
1 0.794 2.0 -1.0 -1.0
1 0.708 3.0 0.0 -1.1
1 0.631 4.0 1.0 -1.2
1 0.562 5.0 2.0 -1.4
1 0.501 6.0 3.0 -1.6
1 0.447 7.0 4.0 -1.9
1 0.398 8.0 5.0 -2.2
1 0.355 9.0 6.0 -2.6
1 0.316 10.0 7.0 -3.1
1 0.282 11.0 8.0 -3.7
1 0.251 12.0 9.0 -4.5
1 0.224 13.0 10.0 -5.4
1 0.200 14.0 11.0 -6.6

Submit your spreadsheet in .xls(x) format and a
printout of your spreadsheet in PDF format to the ap-
propriate dropbox on the course web site.

Lab Report

Plot the measured BER without FEC and the mea-
sured BER with FEC against 𝐸b/𝑁0.
Use the graph to estimate the coding gains at BERs

of 10−2 and 10−6.
Submit a report in PDF format to the appropriate

dropbox on the courseweb site containing the follow-
ing:

• your two flowchart diagrams

• your screen capture of the run-time GUI win-
dow showing the signal on the channel, the in-
put and output bits and the log10(BER) value

• the spreadsheet showing your data

• the plot with two curves showing BER vs 𝐸b/𝑁0
with and without FEC

• your calculations of the coding gains for BERs of
10−2 and 10−6.
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Figure 2: GNU Radio flowgraph for bipolar NRZ over AWGN channel with convolutional FEC code and
Viterbi decoder.

6


	Introduction
	GNU Radio 
	GNU Radio Companion

	Dataflow Flowgraphs
	Eb/N0
	Procedure 
	Using GRC
	Configure the First Flowgraph
	Measure the BER
	Add FEC
	Re-Measure the BER

	Pre-Lab Report 
	Lab Report 

