ELEX 2117 : Digital Techniques 2
2024 Winter Term

Software Installation and Use

Installation

Quartus and ModelSim

Quartus Prime Lite

You can run the software from AppsAnywhere or in-
stall it locally on your PC. Running Quartus from
AppsAnywhere is simpler but may be slower and re-
quires that you be on-line to use the software. Avoid
using the same version of Quartus locally that you use
from AppsAnywhere - they may conflict.

To install the software locally, download and run
the latest Quartus Prime Lite installer from the Intel
FPGA Software Download Center. Select the follow-
ing options:

Intel Quartus Prime Lite Edition 23.15td.0.991 for Windows intel
Name Download Size Install Size  Progress  File Integrity | Description
~ H Quartus® Prir Select a component for more information
v/ Quartus® 16168 85568 [JEIND
~ | |Questa*Ir 078GB  331GB| 0%
Starter
~ H Devices
Arria® Il ¢ 049GB  052GB | 0%
Cyclone® 046GB  050GB | 0%
Cyclone® 026GB  029GB | 0%
Cyclone® 134G 140GB | 0%
VIMAX@ I, 00168 00168 (A
MAX® 10 028GB 035GB | 0%
> Add-ons and
Download to: |C:\Users\Ed\Downloads\intelFPGA_lite_23.1std
/| Auto install after download
V| Agree to Intel License Agreement After-install actions
Install to:\intelFPGA_lite\23.1std| .. Create shortcuts on Desktop Launch USB Blaster II driver installation
Disk Space Required Status
Download size: 1.62GB  Installation size: 8.56 GB T s

Disk space required: 10.18 GB Disk space available: 222.27 GB Downloaded: 1.62 GB / 1.62 GB

Settings | | Help Log Download|  Stop Close

« under Quartus Prime, select only Quartus Prime
(not Questa)

« under Devices, select only MAX Il, MAX V device
support

« select Auto install after download and Agree to In-
tel License Agreement

« unselect all After-install actions (important)

Press Download to download and install the soft-
ware.

software.tex

ModelSim

You'll need to use the ModelSim simulator for
one of the labs. Modelsim will be available if
you run Quartus 20.1 (not 21.1) from AppsAny-
where. If you want to install Modelsim locally,
the installer can be downloaded from the Intel
website under “Individual Files” for version 20.1.
The installer is also available in the ELEX 2117
ShareOut folder. The BCIT ITS Knowledge Base
has instructions on accessing ShareIn and Share-
Out remotely if necessary. Download and run
ModelSimSetup-20.1.1.720-windows.exe, se-
lect ModelSim - Intel FPGA Starter Edition (no license
required) when installing.

USB-Blaster Driver

Do not install the USB Blaster driver distributed with
Quartus. Instead, download the usb-blaster.zip
file available on the course website and extract the
files. Run Device Manager and find the USB-Blaster
device. Right-click on it and select “Update Driver”:

v L Other devices
£ IcService_ New
£ sMS/MMS

£ sMs/MMms

A USBYDI-t=-ratanams
a Fonabl% Update driver
W Ports (C Disable device

= Print qu

Uninstall device

and select the folder where you extracted drivers from
the course website. Finally, check that the 2009
driver version was installed:

l,] Altera USB-Blaster Properties
General Advanced D"E(—" Details Events
s

e 4 Altera USB-Blaster

Driver Provider:  Altera

Driver Date 2009-04-21

Driver Version 24160

Digital Signer Delaware Atera Cog

te

If you have problems when you run the program-
mer tool, see “Resolving USB-Blaster Problems” be-
low.
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https://kb.bcit.ca/student/appsanywhere-resources-3031/
https://www.intel.com/content/www/us/en/software-kit/795188/intel-quartus-prime-lite-edition-design-software-version-23-1-for-windows.html
https://www.intel.com/content/www/us/en/software-kit/795188/intel-quartus-prime-lite-edition-design-software-version-23-1-for-windows.html
https://www.intel.com/content/www/us/en/software-kit/660907/intel-quartus-prime-lite-edition-design-software-version-20-1-1-for-windows.html
https://www.intel.com/content/www/us/en/software-kit/660907/intel-quartus-prime-lite-edition-design-software-version-20-1-1-for-windows.html
https://kb.bcit.ca/student/accessing-sharein-shareout-folders-164/
https://kb.bcit.ca/student/accessing-sharein-shareout-folders-164/

There is a short video on the course website show-
ing how to install the software.

High-Resolution Displays

The Quartus user interface may not display properly
if you have a high-resolution display and you’ve set
text scaling set to more than 100%. You can work
around this by having the operating system scale
the Quartus window itself. Right-click the Quartus
shortcut and select Properties > Compatibility > Change
high DPI settings > High DPI scaling override. Check the
Override box and select System (Enhanced):

5 | Choose the high DPI settings for this program.

Program DPT

Security Details Previous Versions
DUSE this setting to fix scaling problems for this program
in in Setti

General Shortcut Compatbilty

If this program isn't working correctly on this version of Windows, try

set for your main display when you open this program.

Use the DPI that's set for my main display when

I signed in to Windows

o tesonuor
isable fullscreen opti
un this prog inistrator

] Register this program for restar‘/
Change high DPI settings.

scalin
M e o7

& Change settings for all users System (Enhanced) v

oK Cancel Apply OK Cancel

Logic Synthesis with Quartus

1. Run Quartus (on Windows select Intel FPGA ...
> Quartus ...).

2. Select File > New... > New Quartus Prime Project
> OK.

3. In the dialog boxes that follow: select a new
folder for your lab (e.g. C:\ELEX2117\1lab1),
enter a project name (e.g. lab1), select
an empty project, don’t add any files, select
the MAX Il Family, select the specific device
EPM240T100C5, and leave other settings at their
defaults.

I recommend putting the project folder on a
BCIT network drive (e.g. BCIT OneDrive) when
using the lab computers. This is almost as fast
as a local disk. Flash drives are much slower.
Using the D: drive risks other students copying
your solution if it’s not properly deleted when
you leave.

4. Add any existing design files using Project > Ad-
d/Remove Files in Project..., or create new ones us-
ing File > New... > System Verilog HDL File. One of

10.

11.

12.

13.

the files must have a module with the top-level
name specified above (in this example, lab1).
The port names of this module will correspond
to the names assigned to the CPLD pins.

After all the design files have been created and
added to the project, select Processing > Start
Compilation. Correct any errors and recompile
as necessary.

Select Assignments > Pin Planner and select the
correct pin in the Location drop-down box for
each I/O pin. Note that you must compile the
project before the pin names are visible in Pin
Planner. Recompile the project (Processing >
Start Compilation) for the assignments to take ef-
fect.

It’s good practice to assign unused pins as in-
puts. Under Assignments > Device... > Device
and Pin Options... > Unused Pins select “As input
tri-stated with weak pull-up”.

Connect the CPLD board’s coaxial power con-
nector to a USB port and press the power push-
button so that the power LED lights up.

Connect the “USB Blaster” to the JTAG port
on the CPLD/FPGA board and a free USB port.
The POWER and ACT lights on the USB-Blaster
should turn on.

Select Tools > Programmer, click on Hardware
Setup..., select USB-Blaster from the drop-down
and Close. USB-Blaster should appear next to
Hardware Setup...

If necessary, click on Add File.., navigate to the
location of the generated .pof file (typically in
the output_files folder of the project folder)
and select the . pof file.

Check that the Program/Configure checkboxes
are checked and press Start to program the de-
vice. The progress bar should show 100%.

Test your design.

There is a short video on the course website show-

ing how to use Quartus to synthesize a design and
program a CPLD or FPGA.



Simulation with ModelSim

1.

2.

10.

Run ModelSim (on Windows select Intel FPGA
... > ModelSim ...).

(a) Ifthisis the first time you simulate this de-
sign, select File > New > Project..., select the
folder where your files are located as the
Project Location, enter a suitable Project
Name (e.g. 1ab1) and click OK. Select Add
Existing File and select the file(s) that con-
tain the entities you want to simulate, in-
cluding your design files and testbench (if
any), then select Close.

(b) If you had already created a simulation
project and it’s not already open, select File
> Open, select Files of type: Project Files
(*.mpf) and select the project file,

Select Compile > Compile All to compile all the
files in your project into the work library,

If there are syntax errors you will need to fix the
error(s), save the file and go back to step 3,

Otherwise select Simulate > Start Simulation; se-
lect your testbench module from the work li-
brary and select OK.

Drag the signals you wish to view from the ‘Sim’
or ‘Object’ windows to the “Wave’ window (use
the View menu to open windows).

Select Simulate > Run -All; this will run the sim-
ulation until it’s complete.

The Transcript window will contain output
from the testbench.

The Wave window will show the waveforms (se-
lect the Wave window, click on ‘+’ and Wave >
Zoom > Full); you can use a screen capture utility
(e.g. Windows Snip tool) to save the waveforms.

If the results are not as expected, correct the
errors, run Compile > Compile All, Simulate >
Restart..., click OK and Simulate > Run -All.

Resolving USB-Blaster Problems

If possible, check your USB-Blaster, cables and CPLD
or FPGA board at a BCIT lab session by programming
one of the . pof files from the course web site. Ask the
lab instructor for help if necessary.

If your hardware works with the lab PC but not
with your own computer, follow the troubleshooting
guide below.

You will need:

« a Windows 10 PC with Quartus Prime installed

+ two free USB ports (or one port and one USB
charger)

« a USB flash drive

+ (in rare cases) a known-working USB-Blaster,
cables, and CPLD or FPGA board

Do the following, in order:

1. Press the %% (Start) key and type “Core Isolation”
or navigate to 3 (Settings) > Update & Security >
Windows Security > Device Security and click on
Core isolation details.

Check that Memory Integrity is set to Off:

Memory integrity

Prevents attacks from inserting malicious code into high-security
processes.

@ off

The USB-Blaster usblstr.sys drivers are in-
compatible with Memory integrity protection
and will not install if it’s enabled.

2. Unplug any USB peripherals that are not re-
quired to run your computer and restart your
computer.

3. Check that the flash drive works in the USB port
you plan to use for the USB-Blaster.! If other
devices don’t work when plugged into the ports
you plan to use, shut down the computer (don’t
just restart it). If other USB devices still don’t
work, use a different USB port or computer.

4. Disconnect the USB-Blaster from the CPLD/F-
PGA board and plug it into the USB port. Check
the green POWER LED. If it’s not on, try a
known-good mini-USB cable and USB-Blaster.

1USB port power is turned off when you draw too much cur-
rent (e.g. due to a short circuit on your breadboard).


https://support.microsoft.com/en-us/windows/core-isolation-e30ed737-17d8-42f3-a2a9-87521df09b78

5. Run Windows’ Device Manager and expand the
USB controllers section. You should see the
USB-Blaster under Other devices:

= INELWUIK auapers
v K7 Other devices
B USB-Blaster(Altera)

B2 Dactc (0ONA 20 1DT

or USB Controllers:

K System aevices
~ § Universal Serial Bus controllers
§ Altera USE-Blaster
§ Generic SuperSpeed USE Hub
§ Generic SuperSpeed USE Hub
§ Generic USE Hub

If not, (this is rare) try a known-good mini-USB
cable and USB-Blaster.

6. Right-click on the USB-Blaster device, select
Properties and click on the Driver tab. Check that
Driver version 2.4.16.0 is installed as shown be-
low.

k]
1 General Advanced Diver Detals Everts

) E Altera USB-Blaster

_ Driver Provider:  Altera

L} Diver Date: 20090421
Driver Version: 24160

1 Digital Signer: ~ Delaware Atera Corporation

Driver Details ‘View details about the installed driver files.

if you have a different version then you’re prob-
ably using the drivers included with Quartus
rather than the ones from the course web site.
Right-click on Altera USB Blaster and select Unin-
stall device. Check the box for Delete the driver
software for this device.” and click Uninstall.

|
" Uninstall Device X

- Altera USB-Blaster

Waming: You are about to uninstall this device from your system.

Z1 Delete the driver software for this device.

Uninstall Cancel

If no, or the wrong driver, was installed, install
the Altera USB Blaster drivers from the course
web site as described above and check the ver-
sion again. Do not proceed until the correct
driver version has been installed.

ZYou must delete the newer driver so it does not get re-
installed.

7. In Quartus, run Tools > Programmer and click on

10.

Hardware Setup. Check that you can select the
USB-Blaster:

use when programming devices. This programming
nt programmer window.

Currently selected hardware: | USB-Blaster [USB-0]
Hardware frequency: Hz

Available hardware items

Hardware Server Port Add Hardware.
UsB-Blaster Local use-o

If not, close the programmer application, un-
plug any USB devices that may be using an FTDI
serial interface IC, including the Analog Discov-
ery 2, and try again again. If the USB-Blaster
shows up in Device manager but the Quartus
programmer still cannot detect it, go to step 1
(and make sure all USB devices are unplugged
before restarting).

. At this point the USB-Blaster should still be dis-

connected from the CPLD/FPGA board. Re-
move all connections to the CPLD/FPGA pins
(to prevent issues due to short-circuited pins)
and connect the micro-USB power connector
to a USB power supply or USB port. If the
red power LED does not light, check the USB
port/charger and cable. Replace the micro-USB
cable or CPLD/FPGA board if the power LED
does not light.

Note: The USB-Blaster supplies enough power
to light the red power LED on the CPLD/F-
PGA board but not enough for the CPLD/F-
PGA to operate. Do not rely on the power LED
on the CPLD/FPGA board to show whether the
CPLD/FPGA is receiving power.

Connect the USB-Blaster to the CPLD/FPGA
board’s JTAG connector using the ribbon cable.
Note that the connectors are keyed.

Click on Auto Detect to check that the device is
detected:



h intel FPGA ®

Enable real-time ISP to allow background programming when available.

File Device Checksum  Usercode  Program/  Verify Bl
W gl
S Configure ol

¥ stop <nene> EPM240 00000000 <none>
8 Auto Detect
Delete
M Add File
P Change File

S save File

* Add Device.

EPM240

11. If the device is not detected you should see a
pop-up message saying “Unable to scan device
chain.” Run Tools > JTAG Chain Debugger or Click
Yes if the message offers to run it for you.

12. Click on Test JTAG Chain.

If the error is “Chain is in use.” reboot the com-
puter to restart the USB-Blaster driver.

If the error is “No device detected.” double-
check the connection between the USB-Blaster
and the CPLD/FPGA board. Replace the USB-
Blaster, ribbon cable, or CPLD/FPGA board?.

3 Although the most common reason for this error is that there
is no power connected to the CPLD/FPGA board.
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