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Software Installation and Use

Installation

Quartus Prime Lite and ModelSim

You can run the software from AppsAnywhere or in-
stall it locally on your PC. Installing from AppsAny-
where is faster but requires that you be on-line to
use the software. Avoid doing both — the AppsAny-
where version may conflict with the locally installed
version.

To install the software locally, download the lat-
est Quartus Prime Lite from the Intel FPGA Software
Download Center. From the “Individual Files” tab
download:

o Quartus Prime (includes Nios Il EDS),

« Modelsim (or Questa)-Intel FPGA Edition (includes
Starter Edition), and

o MAXII, MAXV device support

Quartus Prime Lite version 21.1.1 and ModelSim
20.1.1 are also available in the ELEX 2117 ShareOut
folder. The BCIT ITS Knowledge Base has instruc-
tions on accessing Shareln and ShareOut remotely.

Unfortunately, the Questa simulation software re-
quires that you register on the Intel web site to obtain
a (free) license. If you want to skip this licensing step
install ModelSim (version 20.1.1) instead or run Mod-
elsim from AppsAnywhere .

Download all three files to the same folder and
run the Quartus installer. Note that the downloads
total about 3 GBytes and installation requires about
15 GBytes of free disk space.

When you run the Quartus installer it should find
the Modelsim (or Questa) and the device installer
files in the same folder and offer to install them. Do
SO.

When the installation is complete the Quartus in-
staller will show an option to install the drivers for
the USB Blaster:
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Uncheck this box! The drivers may “hang” or crash
Windows if you use the ones in recent versions of
Quartus with the “clone” USB Blaster in your parts
kit.

Instead, download the usb-drivers.zip file
available on the course website and extract the files.
Run Device Manager and find the USB-Blaster de-
vice. Right-click on it and select “Update Driver”:
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and select the folder where you extracted drivers from
the course website. Finally, check that the 2009
driver version was installed:
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If you have problems when you run the program-
mer tool, see “Resolving USB-Blaster Problems” be-
low.

There is a short video on the course website show-
ing how to install the software.

High-Resolution Displays

The Quartus user interface may not display properly
if you have a high-resolution display and you’ve set
text scaling set to more than 100%. You can work
around this by having the operating system scale
the Quartus window itself. Right-click the Quartus
shortcut and select Properties > Compatibility > Change
high DPI settings > High DPI scaling override. Check the
Override box and select System (Enhanced):
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Logic Synthesis with Quartus

1.

Run Quartus (on Windows select Intel FPGA ...
> Quartus ...).

Select File > New... > New Quartus Prime Project
> OK.

In the dialog boxes that follow: select a new
folder for your lab (e.g. C:\ELEX2117\1lab1),
enter a project name (e.g. lab1), select
an empty project, don’t add any files, select
the MAX Il Family, select the specific device
EPM240T100C5, and leave other settings at their
defaults.

Add any existing design files using Project > Ad-
d/Remove Files in Project..., or create new ones us-
ing File > New... > System Verilog HDL File. One of
the files must have a module with the top-level
name specified above (in this example, lab1).
The port names of this module will correspond
to the names assigned to the CPLD pins.

After all the design files have been created and
added to the project, select Processing > Start
Compilation. Correct any errors and recompile
as necessary.

Select Assignments > Pin Planner and select the
correct pin in the Location drop-down box for
each I/O pin. Note that you must compile the
project before the pin names are visible in Pin
Planner. Recompile the project (Processing >
Start Compilation) for the assignments to take ef-
fect.

It’s good practice to assign unused pins as in-
puts. Under Assignments > Device... > Device
and Pin Options... > Unused Pins select “As input
tri-stated with weak pull-up”.

10.

11.

12.

13.

Connect the CPLD board’s coaxial power con-
nector to a USB port and press the power push-
button so that the power LED lights up.

Connect the “USB Blaster” to the JTAG port
on the CPLD/FPGA board and a free USB port.
The POWER and ACT lights on the USB-Blaster
should turn on.

Select Tools > Programmer, click on Hardware
Setup..., select USB-Blaster from the drop-down
and Close. USB-Blaster should appear next to
Hardware Setup...

If necessary, click on Add File.., navigate to the
location of the generated .pof file (typically in
the output_files folder of the project folder)
and select the . pof file.

Check that the Program/Configure checkboxes
are checked and press Start to program the de-
vice. The progress bar should show 100%.

Test your design.

There is a short video on the course website show-
ing how to use Quartus to synthesize a design and
program a CPLD or FPGA.

Simulation with ModelSim or Questa

1.

2.

3.

Run ModelSim (on Windows select Intel FPGA
... > ModelSim ...).

(a) Ifthisis the first time you simulate this de-
sign, select File > New > Project..., select the
folder where your files are located as the
Project Location, enter a suitable Project
Name (e.g. 1ab1) and click OK. Select Add
Existing File and select the file(s) that con-
tain the entities you want to simulate, in-
cluding your design files and testbench (if
any), then select Close.

(b) If you had already created a simulation
project and it’s not already open, select File
> Open, select Files of type: Project Files

(*.mpf) and select the project file,

Select Compile > Compile All to compile all the
files in your project into the work library,



4. If there are syntax errors you will need to fix the
error(s), save the file and go back to step 3,

5. Otherwise select Simulate > Start Simulation; se-
lect your testbench module from the work li-
brary and select OK.

6. Drag the signals you wish to view from the ‘Sim’
or ‘Object’ windows to the “Wave’ window (use
the View menu to open windows).

7. Select Simulate > Run -All; this will run the sim-
ulation until it’s complete.

8. The Transcript window will contain output
from the testbench.

9. The Wave window will show the waveforms (se-
lect the Wave window, click on ‘+’ and Wave >
Zoom > Full); you can use a screen capture utility
(e.g. Windows Snip tool) to save the waveforms.

10. If the results are not as expected, correct the
errors, run Compile > Compile All, Simulate >
Restart..., click OK and Simulate > Run -All.

Resolving USB-Blaster Problems

If possible, check your USB-Blaster, cables and CPLD
or FPGA board at a BCIT lab session by programming
one of the . pof files from the course web site. Ask the
lab instructor for help if necessary.

If your hardware works with the lab PC but not
with your own computer, follow the troubleshooting
guide below.

You will need:

« a Windows 10 PC with Quartus Prime installed

« two free USB ports (or one port and one USB
charger)

« a USB flash drive
« (in rare cases) a known-working USB-Blaster,
cables, and CPLD or FPGA board

Do the following, in order:

1. Press the %& (Start) key and type “Core Isolation”
or navigate to S (Settings) > Update & Security >
Windows Security > Device Security and click on
Coreisolation details.

Check that Memory Integrity is set to Off:

Memory integrity

Prevents attacks from inserting malicious code into high-security
processes.

@D orf

The USB-Blaster usblstr.sys drivers are in-
compatible with Memory integrity protection
and will not install if it’s enabled.

. Unplug any USB peripherals that are not re-

quired to run your computer, including any
Analog Discovery 2, and restart your computer.

. Check that the flash drive works in the USB port

you plan to use for the USB-Blaster.! If other
devices don’t work when plugged into the ports
you plan to use, shut down the computer (don’t
just restart it). If other USB devices still don’t
work, use a different USB port or computer.

. Disconnect the USB-Blaster from the CPLD/F-

PGA board and plug it into the USB port. Check
the green POWER LED. If it’s not on, try a
known-good mini-USB cable and USB-Blaster.

. Run Windows’ Device Manager and expand the

USB controllers section. You should see the
USB-Blaster under Other devices:
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If not, (this is rare) try a known-good mini-USB
cable and USB-Blaster.

. Right-click on the USB-Blaster device, select

Properties and click on the Driver tab. Check that
Driver version 2.4.16.0 is installed as shown be-
low.
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Driver Details View details about the installed driverfiles,

1USB port power is turned off when you draw too much cur-
rent (e.g. due to a short circuit on your breadboard).


https://support.microsoft.com/en-us/windows/core-isolation-e30ed737-17d8-42f3-a2a9-87521df09b78

if you have a different version then you’re prob-
ably using the drivers included with Quartus
rather than the ones from the course web site.
Right-click on Altera USB Blaster and select Unin-

stall device. Check the box for Delete the driver

software for this device.> and click Uninstall.

" Uninstall Device X

e Altera USB-Blaster

Waming: You are about to uninstall this device from your system.

Z1 Delete the driver software for this device.

Uninstall

Cancel

If no, or the wrong driver, was installed, install
the Altera USB Blaster drivers from the course
web site as described above and check the ver-
sion again. Do not proceed until the correct
driver version has been installed.

7. In Quartus, run Tools > Programmer and click on
Hardware Setup. Check that you can select the
USB-Blaster:

Hardware Settings  JTAG Settings

Selecta programming hardware setup to use when programming devices. This programming
hardware setup applies only to the current programmer window.

Currently selected hardware: | USB-Blaster [USB-0] z
Hardware frequency: Hz

Available hardware items

Hardware Server Part Add Hardware.

UsB-Blaster Local UsB-0

If not, close the programmer application, un-
plug any USB devices that may be using an
FTDI serial interface IC, including the Analog
Discovery 2, and try again again. If the Quar-
tus programmer shows in Device manager but
the Quartus programmer still cannot detect the
USB-Blaster, go to step 1 (and make sure all USB
devices are unplugged before restarting).

8. At this point the USB-Blaster should still be dis-
connected from the CPLD/FPGA board. Re-
move all connections to the CPLD/FPGA pins
(to prevent issues due to short-circuited pins)
and connect the micro-USB power connector
to a USB power supply or USB port. If the

ZYou must delete the newer driver so it does not get re-
installed.

red power LED does not light, check the USB
port/charger and cable. Replace the micro-USB
cable or CPLD/FPGA board if the power LED
does not light.

Note: The USB-Blaster supplies enough power
to light the red power LED on the CPLD/FPGA
board but not enough for the CPLD/FPGA to
operate. Do not rely on the power LED to de-
termine whether the CPLD/FPGA is receiving
power.

9. Connect the USB-Blaster to the CPLD/FPGA
board’s JTAG connector using the ribbon cable.
Note that the connectors are keyed.

10. Click on Auto Detect to check that the device is
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11. If the device is not detected you should see a
pop-up message saying “Unable to scan device
chain.” Run Tools > JTAG Chain Debugger or Click
Yes if the message offers to run it for you.

12. Click on Test JTAG Chain.

If the error is “Chain is in use.” reboot the com-
puter to restart the USB-Blaster driver.

If the error is “No device detected.” double-
check the connection between the USB-Blaster
and the CPLD/FPGA board. Replace the USB-
Blaster, ribbon cable, or CPLD/FPGA board?.

3 Although the most common reason for this error is that there
is no power connected to the CPLD/FPGA board.
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