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Welcome to Protel 99 SE

Welcome to the world of Protel 99 SE – a complete 32-
bit electronic design system for Windows 95/98/NT.
Protel 99 SE provides a completely integrated suite of
design tools that lets you easily take your designs from
concept through to final board layout.

Protel 99 SE brings to the EDA desktop a new level of
integration. Unlike other tool suites that provide separate
applications for each phase of the design process, all
Protel 99 SE tools run within a single application environment – the Design
Explorer. Start Protel 99 SE and the Design Explorer opens, putting all your
design tools at your fingertips. You benefit from a single, consistent,
customizable user environment – no need to grapple with different applications
for different design tasks.

A single environment also means Protel 99 SE eliminates import/export hassles
as you progress through the design process. For example, autorouting a board in
Protel 99 SE is done directly in the PCB document window at the touch of a
single button – no need to fiddle with separate router files. With Protel 99 SE you
can compile a circuit for implementation in a programmable logic device directly
from the schematic, producing an industry-standard JEDEC device programming
file in a single action.

Simulation is also integrated into Protel 99 SE. You can set up and run mixed
analog/digital simulations directly from the schematic. Protel 99 SE comes with
comprehensive libraries of simulation-ready components, with full support for the
industry-standard simulation language, SPICE 3f5.

Protel 99 SE comes with extensive schematic and PCB footprint libraries. The
Protel Library Development Center continually updates and adds to these
libraries, ensuring you will always be up-to-date with the latest devices and
packaging technologies from all major manufacturers. Updated libraries are
available for download from the Protel web site at www.protel.com.

Protel 99 SE also includes integrated spreadsheet, charting, text editing and
macro creation tools, allowing you to manage all aspects of a design project
without leaving the Design Explorer environment.

Because the Design Explorer is built on an open client/server architecture, you
can extend the functionality of Protel 99 SE with Add-Ons available from both
Protel and third-party vendors. Add-Ons integrate seamlessly into the Design
Explorer environment, providing additional functions and services – extending
the capabilities of your Protel 99 SE design tools. The Protel web site at
www.protel.com provides an up-to-date list of the latest Add-Ons, many of which
are directly downloadable.

Install Protel 99 SE and you have at your fingertips all the tools you need to
produce sophisticated designs with unprecedented speed and ease.
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Folder View
Use folders to organize
the design documents.
Right-click to create a
new document, click and
drag to move a document
to a different folder.

Document/Folder Tabs
Each open document and folder has its own Tab (the icon shows the
active Tab). Right-click on a Tab to split the window, click and drag to
move a Tab to a different region of the window.

Schematic Editor 

Note the Tabs at the top
– there are 2 schematics
currently open.

PCB Editor

You can open and 
work on the PCB at 
the same time. 

Help Advisor

Use the natural language
help system to quickly
find the answer to 
your question.

Design Window

Displays the documents that are currently open in
this design – there is a Tab for each open document
and folder. The window has been split into 3 regions
to display a folder, a schematic sheet and the PCB.
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, text, etc).
Explorer and Editor Panels

As well as the Design
Explorer navigation
panel, other editor
panels are available for
each editor (schematic,
PCB, text, etc).

Active Database

All design documents are
stored in an integrated
design database. 

Navigation Panel

Displays all the documents and folders in
the design database. The active document
is highlighted, right-click on a document
or folder for a menu of options.

System Menu

Click the down-arrow to
display the system menu
– use this to set up the
preferences, compact a
database and customize
the resources.
All other menus and
toolbars automatically
change to suit the
document being edited.

The Protel 99 SE Design Explorer
The Design Explorer is your interface to your designs, and the design tools. 
To start Protel 99 SE and open the Design Explorer, select Protel 99 SE from the
Protel 99 SE Program Group in the Windows Start menu – the Design Explorer 
will open, ready for work. Before starting your own design you might like to
explore some of the example designs included with Protel 99 SE – these are 
located in the \Program Files\Design Explorer 99 SE\Examples\ folder. 



5

To start the tutorial, create a new design 
database by completing the following steps:

Close any design databases that are currently open.

Select File » New from the menus.

The New Design Database dialog will
appear. Two types of design storage
options are available – a MS Access
Database, where all the design documents
are stored within the one database file on
the disk drive, and Windows File System,
where the design documents are stored
separately on the disk drive. Regardless of
which storage option you choose, the way
you work in the design database is exactly
the same. 

For the tutorial we will use an Access
database – set the Design Storage Type to MS Access Database.

Type the name Multivibrator.ddb in the Database File Name field. 
Click the Browse button and navigate to a location where you would like to
store the design.

Click OK to close the New Design Database dialog – the new database will
open in the Design Explorer.

You are now ready to start capturing the schematic.

4

Working in the Design Explorer Creating a new design

Working in the Design Explorer is just like
working in the Windows File Explorer – if you are
familiar with the Windows Explorer then you are
ready to go!

Like the Windows Explorer, there are 2 regions to
work in – the navigation panel on the left, that
displays the contents of the design in a tree-like
structure, and the view of what is currently selected
in the tree is displayed on the right. Simply click
on a document or folder in the tree to display it on
the right.

All the documents in a design are displayed in the
same window, each on a separate tab. Right-click
on a tab to split the window and view multiple
documents simultaneously.

How the design documents are stored
Protel 99 SE stores all the design documents –
including the schematic sheets, PCB, libraries,
simulation results, manufacturing files, and so on –
in an integrated design database. There is no need
to find and open each document individually, you
simply open the database, and from there you can
access all of the design documents.

As well as storing documents within a database,
you can also create folders to organize the
documents.

To make it easy to manage all the documents in
your project you can also store any other type of
document, including Microsoft Word and Excel
documents, AutoCAD drawings, and so on, in the
design database. Documents created by “OLE
compliant servers”, such as Word and Excel, can be opened directly from the
Protel 99 SE design database, simply double-click to edit them.

Tips on working in the Design Explorer
• Select File » New to create a new document or folder.

• Right-click in a folder and select Import to import any document into a
design database.

• Right-click on a document (or folder) to export it from the design database.

• Select Design Utilities from the System menu (the down-arrow) to compact an
MS Access database.

• Click-and-drag to re-organize documents and folders in a design.

• Hold the ALT key as you open a design to stop documents automatically re-opening.

Create folders and store all the documents
for your design in the one design database

The new
Multivibrator design
database open in
the Design Explorer

The first step 
is to create a
new design
database
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pressing the menu hotkey (the underlined letter in the menu name). 
Any subsequent menu items will also have hot keys that you can
use to activate the item. For example, the shortcut for selecting the
View » Fit Document menu item is to press the V key followed by the
D key. Many submenus, such as the Edit » DeSelect menu, can be
called directly. To activate the Edit » DeSelect » All menu item you
need only press the X key (to call up the DeSelect menu directly)
followed by the A key.

Next we will set the general schematic preferences:

Select Tools » Preferences [shortcut T, P] from the menus to 
open the schematic Preferences dialog. This dialog allows 
you to set global preferences that will apply to all schematic
sheets you work on.

Click on the Default Primitives tab to make it active and 
enable the Permanent check box. Click the OK button to close
the dialog.

Before you start capturing your schematic, save this schematic sheet:

From the menus select File » Save [shortcut F, S]. 

Your blank sheet will be saved in the Documents folder.

You can save any schematic
sheet as a document
template, allowing you to
include special information
such as a custom company
title block, logo, and so on.

Refer to the Sheet Templates
topic in the Setting Up the
Schematic Workspace
chapter of the Protel 99 SE
Designer’s Handbook for
complete details on creating
a schematic template.

The Multivibrator
design database
open in the Design
Explorer. The
schematic sheet is
open, ready to start
the design.

6

Creating a new schematic sheet
To create a new blank schematic sheet complete the following steps:

In the panel on the left, expand the navigation tree by clicking on the small +
symbol next to the Multivibrator.ddb icon.

Click on the Documents folder icon to display the contents of the folder on
the right.

From the menu bar select
File » New.

In the New Document dialog
click on the Schematic
Document icon to select a
new schematic sheet.

Click the OK button to close
the dialog and create a new
schematic sheet icon in the
Documents folder.

The icon is created with a default name. Select Edit » Rename and type in the
new name for the sheet, Multivibrator.sch.

Double-click on the Multivibrator.sch icon to open the schematic sheet.

When the blank schematic sheet opens you will notice that the workspace
changes. The main toolbar includes a range of new buttons, two new toolbars are
visible, the menu bar includes new items, and the Panel changes to include
schematic component library management tools.

You can customize many aspects of the workspace. For example, you can
reposition the two “floating” toolbars. Simply click-and-hold the title area of the
toolbar and move the mouse to relocate the toolbar. To “dock” the toolbar, move
it to left, right, top or bottom edge of the main window area. To find out how to
customize other aspects of the workspace, see the topic, Using the Design
Explorer, in the main help file.

Setting the schematic options
The first thing to do before you start drawing your circuit is to set 
up the appropriate document options. Complete the following steps:

From the menus choose Design » Options, the Document Options
dialog will open. For this tutorial the only change we need to make
here is to set the sheet size to standard A4 format. In the Sheet Options
tab find the Standard Styles field. Click the arrow next to the entry to
see a list of sheet styles. 

Use the scroll bar to scroll up to the A4 style and click to select it.

Click the OK button to close the dialog and update the sheet size.

To make the document fill the viewing area again, select the View » Fit
Document menu item. In Protel 99 SE you can activate any menu by simply

Capturing the schematic

Protel 99 SE has a
multilevel Undo,
allowing you to undo
any number of
previous actions. The
maximum number of
Undo steps is user-
configurable, and
limited only by the
available memory on
your computer.
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to your schematic.

You will notice that a number of libraries appear in the Browse Sch
panel, which should be visible behind the open dialog – when you add
one library from a library database all libraries in that database are
added to the list of available libraries. Because all simulation-ready
libraries are now in the library list, we will not need to search for the
other components.

Close the Find Schematic Component dialog.

The libraries in the Sim.ddb will appear in the Browse Sch panel
whenever the Browse mode at the top of the panel is set to Libraries. As
you click on a library name in the upper list, the components in that
library are listed below. The component filter in the panel can then be
used to quickly locate a component within a library. 

Placing the components on your schematic
The first components we will place on the schematic are the two
transistors, Q1 and Q2. For the general layout of the circuit, refer to the
schematic drawing shown in Figure 1.

Select View » Fit Document from the menus [shortcut V, D] to ensure
your schematic sheet takes up the full window.

Set the Browse mode to Libraries in the Browse Sch Editor Panel.

Q1 and Q2 are BJT transistors, click on the BJT.LIB library to make it the
active library.

In the Filter section of the panel, type *3904* and press the ENTER key. A list of
components which have the text “3904” as part of their Part Type field will be
displayed.

Click on the 2N3904 entry in the list to select it, then click the Place button.

The cursor will change to a cross hair and you will have an outlined version of
the transistor “floating” on your cursor. You are now in “part placement” mode.
If you move the cursor around, the transistor outline will move with it.

Before placing the part on the schematic, first edit its properties.

While the transistor is floating on the cursor, press the TAB key. This
opens the Part dialog for the component.

In the Attributes tab of the dialog set the following values: for
Footprint, type TO92A and for Designator, type Q1. Leave all other
fields at their default values.

Click the OK button to return to placement mode.

You are now ready to place the part.

Move the cursor (with the transistor symbol attached) to position the
transistor a little left of the middle of the sheet.

Once you are happy with the transistor’s position, left-click or press
ENTER to “place” the transistor onto the schematic.

Move the cursor and you will find that a copy of the transistor has been placed on
the schematic sheet, but you are still in “part placement mode” with the part outline

Use the filter to
quickly locate

the component
you need

The link between the
schematic component
and the PCB
component is the
footprint. The footprint
specified in the
schematic is loaded
from the PCB library
when you load the
netlist. Double-click 
on a schematic 
component to specify
the footprint.
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Drawing the schematic
You are now ready to begin capturing (drawing) the schematic. For this tutorial
we will use the circuit shown below. This circuit uses two 2N3904 transistors
configured as a self-running astable multivibrator.

Locating the component and loading the libraries
To manage the thousands of schematic symbols included with Protel 99 SE, the
Schematic Editor provides powerful library search features. Work through the
following steps to locate and add the libraries you will need for the tutorial circuit:

From the menus select Tools » Find Component [shortcut T, O], or press the Find
button in the Schematic Editor Panel. This will open the Find Schematic
Component dialog.

First we will search for the transistors, both of which are type 2N3904.

Ensure there is a tick in the box next to the By Library Reference field (click in
the check box to enable it if necessary).

We want to search for all references to 3904, so in the By Library Reference text
field type *3904* (the * symbol is a wildcard used to take into account the
different prefixes and suffixes used by different manufacturers).

Ensure that the Search Scope is set to Specified Path, and that the Path field
contains the correct path to your schematic libraries. If you accepted the
default directories during installation, the path should be C:\Program Files\Design
Explorer 99 SE\Library\Sch\. Ensure that the Sub directories and Find All Instances
boxes are ticked.

Click the Find Now button to begin the search. There are over 60,000
components supplied with Protel 99 SE, so the search may take a couple of
minutes. If you have entered the parameters correctly, 2 libraries will be
found and displayed in the Found Libraries list.

Click on the BJT.LIB library to select it. This library has symbols for all the
available simulation-ready BJT transistors. Like all the simulation-ready
libraries, the BJT library is in the SIM.DDB library database. 

Click the Add To Library List button to make this library available 

Figure 1
A stable
multivibrator
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Once you have placed all the resistors, right-click or press ESC to exit part
placement mode.

Now place the two capacitors:

The capacitor part is also in the Simulation Symbols.Lib library, which
should already be selected in the Browse Sch panel.

Type *cap* in the Filter in the panel and press the ENTER key.
Click on CAP in the components list to select it, then click the Place button. You
will now have a capacitor symbol floating on the cursor.

Press the TAB key to edit the capacitor’s attributes. In the
Attributes tab of the Part dialog, set the Footprint to RAD0.1, the
Designator to C1, and the Part Type to 20n.
Click OK to close the dialog and return to part placement mode.

Press the SPACEBAR to rotate the capacitor by 90° so it is in the
correct orientation.

Position and place the two capacitors in the same way that you
placed the previous parts.

Right-click or press ESC to exit placement mode.

The last component to be placed is the connector. Connectors are
stored in the Miscellaneous Devices.ddb library database.  

Using the steps described earlier, add the Miscellaneous
Devices.ddb library database to the current library list.

Select the Miscellaneous Devices.lib library from the list of
libraries in the Browse Sch panel.

The connector we want is a two-pin socket, set the Filter to
*con2* and press ENTER.
Select CON2 from the parts list and click the Place button. Press TAB to edit the
attributes and set Footprint to FLY4 and Designator to Y1. Click OK to close the dialog.
Before placing the connector, press X to flip it horizontally so that it is in the
correct orientation. Place the connector on the schematic.

Right-click or press ESC to exit part placement mode.
Save your schematic by selecting File » Save from the menus [shortcut F, S].

You have now placed all the components. Note that the components in Figure 2
are spaced so that there is plenty of room to wire to each component pin. This is
important, you can not place a wire
across the bottom of a pin to get to a
pin beyond it, if you do both pins
will connect to the wire. If you need
to move a component click-and-hold
on the body of the component, then
drag the mouse to reposition it.  

To edit the
attributes of an
object placed on
the schematic,
double-click the
object to open its
Attributes dialog.

When you are in any editing 
or placement mode (a cross
hair cursor is active), moving
the cursor to the edge of 
the document window will
automatically pan the
document. If you accidentally
pan too far while you are
wiring up your circuit,
press the V,F key sequence
(equivalent to the View » Fit
All Objects menu item) to
redraw the schematic window,
showing all placed objects.
This can be done even when
you are in the middle of
placing an object.

Figure 2
Schematic with 
all parts placed
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floating on the cursor. This feature of Protel 99 SE allows you to place multiple
parts of the same type. So let us now place the second transistor.

Because this transistor is the same as the previous one, there is no need to edit
its attributes before we place it. Protel 99 SE will automatically increment a
component’s designator when you place a series of parts. In this case the next
transistor we place will automatically be designated Q2.

If you refer to the schematic diagram (Figure 1) you will notice that Q2 is
drawn as a mirror of Q1. To flip the orientation of the transistor that is
floating on the cursor, press the X key. This flips the component horizontally.
Move the cursor to position the part to the right of Q1. To position the
component more accurately, press the PAGEUP key twice to zoom in two
steps. You should now be able to see the grid lines.

Once you have positioned the part, left-click or press ENTER to place Q2.
Once again a copy of the transistor you are “holding” will be placed on the
schematic, and the next transistor will be floating on the cursor ready to be
placed.

Since we have now placed all the transistors, we will exit part
placement mode by clicking the right mouse button or pressing the
ESC key. The cursor will revert back to a standard arrow.

Next we will place the four resistors:

In the list of libraries in the Browse Sch Panel, scroll down and
select the Simulation Symbols.Lib library.

The Simulation Symbols.Lib library includes generic components
such as resistors, capacitors, voltage and current sources, and
linear and non-linear dependant sources.

In the Browse Sch panel set the Filter to *res* and press ENTER.
Click on RES in the components list to select it, then click the
Place button. You will now have a resistor symbol floating on
the cursor.

Press the TAB key to edit the resistor’s attributes.
In the Attributes tab of the Part dialog, set the Footprint to
AXIAL0.4, the Designator to R1, and the Part Type to 100k. 

Click OK to close the dialog and return to part placement mode.

Position the resistor above the base of Q1 (refer to the schematic
diagram in Figure 1) and left-click or press ENTER to place the part. 

Don’t worry about making the resistor connect to the transistor just yet. We will
wire up all the parts later.

Next place the other 100k resistor R2 above the base of Q2 (the designator
will automatically increment when you place the second resistor).

The remaining two resistors, R3 and R4, have a value of 1k, so press the TAB

key to call up the Part dialog and change the Part Type field to 1k, then click
OK to close the dialog.

Position and place R3 and R4 as shown in the schematic diagram in Figure 1.

Use the following
keys to manipulate
the part floating on
the cursor:

Y flips the part
vertically
x flips the part
horizontally
SPACEBAR rotates
the part by 90°

Use the following shortcut keys to
change your view of the sheet:

PAGEUP zooms in one step
PAGEDOWN zooms out one step
Shortcuts V,D redraws the sheet
to fit the current window
Shortcuts V,F redraws the sheet
so that all placed objects are
visible in the current window
The END key redraws the screen 

To reposition any object, simply
place the cursor directly over the
object, click-and-hold the left
mouse button, drag the object to a
new position and then release the
mouse button.



13

to an arrow.

Each set of component pins that you have connected to each other now form
what is referred to as a net. For example, one net includes: the base of Q1, one
pin of R1, and one pin of C1. 

To make it easy to identify important nets in the design you can add net labels.
To place net labels on the 2 power nets complete the following steps:

Select Place » Net Label from the menus. A dotted box will appear
floating on the cursor.

To edit the net label before it is placed press the TAB key to display
the Net Label dialog.

Type 12V in the Net field, then click OK to close the dialog.
Place the net label such that the bottom left of the net label touches
the upper most wire on the schematic, as shown in Figure 3. 

After placing the first net label you will still be in net label
placement mode, press the TAB key again to edit the second net label
before placing it.

Type GND in the Net field, click OK to close the dialog, then place the net label
as shown in Figure 3.

Select File » Save [shortcut F, S] to save your circuit.

Congratulations! You have just completed your first schematic capture. Before
we turn this schematic into a circuit board, let’s take a look at some of the
features Protel 99 SE includes to help you check your schematic design.

Figure 3
The fully wired
schematic

12

Wiring up the circuit
Wiring is the process of creating connectivity
between the various components of your circuit.
To wire up your schematic, refer to the diagram
in Figure 1 and complete the following steps:

To make sure you have a good view of the
schematic sheet, select View » Fit All Objects from the menus [shortcut V, F].
Firstly wire the resistor R1 to the base of transistor Q1 in the following
manner. Select Place » Wire [shortcut P, W] from the menus or click on the Wire
tool from the Wiring Tools toolbar to enter the wire placement mode. The
cursor will change to a cross hair.

Position the cursor over the bottom end of R1. When you
are in the right position a circle will appear at the cursor
location. This indicates that the cursor is over an electrical
connection point on the component.

Left-click or press ENTER to anchor the first wire point.
Move the cursor and you will see a wire extend from the
cursor position back to the anchor point.

Position the cursor so that it is below R1 and level with the
base of Q1.

Left-click or press ENTER to anchor the wire at this point. The
wire between the first and second anchor points will be placed.

Position the cursor over the base of Q1 until you see the
connection circle. Left-click or press ENTER to connect the
wire to the base of Q1.

Right-click or press ESC to finish placing this particular
wire. Note that the cursor remains a cross hair, indicating
that you are ready to place another wire. (To exit
placement mode completely and go back to the arrow
cursor you would right-click or press ESC again – but don’t
do this just now).

We will now wire C1 to Q1 and R1. Position the cursor
over the left connection point of C1 and left-click or press
ENTER to start a new wire.
Move the cursor horizontally till it is directly over the wire
connecting the base of Q1 to R1. A connection circle will
appear.  

Left-click or press ENTER to place the wire segment, then
right-click or press ESC to indicate that you have finished
placing the wire. Note how the two wires are automatically
connected.

Wire up the rest of your circuit, as shown in Figure 3.

When you have finished placing all the wires, right-click
or press ESC to exit placement mode. The cursor will revert

You can start the tutorial at this
point by opening the schematic 
Multivibrator placed.sch located
in the download design database
Multivibrator tutorial.ddb

To graphically edit the shape of
a wire, or any other graphical
object once it has been placed,
position the arrow cursor over
it and left-click once.

Small “editing handles” will
appear at each vertex (corner).
In Protel 99 SE we call this
“focusing” an object.

Click-and-drag an editing
handle to change the shape of
the object.

Whenever a wire runs across
the connection point of a
component, or is terminated on
another wire, Protel 99 SE will
automatically add a junction.

When placing wires, keep in
mind the following points: left-
click or press ENTER to anchor
the wire at the cursor position;
press BACKSPACE to remove the
last anchor point; after placing
the last segment of a wire,
right-click or press ESC to end
the wire placement – the
cursor will remain as a cross
hair and you can begin placing
another wire.

A wire that crosses
the end of a pin will
connect to that pin,
even if you delete
the junction. Check
that your circuit
looks like Figure 3
before proceeding.
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that it is focused). Press the DELETE key to delete the wire.
Re-run the ERC by selecting the Tools » ERC menu item [shortcut T, E] and
then clicking the OK button in the Setup Electrical Rule Check dialog.

A text window with the new ERC report will open giving a warning message that
you have an unconnected input pin in your circuit. A floating input pin error will
also be generated, there is a special option to check for floating input pins in the
Setup tab of the ERC dialog.

To view the ERC report and the schematic sheet together, right-mouse click
on the Multivibrator.ERC tab at the top of the ERC text window, then select Split
Horizontal from the floating menu. The design window will split into 2 regions,
the upper region displaying the schematic, the lower region the ERC report.

Click on the schematic sheet to make it active and then select View » Fit All
Objects from the menus [shortcut V, F] to resize your schematic to fit the new
window size. Note the crossed red circle on Q1 indicating the error.

When an ERC detects a number of errors  in a circuit, you can use Protel 99 SE’s
“Cross Probe” feature to easily find particular errors. While only
one error is present in our circuit, you can see how the Cross Probe
feature works by completing the following steps:

Click on the tab of the ERC report to make it active. 

The error information includes designator and pin details 
(eg Q1-2), and location details (eg @430,390). Double-click
on one of the location details to select it.

Click on the Cross Probe tool in the main toolbar. The
corresponding error will be centered in the schematic window,
and the cursor will point to the location.

Before we finish this section of the tutorial, let’s fix the
error in our schematic:

Click on the tab of the schematic sheet to make it active.

Select Edit » Undo from the menus [shortcut E, U]. The wire you deleted
previously should now be restored.

To check that the undo was successful, re-run the ERC by selecting Tools »
ERC from the menus [shortcut T, E] and clicking OK in the resulting dialog.
The ERC report should show no errors.

Select File » Close from the menus to close the error report window, then
select View » Fit All Objects [shortcut V, F] from the menus to restore your
schematic view.

Congratulations! You are ready to transfer the design to PCB layout.

Cross Probing works
between many different
types of documents in
Protel 99 SE. For example,
you can cross probe from a
schematic component to
the corresponding footprint
in a PCB design. The Cross
Probe feature is a powerful
tool when working in
complex designs.
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Checking the electrical properties of your schematic
Schematic diagrams in Protel 99 SE are more than just simple drawings – they
contain electrical connectivity information about the circuit. You can use this
connectivity awareness to verify your design. To do this, perform an Electrical
Rules Check (ERC) by completing the following steps:

Select Tools » ERC [shortcut T, E] from the
menus. This will open the Setup Electrical
Rule Check dialog.

The Setup tab of this dialog includes
checks for drafting-type errors. Leave the
settings on this tab at their default values.

Click on the Rule Matrix tab. This controls
the electrical characteristics of the ERC.

The matrix gives a graphical representation of
different types of connection points on a
schematic and whether they are allowable or
not. For example, look down the entries on the
left side of the matrix diagram and find Output
Pin. Read across this row of the matrix till you
get to the Open Collector Pin column. The square
where they intersect is red indicating that an
Output Pin connected to an Open Collector Pin
on your schematic will generate an error
condition when the ERC is run. Our circuit
contains only Passive Pins (on resistors, 

capacitors and the connector) and Input Pins (on the transistors).

Let’s check to see if the ERC will detect unconnected input pins:

Look down the row labels to find Input Pin. Look across the column labels to
find Unconnected. The square where these entries intersect indicates the error
condition when an Input Pin is found to be Unconnected in the schematic.
The default is a yellow square, which indicates that a warning will be
generated for unconnected input pins. 

Click the OK button to run the ERC. A text window will open with an ERC
report for your circuit.

If your circuit is drawn correctly, the ERC should be blank. If the report gives
errors, check your circuit and ensure all wiring and connections are correct. If
you can’t find the error in your schematic, try opening the Multivibrator.Sch file in
the Tutorial_1.ddb download database and repeating the above steps.

We will now deliberately introduce an error into our circuit and re-run the ERC:

Click on the Multivibrator.sch tab at the top of the window to make the
schematic sheet the active document.

Click in the middle of the wire that connects C1 to the base wire of Q1
(small, square editing handles will appear at each end of the wire to indicate
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Designing the PCB
Creating a new PCB file
Before you transfer the design from the schematic editor to the PCB editor you need
to create the “blank PCB”. The easiest way to create a new PCB design in Protel 99
SE is to use the PCBMaker Wizard, which allows you to choose from over 60
industry-standard board outlines as well as create your own custom board sizes. To
create a new PCB using the PCBMaker Wizard, complete the following steps:

Open the Multivibrator.ddb design database, then click on the Documents folder
in the navigation tree on the left.

Select File » New from the menus [shortcut F, N], then click on the Wizards tab
in the New Document dialog.

Click the Printed Circuit Board Wizard icon 
to select it, then click the OK button 
to start the Wizard.

The first screen you see 
is the introduction page. 
Click the Next button 
to continue.

The second page allows
you to select the board
outline you wish to use.
For this tutorial we will
enter our own board size.
Select Custom Made Board
from the list of board outlines and then click
the Next button.

In the next page you enter custom board
options. For the tutorial circuit a 2 x 2 inch
board will give us plenty of room. Type 2000 in both the Width and Height
fields. Also, turn off the Corner Cutoff and Inner Cutoff options. Leave the other
fields at their default values. Click the Next button to continue. Note that the
default units for this dialog are mils: 1000mil = 1inch. 

The next page displays the board outline, you can adjust the sizes if
necessary. We will leave the options on this page as they are, click the Next
button to continue.

The next page allows you to select the physical makeup of the board. Leave
the options on this screen set to their defaults. Click the Next button to continue.

The next page allows you to select the types of vias used in the design. Leave
the options on this screen set to their defaults. Click the Next button to continue.

The next page allows you to set the routing options. Select the Thru-hole
components option, and set the number of tracks between adjacent pads to One
Track. Click the Next button to continue.

The next page allows you to set up some of the design rules that apply to
your board. Leave the options on this screen set to their defaults. Click the
Next button to continue.

The next page allows you to save your custom board as a template, allowing
you to create new boards based on the parameters you have just entered. We
do not want to save our tutorial board as a template, confirm that this option
is unchecked and press the Next button to continue.

The PCB Wizard has now collected all the information it needs to create
your new board. Click Finish to close the Wizard. The PCB document editor
will open with your new board outline.

Save the document by selecting File » Save from the menus, then close
it by selecting File » Close.

The new board has been created with the name PCB1.PCB. To
rename the PCB click on the Documents folder in the navigation tree,
then click once on the PCB1.PCB icon displayed on the right to select
it. Select Edit » Rename from the menus, type in the new name,
Multivibrator.pcb, and press ENTER.
Double-click on the Multivibrator.pcb icon to open the PCB, ready to start the
board design.

The PCB Editor
supports imperial and
metric units. Select
View » Toggle Units
to switch.

The PCB
workspace
with the
custom board
outline
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Adding the PCB Footprint libraries
Recall that when we placed the components on our schematic, we typed entries in
the Footprint field of each component’s attributes dialog. Before Protel 99 SE
knows how to handle the various schematic components you have used in your
circuit, it needs a representation or “footprint” for each part. The text we typed
into the footprint fields indicates which footprint to use in the PCB design. 
Protel 99 SE comes supplied with over 35 PCB footprint libraries, including a
number of IPC standard libraries. Before we begin our PCB design we need to
make sure the appropriate footprint libraries are available.

To add the necessary footprint libraries, complete the following steps:

Select Design » Add/Remove Library [shortcut D, L] from the menus to open the
PCB Libraries dialog.

The footprint library databases are located in 3 sub-folders in the \Program
Files\Design Explorer 99 SE\Library\PCB\ folder. Navigate to the \Generic Footprints\
folder to display a list of available generic library databases. For our tutorial
we want two library databases: Advpcb.ddb, which includes a number of
general axial and radial component footprints, and Transistors.ddb, which
contains transistor footprints. Find and select each of these libraries in turn
and press the Add button in the PCB Libraries dialog to add them to the
Selected Files list. When you have added both libraries, click the OK button to
close the dialog.

To check that the correct libraries are available, select Libraries from the drop
down list in the Browse PCB Editor Panel. PCB Footprints.lib and Transistors.lib
should both appear in the list.

Remember that we set the resistors in our schematic to have a footprint entry
of AXIAL0.4. To view this footprint, click on PCB Footprints.lib in the library
list in the Browse PCB Panel. Now scroll down the Components list until you
see the AXIAL0.4 entry. Click on the entry to make it active. A “thumbnail”
of the footprint will appear in the MiniViewer window in the PCB Editor
Panel, as shown in Figure 4.

We now have all the PCB footprint libraries loaded. Let’s turn our attention to
loading our circuit design.

Transferring the design
Transferring the design from the schematic editor to the PCB editor is easy in
Protel 99 SE. To transfer the design:

Click on the Multivibrator.sch tab at the top of the design window to make the
schematic the active document. 

Select Design » Update PCB from the menus.

The Update Design dialog will appear. Uncheck the 2 Classes options at the
bottom of the Synchronization tab, leave all the other settings at their defaults.

Click on the Preview Changes button at the bottom of the dialog to examine
what changes will be carried out. The Changes tab should list 35 macros,
detailing what components, nets and net nodes will be added to the PCB. 

A macro is created for each design change that needs to be performed to get the
contents of the PCB file to correspond to the schematic. Any macro that has an
error listed will not be executed. Click on the Help button for information on
resolving macro errors.

Click the Execute button to close the dialog
and execute the netlist macros.

Once the design transfer is complete, click
on the Multivibrator.pcb tab at the top of the
window to display the board.

The components in your design will appear to
the right of the board outline. Before we start
positioning the components on the board we
need to set up the PCB workspace. 

Setting up the PCB workspace
Before we start positioning the components we need to ensure that our placement
grid is set correctly. All the objects placed in the PCB workspace are
aligned on a grid called the “snap grid”. This grid needs to be set to
suit the routing technology that you intend to use. Our tutorial circuit
uses standard imperial components that have a minimum pin pitch of
100mil. We will set the snap grid to an even fraction of this, say 50 or
25mil, so that all component pins will fall on a grid point when
placed. Also, the track width and clearance for our board are 12mil
and 13mil respectively (the default values used by the PCB Board
Wizard), allowing a minimum of 25mil between parallel track centers. The most
suitable snap grid setting would, therefore, be 25mil. To set the snap grid,
complete the following steps:

Select Design » Options from the menus [shortcut D, O] to open the Document
Options dialog, and click on the Options tab to make it active.

Set the value of the Snap X, Snap Y, Component X and Component Y fields of the
dialog to 25mil. Note that this dialog is also used to define the electrical grid.
The electrical grid operates when you place an electrical object, it overrides
the snap grid and “snaps” electrical objects together.

Click OK to close the Document Options dialog.

Let’s set some other options that will make positioning components easier:

Select Tools » Preferences from the menus [shortcut T, P] to open the PCB
Preferences dialog. In the Editing Options section of the Options tab, ensure the
Snap to Center option is checked. This ensures that when you “grab” a
component to position it, the cursor is set to the component’s reference point.

Click the Display tab in the Preferences dialog to make it active. In the Show
section of this tab, uncheck the Show Pad Nets, Show Pad Numbers and Via Nets
options. In the Draft Thresholds section of this dialog, set the Strings field to 4
pixels, then close the Preferences dialog.

You can start the tutorial
at this point by opening
the PCB multivibrator
components.pcb in the
download design database
Multivibrator tutorial.ddb

Figure 5
The components
next to the
board, ready for
positioning

Figure 4
Use the
MiniViewer to
preview the
component
footprints



2120

Setting up new design rules
The Protel 99 SE’s PCB editor is called a “rules-driven environment”, but exactly
what does this mean?  As you work in the PCB editor and perform actions that
change the design, such as placing tracks, moving components, or autorouting the
board, the PCB editor constantly monitors each action and checks to see if the
design still complies with the design rules. If it does not, then the error is
immediately highlighted as a violation. Setting up the design rules before you start
working on the board allows you to remain focused on the task of designing,
confident in the knowledge that any design errors will immediately be flagged for
your attention.

There are 48 design rules, divided into 6 categories. These rules cover routing,
manufacturing, high speed design, placement and signal integrity requirements.

We will now set up new design rules to specify the width that the power nets must
be routed. To set up these rules complete the following steps:

With the PCB as the active document, select Design » Rules from the menus. 

The Design Rules dialog will appear. Each category of rules is displayed on a
separate tab. Click on the Routing tab to make it active.

Click once on each rule in the Rules Classes list to select it. As you click on
each rule, the lower half of the dialog displays the rules of that kind that are
already set up. These rules are either defaults, or have been set up by the
Board Wizard when the new PCB document was created.

Click on the Width Constraint rule in the Rule Classes list. One rule will be
displayed in the lower half of the dialog. 

One of the powerful features
of Protel 99 SE’s design rule
system is that multiple rules
of the same type can be
defined, each targeting
different objects. The exact
set of objects that each rule
targets is defined by that
rule’s scope. The rule system
uses a pre-defined hierarchy
to work out which rule to
apply to each object.

For example, you could
have a width constraint rule
for the whole board
(meaning all tracks must be
this width), a second width constraint rule for the ground net (this rule overrides the
previous rule), and a third width constraint rule for a particular connection on the
ground net (which overrides both of the previous rules). 

Defining the layer stack and other non-electrical layers
If you look at the bottom of the PCB workspace you will notice a series of layer
tabs. The PCB Editor is a multi-layered environment, and most of the editing
actions you perform will be on a particular layer. 

There are 3 types of layers in the PCB Editor:

Electrical layers – these include the 32 signal layers and 16 plane layers. Electrical
layers are added to and removed from the design in the Layer Stack Manager,
select Design » Layer stack Manager to display this dialog.

Mechanical layers – there are 16 general purpose mechanical layers for defining the
board outline, placing dimensions on, including fabrication details on, or any other
mechanical details the design requires. These layers can be selectively included in
print and Gerber output generation. Select Design » Mechanical Layers to display the
Setup Mechanical Layers dialog, where you can add, remove and name
mechanical layers.

Special layers – these include the top and bottom silkscreen layers, the solder and
paste mask layers, drill layers, the keepout layer (used to define the electrical
boundaries), the multilayer (used for multilayer pads and vias), the connection
layer, DRC error layer, grid layers and hole layers. The display of these special
layers is controlled in the Document Options dialog (Design » Options).

The tutorial is a simple
design and can be routed as
a single, or double-sided
board. If the design was
more complex you would
add more layers in the Layer
Stack Manager. Select
Design » Layer Stack Manager
to display this dialog.

New layers and planes are
added below the currently
selected layer. Layer
properties , such as copper
thickness and dielectric
properties are used for
signal integrity analysis.
Click OK to close the dialog.

The new board has opened with many more layers enabled than you will use, so let’s
turn off all the unnecessary layers. To turn off layers complete the following steps:

Press the L shortcut key to display the Layers tab of the Document Options dialog.
Click the Used On button to disable all layers except those that have something
on them.

Disable the 4 Mask layers and the Drill Drawing layer, then click OK to close the dialog.

Rules are
displayed in
their order 
of priority
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Protel 99 SE’s powerful global editing in the next part
of the tutorial to hide the component comments
(values), as these will not be required on the final board.

Protel 99 SE also includes powerful interactive
placement tools, let’s use these to ensure that the 4
resistors are correctly aligned and spaced.

Holding the SHIFT key, left-click on each of the 4
resistors to select them. Each resistor’s color will
change to the selection color (the default is
yellow).
Click on the Align Tops of Selected Components button
on the Component Placement toolbar – the four resistors will align along their
top edge.
Now click on the Make Horizontal Spacing of Selected
Components Equal button on the Component Placement
toolbar.
Press the X, A shortcut keys to deselect all the resistors. 

The four resistors are now aligned and equally spaced.

Global editing
Both the schematic and the PCB editors include a powerful editing aid – referred
to as global editing. Global editing is the ability to apply the same change that
you are currently making, to other objects in the workspace. Let’s do an example
to demonstrate it.

You have finished positioning the components and you decide that you do not
want the component comments to be displayed. To hide all the component
comments complete the following steps:

Double-click on one of the comment strings to open its Comment dialog,
then click to enable the Hide option.

To apply this change globally to all
components, click on the Global button.
This displays the global editing options
for the dialog.

There are now 3 sections to the dialog; the
original attributes on the left, the Attributes to
Match By in the center, and the Copy Attributes
on the right. 

The options in the Attributes to Match By section
define which other comment strings you want
this change to apply to. For example, if you
only needed to change the attributes of a few
of the comment strings you could select those strings first, then during the global
edit you would match by Selection, targeting only the required comment strings. 

In this case we want the change to apply to all the comment strings so leave

Currently there is one width constraint rule for your design, which applies to the
whole board. We will now add 2 new width constraint rules, one for the 12V net
and another for the GND net. 

To add new width constraint rules complete the following steps:

Click the Add button to add a new width constraint rule. Like all the rule
definition dialogs, there are 2 regions to the Max-Min Width Rule dialog. On
the left of the dialog you define the scope (what you want this rule to target),
and on the right of the dialog you define the rule attributes. 

Let’s set this rule up to target the 12V net. Select Net from the Filter Kind list.
When you do a new field titled Net will appear, select 12V from this list.

In the Rule Attributes section of the dialog change the Minimum Width, Maximum
Width and Preferred Width fields to 25mil, then click OK to close the dialog.
The lower region of the Design Rules dialog now includes the new width
constraint design rule.

Now add another new width constraint design rule for the GND net.

Double-click to edit the original Board scope width rule, and confirm that
the Minimum Width, Maximum Width and Preferred Width fields are all set to 12mil. 
Close the Design Rules dialog.

When you route the board all tracks will be 12mils wide, except the GND and
12V tracks, which will be 25mils.

Positioning the components on the PCB
Before we start positioning the components on the PCB let’s change the view to
zoom in to the board:

Press the V, F shortcut keys to zoom in on the board and components.
To place the connector Y1, position the cursor over the middle
of the outline of the connector, and click-and-hold the left
mouse button. The cursor will change to a cross hair and jump
to the reference point for the part.

While continuing to hold down the mouse button, move the
mouse to “drag” the component.

While dragging the connector, press the SPACEBAR to rotate it by
90°, and position it toward the left-hand side of the board
(ensuring that the whole of the component stays within the
board boundary), as shown in Figure 6.

When the component is in position, release the mouse button to
“drop” it into place. Note how the connection lines drag with
the component.

Reposition the remaining components, using Figure 6 as a guide. Use the
SPACEBAR key as necessary to rotate components as you drag them, so that the
connection lines are as shown in Figure 6. Don’t forget to re-optimize the
connection lines as you position each component.

Component text can be repositioned in a similar fashion – click-and-hold to drag
the text, press the SPACEBAR to rotate it. Before repositioning the text we will use

The connection lines are
automatically re-optimized
as you move a component. 
In this way you can use the
connection lines as a guide
to the optimum position 
and orientation of the
component as you place it.

The thicker green/red line 
is a placement force vector,
it  indicates better/worse
placement locations.

Figure 6
Components
placed on 
the PCB
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Manually routing the board
While autorouting provides an easy and powerful way to
route a board, there will be situations where you will need
exact control over the placement of tracks – or you may
want to route the board manually just for the fun of it! In
these situations you can manually route part or all of your
board. In this section of the tutorial we will manually
route the entire board “single-sided”, with all tracks on
the bottom layer:

To remove the tracks placed by the autorouter, select
Tools » Un-Route » All from the menus [shortcut U, A].
The board will be completely un-routed.

We will now place tracks on the bottom layer of the
board, using the “ratsnest” connection lines to guide us.

In Protel 99 SE, tracks on a PCB are made from a series of
straight segments. Each time there is a change of direction,
a new track segment begins. Also, by default Protel 99 SE
constrains tracks to a vertical, horizontal or 45°
orientation, allowing you to easily produce professional
results (this behavior can be customized to suit your needs,
but for this tutorial we will stay with the default).

Select Place » Interactive Routing from the menus
[shortcut P, T] or click the Interactive Routing button on
the Placement toolbar. The cursor will change to a
cross hair indicating you are in track placement mode.

Examine the layer tabs that run along the bottom of
the document workspace. The TopLayer tab should
currently be active. To switch to the bottom layer
without dropping out of track placement mode, press
the * key on the numeric keypad (this key toggles
between the available signal layers). The BottomLayer
tab should now be active.

Position the cursor over the bottom-most pad on the
connector Y1. Left-click or press ENTER to anchor the
first point of the track.

Move the cursor towards the bottom pad of the
resistor R1. Note how the track is laid. By default,
tracks are constrained to vertical, horizontal or 45°
directions. Also note that the track has two segments.
The first (coming from the starting pad) is solid blue.
This is the track segment you are actually placing.
The second segment (attached to the cursor) is called
the “look-ahead” segment and is drawn in outline.
This segment allows you to look ahead at where the

the Attributes to Match By options unchanged. 

The options in the Copy Attributes section define what changes will be copied
to each of the matched objects.  Ensure that the Hide option in the Copy
Attributes section has a tick next to it.

Set the Change Scope at the bottom of the dialog to All primitives (free
primitives are those primitives that are not part of a component).

Click the OK button to close the dialog. A confirmation message will appear
asking if you want to make 8 changes. Click Yes to apply the changes. 

The comment string for each component will disappear. You can unhide a
component comment by double-clicking on the component.

Now reposition the component designator strings.

When you have finished repositioning the component designators save your
board by selecting File » Save from the menus [shortcut F, S].

With everything positioned it’s time to lay some tracks!

Automatically routing the board
Routing is the process of laying tracks and vias on
the board to connect the components. Protel 99 SE
makes the job of routing easy by providing a
number of sophisticated manual routing tools as well
as a powerful and easy-to-use shape-based
autorouter, which optimally routes the whole or part
of a board at the touch of a button. To see how easy it is to autoroute with Protel
99 SE, complete the following steps:

Select Autoroute » All from the menus [shortcut A, A]. The Autorouter Setup
dialog will appear, click the Route All button to route the board.

When the autorouter has finished, press the END key to redraw the screen.

It’s as simple as that! Protel 99 SE’s autorouter provides
results comparable with that of an experienced board
designer. And because Protel 99 SE routes your board directly
in the PCB window, there is no need to wrestle with exporting
and importing route files.

Select File » Save [shortcut F, S] to save your board.

Note that the tracks placed by the autorouter appear in two
colors: red indicates that the track is on the top signal layer of
the board, and blue indicates the bottom signal layer. The
layers that are used by the autorouter are specified in the
Routing Layers design rule, which was set up by the board
Wizard. You will also notice that the 2 power net tracks

running from the connector are wider, as specified by the 2 new Width Constraint
design rules you set up. Don’t worry if the routing in your design is not exactly
the same as Figure 7, the component placement will not be exactly the same, so
neither will the routing be.

note how the
connection line 
guides you to the 
target pad

segment you are 
currently placing

look-ahead segment

position the cursor
over the pad on R1

click a 2nd time 
to place this track
segment

3rd click to place the next
track segment,
you have now routed
this connection

1st click starts you 
placing a track – now
move the cursor toward
the bottom pad on R1

You can start the tutorial at
this point by opening the PCB
multivibrator placed.pcb in the
download design database 
Multivibrator tutorial.ddb

Figure 7
Fully
autorouted
board
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segment you are placing.
• Press the END key at any time to redraw the screen.
• Press the V, F shortcut keys at any time to redraw the

screen to fit all objects.
• Press the PAGEUP and PAGEDOWN keys at any time to zoom

in or out, centered on the cursor position.
• Press the BACKSPACE key to “un-place” the last track

segment.
• Right-click or press the ESC key when you have

finished placing a track and want to start a new one.
• You cannot accidentally connect pads that should not

be wired together. Protel 99 SE continually analyzes
the board connectivity and prevents you from making
connection mistakes or crossing tracks.

• To delete a track segment, left-click on it to focus it. The segment’s
“editing handles” will appear (the rest of the track will be highlighted in
yellow). Press the DELETE key to clear the focused track segment.

• Re-routing is easy in Protel 99 SE – simply route the new track
segments, when you right-click to finish the old redundant track
segments will automatically be removed.

• When you have finished placing all the tracks on your PCB, right-click
or press the ESC key to exit placement mode. The cursor will change back
to an arrow.

Congratulations! You have manually routed your board design.

Because we originally defined our board as being double-sided in the PCBMaker
Wizard, you could manually route your board “double-sided” using both the top
and bottom layers. To do this, un-route the board by selecting Tools » Un-Route » All
from the menus [shortcut U, A]. Start routing as before, but use the * key to toggle
between the layers while placing tracks. Protel 99 SE will automatically insert
vias if necessary when you change layers.

Verifying your board design
Protel 99 SE provides a rules-driven environment in which to design PCBs, and
allows you to define many types of design rules to ensure the
integrity of your board. Typically you set up the design rules at the
start of the design process, then verify that the design complies with
the rules at the end of the design process.

Earlier in the tutorial we examined the routing design rules and
added 2 new width constraint rules. We also noted that there were
already a number of rules that had been created by the board
creation wizard.

To verify that the routed circuit board conforms to the design rules, we will now
run a Design Rule Check (DRC):

Choose Design » Options from the menus [shortcut D, O], and if necessary click
the Layers tab to make it active.

next track segment you lay could be positioned so that you can easily work
your way around obstacles, maintaining a 45°/90° track orientation.

Position the cursor over the middle of the bottom pad of resistor R1 and left-
click or press the ENTER key. Note that the first track segment turns yellow,
indicating that it has been placed. Move the cursor around a little and you
will see that you still have two segments attached to the cursor: a solid blue
segment that will be placed with the next mouse click, and an outlined
“look-ahead” segment to help you position the track.

Re-position the cursor over the bottom pad of R1. You will have a solid blue
segment extending from the previous segment to the pad. Left-click to place
the solid blue segment. It will turn yellow, indicating it has been placed.

You have just routed the first connection.

Move the cursor to position it over the bottom pad of resistor R4. Note a
solid blue segment extends to R4. Left-click to place this segment. It will
now turn yellow.

Now move the cursor to the bottom pad of resistor R3. Note that this
segment is not solid blue, but drawn in outline indicating it is a look-ahead
segment. This is because each time you place a track segment the mode
toggles between starting in a horizontal/vertical direction and starting at 45°.
Currently it is in the 45° mode. Press the SPACEBAR key to toggle the segment
start mode to horizontal/vertical. The segment will now be drawn in solid
blue. Left-click or press the ENTER key to place the segment.
Move the cursor to the bottom of resistor R2. Once again you will need to
press the SPACEBAR key to toggle the segment start mode. Left-click or press
the ENTER key to place the segment.
You have now finished routing the first net. Right-click or press the ESC key
to indicate that you have finished placing this track. The cursor will remain a
cross hair, indicating that you are still in track placement mode, ready to
place the next track. Press the END key to redraw the screen so that you can
clearly see the routed net.

You can now route the rest of the board
in a similar manner to that described in
the previous steps. Figure 8 shows the
manually routed board.

Save the design.

Keep in mind the following points as you are
placing the tracks:

• Left-clicking the mouse (or pressing
the ENTER key) places the track
segment drawn in solid color. The
outlined segment represents the look-
ahead portion of the track. Placed
track segments are shown in yellow.

• Press the SPACEBAR key to toggle
between the start horizontal/vertical and start 45° modes for the track

Figure 8
Manually
routed board,
with tracks
placed on the
bottom layer

Note that the look-ahead segment is clipping
(no longer attached to the cursor). The PCB
Editor will prevent you from accidentally
placing a track across another object that
would cause a violation. This connection
must be routed around the capacitor.

You can start the tutorial at
this point by opening the
PCB multivibrator
routed.pcb in the download
design database 
Multivibrator tutorial.ddb
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In the System section of this dialog, ensure that the DRC Errors
option is checked.

Click the OK button to close the dialog.

Choose Tools » Design Rule Check from the menus [shortcut T, D].
Both the on-line and batch DRC options are configured in the
Design Rule Check dialog. Leave all options at their defaults and
click the Run DRC button.

The DRC will run and the results will be displayed in a text file.
Look through this DRC report file. It lists each active design rule,
and any violations that occur in the PCB design. Notice that there
are four violations listed under the Clearance Constraint rule. The
details show that the pads of transistors Q1 and Q2 violate the
13mil clearance rule. If you switch to your PCB document, you
will see that the transistor pads are highlighted in green, indicating
a design rule violation.

Normally you would set up the clearance constraint rules before
laying out your board, taking account of routing technologies and
the physical properties of the devices. Let’s analyze the error then
review the current clearance design rules and decide how to
resolve this situation.

To find out the actual clearance between the transistor pads:

With the PCB document active, position the cursor over the
middle of one of the transistors and press the PAGEUP key to zoom in.
Select Reports » Measure Primitives from the menus [shortcut R, P]. The cursor
will change to a cross hair and you will be prompted on the status bar to
“Choose First Primitive”.

Position the cursor over the middle of the lower pad on the transistor and
left-click or press ENTER. Because the cursor is over both the pad and the track
connected to it, a menu will pop up to allow you to select the desired object.
Select the transistor pad from the popup menu.

Position the cursor over the middle of one of the other transistor pads and
left-click or press ENTER. Once again select the pad
from the popup menu.

An information box will open showing the
minimum distance between the edge of the two
pads is 10.711mil. 

Close the information box, then right-click or
press ESC to exit the measurement mode, use
the V, F shortcut to re-zoom the document.

Let’s look at the current clearance design rules.

Select Design » Rules from the menus [shortcut D, R] to open the Design Rules
dialog. Click on the Routing tab to make it active, then in the Rule Classes list
click once on the Clearance Constraint to select it. The region at the bottom of

You can also use the PCB
editor panel to find design rule
violations. Set the Browse
mode at the top of the panel
to Violations, then use the
Details, Highlight and Jump
buttons to find and analyze
the design rule errors.

To make it easier to see the
design rule violations you can
display the primitives in draft
mode. Select Tools »
Preferences, click on the
Show/Hide tab, then click the
All Draft button. When you
close the dialog all primitives
will be shown in draft mode,
except those that are marked
with a DRC error marker. Click
the All Final button in the
Show/Hide tab to display the
primitives as solids again.

the dialog will contain a single rule, specifying that the minimum
clearances for the whole board are 13mil. The clearance between
the transistor pads is 
less than this, which is why they generate a violation when we 
run a DRC.

We now know the minimum distance between transistor pads is a little
over 10mil, so let’s set up a design rule that allows the clearance
constraint to be 10mil for the transistors only.

Click the ADD button to add 
a new clearance constraint rule.

In the Rule Attributes section 
of the resulting dialog, set the 
Minimum Clearance to 10mil.

In the Rule Scope section, 
use the drop-down list to 
change the first Scope Kind
field to Footprint-Pad.
Select TO92A in the Footprint field.

Type an * (asterisk) in the Pad field, 
indicating “any pad” on the TO92A.

Click OK to close the dialog.

The new rule will appear in the lower
region of the Design Rules dialog.

You can now re-run the DRC from the Design Rules dialog by clicking 
the Run DRC button, then clicking the Run DRC button in the Design Rules
Check dialog.

A new report will be generated – this report should show no rule violations.

You have completed the PCB layout, and are ready 
to produce the output documents.

Protel 99 SE supports
fully-hierarchical design
rules. You can set any
number of rules of the
same class, each with a
defined scope. The rule
scope determines the
rule’s precedence.
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Printing to a Windows printing device
Once the layout and routing of the PCB is complete you are ready to produce the
output documentation. This documentation might include a manufacturing drawing
detailing the fabrication information, and assembly drawings detailing component
location information and loading order.

To produce these drawings Protel 99 SE includes a sophisticated printing engine,
called Power Print, that gives you complete control over the printing process.
Using Power Print you first preview the drawings (called printouts), where you can
define precisely what mix of PCB layers you want to print, set the scaling and
orientation, and see exactly how it will look on the page before you print it. 

Print/preview setups are stored as .PPC documents in your design – they can be
renamed, reopened at any time, and copied from one design to another.

To create a print preview document:

Select File » Print/Preview from the PCB menus.

The PCB will be analyzed, and a default printout displayed in a new
PPC window. The default composite preview includes 1 printout. 

To examine the set of PCB layers that are included in the printout,
click on the Browse PCBPrint tab at the top of the panel to display the
printout set, then click on the small + symbol to expand the
Multilayer Composite Print, as shown in Figure 9. 

A print preview document (.PPC) can include any number of printouts, and each
printout can include any combination of layers, overlaid in any order you require.

To change the default composite printout to a composite drill guide, select
Tools » Create Composite Drill Guide from the menus, clicking Yes in the Confirm
Create Print-Set dialog.

The PCB is re-analyzed, and a new printout displayed.

Click on the small + symbol next to the Combination Drill Guide printout
in the Browse PCBPrint panel to display the layers in the printout.

This printout includes both the drill guide, a system layer which includes a
small cross at each drill site, and the drill drawing layer, which includes a
special shape at each drill site, unique for each drill size. 

The drill guide layer is not required in a typical drill drawing, to remove
it right-click on the DrillGuide layer in the panel and select Delete from the
floating menu.

Note the printer icon at the top of the Browse PCBPrint panel – the
printouts will target your default windows printer. 

To change the target printer, and set the page orientation and scaling, select
File » Setup Printer from the menus – then choose your preferred printer and set
the Orientation to landscape in the PCB Print Options dialog.

The preview will be re-analyzed and displayed, ready for printing.

Select File » Print All from the menus to print the drill drawing. For information on
the various printing options refer to the Print Options menu item in the Help menu.

Manufacturing output files
The final phase of the PCB design process is to generate the manufacturing files.
The set of files that are used to manufacture and fabricate the PCB include Gerber
files, NC drill files, pick and place files, a bill of materials and testpoint files. 

All of these files are configured in and produced by Protel 99 SE’s CAM
Manager. The setups for the manufacturing documents are stored in a .CAM
document in the design database.

To create the manufacturing files for the tutorial PCB, make the PCB the
active document, then select File » CAM Manager from the PCB Editor menus.

A new CAM document is created, and the Output Wizard launched. 

The Wizard can be used to create each of the supported output file types,
click Next to display the list of available types.

Select Gerber from the list and click Next for each page of the Wizard,
leaving the options on each page at the defaults, then Finish on the last page. 

Once the Wizard closes, the CAM document will display one CAM output
setup, called Gerber Output 1. The setup of the Gerber files can be changed at
any time, double-click on the name Gerber Output 1 to display the Gerber
Setup dialog. 

Each Gerber file corresponds to 1 layer in the physical board – the component
overlay, top signal layer, bottom signal layer, the solder masking layers, and so
on. It is advisable to consult with your PCB manufacturer to confirm their
requirements before generating the Gerber and NC drill files required to fabricate
your design.

Figure 9 
Default
composite
printout,
includes all
the used
layers on
the board

Power Print gives
you complete
control over the
printing process

Select Edit » Copy
from the menus to copy
the current printout to
the clipboard and paste
it into another Windows
application.

Select File » Export to
export the printouts to
the hard disk as WMF
or EMF files.
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Simulating the design

Protel 99 SE allows you to run a vast array of circuit simulations directly from a
schematic. In the following sections of the tutorial we will simulate the output
waveforms produced by our multivibrator circuit.

Setting up for simulation
Before we can run a simulation we need to add a few things to our
circuit – a voltage source to power the multivibrator, a ground
reference for the simulations, and some net labels on the points of
the circuit where we wish to view waveforms.

Click on the Multivibrator.sch tab at the top of the window to
make the schematic the active document. 

The first step is to replace the connector with a voltage source. 

To delete the connector, click once on the body of the connector to focus it 
(a dotted focus box will appear around the connector), then press the DELETE

key on the keyboard.

At the moment there is not enough room for the voltage source, so we’ll move 
the free ends of the wires. 

To move the dangling end of the 12V wire click once on the wire to focus it.
When the small square editing handles appear click once on the handle on
the free end of the wire, then move the handle up almost to where the wire
changes direction (but not all the way up).

Click again to “drop” the handle. 

Repeat this process for the dangling end of the GND wire,
moving it toward the bottom of the sheet.

Select View » Toolbars » Simulation Sources from the menus to
display the Simulation Sources toolbar.

Click the +12V source button on the Simulation Sources
toolbar. A source symbol will appear floating on the cursor. Press the TAB key
on the keyboard to edit its attributes. In the resulting dialog, click the
Attributes tab to make it active and set the Designator field to V1. Leave the
Footprint field blank. Click the OK button to close the dialog and then place the
source between the dangling ends of the 12V and GND wires.

Using the same technique you used to move the dangling ends of the 12V
and GND wires apart, move them again to attach each wire end to either end
of the voltage source, as shown in Figure 10.

Our last task before running a simulation is to place net labels at appropriate
points on the circuit so we can easily identify the signals we wish to view. In
the tutorial circuit the points of interest are the base and collectors of the two
transistors.

Select Place » Net Label from the menus [shortcut P, N]. Press the TAB key
to edit the net label attributes. In the resulting dialog, set the Net field to
Q1B and close the dialog.
Position the cursor over the wire coming from the base of Q1. Left-click or press
ENTER to place the net label on the wire.

You can start the tutorial at
this point by opening the
schematic multivibrator
sim1.sch in the download
design database Multivibrator
tutorial.ddb

The electrical “hot
spot” of a net label
is the bottom left
corner – ensure
that this corner
touches the wire.

To include a Bill of Materials in the Output
setups, right-click in the CAM document 
and select Insert Bill of Materials from the
floating menu.

In the Bill of Materials Setup dialog enable
the Text format, disable the other 2 formats,
and click OK to close the dialog. Note that 3
formats are supported, Text, CSV (Comma
Separated Values), which loads straight into a
spreadsheet editor or can be imported into a
database, and Spreadsheet, which automatically
opens in Protel 99 SE’s spreadsheet editor.

You are now ready to generate the Gerber and
BOM output documents. Before you do, we will
configure the generation options.

Select Tools » Preferences from the menus to
display the CAM Options dialog. Note that
you can automatically export the documents
to a disk drive. 

Enable the Separate Folder for Each Output Type
option and click OK to close the dialog.

Select Tools » Generate CAM Files from the
menus to create the Gerber and BOM files. 

When the generation process is complete a new folder will appear in the
navigation tree in the
Explorer panel, called CAM
for Multivibrator. 

Click on the small +
symbol to expand the view
and display the Bom Output
and Gerber Output sub-
folders, then click on the
small + symbol next to
each to display the
contents of each folder.

Click on the BOM for
Multivibrator.txt icon to open the Bill of Materials. 

If required, the Gerber files could be exported from the design and shipped to the
PCB manufacturer.

Congratulations! You have completed the PCB design process.

The output documents have been created
and stored in folders in the design database.
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Press the TAB key and change
the Net field to Q1C.
Position the cursor over the
wire coming from the collector
of Q1 and left-click to place
the second net label.

Similarly place net labels with
designators Q2B and Q2C on
the base and collector wires of
Q2 respectively.

When you have finished
placing the net labels, right-
click or press the ESC key to
exit placement mode.

To save your simulation-ready circuit with a different name to that of your
original schematic, select File » Save As [shortcut F, A] and type Multivibrator
simulation.sch in the Save As dialog.

Running a transient analysis
Your schematic now has all the necessary additions, so let’s set up to
run a transient analysis of the circuit.

In our tutorial circuit, the RC time constant is 100k x 20n = 2
milliseconds. To view 5 cycles of the oscillation we will set up to
view a 10ms portion of the waveform.

Select Simulate » Setup from the menus to display the Analyses
Setup dialog. All the simulation options are set up here.

Click on the Transient/Fourier tab at the top of the dialog. 

In the Default Parameters region of the dialog disable the Always Set Defaults
option. When you do, the options in the Transient Analysis region of the dialog

will become available. 

To specify a 10ms simulation window
set the Stop Time field to 10m.
Now set the Step Time field to 10u,
indicating that the simulation should
display a point every 10us (giving 1000
display points in all, enough to give an
accurate picture of the results).

During simulation the actual timestep is
varied automatically to achieve
convergence. The Maximum Step field
limits the variation of the timestep size,
set the Maximum Step to 10u.

The last thing to set up is the nodes in the circuit that you wish to observe. 
To do this:

Click on the General tab in the Analyses Setup dialog

In the Collect Data For field select Node Voltage and Supply Current from the list.
This option defines what type of data you want calculated during the
simulation run.

In the Available Signals field double-click on the Q1B, Q2B, Q1C and Q2C signal
names. As you double-click on
each one it will move to the Active
Signals field.

You are now ready to run a transient
simulation.

Click on the Run Analyses button at
the bottom of the dialog to run 
the simulation.

The simulation will be performed,
when it is finished you should see
output waveforms similar to those
shown in Figure 11. 

Congratulations! You have simulated
your circuit and displayed its output
waveforms. If you like, you can change the values of some of the components on
your schematic and re-run the simulation to see the effects. Try changing the
value of C1 to 47n (double-click on C1 to edit its attributes) and re-running the
transient analysis. The output waveforms will show an uneven mark/space ratio. Figure 11

Output
waveforms
from the
multivibrator

Figure 10
Simulation-
ready
schematic

You can start the tutorial
at this point by opening
the schematic 
multivibrator sim2.sch in
the download design
database Multivibrator
tutorial.ddb

Setting up
the transient
analysis
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Further explorations
This tutorial has introduced you to just some of the powerful features of 
Protel 99 SE. We’ve captured a schematic, run a transient simulation on the
design, and designed and routed a PCB, all with the integrated tools provided in
Protel 99 SE. But we’ve only just scratched the surface of the design power
provided by Protel 99 SE.

Once you start exploring Protel 99 SE you will find a wealth of features to make
your design life easier. To demonstrate the capabilities of the software, a number
of example files are included. You can open these examples in the normal way,
select File » Open from the Design Explorer menus then navigate to the \Program
Files\Design Explorer 99 SE\Examples\ folder. As well as the board design examples
in this folder, there are a number of sub-folders with examples that demonstrate
specific features of Protel 99 SE. 

Check out the \Circuit Simulation\ sub-
folder to explore Protel 99 SE’s
analog and digital simulation
capabilities. As well as analog
examples that demonstrate various
circuit designs, such as amplifiers and
power supplies, there are mixed-mode
examples, a math function example,
an example that includes linear and
non-linear dependent sources (741
Operational Amplifier.ddb), and even
a vacuum tube example!

If you’re interested in PLD design,
the \PLD\ sub-folder has a number of schematic-based pld designs, including
Wait.ddb which can be compiled to produce the JEDEC download file. If you’re
interested in implementing a PLD design using a Hardware Description Language,
the \Reference\ sub-folder includes a number of designs that demonstrate the
various capabilities of Protel 99 SE’s CUPL HDL, including simulating the PLD
design. 

With faster logic switching and design clock speeds, the quality of the digital
signals becomes more important. Protel 99 SE includes a sophisticated signal
integrity analysis tool that can accurately model and analyze your board layout. The
signal integrity requirements such as impedance, overshoot, undershoot, and
slope are defined as PCB design rules, and then tested during the standard design
rule check. If there are nets that you need to analyze in more detail you can select
Tools » Signal Integrity to pass the design to the Signal Integrity Analyzer, where you
can perform reflection and cross talk simulations. The results are displayed in an
oscilloscope-like waveform analyzer, where you can examine the performance
and take measurements directly from the waveforms.

If you are interested in exploring Protel 99 SE’s signal integrity analysis features
why not download the Signal Integrity Analysis Introduction PDF file from the
download page of Protel’s web site, www.protel.com.

Check out the
extensive
examples to
explore more of
Protel 99 SE’s
design
capabilities 

Shortcut keys
Common Schematic and PCB Shortcuts
Keys Function

Left-click Focus object

Left double-click Edit object

Left-click and hold Move object/selection

Left-click, Select inside area
hold and drag

Shift+left-click Select/deselect object

Right-click Popup floating menu/esc from current
operation

X, A De-select all

Alt+Backspace Undo

Ctl+Backspace Redo

V, D View Document

V, F View Fit placed objects

PageUp Zoom in (zooms around cursor, position
the cursor first)

PageDown Zoom out

Home Redraw screen with center at the cursor
point

End Redraw the screen

Spacebar Abort screen re-draw

Tab While an object is floating on the cursor
to edit its attributes

Shift While autopanning to pan at higher speed

X Flip object along the X-axis

Y Flip object along the Y-axis

M Pop-up Move sub-menu

S Pop-up Select sub-menu

Esc Escape from current process

Schematic Shortcuts
Keys Function

Insert While placing an object to clone a placed
object (of the same kind)

Backspace While laying a wire/bus/line/
polygon to delete the last vertex

Spacebar While placing to rotate object by 90
degrees

Ctrl+click Drag object, maintaining wire
(then release Ctrl) connectivity

Ctrl (hold) Temporarily disable the Snap grid 

Left-click and hold, When a wire is focused 
then press Insert to add a vertex

Left-click and hold, When a wire is focused to
then press Delete delete a vertex

PCB Shortcuts
Keys Function

Q Toggle units (metric/imperial)

Ctrl+click Drag track/drag track end

Ctrl+shift+click Break track

Backspace Remove last track corner during track
placement

Ctrl Disable the Electrical grid during placement

Alt Temporarily switch from Avoid Obstacle to
Ignore Obstacle mode

Ctrl+Spacebar Cycle through connection lines on a pad
when routing

Right-click and hold Display slider hand and slide view of PCB

G Pop up snap grid menu

Ctl+G Pop up snap grid dialog

Shift+E Toggle electrical grid on/off

Shift+R Cycle through routing modes (ignore obstacle,
avoid obstacle, push obstacle)

Shift+S Toggle single layer mode on/off

L Layers Tab of Document Options dialog

Ctl+Delete Clear all selected 

Ctl+H Select connected copper

Spacebar Rotate object being moved (anti-clockwise)

Shift+Spacebar Rotate object being moved (clockwise)

Spacebar Toggle start/end mode during track placement

Shift+Spacebar Cycle through all placement modes during
track placement

Ctrl+Spacebar Cycle through connection line on a pad - use
this after starting to route from a pad with
multiple connection lines

L Flip component being moved to the other side of board

N Hide net connections while moving a component

* Cycle through signal layers (numeric keypad)

+ Cycle forwards through layers (numeric keypad)

- Cycle backwards through layers (numeric keypad) 

Design Explorer Shortcuts
Keys Function

Ctrl (during file open) Open design without re-opening documents

Tab Switch from Panel to active document/folder

Shift+Tab Switch from text document to Navigation
Panel

Ctrl+Tab Cycle through open documents/folders

Ctrl+F6 Cycle through open design databases

Ctrl+F4 Close active document/folder

Alt+F4 Close Design Explorer

F5 Refresh the display


