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Target Modeling is a flexible IC-CAP toolkit that enables you to 
adjust a simulation model to definable targets. For example, you 
can use it to adjust a model to a new process or to view the 
overall trend of a production process.

In any semiconductor manufacturing environment, process 
data is monitored using process control monitors (PCM’s). For 
example, those control monitors usually don’t include device 
data from complete sweeps of gate voltages. Typically ID is 
measured at specific values of VG to get discrete pairs of VG/ID 
values. The goal is to use those targets to adjust a simulation 
model with extracted parameters from only a few wafers to the 
manufacturing process trend with a much larger number of 
measurements available through PCMs.

This toolkit enables you to:

• Adjust a simulation model that was extracted on one die of a 
wafer to data that represents the overall trend of this 
process.

• Generate a simulation model for a new technology based on 
an existing model card plus a reduced set of characteristic 
data of this new technology.

• Perform comparisons between different simulated models 
and silicon data.

• Generate documentation containing measured data (PCM, 
Device Data) and the appropriate simulations.

• Easily add your own methods, model definitions, circuit 
definitions, and so on.
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The Target Modeling toolkit’s GUI uses two windows:

• The control GUI to manage data, simulations, and plots.

• Plots/multiplots as the main objects to perform the target 
modeling.

The control module is an IC-CAP .mdl file, which manages the 
OTM objects and handles templates necessary for PCM 
simulation, report generation, and so on.

Control code and data are separated—control code is found 
inside the model Target_Modeling and data is stored inside 
data files using the naming convention 
OTM_Data_(ProjectName).

The data files contain simulation setups, plots and multiplots, 
methods (plot optimizers, extractions), as well as user specific 
extensions. All relevant information regarding one project is 
stored in a single model file.

The control module contains 4 tabs: Data, Diagrams, Reports, 
and Options. The following figure shows the Target Modeling 
GUI.

Figure 1 Target Control GUI
IC-CAP Data Display



Target Modeling 1

IC-CAP Data Display

 

Using the Data tab, you can manage PCM as well as device data. 
PCM data format is read from files formatted as a table 
containing the following details: 

The first n rows of the table are the KEYWORD rows. Keywords 
can be:

• TYPE with 

• ID=Identification 

• IP=Instance parameters 

• PCM=PCM parameters 

• NAME with 

• Fixed Values for:

• DeviceID 

• Name

• Denominators for:

• Instance Parameters (IP)

• PCM values (PCM) 

• SUBSET: specifies in detail the PCM values. Allowed names 
are mean, min, max. These identifiers are used to add 
statistical data.

• TEMP: Temperature of the PCM value

In the file, each column is separated by a comma ( , ). This 
enables you to import the file into table calculation programs 
like MS Excel. 

A further rule for the rows NAME and TEMP is that if a cell does 
not contain a name, the value of the previous one is used. For 
example, T=25°C is used as a temperature for all PCM values as 
long as no other value is specified. Following is an extract from 
such a PCM data file.
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NOTE Default content for empty cells depends on cell type:

• An empty cell inside the NAME row leads to an error message. For example, if 
the cell following AD is empty, you will get the error message Instance 
Parameter Name AD is defined twice. In this case, the name of the previous cell 
is used and double definitions are not enabled.

• An empty data value cell is assumed to have the value of zero.
The goal is to create an easy way to import data from different 
sources that are not in the IC-CAP data format. Using this 
comma separated value (.csv) format, any data format can be 
used with only minor changes. Those changes can be made 
using a table calculation program like MS Excel or similar 
programs.

The Diagrams tab enables you to open plots—single plots can be 
opened from the left side and multiplots from the right side of 
this tab.

On the Report tab, you can create customized reports of the 
projects.

The Options tab enables you to select the simulator and circuits.
IC-CAP Data Display
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To better understand the tasks and to easily try the features, an 
examples directory is provided. This directory is located in 
$ICCAP_ROOT\examples\model_files\target_modeling\
examples. It contains the BSIM4_NMOS_example and the 
BSIM4_NMOS_from_scratch directory, which contains a few 
subdirectories and specific example files that will enable you to 
try all aspects of Target Modeling.

The iv_data directory contains a .dut, .mdl, .mdm, and .set file. 
Another directory, model_parameters, contains an .mps file. 
The simulation_template_configuration directory includes the 
SinglePoint.csv and Vth_GM.csv simulation templates. The 
pcm_data_files directory includes 3 example PCM files.

To create a new project, open $ICCAP_ROOT\examples\model 
files\target_modeling\TargetModeling.mdl. Double choose 
Target_Modeling to open the Target Modeling GUI, then choose 
File > New from the menu. The Create New Data Model window 
opens prompting you to enter a name for the new data model. 
Standard naming convention applies and every new model 
begins with the prefix OTM_, but you can overwrite this setting.
CAUTION Do not rename the data model file as it is displayed in the main window 
after creation: It will be unusable!
Next, select a Simulation Model from the list on the left side of 
this window. Once you’ve selected a model, the right side of this 
window lists the available simulators (see the following figure).
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Select a simulator then select if you would like to use the default 
NMOS or PMOS circuit from the respective Modeling Package. 
This selection is only available after you select a simulator. If 
you would like to select another circuit, you can browse to the 
location where the circuit is located.

Next, select the model parameter set. You can use the default 
model parameter set included in the circuit or import one in 
IC-CAP .mps or .cir format. For example, import the example 
model parameter set from $ICCAP_ROOT\examples\
model_files\target_modeling\examples\
BSIM4_NMOS_from_scratch\model_parameters. 

Figure 2 Startup Wizard to create a new data model
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IC-CAP Data Display
You can also import a model parameter set in the form of a text 
file. This could be a library file containing only one .model 
statement. In this case, select the simulator of origin for the 
model file. For example, this selection gives you the flexibility to 
generate a model for a new technology based on an existing 
model card. You can check if the used model obtains adequate 
results for, let’s say, reduced gate dimensions.
PCM Data
 

After creating a new project, the Target Modeling window shows 
two entries on the Data tab.

For the first step, right click PCM Data and choose New PCM 
Table. The New PCM DUT dialog box appears prompting you for 
the name of the new PCM DUT and the location of the data file, 
which needs to be in comma separated value (.csv) format as 
previously explained.

See $ICCAP_ROOT\examples\model_files\target_modeling\
examples\BSIM4_NMOS_from_scratch\pcm_data_files for 
example PCM data files.

After choosing OK, a new PCM table is inserted below PCM 
Data on the Data tab. Now, right click this new entry to:

• Delete PCM Table

• Derive a Subset or Device Data

• Re-import data for this PCM table by selecting the desired 
data files. This routine checks the data file format and 
reports any errors.

• open a Device Info table showing the names and some 
parameters of the devices read in from the .csv table.
11



1 Target Modeling
NOTE Derive device data is available only after adding and configuring a 
Simulation Template, defining at least one working condition.
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Now, the Data tab contains the information for the PCM below 
the named PCM in the form of a tree structure. The branches 
are: 

• Available Outputs

The available outputs are read in from the PCM data file — 
they represent your PCM data.

• Simulation Templates

A configured Simulation Template is required to simulate 
PCM data and to derive device data. Therefore, it is 
recommended to add and configure a Simulation Template 
first.

• All

The All branch contains device data as specified inside the 
.csv file just read in. The Device Info table shows the devices 
configured for this PCM set.

Simulation Templates

From imported PCM data, two kinds of diagrams can be 
generated using predefined simulation templates:

• PCM values versus Instance Parameters (L, W,..) or 
temperatures

Those plots are generated by configuring Simulation 
Templates.

• I-V like diagrams with only a few measured points but full 
simulation

Those plots are based on the configuration of the Simulation 
Templates plus the subset configuration done while deriving 
device data.
IC-CAP Data Display
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Two types of simulation templates are implemented for the 
BSIM3, BSIM4, and PSP models: 

• Single Point current 

• Vth(Iref,gm), max(gm), gm(Vth+offset) 

Two similar templates for the BSIMSOI3 and BSIMSOI4 models 
are implemented (for floating body SOI):

• Single Point current 

• Vth(Iref,gm), max(gm), gm(Vth+offset) 

Additional templates can be added using the Target_Modeling 
file. 

A support document named “Simulation Templates for Target 
Modeling” describes how to implement a user defined model. 

The following figures show the two different types in more 
detail:

Figure 3 Possible kinds of diagrams
13



14

1 Target Modeling
 

Figure 4 MOS single point simulations for I/V-diagrams

Figure 5 MOS threshold voltage related simulation Vth
IC-CAP Data Display
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Now that PCM data has been read in and subsets have been 
created (if desired), the next step is to configure the simulation 
templates.

Figure 6 MOS threshold voltage related simulation conductance
NOTE Although you can create subsets, you can not create device data until at 
least one simulation template is configured.
Right click the Simulation Templates entry below the PCM Data 
set you just created, then choose Add Template. The Simulation 
Templates dialog box appears. Select a template defined for the 
model and simulator, then choose OK. The selected simulation 
template is inserted into the PCM data tree. Right click this 
template then choose Configure Template. This opens the 
Simulation Assignment window to let you assign specific 
parameters as well as inputs and outputs for this simulation 
configuration. See the following figure for details.
15
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A number of parameters are available for the model chosen. You 
can change the allocation of the parameter to any other 
parameter of this set or you can enter a specific value by 
selecting no allocation (-) from the drop down list. In this case, 

Figure 7 Simulation Assignment
IC-CAP Data Display
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the column named Default is highlighted and you can enter a 
value for the selected parameter. If no parameter value was 
specified, the default value defined in the circuit is used.

The next step is to add input values for the simulation sources. 
In templates for single-point simulations, the values entered are 
the simulation values for the exact points (values of VD, VG, VS, 
and VB) given.

You can add more points (lines) or you can delete points by 
choosing the appropriate button at the bottom of the 
Simulation Assignment window. Mark the lines you would like 
to delete by selecting the check box in front of the line(s). 

In Vth simulations for example, enter the start, stop, and step 
values for VG, then enter the rest of the voltages for swept 
simulations.
As shown in the figure above, the first order sweep VG can only 
be entered into the first row. The following rows are grayed out 
for VG sweep — you can only enter VD, VB, and VS.

The following plot shows the simulation of part of our example 
PCM data using the settings from the figure above. The plot 
shows the value of VTLIN vs. device length (on a logarithmic 
x-axis) for a subset of devices using a width of 5 µm and a 
temperature of 25°C.
17
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Now choose the outputs from the drop-down list. Enter 
parameters to the right of the outputs. For example, if you are 
interested in the value for gm at the point (Vth + x), enter the 
x-value into the applicable column named x. For Vth(IDref) 
simulations, you have to assign a value for IDref into the 
specified column labeled IDREF. If you would like to extract 
Vth(IDref) and gm in one step, the IDref value is valid for both 
simulations. For different values of IDref, use an additional line 
and enter different values as desired into the IDref column.

You can also Export or Import settings from this window to use 
in other simulations.

From the directory $ICCAP_ROOT\examples\model_files\
target_modeling\examples\BSIM4_NMOS_from_scratch\
simulation_template_configuration, you can import one of the 
simulation templates provided: SinglePoint.csv or Vth_GM.csv

Derive Subset

To derive a subset from all devices, right click the All branch (or 
the PCM tree top) then choose Derive Subset. In the Prompt 
Dialog, enter the name of the new subset. You can derive subsets 
based on preferred criteria selected in the Select Criteria 
window. See the following figure. 
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You can configure plots for the new subset based on different 
selectable X-Axis parameters as well as annotation parameters 
and temperatures, if available.

After selecting the subset criteria and choosing OK, a window 
opens showing the devices that are included in the subset. You 
can select one or more devices from this window. Choose OK 
and the new subset is inserted into the tree.

Derive Device Data

To derive device data, right click a PCM table or a subset then 
choose Derive Device Data. The Device Simulation Wizard 
window opens. Enter a name for the simulation and choose an 
available simulation template from the list, then choose Next.

Figure 8 Selections for a subset
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The Device Simulation Wizard window now displays items you 
can include in this device simulation task. Choose one item 
from the list then click the right arrow to assign this item to the 
IV-Curve section. To remove an item from this simulation, 
simply select the item then click the left arrow. 

Figure 9 Device Simulation Wizard
IC-CAP Data Display
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See Figure 4 and Figure 5 for a graphical explanation of Single 
Point or Vth related items. 

When you’re done assigning data points, choose Next to enter 
simulation conditions. See Figure 14. 

Enter the sweep order as well as the conditions for the first 
order sweep. The values for the second order sweep come from 
the PCM data values — they can’t be changed in this window.

Figure 10 Assignment of predefined simulations
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Figure 11 First and second sweep order entries and their relationship to 
the plot
IC-CAP Data Display
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In the example shown, the value of IDREF is identical for the 
determination of VTLIN and VTSAT. However, it is possible to 
have different IDREF values. Simply enter the required values 
into the proper field.

Figure 12 Simulation assignment and related outputs at a predefined 
parameter value, IDREF
NOTE The value of IDREF is multiplied by W/L for each transistor.
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Figure 13 Single Point currents: Relationship between inputs and out-
puts and their representation in the form of single measurements
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Again, choose Next and you are prompted to select devices to 
include in this simulation setup. After choosing the devices, 
choose Finish and the simulation setup is added to the tree of 
PCM data using a specific symbol.

Figure 14 Entering Simulation Conditions (left) and resulting ID-VG dia-

gram (right, shown for two different temperatures). The squares show 
actually measured points.

Start: 0V, Stop: 1.8V, Step: 50mV

1. order sweep: gate voltage

2. order sweep: drain voltage

3. order sweep: temperature
(two discrete values, one drawn

(two discrete values)

(36 discrete values)

in red and one in blue)
25



26

1 Target Modeling
 

ICCAP DUTs-Setups

Right click ICCAP DUTs-Setups to display a menu that enables 
you to create a new DUT, edit an .mdl data file, or import an 
.mdl or .dut file. Choose Edit Data MDL to display the model 
file in edit mode. Since you can define everything inside this 
.mdl file, you must be careful to create a functional model. The 
following figure shows the generated IC-CAP model file.

After creating a new DUT, you can import .mdm files by right 
clicking and choosing Import .mdm. An Import Wizard is 
opened and you are prompted to enter a name for the DUT as 
well as the name and path of the .mdm file to be imported. See 
the following figure.
IC-CAP Data Display
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After entering the information, choose Next and you get a 
warning to check nodes, dimensions, and simulation settings. 
Choose Finish to import data into the setup and open the 
IC-CAP model file for editing.

Figure 15 Measurement Import Wizard, shown is the example .mdm file 
provided for import
Diagrams
Use the Diagrams tab to define plots — Single Diagrams on the 
left and Multiplots on the right. The Multiplots column is empty 
until you add a New Multiplot using the Diagrams menu or the 
icon.
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When you add a new multiplot, you are prompted to enter a 
name. To configure a new or existing multiplot, first select the 
multiplot, then select the plots on the left side of the tab and 
click the arrow to add the plots to the selected multiplot. 

Another method to configure a multiplot is to right click a plot 
on the left and choose Copy, then right click on the desired 
subfolder on the right and choose Paste.

If you would like to change the arrangement of the plots, click 
the Move Up and Move Down icons (yellow arrows) or right 
click a multiplot and choose Move Up or Move Down. 

After the plots are configured, you can open single plots by 
double clicking on the plot or select the plot then choose 
Diagrams > Display Single Plots from the menu or choose the 
Display Plots in Single Diagrams icon. You can open more than 
one single plot if you select multiple plots while pressing and 
holding Shift or Ctrl on your keyboard.

You can open multiplots by double clicking on the multiplot or 
select the multiplot then choose Diagrams > Display Multiplots 
or choose the Display Plots in Multiplots icon.
IC-CAP Data Display
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The Display Plots in Single Diagrams icon is shown on the left 
and the Display Plots in Multiplots icon is shown on the right.

Click the + sign in front of one of the PCM data entries to open 
the tree of single diagrams. You can then open the underlying 
plots by double clicking on them. However in the example above, 
if you open the Conductance or Transconductance diagram 
tree, the plots below that folder are separated by devices. 
Therefore, before you can open the plots, you must first open 
the device folders.
29
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You can also open a single plot in a mulitplot by clicking the + 
sign in front of the multiplot to open the tree, then double click 
one of the single plots. See the following figure.

Figure 16 Multiplot for Lscale_W5u for a Target modeling project
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To get information regarding the origin of a plot, right click on 
the plot then choose Show Origin. A dialog box similar to the 
following appears.

To reconfigure plots, right click a plot then choose Edit. This 
enables you to change axis settings and so on for selected plot. 

After you open a single or multiplot, you can use all the features 
of an IC-CAP plot window like the plot optimizer, tuner, and so 
on. Click the PO-field inside the plot to enable changes in the 
optimizer area.
Report
Use this tab to create reports for the project. Choose Report > 
Configure to open the Configuration of Report window. In this 
window you can enter a headline and comments to be entered 
into the report, as well as the path for the report to be stored. 
Moreover, you can choose to include the plot legend in the 
report and to set the plot size for the report.

For a new project, the Report Structure field on the Report tab 
is empty. Choose Report > Set Report Structure to Default to 
set the report structure to a predefined setup. This enters a 
default structure that you can adapt to your needs.
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To adjust the default structure, use the right mouse button to 
change the order, delete, rename, and add subsets or new 
folders to the structure.

When finished, choose Report > Generate Report. The report 
process starts and the results are stored as .HTML files at the 
selected location. You can use any web browser to view the files.

Figure 17 Default report structure
Options
Use this tab to change which simulator is used with the project. 
The default simulator was selected when you created the data 
model.

To change which simulator or the circuit is used, choose 
Options > Change Simulator and Circuit. Select one of the 
available simulators as well as the circuit desired. After 
selecting a simulator or circuit, a window opens enabling you to 
check the model parameters used by the imported circuit. 

Carefully check if the used circuit parameters match your 
needs. No checking routine is implemented since one of the 
goals of this toolkit is to provide flexibility to use other models 
or circuits without being bound to defaults.

If you would like to use a different simulator than those 
currently defined, edit the Target_Modeling.mdl file and setup 
the new simulator by adding it to the transform 
IC-CAP Data Display
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Configuration/Options/Define Simulators. A ReadMe section at 
the top of the transform contains instructions on how to modify 
it and add your own simulator.
 

NOTE When editing the data model file, use File > RefreshTree from the menu or 
the appropriate icon , for the changes to take place.

After you edit the Target Model file, close the GUI then reopen to get the 
changes into the GUI.
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How to implement a user defined simulation template is 
described in the “Simulation Templates for Target Modeling” 
support document. This procedure requires you to be very 
familiar with IC-CAP because model files have to be edited. 
There is no automatic error check available, since you have all 
the capability that IC-CAP provides. 
IC-CAP Data Display
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