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Errata
The IC-CAP product may contain references 
to “HP” or “HPEESOF” such as in file names 
and directory names. The business entity 
formerly known as “HP EEsof” is now part 
of Agilent Technologies and is known as 
“Agilent EEsof.” To avoid broken functional-
ity and to maintain backward compatibility 
for our customers, we did not change all the 
names and labels that contain “HP” or 
“HPEESOF” references.
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Agilent 85190A IC-CAP 2008

 

IC-CAP 2008 Addon 2 Release Notes

This document describes new features, functionality, fixed 
issues and known defects in IC-CAP 2008. It also identifies 
errors and omissions in the documentation and provides 
workarounds for defects wherever possible. The following table 
shows the version history for this document.

For more information concerning known issues in IC-CAP 2008, 
or to report a new issue, refer to the Agilent EEsof Knowledge 
Center at: https://edasupportweb.soco.agilent.com/

Version Date Revised/New Issue Title

Initial Release 3/08

Addon 1 Release 7/08 New Fixed Issues, IC-CAP 2008 Addon 1

Addon 2 Release 9/08 New Fixed Issues, IC-CAP 2008 Addon 2

New Do not use “:” or “Ungrouped” as group 
names (pg 33)

New Duplicate variable names lead to 
unexpected results (pg 33)

New Hundreds of parameters can be 
accidentally added (pg 34)

New Newly added parameter groups not 
visible (pg 34)

New Adding a Multiplot to a Multiplot is not 
supported (pg 34)

New License-error occurs during 
measurements or simulations (pg 35)

New Error message when using more than 
one instrument (pg 50)

New Message during remote Eldo simulation 
(pg 61)

New Pipe Mode simulation does not work 
with Eldo 2008.1 (pg 61)
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IC-CAP now supports the HSIM_HV model, based on model 
revision HiSIM_HV 1.0.2, released in June 2008. See Examples 
-> model_files -> mosfet -> hisim_hv.  

IC-CAP Platform enhancements include the following:

• Parameter/Variable Searching and Grouping Parameter and 
Variable table UI now includes a search capability and 
supports user-defined parameter and variable group 
definitions

• New PEL functions to allow control of curve selection in plots

• Synopsys’ Saber simulation support added for LINUX 
platform (requires Saber 2007.12 or higher)

• Support for HSPICE License Release Timeout (requires 
HSPICE 2008.03-SP1 or higher)

• ELDO Pipe Mode Support added (Requires Eldo 2007.2a or 
higher)

• Support for 1/f Noise/DC Simultaneous Simulation for ADS 
Simulator added
IC-CAP 2008 Addon 1
IC-CAP now supports the HSIM2 model, based on model 
revision HiSIM241, released in June 2008. See Examples -> 
model_files -> mosfet -> hisim2.
IC-CAP 2008
IC-CAP 2008 is a major new release of the IC-CAP platform. It 
provides the following new features and enhancements:

• New Target Modeling Tool

• This tool enables the extraction of early models for circuit 
designers based on future process specifications or 
design targets before actual silicon is available.

• ADS Simulation Enhancements
IC-CAP Release Notes
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• Support for Linear HF Noise simulations (Noise Figure).

• Support for simulation using Spectre compatible netlists 
directly with ADS simulator.

• New Advanced PEL Functions

• New PEL Program2 transform provides extended 
programming to older Program transform by allowing 
numeric dataset (arrays) passing between calling and 
receiving PEL transforms (previously limited to passing 
string data only).

• PEL functions to programmatically control expanding and 
collapsing the IC-CAP DUT/setup tree.

• New Instrument Support

• Support for the Agilent E5071C Network Analyzer 
(ENA-C) 2-port S-Parameter measurements only.

• Updated Licensing 

• With the release of ADS 2008 and IC-CAP 2008, a 
simplified licensing scheme was implemented when the 
ADS simulator is invoked by IC-CAP. Prior to these ADS 
and IC-CAP releases, when performing ADS simulations 
with IC-CAP, a sim_linear or sim_transient license was 
required. These two ADS simulation licenses, along with 
the iccap_analysis license, were provided as part of the 
IC-CAP 85199BL IC-CAP Analysis Module product (and 
also the 85190L Modeling Suite product). With the new, 
simplified licensing mechanism in place, ADS simulations 
performed with IC-CAP will now only require an 
iccap_analysis license, eliminating the need for the 
additional simulation licenses. To use IC-CAP 2008 with 
ADS 2006 Update 3, you must have hotfix-230108-flexlm 
applied to your ADS installation. 
7
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• On Windows, the Cygwin version that ships with IC-CAP 
($ICCAP_ROOT/tools/bin) changed to 1.5.24-2. Therefore, 
you should not run IC-CAP 2008 and IC-CAP 2006 (or prior) 
on the same computer simultaneously due to 
incompatibilities with the previous version of the Cygwin 
shared library. 

• Supported platforms changed. The following platforms are no 
longer supported: Windows 2000, HP-UX, Solaris 8, Solaris 9, 
and Red Hat Linux WS 3.x. Now Redhat Enterprise 4.0 is 
supported. See “Check the Windows System Requirements” 
or “Check the UNIX System Requirements”.

• Required CPU changed. Intel Pentium © 4 or better, or AMD 
XP 3000 or better now is now required for Windows and 
Linux.

• Required RAM changed. 1 GB RAM is now the recommended 
minimum. 

• Required hard disk space increased. 1 GB is now required for 
installation on UNIX platforms and 800 MB is now required 
for installation on Windows platforms.

• Supported compilers changed. On Windows, Visual Studio 
.NET 2005 is now supported (see “Check the Windows 
System Requirements”). On UNIX, SunStudio 11 and gcc 
4.1.1 are now supported (see “Check the UNIX System 
Requirements”). Customized userc will need to be 
recompiled.

• The version for the license server (lmgrd) has changed to 
FLEXnet 11.4.1 from FLEXnet 10.8. Impacts all systems, 
hardware keys, license servers, and license administration 
scripts.

• The codeword version changed to 2.7 from 2.35. You must 
obtain new FLEXnet license codewords from Agilent EEsof 
EDA. 
IC-CAP Release Notes
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User Interface

• EDA00195901 — The user interface has been modified so the 
missing Redisplay button and Automatic Redisplay check 
box in the Cycle Plot Types folder in a BSIM4's plot window 
are now are visible.

Model-Specific

• EDA00196927 — Beginning in HSPICE 2008.03-SP1, HSPICE 
license will time out in 1800 seconds for CAN_PIPE mode.  
User can customize the time of license timeout by setting 
variable HSPICE_LICENSE_TIMEOUT (unit by second).  
HSPICE_LICENSE_TIMEOUT is only valid for HSPICE 
2008.03-SP1 or later version. 

• EDA00187974 — This issue was initially addressed in 
hotfix-20071001-toolkit, but did not make it into the next 
formal IC-CAP release (IC-CAP 2008).    The BSIM3 package 
and code changes to the modeless tuner have been made to 
address this issue and has been formally delivered in IC-CAP 
2008 Add-on 2.

Instrument-Specific

• EDA00195661 — Changes to properly use the Delay for 
Timeouts options during measurements were added to the 
PNA and ENA drivers.

• EDA00197088 — If the Agilent 5270 was fully configured 
with SMUs filling all slots, the data was not read correctly for 
some of the SMUs. The instrument driver has been updated 
to address this defect.
9
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• EDA00198380 — Resending the command CWFREQ  during a 
measurement using the Agilent 4294 would turn off the 
calibration.   The driver has been updated to no longer 
resend this command if the Agilent 4294 has a valid 
calibration enabled by first using IC-CAP to run the 
calibration sequence.  If a manual calibration is performed, 
the IC-CAP variable, BYPASS_CV_CAL should be set.

• EDA00196213 — The driver for the HP 5250 was updated to 
address this issue.

Simulator-Specific

• The capability of simultaneous DC and /1/f nose simulation 
has been enhanced.

• Saber simulator link on Linux is supported.  The path of the 
Saber AIM shell interpreter (aimsh) must be specified in 
usersimulators. 

• The entry for SABER  has been added to usersimulators for 
both PC and UNIX.  The path of the AIM shell interpreter 
(aimsh) must be specified in usersimulators. 

• EDA00193707 — The message: 
Error: Trying to set the descriptor on an 
array that has already been assigned
should no longer appear when simulating to Saber on 
Windows.

PEL

• EDA00197758 — The icdbf_register_lsync_sweep function 
has been repaired.

Data Management

• EDA00183313 — The ICCAP_VALUES feature for mdm files 
had a string length limited of 1024 characters. Exceeding this 
limit would cause IC-CAP to crash. Now IC-CAP 
automatically reallocate the required memory to hold the 
user defined string.   Note that there will still be an upper 
limit based on the amount of computer memory.
IC-CAP Release Notes
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Documentation

• EDA00195966 — The documentation examples for the Plot 
Options setting has been updated.

• EDA00186131 — Documentation for the ICCAP_FUNC 
"Display Plot" function has been added.
IC-CAP 2008 Addon 1
 

Model-Specific

• In BSIM3, BSIM4, and PSP models, a new math function (* -1) 
was added to Diagrams window’s Cycle Devices, Cycle Plot 
Types, and All Diagrams tabs.

• The plot now updates correctly when tuning Vth in the Plot 
Optimizer.

• When composing a scaled plot using the Diagrams window’s 
All Diagrams tab, the error message no longer appears. 

• In BSIM3, BSIM4 and PSP models, if you add a plot in 
DC_Measure or DC_Extract, it is updated in the Diagrams 
window’s Cycle Devices tab.

• EDA00195901 — In BSIM3, BSIM4, and PSP, the Redisplay 
button no longer disappears from the Diagrams window’s 
Cycle Plot Types tab.

• In BSIM3, BSIM4 and PSP models, Automatic Redisplay is 
now marked as default and Options > Change Simulator and 
Circuits is available from every page.
IC-CAP 2008
User Interface

• EDA00182980 — The Histogram y-axis labeling was corrected 
as follows:

• When  HISTOGRAM_NORMALIZATION is defined as 
TRUE, the y-label will be set as Normalized Number of 
Samples.
11
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• When HISTOGRAM_NORMALIZATION  is defined as 
FALSE or not defined (by default, is  FALSE), the y-label 
will be set as Number of Samples.

Model-Specific

• EDA00192997 — IC-CAP no longer crashes when calling 
EEfet3_spars(), EEfet3_s2ckt(), or EEfet3_package() with 
1port data instead of 2port data as the input argument.

Instrument-Specific

• EDA00194688 — The HP 4145 instrument driver no longer 
identifies itself as another instrument during the IC-CAP 
Hardware Manager Rebuild phase.

• EDA00179430 — An Agilent ENA driver is now available in 
IC-CAP 2008 that fully supports the E5071C series ENA RF 
network analyzers.

• EDA00076126 — The Agilent B1500 instrument driver now 
correctly registers all 10 SMUs.

• EDA00178522 — Modified 3 error messages in the IC-CAP 
PNA and ENA Network Analyzer drivers.

From:

• For Internal Log Sweep: Start Frequency must be less than 
Stop Frequency.

• 1 Sweep must have <= 202 points for Frequency List.
Edit Setup and Retry.

• 3  Sweep must have <= 202 points for Frequency List.
Edit Setup and Retry.

To:

• Start Frequency must be less than Stop Frequency.

• LOG  Sweep must have <= 202 points for Frequency List.
Edit Setup and Retry.

• LIST  Sweep must have <= 202 points for Frequency List.
Edit Setup and Retry.
IC-CAP Release Notes



IC-CAP Release Notes

 

• EDA00193965 — When used with the Agilent PNA or ENA 
network analyzer, the WinCal software was putting the 
instrument into a real binary data format of FORM:BORD 
SWAP mode.  The PNA and ENA drivers in IC-CAP were 
expecting the instruments to be in a real binary data format 
mode of FORM:BORD NORMal mode. When the instrument 
was in FORM:BORD SWAP mode, IC-CAP would read back 
zero data from the instrument.

Now in IC-CAP 2008, the PNA and ENA drivers will always 
make sure the instrument is in FORM:BORD NORM mode 
before reading in binary data. This ensures that IC-CAP will 
now get real binary data when reading back data from the 
instrument.

Measurement/Calibration

• EDA00180888 — Calibration no longer continues past an 
Instrument not found error, which would then lead to a 
frequency range error.

• EDA00192154 — The PNA driver now correctly sets up the 
averaging functionality of the PNA instrument.

• EDA00115743 — A message in IC-CAP had been updated to 
no longer refer to a frequency list. For example, prior to 
IC-CAP 2008 you could see the following message box:

You are about to download the current 
measurement setup into the <instrument_name> 
frequency list.
Press OK to continue or Cancel to abort.

Now in IC-CAP 2008 you'll see the following message box:

You are about to download the current 
measurement setup into the <instrument_name>.
Press OK to continue or Cancel to abort.
13
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Simulator-Specific

• EDA00191709 — LSYNC Sweep INPUT has been enhanced to 
work with  parameterized subcircuit netlists when using the 
ADS simulator.  Additionally, the LSYNC sweep capability 
has been expanded to support not only DC simulations, but 
all supported simulations for this simulator.

• EDA00184405 — IC-CAP now correctly parses the hpeesofsim 
output raw file that contains both S parameter and DC data. 
This caused the program to crash when you tried to switch 
the sweep orders.

• EDA00181997 — Improved the algorithm to make sure the 
variable of master sweep is defined before its slave SYNC 
type sweep. 

• EDA00178176 — Enhanced IC-CAP to simulate high frequent 
noise and to output the following key HF noise parameters 
for any given biasing condition and frequency point:  Noise 
Figure, Gamma Opt, Equivalent R Noise, Min Noise Figure, 
and Equivalent Noise Temperature

• EDA00100636 — The IC-CAP parser is enhanced to enable the 
definition of  variables that start with the following IC-CAP 
keywords: number, define, parameters, end, when, values, 
control section, options, and model. 

• EDA00192862 — In the usersimulator, example reference to 
the MNS simulator and references to the HP-UX platform 
were removed.

• EDA00194069 — The crash caused by misconfigured 
simulator has been fixed. 

• EDA00194288 — Enhance the Saber input syntax (netlist tr() 
with tb=0 and specify xsampling from N to N by N to specify 
the points of data to read back.) to address a transient Saber 
issue.

• EDA00192124 — A tab after the ADS component no longer 
causes a wrong circuit parser error message.

• EDA00191025 — The LSYNC sweep setups are now able to be 
imported correctly even if the LSYNC was written to the 
MDM or setup before the referenced master.
IC-CAP Release Notes
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PEL

• EDA00193243 — The divide by zero error that could occur in 
the deriv transform has been fixed.

• EDA00192917 — ICCAP_ARRAY functions and the sizeof() 
function now accepts string arguments and variable 
arguments at different levels (Model/DUT/Setup). 

• EDA00191059 — IC-CAP error messages are no longer deleted 
from the red error message dialog box when PEL error 
messages are deleted.

• EDA00178590 — PEL actions Close Branch and Open Branch 
were added to support automatically opening and closing a 
DUT’s setup branches. 

• EDA00178350 — The following PEL statements were added in 
IC-CAP 2008:

• GET_STRING  same as LINPUT — used to pass in string 
argument via a dialog or through an iccap_func() call.

• GET_INT  similar to LINPUT — used to pass in an integer 
argument via a dialog or through an iccap_func() call.

• GET_REAL  similar as LINPUT — used to pass in a real 
argument via a dialog or through an iccap_func() call.

• GET_DATASET — used to pass in a dataset or array 
argument through an iccap_func() call.  Only available 
from within Program2 PEL Programs.

Now in Program2 we preserve the current stack argument list 
when iccap_func calls are nested within Program2 calls. The 
older Program PEL program command, doesn't preserve the 
argument stack list after iccap_func calls.

The following PEL statements were also added:

• GLOBAL_VAR used by Program2 to determine which 
variables are defined Globally vs. locally in a PEL 
Program2.

• RETURN_VALUE used to return a single point of data vs. 
return data the size of the setup's input size.

• EDA00192385 — The sizeof() function now accepts both 
string arguments and variable arguments such as 
sizeof(abc2) and sizeof("abc2").
15
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• EDA00194061 — Choosing the IC-CAP Exit button in the 
Studio window now exits IC-CAP immediately. 

Data Management

• EDA00191111 — ImportCreate now works with an LSYNC 
sweep type defined in the imported MDM file.

• EDA00194018 — ImportCreate in the HF Noise Output now 
works correctly.

IC-CAP Studio

• EDA00076021 — GUI Tab pages are no longer displayed 
incorrectly which caused IC-CAP to crash.

Miscellaneous

• EDA00192072 — With the ADS 2008 release, a simplified 
licensing mechanism was implemented when the ADS 
simulator is invoked by IC-CAP to perform ADS 
simulations/optimizations with IC-CAP.  Prior to the ADS 
2008 release, ADS sim_linear and sim_transient license 
codewords were required to execute these simulations.  With 
the new licensing mechanism, ADS simulations performed 
with IC-CAP will only require existing iccap_analysis 
licenses; therefore, ADS sim_linear and sim_transient 
codewords will no longer be included with IC-CAP license 
codeword updates.
IC-CAP Release Notes
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Unit multipliers M and m both refer to milli

EDA00178151 — The unit multipliers M and m both refer to 
milli. The unit multiplier MEG refers to mega. When entering 
values in Input fields expecting a Real Value (as indicated in the 
status panel), the text is automatically reformatted after entry 
(for example, 100M is reformatted to 100.0m). If 100M is 
entered for a variable in the Variable Table, no reformatting 
occurs; when this variable is referenced in a Real Value field, it 
is still interpreted as 100.0m. 

Zoom Box appears not to work 

EDA00179875/EDA00180733 — When you select Zoom Box from 
the pop-up menu (right-click) in any Setup folder and click and 
drag the pointer, there is no visible evidence (such as a box 
drawn with a dashed line) that the command is in progress. But 
the command does work.

This problem seems to be dependent on which window manager 
and operating system you are using, so it may not affect all 
users. This problem may also only affect setups displayed in 
tear-off windows.

Workaround:

Click the two points that represent opposite corners of the box.

Choosing File > Save As displays options that have no effect

EDA00177682 — When you choose File > Save As in the model 
window, the option to Save without Measured/Simulated Data 
is always presented, even though it has no effect on the 
following file types: .cir, .mps, .plt, .tci, .vat.
17
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Plot marker misses the plot trace

EDA00178081 — A plot marker misses the plot trace when two 
different x-axis data points are used. This happens when two 
traces use differing default x data (that is, they come from 
different setups). The plots display properly, but plot markers 
circle phantom points where the foreign setup's data would 
have been, given the foreign setup’s x data.

Workaround:

Plot on separate graphs if markers are required.

Stop button may not stop a data acquisition immediately

EDA00180756 — On faster computers, choosing the Stop button 
in the Status window may not stop a data acquisition 
immediately.

Workaround:

Continue clicking on the Stop button until the data acquisition 
stops.

Colors change or disappear

EDA00177420 — During an IC-CAP session, colors may change 
or disappear making it difficult to read text and plots. We have 
not been able to reproduce this problem. If you experience it, 
please call Technical Support to report the operating conditions 
that led to the problem.

Workaround:

Restart IC-CAP.

Text-entry cursor disappears

EDA00182037 — The text-entry cursor, which should toggle on 
and off, may disappear in edit windows and in input fields of 
dialog boxes. The cursor will stop toggling in either the visible 
or invisible state.

Workaround:
IC-CAP Release Notes
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To regain cursor functionality, move the window containing 
the input field, or select another input line in an edit 
window.

Edit tear-off menus flash

EDA00178298 — If you are working with two different models, 
and you open an Edit tear-off menu from each model, the 
tear-off menus will begin to flash as they exchange being the 
active window. This may be more noticeable when each model is 
open to a different tab.

Workaround:

Open only one Edit tear-off menu at a time.

Mouse buttons lock up

EDA00178070 — If you press the Esc key while choosing a menu 
item from a tear-off menu, the mouse buttons will lock up. You 
will not be able to select menu items or toolbar buttons with the 
mouse.

Workaround:

To avoid this problem, don't use the Esc key while choosing 
a tear-off menu item.

If you encounter this problem while working with a model 
file, close the model file, then reopen it.

If you encounter this problem while working from the 
IC-CAP/Main window, exit IC-CAP, then start a new session.

Status line does not display the complete set of text

EDA00178035 — In the model window, the status line may not 
display the complete set of text such as the Output Modes if the 
font size has been customized.

Workaround:

Use the default font size.
19
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Backspace key does not work properly

EDA00178505 — When adding an instrument in the Hardware 
Setup window, the Backspace key may not work properly when 
editing the instrument address in the Configuration dialog box. 
The cursor may not be in the location you expect.

Workaround:

Use the arrow keys to reposition the cursor, or highlight the 
entire number and use the Backspace key.

Rogue processes may be left behind from IC-CAP

EDA00169372 — Occasionally, when IC-CAP is terminated 
suddenly, rogue processes are left behind from the IC-CAP 
session. Sudden terminations can be caused by actions such as 
issuing a kill command from the UNIX command prompt. Rogue 
processes slow the system down by using all the CPU power. 

Workaround:

If your system becomes slow, shut down all IC-CAP sessions 
and check for processes running from your IC-CAP 
installation. System usage can be checked on UNIX with the 
ps command or the top command. Typically, the process 
eehelp will be causing the problem. Kill any such rogue 
processes. On the PC, use the Task Manager and end 
processes such as: hpeesoficcap, hpeesoficstatus, hpeesofemx, 
hpeesofhelp, hpeesofsim_front. Note: Do not end hpeesofemx 
or hpeesofhelp if ADS is running.

Corrupt .iot files

EDA00177893 — Saving Instrument Options may result in 
corrupt .iot files. Under heavy usage of the Hardware Manager 
combined with repeated saves of .iot files, the .iot files can 
become corrupt by containing multiple entries for the same 
instrument. This problem is difficult to reproduce, but it 
appears to involve a particular combination of actions. The 
actions include rebuilding/adding instruments using the 
Hardware Manager, saving .iot files, and exchanging interface 
addresses among instruments.
IC-CAP Release Notes
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Workaround: 

If you notice corrupt .iot files, restart your IC-CAP session.

Clicking middle mouse button generates a core file

EDA00180875 — On Solaris 5.6, 7.0, and 8.0 clicking with the 
middle mouse button on a System Error dialog box generates a 
core file.

Workaround:

Do not use the middle mouse button on a System Error 
dialog box.

Transformed data not current

EDA00178034 — IC-CAP keeps its transformed data current by 
tracking the data upon which it depends. Thus, if a transform 
calculates beta=ic/ib, it is recalculated any time ic or ib 
changes. However, this dependency is lost whenever ic or ib is 
deleted. If ic or ib is then replaced, the dependency must be 
re-established by re-executing the beta transform. Deletions 
can happen simply by cutting and pasting ic or ib. 

Dependencies that are in place are not broken immediately 
by renaming ic or ib, but the dependency can break 
eventually. For example, if you establish the dependency 
between beta and ic, then rename ic to tmp and modify the 
data in tmp—beta automatically updates when the data in 
tmp changes. After this first update, though, the dependency 
would be corrected to establish a dependency between beta 
and tmp, and break the dependency with ic.

Macro generates core file

EDA00182684 — During a measurement, if a macro writes a 
stream of data containing more than 15K characters 
(comma-separated numbers) to one variable-table variable, and 
saves the data to a file, a core file is generated.

Workaround:
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Include a command in the macro to clear the variable, such 
as setting the variable to null (""), prior to exiting the macro. 
This will work if the variable is used as temporary storage.

Plot order changed

EDA00177774 — If you have set up a specific order for your plots 
in the Plot list, the plot order may change if you open the Plot 
Editor dialog box using the Edit button and modify values. The 
plot name will move to the bottom of the list.

Workaround:

Use on-screen editing to modify a plot’s properties.

Edit > Text > Find responds very slowly

EDA00178362/EDA00177975 — When you choose Edit > Text > 
Find, IC-CAP responds very slowly and may appear to hang. 

Workaround:

None—eventually IC-CAP will respond.

Warning displayed after adding an instrument

EDA00178239 — After you manually add an instrument from the 
Instrument Library list in the Hardware Setup window, the 
following warning is displayed in the status window and in the 
hardware status panel.

warning nwa defined 2 times

The manual add procedure first adds the instrument with 
default unit names and then updates the new unit aliases. 
The first add generates the warning but should not.

Workaround:

Ignore the warning.
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IC-CAP continues to display old data trace

EDA00179219 — If you change the plot definitions when 
Autoscale is turned off and RETAIN_PLOT is set to YES, IC-CAP 
continues to display the old data trace.

Workaround:

Turn Autoscale on or close then reopen the plot.

Rescaling a Histogram or CDF plot

EDA00185573 — When rescaling a Histogram or CDF plot, you 
can either choose Manual rescale or you can draw a box then 
choose Set scale. However, only Set scale allows you to change 
the values for the Y axis. In addition, if the Y axis values are 
changed manually, the change is not reflected after the plot 
is saved and reopened, or copied and pasted.

Inserting columns and rows in the Statistical Analysis window

EDA00178393 — When you insert columns and rows in the 
Statistical Analysis window, they are inserted based on the 
location of the cursor, not the selected row or column.

Cutting or deleting a lot of DUTS/Setups

EDA00177997 — When cutting or deleting a lot of DUTS/Setups 
from an IC-CAP model file, IC-CAP crashes and displays the 
following message: 

IC-CAP Exited with the following errors/warnings having 
been printed to the status window shortly before exit. 
X Error of failed request: BadAlloc (insufficient resources 
for operation) 
Major opcode of failed request: 18 (X_ChangeProperty) 

Workaround:

Exclusively use the right mouse button to select the 
DUT/Setup prior to cutting or deleting, or periodically close 
the model window then reopen it. 
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Choosing from popup menu generates a core file

EDA00177994 — When the cursor is positioned over an input, 
output, or plot, and you quickly click the right mouse button 
and choose View or Edit from the popup menu, a core file may 
be generated.

Entering a value in the Statistical Analysis window

EDA00177324 — When you enter a value in a cell in the 
Statistical Analysis window, the value does not take effect until 
you press the Enter or Tab key or click in another cell. In other 
words, if a cell is blue, its value is only known by IC-CAP to be 
the value the cell was before the cell was entered.

Tuner location does not correspond to parameter values

EDA00179540 — If you select the Tune Fast or Tune Slow 
buttons after manually changing parameters but before 
performing a simulation, the tuner window opens but the 
displayed tuner location does not correspond to the actual 
parameter values. 

Workaround:

Perform a simulation before selecting the Tune Slow or Tune 
Fast buttons.

Name displayed in HP-IB Interface field does not change

EDA00178445 — In the Hardware Setup window, selecting Tools 
> Interface > Change displays the Interface File dialog box. If 
you change the name of the interface file then select OK, the 
name displayed in the HP-IB Interface field does not change.

Workaround:

Rather than changing an interface name, delete the interface 
from the list then add it naming it what you want.
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Warning not displayed when configuring instruments

EDA00177421 — When you are configuring instruments and 
assign reserved ground unit names (GND, GNDU, or GROUND) 
to any unit in the Unit Table, a warning message should appear 
but doesn’t.

Icons overlaid at bottom of screen

EDA00184125 — Model files that were saved on a UNIX system 
with a large screen then opened in Windows NT may overlay the 
icons at the bottom of the screen.

Workaround:

Resize the IC-CAP window to fit the screen.

Problems with minimum required display resolution

EDA00179736 — The minimum required display resolution for 
IC-CAP is 800x600; however, at this resolution you may 
encounter problems with portions of IC-CAP, such as the BSIM3 
or BSIM4 packages.

Pressing the tab key does not move the cursor as expected

EDA00177500 — Pressing the tab key when Measure/Simulate’s 
Input or Output Editor is selected does not move the cursor to 
the expected location. In addition, pressing the tab key when 
the Model Parameter, Model Variable, or Setup Variable table is 
selected produce different results in Windows and UNIX.

Display the Active Devices does not function

In the Hardware Setup window, the Display the Active Devices 
 icon does not function until after the Rebuild button is 

pressed.

Workaround:

Before selecting the Display the Active Devices icon, select 
the Rebuild button.
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Percent complete dialog reports incorrectly

EDA00178434 — If you set the INST_START_ADDR and 
INST_END_ADDR system variables then select Rebuild in the 
IC-CAP/Hardware Setup window, the percent complete 
dialog reports incorrectly. The percent complete dialog 
expects 32 GPIB addresses to be searched and does not take 
into account the fact that the search range was limited by 
the system variables.

Y-axis labels appear incorrect

EDA00183127 — If you manually rescale a plot’s Y-axis, the 
Y-axis labels may appear incorrect due the fact that IC-CAP has 
rounded it to too few digits (e.g., points 1.0, 1.25, 1.5, 1.75, 2.0 
may appear as 1.0, 1.3, 1.5, 1.8, 2.0 because 1.25 and 1.75 were 
rounded up).

Workaround:

Use a marker to determine the correct value of a data point.

IC-CAP appears to be frozen when using Tune Slow

EDA00182045 — If a simulation error occurs when using Tune 
Slow, IC-CAP may not immediately report the error and may 
appear to be frozen. It appears frozen because simulation data 
is not updated (because simulation failed) and nothing else 
appears.

Work around

Move the slider again and the error message should appear.

Setup Inputs, Outputs, and Plots may not arrange correctly

EDA00180250 — Setup Inputs, Outputs, and Plots may not 
arrange correctly in the setup window.
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File > Change Directory does not impact Status window

EDA00178249 — Changing the default directory using the 
IC-CAP/Main window’s File > Change Directory button does not 
change the directory for the Status window’s Error Log File or 
Output Log File.

Cannot rescale y-axis (log10) to sub decade

EDA00182043 — The y-axis (log10) cannot be rescaled to sub 
decades.

Workaround:

Change the y-axis to Lin, then rescale. While it won't label 
the y- axis 10^x, but rather just x, you may also change 
your data to plot log10(data).

Data plotted in IC-CAP does not match data in Data Display

EDA00179268 — Data plotted in IC-CAP as 10*log(data) will not 
match the same data exported and plotted as 10*log(data) in 
the Data Display. IC-CAP interprets 10*log to be ln or the 
natural log. The Data Display interprets 10*log to be log10 or log 
base 10.

File history may not display all the files it should

EDA00179755 — After setting ICCAP_NUM_RECENT_FILES to 
ten and loading ten files with very long file names, file history 
may not display all ten files.

After deleting DUTs, the remaining Setup may be blank

EDA00181420 — After deleting DUTs from the Model, the 
currently selected Setup may not be accessible.

Workaround:

Double click on the Setup to refresh its contents.
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Scroll bar in System Variables window does not work

EDA00179425 — Scroll bar in System Variables window does not 
function correctly. Horizontal scroll bar gives false indications. 

Work around

Grab the border and extend the length of the window.

Copy/Paste places inputs/outputs directly on top of originals

EDA00184275 — In the Measure/Simulate tab, if you copy then 
paste an input or output, it is placed directly on top of the 
original input or output giving the impression that copy/paste 
did not work.

Workaround:

After pasting an input or output, click and drag it to a new 
location.

Inconsistent naming for Save As and Open DUT Parameters

EDA00178528 — When saving DUT Parameters, select DUT Level 
Device Parameter Set. When opening DUT Parameters, select 
Device Parameter Set.

Plot Optimizer Inputs window scroll bar may not display column

EDA00177914 — Using the scroll bar in the Plot Optimizer 
Inputs window, you may not be able to display a particular 
column if the Inputs window contains multiple Target and 
Simulated columns with some columns displaying a longer path. 
Moving the scroll bar may move the column too far to the right 
or left.

Workaround:

Resize the columns to correct the scroll bar functionality.

Rebuilding instruments displays incorrect percent complete

EDA00178434 — When you rebuild the instrument list, the 
percent complete dialog reports incorrectly if you used system 
variables to limit start and end GPIB addresses.
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Title for dialog box incorrectly labeled Export File 

EDA00184534 — The dialog box that appears when you click on 
Create from the Data Management - Import Data dialog box is 
incorrectly labeled Data Management - Export File. It should be 
labeled Data Management - Import File. To view the dialog box, 
click File > Import Data > All Setups in Active DUT from a 
model window, then click Create on the Data Management - 
Import Data dialog box, then click Yes on the Information 
Requested dialog box. The Data Management - Export File 
window appears, which should be labeled Data Management 
- Import File.

Save error message should say save instead of open

EDA00178406 — If you try to save to a file to a location that you 
do not have write permission, an error message appears stating 
that you cannot open the file. The message should say that you 
cannot save the file.

Detached Setup window does not stay in front of model window

EDA00177430 — If you detach a Setup window from a model 
window then click on View or Edit from the detached window 
or try to add an input or output to the detached window, the 
model window is placed in front of the detached window.

Unspecified grid type is no grids

EDA00144785 — The default grid type when not specified was 
always supposed to be off, but a bug on UNIX was turning it on 
when unspecified. With IC-CAP 2004, unspecified means no 
grids.

No indication when in Full Page Plot zoom mode

EDA00182448 — If you select Full Page Plot from a Multiplot 
window, there is no indication on the plot or in the window that 
you are in this zoom mode.

Workaround: 

Use Ctrl Z to get out of Full Page Plot zoom mode.
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Plot symbols overlap the axis name slightly

EDA00177176 — The plot symbols (e.g., the little squares) 
overlap the axis name (e.g., id m specified for y-axis).

Error calculation on/off state toggles incorrectly in Multiplot

EDA00180909 — When displaying an even number of duplicate 
plots in the same Multiplot display, the error display state 
toggles back to the opposite state of what was set for all plots in 
the Multiplot display.

Workaround:

Toggle to the desired state for the individual plots.

Some Error menu picks are greyed out when using Multiplot

EDA00178835 — In a Multiplot, the menu picks Options > Error 
> Select Error Region and Options > Error > Select Whole Plot 
are greyed out.

Workaround:

If you want to set this mode for one of the plots, either use 
the E area tool or right click on the plot and select the 
appropriate menu from the Error menu.

Selected plot in Multiplot not indicated

EDA00182676 — If you change the plot definition of a Multiplot 
such that plots are reorganized while a plot is selected, no plot 
will appear selected after you select Options > Replot. However, 
the plot is still selected but the red frame is not being 
drawn to indicate the selected plot.

Workaround:

Select any plot to restore the Multiplot to a proper state.

Moving mouse out of plot leaves highlight shade in place

EDA00181902 — When the mouse is inside an area tool, it 
generally changes the background color. When it is moved out, 
the background color returns to its normal shade. However, if 
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you remove it quickly, the highlighted shade may remain in the 
original location while you are working in another window or 
another plot in the Multiplot. This effect can be visually 
confusing but does no harm.

Workaround:

Move the mouse back to the original graph to redraw the 
color properly.

Y Label text displayed horizontal

EDA00182936 — Very rarely plots will display with the Y axis 
labels horizontal instead of vertical along the left edge of the 
plot. This issue is still under investigation and it does not seem 
to be very reproducible. The problem is generally isolated to 
just a specific plot, not all plots in the system.

Workaround:

Restarting or reinstalling IC-CAP or just recreating the plot 
generally works around the issue.

Entering extremely large number displays incorrect number

EDA00182245 — Entering extremely large numbers (i.e., 1e+400, 
or -1e+400) into IC-CAP Parameter tables, Optimizer tables, or 
Transform tables can cause the incorrect number to appear in 
the cell.

Workaround:

Limit values to ~+/-1e300.

Preview button on Multiplot can be confusing

EDA00184250 — The Preview button on the Plot Options dialog 
can be confusing if the saved options are different than the 
currently displayed options (session settings). If your intent is 
to modify plot options on the second tab and preview the 
changes, you should first select menu Session Settings > 
Reset to saved Options, or Session Settings > Save Current 
Settings. This will synchronize the current image with the 
saved settings that are manipulated on the Plot Options 
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dialog. Then changes made to the Plot Options dialog are 
previewable. If you don't do this, the Preview button will 
only be able to preview changes to the options.

Histogram and Scatter plot are not supported by Multiplot

EDA00185435 — IC-CAP crashes if you try to open a histogram 
or a scatter plot in a Multiplot. They will open properly as single 
plots, but not in a Multiplot.

Set RETAIN_PLOT is not working if a marker is on the plot

EDA00182457 — RETAIN_PLOT=1 does not function as it did in 
the past if a marker is on the plot.

Workaround:

Turn off the marker by clicking outside the graph to see the 
RETAIN_PLOT behavior.

Manual tune entry fails when tuning if you have a variable 

EDA00184041 — If you have a variable (as opposed to a 
parameter in a parameter table) in an optimizer and use Tune 
Slow or Tune Fast, you will get an error if you try to change the 
value of the tuner in the text entry blank. 

Workaround:

Change the value of the tuner by moving the slider.

AEL Error while importing Data

EDA00181777 — If you choose File > Import > All Duts from a 
model with no duts in it, the dialog opens but is nonfunctional 
and the following message appears in the Status window:
ERROR      AEL0304 (iccap_get_data_obj_attr) operand: wrong 
type of parameter

Shrinking specific Multiplot causes floating point error

EDA00183442 — Shrinking a Multiplot to a very small size or 
just very narrow or wide, may cause floating point errors to be 
reported to the Status window or an error box. These errors are 
annoying, but not harmful and increasing the size of the 
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window will eliminate them. This does not happen with every 
Multiplot. It depends on the number of plots being displayed, 
the types of the plots, the amount of data on each plot, and the 
ranges of the data on the plots.

Duplicate variable names lead to unexpected results

EDA00198612 — Do not enter the same variable into a variable 
table more than once.  Doing so can lead to unexpected results 
with the wrong variable being located both by PEL and by the 
user interface.  A warning is issued to the status window 
Errors/Warnings pane whenever a duplicate is detected.  PEL 
will only find the first such duplicate.  If you add a duplicated 
variable while viewing only a subset of parameters in the 
variable table (by using the variable groups or search 
functionality), you will add an empty duplicate variable at the 
end of the table, but the first found will be displayed in the 
blank where you just added the duplicate.  If you then delete the 
item visible in the table, you will be deleting the first 
occurrence, not the 2nd occurrence.  

Workaround:

To avoid issues in this situation, if you get a message about 
duplicate variables while adding a variable when viewing a 
subset of the entire table, select All Variables then choose Show 
All.  Scroll down to the end of the table and remove the last 
added duplicate.

Do not use “:” or “Ungrouped” as group names

EDA00198611 — IC-CAP 2008 Addon 2 introduces a new feature 
where parameters named PARGROUP_<xxx> and variables 
named VARGROUP_<yyy> will create groups in the associated 
parameter table or variable table named <xxx> or <yyy> 
respectively.  Some names should be disallowed but are not 
currently disallowed.  

Workaround:
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Please don't choose group names with : in them or named 
Ungrouped such as PARGROUP_Ungrouped or 
PARGROUP_MP:ABC.  Such names will cause internal conflicts 
with unexpected results.

Newly added parameter groups not visible

EDA00198610 — If you actively add PARGROUP_<xxx> group 
names while a Plot Optimizer is open, you must close then 
reopen a branch in the parameter selection tree to see the newly 
added groups.  

Workaround:

On Windows, you can either close and reopen the top level 
parameters branch, or the sub-branch that contains the newly 
added group name.  On Linux or Solaris, you must refresh using 
the sub-branch because simply closing and reopening the top 
level parameters branch does not refresh the display.

Hundreds of parameters can be accidentally added

EDA00198609 — With the new tree based parameter selection 
tool in the Plot Optimizer, you can easily add hundreds of 
parameters to the optimization by accidentally clicking the [-->] 
button when a large group of parameters are selected.  

Workaround:

They can be cleared using the Clear Table button, but the clear 
process can be lengthy.  Try to avoid accidentally adding large 
numbers of parameters to the optimizer.  The performance 
should be fine for 10-20 parameters, but noticeable slowdown 
will be observed if the optimizer parameter table contains 100 
or more parameters when Clear Table is selected.

Adding a Multiplot to a Multiplot is not supported

EDA00195154 — IC-CAP will crash if you try to specify another 
Multiplot in a Multiplot Definition.  This is not a supported 
capability.
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License-error occurs during measurements or simulations

EDA00198628 — When a license-error occurs during 
measurements or simulations, a question box may appear 
asking to retry or exit. 

Workaround:

You can now change this behavior by setting the environment 
variable HPEESOF_LM_RETRY_MODE=on. Setting this 
environment variable causes the application to revert back to 
the disconnect behavior of previous releases. With this 
environment variable set, five attempts will be made to 
reconnect to the license server without requiring user 
interaction. If the connection cannot be established during this 
period of time, the application will exit. To turn off this 
alternate disconnect behavior, simply unset the 
HPEESOF_LM_RETRY_MODE environment variable.
Model-Specific
 
Floating point errors occur

EDA00177631 — In the model EEHEMT1.mdl, floating point 
errors may occur if the parasitic resistances are extracted 
incorrectly. The incorrect extractions result in values that are 
too large. The floating point errors occur because the higher 
voltage drops across the parasitic resistors don’t leave enough 
voltage on the intrinsic nodes of the device.

Workaround:

Adjust the values of the parasitic resistors down to lower values 
to avoid the floating point errors.

Measured.data file does not contain the S-parameters

EDA00178074 — The HP Root FET model fails to check file 
status before starting data acquisition. This can waste 
measurement time, since data acquisition may be performed 
with an incomplete set of data. Specifically, if 
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extr_para/parasitics/extract_parasitics has not been 
performed, then there will be no Para.data file. Without this 
data, the Measured.data file will not contain the S-parameters.

Workaround:

Manually verify the file status before starting data acquisition.

Plots displayed during extraction

EDA00178454 — In the hpsimvbic.mdl model file, if you execute 
the Do_all macro and select N in response to the “Do you want 
the plots displayed during extraction?” question, some plots are 
still displayed during extraction.

mxt_npn.mdl file is no longer supported

EDA00116713 — The Mextram 503 extraction implemented in 
the IC-CAP 2001 mxt_npn.mdl file is no longer supported. This 
file was located in the model_files/bjt directory. Some of the old 
MXT_xxx function names are now used for the new Mextram 
504 parameter extraction implemented in the mxt504_npn.mdl 
file (see function browser under the group called MEXTRAM). 
The old MXT_xxx functions that are not used for 504 are 
obsoleted although they are still present in the product. 
Running these obsolete function will cause IC-CAP to display a 
warning dialog box.

The Mextram 503 extraction files mxt3t_npn.mdl and 
mxt4t_npn.mdl are still fully supported and should be used for 
Mextram 503 extraction. The Mextram 503 mxt3t_xxx and 
mxt4t_xxx functions are listed in the function browser under 
the group MEXTRAM503.

EEHEMT, EEFET, and hpsimEEFET3 refer to unavailable TL element

EDA00182269 — Circuit description for HPEEhemt1.mdl, 
HPEEfet3.mdl, and hpsimHPEEfet3.mdl all include TL element. 
However, there is no TL available in ADS. Therefore, if you do 
optimizations from IC-CAP to ADS using the TL element and 
then want to port the design to ADS, you will need to substitute 
a different TL element with potentially different behavior.
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Grid missing in BSIM4 Tutorial Boundaries folder

EDA00144785 — In the BSIM4_DC_CV_Tutroial.mdl file, the 
grid in the Boundaries folder is not the same as the grid in the 
BSIM4_DC_CV_Extract.mdl file’s Boundaries folder. In the 
BSIM4_DC_CV_Extract.mdl file, the grid in the Boundaries 
folder appears to separate the cells but the grid is missing in the 
tutorial. This does not affect the Tutorial’s functionality.

Demo feature file missing TEMP and TNOM variables

EDA00149882 — When using the demo file 
nmos2_MdlgNavigator or nmos3_MdlgNavigator and running 
the Initialize macro BEGIN_MDLG, an error message appears 
stating that there is no value for TEMP or TNOM. If you click 
OK, you will get an error message about these variables. You will 
also get the same error if you try to enter a value for the TEMP 
or TNOM.

Workaround:

Add TEMP=27 and TNOM=27 to the Setup Variables or load the 
variable table file demo_features/sysvars_mini.vat from the 
IC-CAP Main window.

Canceling macro in MM9 model file displays error message

EDA00145919 — In the MM9 example model file, if you start the 
SETUP macro then click Cancel, the following Error Message 
appears:

User selected cancel on dialog box
At or near Line 9: MM9_SETUP failed
At or near Line 10: Assignment operation failed.
ERROR: During execution off Macro mm9/setup

Erroneous warning when generating BSIM4 HTML report

EDA00182445 — The following error message may appear when 
setting the directory path for HTML generation:
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A previous report was detected in the HTML path:
<Directory Path>
If you want to remove this report, continue, 
otherwise CANCEL now and reconfigure the web 
path.

Workaround: 

HTML files are still generated if you just proceed with the step.

Main BSIM4 window desensitized when Display Plot open

EDA00148492 — By design, all the icons in the main BSIM4 
Extraction window are desensitized when the Display Plot 
window is open. However, there is no indication that they are 
desensitized.

Some interactive extraction steps window opens too small

Some BSIM4 interactive extraction steps (such as Large- 
-Basic Vth Mobility) open too small and must be expanded 
in the vertical direction to a dimension larger than 768 
pixels.

Workaround:

Using a 1280x1024 screen resolution or larger will allow you 
to expand the window. On smaller resolution screens you 
may not be able to view the window sufficiently.

Warning appears about max setting for DVT2 and DVT2W

EDA00126048 — When using the BSIM4_DC_CV_Extract.mdl 
with the binned project example, a pop-up warning dialog may 
appear about the max setting for the parameters DVT2 and 
DVT2W being above the max limit. If you go the boundaries tab 
and edit a value or just select another tab, a pop-up dialog will 
appear indicating the current max limit for parameters DVT2 
and DVT2W exceed the maximum recommended value for these 
parameters.

Workaround:
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Just select yes to reset the limit or manually change the max 
limit in the parameter boundaries table.

Cannot save plot customizations 

When customizing graphs on the BSIM4 Diagrams Multiplot 
window, each time a graph is Redisplayed, IC-CAP will not 
retain these customized settings (such a legend on/off, etc.). 
Even if the graph did not change during the Redisplay, it 
will be refreshed and reset.

Workaround: 

Use the save plot optimizer feature to save the graph layout 
and customizations.

Error reported when using numbers in directory names

The BSIM4 package does not support using directories for 
projects that begin with numeric characters; therefore, do 
not copy BSIM projects into a directory begins with 3 
numeric digits or in sub-directories that have any parent 
directory that begins with 3 numeric digits. Examples: c:\
123\this\is\bad,   c:\this\is\also\bad\123bad

In BSIM4, problems recalling Plot Optimizer in Display windows

EDA00182934 — In the BSIM4_DC_CV_Extrac.mdl, with 
bsim4_for_expert loaded and the Display window open, load 
the mobility_4_device Plot Optimizer configuration to see the 
following problems:

• The Plot Optimizer window displays the input table, which 
can be confusing.

• The color of trace regions (red and brown) are very 
similar and difficult to distinguish.

• When you load a new project, the Plot Optimizer 
configuration dropdown does not get reset to empty.

Workaround:
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To change the color of the trace regions, select a plot, open 
the Plot Options dialog, and change the Data 0 color from 
red to some other color.

Bsim4 binned log failure text does not match model description

EDA00182946 — The log failure text for Bsim4 binned does not 
match the model description. 

The bsim4_binned~bsim4_dc_cv_extract~log_fail.txt file 
reads:
Failure in C_Junction_BD/extraction/extr_CJSWD_MJSWD_PBSWD

and should read: 
Failure in C_Junction_BD/extract/extr_CJSWD_MJSWD_PBSWD

The failure log should match the model DUT, Setup, 
Extraction, e.t.c.... names.

On Linux, BSIM4 Output drop down dialog jumps up in window

EDA00182961 — In the Bsim4_DC_CV_Extract/expert_prj, open 
the Display window, click on the ALL diagrams tab, then select 
a plot type. In Select Output, click on the X-axis or Y-axis drop 
down. Notice that the little drop down dialog jumps all the up in 
the display window. This only happens the first time you select 
a value for X or Y axis. The second time the drop down dialog 
stays in its place.

BSIM3 RF Measure may not save DUT order

EDA00179675 — When adding devices to the BSIM3 RF Measure 
module, the saved order of the devices may not be preserved.

BSIM3 and BSIM4 Tutorial uses old user interface

EDA00172178 — The BSIM3 and BSIM4 Tutorial uses the old 
interface. Opening example files, generates errors in status 
window. Opening Plots also results to errors in status window.
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GWIND_WHITE not working in BSIM3

EDA00182964 — IC-CAP 2006 obsoleted the use of the variable 
GWIND_WHITE in favor of the settings in Plot Options. The 
BSIM3 package was not updated for this change, so the 
setting of GWIND_WHITE in the BSIM3 package is 
non-functional in IC-CAP 2006.

Workaround:

Right click on the BISM3 model icon then select Edit to 
open the model window. Select Tools > Plot Options to 
change the default look of the plots.

Fonts on HP-UX seem clipped in DC Transistor DUT tab

EDA00184289 — With some combinations of Display 
resolutions, DPI settings, and available fonts, the tables in the 
PSP and BSIM packages may appear to be set to the wrong 
widths causing an overlapped appearance of the column 
headers.

Workaround:

Try a different display resolution, dpi setting, or edit the 
fonts in ICCap5 to correct the display.

Icon for Insensitive (greyed out) HW Icon missing

EDA00184285 — In the BSIM and PSP Measure modules, if the 
icon for making a measurement is insensitive, it appears as a 
blank button on UNIX. The icon will display normally when it is 
available to be selected.

PSP Add Parameter dialog scrolls out of range on selection

EDA00184195 — When using the Initialize > Add Parameter 
menu in the PSP_DC_CV_Extract.mdl, the dialog always scrolls 
to the last item selected after any new selection. This makes it 
difficult to select numerous parameters at the top of the list 
after selecting one at the bottom.
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IC-CAP hangs when working with too many PSP projects

EDA00184228 — When working with many PSP projects in the 
same directory, IC-CAP may get into a bad state that results in 
hung optimizations, inability to perform simple save 
operations, or inability to launch the program from that 
directory.

Workaround:

If you encounter these symptoms, try moving some of the 
PSP projects to different directories to minimize the number 
of files in a single directory.

Some plot do not have a title in PSP All Diagrams window

EDA00184286 — In the PSP model, the All Diagrams window 
does not display titles for the following plots:

• Junction capacitance Bulk-Drain @ Tnom plots

• all the Diode Bulk-Drain plots

On Windows, Agilent HBT file browser help button does not work

EDA00184087 — In the Agilent HBT Extraction package on 
Windows, some directory browsers have a non-functional Help 
button.

Agilent HBT displays blank temperature

EDA00175104 — In the Agilent HBT Extraction package, if you 
change the Temperature table on the Measurement Settings tab, 
the Temperature dropdown on the Measure DC tab may display 
a blank temperature. You must use the dropdown to change to a 
valid temperature or the following error message will appear:
At or near Line 21: LOOKUP_VAR: Unable to locate 
variable ../setup_dc_fgummel/MeasStatusListDCfor TEMP[-1].
At or near line 22: Assignment operation failed
ERROR:  During execution of Transform 
HBT_MODELING/Configuration/Measure/chTemperatureDC.
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Clicking Clear/Reset Data in Agilent HBT displays error

EDA00182933 — In the AHBT_Package.mdl, if you attempt to 
clear/reset data on the Pad Open/Short tab in demo mode after 
performing a measurement on the same setup, an error box 
stating Simulation Failed: Data Unchanged appears.

Workaround:

Simply click the Clear/Reset Data button a second time.

Agilent HBT instrument options table requires scrolling

EDA00175100 — On UNIX platforms, the table of instrument 
options under the Advanced Settings button on the Agilent HBT 
package does not have enough horizontal space to see the 
contents without using the horizontal scrollbar.

Changing Agilent HBT temperature does not update status

EDA00174129 — If you change temperature values in the table 
on the Measurement Settings tab, you must manually Clear All 
Status after selecting that temperature on the Measure DC or 
Measure RF page. Otherwise, the data will still remain from the 
previous temperature and will be reported as the new 
temperature.

Closing Agilent HBT Info dialog with ESC or X equals clicking OK

EDA00174120 — During Step-By-Step extraction using the 
Agilent HBT package, the procedure prompts you with a dialog 
titled Info and the message Do you wish to continue?. Closing 
this dialog by pressing ESC or hitting the close-window icon is 
interpreted the same as clicking OK. Click the Cancel button if 
you want to cancel.

In BSIM3, BSIM4, PSP, some optimization failures can be ignored

Some simulators like Spectre limit the currents generated and 
will fail to produce results if currents in excess of these limits 
are simulated.  With current MOS technologies, often small 
parameter variations and parameter combinations can lead to 
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unrealistic currents. A typical example is the gate current in the 
BSIM4 model or the STI stress effect in both the BSIM4 and PSP 
model.

If this happens during optimizations, the IC-CAP optimizer will 
treat the bad simulation as unchanging (or insensitive to all 
parameters) and will move away from those parameter 
combinations toward a realistic solution, but IC-CAP reports 
simulation failures to the status window or an error box.

Such failures during optimization can thus be ignored with the 
BSIM3, BSIM4, and PSP packages.
Instrument-Specific
Agilent 8510 Network Analyzer locks up 

EDA00176549 — The Agilent 8510 Network Analyzer with 
firmware revision 7.16 CRT may lock up after a period of 
continuous measurements. To date, this problem has only 
appeared when using the HPRoot model. The time can vary 
from 2 to 20 hours before the problem occurs. Many times the 
8510 screen will be blue indicating the 8510 is in an error state.

Workaround:

Use the 7.16 LCD version or 6.xx versions of the firmware.

Intermittent measurement problems with Agilent 4145

EDA00178085 — An intermittent measurement problem occurs 
when using the Agilent 4145. Sometimes, while doing 
automated measurements, newly measured data is not sent 
from the 4145 to IC-CAP, or duplicate data from a previous 
measurement is sent to IC-CAP instead of the newly measured 
data.

Agilent 4156 is slower making LIST sweep measurement

EDA00182015 — The Agilent 4156 is slower making a LIST 
sweep measurement than the Agilent 4142. The 4156 is slower 
because it does not internally support a LIST sweep, and must 
rely on the driver to perform the measurement 
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programmatically. To perform this type of sweep the driver for 
the 4142 and 4156 performs a spot measurement at each bias 
which is more time consuming on the 4156.

Driver for Agilent 8510XF now supports uncoupled ports

EDA00145119 — IC-CAP’s 8510 driver supporting the Agilent 
8510XF Network Analyzer now supports uncoupled ports. See 
Chapter 1 in the Reference manual for instructions on setting 
up a measurement with uncoupled ports.

IF Bandwidth on the Agilent 8753 not set correctly

EDA00185034 — The IF Bandwidth on the Agilent 8753 may not 
be set correctly during a measurement. The IF Bandwidth is in 
the sequence of 10, 30, 100, 300, 1k, 3k, 3.7k, and 6k. However, 
depending on how the instrument options are set, the value sent 
to the 8753 may not equal one of the available settings, and it 
may not round to the nearest setting. For example, a value of 
3710 may result in a 6k setting instead of 3.7k.

Workaround:

Use the exact value for the settings available for IF Bandwidth 
in the 8753. 
IFBW = 10, 30, 100, 300, 1k, 3k, 3.7k, 6k.

Characteristics for Agilent 54750 driver

EDA00178377 — The driver for the Agilent 54750 Series 
Oscilloscope exhibits these characteristics:

• The IC-CAP driver for the 54750 Oscilloscope requires that 
the plug-in modules be installed in sequential slots, starting 
in slot one.

• To use the 54754 plug-in module with an Agilent 83480 
mainframe, a software key must be installed in the 83480. 
IC-CAP does not detect the presence of the software key, and 
will not notify you if the key is missing.

• Rebuilding the instrument list will find a 54750 attached to 
the system, however the Hardware Status window may not 
report the instrument name, only the address it is set to, 
such as 6. A list might appear as:
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Rebuilding the Instrument List
found at address 6. 
HP8720 found at address 8. 
HP8753E/ES found at address 14. 

End of List 
Command Completed

• The sweep measurement may not terminate on demand when 
using the Stop command from the Status window. Local 
control of the TDR will be locked out requiring that you wait 
until the sweep is done before any commands take effect or 
local control of TDR is available.

Raw data returned incorrectly

EDA00178012 — If you make a measurement with the 8720ES 
set to Cal Type= N (No cal), the raw data returned is incorrect.

IC-CAP terminates using an unsupported 86100

EDA00177505 — If you are using a 54754A with an 86100, which 
is unsupported, aliased to an 83480, IC-CAP may terminate.

Sweep time setting incorrect for PNA driver

EDA00178599 — The sweep time setting for the PNA driver does 
not work correctly in step mode.

Workaround:

For step mode, set the dwell time (time the PNA waits before 
taking the measurement at each point) and leave the sweep time 
in auto mode. In general, it is best to leave both sweep and dwell 
time in auto mode to allow the PNA to choose the most efficient 
values. 

IF bandwidth for the PNA driver

EDA00178437 — The IF bandwidth for the PNA driver is from 
1 Hz to 40 kHz with the following allowed values: 1, 2, 3, 5, 7, 10, 
15, 20, 30, 50, 70, 100, 150, 200, 300, 500, 700, 1k, 1.5k, 2k, 3k, 
5k, 7k, 10k, 15k, 20k, 30k, 35k, 40k. If you set the bandwidth to 
31.5 kHz no error message is displayed, however, the PNA 
rounds the IF bandwidth to 35.0 kHz (the next greater value) 
without updating the PNA driver’s option table.
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Workaround:

Use only allowed values for the IF Bandwidth.

Measurement is very slow

EDA00160051 — When an IC-CAP variable for the PNA driver is 
not defined, the number zero is passed to the internal functions. 
In the case of IF Bandwidth, this gets changed to one since zero 
is not allowed. With an IF Bandwidth of one second, the 
measurement is very slow (202 second at least for 101 point 
measurement). IC-CAP appears to be hanging, but is actually 
waiting for the measurement to complete. Setting undefined 
variables in other PNA fields generally does not cause any 
problem as the value zero is allowed. 

415x driver requires more than one SMU

EDA00178401 — The 415x driver requires more than one SMU 
to do an internal sweep. If all inputs are set to SYNC or GNDU, a 
measurement failure occurs.

Workaround:

Specify an additional Dummy SMU.

Agilent E2050A fails to connect to network

EDA00120995 — If the Agilent E2050A LAN/GPIB Interface is 
disconnected from the network, IC-CAP hangs until a timeout 
occurs and all attempts to reconnect the E2050A to the network 
fail.

Workaround:

Reboot the Agilent E2050A. 

Agilent 4294A fails to recognize stop sign

EDA00178735 — If you are making a measurement on UNIX 11i 
using an Agilent 4294A with a long hold time, clicking the stop 
sign in the Status window may not stop the measurement.

Workaround:
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Wait until the measurement completes.

HP/Agilent 4155/6 displays Error 117 

EDA00114625 — The HP/Agilent 4155/6 may display a red error 
dialog with Error 117. This is caused by a timing issue and can 
be avoided using one of the following workarounds.

Workaround:

Use MEASURE_FAST — this can be used only if you run the 
measurement at least once to correctly setup the sweeps.

or

Set User Sweep to Yes — this slows down the measurement 
avoiding the timing issue.

PNA may report an error every other measurement

EDA00179403 — The PNA may report an error every other 
measurement.

Workaround:

Make sure that input sweeps, instrument options, and 
calibration settings are valid before running the measurements. 
If you get Out of range error from the PNA, repeat a subsequent 
VALID measurement twice to clear the status register.

Deleting 4142 displays incorrect information in status pane

EDA00148789 — If you delete the HP 4142 from the Hardware 
Setup window, the hardware status pane displays incorrect 
information.
Measurement/Calibration
Measurement takes an inordinately long time

EDA00178136 — A measurement appears to take an 
inordinately long time to complete. If you click the Measure 
button and then press the spacebar (for example, to dismiss a 
screen saver which has come on), the Measure command is 
IC-CAP Release Notes



IC-CAP Release Notes

 

executed again. This is a result of the Motif window manager 
interpreting the spacebar as another click of the button that has 
the active focus.

8510 with different sweep modes displays no warning

EDA00177247 — On an Agilent 8510 NWA, IC-CAP allows you to 
select one sweep mode for calibration and a different sweep 
mode for the measurement without displaying any warning 
message.

Workaround:

Set the 8510 instrument option Fast Sweep to correspond to the 
current calibration sweep mode.

Measurement fails due to a timeout

EDA00179158 — When you change an output’s mode, all 
compliance values are set to zero. If you don’t reset it to a valid 
compliance, the next measurement will likely fail due to a 
timeout.

Workaround:

Always set your compliance properly when changing modes.

Error message appears with Use User Sweep set to No

EDA00182009 — If setup includes linear voltage sweeps, a 
current output, ground, and the instrument option Use User 
Sweep is set to No, the following error message may appear.

ERROR: HP4156.7.11 While setting to system mode. 
ERROR: Measurement failed. 

Workaround:

Set Use User Sweep to Yes.

Synchronized AC sweeps don’t netlist properly

EDA00180246 — IC-CAP does not properly netlist the results 
from an AC input of type “Synch” in the Measure/Simulate page.
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Workaround:

Do not use an AC sweep as your synchronization sweep.

Data invisible for linear sweep of two identical values

EDA00180636 — If you define a Setup with a linear sweep of one 
point (with the same start and stop values) and the sweep order 
is set to "1", the simulation succeeds but the data is not visible 
in the plot.

Workaround:

Since the total number of array points is not impacted by 
changing from a linear sweep of one point to a constant sweep, 
set RETAIN_DATA then change sweep type from linear to 
constant. 

Another workaround is to change the sweep order of the one 
point linear sweep to a value higher than 1.

Error message when using more than one instrument

EDA00197426 — If you try to use more that one instrument with 
your outputs, you must set Use User Sweep because IC-CAP 
assumes that two instruments can not synchronize a single 
internal sweep.  The error message for this state is misleading.  
If you try to use an internal sweep but try to collect data in two 
outputs from different instruments, you will get this message:
ERROR: No AC measurement unit defined in Setup <setupname>

You will get this message even if the setup is a DC measurement.

Workaround:

The solution is to set Use User Sweep.
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Optimization fails if maximum values are excessively high

EDA00183115 — When setting the maximum values for 
parameters used in optimizations, be sure to use reasonable 
values that are not excessively high. Otherwise, simulated data 
will not converge to measured data, causing the optimization to 
fail.

Workaround:

Use the tuner function to determine reasonable limits. Apply 
the Autoset Min and Max to set reasonable initial values for Min 
and Max.

Optimization fails if values too close to maximum values

EDA00114614 — The L-M optimizer may fail to converge to a 
good solution if one or more of the parameter values are too 
close to their maximum values set in the parameter table.

Workaround:

Increase the parameters’ maximum limits in the Optimizer’s 
Parameters table. Use one of the other optimizers, like the 
Minimax.

Names do not reflect relationship

EDA00178006 — Optimizer targets X MIN and X MAX refer to 
the 1st order sweep data and CURVE MIN and CURVE MAX 
refer to the 2nd order sweep of the actual setup inputs. This 
causes some confusion since the names do not reflect this 
relationship.

FPE error occurring during optimization may stop the optimizer

EDA00171260 — As a results of FPE errors occurring during the 
optimization, the RMS or MAX error may be calculated as zero 
and consequently stop the optimization.

Workaround:
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Make sure you have reasonable Min and Max parameter ranges 
to improve the robustness of the simulation results while the 
optimizer tries to simulate with parameter values within those 
ranges. Make sure that macros/transforms are not generating 
FPE errors.

Setting Optimizer's Min/Max does not auto adjust their values to 
fit global range

EDA00177301 — In an optimizer (or Plot Optimizer), changing a 
parameter Min or Max does not automatically adjust its value to 
fit the global range defined in the Model or DUT Parameter 
Table (when this is defined). However, running the optimization 
automatically updates the local Min and Max values to fit the 
global range and a warning is issued in the Status window if a 
change in the local Min or Max occurred.

Plot optimizer table displays incorrect values when y and y2 axis 
differ

EDA00182070 — When the y and y2 axes differ in scale, the plot 
optimizer does not display the correct values in the optimizer 
table on the Inputs tab for Target Min and Max. If y is linear and 
y2 is log or DB, the target max value for y2 is log or DB for the 
linear target max from y. Instead it should be the max from the 
y2 axis in the appropriate units.

Zero sensitivity incorrectly calculated

EDA00183670 — Certain optimizations that change very small 
parameters around zero may incorrectly calculate a zero 
sensitivity. This issue is still under investigation.
Simulator-Specific
Use NOISETEMP for Noise analysis with MNS simulator

EDA00114550 — When performing Noise analysis using the MNS 
simulator, use the IC-CAP variable NOISETEMP to set the 
temperature. If it is not set, a default value of 290o F will be 
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used. When using the ADS simulator (hpeesofsim), there is no 
way to set the temperature just for Noise analysis. Therefore, 
the analysis will be done at the circuit temperature.

Resimulating new State.mds file shows unchanged results

EDA00128193 — When using the hpeesofsim or MNS simulator 
to perform certain simulations, you may need to restart the 
simulator, or use CANNOT_PIPE. These simulators have 
increased performance by using a new Tune Mode interface that 
enables you to alter a parameter in the IC-CAP user interface, 
and generate a new simulation. However, changes to State.mds 
(the file read by the simulator for data retrieval with Root 
Models) are not sensed by the simulator in this mode. Thus 
generating a new State.mds file in IC-CAP and resimulating can 
show unchanged results. The simulator must be stopped and 
restarted for the simulator to become aware of the new 
State.mds file. The simulator must be stopped and restarted for 
the simulator to become aware of the new options.

Workaround:

Use the following suggestions as workarounds depending on 
your requirements:

• To stop and restart the simulator as needed, select Tools > 
Stop Simulator. 

• Always keep the Simulation Debugger open. This 
workaround will slow simulations down when tweaking 
parameters that appear on the Circuit page.

• Set the simulator to CANNOT_PIPE in the usersimulators 
file. This has the same effect as having the Simulation 
Debugger open all the time.

Certain SPICE simulators do not simulate properly

EDA00180936 — Certain SPICE simulators such as SPICE2 and 
SPICE3 (perhaps others) will not simulate properly when a 
parameter sweep is used as the inner sweep and a bias sweep as 
the outer sweep.

Workaround:
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Always use parameter sweeps as the outer-most sweep. If you 
need to invert the sweep order later, use the Data Manager.

Certain simulation errors cause SPICE3 to hang

EDA00071362 — Certain simulation errors will cause SPICE3 to 
hang. When this occurs, IC-CAP thinks that the simulation is 
still running and is unable to detect the error.

Workaround:

Use the stop sign on the Status window to abort these 
simulations.

Circuit definitions do not accept parameter units

EDA00181374 — IC-CAP circuit definitions do not accept 
parameter units for the hpeesofsim simulator’s netlist. For 
example, the following statement produces a syntax error in the 
circuit definition:

model RM1 R_Model R=50 Ohm

Remove Ohm to fix the error.

Workaround:

If you generate a netlist.log in an Advanced Design System 
simulation, and copy it to IC-CAP to use with the hpeesofsim 
simulator, you must edit all of the model parameters to remove 
the units.

IC-CAP’s parser more strict than simulator’s parser

EDA00182021 — The parser for the hpeesofsim and MNS netlists 
in IC-CAP is slightly more strict than the simulators’ own 
parsers. Problems usually occur due to extra spaces in 
statements when netlists are generated in another application 
such as ADS, and then used in IC-CAP. For example, the 
following line works fine in the simulators but IC-CAP will not 
identify the nodes properly due to the space between the colon 
(:) and the element name:

elemType: elemname node1 node2 ...
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Workaround:

Always specify such lines with no spaces on either side of the 
colon (:). The previous example should be:

elemType:elemname node1 node2 ...

MNS simulations fail without presenting any feedback

EDA00178986 — When using the MNS simulator on Sun 
platforms, it is possible for the simulator to fail without any 
indication of the failure mode. This is usually related to an 
incorrectly defined MDSROOT environment variable. If your 
MNS simulations fail without IC-CAP presenting any feedback, 
double-check the definition of the MDSROOT environment 
variable.

One-port simulation is not supported

EDA00185158/EDA00177298 — If you make a one-port 
simulation, the data is not correct and no error message is 
displayed. 

Workaround:

Set up the one-port simulation as a two-port simulation, then 
only use the information relevant to the port of interest. 

Simulator differences and modifications

EDA00111511 — The noise data returned from HSPICE and 
SPICE3 differ from the noise data returned from hpeesofsim 
(ADS), MNS, and SPECTRE. HSPICE and SPICE3 have units of 

 and the others have .

Also, it is not recommended that you try to modify the 
contents of your simulations by adding .PRINT or .PLOT 
lines to your circuits. Doing so can confuse the rawfile 
readers in IC-CAP and lead to unexpected results.

V
2

Hz⁄ V Hz⁄
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Simulation complete displayed but no simulation performed

EDA00179728 — If no adjustments are made to the setup 
configuration before using the hpeesofsim simulator to perform 
a resimulation of a simulation setup, the message simulation 
complete is displayed even though no simulation is actually 
performed. If you make manual adjustments to the parasitics in 
the main DUT variable table, then resimulate your extracted 
Root Model, the resimulation is not actually performed and the 
simulation data does not change. 

Workaround:

Use non-piped simulation mode so that variables in the 
State.mds file that are changed will be reflected in 
subsequent simulations. You can either configure the ADS 
link for non-piped mode, or force IC-CAP to close the 
current ADS simulation process by selecting Tools > Stop 
Simulator.

Parameter assignments do not parse

EDA00179225 — When using the hpeesofsim simulator, 
parameter assignments that contain an expression may not 
parse.

Workaround:

Use parentheses when assigning hpeesofsim parameters that 
contain an expression. For example, use id=(IS*exp(foo)) 
instead of id=IS*exp(foo). 

Spectre CAN_PIPE simulations left behind .scllog files

EDA00179212 — If you run spectre CAN_PIPE simulations, 
.scllog files are left behind in /var/tmp.

Workaround:

Manually remove the .scl files in the /var/tmp directory.

rm /var/tmp/*.scl
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BSIM4 example files are write protected

EDA00125155 — The BSIM4 example files located in the 
$ICCAP_ROOT/examples/model_files/mosfet/bsim4/examples 
directory are write protected. If you open one of the example 
files and make changes, a warning message appears. However, 
on some PC installations, the files are not be write protected. In 
this case, you should still copy the examples to your working 
directory using the Demo button in the BSIM4 package.

Workaround:

Copy or save the BSIM4 example files to your working 
directory before making changes.

ADS 2001 simulator generates a core file

EDA00135644 — When using the ADS 2001 simulator, a core file 
is generated.

Workaround:

A patch for the ADS 2001 simulator is available. Contact 
IC-CAP customer support.

IC-CAP does not react to simulation failure

EDA00181249 — When using the hpeesofsim simulator in 
CAN_PIPE mode, a simulation failure generates a warning 
message that is sent to the ADS status window. However, 
IC-CAP does not react leading you to believe that the simulation 
succeeded. This generally happens when changing a resistance 
to 0.

Workaround:

Check the ADS status window when using the hpeesofsim 
simulator. Select Tools > Stop Simulator, then resimulate.

IC-CAP hangs when using the TDR simulation type

EDA00179245 — When using the TDR simulation type in the 
SPICE3 simulator, IC-CAP hangs unless the Simulation 
Debugger is open. This only happens for certain permutations 
of input sweeps and number of points.
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Workaround:

Open the Simulation Debugger by clicking on the Simulation 
Debugger icon on the IC-CAP Main window, or adjust the 
number of points in your time sweep.

Transient simulation results are different

EDA00180241 — Transient simulations between simulators can 
vary because simulators often produce adaptive time stepping. 
IC-CAP uses linear interpolation to gather the points specified 
in the setup from the simulator's resulting data. This can lead to 
slightly different results between simulators if the two 
simulators choose differing time steps.

Parameter assignments do not parse

EDA00178675 — When using the hpeesofsim simulator, 
parameter assignments that contain the following type of 
syntax may not parse.
file{DAC1,"L"}

Workaround: 

Use #echo in front of such lines.

SPICE3 has a memory leak

EDA00179296 — The version of SPICE3 used by IC-CAP has a 
memory leak. The memory leak is very small for DC 
simulations, but is more pronounced for Two-Port simulations.

Workaround:

Select Tools > Stop Simulator every 1000 or so simulations 
to avoid draining system resources. 

Spectre442/443 simulation fails when LEVEL parameter defined

EDA00164251 — Spectre442 and spectre443 simulation fails 
when LEVEL parameter is defined as LEVEL = n, where n is a 
number.

Workaround:
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Enclose the LEVEL parameter value in parenthesis. For 
example: LEVEL = (11)

Native spectre parser does not display comments

EDA00178196 — The Native Spectre parser ignores comments 
and text within lang=spice blocks. This means that it will not 
include this with the netlist it sends to the simulator during 
simulation, nor when performing File > Export > Extracted 
Deck. 

Workaround:

Place such text behind #echo statements.

Mysim example file fails to simulate

EDA00179446 — The mysim example file fails to simulate with 
the Simulation Debugger window open.

Sync sweep may not fully work with Spectre

EDA00179404 — Sync sweep using LOG type sweeps may not 
work correctly when using the Spectre simulator.

HSPICE simulation results may be generated in $HOME directory

EDA00182016 — With IC-CAP 2004, all temporary hspice 
simulation result files should be generated in your tmp 
directory. However, some files may still be generated in the 
users's $HOME directory. When this happens, they may not be 
automatically removed by IC-CAP.

Workaround:

When using the hspice simulator, periodically check your 
$HOME directory for files starting with IC and ending with 
hspice suffixes such as .ac0, .st0, .sw0. If all simulations have 
completed, these file can be removed.
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SPICE3 simulator miscalculates temperature effects

EDA00177393 — The diode model in the spice3e2 simulator 
used by IC-CAP miscalculates temperature effects in AC or 
Two-Port simulations. This defect is in the spice simulator and 
still appears in the latest spice3f5 bits from Berkeley.

Workaround: 

Use another simulator (hpspice, spice2, e.t.c.) for diode 
temperature dependent simulations.

SPICE3 noise simulation without input hangs IC-CAP

EDA00178430 — If you simulate a noise setup without an input 
using SPICE3, IC-CAP hangs.

Workaround:

Click the Stop sign in the Status window to abort the 
simulation.

CAN_PIPE not working for Spectre

EDA00183697 — Using CAN_PIPE with Spectre does not work 
with the latest versions (MMSIM60, MMSIM61) or the older 
Cadence based installations (5.1.41, e.t.c.), or if the +csfe option 
is used. CAN_PIPE was an unsupported feature in Spectre that 
no longer works. 

Workaround:

Use CANNOT_PIPE mode for the newer versions or if +csfe is 
required. 

Spectre gets duplicate options line in netlist

EDA00182956 — If you examine the netlist sent to Spectre from 
IC-CAP in the simulation debugger, you may see duplicate 
options lines depending on the analysis and the netlist. This 
duplicate line does not affect the simulation results and can be 
ignored.
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Using stop sign during ELDO simulations cause IC-CAP to crash

EDA00174152 — You should not use the stop sign on the Status 
window during ELDO simulations. On occasion it can cause 
IC-CAP to crash.

Status window displays message during hpeesofsim simulations

EDA00174055 — The following message is often written to the 
Status window during hpeesofsim simulations using ADS 
2006A:
hpeesofsess: couldn't display info for session handle (#)

This will be resolved in an upcoming ADS MSR. Tools > Options 
> Status Window To Top can be deactivated to keep the Status 
window from popping to the front for this (or any other) 
message.

Message during remote Eldo simulation

EDA00198691 — During remote simulation to Eldo, a message 
like the following may be displayed to the status window:
/bin/rm: cannot remove `/var/tmp/IC2704.cou': No such file 
or directory

This message can be ignored.

Pipe Mode simulation does not work with Eldo 2008.1

EDA00198638 — Piped simulation support was added to the 
IC-CAP 2008 Addon 2 release, which leveraged a new Eldo 
interactive mode feature.   However, the new pipe mode support 
for Eldo  does not work with the new Eldo 2008.1 release due to 
some changes made to Eldo.   Agilent worked with Mentor to 
diagnose the root cause and Mentor has committed to provide a 
fix with their Eldo 2008.2 release.

In summary,  piped mode simulation is supported with Eldo 
2007.2b or higher with the exception of Eldo 2008.1.
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On Solaris, measurement in first session interrupted

EDA00179396 — On Solaris, when running a system using a NI 
GPIB interface, if you are running two IC-CAP sessions, and you 
exit the session that was started second, a measurement 
underway in first session can be interrupted. When the first 
session starts, the interface is not locked. This allows the 
second session to initialize the interface when it starts, causing 
the conflict when the second session closes.

Workaround:

Delete the .icconfig file from your $HOME directory before 
starting up a second IC-CAP session. This prevents the second 
session from initializing the interface.

On Solaris, core file generated

EDA00181802 — On Sun systems, IC-CAP may generate a core 
file if you enter an incorrect line feed to an Output's View Data 
window and choose the Accept Changes button. 

On Sun computers, “Switch DMM terminals to rear” appears

EDA00177972 — Occasionally on Sun computers, the message 
"Switch DMM terminals to rear" appears even though the switch 
button is set to rear already. 

Workaround:

Initialize the GPIB interface in the hardware window to dismiss 
the message. 

On Windows 2000, tab key does not move cursor

EDA00068817 — On Windows 2000, if you click on a cell in the 
IC-CAP/System Variables table then press the tab key, the 
cursor does not move from cell to cell.

Workaround:
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Highlight the entry in the IC-CAP/System Variables table before 
pressing the tab key.

On the PC, can not select text in Active Setup field

EDA00178123 — On the PC, you can not select the text in the 
Active Setup field for copying and pasting like you can on UNIX.

On the PC, only top banner showing of dialog box

EDA00178481 — On the PC, if you close the System Variables 
dialog box when it is minimized, then open it again, it will open 
at normal size in the minimized location with only the top 
banner showing. 

Workaround:

Click and drag the dialog box to the desired location.

On the PC, ICCAP_FUNC Dump Via Server can not print

EDA00182020 — On the PC, the ICCAP_FUNC Dump Via Server 
action can not automatically print the object, it can only write 
to a file.

On the PC, no warning message about expiring ADS license

EDA00132889 — On the PC, the Status window does not display 
warning messages that your ADS license is close to expiring.

Workaround:

Manually keep track of your ADS license expiration dates or 
periodically launch ADS as a standalone product. As a 
standalone product, ADS will display a warning message when 
the license is close to expiring.

On the PC, IC-CAP very slow

EDA00179466 — On the PC, IC-CAP may be very slow if too 
many temporary IC-CAP files are in the temporary directory. 
Temporary files are stored in the directory defined by the 
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ICCAP_TMP variable. If ICCAP_TMP is not defined, temporary 
files are stored in the TMP directory. If the TMP directory does 
not exist, temporary files are stored in the TEMP directory.

Workaround:

Exit all IC-CAP sessions and delete the temporary IC-CAP files 
(files beginning with Ic) from the temporary directory.

On the PC, IC-CAP text files difficult to read using Notepad

EDA00179078 — If you use Notepad on the PC to view the 
IC-CAP text files in $ICCAP_ROOT/config (new.txt, support.txt, 
or about.txt), the text files are difficult to read because they 
don't wrap correctly.

Workaround:

From the Main window select Help > What Is New to view 
new.txt and Help > About to view about.txt. Use WordPad to 
view the support.txt file.

On the PC, Import Create/Data display last directory

EDA00181977 — On the PC, when you select Import Create or 
Import Data then select Browse, the last directory that was 
selected is displayed instead of the current working directory.

On UNIX, BSIM4 RF Extract displays one less item

EDA00178432 — On UNIX, if you change the number of radio 
buttons displayed on the BSIM4 RF Extract model’s Display 
folder, one less item than the selected number is displayed. For 
example, if you change the number of radio buttons from four to 
five, then back to four, three buttons will be displayed. 

Workaround:

Close BSIM4 window and reopen.

On the PC, Status messages display slower

EDA00182046 — On the PC, if the Status window contains a lot 
of text, additional messages may display slower.
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Workaround:

Whenever status messages start to display slowly, select the 
Clear Output  and Clear Errors  icons on the Status 
window.

On the PC, Interface Name not Installed message appears

EDA00179464 — On the PC, IC-CAP may display numerous 
"Interface Name not Installed" pop-up messages when you click 
Add Interface in the Hardware Manager.

On the PC, Status window Stop sign fails to stop measurement

EDA00182171 — On the PC, the Status window’s Stop sign does 
not stop measurements with long hold times. The Stop sign only 
stops the measurement after the hold time completes. 

Workaround:

Do not set excessively long hold times.

On the PC, error message occur if directory paths have spaces

EDA00179462 — Do not launch IC-CAP from a directory that has 
a space anywhere along its full path. Do not Change the Start in 
field of the IC-CAP shortcut to such a path. Doing so will result 
in the following error messages being posted to your status 
window at startup:
Gemx error, error code = 11
ERROR AEL0352 11, Failed to invoke the process.: gemx error
Failed to invoke hpeesofdss!

Although it is possible to do so without an error posting, it 
is not recommended to use File > Change Directory to 
change to a directory that has spaces in it.

On the PC, license information usage may not function correctly

EDA00178987 — Clicking Help > License Information... from the 
IC-CAP/Main window, displays the Agilent License Information 
window. If you click on the Usage tab, IC-CAP on the PC may not 
be able to get the information from the license server.
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On UNIX, Rebuild Active List does not display searching message

EDA00179202 — On UNIX, the Rebuild Active List window does 
not display “searching for device at lan   [iccapgpib]:hpib xx”.

On the PC, tab pages may be redrawn incorrectly

EDA00181245 — When executing a macro after viewing the 
Setup Variables page, the DUTs - Setups page may be redrawn 
over the top of the Macros page and the Execute button may be 
redrawn over the top of the DUTs-Setups page. 

Workaround:

Click on the DUTs-Setups tab to redraw and correct the 
display.

On UNIX, checkbuttons with no caption are too small

EDA00177384 — If you make a checkbutton with no caption on 
UNIX, the button is abnormally small. 

Workaround:

Use a space “ “for the caption. However, this makes it 
difficult to center the widget in tables and such.

On the PC, ampersands don’t show up consistently in Studio

EDA00177374 — Ampersands (&) in pushbutton or table 
captions may not be displayed on the PC. For example, the 
caption foo & bar may be displayed as foo bar.

On the PC, Studio hangs when using a radio box in a table

EDA00179930 — On the PC, if you insert a radio box in the same 
table that contains a tabbed folder, IC-CAP can hang when an 
entry in radio box is selected. Note that this doesn't happen for 
all cases.

Workaround:
IC-CAP Release Notes



IC-CAP Release Notes

 

When designing a custom GUI using IC-CAP Studio, save 
your model before testing any dialog that contains both a 
tabbed folder and a radio box. If the problem occurs, 
redesign the dialog to avoid using a radio box or move the 
radio box to another table.

On the PC, IC-CAP does not default to 'home' directory

EDA00177718 — Various dialogs such as the File > Save As 
dialog in the Model window have a blank for a filename and a 
Browse button. When the blank is empty and Browse is selected, 
the browser should default to your current working directory 
(set using File > Change Directory in the IC-CAP/Main 
window). However on the PC, it may open up to the most 
recently viewed directory.

Workaround:

To easily insure your browser opens in the current working 
directory, type .\ in field prior to clicking Browse.

On the PC, scroll bar and cursor position may change

EDA00180295 — When you switch between two macros or two 
transform programs, the scroll bar and cursor position will 
probably not be where you left them when you return to a 
particular program.

On the PC, edits not updated in IC-CAP until Enter key is pressed

EDA00128645 — On the PC, on-screen edits to the Input, Output, 
and Plot pages are not updated in IC-CAP until the Enter key is 
pressed. If you make a change and then press a button outside 
the area you were editing, IC-CAP is not updated with your new 
edits. On UNIX, clicking anywhere outside the window 
automatically updates IC-CAP.

Workaround:

Press the Enter key when making on-screen edits to Inputs, 
Outputs, and Plots to assure that IC-CAP is updated with 
your edits.
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On HP-UX, error message displayed after using HPSPICE

EDA00182066 — When exiting IC-CAP after running simulations 
using the HPSPICE simulator, IC-CAP may display the following 
error after shutting down: 

"PID XXXX killed due to text modification or page IO error"

This error is benign.

On the PC, the system$() date command may return GMT

EDA00184563 — The system$() date command may return 
Greenwich Mean Time instead of the time on the system.

On the PC, IC-CAP may not use HOME directory when starting

EDA00184338 — If you define a custom HOME directory when 
you install IC-CAP on the PC, IC-CAP may display a warning 
message in the Status window when starting. The warning 
message states that it is unable to open .icconfig for reading. 
This occurs if a system HOME environment variable is defined.

On Linux, Spice2 and Agilent Spice may not work 

EDA00148769 — When trying to simulate using either Spice2 or 
Agilent Spice on Linux, a simulation failure may occur. This is 
do to missing Linux system shared libraries on some 
installations.

Workaround:

Install the GNU gcc 3.3.2 compiler if not installed or not 
installed in /usr/lib, then include the location of the compiler lib 
directory with LD_LIBRARY_PATH environment variable.

In Window 2000, Import Create causes IC-CAP to hang

EDA00184292 — In Windows 2000, if you try to Import Create 
from PEL to a setup that is empty, IC-CAP hangs.

Workaround:

First do an iccap_func(".../setup","Add 
Input","dummy") and then Import Create should work.
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On Linux, simultaneous AC/DC hpeesofsim simulations hang

EDA00182091 — Some simultaneous AC/DC hpeesofsim 
simulations may cause IC-CAP to hang on Linux. Clicking on the 
Stop sign to recover may result in a crash.

Workaround:

If an hpeesofsim simulation hangs while doing an simultaneous 
AC/DC simulation, find the hpeesofsim process with the ps 
command and type:

kill -9 <pid> 

where <pid> is the process id of the hpeesofsim process

If problems persist, you may also kill -9 the pid of process 
iccaplsim. Killing one or both should restore control to IC-CAP.

On Sun & HP-UX, IC-CAP cpp does not work well with native cpp

EDA00183018 — The default args that IC-CAP uses for cpp do 
not work well with the native cpp provided by Sun and HP-UX. 
Sometimes the IC-CAP cpp is listed in your path ahead of the 
native cpp provided by Sun and HP-UX.

Workaround:

On Solaris make sure that /usr/ccs/lib/cpp is listed first in 
your path. On HP-UX make sure that /usr/ccs/lbin/cpp is 
listed first. If the expected cpp is not available (for example, due 
to a trimmed OS install), it should be safe to set 
ICCAP_CPP_ARGS=-w --traditional in your iccap.cfg file 
and use a gnu version of cpp on these platforms. However, this 
is not tested nor supported. The supported solution is to load 
the part of the OS that provides the cpp under the /usr/ccs 
hierarchy.

On Linux, plots flash during optimization

EDA00178088 — The plot refresh mechanism on Linux appears 
to be slower than HP-UX or Solaris. This leads to a flashing 
appearance during optimizations and may cause the 
optimizations to be slower.
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Workaround:

Configuring your display to use a backing store may improve 
this situation.

On Solaris, widget with multi-line caption crashes IC-CAP

EDA00174113 — On Solaris, if you create a widget with a 
multi-line caption and try to display it, IC-CAP will crash. 

Workaround:

Enclose the widget and multi-line caption in an empty table 
with no caption (or a single line caption), and display the 
enclosing table.
PEL
In PEL, assignment handled differently

EDA00181445 — In PEL, assignment on an index-by-index basis 
is handled differently from assignment of an entire dataset. If 
you enter the statement x=ic*4 (where ic is an output of type B 
for both simulated and measured data), x will have both 
measured and simulated data assigned to it. If you use the 
statement x[0]=ic[0]*4, only the measured portion will be 
assigned. If you want to assign both, you must use two 
statements:

x.m[0]=ic.m[0]*4 

and
x.s[0]=ic.s[0]*4

Certain calls that close windows are delayed 

EDA00178706 — Certain calls from iccap_func statements that 
should close windows may not take effect until the macro is 
completed, or until another window is opened. The CloseAll 
keyword is one example. The apparent delay occurs during 
macro execution because X Window events are not regularly 
dispatched. When an iccap_func statement requests a window 
closure, a certain number of events must be processed before 
the X server actually removes the window from the screen. 
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Usually these events get processed when the macro ends, and 
the X event queue is fully processed. At times, though 
(depending on network latency and other factors), these events 
may be processed along with an iccap_func request to open a 
window.

Workaround:

There is no specific workaround, though a partial solution to 
the problem is available. This should only be used by advanced 
users who are trying to solve problems with large automations, 
and are willing to work through potential problems.

If you set the variable 
ICCAP_PROCESS_EVENTS_DURING_AUTOMATION to “Y” in 
your IC-CAP configuration file ($ICCAP_ROOT/config/iccap.cfg, 
$HOME/.iccap, $PWD/.iccap, $HOME/hpeesof/config/iccap.cfg, 
or $PWD/iccap.cfg), IC-CAP attempts to dispatch events 
whenever a window is opened or closed during PEL execution. 
Unfortunately, this is only partially effective, but may improve 
some long running automations that open and close many 
windows.

Transform does not execute

EDA00178000 — If one transform depends on data from a 
second transform and the second transform calls the first via 
iccap_func(), it will not execute at that time. The reason is that 
the data upon which it depends (results from the 2nd 
transform) is not yet ready.

Workaround:

Remove the dependency from the first transform or set it to 
UPDATE_AUTO and it will automatically be executed whenever 
the data in the 2nd transform is updated.

Do not use the dataset() function as Simulated entry

EDA00179089 — The new dataset() function should not be used 
in the optimizer as your Simulated entry. The reason is that the 
optimizer will try to juggle the parameters and then resimulate 
as necessary. If you specified dc/fgummel/ic as your Simulated 
entry, then IC-CAP would be able to resimulate setup 
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dc/fgummel after changing the parameters to see how the new 
parameters affected Simulated versus Target. However if you 
specified dataset("dc/fgummel/ic"), then IC-CAP only knows the 
value of the dataset function when it runs the expression. The 
Simulated expression is only run after the simulation occurs 
and thus IC-CAP does not know which (if any) simulation to 
run.

Setup Variables list is reordered

EDA00177511 — If you auto-create the Setup Variables using 
MDM_VALUES_LIST, the Setup Variables list is possibly 
reordered.

Can not automate Tools > Options > Status Window to Top

EDA00179493 — You can not automate the menu selection Tools 
> Options > Status Window to Top.

Deleting Input renders setup unusable

EDA00134728 — If an optimizer has a max() function call 
referring to an Input, deleting this Input can render the setup 
unusable. Even if a new Input with the correct name is added, 
viewing that data will show blank data because IC-CAP wants to 
calculate the max() function call before calculating the input 
points.

Workaround:

Remove the max() function prior to re-adding the Input, then 
replace it after the Input is added. 

Import Create does not reflect MDM

EDA00179378 — iccap_func(".","Import Create") does not reflect 
MDM_FILE_PATH and MDM_FILE_NAME. However, clicking 
the Import Create button does.

Import Create opens file browser with Export in header

EDA00182081 — iccap_func(“.”,”Import Create”) opens a file 
browser with Data Management - Export File in the header.
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PEL tanh(x) function fails for arguments greater than 355

EDA00177900 — The PEL tanh() function fails for arguments 
greater than 355. 

Workaround:

If argument is greater than 355, set tanh=1.

Variable containing ‘/’ not flagged as error when unresolved

EDA00177768 — If you run a macro with an output or transform 
variable that contains slashes (e.g., Main/NewSetup/SetupVar) 
and the variable does not exist, IC-CAP treats the variable as a 
local variable.

extr_para function not working for all frequencies in array

EDA00181689 — When generating a root model using the 
Frequency model variable in the 
/extr_para/parasitics/extract_parasitics function 
(HPRoot_wr), not all values of Frequency contained in the 
Setup parasitics freq array yield results.

In PEL, Averages has extra space for hp35670.cxx

EDA00179198 — The field name for Averages on the HP35670 
instrument options has a trailing space in the name. When 
accessing that field from PEL, you must refer to it as "Averages " 
(note the trailing space).

PEL recursion may not work if GUI callback is part of recursion

EDA00184100 — Be careful that you do not trigger further 
callbacks in a callback that recurses upon the same function or 
IC-CAP may crash. An example of a problem would be a Variable 
Changed callback on a GUI Item that in turn changes the 
variable being changed each time it is run. For example, if you 
have a variable changed callback for variable abc that calls 
function change_abc which is defined as:
change_abc: 

abc=abc+1 
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Once abc changes, the system will call change_abc which will 
again change abc causing the change_abc function to be 
reentered. Such recursion can cause the stack to overflow. 
Focus changed callbacks that cause other callbacks can get into 
cycles of recursion as well.

Problems reading long lines of PEL and circuit netlists

EDA00183501 — Prior to release IC-CAP 2006A/B, a space was 
inserted every 1024 (UNIX) or 512 (Windows) characters in long 
lines of PEL and circuit netlists when written to file (.mdl, .cir, 
.xfm, e.t.c.). Starting with release IC-CAP 2006 and all 
subsequent versions, the program writes long lines without 
adding any extra spaces.

Prior to release IC-CAP 2006B Addon2, UNIX versions could 
only read long lines properly if they had spaces every 1024 
characters. Windows versions could only read long lines 
properly if they had spaces every 512 characters. This means 
that IC-CAP 2006, IC-CAP 2006B, and IC-CAP 2006B Addon1 
could not read their own files properly if they contained lines 
longer than 512 or 1024 characters depending on the OS. Only 
the first 512/1024 characters would be read in. As of release 
IC-CAP 2006B Addon2, the entire long line will be read without 
any assumption about whether the spaces are every 512 
characters or 1024 characters—IC-CAP reads what is in the file.

Now with the change, if you read a file that has PEL/circuit 
lines longer than 1024 (UNIX) or 512 (Windows) characters and 
the file was saved with a version of IC-CAP prior to IC-CAP 
2006, then the line will have extra spaces in it that may or may 
not cause problems with the syntax of the line. To address this 
issue with older model files, simply correct any such lines in the 
circuit/PEL window using IC-CAP 2006B Addon2 and resave 
the file. Files with long PEL/circuit lines written from any 
version of IC-CAP 2006 and later will have been written without 
any extra spaces and thus will read properly into IC-CAP.
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Default file name in Selection field does not reflect file name field

EDA00179376 — When you click the Browse button in the 
Export Data dialog box to change the path and/or file name, the 
default file name in the Selection field does not always reflect 
the contents of the file name field in the first dialog box. 

• If you indeed want to change it, this is not a problem.

• If you decide to keep the path and file name displayed, 
review the Selection field carefully (or be sure you click 
Cancel instead of OK).

Data type unknown in an MDM file

EDA00178030 — When exporting data from IC-CAP to a Data 
Manager (MDM) file, you request the type of data to export, 
either Measured or Simulated. If an output is found that does 
not contain the requested data type, the other type is exported. 
So, if you request to export Measured data, then Measured data 
is exported from outputs of type M or B. However if only an 
output of type S is found, Simulated data is exported. Therefore, 
you do not know if the data in an MDM file is Measured or 
Simulated.

MDM cannot distinguish output and transform with same name

EDA00178025 — If an output and a transform have the same 
name, they look identical to MDM. If you choose to export the 
transform, both are exported to the MDM file.

Workaround:

The only way to distinguish the output data from the transform 
in the MDM file is to know that the first occurrence is the 
output data.

No warning that transform name is invalid

EDA00178468 — If an invalid transform name(s) is assigned to 
the MDM_XFORM_LIST variable, IC-CAP does not warn that the 
list of transform names is invalid. 
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Not all variables in MDM_VALUES_LIST transferred to MDM file

EDA00178417 — If a comma and a space separate variable1 and 
variable2 in the MDM_VALUES_LIST variable value, only the 
variable1 contents are transferred to the MDM file. In other 
words, more than one delimiter in a row for the 
MDM_VALUES_LIST variable does not work.

Workaround:

Separate variables in the MDM_VALUES_LIST with only a 
single comma or a single space.

MDM_FILE_PATH/NAME not correctly set using Export Data

EDA00177401 — MDM_FILE_PATH and MDM_FILE_NAME 
variables are not correctly set when using Export Data 
functions in macros. Even if the MDM_FILE_PATH and 
MDM_FILE_NAME variables are set and you execute a macro 
that uses the export data functions, the Data 
Management-Export File dialog box appears but the selection 
doesn't point to the values set by the MDM_FILE_PATH and 
MDM_FILE_NAME variables.

Import Create fails on setup with only CON sweeps

EDA00180461 — If you perform an Import Create on a setup 
with only CON sweeps, in which the input names don't change 
but some CON values do change, the values for the CON inputs 
still show the previous values.

Workaround:

Delete all inputs prior to importing an all-CON setup.

Using quote marks with ICCAP_VALUES variable crashes IC-CAP

EDA00184432 — If you add quotes around the name of a 
variable under the ICCAP_VALUES section of an MDM file (e.g., 
"myvar" "123"), it will not read properly and will instead create a 
variable with the name of " and a value of everything else (e.g., 
Name=" Value=myvar" "123"). These are invalid values for a 
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variable table and are not properly prevented by IC-CAP. If you 
then try to save and reread such a corrupted variable table, 
IC-CAP will crash.

MDM reader cannot read 0.000E+00

EDA00184190 — The MDM reader in IC-CAP cannot read 
0.000E+00.

Workaround:

Use 0 or 0.0, but not E notation.
Hardware Manager
 

IC-CAP may crash during rebuild active list

EDA00182296 — If you interrupt an "rebuild active list" 
operation by clicking both the Cancel and the Status window 
stop sign in succession, IC-CAP may crash.

Workaround:

Only use either the dialog Cancel or the Status window stop 
sign to interrupt a rebuild active list in progress.

Hardware setup manager fails to update Interface list

EDA00178394 — The hardware setup manager may fail to 
update the Interface list in the Hardware Setup dialog when you 
physically disconnect an installed interface (LAN or GPIB card) 
without first deleting it from the active interfaces list.

Workaround:

Before disconnecting an interface, such as a LAN box, remove it 
from the active Interfaces list in the Hardware Setup dialog.

Hardware manager fails to recall saved .hdw files

EDA00179427 — The hardware manager fails to recall saved 
.hdw files if the instrument list was deleted but the interface list 
was not deleted. The following is an example of an error 
message that appears in the Status window:
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No interface file at select code -2 -- can't add Agilent E5270 0 18. 

Workaround:

Before recalling a .hdw file, delete both the instrument list and 
the interface list.

On the PC, defining usb0 as hardware interface crashes IC-CAP

EDA00110565 — Selecting the following in IO setup cause a core 
file to be generated when usb0 is selected as interface name in 
the Hardware Setup dialog.
VISA Type | Interface Discription
-----------------------------------
USB | *USB Instruments

VISA name | SICL Name
-------------------------
USB0 | usb0

Workaround:

USB Instrument is not a supported interface. Do not use it. Use 
the Agilent 82357A USB/GPIB SICL/VISA interface instead.
 

IC-CAP Studio
Widgets in the Table are resized to 0x0 and not visible

EDA00178913 — If you create a Table widget, with width and 
height options locked, and place it directly on a Page widget 
(other than the first Page), the widgets in the Table are resized 
to 0x0 and not visible when you change to that Page.

Workaround:

Place a Table with no options on a Page, then place the Table 
with the locked width and height inside of the first Table.

Tasks not performed when GUI closed using windows manager

EDA00177303 — If you create a GUI with a Cancel or Close 
button that not only closes the GUI but also performs other 
tasks, you need to be aware that the user can close the GUI 
using the window manager (x in upper left hand corner). 
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Closing the GUI using the window manager closes the GUI 
without alerting the GUI program that the GUI was closed. 
Therefore, the other tasks will not be performed.

Edits to spreadsheet not relayed into variable table

EDA00178427 — If you are creating a spreadsheet table and you 
specify a one dimensional array for the Entries option, the 
spreadsheet comes up as defined but edits to the spreadsheet 
are not relayed into the variable table. However, edits to the 
variable table are displayed in the spreadsheet table.

If you select Add Child then Cancel, child still displayed in GUI

EDA00181991 — If you are creating a GUI and you select Add 
Child then select Cancel, the child will be displayed in the GUI 
even though it is not listed in the tree of the Model GUI Items 
folder.

Workaround:

Add a dummy child, then delete it. The GUI will now match the 
Model GUI Items folder (i.e., there won’t be any extra button 
entries).

Visible Rows and Columns Visible options do not function

EDA00184370 — The Visible Rows and Columns Visible options 
do not function on the Table GUI item.

Workaround:

Ignore the Visible Rows and Columns Visible options for Table 
GUI item.

Widgets in table incorrectly sized

EDA00180455 — If you create a table and select both Equalize 
All and Minimize Width, the widgets in the table may be 
incorrectly sized.

Workaround:

Do not select both Equalize All and Minimize Width.
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Dropdown combo in IC-CAP studio display hourglass

EDA00181821 — Dropdown combo boxes in IC-CAP studio may 
display an hourglass while selecting an entry. Please ignore the 
hourglass, the combo box will still work properly.
1/f Noise Extraction Toolkit
Changing icon name does not change subcircuit name

EDA00177969 — If you change the 1/f Noise model icon name, 
the subcircuit name does not automatically change.

Workaround:

For each DUT, manually change the subcircuit name in the Test 
Circuit tab.

Data lost after changing simulator

EDA00179244 — Changing the simulator in the 1/f Noise 
Extraction Toolkit loads new Circuit, Subcircuit, and Parameter 
files. This can result in lost data. Therefore, you should not 
change the simulator in any window other than the 1/f Noise 
System Setting window.

Workaround:

Only change simulators in the 1/f Noise System Setting window 
and make sure you have Circuit and Subcircuit files specified 
for the new simulator (see IC.3195).

Simulation ends with an error

EDA00145431 — Changing the simulator in the 1/f Noise 
Extraction Toolkit requires a dedicated circuit deck file that 
loads automatically. If you change the simulator without having 
this file, nothing gets loaded in the circuit deck. If you try to 
simulate, the simulation ends with an error. 

Workaround:

Before changing the simulator, make sure you have a dedicated 
circuit deck file that loads automatically.
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Options menu items are not functional for histogram

EDA00177976 — The menu items under Options for histogram 
are not functional but can be selected.

IC-CAP may crash when opening an invalidly formatted .sdf file

EDA00181993 — If you attempt to open a ill-formatted .sdf file, 
the program may crash and generate a core file.

Column 1 does not change to selected width

EDA00178457 — If you change the column width, column 1 does 
not change to the number you select. 

Row or column moves one less than you specify 

EDA00184304 — When you move a row or column, the row or 
column moves one less than you specify. For example, if you 
specify to move row 1 to row 4, row 1 moves to row 3.

Workaround:

Add one to the desired row or column number. For example, if 
you want to move column 1 to column 4, specify column 5.

One less boundary point than defined

EDA00178684 — The scatter plots for non-parametric statistics 
display one less boundary point than what was defined in the 
Non-Parametric Analysis dialog box. For example, if 5 boundary 
points were defined, only 4 are plotted.

Workaround:

Define one more boundary point than the desired number in 
the Non-Parametric Analysis dialog box.

Scatter Plot Matrices will also plot de-activated columns

EDA00182301 — Scatter Plot Matrix plot will also plot columns 
marked as deactive if selected.
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Workaround: 

Select only columns of interest for the scatter plot matrix

Scatter Plot Matrix print function does not work 

EDA00180102 — The print function for the Scatter Plot Matrix 
does not work.

Importing an SDF formatted file causes IC-CAP to crash

EDA00181354 — IC-CAP will crash if you attempt to import an 
SDF formatted file into the Statistical Analysis window.   The 
statistics import function is used to import space delimited 
ascii formatted data only.

Autoscale in Manual Rescale dialog produces unexpected results

EDA00179003 — Using the Manual Rescale dialog to select 
Autoscale for the X axis of a histogram or CDF plot does not 
produce the expected result. Do not use this mode.

ERROR AEL0003 displayed while using Data Filter dialog

EDA00177461 — When viewing the Data > Data Filter dialog in 
the Statistics package, do not change the column selected to an 
attribute column or you will see the following error:
ERROR      AEL0003 (less than) file 
"../../../../projects/iccap/ael/icstat/icstatfilter.ael", 
line 194, column 28: parameter stack underflow

Statistics with an underscore in the name cause problems

EDA00182555 — Columns in statistics with an underscore (_) in 
the name cause problems when performing Data 
Transformation.

Workaround:

Avoid using parameters with an underscore (_) in the name.
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Statistics can be opened from PEL on all platforms

EDA00183252 — The Statistics package can be opened from PEL 
on all platforms. The Statistics package should not open from 
unsupported platforms.

Running Correlation Analysis on empty spreadsheet

EDA00183021 — If you attempt Correlation Analysis with out 
any numeric values, (such as just after a File > New, or after 
adding text to one of the cells when all others are empty) an 
integer division by zero results which crashes IC-CAP on Solaris 
but only generates a floating point error on HP-UX.

Spreadsheet macro mdm2stats does not work correctly

EDA00183140 — In the demo_features example file 
8_statistics/meas_vs_param_stats.mdl, if you run the macro 
mdm2stats accepting all the defaults, you will end up with 100 
rows of data but only the first 11 will have real data. To begin 
statistical analysis after running the macro, select all blank 
rows and delete them.
Miscellaneous
Attempting to open the file browser causes IC-CAP to crash

EDA00178135 — Attempting to open the file browser after 
removing the execute permission from the current working 
directory will cause IC-CAP to crash.

Workaround:

None

Parsing error message appears when parameter table cleared

EDA00178157 — The Parameter table is cleared and a parsing 
error message appears. This problem will occur if you load a 
.mdl file that was saved in a previous session with 
SIMULATOR=xxx, and xxx is not properly defined in the 
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current session. (IC-CAP will assume the circuit is SPICE 
syntax, and if it is actually MNS or Saber, saving the file will 
overwrite the parameters previously saved in the file.)

Workaround:

The only way to preserve the parameters in the saved file is to 
exit IC-CAP without saving changes, define the simulator name 
in usersimulators, and restart IC-CAP. You can then continue 
making changes to parameters.

No warning message displayed for invalid path statements

EDA00180108/EDA00177979 — Be careful to use valid path 
statements for the USERSIMFILE variable and similar file 
definition variables in iccap.cfg or .iccap because IC-CAP will 
not display a warning message in this situation. If you set 
USERSIMFILE in .iccap to an undefined location, only the 
default SPICE2, SPICE3, and HPSPICE will appear when you 
choose Tools > Select Simulator.

On UNIX, some newer printers not supported

EDA00178844 — The version of ghostscript shipped with IC-CAP 
UNIX is not the latest version available, and it does not support 
some of the newer HP DeskJet printers, such as the HP CM1600.

Workaround:

Download the newest version of ghostscript from its web site at 
www.ghostscript.com.

License Status window slow to display

EDA00138685 — If you have a license.lic with 'uncounted' 
licenses (that is, the INCREMENT lines say 'uncounted' or 0 
after the expiration date) and you do not specify the hostname 
properly (the first word after SERVER), selecting Tools > License 
Status will take excessively long.

Workaround:
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Edit the license.lic file and specify the proper hostname. The 
proper hostname can be determined by selecting Start > Settings 
> Control Panel > Network.

Floating point errors reported

EDA00179241 — The computer related mathematical 
computational limit is ~1.7e-308 (double 64-bit). If you attempt 
to compute values smaller than that floor limit, floating point 
errors may be reported.

Workaround:

Do not attempt to compute values smaller than the system’s 
numerical limit.

Points per octave incorrect

EDA00128781 — The definition for octave log sweep was 
corrected in IC-CAP 2004. Therefore, if you saved an .mdl file in 
IC-CAP 2002 or earlier that had an octave based log sweep, you 
may lose data when reading the file into IC-CAP 2004. However, 
if you specified both the # of Points and Total Pts with real 
numbers (not variables) and # of Points is divisible by 3, data 
will not be lost. In this case only, your data is properly read 
forward into IC-CAP 2004.

Workaround:

Open the .mdl file in IC-CAP 2002 (or earlier) then change the 
sweep type from LOG to LIST. This preserves the sweep values 
and you will not lose any data when you read the file into 
IC-CAP 2004.

Warning issued about missing terminating character

EDA00179272 — When running a simulation, a warning message 
may appear about a missing terminating character. This occurs 
if you added comments that included apostrophes or quote 
marks without matching end quotes. The message is merely a 
warning and does not affect the simulation.

Workaround:
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To avoid the message, don’t use apostrophes or unmatched 
quote marks in your comments. For example, *”hello.

If startup directory contains spaces, Gemx error occurs

EDA00179237 — If during installation you select a startup 
directory that contains spaces, a Gemx error occurs. During 
installation on the PC, you can inadvertently select a startup 
directory that contains spaces by deleting the suggested 
directory and leaving it blank. Depending on your Windows 
configuration, the resulting default directory could be 
something like Documents and Settings which contains spaces.

IC-CAP appears to be locked up after you click License Status

EDA00177993 — If you have a lot of licenses on remote 
machines with a high latency network, IC-CAP appears to be 
locked up after you click Tools > License Status.

Printing plots with Area Tools on in black and white prints black 
squares for the area tools

When printing IC-CAP plots, the area tools will just print as 
black blocks.

Workaround:

Turn off area tools display before printing.

Data points not determined by calculation applied to reference

EDA00184439 — IC-CAP can display curves with differing 
numbers of points on the same graph as long as IC-CAP can 
determine the origin of the data. Thus if you specify 
../fgummel/ic as an X or Y on a plot, then IC-CAP knows the 
correct number of points per curve to use for ic data by 
referencing the fgummel setup. However, as soon as you apply 
any calculation to the reference, IC-CAP does not look inside 
the calculation to determine number of points so an expression 
like -1*../fgummel/ic will generate N points of data, but in 
order to plot these N points, the plot needs to know how many 
points go for each curve. Since it doesn't look inside the 
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expression it defaults to the current setup and uses the points 
per curve in the current setup as the way to plot the N points of 
data.

Problem with equations that rely on values defined later in model

EDA00182880 — Avoid equations in DUT level Parameters that 
rely on values that occur later in the model (in setups or DUTS 
that occur below the current DUT in the DUTs Setup tree). 
Doing so will cause problems reading in the file where values 
will not be calculated correctly possibly leading to loss of data.

Simulation fails if DC setup does not have LIN or CON sweeps

EDA00182110 — If you create a DC setup that does not have a 
LIN sweep or CON sweep, then IC-CAP will not create a .DC line 
and the simulation will fail.

Workaround:

Add a dummy node that is set to a CON value.
 

Documentation Search
Partial word queries 

Using a partial word for a query entry could prevent the search 
engine from finding any matches. For example, when you 
perform a query, use a complete term such as hpeesofsim 
because no matches will be found for eesofsim. 

Boolean operators are not allowed in searches for exact phrases 

When searching for an exact phrase, Boolean operators (AND, 
NOT, OR) are not allowed in the query. For example, the exact 
phrase "design and display" is not allowed, and the following 
message will appear: 

"Bad query. Not expected in phrase: and." 

Workaround:

Try to reformulate your query using an alternate syntax such 
as: 
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design NEAR display 

More information about this issue may be found by referring to 
the Agilent EEsof Knowledge Center at: 

http://edasupportweb.soco.agilent.com/cgi-bin/show.pl?id=
Learning_Prd.4407

Running a second search in the Documentation window causes 
an error 

When you run a search using the entry box available in the 
Documentation window, a Search window appears with the 
results. On UNIX, if you run a second search in the 
Documentation window (not in the Search window), a 
JavaScript error appears: "Search applet undefined". 

Workarounds:

• When the Search window is open, run any additional 
searches from the Search window.

• If you prefer running additional searches from the 
Documentation window, close the Search window first, or 
click Reload in the Documentation window's toolbar, then 
run the search.

Documentation Search errors may occur on WinXP SP2 systems 
with local installations 

In certain cases, documentation search errors may occur on 
Windows XP SP2 systems if you are logged in as a local user 
without administrator privileges. 

Workarounds: 

• Use a different web browser such as Netscape or Mozilla 
Firefox. 

• Have administrator privileges enabled for you. 

More information about this issue may be found by referring to 
the Agilent EEsof Knowledge Center at: 

http://edasupportweb.soco.agilent.com/cgi-bin/show.pl?id=
Learning_Prd.4523
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Hyperlinks to PDF files do not work on Windows machines using 
Internet Explorer 6x

In Microsoft Windows machines running Internet Explorer 6.x, 
there may be no response when a hyperlink to a PDF file is 
selected.

Workarounds:

• You may choose to reconfigure your Windows XP or 2000 
machine to enable PDF files to open in Internet Explorer 6.0. 

For Problems Viewing PDFs from a local installation of ADS.

To accomplish this use the following four procedures:

Prior to making these modifications, please review the following Microsoft 
 

NOTE
support documents:
http://support.microsoft.com/kb/315933/en-us?spid=2073&sid=global
http://support.microsoft.com/kb/182569/
http://support.microsoft.com/default.aspx?scid=kb;en-us;833633
Configure XP to Display the My Computer Web Content Zone in the IE 
Tools Internet Options Security tab.

1 From the Windows task bar, choose Start > Run to open the 
Run dialog. 

2 In the Run dialog, enter regedit and click OK. 

3 In the Registry Editor, click on the [+] buttons to open 
subfolders and browse to the following registry key folder: 

HKEY_CURRENT_USER >Software > Microsoft > Windows > 
CurrentVersion > Internet Settings >Zones > 0.

4 In the Registry Editor, “Name” column, double-click Flags. 

5 In the Edit DWORD Value dialog, change the Value data: 
from 21 to 47 and click OK.

6 In the Registry Editor, choose File > Exit. 
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Configure IE Internet Options “Advanced” Settings (Windows XP only).

1 From the Windows task bar, choose Start > Internet (Internet 
Explorer) to open Internet Explorer (IE). 

2 In IE, choose Tools > Internet Options. 

3 In the Internet Options dialog, click the Advanced tab. 

4 Scroll down to the Security section and select the “Allow 
active content to run in files on My Computer” checkbox. 

5 In the Internet Options dialog, click Apply. 

Configure IE Internet Options “Security” Settings.

1 In the Internet Options dialog, click the Security tab. 

2 In the “Select a Web content zone to specify its security 
settings”, click My Computer. 

3 In the Security level for this zone group, click Custom Level. 

4 In the Security Settings dialog Reset custom settings group 
Reset to: drop-down list, choose Medium and click Reset. 

5 In the “Warning! Are you sure you want to change security 
settings for this zone?” dialog, click Yes. 

6 In the Security Settings dialog, click > OK. 

7 In the Internet Options dialog, click > OK. 

8 Close all instances of Internet Explorer. 

If you still cannot open PDFs:
NOTE

Repeat Steps 1 through 8 in, “Configure IE Internet Options Security 
Settings.”

Ensure that Acrobat Reader is configured to open PDF files within the 
browser (In Acrobat Reader, click Edit > Preferences > Options and 
ensure the checkbox “Display PDF in Browser” is selected.
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For Problems Viewing PDFs on the Web:

On some machines there is a problem with the security settings 
in Internet Explorer 6x. In this case, the following steps may 
resolve the problem:

1 Open IE 6.x.

2 Choose Tools > Internet Options.

3 Click the Security tab.

4 Click the Local Intranet icon.

5 Click the Sites button.

6 Click the Advanced button.

7 Enter “http://eesof.tm.agilent.com” in the “Add this Web site 
to the Zone” field.

8 Click the Add button.

9 Accept the changes to the preceding dialogs by selecting OK 
for each.

Alternately you may:

• Right-click the PDF hyperlink, then choose “Save Target As”.

• Use a different web browser such as Netscape or Mozilla 
Firefox.

More information about this issue may be found by referring to 
the Agilent EEsof Knowledge Center at:

http://edasupportweb.soco.agilent.com/cgi-bin/show.pl?id=L
earning_Prd.4529

On Linux Systems, PDF Files May Not Open Using the Mozilla 
Browser.

This happens because the Mozilla browser expects the PDF 
application to be in a specific location, and this may not be the 
case. To solve this problem, modify the location of the PDF 
application specified in the browser settings. This modification 
will be retained for future use.
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