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This chapter documents the Agilent 85191A Agilent Root FET 
model generator software. It provides an example procedure 
that takes you step-by-step through a complete data acquisition 
and model generation.

The complete procedure includes all the instructions needed to 
generate a new device model by modifying the variable values in 
factory default tables. After you have set these variables, 
subsequent procedures are much faster. 
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Model Description
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The Agilent Root FET model is a data-based model, rather than 
a physical or empirical model. It generates a device-specific 
large-signal model directly from measured DC and small-signal 
S-parameter data, that accurately represents the terminal 
characteristics of the device. The model is constructed without 
circuit simulation or optimization. Use of S-parameter as well as 
DC data results in a model that can accurately predict nonlinear 
device performance with frequency dispersion, as a model 
simulated with a single set of nonlinear current functions 
cannot. The Agilent Root FET model predicts the device 
performance as a function of bias, power level, and frequency. It 
allows circuits containing devices for which measured data 
exists—but for which there are no good physical or empirical 
models—to be simulated.

The Agilent Root FET model works for MESFETs and HEMTs 
(MODFETs). It is scalable to allow simulation of devices with 
different geometries based on the characterization of a single 
device. The present implementation is used for positive 
drain-source bias (Vds ≥ 0), which corresponds to the typical 
operating region. 

Based on gate-current and power-dissipation device 
compliances you provide in software, the data acquisition 
system calculates the safe operating range for the device. Within 
this region, the model takes data adaptively at multiple bias 
points, depending on the specific nonlinearities of the device 
under test. Measurements are densely spaced in the most 
nonlinear regions, such as at the knees of the IV curves and the 
onset of breakdown, and less densely spaced in the linear 
saturation region.

The model data set of internodal nonlinear current and charge 
components at each bias point is then mathematically generated 
and stored. The model is thus generated without the usual need 
for simulation and optimization as required by all previous 
empirical models. The Root FET model may thus capture 
nonlinear device behavior for any MESFET device for which 
measured data can be taken but for which there are no good 
physical or empirical models.
IC-CAP Nonlinear Devices Models Volume 2
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The data acquisition system sets the DC bias levels and controls 
the system hardware to take the DC and S-parameter 
measurements, based on your inputs. The model generator 
processes the measured data and generates the lookup tables 
required by a circuit simulator. It produces data files that are 
directly readable by the Agilent RF and Microwave Design 
System (MDS). Both IC-CAP and MDS can be run 
simultaneously in the X Windows environment. During a 
simulation, the tabular state-function data from the generated 
Agilent Root FET model is interpolated using multidimensional 
spline functions to emulate the terminal characteristics of the 
device.

The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP.
olume 2 13
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This example procedure assumes the following:

• The system hardware has been set up and switched on 
according to the instructions under 

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System” 

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System” 

Rename the SMUs to correspond with the FET terminals. 

Rename a medium-power SMU such as MPSMU1 as VG (gate 
supply)

Rename a high-power SMU such as HPSMU3 as VD (drain 
supply)

Rename the GNDU unit (which must be connected to the 
device source) as GND.
IC-CAP Nonlinear Devices Models Volume 2
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on opening the IC-CAP software and accessing the model file 
you need. Find the Agilent Root FET model file under:

/examples/model_files/mesfet/HPRootFet.mdl

Then return to this chapter and continue with the procedure.
NOTE Do not install the device yet. The procedure will instruct you to install it 
after extracting the measurement port resistances.
Before you continue with the IC-CAP procedures, make a new 
directory in an appropriate location to store the data and model 
files that will be generated. Give the directory a name that will 
associate it with the device you are going to model. Use the cd 
command to change to the new directory.
MNS Link
 
The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP. The link 
is set up for MDS version B.07.00, and will need to be modified 
when MDS is updated. For the link to work, the path and 
environment variables need to be set correctly: this is done at 
the factory for the path and environment of a typical MDS 
B.07.00 system. Only minor changes to reflect unusual MDS 
paths or updated MDS versions are likely to be required. If you 
do need to modify your UNIX files to reset the MNS link, follow 
these steps to set the root MDS directory on your system and 
add $MDSROOT/mdsbin to the path:
olume 2 15
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For shell or kshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory to automatically set 
the environment variables:

MDSROOT=/mds_b.07.00 (depending on the version and 
location of MDS)
export MDSROOT
PATH=$MDSROOT/mdsbin: “$PATH”
export PATH

2 Also add a line similar to the following to the usersimulators 
file in /usr/iccap/lib, so that IC-CAP recognizes the MNS 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” CANNOT_PIPE

For cshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory:

#Setup for mns simulator:

setenv MDSROOT /mds_b.07.00
setenv PATH $MDSROOT/mdsbin: “$PATH”

2 Add a line similar to the following to the usersimulators file 
in /usr/iccap/lib, so that IC-CAP recognizes the mns 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” CANNOT_PIPE
IC-CAP Nonlinear Devices Models Volume 2
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This chapter provides an example procedure that takes you 
step-by-step through a measurement and model generation. The 
device used in this example was a GaAs MESFET, and the 
device data sheet was used for information on device 
characteristics and compliance values. Values you use in 
generating your own device model will depend on the particular 
characteristics of your device: use its data sheet (if available) as 
a reference.

This example is provided as a starting point. It is a 
straightforward procedure that uses only a subset of IC-CAP’s 
total capabilities. The complete procedure documented gives all 
the steps necessary to configure IC-CAP with the values 
required for preverification measurements, parasitic 
extractions, and the main data acquisition. Once a model has 
been developed for a particular device type, the built-in scaling 
feature allows you to apply it to any device with the same 
geometry and process. The modeling procedure then becomes 
more simple, and can be accomplished in a few easy steps.
NOTE Although you will modify the variable values in factory default files during 
this procedure, do not under any circumstances change the names of any 
variables or setups. These names are used by the software in the data 
acquisition and model generation process.

The example procedure measures the FET under test in a common-source 
configuration.
The example procedure gives detailed instructions on how to:

• Initialize device parameters.

• Measure and extract the system measurement port series 
resistances.

• Make a DC measurement to preverify device DC performance 
(optional).

• Calibrate the network analyzer for both swept and CW 
measurements.
olume 2 17



18

1 Agilent Root FET Model Generator
• Make an S-parameter measurement to preverify device 
performance at high frequencies (optional). 

• Measure and extract the ideality factor.

• Measure and extract the device parasitic resistances and 
inductances.

• Set up and initiate the main data acquisition. Plot the 
measured data.

• Set up and initiate the model generation, first selecting a 
starting point for contour integration. Plot the calculated 
state functions.

• Verify the model against measured data.

• Store the data and model files for circuit simulation in 
Agilent MDS.

Where necessary, other chapters are cross-referenced at 
appropriate points in the procedure, so that you will have the 
information you need for system hardware setup and 
calibration at the proper times.
 

NOTE Measurement values and measured data are specific to individual devices. 
Information and data are provided here as examples and guidelines, and 
are not intended to represent the only correct results.
The procedure provides guidelines on setting values to measure 
your device. However, the values you use will be based on your 
knowledge of your device and on information in its data sheet, 
as well as on the guidelines presented here: they may or may not 
correspond with the example values.

The illustrations of plotted data are provided as visual examples 
of possible results. They are not intended to represent a single 
device, nor do they necessarily correspond with the values 
given in the procedure. The plots can be used to check the 
reasonableness of your own data, which should appear similar 
in shape but not necessarily coincident in values.
IC-CAP Nonlinear Devices Models Volume 2



Agilent Root FET Model Generator 1
The DUTs and Setups
IC-CAP Nonlinear Devices Models V

 

The Model window is the central access point for the 
measurement and model generation procedures. The Model 
window includes the DUT/Setup panel and the file tabs to 
access the Model Parameters table, the Model Variables table, 
and other IC-CAP features.

The illustration shows the DUT/Setup panel for this model. The 
DUTs (for example pre_verify), indicated by the inverted 
triangles, are groupings of similar measurement setups used to 
extract related model parameters. The setups (for example 
idvd_vg) contain the information used to define the inputs and 
outputs for each measurement, as well as their measurement 
hardware configurations and their associated transforms and 
plots.

The MACRO list provides access to functions that combine 
certain groups of  IC-CAP operations into single operations.

Figure 1 The DUT/Setup Panel
olume 2 19
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You begin the procedure by entering certain key values for the 
device and the model generation, and giving the device an 
identifying name. For this you use the init_parameters macro. 
When this macro is executed, it also initializes internal program 
functions that are essential in the model generation process, 
and it provides annotations for the data plots.

1 Click the Macros tab, and a list of macros is displayed.

2 In the Select Macro list, select init_parameters, and Execute.

3 A series of dialog boxes is displayed, asking you to input 
appropriate values for your device under test. Each time you 
enter a value, click OK or press Enter.

4 Enter the extraction frequency. This is the CW frequency you 
will use for the data acquisition, and must be the same as the 
frequency of your CW calibration. If you know the 
fundamental frequency of anticipated operation, use that. If 
not, a good rule of thumb is to use a value such that fT/5 ≤ 
fextract ≤ fT/2. 

fT of a device is given by the equation:  

5 Enter the forward conducting gate current in amps. This is 
typically 200 mA per mm of gate width.

6 Enter the reverse gate breakdown current in amps. This is 
typically 20 mA per mm of gate width.

7 Enter the number of gate fingers.

8 Enter the width of the device gate, in meters.

9 Enter a name to identify the device under test.

10 When you finish responding to the questions in the dialog 
boxes, the macro will close.

fT
gm

2πCG
---------------≈
CAUTION Do not edit the init_parameters macro. Especially, do not make any 
changes below the line (as instructed in the macro). The information 
below the line is executable code: modifying it can cause problems in 
the program.
IC-CAP Nonlinear Devices Models Volume 2
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The illustration shows the Model Parameters table, with initial 
values for the extrinsic parasitic capacitances and inductances. 
The table is presented so that you can enter values for these 
extrinsic parasitics based on your knowledge of the device, or 
on estimates, or on measurements of the open fixture. In 
addition, you can set limits by entering minimum and maximum 
values for each parameter. Parameter values that are outside 
their limits are clamped to their minimum or maximum values.

To change a value in the Parameters table, move the mouse 
pointer over the current entry and click left to highlight it, then 
type in a new value.

The default for all the c values is 0.000. A reasonable 
capacitance value to enter for a pad on a wafer might be 50 fF.

The l_ext.1 values are the bond inductances for the three 
terminals. The default value for all three is 0.000. If you know or 
can estimate the bond inductances for your device based on 
wire length or grid size, enter appropriate values.

Figure 2 Model Parameters Table
Extracting the Measurement Port Series Resistances
This procedure need be performed only following initial 
installation of the system and if changes are made in the system 
hardware.
olume 2 21
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The procedure measures a short circuit at the normal device 
measurement interface plane. IC-CAP controls the DC 
source/monitor to force a gate current and monitor the gate 
voltage. The primary measurement is at port 1, and the port 2 
measurement is synchronized to the port 1 measurement. You 
set the measurement parameters by defining the instrument 
states and the DC input values, as explained in the next pages.

The software calculates the series resistances from the outputs 
of the bias networks to the inputs of the device under test. The 
resistance values are then incorporated into the model file, and 
their effects are removed from the device response during the 
modeling process. (The default port resistance for both port 1 
and port 2 is 0Ω.)

Note that the first part of the procedure differs for probe station 
and in-fixture measurements.

Setting Up for the Measurement

1 If you are using a probe station, position an impedance 
standard substrate (ISS) on the chuck. Place both the port 1 
and port 2 probes on a short circuit standard. 

2 If you are using a fixture, insert the short from the in-fixture 
calibration kit.

3 From the DUT/Setup panel select the r_series setup. 

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Set Integ Time to M (medium). Then return to this chapter and 
continue.
IC-CAP Nonlinear Devices Models Volume 2
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Setting the r_series Inputs

Use the following guidelines for setting the ig and id inputs (in 
most cases, the default settings should suffice):

Table 1 For the ig input

Set To

Mode I

To Node G (gate)

From Node GROUND

range Start and Stop current values that define a current range 
within the limits of the bias network (see Caution below)

# of Points sufficient to make several measurements 
across the current range

Compliance As high as 5 to 10V. With a current input, compliance refers 
to voltage. You can set the compliance as high as 5 to 10V 
because the device is not yet connected.

The Step Size will be set automatically.

Table 2 For the id input

Set To

To Node D 

Unit VD

Compliance same as ig

SweepType SYNC 

Master Sweep ig (so that the id sweep is synchronized to the ig sweep, 
with a 0.0 Offset)

Ratio 1.000 (so that the id sweep is synchronized to the ig sweep)
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CAUTION The bias networks can be destroyed if IC-CAP measurement current 
values are set too high! Be sure you know the maximum current 
ratings of your bias networks, and do not set current values beyond 
these limits. (The standard bias networks for the Agilent 85122A and 
85123A parameter extraction test systems are rated at 0.5 amp.) 
24

 

• The Unit name must match the name of the SMU connected 
to the device gate (probably VG). This is also the SMU unit 
name set in the Hardware window. Refer to the appropriate 
chapter as follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

• The default settings for the Outputs should not be changed.

Measuring and Extracting

1 Select Measure/Simulate > Measure.

2 When the measurement is complete, the Measuring light on 
the DC source/monitor goes out and the IC-CAP wristwatch 
icon goes away.

3 Select the Extract/Optimize tab.

4 Select compute_rseries > Execute. The transform calculates the 
port series resistances from the measured data and inserts 
the values into the model variable table as r1s and r2s.
Installing the Device

CAUTION Ground yourself with an antistatic wrist strap to reduce the chance of 
electrostatic discharge. (Note that the Agilent 85122 or 85123 system 
work surface is coated with antistatic material and is connected to 
chassis ground, therefore a static mat is not required.)
IC-CAP Nonlinear Devices Models Volume 2
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Install the device carefully on the probe chuck or in the fixture. 
Be sure to handle the device as little as possible, to avoid 
damaging it. Once the device is in place, avoid bumping the test 
station.
Preverifying the Device DC Data

CAUTION Remove any high-intensity light sources such as microscope light 
before taking a measurement. One simple method of blocking light is to 
place an opaque box on the fixture directly above the device.
 

This procedure uses the idvd_vg setup to measure drain current 
with respect to drain voltage, at several values of gate voltage. 
The drain voltage is swept from 0V to the upper limit of its 
normal operating range. This is an opportunity to take a first 
look at the device performance and explore its characteristics. 
This also lets you select the most appropriate measurement 
range for the main data acquisition and other measurements.

In addition, this is a quick way to verify that the device DC 
characteristics are good, before starting a complete data 
acquisition and model generation. The data from this 
measurement can also be used for later comparison with data 
predicted by the generated model. It is not necessary to do the 
preverification measurement every time you perform a model 
generation, especially if you are using a data sheet.
NOTE If you do not wish to preverify either the DC or S-parameter performance of 
the device, you can skip ahead to the section “Measuring and Extracting 
the Ideality Factor” on page 39.
Defining the DC Source/Monitor Instrument State

Follow the same process you used in the r_series measurement. 
Use the same settings. 
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Setting the idvd_vg Inputs

This procedure defines the input signals to be applied to the 
device under test for the DC preverification measurement. The 
actual settings you use will be dependent on the compliance 
limits for both the device and the SMUs/bias networks, and on 
the range of measurements you wish to take. Since this 
measurement is intended only to preverify the device, the 
values can be quite conservative and need not stress the device 
to the boundaries of its performance.

If you are measuring a series of devices of the same type and 
have already set the inputs, go directly to “Measuring and 
Plotting” on page 28. Otherwise, perform the following steps:

Select the idvd_vg setup.

Table 3 For the vd input

Set To

Mode V (voltage)

Compliance No greater than the maximum breakdown current value for 
the device.(You set compliance values to limit SMU output 
voltage or current and thus prevent damage to the device 
under test, as well as to the SMUs, bias networks, and 
probes if used. With a voltage input, compliance refers to 
current)

Sweep Type LIN (to provide a linear voltage sweep from start to stop 
voltage values)

range Start at 0.0

Stop at or below the upper limit of the device’s normal 
operating range

# of Points to a value sufficient to clearly display the results

Note: The Step Size is calculated automatically in software from the start/stop 
values and number of points
IC-CAP Nonlinear Devices Models Volume 2
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• The Unit names must conform to the names set in the 
Hardware window. Refer to the appropriate chapter as 
follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

They must also correspond with the actual SMU connections 
from the Agilent 4142. Since the source is grounded, only the 
drain and gate inputs need to be set.

Table 4 For the vg input

Set To

Mode V (voltage)

Compliance No greater than the maximum allowable gate current value 
(You set compliance values to limit SMU output voltage or 
current and thus prevent damage to the device under test, 
as well as to the SMUs, bias networks, and probes if used. 
With a voltage input, compliance refers to current)

Sweep Type LIN (to provide a linear voltage sweep from start to stop 
voltage values)

range Such that Start, Stop, and # of Points will yield three to five 
measured values (points), in a range from approximately 
Vgs=Vpinchoff to Vgs=0V.
Set Start at a value close to Vpinchoff, but not so close that 
the curve will be difficult to discern.
Set Stop to 0.
CAUTION Do not set the value of Vg high enough to damage the device.
• The default settings for the Outputs should not be changed.
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Measuring and Plotting

This procedure triggers the DC source/monitor measurement 
and monitors the results.
NOTE Before making the DC measurement, manually put the network analyzer in 
hold sweep mode by pressing STIMULUS > MENU > MORE > HOLD.
1 Select the Plots tab.

2 Select Display All (to the left of the setup window). Two plots 
are displayed.

3 Select the Measure/Simulate tab, then select Measure. When 
the measurement is complete, the Measuring light on the DC 
source/monitor goes out, the IC-CAP wristwatch icon goes 
away, and the measured data is displayed in the plot 
windows.

Figure 3 Example Measured pre_verify id_vd Data
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4 Check the id_vd plot. The data displayed should resemble 
Figure 3, with the lowest curve close to the X-axis to show 
the pinch-off characteristics. If the data indicates the device 
is not operating in its normal range, go back to the inputs and 
change the gate voltage values. (If more than one curve is low, 
change vg Start to a higher value. Or if all the curves are high, 
change vg Start to a lower value.) Then repeat the 
measurement. 

5 Check the ig_vd plot. The data should resemble the following 
figure, with smooth curves and no significant spikes present 
on the traces.

6 If the measured data looks wrong for your device, check the 
probe contacts, the bias connections, and the measuring 
instruments. Make sure the device is oriented properly, with 
the right ports connected to the right terminals. If none of 
these resolves the problem, the device may be defective. For 
example, if all the curves are superimposed, the gate may be 
shorted.

Figure 4 Example Measured pre_verify ig_vd Data
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7 You can save the measured data for later comparison with 
data predicted by the extracted model. To do so, select File > 
Save As and a filename with the suffix .set (for example 
dc_test.set). Then click OK.

8 Close the plots.
Calibrating the Network Analyzer
It is important to calibrate the network analyzer before you 
perform any S-parameter measurements. Good calibration of 
the network analyzer is critical to a good measurement and 
model generation. Without a good calibration, the model will be 
inaccurate.

The Agilent Root FET measurement procedure requires two 
network analyzer calibration sets, a swept broadband cal and a 
CW cal. The broadband cal is used for the S-parameter 
preverification measurement. The CW cal is used for the 
parasitics extraction and the main data acquisition. 

For a system with an Agilent 8510 network analyzer, this 
procedure uses the frequency list mode for both the broadband 
and CW calibrations. The two calibrations can be done with 
only one set of standards measurements, by making the CW cal 
a subset of the broadband cal. For a system with an Agilent 
8753 or 8720 network analyzer, two separate calibrations must 
be performed.

Frequency list calibration procedures for an Agilent 8510-based 
system and an Agilent 8753-based system are provided in the 
next few pages. A CW calibration subset procedure for an 
Agilent 8510-based system is also provided.

Calibration for an Agilent 8753-Based System

Although the Agilent 8753 and 8720 have frequency list 
capability, IC-CAP does not support the subset calibration 
technique used in an Agilent 8510 system. Therefore it is 
necessary to perform two separate calibrations for an Agilent 
8753- or 8720-based system: one frequency list cal and one CW 
cal. A separate set of standards measurements must be made 
for each calibration.
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Frequency List Mode

Frequency list lets you define an arbitrary list of frequencies in 
one or more segments. During the measurement sweep the 
synthesizer is phase-locked at each frequency point, as in the 
stepped-sweep mode. The advantage of frequency list mode for 
use in a table-based model such as this is that it lets you define 
a smaller number of measurement points than for a step or 
ramp frequency cal. This reduces the total measurement time. A 
# of Points of 11 provides adequate measurement resolution as 
well as a quite fast total measurement time.

For the purpose of this model you will define two frequency 
segments in the list, a broadband segment and a CW segment. 
Set the broadband frequency list segment range at least as wide 
as the operating range of the device.

Set the CW frequency segment to the frequency you intend to 
use for the data acquisition, the same frequency you set in the 
init_parameters macro at the beginning of this procedure. The 
frequency should be above 200 MHz to eliminate the effects of 
test set coupler roll-off at low frequencies, and low enough to 
eliminate bond inductances and other parasitic inductance 
considerations. 

Based on the broadband cal, use a calibrated measurement 
point equal to the start frequency plus an integer multiple of the 
step size: an example frequency might be 600 MHz.

200 MHz (start freq) + 1 ⋅ 400 MHz (step size) = 600 MHz

Frequency List Calibration for an Agilent 8510-Based System

If you are using an Agilent 8510-based system, follow the steps 
below.

1 On the network analyzer press PRESET.

2 To define a linear frequency list, on the network analyzer 
press  STIMULUS > MENU > MORE > EDIT LIST > ADD. A 
default frequency list segment is presented.

3 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
start frequency, ending with one of the terminator keys (such 
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as M/µ) at the right of the keypad. Similarly, press STOP and 
set the stop frequency.
NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys in the STIMULUS area of the front panel.
4 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range. Keep in 
mind that the fewer the number of points, the less time the 
measurements take.

5 Press DONE to return to the frequency list menu. The 
segment you just defined is listed on the screen.

6 Press DONE to return to the main stimulus menu. Press 
FREQUENCY LIST to activate the frequency list mode.

7 Press PRIOR MENU > MORE > CONTINUAL to set a continual 
stimulus sweep.

8 Press PRIOR MENU > POWER MENU, and set the desired 
power level. In setting the source power and attenuation, take 
care that the power level will not be excessive at the device 
input. Also consider the gain of the device, and set a power 
level that will not saturate the input port samplers of the 
analyzer. If the power level at the sampler goes above  
≈−8 dBm, an IF OVERLOAD error message is displayed and you 
will need to reduce the source output power. The default 
network analyzer power level is 0 dBm.

9 For a device with power drop-off at higher frequencies, you 
may wish to set a power slope using the stimulus menus. An 
appropriate power slope would be in the region of 
2-3 dB/GHz.

10 Press RESPONSE > MENU > AVERAGING ON/restart, and 
enter an averaging factor high enough to reduce trace noise 
and increase dynamic range as appropriate for your device 
measurements. Although the default is 256, you may wish to 
use an averaging factor as low as 16 to reduce overall 
measurement time.

11 If the cal kit constants for your calibration kit are not loaded 
into the network analyzer, load them from disc now by 
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pressing DISC > LOAD and specifying the data type and file 
name.

12 If you wish to modify one of the internal cal kit definitions 
(see Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”), do so now.

13 Press CAL > CAL1 or CAL2 (depending on your cal kit), and 
perform a two-port calibration, measuring each of the 
standard devices in turn and pressing the softkeys as each 
measurement is complete.

14 At the end of the calibration sequence, the cal set numbers 
are listed in the softkey menu. Press CAL SET #1 to store the 
calibration in cal set #1. (Or use another available cal set.)

CW Calibration Subset for an Agilent 8510-Based System

1 To create a CW frequency subset of the broadband frequency 
list calibration, press CAL > CORRECTION ON > CAL SET 1 
(this turns on the broadband cal you just completed), then 
MORE > MODIFY CAL SET > FREQUENCY SUBSET. Use the 
SUBSET: START and SUBSET: STOP softkeys in the SUBSET 
menu (NOT the front panel keys) to set both start and stop to 
the same frequency.

2 Press CREATE & SAVE, and store this calibration in cal set 
#2 or another available cal set.

3 Note the numbers of the cal sets where you save the 
calibrations: you will need to list one of these numbers as 
part of the instrument state for each of the network analyzer 
measurements.
NOTE For more detailed information, refer to the Agilent 8510 Operating and 
Programming Manual.
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Frequency List Calibration for an Agilent 8753-Based System

If you are using an Agilent 8753-based system, follow the steps 
below. 

1 On the network analyzer, press LOCAL to gain front panel 
control. Press PRESET to return to a known standard state.

2 If you are using a system with the 6 GHz receiver option and 
you wish to measure in the 3 GHz to 6 GHz range, press 
SYSTEM > FREQ RANGE 3GHz6GHz.

3 To define a linear frequency list, on the network analyzer 
press MENU > SWEEP TYPE MENU > EDIT LIST > CLEAR 
LIST > YES > ADD. A default frequency list segment is 
presented.

4 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
start frequency, ending with one of the terminator keys (such 
as M/m) at the right side of the keypad. Similarly, press STOP 
and set the stop frequency.
 

NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys on the front panel.
5 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range, then 
press the x1 terminator key. Keep in mind that the fewer the 
number of points, the less time the measurements take.

6 Press DONE to return to the edit list menu. The segment you 
just defined is listed on the screen.

7 Press DONE to return to the sweep type menu. Press LIST 
FREQ > SINGLE SEG SWEEP to activate the frequency list 
mode and set the analyzer to sweep the segment you defined.

8 Press RETURN > RETURN > TRIGGER MENU > 
CONTINUOUS to set a continuous stimulus sweep.

9 Press MENU > POWER and set the desired power level, then 
press the x1 terminator key. In setting the source power and 
attenuation, take care that the power level will not be 
excessive at the device input. Also consider the gain of the 
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device, and set a power level that will not saturate the input 
port samplers of the analyzer. If a receiver input is 
overloaded (>+14 dBm), the analyzer automatically reduces 
the output power of the source to −85 dBm and displays the 
error message OVERLOAD ON INPUT (R, A, B) POWER REDUCED. 
In addition, the annotation P↓  appears in the left margin of 
the display to indicate that the power trip function has been 
activated. When this occurs, reset the power to a lower level, 
then toggle the SOURCE/PWR on/off softkey to switch on the 
power again.

10 Press AVG > AVERAGING FACTOR, and enter an averaging 
factor high enough to reduce trace noise and increase 
dynamic range as appropriate for your device measurements. 
A good default averaging factor is 256. To speed your 
measurements, you may find it convenient to set an 
averaging factor as low as 16. Press AVERAGING ON.

11 You can further reduce the noise floor by reducing the 
receiver input bandwidth. Press IF BW in the average menu, 
and enter one of the following allowed values in Hz: 3000, 
1000, 300, 100, 30, or 10. A tenfold reduction in IF bandwidth 
lowers the measurement noise floor by about 10 dB; however, 
the sweep time may be slower. For more information on 
averaging and the different trace noise reduction techniques, 
refer to the Agilent 8753 operating manual.

12 Press CAL > CAL KIT, and select the appropriate default or 
user-defined cal kit for your calibration devices.

13 If you wish to modify an internal calibration kit definition 
(see Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”), do so now.

14 Press CAL > CALIBRATE MENU, and perform the calibration 
of your choice at the analyzer front panel, measuring each of 
the standard devices in turn and pressing the softkeys as 
each measurement is complete. A full two-port cal provides 
the greatest accuracy. A TRL* or LRM* cal is an appropriate 
alternative for in-fixture measurements (see Appendix C, 
“Using IC-CAP with an Agilent 85123A Device Modeling 
System”). Omit isolation cal. Press DONE, and save the cal in 
the register number specified in the instrument options 
table. 
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15 Detailed procedures for measurements of calibration 
standards are provided in the Agilent 8753 operating 
manual.

CW Calibration for an Agilent 8753-Based System

Refer to Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System” for a CW calibration procedure that 
can be used for a system with an Agilent 8753 or 8720 network 
analyzer.
Preverifying the Device S-Parameter (AC) Data
This procedure uses the s_vgvdf setup to measure S-parameters 
across a calibrated frequency range, with the drain bias voltage 
swept from 0V to the upper limit of the normal device operating 
range, and several values of gate bias. 

The procedure can be used as a quick check that the device 
performance is good at higher frequencies, before you do a 
complete data acquisition and model generation. It is not 
necessary to do the preverification every time you generate a 
model, especially if you are using data sheet values.
NOTE The frequency range and number of points set for the Input must 
correspond with the swept broadband calibration of the network analyzer, 
or the calibration will be invalid.
Defining the Instrument States

Select the Instrument Options tab and follow the steps described 
in the section “Instrument States for Swept Measurements” on 
page 598 (for an Agilent 8510-based system), with the 
exceptions noted below.

Because you used a frequency list cal rather than a swept 
frequency cal, note these differences:

• Be sure the instrument states you set for the network 
analyzer correspond with the values you set in your 
calibration.
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• Set Use Fast CW to No.

• Be sure to set the averaging factor the same as in your 
calibration.

• Set Cal Type (SHN) to H for hardware.

• Set Cal Set No to the cal set where you stored your 
broadband frequency list calibration.

• Set Use Linear List to Yes.

Setting the s_vgvdf Inputs

This procedure defines the input signals from both the DC 
source/monitor and the network analyzer for this measurement. 

Since this measurement is intended only to preverify the device, 
the values can be quite conservative and need not stress the 
device to the boundaries of its performance.

1 Select the s_vgvdf setup.

2 Set the vd Compliance no greater than the maximum 
breakdown current value for the device.

3 Set the vg Compliance no greater than the maximum 
allowable gate current value.

4 Set the vd range with a Start value of 0.0, and a Stop value ≤ 
the upper limit of the device’s normal operating range. For # 
of Points, 3 is sufficient to display the data while giving fast 
results. 

5 Set the vg range (Start, Stop, and # of Points) to measure at 
about three different bias points, in a range from 
approximately Vgs=Vpinchoff to Vgs=0V.

6 Set the freq Mode to F, Sweep Type to LIN, and Sweep Order 
to 1.

7 Set the freq Start and Stop values to correspond with the 
frequency range of the broadband frequency list calibration 
you performed.

8 Set the # of Points to correspond with the calibration.
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Measuring and Plotting
NOTE Before performing the S-parameter measurements, manually take the 
network analyzer out of hold sweep mode. Press STIMULUS > MENU > 
MORE > CONTINUAL on an Agilent 8510, or MENU > TRIGGER MENU > 
CONTINUOUS on an Agilent 8753, to initiate continuous sweep.
1 Select the Plots tab.

2 Select Display All. Two S-parameter plots are displayed.

3 Select Measure/Simulate > Measure. 

4 Check the S-parameter plots. The data displayed should be 
typical for your device. 

If the results are unexpected, recheck the values you set in 
the inputs and instrument options. In particular, be sure the 
instrument states and input stimulus signals match the 
values set in the network analyzer calibration.

If you change the inputs or instrument states, repeat the 
measurement. If the data still looks abnormal, the device may 
be defective and may need to be replaced with an acceptable 
one.

5 To save the measured data if you wish, select File > Save As, 
type in an appropriate filename (for example spar_test), and 
click OK.

If you are satisfied with the measured data for your device, 
continue with the procedures.
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It is necessary to extract the ideality factor (n) so that the 
model generator can use it to calculate and de-embed the gate 
diode resistance, Rg, where n is the coefficient that multiplies 
Vthermal in the ideal diode equation. The diode resistance is 
approximated by the equation:

where n is the ideality factor, Vth is Vthermal (0.025V at room 
temperature), and Ig is the gate current.

In this setup, the FET is configured with both the gate-source 
and gate-drain diode junctions strongly forward biased and 
intrinsic Vds=0. The drain current is set to exactly one-half the 
gate current, to force Is=Id, and the drain current is 
synchronized to the gate current. This makes the intrinsic Vds 
equal to zero, removing the channel resistance, and the device 
can thus be modeled as a T-network. The gate current is swept 
from zero to maximum, and Ig is measured as a function of Vg.

The inputs you set in the following procedure configure the FET 
as shown.

Figure 5 FET Bias Configuration for Ideality Measurement
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Defining the DC Source/Monitor Instrument State

Follow the same process you used in the r_series and idvd_vg 
measurements. Use the same settings.

Setting the ideality Inputs

Most of the input parameters for this measurement are factory 
preset and should not be changed. 

1 Select the ideality setup.

2 The voltage Compliance can be set quite high for both ig and 
id, because the current will be forced only up to the 
maximum gate current limits set in the init_parameters 
macro.

3 The ig Sweep Type must be set to LOG scale, to allow 
measurement of the inherently exponential distribution of 
points. 

4 The id Sweep Type must be set to SYNC, to synchronize the 
drain current to the gate current.

5 The purpose of the Start and Stop settings for ig is to force 
current from 0 amps to maximum, exercising the diode 
junction to include the region of its exponential behavior. 
Stop must be set to IFwd, which is the forward conducting 
gate current compliance. Start must be set equal to IFwd 
divided by some large number between 1000 and 100000.

When the ig Sweep Type is set to LOG, the input table 
automatically adds the fields Dec or Oct and Total Pts in 
place of Step Size.

6 Dec or Oct refers to a decade or octave log scale for the 
plotted data. The correct setting for this measurement is Dec.

7 To set the number of points, you can enter either a # of 
Points per decade, or a Total Pts across the sweep. 

When the id Sweep Type is set to SYNC, the input table 
automatically adds fields for Ratio, Offset, and Master Sweep.

8 The id Ratio must be set to -500.0m to make the drain 
current exactly -1/2 the gate current.

9 Offset must be set to 0.000.
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10 The id Master Sweep must be set to ig to synchronize Id to 
Ig.

11 The Outputs are factory set, and should not be changed.

Measuring, Extracting, and Interpreting the Results

This procedure makes the measurement and computes the 
ideality factor from the results. The procedure explains how to 
check the measured data and computed ideality, and override 
the computed value if appropriate.

1 Select the Plots tab. 

2 Select the n_vs_vg plot, and Display Plot.

3 Select Measure/Simulate > Measure. Check the plot of n 
(ideality) as a function of Vg. The displayed trace should 
resemble the following figure. Note that n is computed as the 
minimum value along the linear region of the logarithmically 
displayed curve, and should be a value between 1 and 2.

4 Select the Extract/Optimize tab.

5 Select compute_N > Execute. The transform calculates the 
ideality factor from the measured data, and puts the value 

Figure 6 Example n_vs_vg Ideality Plot
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into the extr_para DUT variable table. You can view the DUT 
variable table by selecting extr_para > DUT Variables.

6 You can check the ideality factor in the variable table against 
a measured value on the trace. Put the mouse pointer at a 
selected point on the linear portion of the trace, click the 
middle mouse button, and a readout of the Y-axis value at 
that point will be displayed. (Note that the linear region of 
the measurement is the region where the Rdiode equation 
given under “Measuring and Extracting the Ideality Factor” 
on page 39 applies.)

If the n_vs_vg plot looks significantly different from the 
illustration, it may be necessary to modify the transform or 
the computed value, as explained in the following steps.

7 If noise is present on the trace below the linear region of the 
curve, n may have been computed as the minimum value of 
the noise. In this case, go back to Inputs and change the ig 
Start value from IFwd/10000 to IFwd/1000 to start the 
measurement at a value of current above the noise level. 
Execute the compute_N transform again, observing the 
change in the plot and in the ideality value in the variable 
table.

8 If no measured linear region is shown on the trace, a good 
ideality factor cannot be computed from it. In this case, you 
will need to manually enter a value of 1 or 0 for ideality. (In 
the Rdiode equation, the nVth term is relatively small 
compared with Ig. If a good ideality factor cannot be 
computed, it is best to eliminate the contribution of the nVth 
term by using an n value of 0.)

9 To change the ideality factor in the variable table, move the 
mouse pointer over the value and click left to highlight it, 
then type in the new value. 

10 The illustration below is a typical ig_vs_vg Plot.
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Figure 7 Example ig_vs_vg Ideality Plot
Measuring and Extracting Parasitic R and L Values
 

This procedure performs an S-parameter measurement at a 
single CW frequency, with the FET in the same configuration as 
for the ideality measurement. Drain current is set to one half 
gate current, to force Is = Id = −1/2 Ig. This measurement is 
performed at the same CW frequency as the main data 
acquisition, using the same network analyzer CW calibration.

Figure 8 FET Bias Configuration for parasitics Measurement
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Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for Swept Measurements” on page 598 
(for an Agilent 8510-based system) in Appendix B, “Using 
IC-CAP with an Agilent 85122A Precision Modeling System”

• “Instrument States for Swept Frequency Measurements” on 
page 624 (Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Set the Cal Set No to the cal set or register where you saved your 
broadband calibration. The procedures in this manual use cal 
set #1.

Setting the parasitics Inputs

Most of the input values for this measurement are factory 
preset and should not be changed. 

1 Select the parasitics setup.

2 Set the voltage Compliance for both ig and id to any 
reasonable values. The values can be quite high because the 
current is limited by the forward conducting gate current 
value you set in the init_parameters macro.

3 The Sweep Type is set to CON (constant) for both ig and id.

4 The ig Value must be set to IFwd, (the forward conducting 
gate current value you set in the init_parameters macro).

5 The id Value must be set to -IFwd/2, to force Is = Id.

6 Under freq, the Mode must be set to F and the Sweep Type to 
LIN (linear).

7 Set the freq Start, Stop, and # of Points to correspond with 
the swept frequency calibration you performed.

Measuring and Extracting

1 In the parasitics setup select Measure.

2 When the measurement is complete, select the 
Extract/Optimize tab.
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3 Select extract_parasitics > Execute. The transform calculates 
the parasitic R and L values from the measured data.
Setting Up the Main Data Acquisition
 

This sets up the values for the main measurement procedure, 
which takes the data from which the model is generated. The 
procedure measures  S-parameters at a calibrated CW 
frequency, across a range of drain and gate bias voltages, with 
the gate forward biased and intrinsic Vds = 0. It takes adaptive 
measurements, densely spaced in the most nonlinear regions 
such as at the knees of the I-V curves and at the onset of 
breakdown, and less densely spaced in the linear saturation 
region. The number of data points measured depends on the 
nonlinear behavior of the device and on the measurement 
conditions you set up.

Some knowledge of the device characteristics is needed in order 
to enter valid parameters. The data you measured in the DC and 
S-parameter preverifications may be useful in determining 
appropriate values for your device. Do not exceed maximum 
allowable values. Perform the steps in the following paragraphs.

Once you have initiated the transform, the data acquisition 
procedure takes approximately 1 to 2 hours to run before your 
interaction is needed again. The data acquisition rate is 
approximately 700 points per hour.

Defining the Instrument States

The instrument states for the main data acquisition are set in 
the dc_bias and ac_bias setups.
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CAUTION Do not change the Inputs in the dc_bias, ac_bias, or create_mdl 
setups. Their function is not the same as in the other setups. They 
contain factory-set information essential to the program, and they 
must not be changed.
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1 Select the dc_bias setup.

2 Select the Instrument Options tab to display the DC 
source/monitor instrument states.

3 Set the Agilent 4142 instrument state the same as for the DC 
preverification. Refer to the appropriate chapter as follows:

• Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

4 Set Use User Sweep to No.

5 Select the ac_bias setup.

6 Set the instrument states the same as for the parasitics 
measurement, using the same network analyzer CW 
frequency calibration. 

7 Set Use User Sweep to Yes and Use Linear List to Yes.

8 Set the Cal Set No to the cal set where you stored your CW 
calibration.

Setting the data_acquisition Variables

You set the values that define the measurement and model 
generation in the data_acquisition and model_generator 
transforms in the create_mdl setup. Based on your information, 
IC-CAP characterizes the device within a subset range of the 
bias plane (Vd-Vg plane). This range is typically larger than the 
normal safe range for long-term DC device operation specified 
in the data sheet. In other words, the device is briefly pushed 
beyond its long-term normal DC operating range. This is 
required by the model for simulating large-signal AC and 
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transient pulsed operation, where the instantaneous voltages 
can temporarily exceed the boundaries of long-term safe DC 
operation.

1 Select the create_mdl setup.

2 Select the Extract/Optimize tab, and the create_mdl transforms 
are listed.

3 Select data_acquisition to display the table of variables used in 
the data acquisition transform (Figure 9).

4 Follow the steps below to enter variable values appropriate 
for your device. 

5 For Power level, enter the total maximum power dissipation 
value. Typically this should be 2 watts per mm of gate width 
for devices up to 1 mm.

6 For I_Brk, enter the reverse gate current breakdown value, 
typically 20 mA per mm of gate width.

7 For I_Fwd, enter the forward conducting gate current, 
typically 200 mA per mm of gate width.

Figure 9 Variables in the data_acquisition Transform
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8 The next four voltage values define hard limits to the 
measurement domain. The voltage values are set well beyond 
the normal device operating range to explore the device’s 
boundary response. If the values are set too conservatively, 
data will not be measured in the nonlinear areas of 
breakdown and maximum forward conduction. If this occurs 
in the measurement, return to this table and change the 
voltage values. Reduce the minimum values and increase the 
maximum values.

9 Min Vd should typically be slightly negative, to allow data to 
be taken slightly beyond the bounds of the model so that it 
possible to properly extrapolate beyond the data.

10 Max Vd should typically be slightly higher than any 
anticipated breakdown voltage.

11 Min Vg should typically be several volts lower than Vpinchoff.

12 Max Vg should typically be greater than the voltage required 
to achieve the maximum fundamental gate current.

13 For Min step, enter a value to define the step size between 
densely-spaced measurements.

14 For Max step, enter a value to define the measurement step 
size where you expect the data to be relatively linear and you 
do not need densely-spaced measurements.

15 For Vp, enter the gate pinch-off voltage where drain voltage = 
0V.

16 Delta defines a voltage range below Vpinchoff, where a high 
density of Vgs measurements is needed due to the nonlinear 
decrease in drain current at pinch-off. A typical value for 
Delta is 2 volts.

17 Vdiode defines a voltage above which high-density 
measurements are needed, because of nonlinearities caused 
by the increase of gate current in diode junction forward 
conduction mode. A typical value for Vdiode is between 0V 
and the diode junction turn-on voltage.

18 Eps (Epsilon) is used to predict the next point to be 
measured, and thus control automatic data acquisition step 
size. Increasing the value of epsilon decreases the sensitivity 
of the automatic data acquisition.
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19 For Noise thresh, enter a current threshold value for both 
drain current and gate current below which you do not need 
closely-spaced measurements. The automatic step-size 
algorithm is not used below the Noise thresh value, where 
measured currents are sampled at the maximum step size.

Do not make Noise thresh so small that it measures 
numerous points below pinch-off, wasting measurement time 
and storage capacity. On the other hand, do not make it too 
large. A typical value is 5.0x10-7 amps per mm.

20 For SMU Compl, enter the drain SMU maximum current 
compliance value in amps. This is the maximum output 
current capability of the Agilent 4142B plug-in 
source/monitor unit (SMU) supplying the drain terminal. In 
the example procedure, this is VD. For the Agilent 41420A 
high-power SMU, the compliance is 1A; for the Agilent 
41421B medium-power SMU, the compliance is 100 mA.
 

CAUTION Also be aware of the current ratings of your bias networks, and do not 
set current values beyond their specified maximum limits. It is quite 
possible to destroy the bias networks, and the probes, by applying 
current values beyond the specified limits. (The standard bias 
networks for the Agilent 85122A/85123A parameter extraction 
systems are rated at 0.5 amp.)
21 You can save the values in the data_acquisition transform. 
Choose File > Save As and select Transform as the File Type. 
Type an appropriate filename, and click OK. The file is saved 
with the suffix .xfm for transform.
Performing the Data Acquisition Measurement
This procedure performs the measurement you defined. Once 
you initiate the transform, the data acquisition takes 
approximately 1 to 2 hours to run before your interaction is 
needed again. The data acquisition rate is approximately 700 
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points per hour. The number of data points measured depends 
on the nonlinear behavior of the device and on the 
measurement conditions you set up.

1 In the create_mdl setup select the Extract/Optimize tab.

2 Select the data_acquisition transform, and Execute.
CAUTION Do not perform data acquisition more than once. This will write over 
the existing data, and will use more time and memory.
3 If you do attempt to perform data acquisition after the 
measurement has already been done, a dialog box will alert 
you that a measurement file exists. You then have several 
choices: If you do not need the data in the current file you 
can click OK or press Enter to overwrite it. Or you can abort 
your new measurement by selecting Cancel. Or if you wish to 
save the measured data and perform another data 
acquisition, go to a UNIX window, change directories if 
necessary, find the file Measured.data, and rename it with 
another appropriate name, then continue with the data 
acquisition.

Ignore this message if it occurs: CAUTION: CALSET X STATE MAY 
BE INVALID.

4 During the data acquisition, a running message in the Status 
window indicates the approximate percentage of completion.

5 When the process is complete, a message similar to the 
following is displayed:

INITIAL Extraction Results

Max_num = 66.00

Max_row = 49.00 

The numbers are part of the internal function of the 
program, and irrelevant in user interaction with the 
program. They are associated with the maximum number of 
points for a given Vgs, and the number of Vgs steps.
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The plots in the create_mdl setup provide graphical outputs of 
the data acquisition and model generation. For hardcopy 
output, black and white can be reversed for faster printing and 
easier reading on paper, as explained here.

If you wish to plot data from a previously stored data set, you 
will need to perform the steps explained under “To Plot an 
Earlier Data Acquisition,” on the next page. Otherwise, follow 
these steps.

Viewing and Printing the Plots

1 Select the plots tab.

2 Select the plot of your choice, and Display Plot.

3 You can augment the annotation of a plot by specifying 
header and footer labels you wish to print with the data. 
However, it is essential not to change the Y data input fields.

4 To change a plot’s annotation, go to the Header or Footer 
lines in the plot definition. You can type a label of your choice 
in the header or footer input field (right side of the definition 
table). Then select Options > Update Annotation, and your label 
is added to the plot.
NOTE Changing the Y Data n input fields can cause anomalies in the 
measurement and modeling results.
5 If you wish to exchange the black and white in a plot for 
better hardcopy quality, select Options from the plot menu, 
and Exchange Black_White from the pull-down menu. You can 
also change from colored traces to all black by selecting 
Options > Color. This is particularly useful if one of the traces 
is a light color such as yellow, which may not show well 
against a white background.

6 To get a hardcopy of a plot, from the plot menu select File > 
Print Setup. Enter the name of a printer and make any other 
changes to the printer/plotter setup you wish, then click OK.
olume 2 51



52

1 Agilent Root FET Model Generator
 

7 If you have your printer setup completed, select File > Print.

To Plot an Earlier Data Acquisition

If you wish to view data from a previously stored Agilent 
RootFET data acquisition, you will need to perform these 
additional steps to bring the data into this model file and 
display the plots.

1 From the IC-CAP main menu select File > Change Directory. 
Type in the pathname of the file where your data is stored, 
and click OK.

2 Select the create_mdl setup.

3 From the Plots tab, select the plot of your choice, and Display 
Plot. The displayed plot window will be blank and an error 
message will be displayed. This is not a problem. Click OK in 
the error message window and the error will be erased.

4 Now select Display Plot again, and the plotted data will be 
properly displayed. (The first time you selected Display Plot, 
an internal function re-initialized the data from the changed 
directory.)

The following figures illustrate the data measured by the 
data_acquisition transform for an example device.

• Id_vd plots the DC measurement of drain current Id as a 
function of Vds for different values of Vgs (Figure 10).
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If you are not satisfied with the bias range of the 
measurement, make the necessary changes to the values of 
Min Vd, Max Vd, Min Vg, and Max Vg.

• Ig_vd plots the DC measurement of gate current Ig as a 
function of Vds for different values of Vgs. The following 
figure illustrates an example of this data. The concentration 
of traces around Vgstart may be unfamiliar but is correct for 
the very strongly forward-biased conditions.

Figure 10 Example Id_vd Data
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• Y11i plots the imaginary data for Y11.

• Y12i plots the imaginary data for Y12.

• Y21r plots the real data for Y21.

• Y22r plots the real data for Y22.

• Vd_Vg plots the distribution of test data in the Vgs-Vds plane. 
It shows how the data is taken adaptively depending on the 
device nonlinearities. More test data is taken where the 
device characteristics change rapidly such as at the knees of 
the I-V curves and the onset of breakdown, and less in the 
linear saturation region. The following figure illustrates an 
example of this data.

Figure 11 Example Ig_vd Data
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If you are satisfied with the measured data for your device, 
proceed to the model generation. Be sure the limits of the 
measurement domain are adequate: the domain should extend 
beyond the normal operating range of the device. If the 
measured data does not show the limits of device behavior, you 
may wish to redefine the voltage ranges you set in the 
init_parameters macro, using values that are less conservative.

Figure 12 Example Vd_Vg Data
Generating the Model
This procedure calculates the model parameters from the 
measured data, and generates a corresponding model for the 
device. The model nonlinear functions are calculated by contour 
integration, therefore you must provide the program with a 
starting point for the contour integration.

If you are generating a model from a previously stored data set, 
perform the steps listed later in this procedure under “To 
Generate a Model Using Data from an Earlier Measurement.”
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Computing the Parasitics for the Model Generation

An earlier part of the procedure calculated the intrinsic 
parasitic resistances of the device and entered them in the file 
Para.data. Now this procedure updates the data and gives you 
the opportunity to override the calculated values and enter 
values of your own if you believe they are more appropriate.

1 Select the main DUT, and the DUT Variables tab. A variable 
table is displayed, showing current values for the intrinsic 
parasitic resistances and inductances, as well as other 
variable values. The figure on the next page illustrates the 
DUT variables table.

2 If you have reason to change any of the parasitic values, you 
can change them in this variable table. For example, if you 
have calculated the parasitic values by another method, such 
as from material measurements of by using a different 
algorithm, you may prefer to use those values.

3 Or based on the model generation results plotted later in the 
procedure, you may wish to return to this step and modify 
values, then perform the transforms again.

4 To change a parasitic value in the variable table, move the 
mouse pointer over the current entry and click left to 
highlight it, then type in a new value.

5 Do not change any of the other variable values in the table 
besides the R and L values. The other variables listed are 
internal functions necessary to the program, and can be 
ignored. Do not change them.

6 If you make any changes to the parasitic values in the table, 
do not execute the compute_parasitic transform.
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7 If you do not wish to make changes to the parasitic values in 
the table, select the compute_parasitic transform, and Execute. 
You will probably observe changes in the parasitic values in 
the table.

Figure 13 Variables Table in the main DUT
NOTE You can copy the variable table by selecting Detach to display it in a 
separate window. Resize the window and move it to a convenient place 
away from the central work area.
olume 2 57



58

1 Agilent Root FET Model Generator
 

Setting the Starting Point for Contour Integration
NOTE For the modeled nonlinear functions to be valid, contour integration must 
be done in the normal operating range of the device. Outside the range, the 
results will be very different and less accurate. The further from the 
operating range, the less accurate the model will be.
Use these guidelines to set the starting point of contour 
integration:

1 The starting point should be set at an intersect of Vd and Vg 
that is within the saturated class A operating range of the 
device, where drain voltage is beyond the knee and less than 
breakdown, and gate voltage is between zero and Vpinchoff.

2 If you know Vpinchoff and Vbreakdown, set:

• Vpinchoff < Vg_start < 0
and 
0 < Vd_start < Vbreakdown

or

• Vg_start = Vpinchoff/2
and 
Vd_start = Vbreakdown/2
NOTE To generate a good model, make sure sufficient data points are available 
around the Vg,Vd points chosen for the starting point of the contour 
integration. Before running the model generator, look at the Id_Vd plot 
under the create_mdl setup. Use data markers to see the discrete points at 
which data was taken. The values you choose for the Vg,Vd values for 
contour integration should be well within the data space over which data 
was taken. Note that this will be bias value at which the best fits are 
achieved for the Root Model.
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Setting the model_generator Variables

1 Select the create_mdl setup.

2 Select the Extract/Optimize tab to display the list of 
transforms.

3 Select model_generator to display the table of variables used in 
the model generator transform (see illustration).

4 In the variable table, click left on the vd_start value to 
highlight it, then type in an appropriate value for your device.

5 Similarly, set an appropriate vg_start value for your device.

6 Enter an appropriate value for t_dispersion. This is the 
dispersion time constant, and its default value is 1e−7 or 100 
nanoseconds, 100.0n. In most cases, t_dispersion is not a 
significant factor although it is used in the model generation 
calculations. However, in a case where you wish to add time 
dispersion effects, you can increase the value.

Executing the Model Generator Transform

1 Select model_generator > Execute to start generating the model 
for the device under test.

2 A dialog box asks you for an MDS file name. The standard file 
generated by the model is State.mds. This file can be used 
with both ADS and MDS. If you want to retain this filename 
click OK or you can define a different filename. 

Figure 14 Variables in the model_generator Transform
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NOTE If you plan to do a verification, retain the filename State.mds for now, as 
the verification process requires this filename. You will have another 
opportunity to change the filename after the verification process.
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The model generation takes a few seconds. When the model 
generation is complete, a message is displayed.

Generating a Model Using Data from an Earlier Measurement

If you wish to generate a model from a previously stored 
measurement, you will need to perform these additional steps 
to bring the data into this model file in the correct form.

1 From the IC-CAP main menu select File > Change Directory. 
Enter the path of the file where your data is stored, and 
press Return.

2 Select the create_mdl setup.

3 Select the Extract/Optimize tab.

4 Select the compute_parasitics transform, and Execute.

5 Now perform the standard procedures “Setting the Starting 
Point for Contour Integration” on page 58 and “Executing the 
Model Generator Transform” on page 59.
Plotting the Generated Data

NOTE To plot the data, note the extra steps described in “To Plot an Earlier Data 
Acquisition” on page 52.
In the create_mdl setup, the Idh, Qg and Qd plots show the 
calculated state function data generated by the 
model_generator transform.
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NOTE The modeled state function data will not be plotted unless the 
init_parameters macro has been executed (see the instructions near the 
beginning of this chapter). The icplotnotes file generated by the 
init_parameters macro provides the x-axis information needed to plot the 
modeled data. IC-CAP will display an error message if you have not 
executed the init_parameters macro.
IC-CAP Nonlinear Devices Models V
To view a specific plot:

Select the plot and click Display Plot.

• Idh plots the high-frequency drain current Id as a function of 
Vds for different values of Vgs.

• Qg is the distribution of charge current under the gate. 

• Qd is the distribution of charge current under the drain. 
Other Outputs of the Model Generation Process
 

The model generation process results in a number of different 
output files to be used for different purposes. These include the 
model file for MDS interface, data on various modeled 
parameters, measured device data, and files for internal use by 
the program.

Some files have default filenames assigned by the program. 
Others may be files you created during the procedure to save 
device-specific information. 
CAUTION In general, the files should NOT be modified, because changing them 
can cause problems that may invalidate the model. It is also important 
that you do not change the names of files created by the model 
generator, with the exception of State.mds.
The following list of files will be (or may be) created during the 
modeling process:
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• icplotnotes. This is the only file you can safely edit or add to. 
The program appends it as a label to any graphical outputs, 
to identify the device. It includes a device ID string and any 
additional information you choose to have added to graphs 
when they are plotted.

• icplotnumbers. This is an internal file used by the program 
to generate a graphical interface. It is related to the 
Max_num and Max_row messages that appear in the 
parasitics variable table of the main DUT and in the UNIX 
window at the end of the data acquisition. While these 
parameters are irrelevant to user interaction with the 
program, they are essential to its function, and they must 
appear on-screen. Do not change this file.

• Measured.data. This is the raw measured S-parameter data 
as a function of bias and frequency, produced by the 
create_mdl data acquisition process.

• Para.data. This is the S-parameter data with forward bias 
current used by the program to calculate parasitic resistance 
and inductance values.

• State.data. This file is used by the program in plotting 
nonlinear functions such as Qg and Idh. Do not change this 
file.

• State.mds. This is the model file used by the Agilent RF and 
Microwave Design System (MDS) in a circuit simulation. It is 
also used in verifying the model, and needs to retain the 
name State.mds in the verification process in order to 
maintain the MNS simulator link. However, since every 
Agilent RootFET model initially has this name, you change 
the name to identify the device, either when you initiate the 
transform to generate the model (if you are not performing a 
verification), or at a later time as described at the end of this 
chapter.

• Y.data. This file contains the Y-parameters as a function of 
bias, to examine through graphical interface. NO changes can 
be made to the Y.data file, except for adding header and 
footer labels as explained under “Plotting the Measured 
Data,” earlier.
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• dc_test.set (or some other name designated by you). If you 
decided to save it, this is the measured DC data generated in 
the DC preverification procedure.

• spar_test.set (or some other name designated by you). If you 
decided to save it, this is the measured S-parameter data 
generated in the  S-parameter (AC) preverification.
Verifying the Model DC Data
 

This procedure verifies the model DC data against the DC data 
measured in the idvd_vg setup, using the MNS simulator link.

Notes

• The simulator used must be MNS. If the SIMULATOR variable 
in the model variable table is set to another value, change it 
to mns.

• The name of the model file must be State.mds for the 
purposes of verification, to maintain the MNS simulator link.

1 Select the idvd_vg setup. Make sure the output Type is set to B 
for both measured and simulated data.

2 Select the Plots tab.

3 Select the id_vd plot, and Display Plot.

4 Under Measure/Simulate select Simulate.

5 Check that the simulated data (dotted line) and measured 
data agree.
Verifying the Model S-Parameter Data
This procedure verifies the model S-parameter data against the 
S-parameter data measured in the s_vgvdf setup, using the MNS 
simulator link.

Notes

• The simulator used must be MNS. If the SIMULATOR variable 
in the model variable table is set to another value, change it 
to mns.
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• The name of the model file must be State.mds for the 
purposes of verification, to maintain the MNS simulator link.

1 Select the s_vgvdf setup. Make sure the output Type is set to 
B.

2 Select the Plots tab. Select Display All to display both 
S-parameter plots.

3 Under Measure/Simulate select Simulate.

4 Check that the simulated data (dotted line) and measured 
data agree.
Storing Data and Using it with MDS 
Once you have developed your device model, you can store it in 
a file for future use. You can use it for circuit simulation in the 
Agilent RF and Microwave Design System, inserting it into 
circuits under design to emulate the characteristics of your 
device. It can be used to represent any device with the same 
geometry from the same process, or scaled to represent a 
different-sized device. It will predict the gain, power, gain 
compression, and harmonics performance of the device as a 
component in circuits you design using MDS. It will predict 
large-signal device operation over a range of bias points and 
loading conditions.

The file generated by the modeling process for interface with 
MDS is called State.mds. You need to change the name to one 
that will identify the device under test, since every Agilent Root 
FET model file is initially named State.mds.

If you chose not to perform a verification, you may already have 
changed the filename using the dialog box presented before the 
model_generator transform. If not, you can change the filename 
now in UNIX and store the file as follows:

Storing the Model

1 Use the UNIX directory you created at the beginning of the 
procedure, when you first opened the model file.

2 From the IC-CAP/Main window select File > Save As.
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3 A dialog box is displayed. Select the File Type (.mdl for a 
complete model) by clicking the corresponding radio button.

4 Select a new filename that associates this model with the 
device. 

5 Use the UNIX copy (cp) or move (mv) command to copy the 
file State.mds to the new filename, including the pathname of 
the designated directory. Click OK.

This completes the example Agilent Root FET measurement and 
model generation procedure. For an explanation of how to use 
IC-CAP model data in MDS, refer to Appendix D, “Using IC-CAP 
Data with MDS.”
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12 Direct Extraction Of GaAs Mesfet Intrinsic Element And 
Parasitic Inductance Values. Eric Arnold, Michael Golio, 
Monte Miller, and Bill Beckwith, Motorola Inc., Strategic 
Electronic Division, Chandler, AZ. IEEE MTT-S Digest, 1990.

13 A New Method for Determining the FET Small-Signal 
Equivalent Circuit. Gilles Dambrine, Alain Cappy, Frederic 
Heliodore, and Edouard Playez. IEEE Transactions on 
Microwave Theory and Techniques, Vol. 36, No. 7, July 1998.

(Additional references are listed in the bibliography at the end 
of some of these publications.) 
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2
High-Frequency FET (Curtice) Models

Getting Started in IC-CAP 71

Using the Curtice Cubic Model 73

This chapter documents the Agilent 85192A high-frequency FET 
modeling software which includes three models:

• Curtice quadratic

• Curtice cubic

• Statz (Raytheon)

While these models are well known for use with DC and 
low-frequency devices, the extraction methodology used here is 
specific to high-frequency devices. The measurement and 
extraction software and procedures have been developed to 
ensure accurate modeling results that are constant, rather than 
a function of frequency. 

The example procedures here focus on the Curtice cubic model. 
Some differences between the Curtice cubic and Curtice 
quadratic models are documented in the IC-CAP Reference 
manual.

The software performs a series of DC and S-parameter 
measurements, based on predefined measurement 
configurations and on variables you define during the 
procedures. The measured values are then used to extract 
individual device parameters, through software conversion of 
the S-parameters to admittance or impedance parameters. The 
resulting model can be used to simulate the performance of any 
similar device in a circuit under design. Its data files can be 
read directly into datasets in the Agilent RF and Microwave 
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Design System (MDS). The model can also be used as a standard 
for quantitative performance measures in process and material 
control.
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The procedures in this chapter assume the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename a medium-power SMU connected to the device gate 
as VG

Rename a high-power SMU connected to the device drain as 
VD

Rename the GNDU unit (which must be connected to the 
source) as GND.
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on launching the IC-CAP software and opening the model file 
you need. The Curtice FET model file is under: 

/examples/model_files/mesfet/CGaashf.mdl

Then return to this chapter and continue with the procedures 
here.

Before you continue with the IC-CAP procedures, make a new 
directory in an appropriate location in the UNIX structure, 
using the mkdir command, to store the data and model files that 
will be generated. Give the directory a name that will associate 
it with the devices you are going to model. Use the cd command 
to change to the new directory in UNIX.
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This chapter provides example procedures that take you 
step-by-step through a FET measurement and parameter 
extraction. The procedures are arranged in the most logical 
sequence to allow earlier measured data or extracted 
parameters to be used as a basis for later measurements or 
extractions.

The device used in this example was a GaAs MESFET, and its 
data sheet was used for information on device characteristics 
and compliance values. Values you use in your own parameter 
extraction procedures will depend on the particular 
characteristics of your device: use its data sheet (if available) as 
a reference.

This example is provided as a starting point. It is a set of 
straightforward procedures that use only a subset of IC-CAP’s 
total capabilities. The complete procedures documented give all 
the steps necessary to set up and perform the measurements 
and extract device parameters from the resulting data. Once the 
measurement setups have been defined, they can be used for 
measurement and extraction of any device of the same type and 
geometry. The modeling procedure then becomes more simple, 
and can be accomplished in a few steps.

The procedures use a series of different setups to measure 
current or voltage vs bias under different bias conditions. The 
purpose of the different measurement setups is to decouple the 
model equations as much as possible and effectively isolate the 
individual FET parameters.
NOTE Although you will modify the variable values in factory default files during 
this procedure, do not under any circumstances change the names of any 
variables or setups. These names are used by the software in the 
parameter extraction process.

NOTE These example procedures assume that in-fixture measurements are 
made with the FET under test mounted in the fixture in a common-source 
configuration.
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The procedures in this chapter include detailed instructions for 
the following:

• Setting the input parameters for each measurement.

• Making the DC and S-parameter measurements: qualifying 
the results.

• Extracting the individual model parameters.

• Verifying the extraction results against the measured data.

• Storing the model and individual parameters.

Where necessary, other chapters are cross-referenced at 
appropriate points in the procedures, so that all system 
hardware setups and calibrations are performed at the right 
times.
 

NOTE Measurement parameters and measured data are specific to individual 
devices. Information and data are provided here as examples and 
guidelines, and are not intended to represent the only correct method or 
results.
The procedures start with example values for IC-CAP 
measurement inputs. They provide guidelines on setting the 
values to measure your device. However, the values you use will 
be based on your knowledge of your device and on information 
provided in its data sheet as well as on the guidelines provided 
here: they may or may not correspond with the examples. In 
some cases, it may be necessary to set the input values, make a 
measurement, and then reset the inputs based on the 
measurement results. The procedures give suggestions on 
judging the applicability of the input values and measured data.

The illustrations of plotted data are provided as visual examples 
of possible measurement results. They are not intended to 
represent a sequential measurement of one device, nor do they 
necessarily correspond with the example measurement inputs 
described in the procedures. The plots can be used to check the 
reasonableness of your own measured data, which should 
appear similar in shape but not necessarily coincident in values.
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In addition, the IC-CAP software itself includes measured data 
for some of the setups. This data is from the measurement of a 
single device, and shows another example of possible results. 
Many, though not all, of the input settings for this measurement 
correspond with the example settings. In looking for 
information on preferred values, or on how the measured data 
should look, refer to the manual as a guide.
The DUTs and Setups
 

The DUT/Setup panel is the central access point for the 
measurement and extraction procedures. The DUTs (for 
example DC), indicated by the inverted triangles, are groupings 
of similar measurement setups used to extract related model 
parameters. The setups contain the information used to define 
the inputs and outputs for each measurement, as well as their 
measurement hardware configurations and their associated 
transforms and plots.

Figure 15 The CGaashf DUT/Setup Panel
Making the DC Measurements
The DC measurement procedures measure DC current or 
voltage vs bias under different bias conditions. Setting up the 
measurement conditions involves two main processes for each 
measurement setup: defining the instrument state for the DC 
source/monitor, and setting the input values for the device 
measurement.
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Leave the network analyzer disconnected from the bias 
networks while you perform the DC measurements, with the RF 
IN connectors of the bias networks terminated to prevent 
possible bias oscillation.

Defining the Instrument States

For each of the measurement setups, it is necessary to define 
the instrument states (options) for the measurement 
instruments that will be used in that setup. The instrument 
states need to be defined individually for each setup. Different 
setups use different measurement instruments. However, with 
minor exceptions that will be explained, the instrument states 
for the same measurement type must be used for all the setups 
that use that measurement type.

1 After you have selected a setup, for example idvd_vg, the 
setup window tabs are displayed.

2 Select the Instrument Options tab, and a window is displayed 
showing the instrument states for all instruments used in 
that measurement. In the DC measurement setups, the 
instrument states for the DC source/monitor are displayed. 
In the S-parameter measurement setups, the instrument 
states for both the DC source/monitor and the network 
analyzer are displayed.

The instrument state settings are explained in this chapter with 
their corresponding setups.

Measuring the Characteristic Curves (idvd_vg)

This procedure measures drain current with respect to drain 
voltage, at several values of gate voltage. The drain voltage is 
swept from 0V to the upper limit of its normal operating range. 

FET Configuration: The input values you set in the following 
procedure configure the FET as shown in the following figure.
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Parameters to Be Extracted

This procedure is done first to determine whether or not the 
device is good. The data from this measurement will be used to 
extract beta2 and gamma2, the Curtice Cubic parameters that 
control the linear and saturation regions of device operation. 
RDS0 (intrinsic output resistance) is also extracted from this 
measurement through optimization. (In a Curtice quadratic 
model, this data would be used to extract the beta, gamma, and 
alpha coefficients.)

This data can also be used for later comparison with predicted 
data provided by the extracted model.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Then return to this chapter and continue.

Figure 16 FET Bias Configuration for idvd_vg Measurement
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Setting the idvd_vg Input Values

This procedure defines the input signals to be applied to the 
device under test for this measurement. The actual settings you 
use will be dependent on the compliance limits for both the 
device and the SMUs/bias networks, and on the range of 
measurements you want to take.

If you are measuring a series of devices of the same type and 
have already set the input values, go directly to the section 
“Measuring and Plotting” on page 80. Otherwise, select the 
idvd_vg setup (from the DC DUT) and use the following 
instructions as a starting point to set up the measurement for 
your particular device. Refer to your device data sheet as 
needed for specifications and compliances.

Table 5 For the vd input

Set To

Mode V (voltage)

Compliance no greater than the maximum breakdown current value in 
the device data sheet. With a voltage input, compliance 
refers to current. Compliance values limit SMU output 
voltage or current and prevent damage to the device under 
test, as well as to the SMUs, bias networks, and probes if 
used.

Sweep Type LIN to provide a linear voltage sweep from start to stop 
voltage values

Start 0.0 

Stop Referring to the data sheet for your device, set the Stop 
value ≤ the upper limit of the device’s normal operating 
range.

# of Points Set the # of Points to 21 or less.

The Step Size is calculated automatically in software from the start/stop values 
and number of points. (Alternatively you can set the Step Size and the # of 
Points is calculated automatically.) Note, however, that the step size must be an 
integer multiple of the minimum step size of the SMU (refer to the Agilent 4142 
Operation Manual for the SMU specifications).
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Table 6 For the vg input

Set To

Mode V (voltage)

Compliance no greater than the maximum allowable gate current value 
in the data sheet. With a voltage input, compliance refers to 
current. Compliance values limit SMU output voltage or 
current and prevent damage to the device under test, as 
well as to the SMUs, bias networks, and probes if used.

Sweep Type LIN to provide a linear voltage sweep from start to stop 
voltage values

Start, Stop, and # 
of Points

Set such that three to five values (points) will be measured, 
in a range from approximately Vgs=Vpinchoff to Vgs=0V. 
Set Start to a value close to Vpinchoff, but not so close that 
the curve will be difficult to discern. (Since the data sheet is 
likely to provide a range of values, these settings may need 
to be changed after the first measurement.)
 
CAUTION In setting vg, be careful not to set gate voltage values high enough to 
damage the device.
• The Outputs are factory set, and should not be changed, with 
the exception of Type. This is the type of data to be plotted, M 
for measured, S for simulated, or B for both. There is a 
tradeoff in making this choice: if the measurement will be a 
slow one because of long integration time or large number of 
points, you can save time by setting Type to M. If the 
measurement will be fast, you can save the need to change 
the plot Type later during extraction by setting B. Set it to M 
for now, to save time in plotting the measured values.

• The Unit names must conform to the names set in the 
hardware window. Refer to the appropriate chapter as 
follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”
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• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

They must also correspond with the actual plug-in SMU 
connections from the Agilent 4142. Set the vd Unit to VD and 
the vg Unit to VG. Since the source is grounded, only the 
drain and gate inputs need to be set.

Measuring and Plotting

This procedure triggers the device measurement, controlling the 
DC source/monitor to supply the signals you defined in the 
instrument options and the inputs, and monitors the results.
NOTE Remove any high-intensity light sources such as microscope light before 
taking a measurement. One simple method of blocking light is to place an 
opaque plastic box on the fixture directly above the device.
1 From the idvd_vg setup select the Plots tab.

2 Select the id_vs_vd plot, and Display Plot.

3 If you have not already connected the DUT, do so now. 
Observe antistatic precautions.

4 Select Measure/Simulate > Measure. Do not touch the fixture 
or the bias networks while the system is measuring. When 
the measurement is complete, the yellow MEASURING light 
on the DC source/monitor goes out, the IC-CAP wristwatch 
icon goes away, and the measured data is displayed in the 
plot window.

5 The plotted data should resemble the following figure, with 
the lowest curve close to the X-axis to show the pinchoff 
characteristics. If the data indicates the device is not 
operating in its normal range, you may need to change the 
gate voltage values you set in the inputs. (If more than one 
curve is low, change vg Start to a higher value. Or if all the 
curves are high, change vg Start to a lower value.) Then select 
Measure again.
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6 If the measured data looks wrong for your device, check the 
probe contacts, the bias connections, and the measuring 
instruments. Make sure the device is oriented properly, with 
the right ports connected to the right terminals. If none of 
these resolves the problem, the device may be defective. For 
example, if all the curves are superimposed, the gate may be 
shorted.

7 If you wish, you can save the measured data for later 
comparison with data predicted by the extracted model. To 
do so, from the Main window, select File > Save As. Use the 
File Type suffix .set. Enter an appropriate filename (for 
example dc_test), and press Return or click OK to save the 
file.

8 Close the plot.

Figure 17 Example idvd_vg Measurement of FET Characteristic Curves
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Measuring Drain Current vs Gate Voltage (idvg_vd)

This procedure measures drain current as a function of swept 
gate voltage, at a single drain voltage bias point in the typical 
operating range of the device. Values of gate voltage are selected 
to take the device from pinchoff to IDSS.

FET Configuration: The input values you set in the following 
procedure configure the FET as shown in the following figure.

Parameters to Be Extracted

This is a very important measurement, because the A 
coefficients will be determined from it. The A coefficients form 
the core of a Curtice cubic model, and therefore must be 
carefully extracted. Poor measurement and extraction can 
result in a device model in which the DC performance appears 
reasonable while the AC performance, specifically S21, is 
suspect.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

Figure 18 FET Bias Configuration for idvg_vd Measurement
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• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings for the idvg_vd setup as you did for the 
idvd_vg, except set Integ Time to L (long) for maximum 
averaging, because this measurement uses a derivative process. 
Note: The instrument states need to be set independently for 
each setup.

Then return to this chapter and continue.

Setting the idvg_vd Input Values

Select the idvg_vd setup and use these guidelines for setting the 
vd and vg inputs.

Table 7 For the vd input

Set To

Sweep Type CON (constant) to provide a constant voltage at one bias 
value

Value at or near the typical operating region of the device.

Table 8 For the vg input

Set To

Sweep Type LIN (linear)

Start and Stop Set such that the gate voltage takes the device from 
pinchoff to IDSS. It is best to set a start value below 0.0V to 
avoid contaminating lesser values of drain current with the 
heat generated at IDSS. The Curtice model does not 
compensate for heating effects, which would cause a 
downslope in the measured data at the higher values of 
drain current. 

# of Points Set fairly large (>100) to ensure an adequate set of 
measurements across the voltage range.
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Measuring and Plotting

1 From the Plots tab, select the id_vs_vg plot, and Display Plot.

2 Select Measure/Simulate > Measure. The plot will be updated 
with the measured data, which should resemble the following 
illustration. Typically Id increases parabolically with the 
increase in Vg. If not, there may be a problem with the device.

3 Save the data using File > Save As and a filename with the 
suffix .set.

4 Close the plot.

Measuring Ideality 

This setup forces the FET into a forward-biased diode 
configuration (gate-source junction), by applying a swept 
voltage at the gate and opening the drain. Gate-source current is 
measured as the gate voltage is swept. 

FET Configuration: The input values you set in the following 
ideality procedure configure the FET as shown in the following 
figure.

Figure 19 Example idvg_vd Measured Data
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Parameters

The data from this DC measurement will be used to extract the 
diode parameters VBI (built-in voltage), IS (junction saturation 
current), and N (ideality factor).

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings for ideality that you did for the idvg_vd 
setup, and set Integ Time to L (long).

Then return to this chapter and continue.

Figure 20 FET Bias Configuration for the Ideality Measurement
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olume 2 85



86

2 High-Frequency FET (Curtice) Models
 

Setting the ideality Input Values
CAUTION Since the gate-source junction is forward-biased in this configuration, 
be particularly careful in setting compliance values.
Select the ideality setup and use these guidelines for setting the 
vg and id inputs.

Table 9 For the id input

Set To

Mode I

Value 0.0 to float the drain

Sweep Type CON (constant)

Compliance In current mode, compliance refers to voltage. If the device 
data sheet specifies a maximum drain voltage, use that 
value for Compliance.

Table 10 For the vg input

Set To

Compliance a good rule of thumb is to use 0.1 mA gate current per 
micron of gate width (for example 50 mA for a 500 um 
device). Allowing too high a current compliance can 
overstress the device and degrade its performance, even 
though the results may not be obvious.

Sweep Type LIN (linear) for a swept voltage from Start to Stop values
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Measuring and Plotting

1 From the Plots tab, select the ig_vs_vg plot, and Display Plot.

Start and Stop Start with conservative values for gate voltage to prevent 
possible damage to the device. They can quickly be 
changed after the first measurement if necessary. The FET 
data sheet is unlikely to specify diode characteristics, so 
start with best-guess values. Begin by setting a vg Stop 
value of 500.0m, and increase it if appropriate until the 
measured data shows the characteristics explained under 
“Measuring and Plotting” on page 87 (The increase must be 
an integer multiple of the SMU step size.) A typical gate 
voltage range is from 100 mV to 800 mV.

# of points Use a large enough # of points to ensure distribution of 
measurements across the exponential region of the diode 
characteristics.

Figure 21 Example Measured ideality Data

Table 10 For the vg input

Set To
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2 Select Measure/Simulate > Measure. The plotted data should 
be similar to the illustration. (Note that Ig is plotted on a log 
scale to show the exponential behavior of the diode junction.) 
The current should be very low at the low end, and the curve 
should bend at the high end where the parasitic gate and 
drain resistances are having an effect. The trace should be 
smooth and noise-free if a long integration time was used. 
Noise at the low end occurs if a shorter integration time is 
used.

3 The bend at the high end of the curve defines where the 
parasitics start dominating, and sets the bounds for 
extraction. If the displayed data does not show this bend, go 
back to the inputs and increase the Vg Stop value slightly 
(perhaps by 100 mV). Repeat the measurement. Iterate as 
necessary, gradually increasing Vg Stop until the bend in the 
trace does appear.

4 The other plot is used later, in the extraction process.

5 Close the plot.

Measuring Breakdown Characteristics (Optional)

Breakdown is not normally a factor in small-signal device 
operation, typically only occurring if the device is driven hard. 
The usefulness of this measurement is limited, since the model’s 
extraction of VBR (breakdown voltage) defines a hard 
breakdown point, while MESFETs typically have a soft 
breakdown characteristic. However, breakdown is one source of 
nonlinearity, so you may want to measure and model it. Be 
aware, however, that it may cause prediction of false harmonic 
values when the model is used in a simulation.

In this measurement, the source is open and the drain 
grounded. The gate current is monitored as gate voltage is 
swept from a positive voltage in the saturation region to a 
negative voltage beyond the expected reverse breakdown point. 
If you have a standard system with two SMUs, either disconnect 
the GNDU SMU from the source and leave it open, or reverse the 
source and drain connections (GNDU at the drain and SMU2 at 
the source). 
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings for breakdown as you did for ideality. 
Integ Time can be set to M (medium).

Then return to this chapter and continue.

Setting the breakdown Input Values

Select the breakdown setup and use these guidelines for setting 
the vg and vd inputs.

Figure 22 FET Bias Configuration for breakdown Measurement

Table 11 For the vg input

Set To

Compliance Set a small value to prevent damage to the device in the 
reverse breakdown region. 500A is appropriate
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Measuring and Plotting

1 From the Plots tab, select the ig_vg plot, and Display Plot.

2 Select Measure/Simulate > Measure. The measured data 
should be similar to that shown in the following figure. VBR 
(breakdown voltage) is the gate voltage Vg value at which 
gate current Ig stops increasing.

Sweep Type LIN for a linear voltage sweep from Start to Stop

Start a positive value in the saturation region

Stop a negative voltage beyond the expected reverse breakdown 
point

Table 12 For the vd input

Set To

Compliance small

Sweep Type If you disconnected the source and left it open, set Sweep 
Type to CON (constant), with a value of 0.0. (Alternatively, 
connect the GNDU SMU to the drain.) 

Table 11 For the vg input

Set To
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3 Close the plot.

Figure 23 Example breakdown Measurement Data
Calibrating the Network Analyzer
It is important to calibrate the network analyzer before you 
perform the S-parameter measurements. Good calibration of 
the network analyzer is critical to a good measurement and 
extraction.

For this procedure, the network analyzer must be calibrated 
over a broadband frequency range at least equal to the 
operating range of the device. No subset calibration is required.

For step-by-step calibration procedures, refer to the 
appropriate chapter as follows:

• “Calibrating the Network Analyzer” on page 589 (if you have 
an Agilent 8510-based system) in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• “Calibrating the Network Analyzer” on page 631 (if you have 
an Agilent 8753-based system) in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”
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Then return to this chapter and continue.
Making the S-Parameter Measurements

NOTE IC-CAP requires values to be entered into the software regarding 
calibrations, instrument states, and measurement values. It is important 
that values entered in software correspond with actual instrument 
settings.
The swept S-parameter measurements in the next two setups 
provide the data that allows extraction of parameters related 
specifically to the high-frequency performance of the device. A 
swept-frequency signal is applied to the gate, and the device 
S-parameters are measured at the drain.

Setting up the measurement conditions involves processes 
similar to those for the DC measurements: defining the 
instrument states and setting the input values for each 
measurement.

Measuring S-Parameters vs Frequency

This procedure measures S-parameters across a calibrated 
microwave frequency range, with a fixed bias value in the 
typical linear operating region of the device. 

FET Configuration: The input values you set in the following 
s_vs_f procedure configure the FET as shown in the following 
figure.
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Parameters

The data from this measurement will be used to extract RIN, 
RDG, CDGN, RDGN, CDG, CGS0, A5, and RC.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for Swept Measurements” on page 598 
(for an Agilent 8510-based system) in Appendix B, “Using 
IC-CAP with an Agilent 85122A Precision Modeling System”

• “Instrument States for Swept Frequency Measurements” on 
page 624 (Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Set the Cal Set No to the cal set or register where you stored the 
broadband calibration you performed earlier. The procedures in 
this manual use cal set #1.

Then return to this chapter and continue.

Setting the s_vs_f Input Values

Connect the network analyzer RF input cables to the RF IN 
ports of the bias networks and select the s_vs_f setup. 

Figure 24 FET Bias Configuration for the s_vs_f Measurement
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• The Outputs are factory set, and should not be changed, 
except for Type. To reduce time in plotting all four 
S-parameters, you can set Type to M (medium) for now.

Table 13 For the freq input

Set To

Mode F

Sweep Type LIN (linear) for a linear measurement sweep across the 
frequency range.

Sweep Order 1

Start, Stop Set the Start and Stop values to correspond with the 
frequency you defined in your broadband calibration. 

# of Points The same as in the calibration.

Table 14 For the vd input

Set To

Mode F

Sweep Type CON (constant), to provide fixed bias values of both gate 
and drain voltage

Compliance no greater than the maximum breakdown current value in 
the device data sheet

Value bias the device in a typical linear operating region of the 
device

Table 15 For the vg input

Set To

Compliance no greater than the maximum allowable gate current value

Sweep Type CON (constant), to provide fixed bias values of both gate 
and drain voltage

Value bias the device in a typical linear operating region of the 
device
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Measuring and Plotting

1 Select Plots > Display All. This displays all the plots at the 
same time. Alternatively, you can display them one-by-one 
using the method explained in the other measurement 
procedures.

2 Select Measure/Simulate > Measure. The plotted data should 
be typical for your device. The illustrations below show 
measured S-parameter data for an example device. If the 
results are unexpected, recheck the values you set in the 
inputs and instrument options. In particular, be sure the 
instrument states and input stimulus signals match the 
values set in the network analyzer calibration. 

3 If you change the inputs or instrument states, repeat the 
measurement. If the data still looks abnormal, the device may 
be defective.

4 Save the measured data using File > Save As and a filename 
with the suffix .set.

5 Close the plots.

Measuring Parasitic Resistances and Inductances

This procedure uses S-parameter measurements to determine 
the device parasitic resistance and inductance values. It 
measures S-parameters vs frequency, with both the gate-source 
and gate-drain junctions strongly forward biased, and fixed 
values of gate and drain current. Drain current is set to one half 
gate current, to force Is = Id: this makes the intrinsic Vds zero, 
removing the channel resistance. The device can thus be 
modeled as a T-network.

FET Configuration: The input values you set in the following 
parasitics procedure configure the FET as shown in the 
following figure.
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This measurement is done last because of the high gate current 
applied to the device. However, this high current should not be a 
problem because the power dissipation is not correspondingly 
high with Vds forced to zero. Theoretically, if the parasitic 
resistance were large enough for heat to be generated, the 
device could be damaged, but this situation is highly unlikely.

Parameters

The data from this measurement will be used to extract all the 
parasitic resistance and inductance values: RG, RD, RS, LG, LD, 
and LS.

Defining the Instrument States

Follow the same procedure you used in the s_vs_f measurement. 
Use the same settings.

Setting the parasitics Input Values

1 Select the parasitics setup.

2 Set the input values under freq the same as for the s_vs_f 
measurement, as you will be using the same network 
analyzer calibration.

3 Set the id Compliance as high as the device maximum Vds 
value or higher. The voltage compliance should not be so low 
as to inhibit current flow in this measurement.

Figure 25 FET Bias Configuration for parasitics Measurement
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4 Set the ig Compliance as high as the device maximum Vgs 
value or higher.

5 Set the Sweep Type to CONstant for both id and ig to provide 
fixed current values.

6 Set the id current Value to ID and the ig Value to IG. 
Numerical values are assigned to these variables as follows:

• To ensure that the Is = Id = Ig/2 relationship is 
maintained, the ratio between gate current and drain 
current is defined in the setup variable table. This allows 
the gate current to be set to a numerical value and the 
drain current to be specified with respect to the gate 
current.

• Select the Setup Variables tab. A variable table is displayed 
where you can define Ig and Id.

• Set the IG current value based on gate width: 0.1 to 0.2 mA 
per micron. Thus for a device with 500 um gate width, Ig 
would be 100 mA. This may seem like a lot of gate current, 
but the larger Ig is, the smaller the dynamic impedance 
becomes.

• Set the ID current to −IG/2, to force Is = Id.

Measuring and Plotting

1 From the Plots tab, select the R_data plot, and Display Plot.

2 Select Measure/Simulate > Measure.

3 To make sure the SMUs did not compliance-limit during this 
measurement, check the UNIX window for an error message 
to that effect. If the SMUs did reach compliance limit, the 
current may not have been balanced in the drain and source, 
which will cause misleading extraction results. In this case, 
go back to the inputs and increase the ig and id Compliance 
values by as much as 10 to 20%.

4 The measured data should resemble the following 
illustration. The annotation shows the resistance data as the 
real part of the device impedance Z. The displayed traces are 
the measured values for Rs, Rd, and Rg.
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5 Select the L_data plot, and Display Plot. The plotted data 
should resemble the illustration. The annotation shows the 
inductance data as the imaginary part of the device 
impedance Z. The displayed traces are the measured values 
for Ld, Lg, and Ls.

Figure 26 Example Parasitic Resistances
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6 Leave the parasitics setup open, as it is the first setup used in 
the extraction process.

Figure 27 Example Parasitic Inductances
Parameter Extraction
Now that all the measurements have been made, the extraction 
process can begin. There is no single clear and exact procedure 
for extracting parameters: the process is very iterative and 
subjective. The goal is to create a list of device parameters that 
can be used in a model to accurately predict performance. A key 
to success is that the parameters must be realistic. Because of 
the inherent coupling of the model equations, a variety of 
parameter value combinations will result in a good match 
between simulated and measured data.

The specific measurement setups are defined for the purpose of 
decoupling the model equations as much as possible. In this 
way, the effects of individual parameters or small groups of 
related parameters can be isolated, and their values determined 
with reasonable certainty. However, no matter how good the 
measurement setup, there is always some interaction between 
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parameters. Therefore, during the extraction process, the 
validity of the extracted parameters must be constantly 
scrutinized.

The ability to discern reasonable values from questionable ones 
comes from knowledge of device physics, knowledge of the 
particular device, and individual experience. Parameter 
extraction is still very much an art.

Parasitic Extraction

In all the equations governing the behavior of the model, the 
voltages are assumed to be intrinsic. There is no direct way to 
measure or set the intrinsic voltages, so they must be 
determined indirectly. To accomplish this, the parasitic 
resistances and inductances must first be very accurately 
determined. Once these are known, the intrinsic voltages can be 
calculated from these parasitic values and the known currents, 
using the following equations:

DC:

VGSint = VGSext - Ig ⋅ RG - Is ⋅ RS

VDSint = VDSext - Id ⋅ RD - Is ⋅ RS

AC:

vgsint = vgsext - ig(RG + jωLG) - is(RS + jωLS)

vdsint = vdsext - id(RD + jωLD) - is(RS + jωLS)

These intrinsic voltages are used by the Curtice cubic model to 
predict device performance, so they must be known before any 
other parameters can be extracted.

Selecting the Simulator

One last step remains before the actual extractions: to check 
that the selected simulator is compatible with the model. The 
only simulator that supports the Curtice GaAs model is hpspice.

Select the Model Variables tab. A variable table is displayed, 
showing the name of the currently selected simulator. If the 
SIMULATOR name is not hpspice, then type hpspice.
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Displaying the Parameters Table

The CGaashf Model Parameters table lists all the parameters 
that will be extracted, and initially displays default values. As 
you perform the individual extractions, the default values 
change to extracted values. Throughout the extraction process, 
you will use the Parameters table to read extracted values, and 
to enter or modify values to adjust interactive parameters for 
best agreement of simulated with measured data. In addition, 
you can set limits by entering minimum and maximum values 
for each parameter. Parameter values that are outside their 
limits are clamped to their minimum or maximum values. To 
view the parameters, click the Model Parameters tab.

Extracting Parasitic Resistances and Inductances

This procedure extracts the parasitic gate, drain, and source 
resistances (RG, RD, RS) and gate, drain, and source 
inductances (LG, LD, LS). These parameters are extracted from 
the S-parameter data measured with the parasitics setup.

1 Locate the default values for RG, RD, RS, LG, LD, and LS in 
the Parameters table.

2 Select the parasitics setup from the DUT/Setup panel.

3 From the Plots tab, select R_data > Display Plot, and L_data > 
Display Plot.

4 From the Extract/Optimize tab, select the autoextract 
transform and Execute. The transform calculates the parasitic 
values with frequency and enters them in the Parameters 
table. In the plots, the resistance data displayed is the real 
part of the device impedance Z, and the inductance data is 
the imaginary part of the impedance.

5 Select the zg transform and Execute. The transform data is 
added to the R_data and L_data plots.

6 To verify the RG and LG data values in the Parameters table 
against the values plotted, position the pointer at a frequency 
of interest or on some approximately median point on the 
trace, and click middle. A readout of the trace value (Y) at 
that point is listed above the plot: compare this value with 
the value in the Parameters table.
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7 If the trace value you selected and the Parameters table value 
do not closely correspond, it may be because a portion of the 
trace is noisy. In particular, the inductance values at the 
lower frequencies are likely to be noisy and less valid. You 
may wish to change the Parameters table value to more 
closely represent a linear portion of the trace. The parasitic 
values calculated by autoextract are averaged across the 
entire frequency range of the measurement by default. To 
average across only a portion of the trace you can use the 
X-low/X-high function.

• Select the Setup Variables tab. A variable table will appear, 
listing X_LOW and X_HIGH with their default or current 
frequency values. 

• From the plotted data choose a linear portion of the trace. 
Put the mouse pointer at the low end of that portion and 
click left, then put the pointer at the high end and click left 
to make a box on the trace, as shown in the illustration.

• From the plot menu select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values in the table to the 
values you selected on the trace.

Figure 28 Selecting a Linear Portion of the L_data Trace
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• Repeat autoextract > Execute. The transform recalculates 
the parasitic values using the new X-low/X-high values.

8 Select Extract/Optimize > zd > Execute. To verify the drain 
resistance and inductance values (RD and LD) in the 
Parameters table, follow the same steps as for the gate 
parasitics.

9 Select zs > Execute. To verify the source resistance and 
inductance values (RS and LS) in the Parameters table, 
follow the same steps as for the gate parasitics.

10 Close the plots.

Extracting the Gate Diode Parameters

This procedure extracts the parameters N (ideality factor), VBI 
(built-in voltage), and IS (junction saturation current). These 
parameters are extracted from the DC data measured with the 
ideality setup.

N (Ideality Factor)

1 Scroll the Parameters table until it shows the value for 
ideality, represented as NMF1.N.
NOTE Several of the parameter names in the table are preceded by NMF1.
2 Select DUTs/Setups > ideality. 

3 Select Plots > n_vs_vg > Display Plot.

4 Select Extract/Optimize > extract > Execute.

5 Select the n transform, and Execute. This calculates the 
ideality factor and enters it into the Parameters table.

6 The data displayed in the n_vs_vg plot should resemble 
Figure 29. N is computed as the minimum value along the 
linear region of the logarithmic curve (shown in the box in 
Figure 29). Beyond the linear region, the parasitic values 
begin to dominate, and N is no longer identifiable.
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7 To check the N value in the Parameters table against a value 
on the trace, put the mouse pointer on the linear portion of 
the trace and click middle for a readout of the Y-axis value at 
that point.

8 If the n_vs_vg plot looks significantly different from the 
following figure, the N value in the Parameters table may not 
be valid. For example, if noise is present on the trace below 
the linear region of the curve, N may have been computed as 
the minimum value of the noise. In this case, use the 
X-low/X-high function to get a more valid value.

9 To compute N over only the linear portion of the trace using 
X-high/X-low:

• Select Setup Variables to open the X-high/X-low variable 
table. 

• In the Value field (right side of the table) for 
OVERRIDE_LIMITS, change FALSE to TRUE, to set 
override limits to true.

• Make a box on the trace by clicking left on the ends of the 
linear portion.

Figure 29 Linear Portion of the n_vs_vg Plot
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• From the plot menu select Options > Copy to Variables to 
change the X-low/X-high values to the trace limits you 
selected.

• Select Extract/Optimize > extract > Execute to recalculate the 
N value using the new X-low/X-high values.

• Check the value of NMF1.N in the Parameters table.

10 If no linear region is shown on the trace, a valid ideality 
factor cannot be computed from it. In this case, you will need 
to manually enter a value of 1 or 0. Since the contribution of 
N to the gate current is relatively small, it is best when the 
data is very nonlinear to eliminate the contribution of the N 
factor by using a value of 0. To change the NMF1.N value in 
the Parameters table, move the mouse pointer over the 
current entry and click left to highlight it, then type in the 
new value and press Return.

IS (Saturation Current)

1 Select Plots > ig_vs_vg > Display Plot. The data displayed 
should resemble the following figure, with two plotted 
functions of gate current Ig vs gate voltage Vg. The solid line 
is the measured data, and the dashed line is the simulation.

Figure 30 Measured and Simulated Saturation Current (IS) Data
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2 Scroll the Parameters table until it shows the value for 
NMF1.RF.

3 Select DUTs/Setups > Extract/Optimize > rf_off > Execute. The 
value of NMF1.RF in the Parameters table will change to 0.

4 Scroll the Parameters table until it shows the value for 
NMF1.IS.

5 Select Extract/Optimize > opt_is > Execute. Observe the plot and 
see the simulated data converge on the measured data as the 
value for IS is optimized. (Note that the opt_is transform 
optimizes the linear data for which the ideality factor is 
valid.)

6 Observe the change in the Parameters table value for IS.

7 The parameter value for VBI is also changed.

8 Close the plots.

Extracting the A Parameters and VDS0

This procedure extracts and optimizes the A0, A1, A2, and A3 
coefficients that describe the threshold characteristics of the 
device. VDS0 is the value of VDS at which A0 through A3 are 
determined; its default value is the value of Vd specified in the 
idvg_vd inputs. 

These parameters are extracted from the DC data measured 
with the idvg_vd setup.

1 Scroll the Parameters table until it shows the default values 
for A0, A1, A2, and A3.

2 Select DUTs/Setups > idvg_vd.

3 Select Plots > id_vs_vg > Display Plot.
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4 Select Extract/Optimize > extract > Execute.

5 The transform calculates the values of A0, A1, A2, A3, and 
VDS0 and enters them into the Parameters table.

6 Scroll the Parameters table until you find the value for 
NMF1.VDS0. Manually enter this same value into the 
Parameters table for VDSDC (you will need to scroll the 
Parameters table again to find it).

7 Select Measure/Simulate > Simulate. The plot should now 
display a solid-line measured curve and a dashed-line 
simulated curve.

8 Select Extract/Optimize > opt_cubic > Execute. Watch the 
simulated data converge on the measured data as the values 
for the A coefficients are optimized (as in Figure 31).

9 Select Model Parameters, and observe the new Parameters 
table values for the A coefficients and VDS0.

10 Close the plot.

Figure 31 A Parameter Data After Optimization
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Extracting Beta and Gamma Parameters and RDS0

This procedure extracts beta2 and gamma2, the Curtice cubic 
parameters that control the linear and saturation regions of 
device operation. Gamma2 dominates in the linear region and 
determines the transition from linear to saturation; beta2 
dominates in the saturation region. 

Also extracted through optimization is RDS0, the intrinsic 
output resistance. RDS0 dominates at both the low and high 
values of Vds relative to VDS0 (that is, Vds ≤ VDS0 and VDS0 ≤ 
Vds).

These parameters are extracted from the DC data measured 
with the idvd_vg setup.

1 Scroll the Parameters table until you find RDS0. Manually set 
an RDS0 value of 1K ohms, as the initial value to be used in 
the optimization.

2 Select the idvd_vg setup.

3 Select Plots > id_vs_vd > Display Plot.

4 Select Extract/Optimize > extract > Execute.

5 Select Measure/Simulate > Simulate.

6 The plot should now display a family of solid-line measured 
curves and dashed-line simulated curves, as in the following 
figure.
IC-CAP Nonlinear Devices Models Volume 2



High-Frequency FET (Curtice) Models 2

IC-CAP Nonlinear Devices Models V

 
7 Select Extract/Optimize > opt_cubic > Execute. Watch the 
simulated curves converge on the measured curves as the 
beta and gamma coefficients are optimized.

8 Scroll the Parameters table and observe the new values for 
BETA, GAMMA, and RDS0.

9 Close the plot.

Extracting the AC and Capacitance Parameters

This extracts the parameters RIN, RGDN, CGDN, CDS, CGS0, 
A5, and RC. These parameters are extracted from the 
S-parameter data measured with the s_vs_f setup. The 
transforms calculate the intrinsic admittances vs frequency.

In an extraction of admittances vs frequency, the linear region 
of the data may be bounded by nonlinearities at the ends of the 
frequency range. Capacitance tends to dominate at lower 
frequencies, and inductance at higher frequencies. The most 
appropriate values for the extracted parameters occur in the 

Figure 32 Measured and Simulated Data for Beta, Gamma, and RDS0 
Extraction
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linear resistive region of the data. The X-low/X-high function 
lets you define the boundaries of the linear region and perform 
the transform over only that region. 

1 Select the s_vs_f setup.

2 Select the Plots tab, then select and display the following 
plots: Rs, Cs, tau_a5, and CGS0.

3 Select the Extract/Optimize tab, then select and execute the 
following transforms: ygs, ygd, yds, a5, cgs0, and ygm.

4 Examine the plots and use the X-low/X-high function if 
necessary to limit the range of the extractions that will 
follow:

• Select Setup Variables to open the X-high/X-low variable 
table.

• Click left at the ends of the linear region to make a box on 
the trace.

• From the plot menu select Options > Copy to Variables to 
change the X-low/X-high values to the trace limits you 
selected.

• Select Extract/Optimize > extract > Execute to recalculate the 
parameter values using the new X-low/X-high values.

5 Select extract_RC > Execute. This transform optimizes RC to 
minimize the difference between the measured real yds and 
the simulated real yds.

6 Verify the values of the extracted parameters listed in the 
Parameters table against the measured data in the plots.

• The Cs plot shows the value for CGDN as imag(ygd), the 
imaginary part of the measured gate admittance; and CDS 
as imag(yds), the imaginary part of the measured drain 
admittance.

• The Rs plot shows RIN as real(ygs), the real part of the 
measured gate admittance; and RGDN as real(ygd), the 
real part of the measured drain admittance.

• The CGS0 plot shows CGS0 as real(cgs0).

• The tau_a5 plot shows A5 as imag(a5).
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Verifying the AC and Capacitance Extractions

1 Select Plots > S11 > Display Plot. Repeat this for S12, S21, and 
S22.

2 The plots show the measured and simulated S-parameter 
values. If the extraction is good, the simulated traces should 
converge toward the measured traces, as in the S-parameter 
plots below.

3 If the simulated traces do not match the measured traces 
well, recheck the extracted R, C, and L values.

4 Close the plots.

This ends the extraction process.
Storing the Model
 

This procedure stores the model in IC-CAP, including all the 
device-specific measured and simulated data. Once you have 
developed the device model, it can be used as a component in 
the Agilent RF and Microwave Design System (MDS). You can 
use it for circuit simulation, inserting it into circuits under 
design to emulate the characteristics of your device. 

If you will be modeling large numbers of devices, it is 
worthwhile to organize your directory structure according to 
device type, geometry, and batch or wafer.

1 Use the UNIX directory you created at the beginning of the 
procedure, when you first opened the CGaashf.mdl file.

2 From the CGaashf:1 main menu select File > Save As.

3 A dialog box is displayed, as illustrated.
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4 Select the File Type (.mdl for a complete model) by clicking 
the corresponding radio button.

5 Select a new filename that associates this model with the 
device, for example fet5.mdl. Type the full directory 
pathname and the filename into the dialog box. Select OK to 
store the data and close the dialog box.

Storing the Parameters Table

The Parameters table lists all the parameters extracted for a 
device model. You can save the Parameters table for a specific 
device. The illustration shows a portion of the table.

Figure 33 Save As Dialog Box
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1 To save the Parameters table select File > Save As.

2 In the dialog box, select the File Type .mps for model 
parameter set.

3 Type in a filename or use the one in the File Name field.

4 Select OK.

You can now recall the same set of device parameters any time 
you wish.

Figure 34 Top Portion of the Model Parameters Table
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3
High-Frequency BJT (Gummel-Poon) 
Model

Getting Started in IC-CAP 117

Using the High-Frequency BJT Model 119

The Agilent 85193A high-frequency BJT model is a 
three-terminal version of the Gummel-Poon model, with a 
measurement and extraction methodology that has been 
developed specifically for high-frequency devices. 

The high-frequency BJT model provides improved accuracy for 
modeling the AC parameters of a high-frequency device, by 
using a network analyzer to measure the device S-parameters. 
Additionally, because accurate capacitance measurements are 
extremely difficult at high frequencies, the software computes 
the model junction capacitances from the measured 
S-parameter data, rather than using a CV meter.

This chapter provides example procedures to enable you to use 
the software as a tool to measure your devices and extract their 
model parameter values. They take you step-by-step through a 
BJT measurement and parameter extraction. The procedures 
are arranged in the most logical sequence to allow earlier 
measured data or extracted parameters to be used as a basis for 
later measurements or extractions. The sequence also requires 
the least number of configuration changes.

The procedures use a series of different setups to measure 
current or voltage versus bias under different bias conditions. 
The measured values are later used in the extraction process to 
isolate individual parameters. In the BJT model, the parameters 
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are very interdependent because of the inherent coupling of the 
model equations. The purpose of the different measurement 
setups is to decouple the SPICE equations as much as possible. 
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These procedures assume the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System.”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System.”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename a medium-power SMU connected to the device base 
as SMU1

Rename a high-power SMU connected to the device collector 
as SMU2

Rename the GNDU unit (which must be connected to the 
emitter) as GND.
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on opening the IC-CAP software and accessing the model file 
you need. Find the high-frequency BJT model file under:

/examples/model_files/bjt/bjt_ncehf.mdl

Then return to this chapter and continue with the procedures 
here.

Before you continue, create a new directory (using the mkdir 
command), to store the data and model files that will be 
generated, and then change to that directory.
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To effectively isolate the individual parameters of a BJT, some 
device measurements require that the collector is biased and 
the emitter grounded, while some require that the emitter is 
biased and the collector grounded. These procedures assume 
that in-fixture measurements are made with the device 
mounted in the fixture in a common-emitter configuration as 
shown in the following figure. In some measurements, the 
collector is synchronized to the emitter with an offset, to 
provide data equivalent to that of a common-collector 
configuration.

Figure 35 BJT in Common-Emitter Configuration
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NOTE An earlier version of the Agilent 85193A high-frequency BJT model made 
use of a BJT switching adapter to switch the device between 
biased-collector and biased-emitter configurations. Now a synchronized 
sweep (SYNC) is used to synchronize the base and collector SMUs 
together, allowing all measurements to be made using a common-emitter 
configuration thus eliminating the need for the switching adapter. The 
earlier model, bjt_nhf, can still be used, along with the switching adapter, 
if you prefer.
The procedures in this chapter include detailed instructions for:

• Setting the instrument states for each measurement

• Setting the input values for each measurement

• Making the measurements and qualifying the results
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• Extracting DC, capacitance, and AC parameters; optimizing 
the results

• Verifying the simulated performance against measured data

• Adjusting the extracted parameters for best model accuracy
NOTE Measurement parameters and measured data are specific to individual 
devices. Information and data are provided here as examples and 
guidelines, and are not intended to represent the only correct method or 
results.
The procedures start with example values for IC-CAP 
measurement inputs. They provide guidelines on setting the 
values to measure your device. However, the values you use will 
be based on your knowledge of your device and on information 
provided in its device data sheet, as well as on the guidelines 
provided here: they may or may not correspond with the 
examples. In some cases, it may be necessary to set the input 
values, make a measurement, and then reset the inputs based 
on the measurement results. The procedures give suggestions 
on judging the applicability of the input values and measured 
data.

The illustrations of plotted data are provided as visual examples 
of possible measurement results. They are not intended to 
represent a sequential measurement of one device, nor do they 
necessarily correspond with the example measurement inputs 
described in the procedures. The plots can be used to check the 
reasonableness of your own measured data, which should 
appear similar in shape but not necessarily coincident in values.

In addition, the IC-CAP software itself includes measured data 
for some of the setups. This data is from the measurement of a 
single device, and shows another example of possible results. 
Many, though not all, of the input settings for this measurement 
correspond with the example settings.
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The DUT/Setup panel is the central access point for the 
measurement and extraction procedures. The DUTs (for 
example DC) indicated by the inverted triangles, are groupings 
of similar measurement setups used to extract related model 
parameters. The setups contain the information used to define 
the inputs and outputs for each measurement, as well as their 
measurement hardware configurations and their associated 
transforms and plots.

Figure 36 The DUT/Setup Panel
Making the DC Measurements
The DC measurement procedures measure DC current or 
voltage versus bias under different bias conditions. Setting up 
the measurement involves two main processes for each 
measurement setup: defining the instrument state for the DC 
source/monitor, and setting the inputs for the device 
measurement.
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Leave the network analyzer disconnected from the bias 
networks while you perform the DC measurements, with the RF 
IN connectors of the bias networks terminated to prevent 
possible bias oscillation.

Defining the Instrument States

For each of the measurement setups, it is necessary to define 
the instrument states (options) for the measurement 
instruments that will be used in that setup. The instrument 
states need to be defined individually for each setup. Different 
setups use different measurement instruments. However, with 
minor exceptions that will be explained, the instrument states 
for the same measurement type must be used for all the setups 
that use that measurement type.

To define the instrument state for any given setup:

1 Select the setup, for example fgummel.

2 Click the Instrument Options tab, and the window changes to 
display the instrument states for all instruments used in that 
measurement. In the DC measurement setups, the 
instrument states for the DC source/monitor are displayed. 
In the S-parameter measurement setups, the instrument 
states for both the DC source/monitor and the network 
analyzer are displayed.

The instrument state settings will be explained in this chapter 
with their corresponding setups.

Making the Forward Gummel Measurement

The forward and reverse gummel measurements plot the 
operating range of the base and collector currents with the 
transistor in the forward active and reverse active modes. All 
coefficients of the DC model equations are derived from the 
fgummel and the rgummel data.

This procedure measures Ic and Ib with respect to Vbe. The base 
and collector are swept across a range large enough that both 
high-level and low-level effects occur. This measurement should 
always be done first because its result is used to properly define 
the ranges of subsequent measurement setups.
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BJT Configuration: The input values you set in the following 
fgummel procedure configure the BJT as shown in the following 
figure.

Parameters

The data from this measurement will be used to extract IS, BF, 
NF, ISE, NE, and IKF. It may also need to be used to 
interactively modify other parameters such as RE, RC, RB, and 
VAR.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Defining the DC Source/Monitor Instrument State” on 
page 621 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

However, for the forward gummel measurement, set Integ Time 
to L (long) to reduce noise at low current values. Then return to 
this chapter and continue.

Figure 37 BJT Configuration for fgummel Measurement
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Setting the fgummel Input Values

This procedure defines the input signals to be applied to the 
device under test for this measurement. The actual settings you 
use will depend on the compliance limits for both the device 
and the SMUs/bias networks, and on the range of 
measurements you wish to take.

You provide compliance values to limit SMU output voltage or 
current and prevent damage to the device under test, as well as 
to the SMUs, bias networks, and probes, if used. With a voltage 
input, compliance refers to current. Refer to your device data 
sheet as needed for specifications and compliances. From the 
DC DUT select the fgummel setup. The setup inputs and outputs 
are displayed.

Table 16 For the vb input

Set To

Mode V (voltage)

Unit SMU1

Compliance no greater than the maximum allowable base current value 
in the device data sheet.

Sweep Type LIN, to provide a linear Vbe sweep from start to stop voltage 
values

Start and Stop Voltage values that define the operating range of the 
device. The Start value should be low enough so that the Ib 
curve bends up at the low end due to recombination in the 
base-emitter depletion region. The Stop value should be 
large enough so that the Ic curve begins to bend over at the 
high end due to high-level effects.

# of Points A value sufficiently large such that the subtle bends at the 
low and high ends of the curves are clearly displayed—51 
points is usually an adequate number
IC-CAP Nonlinear Devices Models Volume 2
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• The Unit names must conform to the names set in the 
hardware window. Refer to the appropriate chapter as 
follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

They must also correspond with the actual plug-in SMU 
connections from the Agilent 4142. 

Table 17 For the ve input

Set To

Mode V (voltage)

Unit GND

Sweep Type CON

Value 0.000 to provide a constant zero voltage. This holds the 
emitter at ground potential to prevent reverse leakage from 
influencing Ib.

Table 18 For the vc input

Set To

Mode V (voltage)

Unit SMU2

Compliance no greater than the maximum collector current value in the 
data sheet.

Sweep Type SYNC, to synchronize it to the Master Sweep vb.

Ratio 1.000

Offset 0.000
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• The Outputs are factory set, and should not be changed, with 
the exception of Type. This is the type of data to be plotted, M 
for measured, S for simulated, or B for both. The illustrations 
of measured data in this chapter were plotted with the 
outputs set to M: in the extraction section later in the 
chapter, where the illustrations show both measured and 
simulated data, the outputs were set to the default, B.

Measuring and Plotting

This procedure triggers the device measurement, controlling the 
DC source/monitor to supply the signals you defined in the 
instrument options and the inputs, and monitors the results.
NOTE Remove any high-intensity light sources such as microscope light before 
taking a measurement. This is particularly important if currents in the 
nanoamp range are being measured. One simple method of blocking light 
is to place an opaque plastic box on the fixture directly above the device.
1 From the Plots tab, select the ibicvsvb plot, and Display Plot. 

2 If you have not already connected the DUT, do so now. 
Observe antistatic precautions.

3 Select Measure/Simulate > Measure. Do not touch the fixture 
or the bias networks while the system is measuring. The 
yellow MEASURING light on the DC source/monitor will go 
off when the measurement is complete. 

4 The plot will be updated with the measured data. If the Ic 
curve does not bend over at the high end, go back to the 
inputs and set vb Stop to a larger value. Be careful, however, 
not to exceed the maximum current rating of the device. If 
the Ib curve does not bend up at the low end, set vb Start to a 
smaller value. Repeat the measurement.

The other plots are used later, in the extraction process.

5 Save the data using File > Save As and a filename with the 
suffix .set.

6 Close the plot.
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Making the Reverse Gummel Measurement

This procedure measures Ie and Ib with respect to −Vce. The 
emitter and base are grounded, and the base-collector voltage is 
swept across a negative range wide enough to show both 
high-level effects and low-level depletion effects.

BJT Configuration: The input values you set in the following 
rgummel procedure configure the BJT as shown in the following 
figure.

Parameters

The data from this measurement will be used to extract BR, ISC, 
NR, IKR, and NC. It may also need to be used to interactively 
modify other parameters such as RE, RC, RB, and VAF.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Defining the DC Source/Monitor Instrument State” on 
page 621 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

Figure 38 BJT Configuration for rgummel Measurement
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Use the same settings for the rgummel setup as you did for the 
fgummel. 
NOTE The instrument states need to be set independently for each setup.
Then return to this chapter and continue.

Setting the rgummel Input Values

1 In the DC DUT select the rgummel setup.

2 The vb Value is usually set to 0.000 to prevent reverse leakage 
from influencing Ib at low −Vc values.

3 Set the vc Start value low enough that the Ib curve preferably 
bends up at the low end due to recombination in the 
base-collector depletion region. The Stop value should be 
large enough that the Ie curve begins to bend over at the high 
end due to high-level effects. Synchronization is not 
necessary for this measurement.

4 Do not change the ve values, which set the emitter to ground. 

Measuring and Plotting

1 From the Plots tab, select the ibievsvc plot, and Display Plot.

2 Select Measure/Simulate > Measure. The plot will be updated 
with the measured data. If the Ie curve does not bend over at 
the high end, go back to the inputs and set vc Stop to a larger 
value. Be careful, however, not to exceed the maximum 
current rating of the device. Repeat the measurement.

3 Save the data using File > Save As and a filename with the 
suffix .set.

4 Close the plot.

Making the Forward Early Measurement

The forward early measurement models the effect of base-width 
modulation due to variations in the base-collector depletion 
region.
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This procedure measures Ic with respect to Vce at a single value 
of Vbe. The emitter is grounded and the collector voltage is 
swept. The Vbe value is taken from the log-linear region of the 
fgummel measurement. 

BJT Configuration: The input values you set in the following 
fearly procedure configure the BJT as shown in the following 
figure.

Parameters

The data from this measurement will be used to extract VAF, the 
forward early voltage.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Defining the DC Source/Monitor Instrument State” on 
page 621 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

Figure 39 BJT Configuration for fearly Measurement
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Use the same settings as for the fgummel measurement, except 
set Integ Time to M (medium) if you prefer. Then return to this 
chapter and continue.

Setting the fearly Input Values

1 Select the fearly setup.

2 Set Vb to measure at a single constant value. This should be 
in the log-linear range of the fgummel measurement, between 
the high- and low-level effects. To determine the Vb value, 
refer to the measured data from the fgummel measurement.

3 The reason for measuring at only one value of Vbe is that the 
rearly measurement must use the same number of base 
voltage values. The rearly measurement uses the sync 
function, and it can only synchronize on one base value. 

4 Set the vc range with a Start value of 0.0. Referring to the 
data sheet for your device, set the Stop value ≤ the upper 
limit of the device’s normal operating range. 

5 Set the vc # of Points sufficient that the resulting Ic curves 
will be clearly separated and easily distinguishable.

6 Do not change the ve values, which set the emitter to ground.

Measuring and Plotting

1 From the Plots tab, select the icvsvc plot, and Display Plot.

2 Select Measure/Simulate > Measure. The plot will be updated 
with the measured data. If you are not satisfied with the 
data, go back to the inputs and change the vb or vc values, 
staying within the log-linear range of the fgummel 
measurement for vb. Repeat the measurement.

3 Save the data using File > Save As and a filename with the 
suffix .set.

4 Close the plot.

Making the Reverse Early Measurement

The reverse early measurement models the effect of base-width 
modulation due to variations in the base-emitter depletion 
region. 
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This procedure measures Ie with respect to −Vce. The base is 
synchronized to the collector. The Vbc values are taken from the 
−Vc values in the log-linear region of the rgummel 
measurement, taking the device from near cutoff to near 
saturation. 

BJT Configuration: The input values you set in the following 
rearly procedure configure the BJT as shown in the following 
figure.

Parameters

The data from this measurement will be used to extract VAR, 
the reverse early voltage.

Defining the DC Source/Monitor Instrument State

Follow the same procedure you used in the fearly measurement. 
Use the same settings.

Setting the rearly Input Values

1 Select the rearly setup.

2 Set the vc range with a Start value of 0 and a Stop value in 
the negative range. This should be in the log-linear range of 
the rgummel measurement, between the high- and low-level 
effects. 

Figure 40 BJT Configuration for rearly Measurement
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3 Because vb is synchronized to the master sweep vc, only one 
vb value can be set. In this example, vb is offset from vc by 
670 mV, so that Vb = Vc + 670 mV. The ratio of vb to vc is 1:1.

Measuring and Plotting

1 From the Plots tab, select the ievsvc plot, and Display Plot.

2 Select Measure/Simulate > Measure. If you are not satisfied 
with the measured data, go back to the inputs and change the 
vc values or the vb offset. Repeat the measurement.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the fearly_family Measurement

This setup measures Ic with respect to Vce at three values of 
Vbe. The collector is set to the same values as in the fearly 
measurement, but the base voltage is set for measurements at 
three values. This allows you to view the device behavior over a 
wider range of base input voltages.

BJT Configuration: The input values you set in the following 
fearly_family procedure configure the BJT as shown in the 
following figure.

Defining the DC Source/Monitor Instrument State

Follow the same procedure you used in the fearly measurement. 
Use the same settings.

Figure 41 BJT Configuration for fearly_family Measurement
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Setting the fearly_family Input Values

1 Select the fearly_family setup.

2 Set the vb # of Points to 3 to allow for measurements at three 
different values so that you can see the device behavior at 
different base voltages. One of the base voltage values is the 
same as the value used in the fearly measurement.

3 To determine the Vb values, refer to the measured data from 
the fgummel measurement. Set vb Start and Stop to values in 
the log-linear range of the fgummel measurement, between 
the high- and low-level effects. The step size should be 
sufficient that the resulting measured Ic curves will be 
clearly separated and easily distinguishable.

4 Set the vc range with Start and Stop values the same as for 
the fearly measurement.

Measuring and Plotting

1 From the Plots tab, select the icvsvc plot, and Display Plot.

2 Select Measure/Simulate > Measure. If you are not satisfied 
with the spacing of the Ic traces, go back to the inputs and 
change the vb Start and/or Stop values, staying within the 
log-linear range of the fgummel data. Repeat the 
measurement.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the rcflyback Measurement

This procedure drives the base with a current to negate the 
effect of the base parasitic resistance. The collector is 
synchronized to the base such that −Ic = Ib. The change in 
negative collector voltage is monitored vs the change in base 
current. The collector voltage is the base current times the 
parasitic resistance in the collector.

BJT Configuration: The input values you set in the following 
rcflyback procedure configure the BJT as shown in the 
following figure.
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Parameters

The data from this measurement is used to extract the parasitic 
collector resistance RC.

Defining the DC Source/Monitor Instrument State

Follow the same procedure you used in the fearly measurement. 
Use the same settings.

Setting the rcflyback Input Values

1 Select the rcflyback setup.

2 In this setup, the ib inputs set the base current from the 
source/monitor to sweep from 100 uA to 10 mA, so that the 
measured data will be linear.

3 Set the ic Sweep Type to SYNC. The ic inputs synchronize the 
collector to the base, such that −Ic = Ib. This is done with a 
ratio of −1 and an offset of 0.

Measuring and Plotting

1 From the Plots tab, select the vcvsib plot, and Display Plot.

2 Select Measure/Simulate > Measure. The measured data 
should be similar to that shown in the following figure. The 
straight line is measured −Vc data. It should be fairly linear, 
and should only begin to deviate from a straight line at the 

Figure 42 BJT Configuration for rcflyback Measurement
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high end of the base current value, if at all. If necessary, you 
can go back to the inputs and change the ib Stop value, then 
repeat the measurement.

Making the reflyback Measurement

This procedure is similar to the rcflyback measurement. A 
current source drives the base to negate the effect of the base 
parasitic resistance. In this case the collector is open-circuited 
by setting its SMU current to zero. The change in collector 
voltage is monitored vs the change in base current. The 
collector voltage is the base current times the parasitic 
resistance in the emitter.

BJT Configuration: The input values you set in the following 
reflyback procedure configure the BJT as shown in the 
following figure.

Figure 43 Example Measured rcflyback vcvsib Data
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Parameters

The data from this measurement is used to extract the parasitic 
emitter resistance RE.

Defining the DC Source/Monitor Instrument State

Follow the same procedure you used in the fearly measurement. 
Use the same settings.

Setting the reflyback Input Values

1 Select the reflyback setup.

2 Set the ib Start value to 0.000. Set Stop to a current value 
such that the measured Vc curve will be fairly linear. This is 
similar to the range used in the rcflyback measurement.

3 Set the ic Sweep Type to CON (constant) with a Value of 
0.000, to open-circuit the collector.

Measuring and Plotting

1 From the Plots tab, select the vcvsib plot, and Display Plot.

2 Select Measure/Simulate > Measure. The measured data 
should be similar to that shown in the following figure. Note 
that the stepped effect of the trace is caused by the resolution 
of the SMU in the DC source/monitor.

Figure 44 BJT Configuration for reflyback Measurement
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3 The Vc trace should be fairly linear, and should only begin to 
deviate from a straight line at the high end of the base 
current value, if at all. If necessary, go back to the inputs and 
change the ib Stop value, then repeat the measurement.

Figure 45 Example Measured reflyback vcvsib Data
Calibrating the Network Analyzer
It is important to calibrate the network analyzer before you 
perform any S-parameter measurements. Good calibration of 
the network analyzer is critical to a good measurement and 
extraction. Without a good calibration, the results of the 
extraction will be inaccurate.

The high-frequency BJT measurement procedure requires a 
swept broadband calibration and one or two CW calibrations. 
The network analyzer is calibrated over the operating range of 
the device for the swept-frequency S-parameter measurements 
used to extract the AC device parameters. In addition, a 
calibration is performed at a single frequency for the CW 
S-parameter measurements used to extract the parasitic 
capacitance parameters. If the measurement system you are 
using is Agilent 8510-based, the CW calibration can be a subset 
of the broadband calibration. For Agilent 8753- and 8720- based 
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systems, IC-CAP does not support the subset calibration 
technique, and separate standards measurements are needed 
for the swept and CW calibrations. In either case, a second CW 
calibration may be needed later for the h21vsvbe measurement.

CW Calibration Frequency

The frequency of the CW calibration for the capacitance 
measurements should be around 100 to 200 MHz to eliminate 
the effects of test set coupler roll-off at low frequencies, and low 
enough to eliminate bond inductance and other parasitic 
inductance considerations. With an Agilent 8510-based system, 
use a calibrated measurement point equal to the start frequency 
of the broadband cal plus an integer multiple of the step size: 
the frequency used in the example procedure is 110 MHz.

50 MHz (start freq) + 1 ⋅ 60 MHz = 110 MHz

The h21vsvbe measurement is also performed at a single CW 
frequency. However, this frequency is determined based on the 
data provided by the S-parameter measurements, and cannot 
yet be determined. When you reach the h21vsvbe measurement 
and determine the measurement frequency, you can use the 
same method to perform that calibration.

For step-by-step calibration procedures, refer to the 
appropriate chapter as follows:

• “Calibrating the Network Analyzer” on page 589 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System” (if you have an Agilent 
8510-based system)

• “Calibrating the Network Analyzer” on page 631 in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System” (if you have an Agilent 8753-based system)
Measuring the Junction Capacitances
The junction capacitances are measured with a calibrated 
network analyzer, rather than a CV meter, for the greatest 
measurement accuracy. Accurate capacitance measurements 
are extremely difficult at high frequencies, therefore the 
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S-parameters measured at the collector and emitter of the 
device, with a CW frequency signal applied to the base.

Setting up the measurement conditions involves processes 
similar to those for the DC measurements: defining the 
instrument states and setting the inputs.

Making the sparm_Cjunc Measurement

This procedure measures the base-emitter and base-collector 
junction capacitances. An RF signal at a CW frequency is 
applied to the base, while the base voltage is swept from slightly 
forward-biased to strongly reverse-biased. A network analyzer 
takes S-parameter measurements from which the junction 
capacitances are derived.
 

NOTE This setup combines and replaces both the earlier sparm_cje and 
sparm_cjc setups. While this simplifies the measurement, the bias is 
limited to the maximum base-emitter reverse breakdown voltage. If 
necessary, you can create two junction setups, sparm_cje and sparm_cjc, 
and make two separate measurements.
BJT Configuration: The input values you set in the following 
sparm_Cjunc procedure configure the BJT as shown in the 
following figure.

Figure 46 BJT Configuration for sparm_Cjunc Measurement
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Parameters

The data from this measurement is used to extract CJE, VJE, 
MJE, CJC, VJC, and MJC.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for CW Frequency Measurements” on 
page 601 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Instrument States for CW Frequency Measurements” on 
page 628 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

Set the Cal Set No to the cal set or register where you stored 
your CW calibration. The procedures in this manual use cal set 
#2. Then return to this chapter and continue.

Setting the sparm_Cjunc Input Values

1 Connect the network analyzer RF input cables to the RF IN 
ports of the bias networks.

2 Select the sparm_Cjunc setup.

3 The swept base voltage biases both the base-emitter and the 
base-collector junctions with the same voltage. The applied 
bias must be limited to the maximum base-emitter reverse 
breakdown voltage to prevent damage to the device.

4 Set the vc Sweep Type to CON (constant) with a Value of 
0.000, to open-circuit the collector.

5 Do not change the ve values, which set the emitter to ground.

6 Set the freq Sweep Type to CON (constant) to measure at a 
single CW frequency. 

7 Set the freq Value to the frequency of your CW calibration 
(see “Calibrating the Network Analyzer,” earlier). The 
frequency used in this example procedure is 110 MHz. The 
frequency should be in the MHz range to eliminate the effects 
IC-CAP Nonlinear Devices Models Volume 2
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of test set roll-off at low frequencies, and low enough to 
eliminate bond inductance and other parasitic inductance 
considerations.
NOTE In setting a MHz value, write MEG in full. IC-CAP is not case-sensitive, and 
assumes that m or M corresponds to milli. If the message Error: NWA 
frequency value <45 MHz is displayed, you may have entered M only.
Measuring and Plotting

1 From the Plots tab, select the cj_vs_v plot, and Display Plot.

2 Select Measure/Simulate > Measure. 

3 Save the data using File > Save As and a filename with the 
suffix .set.

4 Close the plot.
Measuring S-Parameters versus Frequency
 
The swept S-parameter measurements in the next two setups 
provide the data that allows extraction of parameters related 
specifically to the high-frequency performance of the device. 
The S-parameters are measured at the collector of the device, 
with a swept-frequency signal applied to the base. The first 
setup performs an S-parameter measurement without DC bias; 
the second is a DC-biased S-parameter measurement.

Making the sparm_0v Measurement

This procedure measures the S-parameters at the collector of 
the BJT across a calibrated microwave frequency range, with no 
DC bias signals applied.

BJT Configuration: The input values you set in the following 
sparm_0v procedure configure the BJT as shown in the 
following figure.
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Parameters

The data from this measurement will be used in the extraction 
of RB and LVIA.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for Swept Measurements” on page 598 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System” (for an Agilent 8510-based 
system)

• “Instrument States for Swept Frequency Measurements” on 
page 624 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (Agilent 8753- or 
8720-based system)

Note: The instrument states need to be set independently for 
each setup, and are different for CW and swept frequency 
measurements. Set the Cal Set No to the cal set or register 
where you stored your broadband calibration. The procedures 
in this manual use cal set #1. Then return to this chapter and 
continue.

Figure 47 BJT Configuration for sparm_0v Measurement
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Setting the sparm_0v Input Values

1 Select the sparm_0v setup.

2 Set the Sweep Type for all the voltage inputs (vb, vc, and ve) 
to CON (constant), with a Value of 0.000, to apply zero bias 
at all terminals.

3 Set the freq Sweep Type to LIN, for a linear measurement 
sweep across the frequency range. Set the Start and Stop 
values to correspond with the frequency range you defined in 
your broadband calibration. The frequency range used in the 
example procedure is 50 MHz to 6.05 GHz. Set the # of Points 
the same as in the calibration.

Measuring and Plotting

1 From the Plots tab, select the s11 plot, and Display Plot.

2 Select Measure/Simulate > Measure. The measured data 
should be similar to that shown in the following figure, 
though the trace may or may not cross the real (horizontal) 
axis.

Figure 48 Example Measured sparm_0v s11 Data
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The following steps determine the device resonant frequency Fr 
(the frequency where the S11 curve crosses the real axis), and 
the input impedance R(@Fr).

1 If the trace does not cross the real axis, you have two 
alternatives:

• You can increase the network analyzer upper frequency 
limit until the trace does cross the real axis (a 
time-consuming solution because you will need to 
recalibrate). 

• Or (preferably) you can visually extrapolate the S11 trace 
to see where it would cross the real axis if it were actually 
extended.

2 After you find the point where the trace crosses (or would 
cross) the axis, on the network analyzer press LOCAL to 
obtain front-panel control. Then press PARAMETER > S11 > 
FORMAT > SMITH CHART > MARKER > MARKER 1. Turn the 
RPG knob to move the marker to the point where the trace 
crosses the real axis. The marker readout shows the 
frequency at that point, as well as the real and imaginary 
impedance values. 

3 Record the frequency: this is the resonant frequency Fr of the 
device.

4 Record the real impedance value: this is the input impedance 
R(@Fr).

5 Save the measured data using File > Save As and a filename 
with the suffix .set.

Making the sparm_bias Measurement

This procedure measures the S-parameters at the collector of 
the BJT across a calibrated microwave frequency range, at three 
values of base-emitter bias that take the device from near cutoff 
to near saturation.

BJT Configuration: The input values you set in the following 
sparm_bias procedure configure the BJT as shown in the 
following figure.
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Parameters

The data from this measurement will be used in the extraction 
of RB, IRB, RBM, TF, PTF, FC, and XCJC. This data will also be 
used to check the overall quality of all the extracted parameters.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for Swept Measurements” on page 598 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System” (for an Agilent 8510-based 
system)

• “Instrument States for Swept Frequency Measurements” on 
page 624 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (Agilent 8753- or 
8720-based system)

Use the same settings as you did for the sparm_0v setup. Then 
return to this chapter and continue.

Setting the sparm_bias Input Values

1 Select the sparm_bias setup.

2 Set the vb # of Points to 3, to provide three different bias 
levels.

Figure 49 BJT Configuration for sparm_bias Measurement
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3 To determine the Vb values, refer to the measured data from 
the fgummel measurement. Set vb Start to a value near 
device cutoff, and Stop to a value near saturation.

4 Set the vc Sweep Type to CON (constant), with a Value at or 
near the normal operating point of the device.

5 Do not change the ve values.

6 Set the freq values the same as you did for the sparm_0v 
setup, to correspond with your broadband calibration.

Measuring and Plotting

1 From the Plots tab, select Display All to display all the 
S-parameter plots.

2 Select Measure/Simulate > Measure. Note that the db_h21 plot 
shows the device gain H21 at the three bias levels.

3 If the db_h21 plot shows an unexpected drop in the gain of 
the device with bias (an abrupt change of several dB between 
one measurement point and the next), it is caused by thermal 
runaway. In this case, go back to the inputs and reduce the 
collector voltage by changing the vc Value. Then repeat the 
measurement.

4 When you are satisfied with the measured data, save it using 
File > Save As and a filename with the suffix .set.

Making the h21vsvbe Measurement

This procedure uses the network analyzer to measure H21 (the 
device current gain) versus Vbe, at a single microwave 
frequency. The base voltage is swept from near cutoff to near 
saturation. The H21 magnitude is derived from the 
S-parameters measured at the collector.

The measurement frequency is determined from the sparm_bias 
measurement data. A frequency is chosen in the linear range of 
the db_h21 plot. A network analyzer calibration is performed at 
that frequency prior to the h21vsvbe measurement, unless the 
frequency is the same as the frequency used for the 
sparm_Cjunc measurement.
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Because this measurement data will be combined with the data 
from the ftic measurement performed next, the Vb and Vc 
values used in both measurements need to be identical. This is 
accomplished by setting input values for both procedures to 
variables that are defined in the model variables table, as 
explained below.

BJT Configuration: The input values and measurement 
variables you set in the following procedures configure the BJT 
as shown in the following figure.

Parameters

The data from this measurement and the ftic measurement will 
be used to generate Ft vs Ic. This will then be transformed to 
extract TF, VTF, XTF, and ITF.

Determining the Measurement Frequency

The frequency value for this measurement is determined from 
the sparm_bias measurement data. 

1 Referring to the db_h21 plot from your sparm_bias 
measurement, note that part of the trace has a roll-off of 
approximately 20 dB per decade. Within this portion of the 
trace, select a frequency near the low end (see Figure 51).

2 To take advantage of the easy calibration subset capability of 
an Agilent 8510-based system, choose a frequency equal to 
the broadband cal start frequency plus an integer multiple of 
the calibration step size. Typically a frequency close to 

Figure 50 BJT Configuration for h21vsvbe Measurement

NA PORT 2

NA PORT 1 B

C

E

SMU2

SMU1
+

-

+

-

olume 2 147



148

3 High-Frequency BJT (Gummel-Poon) Model
 

200 MHz is adequate. The frequency used in the example 
procedure is 170 MHz.

50 MHz (start freq) + 1 ⋅ 120 MHz = 170 MHz

(If you have an Agilent 8753- or 8720-based system, you 
cannot use the cal subset feature with IC-CAP. Choose any 
appropriate frequency in the 20 dB per decade region of the 
trace.)

Calibrating the Network Analyzer

Figure 51 Determining the Frequency for the h21vsvbe Measurement

20 dB/decade
NOTE If the frequency you selected for this measurement is the same as the 
frequency of the sparm_Cjunc measurement, you need not perform 
another calibration.
If the frequency you selected is not the same, and your system is 
Agilent 8510-based, perform the following steps to create a CW 
frequency calibration subset of the original broadband cal:

1 On the Agilent 8510 network analyzer, press CAL > 
CORRECTION ON > CAL SET 1 to turn on the broadband 
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calibration. Then press MORE > MODIFY CAL SET > 
FREQUENCY SUBSET.

2 Use the SUBSET: START and SUBSET: STOP softkeys in the 
subset menu (NOT the front panel keys) to set both start and 
stop to the same frequency.

3 Press CREATE & SAVE, and store this calibration in cal set 
#3.

If your system is Agilent 8753- or 8720-based and the frequency 
you selected is not the same as the frequency of the 
sparm_Cjunc measurement, perform a new CW calibration at 
that frequency.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Instrument States for CW Frequency Measurements” on 
page 601 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Instrument States for CW Frequency Measurements” on 
page 628 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

Use the same settings as you did for sparm_0v and sparm_bias, 
unless you performed a new calibration for this measurement, 
set Cal Set No to 3. Then return to this chapter and continue.

Setting the h21vsvbe Input Values

1 Select the h21vsvbe setup.

2 Under vb, set Start to h21start, set Stop to h21stop, and 
set # of Points to h21npts. These are set to variables, instead 
of numerical values, to ensure the values will be identical to 
those used in the ftic measurement. The method for setting 
the actual values is described in the section, “Defining the 
h21 Measurement Variables” on page 150.

3 Under vc, set Start to h21stop, so that the Vc start value 
equals the Vb stop value. Set Stop to a value close to the 
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normal Vc operating point. However, if heat dissipation of the 
device fixture is a concern, keep the collector bias below 2V.

4 Set the vc # of Points to 2, to measure at the lower and upper 
Vc values.

5 Do not change the ve values.

6 Set the freq Sweep Type to CONstant to measure at a single 
frequency. Set the Value to the frequency you defined at the 
beginning of this procedure.

Defining the h21 Measurement Variables

This assigns numerical values to the variables listed as inputs. 
(The same values will apply to the ftic measurement.)

1 Select the Model Variables tab. The model variable table is 
displayed, as shown in the illustration.
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2 Set h21start and h21stop to appropriate Vbe values that will 
take the device from near cutoff to near saturation. The lower 
Vbe limit should not be so low that the device is cut off. The 
upper limit should be high enough that the measured H21 
curve will begin to roll-off due to higher order effects. Typical 
values range from Vbe = 0.65V to 0.8V.

3 Set h21npts (number of points) to a value that will make the 
voltage step size equal to an integer multiple of the Agilent 
4142 voltage resolution. For information on the voltage 
resolution of Agilent 4142 SMUs, refer to the “Getting 
Started” chapter of the Agilent 4142B Operation Manual.

Measuring and Plotting

1 Make the DUT/Setups folders active again and select the Plots 
tab. Select the h21_vbe plot, and Display Plot.

2 Select Measure/Simulate > Measure. 

3 If the measured data shows an unexpected drop in 
magnitude (an abrupt change of several dB between one 
measurement point and the next), it is caused by thermal 
runaway. The following figure shows an example. In this 
case, go back to the variable table and reduce the upper limit 
of Vbe by reducing the h21stop value. Then repeat the 
measurement.
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4 When you are satisfied with the measured data, save it using 

File > Save As and a filename with the suffix .set.

Making the ftic Measurement

This is a DC-only measurement that monitors the change in 
collector current with respect to a change in base-emitter 
voltage. The device configuration is the same as for the 
h21vsvbe measurement, except there is no RF input signal.

Because this measurement data will be combined with the data 
from the h21vsvbe measurement performed previously, the Vb 
and Vc values used in both measurements need to be identical. 
For this reason, some of the input values are set as variables 
that were defined in the h21vsvbe procedure.

Figure 52 Effects of Thermal Runaway
NOTE The network analyzer test port cables can remain connected.
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BJT Configuration: The input values you set in the following ftic 
procedure configure the BJT as shown in the following figure.

Parameters

The data from this measurement and the h21vsvbe 
measurement is used to generate Ft vs Ic. This is then 
transformed to extract TF, VTF, XTF, and ITF.

Defining the Instrument States

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 in Appendix B, “Using IC-CAP with an Agilent 
85122A Precision Modeling System” (for an Agilent 
8510-based system)

• “Defining the DC Source/Monitor Instrument State” on 
page 621 in Appendix C, “Using IC-CAP with an Agilent 
85123A Device Modeling System” (for an Agilent 8753- or 
8720-based system)

Use the same settings as you did for the h21vsvbe setup.

Figure 53 BJT Configuration for ftic Measurement
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Setting the ftic Input Values

1 Select the ftic setup.

2 Under vb, set Start to h21start, set Stop to h21stop, and 
set # of Points to h21npts, to ensure these values are 
identical to those used in the h21vsvbe measurement.

3 Set vc Start to h21stop, so that the Vc start value equals the 
Vb stop value.

4 Set vc Stop to the same value as in the h21vsvbe 
measurement.

5 Set the vc # of Points to 2.

6 Do not change the ve values.

Measuring and Plotting

1 From the Plots tab, select the ft_ic plot, and Display Plot.

2 Select Measure/Simulate > Measure. 

3 When you are satisfied with the measured data, save it using 
File > Save As and a filename with the suffix .set.

4 Close the plot.
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The extraction procedures are presented in the appropriate 
sequence to allow earlier extracted parameters to be used as a 
basis for later extractions.

In a BJT model, the parameters are very interdependent 
because of the inherent coupling of the model equations. The 
purpose of the different setups in the measurement process is 
to decouple the SPICE equations as much as possible. In the 
extraction process, the effects of individual parameters or small 
groups of related parameters can be isolated, and their values 
determined with reasonable certainty. The goal is to create a 
list of realistic parameters that can be used in a model to 
accurately predict device performance. Because of the 
interdependence of the parameters, the extraction process is 
extremely iterative, and involves many subjective judgments. 
The validity of the extracted parameters must be checked 
repeatedly. 

The ability to discern reasonable values from questionable ones 
comes from knowledge of device physics, familiarity with a 
particular device, and individual experience. Parameter 
extraction is very much an art.

Displaying the Parameters Table

The bjt_ncehf Model Parameters table lists all the parameters 
that will be extracted, and initially displays default values. As 
you perform the individual extractions, the default values 
change to extracted values. Throughout the extraction process, 
you will use the Parameters table to read extracted values, and 
to enter or modify values to adjust interactive parameters for 
best agreement of simulated with measured data.
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1 Click the Model Parameters tab. The table of model parameters 
is displayed, showing the current values of the individual 
parameters. The illustration shows a portion of the table.

2 To save the Parameters table after your device parameters 
are extracted, select File > Save As.

Figure 54 Top Portion of the Model Parameters Table
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3 In the dialog box, select the File Type .mps for model 
parameter set.

4 Type a filename or use the one in the File Name field and 
click OK.

You can now recall the same set of device parameters any time 
you wish.

Extracting the Junction Capacitance Parameters

This procedure extracts the base-emitter parameters CJE, VJE, 
and MJE; and the base-collector parameters CJC, MJC, and VJC. 
These parameters are extracted from the data measured in the 
sparm_Cjunc setup.

1 Scroll the Parameters table until it shows the values for CJE, 
VJE, and MJE.

2 Select DUT/Setups > sparm_Cjunc.

3 From the Plots tab, select the cj_vs_v plot, and Display Plot.

Parameter Description

CJE Zero-bias base-emitter capacitance.

VJE Base-emitter junction built-in potential.

MJE Base-emitter grading coefficient.

CJC Zero-bias base-collector capacitance.

VJC Base-collector junction built-in potential.

MJC Base-collector grading coefficient.
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4 Select the Extract/Optimize tab.

5 Select the set_Cjunc transform, and Execute. The transform 
calculates the values for CJE and CJC and enters them in the 
Parameters table. 

6 Select calc_cje > Execute. Then select opt_cje > Execute. The 
simulated cje data in the plot should converge on the 
measured data, as in the previous figure.

7 Select calc_cjc > Execute. Then select opt_cjc > Execute. The 
simulated cjc data in the plot should converge on the 
measured data.

8 Close the plot.

Figure 55 Measured and Simulated sparm_Cjunc cj_vs_v Data
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Extracting the Collector Parasitic Resistance RC

This procedure extracts RC, using the data measured with the 
rcflyback setup. The measurement drives the base with a 
current source to negate the effects of the base parasitic 
resistance, and monitors −Vc vs Ib with Ie at 0 amps. The 
measured value at Vc is therefore equal to Ib times RC.

1 Select the rcflyback setup.

2 Select Plots > vcvsib > Display Plot. The plotted −Vc voltage is 
the product of the base current times the collector parasitic 
resistance (see the following figure).

3 Select the Extract/Optimize tab.

4 Select the rcextract transform, and Execute. The transform 
calculates RC as the slope of the −Vc vs Ib curve, and enters 
the value in the Parameters table.

5 Close the plot.

Figure 56 Example Plotted rcflyback vcvsib Data
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Extracting the Emitter Parasitic Resistance RE

This procedure is similar to the previous one. It extracts RE, 
using the data measured with the reflyback setup. The 
measurement drives the base with a current source to negate 
the effects of the base parasitic resistance, and monitors Vc vs 
Ib with Ic at 0 amps. The measured value at Vc is therefore 
equal to Ib times RE.

1 Select the reflyback setup.

2 Select Plots > vcvsib > Display Plot. The plotted collector 
voltage is the product of the base current times the emitter 
parasitic resistance (see the following figure).

3 Select Extract/Optimize > reextract > Execute. The transform 
calculates RE as the slope of the Vc vs Ib curve, and enters 
the value in the Parameters table.

4 Close the plot.

Figure 57 Example Plotted reflyback vcvsib Data
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The Intrinsic and Extrinsic Inductances

The intrinsic inductances of high-frequency BJTs are usually 
relatively small. At the frequencies where a BJT is normally 
used, they have essentially no effect on the device model. 
Compared to extrinsic parasitic inductance values such as the 
bond inductances, the intrinsic inductance values are small 
enough that they can be ignored.

A greater effect is caused by the extrinsic bond inductances LB 
and LE. In addition, if a carrier is used that has a via hole 
connecting the emitter pad to the backside ground plane, an 
additional amount of inductance is inherent in the via. This 
parasitic inductance is LVIA: its value is added to the value of 
LE.

The next procedure records the values for LB and LE; the 
following procedure extracts LVIA where applicable.

The Bond Inductances LB and LE

For this step it is necessary that the base and emitter bond 
inductances of your device are known. For example, if you know 
the inductance per unit length of the bond wire used, you can 
calculate the total bond wire inductance. Be sure to minimize 
the bond inductances, by making the bond length as small as 
possible or the bond wire as thick as possible.

1 Scroll the Parameters table until it shows the parameters LB 
and LE.

2 Manually enter the base and emitter bond inductance values 
for your device.

Extracting LVIA and RB

In a device mounted in a carrier that has a via hole connecting 
the emitter pad to the backside ground plane, LVIA is the 
inductance of the via. RB is the zero-bias base resistance. 
NOTE If you are making on-wafer probed measurements rather than in-fixture 
measurements, you can ignore the effects of LVIA (but not of RB).
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This procedure uses data from the sparm_0v measurement to 
solve two equations. At zero bias the input of a BJT can be 
modeled as a series RLC circuit, where:

R = RE + RB
L = LE + LB + LVIA
C = CJE0

(Note that this ignores the effects of CJC0 and the BJT output 
circuit. The resultant error for a typical high-frequency device 
with an fT of >4 GHz is <10%.)

1 From the sparm_0v measurement, note the values you 
recorded for the device resonant frequency Fr and the input 
impedance R(@Fr).

2 Refer to the Parameters table for the value of RE you 
extracted earlier.

3 Use a calculator to find the value of RB by solving this 
equation: 

RB = R(@Fr) − RE

4 Manually enter the calculated value for RB in the Parameters 
table.

5 If applicable, use the previously recorded values for LB and 
LE to find the value of LVIA by solving this equation:

LVIA = [CJE ⋅ (2 ⋅ π ⋅ Fr)
2]−1 − (LB + LE)

6 Add the value of LVIA to the value of LE in the Parameters 
table, and manually enter the total into the Parameters table 
as the new value for LE.

Extracting VAR and VAF

This procedure is very iterative. The values for both VAR (the 
reverse early voltage) and VAF (the forward early voltage) are 
strongly dependent on the saturation current IS. The value of 
IS, however, is in turn strongly dependent on VAR. Therefore, 
the procedure begins with a first-pass rough extraction of IS, 
which is used in the extractions of VAR and VAF. After the 
values of VAR and VAF are extracted and optimized, IS will be 
extracted again using these values, in the next procedure.
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First Estimate of IS

1 Select the fgummel setup.

2 Do not open any plots.

3 Select Extract/Optimize > isextract > Execute. The transform 
calculates a first estimate value for IS and enters it in the 
Parameters table.

Extracting VAR

1 Select the rearly setup.

2 Select Plots > ievsvc > Display Plot. The plotted data should be 
similar to Figure 59. 

3 Select Extract/Optimize > evextract > Execute. This calculates a 
first estimate of both VAR and VAF.

4 The VAR extraction will be optimized over only the linear 
portion of the Ie trace. The next steps use the X-low/X-high 
function to select a portion of the trace.

• Select the Setup Variables tab. A variable table will appear, 
listing X_LOW and X_HIGH with their current values, as 
shown in the illustration.

• From the plotted data choose a linear portion of the Ie 
trace, along the constant slope of the saturated region (as 
illustrated by the box in Figure 59). Avoid any curved area 
at the high end of the trace. Click the mouse pointer at the 
lower and upper boundary points of the linear portion to 
make a box on the trace.

• From the plot menu select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values for this plot to 
your boundary points.

Figure 58 The rearly Setup Variables Table
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5 Select Extract/Optimize > opt_var > Execute. The transform 
converges the simulated data to the measured data in the 
plot. It calculates the value of VAR using the linear portion of 
the Ie trace you defined with X-low/X-high, and enters the 
value in the Parameters table.

Extracting VAF

This is similar to the procedure for VAR, using the fearly setup.

1 Select the fearly setup.

2 Select Plots > icvsvc > Display Plot. 

3 Use the X-low/X-high function to define a linear portion of 
the Ic trace for the extraction, as explained under “Extracting 
VAR” on page 163.

4 Select Extract/Optimize > opt_vaf > Execute. The transform 
converges the simulated data to the measured data. It 
calculates the value of VAF using the portion of the trace you 
defined, and enters the value in the Parameters table.

5 Close the plot.

Figure 59 Plotted rearly ievsvc Data for VAR Extraction
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Extracting IS, NF, BF, ISE, NE, and IKF

This procedure uses several different transforms that isolate 
and optimize the individual parameters in the regions where 
they have the most dominant effect. These forward parameters 
are all extracted using the data measured with the fgummel 
setup. Note that extractions based on the fgummel 
measurement make the assumption that Ic = −(Ie + Ib).

Initial Extraction

1 Select the fgummel setup.

2 Select Extract/Optimize > isextract > Execute to extract initial 
values for IS and NF.

3 Select fgextract > Execute to extract initial values for IKF, BF, 
ISE, and NE.

4 Select Plots > ibicvsvb > Display Plot, and nf_vs_vb > Display Plot.

5 Select Measure/Simulate > Simulate.

6 Observe the plots. The simulated data should be reasonably 
close to the measured data. If so, proceed to “Optimizing IS 
and NF.”

Table 19 Forward parameters extracted using the fgummel setup

Parameter Description

IS Transport saturation current.

NF Forward current emission coefficient (models the deviation 
of the emitter-base diode junction from the ideal).

BF Ideal maximum forward beta.

ISE Base-emitter leakage saturation current (the value of the 
base current at zero base-emitter voltage).

NE Base-emitter leakage emission coefficient (models the 
recombination of the base current in the base-emitter space 
charge region at low base-emitter voltage).

IKF Forward knee current (models the drop in forward beta at 
high collector currents due to high-level injection).
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7 If the simulated data does not match fairly well with the 
measured data, the optimizer may not converge properly. In 
this case, extract the parameters manually with the Draw 
Diag Line feature, using the “Manual Extractions” 
explanations at the end of this procedure. Then come back to 
the optimization procedures given below.

Optimizing IS and NF

This optimization is performed over a section of the Ic curve at 
medium Vbe values, avoiding the low and high current effects. 

1 Using the ibicvsvb plot (Figure 60), choose a section of the Ic 
(upper) curve at medium Vbe values. Avoid the low and high 
current effects. Alternatively, use the nf_vs_vb plot and 
choose a Vbe range where NF is reasonably flat and near 
minimum (see Figure 61).

2 Use the X-low/X-high function to define the section of the 
curve to be optimized:

• Position the pointer at the lower end of your chosen range 
and click left, then at the high end and click left. 

Figure 60 Appropriate Region of Ic for Optimization of IS and NF
IC-CAP Nonlinear Devices Models Volume 2



High-Frequency BJT (Gummel-Poon) Model 3

IC-CAP Nonlinear Devices Models V

 

• From the plot menu select Options > Copy to Variables, to 
change the X-low/X-high values to the trace limits you 
selected.

3 Select Extract/Optimize > optic_is_nf > Execute. The transform 
converges the simulated data to the measured data in the 
plot. It optimizes the values for IS and NF using the section of 
the curve you defined, and enters the values in the 
Parameters table.

Optimizing BF

1 Use the same linear section of the Ic curve as in “Optimizing 
IS and NF” on page 166. 

2 Select opt_beta > Execute. The transform optimizes the value 
for BF using the defined section of the Ic curve, and enters 
the value in the Parameters table.

Optimizing ISE and NE

This optimization is performed at the low end of the Ib curve.

1 Using the ibicvsvb plot, choose a section at the low end of the 
Ib curve where the slight bending upward of the trace 

Figure 61 Appropriate NF Region to Optimize IS and NF
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indicates the recombination in the base-emitter depletion 
region. Refer to Figure 62: the portion of the trace in the box 
is the appropriate region for optimization.

2 Use the X-low/X-high function to define the section of Ib to 
be optimized.

3 Select optib_ise_ne > Execute. The transform converges the 
simulated data to the measured, and enters the optimized 
values for ISE and NE in the Parameters table. 

Optimizing IKF

This optimization is performed at the high end of the Ib and Ic 
curves.

1 Using the ibicvsvb plot, choose a section at the high end of 
both curves where they begin to deviate from a straight line. 
Refer to Figure 63: the portion of the traces in the marked 
box is the appropriate region for optimization. Alternatively, 
look at the nf_vs_vb plot (Figure 61), and set the lower limit 
for optimization above the point where NF begins to deviate 

Figure 62 Appropriate Region of Ib for Optimization of ISE and NE
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from a straight line. The upper limits for Ic and Ib are set by 
the maximum value of Vb.

2 Use the X-low/X-high function on one of the traces, to define 
the range to be optimized.

3 Select opt_ikf > Execute. The transform converges the 
simulated data to the measured, and enters the optimized 
value for IKF in the Parameters table.

Manual Extractions (Optional)

Use these procedures only if the data simulated in “Initial 
Extraction” on page 165 does not match reasonably well with 
the measured data.

Manually Extracting IS and NF

1 Use the ibicvsvb plot. Choose a linear portion of the Ic vs Vb 
curve, avoiding the low and high current effects. Put the 
mouse pointer at the low end of the chosen portion and click 

Figure 63 Appropriate Region of Ib and Ic for Optimization of IKF
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left, then put the pointer at the high end and click left, to 
make a box on the trace.

2 From the plot menu select Options > Draw Diag Line. A diagonal 
line is drawn on the plot that extends the linear portion you 
chose to the boundaries of the plot (see the following figure 
for an example). Annotations below the plot give the values 
for:

Slope of the diagonal line
Yo, the y-axis intercept of the diagonal line
Xo, the x-axis intercept of the diagonal line

3 Manually enter the Yo value into the Parameters table as the 
value for IS.

4 Solve the following equation (using a calculator) to 
determine the value of NF. Note that this equation is only 
valid up to high injection effects.

Figure 64 Manual Extraction of IS and NF Using Draw Diag Line

NF
1
VT
-------

d loge Ic( )⋅

d Vbe⋅-----------------------------
1

VAR VBE–
-----------------------------–

1–
=
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where:

and:

elementary charge q = 1.60218 ⋅ 10−19

Planck’s constant k = 1.38066 ⋅ 10−23

temperature T = TNOM + 273.15

5 Manually enter the NF value in the Parameters table.

Manually Extracting BF

1 Using the ibicvsvb plot, pick a value of Vb in the linear 
portion of the Ib and Ic curves where the curves are as close 
as possible to parallel. The following figure shows an 
example.

 where both Ic and Ib are measured at the same Vb.

Figure 65 Manual Extraction of BF

VT
kT
q

------=

BF
Ic
Ib
-----=
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2 To determine the value of Ic at the chosen value of Vb, 
position the pointer on the trace at that value, and click 
middle to get a readout of the value at that point.

3 Repeat for Ib.

4 Subtract the logarithmic value of Ib from the logarithmic 
value of Ic to get the value of BF.

5 Manually enter the value of BF in the Parameters table.

Manually Extracting ISE and NE

1 Using the ibicvsvb plot, choose a linear portion at the low 
end of the Ib vs Vb curve, where the slight bending upward of 
the trace indicates the recombination in the base-emitter 
depletion region.

2 Use the Draw Diag Line feature to extrapolate the linear 
portion to the boundaries of the plot (the following figure 
shows an example).

3 Read the Yo value from the annotations below the plot, and 
manually enter it in the Parameters table as the value for 
ISE.

Figure 66 Manual Extraction of ISE Using Draw Diag Line
IC-CAP Nonlinear Devices Models Volume 2



High-Frequency BJT (Gummel-Poon) Model 3

IC-CAP Nonlinear Devices Models V

 

4 Use a calculator to solve the following equation for NE. Note 
that this equation is only valid at low Vbe values where 
recombination takes place in the base-emitter space charge 
region.

where: 

and:

elementary charge q = 1.60218 ⋅ 10−19

Planck’s constant k = 1.38066 ⋅ 10−23

temperature T = TNOM + 273.15

5 Manually enter the NE value in the Parameters table.

Manually Extracting IKF

A hardcopy plot is used for this procedure.

1 Choose File > Print from the ibicvsvb plot, to obtain a 
hardcopy of the plot.

2 Manually draw a diagonal line along the linear portion of the 
Ic curve in the medium range of Vbe. Extend the line beyond 
the trace at the top end, as illustrated.

3 Draw another diagonal line along the upper range of Ic where 
the high-level effects begin to dominate. Extend the low end 
of the diagonal line so that it intersects the first diagonal line, 
as in the following figure.

4 IKF is the value of IC at the intersection of the two diagonal 
lines. Put the mouse pointer on the trace at this point, and 
click middle to get a readout of the value.

5 Manually enter the value of IKF in the Parameters table.

NE
1
VT
-------

d VBE⋅
d loge( ) IB( )⋅----------------------------------=

VT
kT
q

------=
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Verifying the Manual Extractions

1 Select Measure/Simulate > Simulate.

2 Observe the ibicvsvb plot. The simulated and measured data 
should now be very close.

3 Now go back to “Optimizing IS and NF” on page 166. Perform 
that and the subsequent three procedures for optimizing BF, 
ISE and NE, and IKF. 

4 Close the ibicvsvb plot.

Extracting NR, BR, ISC, NC, and IKR

The procedure for extracting these reverse parameters 
corresponds closely to the last procedure for extracting the 
forward parameters. The main differences are that IS is not 
extracted in the reverse direction, and that the rgummel data is 
used in place of the fgummel. As in the forward gummel 
extractions, this procedure uses several different transforms 
that isolate and optimize the individual parameters in the 
regions where they are most dominant. Note that extractions 
based on the rgummel measurement make the assumption that 
Ie = −(Ic + Ib).

Figure 67 Manually Extracting IKF 
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Initial Extraction

1 Select the rgummel setup.

2 Select Extract/Optimize > nrextract > Execute to extract the 
initial value for NR.

3 Select rgextract > Execute to extract initial values for BR, ISC, 
NC, and IKR.

4 Select Plots > ibievsvc > Display Plot.

5 Select Measure/Simulate > Simulate.

6 Observe the ibievsvc plot. The simulated data should be 
reasonably close to the measured data. If so, proceed to 
“Optimizing NR.”

7 If the simulated data does not match fairly well with the 
measured data, the optimizer may not converge properly. In 
this case, extract the parameters manually with the Draw 
Diag Line feature, as explained for the forward gummel 
parameters under “Manual Extractions (Optional)” on 
page 169. Then come back to the optimization procedures 
given below.

Table 20 Reverse parameters extracted using the rgummel setup

Parameter Description

NR Reverse current emission coefficient (models the deviation 
of the collector-base diode junction from the ideal).

BR Ideal maximum reverse beta. 

ISC Base-collector leakage saturation current (the value of the 
base current at zero base-collector voltage).

NC Base-collector leakage emission coefficient (models the 
recombination of the base current in the base-collector 
space charge region at low base-collector voltages).

IKR Reverse knee current (models the drop in reverse beta at 
high emitter currents due to high-level injection).
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Optimizing NR

This optimization is performed over a section of the Nr curve at 
medium Vce values, avoiding the low and high current effects.

1 Select Plots > nr_vs_vc > Display Plot.

2 Choose a linear section of the curve at medium Vce values, as 
shown in the following figure. Avoid the low and high current 
effects. 

3 Use the X-low/X-high function to define the section of the 
curve to be optimized:

• Position the mouse pointer at the low end of your chosen 
range and click left, then at the high end and click left.

• From the plot menu select Options > Copy to Variables, to 
change the X-low/X-high values to the trace limits you 
selected.

4 Select Extract/Optimize > optie_nr > Execute. Observe the 
ibievsvc plot (Figure 69) to see the simulated Ib and Ie data 
converge to the measured data. The transform optimizes the 
value for NR using the section of the trace you defined, and 
enters it in the Parameters table. 

Figure 68 Appropriate Region of Trace for Optimization of NR
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Optimizing BR

1 Use the same linear section of the trace as in “Optimizing NR” 
on page 176.

2 Select opt_beta > Execute. The transform optimizes the value 
for BR using the defined section of the trace, and enters the 
value in the Parameters table.

Optimizing ISC and NC

This optimization is performed at the low end of the curve.

1 Using the nr_vs_vc plot, choose a section at the low end of 
the curve, as in the following figure. If possible, look for a 

Figure 69 Measured and Simulated Ib and Ie Data, Well Converged
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transitional area where the slope begins to change, indicating 
the recombination in the base-collector space charge region.

2 Use the X-low/X-high function to define the section of the 
curve to be optimized.

3 Select optib_isc_nc > Execute. The transform converges the 
simulated data to the measured, and enters the optimized 
values for ISC and NC in the Parameters table.

Optimizing IKR

This optimization is performed over the upper portion of the Nr 
curve. 

1 Using the nr_vs_vc plot, choose a section at the high end of 
the measured curve starting with the transitional area where 
the slope begins to change. Refer to Figure 71: the portion of 
the trace in the box is the appropriate region for 

Figure 70 Appropriate Region of Curve for Optimization of ISC and NC
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optimization; the upper limit is set by the maximum value of 
Vc.

2 Use the X-low/X-high function to define the section of the 
trace to be optimized.

3 Select optie_ikr > Execute. The transform converges the 
simulated data to the measured, and enters the optimized 
value for IKR in the Parameters table.

4 Close the plots.

Figure 71 Appropriate Region of Trace for Optimization of IKR
Verifying the Predicted DC Performance
All the DC parameters have now been extracted. Before you 
proceed to the AC parameter extractions, it is important to 
verify that the extracted parameters do indeed predict the DC 
performance of the device. The AC performance of the device, 
and hence the AC extractions, are strongly dependent on the 
accuracy of the DC parameters.
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Comparing the Measured and Resimulated fearly Data

1 Select the fearly setup.

2 Select Plots > icvsvc > Display Plot.

3 Select Measure/Simulate > Simulate.

4 Observe the plot. The resimulated data using the new 
parameters should be almost indistinguishable from the 
measured data. 

5 Close the plot.

Comparing the Measured and Resimulated rearly Data

1 Select the rearly setup.

2 Select Plots > ievsve > Display Plot.

3 Select Measure/Simulate > Simulate.

4 Observe the plot. Due to the non-reciprocal nature of the 
base-emitter and base-collector junctions, the current levels 
of the measured and simulated rearly data will not coincide. 
SPICE assumes that the saturation current IS is identical for 
both junctions: since this is not in reality the case, it is 
seldom possible to have both the fearly and rearly data match 
simultaneously. However, the slope of the Ic vs Vce curve 
beyond saturation is independent of IS, and therefore the 
measured and simulated slopes should match in this region.

5 Close the plot.

Comparing the Measured and Resimulated fgummel Data

1 Select the fgummel setup.

2 Select Plots > ibicvsvb > Display Plot.

3 Select Measure/Simulate > Simulate.

4 Observe the plot. Even though the equations describing the 
forward gummel data are dominated by the forward gummel 
parameters, the reverse parameters do also have an effect. 
Therefore check that the forward gummel data resimulated 
using the new parameters still closely matches the measured 
data. 

5 Close the plot.
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Modifying the DC Parameters

You may obtain unexpected results from your comparisons 
between measured DC data and data resimulated using the new 
parameters. In this case, you might choose to make minor 
changes in the values of one or more parameters, to more 
closely match the simulated data to the measured data. If you 
do this, it is important that you check all the DC simulations, 
and modify other parameters if necessary, to compensate. This 
cycle must be continued until all simulations are acceptable, 
and you will probably have to make some trade-offs in the 
process. You will need to exercise judgment based on your 
knowledge of device physics and the particular device under 
test. 
AC Extractions
 

The AC performance of the device, and hence the AC 
extractions, are strongly dependent on the accuracy of the DC 
parameters. It is essential that the DC parameters and the 
parasitic capacitance and resistance parameters are known to 
be good, before the AC extractions are done. If you have any 
doubts about the validity of these parameters, continue to 
refine the DC extractions before proceeding with the AC 
extractions.

Setting Initial Values for FC and XCJC

The final values for FC and XCJC will be extracted after the 
other AC parameters have been determined. Because FC and 
XCJC have an effect on the overall AC performance of the 
device, initial values are assigned to them before extraction of 
the other parameters.

• If you know the values of FC and XCJC for your device, enter 
those values into the Parameters table.

• If you do not know the values of FC and XCJC for your 
device, enter the value of FC as 0.5, and the value of XCJC as 
0.7.
olume 2 181



182

3 High-Frequency BJT (Gummel-Poon) Model
 

Extracting High-Frequency Transit Time Parameters 

This procedure uses several different transforms to optimize the 
individual parameters in the regions where they have the most 
dominant effect. The parameters are extracted using both the 
h21vsvbe and ftic setups. 

Initial Extraction

1 Select the h21vsvbe setup.

2 Select Measure/Simulate > Simulate.

3 Select the ftic setup.

4 Select Plots > ft_ic > Display Plot.

5 Select Extract/Optimize > Ft > Execute to draw the Ft vs Ic data 
on the plot.

6 Select AC_decoupled > Execute. The transform calculates the 
values for TF, XTF, VTF, and ITF, and enters them in the 
Parameters table.

7 If the simulated curves do not converge closely to the 
measured curves, you can perform manual optimization 
procedures using the h21vsvbe setup, starting on the next 
page. The procedures make iterative changes to the values in 
the Parameters table to obtain a best fit of the simulated 
curves to the measured curves.

8 Close the ft_ic plot.

Table 21 Parameters extracted using the h21vsvbe and ftic setups

Parameter Description

TF Ideal forward transit time (models the finite bandwidth of 
the device in forward mode).

XTF Bias-dependence coefficient of TF (models the minimum 
value of TF at low Vce and high Ic).

VTF Voltage describing the dependence of TF on Vbc (models 
the effects of Vbc on TF).

ITF High-current parameter effect on TF (models the decline of 
TF with high Ic).
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Optimizing TF and VTF

This is an iterative process that optimizes the convergence of 
the simulated data at the peaks of the curves. TF sets the height 
of both peak values of Ft (the peaks of both Vce curves). VTF 
sets the separation between the two curves at their peak Ft 
value.

1 Select Model Parameters. In the Parameters table, modify the 
values of both TF and VTF. These are “first guess” value 
changes that will be modified iteratively until you achieve 
acceptable results.

2 Select DUT/Setups > h21vsvbe.

3 Select Plots > h21_vbe > Display Plot.

4 Select Measure/Simulate > Simulate.

5 Observe the plot. The simulated curves should match the 
measured curves reasonably well at the peaks of both Vce 
curves, as in the following figure.

6 If not, repeat the above steps as necessary to modify the TF 
and VTF values and resimulate, until the simulated and 

Figure 72 Measured and Simulated Vce Curves (Ft vs Ic)
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measured curves at both values of Vce are close at the point 
where Ft is maximum.

7 Do not close the plot.

Optimizing ITF

This is an iterative process that optimizes the simulated data for 
the high end of the Ic curves. ITF predominantly affects the high 
Ic roll-off of the lower Vce curve, and also has an appreciable 
effect on the higher Vce curve.

1 In the Parameters table, modify the value of ITF. This is a 
“first-guess” value change.

2 Select the h21vsvbe setup.

3 Select Measure/Simulate > Simulate.

4 Observe the ft_ic plot from the ftic setup. The simulated 
curves should match the measured curves reasonably well in 
the region of high Ic roll-off.

5 If not, repeat as necessary to improve the convergence of the 
simulated data to the measured data in the region of high Ic 
roll-off, especially in the lower curve.

Optimizing XTF

This optimizes the convergence of the simulated data for the 
upper Vce curve. XTF value changes should be minimal.

1 After ITF is set, sparingly modify the value of XTF in the 
Parameters table.

2 In the h21vsvbe setup select Measure/Simulate > Simulate.

3 Observe the ft_ic plot. The upper simulated Vce curve should 
converge to the upper measured curve.

4 If not, repeat as necessary until the curves converge.

5 Close the ft_ic plot.
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Extracting PTF

This procedure uses the H21 magnitude data measured in the 
sparm_bias setup to determine the value of PTF, the excess 
phase of TF (which is also the value of excess phase at Ft).

1 Select the sparm_bias setup.

2 Select Plots > db_h21 > Display Plot.

3 In the db_h21 plot, find the highest frequency where the H21 
magnitude is 0 dB (see the following figure). If necessary, use 
the Draw Diag Line feature to extend the highest Vbe curve 
through the 0 dB line.

4 Position the pointer on the trace at this point and click 
middle to get a readout of the values. The frequency (x-axis 
value) at that point is Ft.

5 Select the ph_h21 plot, and Display Plot. Figure 74 illustrates a 
typical H21 phase plot.

6 Find the location of Ft on the ph_h21 plot. Put the mouse 
pointer on the trace at this point and click middle to get a 
readout of the phase value. 

Solve for PTF by subtracting 90° from the phase of H21 at Ft:

Figure 73 Determining Ft. Example Plot of H21 Magnitude
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PTF (degrees) = |phase of H21 @ Ft| −90

7 Manually enter the calculated value of PTF in the Parameters 
table.

8 Close the plots.

Extracting IRB and RBM

This procedure uses the S11 data measured in the sparm_bias 
setup to extract the following parameters:

Figure 74 Typical Plot of H21 Phase, with Location of Ft
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1 In the sparm_bias setup, select the s11 plot, and Display Plot.

2 Select Measure/Simulate > Simulate. Observe the high-bias S11 
curve on the plot. If the measured and simulated values agree 
at the resonant frequency (where the S11 curve crosses the 
real axis), no adjustment of RBM is needed. If the high-bias 
S11 curve does not cross the real axis, visually extrapolate to 
see where it would cross the real axis if it were extended: if 
measured and simulated values agree no adjustment of RBM 
is needed.

3 If the high-bias measured and simulated S11 values do not 
agree at the resonant frequency (or the extrapolated 
resonant frequency), modify the value of RBM in the 
Parameters table. This is a “first guess” value change.

4 Select Measure/Simulate > Simulate.

5 Continue to modify the value of RBM and resimulate until 
the measured and simulated values of S11 do agree at the 
resonant frequency.

6 Observe the medium-bias S11 curve on the plot. If the 
measured and simulated values agree at the resonant 
frequency, no adjustment of IRB is needed.

7 If the medium-bias measured and simulated S11 values do 
not agree at the resonant frequency, modify the value of IRB 
in the Parameters table and resimulate.

8 Continue to modify the value of IRB and resimulate until the 
measured and simulated values do agree at the resonant 
frequency.

9 The simulated low-bias S11 curve depends mainly on the 
value of RB extracted earlier, and should therefore already 
agree with the measured value.

Table 22 Parameters extracted using the sparm_bias setup

Parameter Description

IRB Current where the base resistance falls halfway to its 
minimum value from its zero-bias value RB.

RBM Minimum base resistance at high currents (models the 
effects of current crowding on the base resistance).
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10 Close the s11 plot.

Extracting CC

This procedure uses the S22 data measured in the sparm_bias 
setup to extract CC, the parasitic capacitance at the output of 
the device. This represents the capacitance between ground and 
the pad on which the device is epoxied, as well as any other 
stray capacitance to ground. This value is very difficult if not 
impossible to measure directly, therefore its value is determined 
indirectly using the following method.

1 In the sparm_bias setup select the s22 plot, and Display Plot.

2 If the maximum frequency points (end points) of the 
measured and simulated S22 curves are comparable in value, 
no adjustment of CC is needed.

3 If the maximum frequency points of the measured and 
simulated S22 curves are not comparable in value, modify the 
value of CC in the Parameters table. This is a “first-guess” 
value change.

4 Select Measure/Simulate > Simulate.

5 Continue to modify the value of CC and resimulate until the 
maximum frequency points of the measured and simulated 
curves are comparable in value.

Extracting FC

This procedure uses the data measured in the ftic setup to 
extract FC, the coefficient for forward bias capacitance. The S11 
data measured in the sparm_bias setup is also used to verify the 
value of FC.

FC models the continuity between the forward and reverse bias 
base-emitter capacitance. Therefore it has the most effect at the 
low end of the Vbe curves, in the region dominated by junction 
capacitances where the base-emitter junction capacitance is 
comparable to the forward diffusion capacitance.

1 Select the ftic setup.

2 Select Plots > ft_ic > Display Plot.
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3 The simulated data should match the measured data 
reasonably well at the low end of the curves, in the region 
indicated in the following figure.

4 If the simulated data does not match the measured data in 
the indicated region, modify the value of FC in the 
Parameters table.

5 Select Measure/Simulate > Simulate.

6 Continue to modify the value of FC and resimulate until the 
simulated data converges to the measured data in the 
indicated region.

7 Select the sparm_bias setup.

8 Select Plots > s11 > Display Plot.

9 Check the convergence of the simulated to measured S11 
curves in the low-bias region. If they are well converged, this 
verifies that the extracted value of FC is good.

10 Leave the s11 plot open.

Figure 75 Region of Curves Where Junction Capacitances Dominate
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Extracting XCJC

This procedure uses the S11 and S22 data measured in the 
sparm_bias setup to extract XCJC, the fraction of base-collector 
capacitance connected to the internal base node. XCJC models 
the distributed effects of the base-collector junction. The effects 
are typically only noticeable at high frequencies.

1 In the sparm_bias setup select the s22 plot, and Display Plot.

2 The simulated data should match the measured data at the 
higher frequencies.

3 If not, modify the value of XCJC in the Parameters table.

4 Select Measure/Simulate > Simulate.

5 Repeat as necessary to improve the convergence of the 
simulated to measured S11 and S22 curves at the higher 
frequencies.
Final Parameter Adjustments
All the BJT parameters have now been extracted. To verify the 
accuracy of the AC parameters, now resimulate all the AC 
setups using the final parameters. It may be necessary to make 
minor modifications to one or more of the parameters to 
achieve a better fit between the simulated and measured data. 
This is a somewhat nebulous task: the following instructions are 
guidelines that try to provide some structure. None of the 
parameters should require more that slight adjustment: if any of 
them do, some of the parameter values may be suspect. 

Recall that the DC, capacitance, and parasitic resistance 
parameters have a significant influence on the simulated AC 
performance of the device. Therefore, if it is difficult or 
impossible to find AC parameters that adequately predict the 
AC performance, it may be necessary to modify some or all of 
these parameters. Note that, because of the inherent interaction 
between parameters, any change to one usually requires the 
modification of many. If too many parameters need to be 
modified by too much, it may be advisable to start the 
extraction process over.
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LE, LB and LVIA

Use the S-parameter plots in the sparm_bias setup, starting 
with s11. Cautiously adjust the values of these parameters in 
the Parameters table and resimulate, until the simulated 
S-parameter curves match the measured ones. The values of the 
parasitic inductance parameters vary the length of the curves, 
particularly the S11 curves. This is because of the BF+1 factor 
in the impedance transformation from emitter to base, which 
causes the inductances at the emitter to have much more of an 
effect on the input impedance, and consequently on S11.

RC

Use the s22 plot in the sparm_bias setup. Cautiously adjust the 
value of RC in the Parameters table and resimulate, until the 
simulated S22 curves match the measured ones. The effect of 
RC is most prominent at the high-frequency end of the S22 
curves. Varying RC affects the loss of S22, therefore the value of 
RC can be adjusted until the high-frequency ends of the 
simulated and measured S22 curves line up.

TF

Use the h21_vbe plot in the h21vsvbe setup. Adjust the value of 
TF in the Parameters table and resimulate, to improve the 
match between the peaks of the simulated and measured 
curves.

XCJC and FC

The requirements for extracting these parameters are less rigid 
than for other more explicitly defined parameters. Therefore, 
you can modify either or both of these values in the Parameters 
table to adjust the overall simulated AC performance if 
necessary.

RE

Use the s11 plot in the sparm_bias setup. Although RE has been 
determined through the DC extraction using the reflyback data, 
you may need to adjust its value slightly to accommodate the AC 
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performance. You can do this by monitoring the simulated loss 
in the S11 curves. Note that in a fashion identical to LE the 
effect of RE on the input impedance is increased by the factor 
BF+1. This results in S11 being very sensitive to RE, especially 
at bias values where BF is large. Be very careful when you 
adjust this parameter!

IS and NF

Be particularly careful here. These two parameters have a 
dramatic effect on the overall performance of the device. If, 
during the course of fine-tuning the final parameter values, you 
decide to adjust either IS or NF, you will need to perform the 
extraction process again, based on the new values for IS and NF.
Storing the Model
This procedure stores the model in IC-CAP, including all the 
device-specific measured and simulated data. Once you have 
developed the device model, it can be used as a component in 
the Agilent RF and Microwave Design System (MDS). You can 
use it for circuit simulation, inserting it into circuits under 
design to emulate the characteristics of your device. 

If you will be modeling large numbers of devices, it is 
worthwhile to organize your directory structure according to 
device type, geometry, and batch or wafer.

1 Use the directory you created at the beginning of the 
procedure, when you first opened the bjt_ncehf.mdl file.

2 From the bjt_ncehf:1 main menu select File > Save As.

3 A dialog box is displayed, as illustrated.
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4 Select the File Type (.mdl for a complete model) by clicking 
the corresponding radio button.

5 Select a new filename that associates this model with the 
device, for example bjt3.mdl. Type the full directory 
pathname and the filename into the dialog box. Select OK to 
store the data and close the dialog box.

Figure 76 Save As Dialog Box
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Agilent Root MOSFET Model Generator

Model Description 196

Getting Started in IC-CAP 198

Using the Agilent Root MOS Model 201

This chapter documents the Agilent 85194B Agilent Root 
MOSFET model generator software. It provides an example 
procedure that takes you step-by-step through a complete data 
acquisition and model generation.

The complete procedure includes all the instructions needed to 
generate a new device model by modifying variable values in 
macros and factory default tables. After you have set these 
variables, subsequent measurement and model generation 
procedures are much faster. 
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The Agilent Root MOSFET model applies to MOS devices the 
same database modeling principles as those used in the Root 
FET model. This three-terminal model can be applied to 
vertical, LD, and power MOS devices, where substrate effects do 
not need to be a part of the model. It can be used for both NMOS 
and PMOS devices. As with the Root FET model, the Root MOS 
model is generated from small-signal S-parameters measured at 
numerous bias points over the entire operating current-voltage 
(IV) plane.

Based on current and power dissipation device compliances you 
provide in software, the data acquisition system calculates the 
safe operating range for the device. Within this region, the 
model takes data adaptively at multiple bias points, depending 
on the specific nonlinearities of the device. Measurements are 
densely spaced in the most nonlinear regions, such as at the 
knees of the IV curves and the onset of breakdown, and less 
densely spaced in linear regions.

The data set of internodal nonlinear current and charge 
components at each bias point is then mathematically generated 
and stored. The model is thus generated without the usual need 
for simulation and optimization as required by all previous 
empirical models. The Root MOS model may thus capture 
nonlinear device behavior for any MOSFET device for which 
measured data can be taken but for which there are no good 
physical or empirical models.

The data acquisition system sets the DC bias levels and controls 
the system hardware to take the DC and S-parameter 
measurements, based on your inputs. The model generator 
processes the measured data and generates the lookup tables 
required by a circuit simulator. It produces data files that are 
directly readable by the Agilent RF and Microwave Design 
System (MDS). Both IC-CAP and MDS can be run 
simultaneously in the X Windows environment. During a 
simulation, the tabular state-function data from the generated 
Agilent Root MOS model is interpolated using multidimensional 
spline functions to emulate the terminal characteristics of the 
device.
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The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP.
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This example procedure assumes the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename the SMUs to correspond with the MOSFET terminals

Rename a medium-power SMU such as MPSMU1 as VG (gate 
supply)

Rename a high-power SMU such as HPSMU3 as VD (drain 
supply)

Rename the GNDU unit (which must be connected to the 
device source) as GND
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on opening the IC-CAP software and accessing the model file 
you need. The default path name and filename for the Agilent 
Root MOS model file used as a starting point in these 
procedures is:

/examples/model_files/mosfet/HPRootMos.mdl

Then return to this chapter and continue with the procedure.
NOTE Do not install the device yet. The procedure will instruct you to install it 
after extracting the measurement port resistances.
 

Before you continue with the IC-CAP procedure, make a new 
directory in an appropriate location in the UNIX structure, 
using the mkdir command, to store the data and model files that 
will be generated. Give the directory a name that will associate 
it with the device you are going to model. Use the cd command 
to change to the new directory in UNIX.

MNS Link

The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP. The link 
is set up for MDS version B.07.00, and will need to be modified 
whenever MDS is updated. For the link to work, the path and 
environment variables need to be set correctly. This is done at 
the factory for the path and environment of a typical MDS 
B.07.00 system. Only minor changes to reflect unusual MDS 
paths or updated MDS versions are likely to be required. If you 
do need to modify your UNIX files to reset the MNS link, follow 
these steps to set the root MDS directory on your system and 
add $MDSROOT/mdsbin to the path:
olume 2 199



200

4 Agilent Root MOSFET Model Generator
 

For shell or kshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory to automatically set 
the environment variables:

MDSROOT=/mds_b.07.00 (depending on the version and 
location of MDS)
export MDSROOT
PATH=$MDSROOT/mdsbin: “$PATH”
export PATH

2 Also add a line similar to the following to the usersimulators 
file in /usr/iccap/lib, so that IC-CAP recognizes the MNS 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” 
CANNOT_PIPE

For cshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory:

#Setup for mns simulator:

setenv MDSROOT /mds_b.07.00
setenv PATH $MDSROOT/mdsbin: “$PATH”

2 Add a line similar to the following to the usersimulators file 
in /usr/iccap/lib, so that IC-CAP recognizes the MNS 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” 
CANNOT_PIPE
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This chapter provides an example procedure that takes you 
step-by-step through a measurement and model generation of 
an NMOS device. Values you use in generating your own device 
model will depend on the particular characteristics of your 
device: use its data sheet (if available) as a reference.

This example is provided as a starting point. It is a 
straightforward procedure that uses only a subset of IC-CAP’s 
total capabilities. The complete procedure documented gives all 
the steps necessary to configure IC-CAP with the parameters 
for preverification measurements, parasitic extractions, and the 
main data acquisition. Once a model has been developed for a 
particular device type, the built-in scaling feature allows you to 
apply it to any device with the same process and a different 
total gate width and/or number of fingers. The modeling 
procedure then becomes more simple, and can be accomplished 
in a few easy steps.
 

NOTE Although you will modify the variable values in factory default files during 
this procedure, do not under any circumstances change the names of any 
variables or setups. These names are used by the software in the data 
acquisition and model generation process.

NOTE The example procedure measures the MOSFET under test in a 
common-source configuration.
The example procedure gives detailed instructions on how to:

• Initialize device parameters.

• Measure and extract the system measurement port series 
resistances.

• Make a DC measurement to preverify device DC 
performance.

• Calibrate the network analyzer for both swept and CW 
measurements.
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• Make an S-parameter measurement to preverify device 
performance at high frequencies. 

• Measure and extract the device parasitic resistances.

• Set up and initiate the main data acquisition. Plot the 
measured data.

• Set up and initiate the model generation. Plot the calculated 
state functions.

• Verify the model against measured data.

• Store the data and model files for circuit simulation in 
Agilent MDS.
NOTE Measurement parameters and measured data are specific to individual 
devices. Information and data are provided here as examples and 
guidelines, and are not intended to represent the only correct results.
The procedure provides guidelines on setting values to measure 
your device. However, the values you use will be based on your 
knowledge of your device and on information in its data sheet, 
as well as on the guidelines presented here: they may or may not 
correspond with the example values.

The illustrations of plotted data are provided as visual examples 
of possible results. They are not intended to represent a single 
device, nor do they necessarily correspond with the values 
given in the procedure. The plots can be used to check the 
reasonableness of your own data, which should appear similar 
in shape but not necessarily coincident in values.
The DUT and Setups
The Model window is the central access point for all the 
procedures in the measurement and model generation process. 
The Model window includes the DUT/Setup panel and the file 
tabs to access the Model Parameters table, the model variable 
table, and other needed IC-CAP features.

The illustration shows the DUT/Setup panel for the model 
generator file HPRootMos.mdl. The DUTs (for example 
pre_verify) indicated by the inverted triangles are groupings of 
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similar measurement setups used to make related 
measurements or extract related model parameters. The setups 
(for example idvd_vg) contain the information used to define 
the inputs and outputs for each measurement and extraction, as 
well as the measurement hardware configurations and the 
transforms and plots associated with each setup.

Figure 77 Agilent Root MOSFET DUT/Setup Panel
Initializing Device Parameters
You begin the procedure by giving the device an identifying 
name, and entering the number of fingers and gate width. For 
this you use the init_parameters macro. When this macro is 
executed, it also initializes internal program functions that are 
essential in the model generation process, and it provides 
annotations for the data plots. (IC-CAP macros are used to 
combine or simplify operations.)

1 Click the Macros tab to display the macro names.

2 From the Select Macro list, select init_parameters, and Execute.

3 In the dialog box that appears, enter a name to identify the 
device under test, then click OK or press Return.

4 In the next dialog box, enter the number of gate fingers.

5 Next enter the gate width in meters.
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6 The next dialog box prompts you for a directory name. Click 
OK to store the model files in the directory shown, enter the 
name of another existing directory. Click OK or press Return.

7 The macro is executed, and the values you selected are 
entered in the model variable table. You can open the table by 
clicking on the Model Variables tab.
NOTE Do not edit the init_parameters macro. The macro includes executable 
code; modifying it can cause problems in the program.
Setting the Extraction Frequency

You use the model variable table to set the frequency at which 
the model will be generated. To edit the variable table, move the 
mouse pointer to the appropriate variable value, click left, and 
move the pointer over the old information to highlight it. Then 
type in the new value over the old.

1 Enter the CW frequency you intend to use for the data 
acquisition and model generation. This must be the same as 
the frequency of the network analyzer CW calibration you 
will perform before doing any S-parameter measurements. 

Figure 78 Model Variable Table
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Refer to the explanation under “Calibrating the Network 
Analyzer” on page 214, which explains how to perform a CW 
calibration and how to decide the CW frequency.

2 Make sure the Value listed for SIMULATOR in the model 
variable table is mns, to ensure that the mns link is in place 
to allow verification of the model in IC-CAP. 

3 Do not change the other values in the table at this time.

Values in the Parameters Table

The illustration shows the Model Parameters table, with the 
initial values for the extrinsic parasitic capacitances and 
inductances. The table is presented here so that you can enter 
values for these extrinsic parasitics based on your knowledge of 
the device, or on estimates, or on measurements of the open 
fixture. In addition, you can set limits by entering minimum and 
maximum values for each parameter. Parameter values that are 
outside their limits are clamped to their minimum or maximum 
values.

To access the Parameters table, click on the Model Parameters 
tab.

To change a value in the Parameters table, move the mouse 
pointer over the current entry and click left to highlight it, then 
type in a new value.

Figure 79 Model Parameters Table
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The default for all the c values is 0.000. A reasonable 
capacitance value to enter for a pad on a wafer might be 50 fF.

The l_ext.l values are the bond inductances for the three 
terminals. The default value for all three is 0.000. If you know or 
can estimate the bond inductances for your device based on 
wire length or grid size, enter appropriate values.
Extracting the Measurement Port Series Resistances
This procedure need be performed only following initial 
installation of the system or if changes are made in the system 
hardware.

The procedure measures a short circuit at the normal device 
measurement interface plane. IC-CAP controls the DC 
source/monitor to force a gate current and monitor the gate 
voltage. The primary measurement is at port 1, and the port 2 
measurement is synchronized to the port 1 measurement. You 
set the measurement parameters by defining the instrument 
state and the DC input values, as explained in the next pages.

The software calculates the series resistances from the outputs 
of the bias networks to the inputs of the device under test. The 
resistance values are then incorporated into the model file, and 
their effects are removed from the device response during the 
modeling process. The default port resistance for both port 1 
and port 2 is 0Ω.

Note that the first part of the procedure differs for probe station 
and in-fixture measurements.

Setting Up for the Measurement

1 If you are using a probe station, position an impedance 
standard substrate (ISS) on the chuck. Place both the port 1 
and port 2 probes on a short circuit standard. 

2 If you are using a fixture, insert the short from the in-fixture 
calibration kit.

3 From the DUT/Setup panel select the r_series setup.
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Set Integ Time to M (medium). Then return to this chapter and 
continue.

Setting the r_series Inputs

Use the following guidelines to set the ig and id inputs (most 
will not need to be changed from the default settings):

Table 23 For the ig input

Set To

Mode I

To Node G (gate)

From Node GROUND

Compliance as high as 5 to 10V, because the device is not yet connected

Start, Stop values that define a current range within the limits of the 
bias network

# of Points a value sufficient to make several measurements across the 
current range

The Step Size will be set automatically
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• The Unit name must match the name of the SMU connected 
to the device gate (probably VG). This is also the SMU unit 
name set in the hardware window. Refer to the appropriate 
chapter as follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

• With a current input, compliance refers to voltage. 
CAUTION The bias networks can be destroyed if IC-CAP measurement current 
values are set too high! Be sure you know the maximum current 
ratings of your bias networks, and do not set current values beyond 
these limits. (The standard bias networks for the Agilent 85122A and 
85123A parameter extraction test systems are rated at 0.5 amp.)
• The Outputs are factory set, and should not be changed.

Table 24 For the id input

Set To

Mode I

To Node D (drain)

From Node GROUND

Unit VD

Compliance the same as for ig

Sweep Type SYNC

Ratio 1.000, so that the id sweep is synchronized to the ig sweep

Offset 0.0

Master Sweep ig, so that the id sweep is synchronized to the ig sweep
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Measuring and Extracting the Port Series Resistance Values

1 Under Measure/Simulate select Measure.

2 When the measurement is complete, the Measuring light on 
the DC source/monitor goes out and the IC-CAP wristwatch 
icon goes away.

3 Select the Extract/Optimize tab.

4 Select compute_rseries > Execute. The transform calculates the 
port series resistances from the measured data and enters 
the values into the model variable table as r1s and r2s.
Installing the Device

CAUTION Ground yourself with an antistatic wrist strap to reduce the chance of 
electrostatic discharge. (Note that the Agilent 85122 or 85123 system 
work surface is coated with antistatic material and is connected to 
chassis ground, therefore a static mat is not required.)
 

Install the device carefully on the probe chuck or in the fixture. 
Be sure to handle the device as little as possible, to avoid 
damaging it. Once the device is in place, avoid bumping the test 
station.
Preverifying the Device DC Data

CAUTION Remove any high-intensity light sources such as microscope light 
before taking a measurement. One simple method of blocking light is to 
place an opaque box on the fixture directly above the device.
This procedure uses the idvd_vg setup to measure drain current 
and gate current with respect to drain voltage, at several values 
of gate voltage. The drain voltage is swept from 0V to the upper 
limit of its normal operating range. This is an opportunity to 
take a first look at the device performance and explore its 
characteristics. This also lets you select the most appropriate 
measurement range for the main data acquisition and other 
measurements.
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In addition, this is a quick way to verify that the device DC 
characteristics are good, before starting a complete data 
acquisition and modeling generation. The data from this 
measurement can also be used for later comparison with data 
predicted by the generated model. It is not necessary to do the 
preverification measurement every time you perform a model 
generation, especially if you are using a data sheet.

Device Configuration: The input values you set in this 
procedure configure the device as shown in the following figure.

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the r_series measurement. 
Use the same settings.

Then return to this chapter and continue.

Setting the idvd_vg Inputs

This procedure defines the input signals to be applied to the 
device under test for the DC preverification measurement. 

The actual settings you use will be dependent on the compliance 
limits for both the device and the SMUs/bias networks, and on 
the range of measurements you wish to take. Since this 
measurement is intended only to preverify the device, the 
values can be quite conservative and need not stress the device 
to the boundaries of its performance.

Figure 80 MOSFET Bias Configuration for DC Preverification
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If you are measuring a series of devices of the same type and 
have already set the input parameters, go directly to “Measuring 
and Plotting” on page 212. Otherwise, select the idvd_vg setup 
use the following settings as a guideline:

Table 25 For the vd input

Set To

Mode V

Compliance no greater than the maximum breakdown current value for 
the device

Sweep Type LIN, to provide a linear voltage sweep from start to stop 
voltage values

Start 0.0

Stop at or below the upper limit of the device’s normal operating 
range

# of Points sufficient to clearly display the measurement results

The Step Size will be set automatically

Table 26 For the vg input

Set To

Mode V

Compliance no greater than the maximum allowable gate current value.

Sweep Type LIN, to provide a linear voltage sweep from start to stop 
voltage values

Start, Stop, 
# of Points

such that three to five values (points) will be measured, in a 
range from approximately Vgs=Vthreshold to Vgs=3 or 4V. 
Set Start to a value close to Vthreshold, but not so close 
that the curve will be difficult to discern.

The Step Size will be set automatically
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PMOS device both vd Start and vg Start will be negative, and Stop will be 
0.000.
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• The Unit names must conform to the names you set in the 
hardware window when you configured IC-CAP to recognize 
the system hardware (probably VD and VG). They must also 
correspond with the actual SMU (source/monitor unit) 
connections from the Agilent 4142. Since the device source 
terminal is grounded, only the drain and gate inputs need to 
be set.

• You provide compliance values to limit SMU output voltage or 
current and thus prevent damage to the device under test, as 
well as to the SMUs, bias networks, and probes if used. With 
a voltage input, compliance refers to current.

• The Outputs are factory set, and should not be changed.

Measuring and Plotting

This procedure triggers the DC source/monitor measurement 
and monitors the results.
NOTE Before making the DC measurement, manually put the network analyzer in 
hold sweep mode by pressing STIMULUS > MENU > MORE > HOLD on an 
Agilent 8510, or MENU > TRIGGER MENU > HOLD on an Agilent 8753.

Be sure to keep a UNIX window open so that you will see any compliance 
error that may be reported by the DC source/monitor.
1 From the Plots tab, select Display All (to the left of the setup 
window). Two plots are displayed.

2 Select the Measure/Simulate tab, then select Measure. When 
the measurement is complete, the Measuring light on the DC 
source/monitor goes out, the IC-CAP wristwatch icon 
disappears, and the measured data is displayed in the plot 
window.

3 Check the id_vd plot. The data displayed should resemble 
that shown in the following figure, with the lowest curve 
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close to the X-axis to show the threshold characteristics. If 
the data indicates the device is not operating in its normal 
range, go back to the inputs and change the gate voltage 
values. (If more than one curve is low, change vg Start to a 
higher value. Or if all the curves are high, change vg Start to a 
lower value.) Then select Measure again.

4 If the measured data looks wrong for your device, check the 
probe contacts, the bias connections, and the measuring 
instruments. Make sure the device is oriented properly, with 
the right ports connected to the right terminals. If none of 
these resolves the problem, the device may be defective. For 
example, if all the curves are superimposed, the gate may be 
shorted.

5 To save the measured data for later comparison with data 
predicted by the extracted model, choose File > Save As and a 
filename with the suffix .set (for example dc_test.set). Then 
click OK.

6 The following figure illustrates a typical id_vd plot for a 
PMOS device.

Figure 81 Example Measured pre_verify id_vd Data
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7 Close the plots.

Figure 82 Example Measured id_vd Data for a PMOS Device
Calibrating the Network Analyzer
It is important to calibrate the network analyzer before you 
perform any S-parameter measurements. Good calibration of 
the network analyzer is critical to a good measurement and 
model generation.

The Agilent Root MOS measurement procedures require two 
network analyzer calibrations: a swept broadband cal and a CW 
cal. The broadband cal is used for the S-parameter 
preverification and parasitics measurements. The CW cal is 
used for the main data acquisition.

For a system with an Agilent 8510 network analyzer, this 
procedure uses the frequency list cal mode for both the 
broadband and CW calibrations. The two calibrations can be 
done with only one set of standards measurements, by making 
the CW cal a subset of the broadband cal. For a system with an 
Agilent 8753 or 8720 network analyzer, two separate 
calibrations must be performed.
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Frequency list calibration procedures for an Agilent 8510-based 
system and an Agilent 8753-based system are provided in the 
next few pages. A CW calibration subset procedure for an 
Agilent 8510-based system is also provided.

Calibration for an Agilent 8753-Based System

Although the Agilent 8753 has frequency list capability, IC-CAP 
does not support the subset calibration technique used in an 
Agilent 8510 system. Therefore it is necessary to perform two 
separate calibrations for an Agilent 8753- or 8720-based system: 
one frequency list calibration and one CW calibration. A 
separate set of standards measurements must be made for each 
calibration.

Frequency List Mode

Frequency list lets you define an arbitrary list of frequencies in 
one or more segments. During the measurement sweep the 
synthesizer is phase-locked at each frequency point, as in the 
stepped-sweep mode. The advantage of frequency list mode for 
use in a table-based model such as this is that it lets you define 
a smaller number of measurement points than for a step or 
ramp frequency cal. This reduces the total measurement time. A 
# of Points of 11 provides adequate measurement resolution as 
well as a quite fast total measurement time.

For the purpose of this model you will define two frequency 
segments in the list, a swept broadband segment and a CW 
segment. Set the broadband frequency list segment range at 
least as wide as the operating range of the device.

Set the CW frequency segment to the frequency you intend to 
use for the data acquisition, the same frequency you set in the 
model variable table at the beginning of this procedure. This 
frequency should be above 200 MHz to eliminate the effects of 
test set coupler roll-off at low frequencies, and low enough to 
eliminate bond inductances and other parasitic inductance 
considerations. 

Based on the broadband cal, use a calibrated measurement 
point equal to the start frequency plus an integer multiple of the 
step size. An example frequency might be 600 MHz. 
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200 MHz (start freq) + 1 ⋅ 400 MHz (step size) = 600 MHz

Frequency List Calibration for an Agilent 8510-Based System

If you are using an Agilent 8510-based system, follow the steps 
below.

1 On the network analyzer press PRESET.

2 To define a linear frequency list, on the network analyzer 
press STIMULUS > MENU > MORE > EDIT LIST > ADD. A 
default frequency list segment is presented.

3 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
start frequency, ending with one of the terminator keys (such 
as M/µ) at the right of the keypad. Similarly, press STOP and 
set the stop frequency.
 

NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys in the STIMULUS area of the front panel.
4 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range. Keep in 
mind that the fewer the number of points, the less time the 
measurements take.

5 Press DONE to return to the frequency list menu. The 
segment you just defined is listed on the screen.

6 Press DONE to return to the main stimulus menu. Press 
FREQUENCY LIST to activate the frequency list mode.

7 Press PRIOR MENU > MORE > CONTINUAL to set a continual 
stimulus sweep.

8 Press PRIOR MENU > POWER MENU, and set the desired 
power level. In setting the source power and attenuation, take 
care that the power level will not be excessive at the device 
input. Also consider the gain of the device, and set a power 
level that will not saturate the input port samplers of the 
analyzer. If the power level at the sampler goes above 
≈−8 dBm, an IF OVERLOAD error message is displayed and you 
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will need to reduce the source output power. The default 
network analyzer power level is 0 dBm.

9 For a device with power drop-off at higher frequencies, you 
may wish to set a power slope using the stimulus menus. An 
appropriate power slope would be in the region of 
2-3 dB/GHz.

10 Press RESPONSE MENU > AVERAGING ON/restart, and 
enter an averaging factor high enough to reduce trace noise 
and increase dynamic range as appropriate for your device 
measurements. Although the default is 256, you may wish to 
use an averaging factor as low as 16 to reduce overall 
measurement time.

11 If the cal kit constants for your calibration kit are not loaded 
into the network analyzer, load them from disc now by 
pressing DISC > LOAD and specifying the data type and file 
name.

12 If you wish to modify one of the internal cal kit definitions 
(see Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”), do so now.

13 Press CAL > CAL1 or CAL2 (depending on your cal kit), and 
perform a two-port calibration, measuring each of the 
standard devices in turn and pressing the softkeys as each 
measurement is complete.

14 At the end of the calibration sequence, the cal set numbers 
are listed in the softkey menu. Press CAL SET #1 to store the 
calibration in cal set #1. (Or use another available cal set.)

CW Calibration Subset for an Agilent 8510-Based System

1 To create a CW frequency subset of the broadband frequency 
list calibration, press CAL > CORRECTION ON > CAL SET 1 
(this turns on the broadband cal you just completed), then 
MORE > MODIFY CAL SET > FREQUENCY SUBSET. Use the 
SUBSET: START and SUBSET: STOP softkeys in the SUBSET 
menu (NOT the front panel keys) to set both start and stop to 
the same frequency.

2 Press CREATE & SAVE, and store this calibration in cal set 
#2 or another available cal set.
olume 2 217



218

4 Agilent Root MOSFET Model Generator
 

3 Note the numbers of the cal sets where you save the 
calibrations: you will need to list one of these numbers as 
part of the instrument state for each of the network analyzer 
measurements.
NOTE For more detailed information, refer to the Agilent 8510 Operating and 
Programming Manual.
Frequency List Calibration for an Agilent 8753-Based System

If you are using an Agilent 8753-based system, follow the steps 
below. 

1 On the network analyzer, press LOCAL to gain front panel 
control. Press PRESET to return to a known standard state.

2 If you are using a system with the 6 GHz receiver option and 
you wish to measure in the 3 GHz to 6 GHz range, press 
SYSTEM > FREQ RANGE 3GHz6GHz.

3 To define a linear frequency list, on the network analyzer 
press MENU > SWEEP TYPE MENU > EDIT LIST > CLEAR 
LIST > YES > ADD. A default frequency list segment is 
presented.

4 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
start frequency, ending with one of the terminator keys (such 
as M/µ) at the right side of the keypad. Similarly, press STOP 
and set the stop frequency.
NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys on the front panel.
5 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range, then 
press the x1 terminator key. Keep in mind that the fewer the 
number of points, the less time the measurements take.

6 Press DONE to return to the edit list menu. The segment you 
just defined is listed on the screen.
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7 Press DONE to return to the sweep type menu. Press LIST 
FREQ > SINGLE SEG SWEEP to activate the frequency list 
mode and set the analyzer to sweep the segment you defined.

8 Press RETURN > RETURN > TRIGGER MENU > 
CONTINUOUS to set a continuous stimulus sweep.

9 Press MENU > POWER and set the desired power level, then 
press the x1 terminator key. In setting the source power and 
attenuation, take care that the power level will not be 
excessive at the device input. Also consider the gain of the 
device, and set a power level that will not saturate the input 
port samplers of the analyzer. If a receiver input is 
overloaded (>+14 dBm), the analyzer automatically reduces 
the output power of the source to −85 dBm and displays the 
error message OVERLOAD ON INPUT (R, A, B) POWER REDUCED. 
In addition, the annotation P↓  appears in the left margin of 
the display to indicate that the power trip function has been 
activated. When this occurs, reset the power to a lower level, 
then toggle the SOURCE/PWR on/off softkey to switch on the 
power again.

10 Press AVG > AVERAGING FACTOR, and enter an averaging 
factor high enough to reduce trace noise and increase 
dynamic range as appropriate for your device measurements. 
A good default averaging factor is 256. To speed your 
measurements, you may find it convenient to set an 
averaging factor as low as 16. Press AVERAGING ON.

11 You can further reduce the noise floor by reducing the 
receiver input bandwidth. Press IF BW in the average menu, 
and enter one of the following allowed values in Hz: 3000, 
1000, 300, 100, 30, or 10. A tenfold reduction in IF bandwidth 
lowers the measurement noise floor by about 10 dB; however, 
the sweep time may be slower. For more information on 
averaging and the different trace noise reduction techniques, 
refer to the Agilent 8753 operating manual.

12 Press CAL > CAL KIT, and select the appropriate default or 
user-defined cal kit for your calibration devices.

13 If you wish to modify an internal calibration kit definition 
(see Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”), do so now.
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14 Press CAL > CALIBRATE MENU, and perform the calibration 
of your choice at the analyzer front panel, measuring each of 
the standard devices in turn and pressing the softkeys as 
each measurement is complete. A full two-port cal provides 
the greatest accuracy. A TRL* or LRM* cal is an appropriate 
alternative for in-fixture measurements (see Appendix C, 
“Using IC-CAP with an Agilent 85123A Device Modeling 
System”). Omit isolation cal. Press DONE, and save the cal in 
the register number specified in the instrument options 
table. 

15 Detailed procedures for measurements of calibration 
standards are provided in the Agilent 8753 operating 
manual.

CW Calibration for an Agilent 8753-Based System

Refer to Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System” for a CW calibration procedure that 
can be used for a system with an Agilent 8753 or 8720 network 
analyzer.
 

Preverifying the Device S-Parameter (AC) Data
This procedure uses the s_vgvdf setup to measure the device 
S-parameters across a calibrated frequency range, with the 
drain bias voltage swept from 0V to the upper limit of its normal 
operating range, and several values of gate bias.

The procedure can be used as a quick check that the device 
performance is good at higher frequencies, before you do a 
complete data acquisition and model generation. It is not 
necessary to do the preverification every time you generate a 
model, especially if you are using data sheet values.

Device Configuration: The input values you set in this 
procedure configure the device as shown in the following figure.
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Defining the Instrument States

Select the Instrument Options tab and follow the steps described 
in the section “Instrument States for Swept Measurements” on 
page 598 (for an Agilent 8510-based system), with the 
exceptions noted below.

Because you used a frequency list cal rather than a swept 
frequency cal, note the following:

• Be sure the instrument states you set for the network 
analyzer correspond to the values you set in your calibration.

• Set Use Fast CW to No.

• Be sure to set the averaging factor the same as in your 
calibration. 

• Set Cal Type [SHN] to H for hardware.

• Set Cal Set No to the cal set where you stored your 
broadband frequency list calibration.

• Set Use Linear List to Yes.

Then return to this chapter and continue.

Setting the s_vgvdf Inputs 

This procedure defines the input signals from both the DC 
source/monitor and the network analyzer for this measurement. 
Since this measurement only preverifies the device, the values 
can be quite conservative and need not stress the device to the 
limits of its performance. Select the s_vgvdf setup.

Figure 83 MOSFET Bias Configuration for S-Parameter Preverification
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Table 27 For the vd input

Set To

Mode V

Compliance no greater than the maximum breakdown current value for 
the device.

Sweep Type LIN

Sweep Order 2

Start 0.0

Stop at or below the upper limit of the device’s normal operating 
range

# of Points 2 or 3 is sufficient to display the data while giving fast 
results

Table 28 For the vg input

Set To

Mode V

Compliance no greater than the maximum allowable gate current value.

Sweep Type LIN

Sweep Order 3

Start, Stop, 
# of Points

to measure at two or three different bias points, in a range 
from approximately Vgs=Vthreshold to Vgs=3 or 4V.
NOTE The vd and vg ranges apply to an NMOS device. Recognize that for a 
PMOS device both vd Start and vg Start are negative, and Stop is 0.000.
Table 29 For the freq input

Set To

Mode F
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To Node

From Node

Unit

Compliance

Sweep Type LIN

Sweep Order 1

Start, Stop, 
# of Points

correspond with the broadband frequency list calibration 
you performed.

Table 29 For the freq input

Set To
NOTE If you set a MHz value, write MEG in full.
 

Measuring and Plotting
NOTE Before performing the S-parameter measurements, manually take the 
network analyzer out of hold sweep mode. Press STIMULUS > MENU > 
MORE > CONTINUAL on an Agilent 8510, or MENU > TRIGGER MENU > 
CONTINUOUS on an Agilent 8753, to initiate continuous sweep.
1 From the Plots tab, select Display All. Two S-parameter plots 
are displayed.

2 Select Measure/Simulate > Measure. 

3 Check the S-parameter plots. If the results are unexpected, 
recheck the values you set in Inputs and Instrument Options. 
In particular, be sure the instrument states and input 
stimulus signals match the values you set in the network 
analyzer broadband calibration.

4 If you change the inputs or instrument states, repeat the 
measurement. If the data still looks abnormal, the device may 
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be defective and may need to be replaced with an acceptable 
one.

5 To save the measured data, select File > Save As, type in an 
appropriate filename (for example spar_test.set), and select 
OK.

6 Close the plots.

If you are satisfied with the measured data for your device, 
continue with the procedures.
Measuring and Extracting Parasitic Resistance Values
This procedure measures the device S-parameters across the 
frequency range of operation, with the device in an unbiased 
condition (that is, with both the gate and drain bias set to zero). 
Under these conditions, the transconductance and drain 
conductance are negligible, so the equivalent circuit consists 
only of the parasitic elements and capacitances. The program 
calculates the intrinsic parasitic resistance from the measured 
data.

Device Configuration: The input values you set in this 
procedure configure the device as shown in the following figure.

Figure 84 MOSFET Bias Configuration for parasitics Measurement
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NOTE Make sure you have calibrated the network analyzer before you begin this 
procedure. Refer to the instructions earlier in this chapter.
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Defining the Instrument States

Perform the same procedure you did for the s_vgvdf 
measurement. Pay particular attention to the notes listed in 
that procedure. The instrument states need to be set 
independently for each setup.

Then return to this chapter and continue.

Setting the parasitics Inputs

Most of the input values for this measurement are factory 
preset and should not be changed. 

1 Select the parasitics setup.

2 Set the current Compliance for vg and vd to any reasonable 
values: in this unbiased condition, current values to the 
device will be negligible.

3 The Sweep Type is set to CONstant for both vg and vd.

4 The vg Value is set to 0 to ground the gate.

5 The vd Value is set to 0 to ground the drain.

6 The freq inputs set the network analyzer for a linear sweep of 
the calibrated frequency range. Set the freq Start, Stop, and # 
of Points to correspond with your broadband calibration.

Measuring, Plotting, and Extracting

1 Select Plots > r_f > Display Plot.

2 Select Measure/Simulate > Measure.

3 When the measurement is complete, select Extract/Optimize > 
z > Execute. The transform calculates the parasitic R values vs 
frequency from the measured data and enters them in a file 
named Para.data.

4 The r_f plot illustrated shows parasitic resistance with 
frequency. The resistance data displayed is the real part of 
the measured device impedance z.m.
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5 If you wish, you can recompute the resistance values over the 

linear portion of the data only, using the X-low/X-high 
function as follows:

• Select Setup Variables. A variable table will appear, listing 
X_LOW and X_HIGH with their default values of 0 or 
current values.

• Choose a relatively linear portion of the plotted traces. 
Click at the lower and upper boundary points of the linear 
portion to make a box on the trace, as shown next.

Figure 85 Example parasitics r_f Data
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• From the plot menu select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values in the table to the 
boundary points you selected.

6 Select Extract/Optimize > compute_r > Execute. The transform 
recalculates the parasitic resistance values as the average of 
the linear data you defined, and modifies the Para.data file 
accordingly. The values for rs, rd, and rg are listed in the 
IC-CAP Status window.

7 The parasitic values can be modified after the main data 
acquisition, just before the model generation. 

8 Close the plot.

Figure 86 Choosing a Relatively Linear Portion of the Traces
Setting Up the Main Data Acquisition
This sets up the values for the main measurement procedure, 
which takes the data from which the model will be generated. 
The procedure measures S-parameters at a calibrated CW 
frequency, across a range of drain and gate bias voltages. It 
takes adaptive measurements, densely spaced in the most 
nonlinear regions such as at the knees of the I-V curves and at 
the onset of breakdown, and less densely spaced in the linear 
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saturation region. The number of data points measured 
depends on the nonlinear behavior of the device and on the 
measurement conditions you set up.

Some knowledge of the device characteristics is needed in order 
to enter valid parameters. The data you measured in the DC and 
S-parameter preverifications may be useful in determining 
appropriate values for your device. Do not exceed maximum 
allowable values. Perform the steps in the following paragraphs.

The data acquisition rate is approximately 700 points per hour. 
Once you have initiated the transform, the data acquisition 
takes approximately 1 to 2 hours before your interaction is 
needed again.

Defining the Instrument States

The instrument states for the main data acquisition are set in 
the dc_bias and ac_bias setups.
 CAUTION Do not change the Inputs in the dc_bias or ac_bias setups. Their 
function is not the same as in the other setups. They contain 
factory-set information essential to the program, and they must not be 
changed.
1 Select the dc_bias setup.

2 Select the Instrument Options tab to display the DC 
source/monitor instrument states.

3 Set the Agilent 4142 instrument state the same as for the 
idvd_vg DC preverification measurement.

4 Select the ac_bias setup, then Instrument Options.

5 Note that the instrument states are different for CW and list 
frequency measurements. Set the instrument states almost 
the same as you did for the s_vgvdf preverification 
measurement, with the following exceptions (because you are 
now using the CW calibration instead of the broadband 
frequency list cal):

• Set Use User Sweep to Yes.
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• Set Cal Set No to the cal set or register where you stored 
your CW calibration.
NOTE If you fail to use the CW calibration and use the broadband cal instead, the 
measurement will take a great deal more time than expected. It will 
measure data at all the bias points at every frequency point. The plotted 
results will be hard to interpret!
 

Setting the Variables

You set the values that define the main measurement and the 
model generation in the data_acquisition and model_generator 
transforms in the create_mdl setup. Based on your information, 
IC-CAP characterizes the device within a subset range of the 
bias plane (Vd-Vg plane). This range is typically larger than the 
normal safe range for long-term DC device operation specified 
in the data sheet. In other words, the device is briefly pushed 
beyond its long-term normal DC operating range. This is 
required by the model for simulating large-signal AC and 
transient pulsed operation, where the instantaneous voltages 
can temporarily exceed the boundaries of long-term safe DC 
operation.

1 Select the create_mdl setup.

2 Select the Extract/Optimize tab, and the create_mdl transforms 
are listed.

3 Select data_acquisition to display the variables used in the 
data acquisition. 
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4 Follow the steps below to enter variable values appropriate 

for your device. 

5 Do not change the Function name at the top of the table.

6 For Power level, enter the total maximum power dissipation 
value. This should typically be 2 watts per mm of gate width 
for devices up to 1 mm.

7 For I Breakdown, enter the reverse gate current breakdown 
value.

The next four voltage values define hard limits to the 
measurement domain. The voltage values are set well beyond 
the normal device operating range to explore the device’s 
boundary response. If the values are set too conservatively, 
data will not be measured in the nonlinear areas of 
breakdown and maximum forward conduction. If this occurs 
in the measurement, return to this transform and change the 
voltage values. Reduce the minimum values and increase the 
maximum values.

Figure 87 Variables in the data_acquisition Transform
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• Min Vd should typically be slightly negative, to allow data 
to be taken slightly beyond the bounds of the model so that 
it is possible to properly extrapolate beyond the data. 

• Max Vd should typically be slightly higher than any 
anticipated breakdown voltage. 

• Min Vg should typically be one to several volts lower than 
Vthreshold for an NMOS device.

• Max Vg should typically be around the maximum gate 
operating voltage. 

8 For Min Step, enter a value to define the step size between 
densely-spaced measurements. 

9 For Max Step, enter a value to define the measurement step 
size where you expect the data to be relatively linear and you 
do not need densely-spaced measurements. 

10 For Vth, enter the gate threshold voltage Vthreshold.

11 Delta defines a voltage range below Vth where a high density 
of Vgs measurements is needed due to the nonlinear decrease 
in drain current at threshold. 

12 Eps (Epsilon) is used to predict the next point to be 
measured, and thus control automatic data acquisition step 
size. Increasing the value of epsilon decreases the sensitivity 
of the automatic data acquisition. 

13 For Noise thresh, enter a current threshold value for both 
drain current and gate current below which you do not need 
closely-spaced measurements. The automatic step-size 
algorithm is not used below the Noise thresh value, where 
measured currents are sampled at the maximum step size. 

14 For SMU Compl, enter the drain SMU maximum current 
compliance value in amps. This is the maximum output 
current capability of the Agilent 4142 plug-in source/monitor 
unit (SMU) supplying the drain terminal. In the example 
procedure, this is VD or HPSMU3. For the Agilent 41420A 
high-power SMU, the compliance is 1A; for the Agilent 
41421B medium-power SMU, the compliance is 100 mA.
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CAUTION Also be aware of the current ratings of your bias networks, and do not 
set current values beyond their specified maximum limits. It is quite 
possible to destroy the bias networks, and the probes, by applying 
current values beyond the specified limits. (The standard bias 
networks for the Agilent 85122A/85123A parameter extraction test 
systems are rated at 0.5 amp.)
232

 

15 You can save the values in the transform to use for another 
extraction. Select File > Save As, then the File Type 
Transform, type an appropriate filename, and select OK. The 
file is saved with the suffix .xfm.

Performing the Data Acquisition Measurement

This procedure performs the measurement you defined. Once 
you initiate the transform, the data acquisition takes 
approximately 1 to 2 hours to run before your interaction is 
needed again. The data acquisition rate is approximately 700 
points per hour. The number of data points measured depends 
on the nonlinear behavior of the device and on the 
measurement conditions you set up.

1 In the create_mdl setup select the Extract/Optimize tab.

2 Select data_acquisition > Execute. During the data acquisition 
process, a running message in the UNIX window indicates 
the approximate percentage of completion.
CAUTION Do not perform data acquisition more than once. This will write over 
the existing data, and will use more time and memory.
3 If you do attempt to perform data acquisition after the 
measurement has already been done, a dialog box will alert 
you that a measurement file exists. You then have several 
choices: If you do not need the data in the current file you 
can select OK or Return to overwrite it. Or you can abort 
your new measurement by selecting Cancel. Or if you wish to 
save the measured data and perform another data 
acquisition, go to a UNIX window, change directories if 
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necessary, find the file Measured.data, and rename it with 
another appropriate name, then continue with the data 
acquisition.

4 Ignore this message if it occurs: CAUTION: CALSET X STATE MAY 
BE INVALID.

5 When the process is complete, a message similar to the 
following is shown in the UNIX window:

INITIAL Extraction Results 
Max_num = 66.00 
Max_row = 49.00 
Done!

The numbers are part of the internal function of the 
program, and irrelevant in user interaction with the 
program. They are associated with the maximum number of 
points for a given Vgs, and the number of Vgs steps.

Plotting the Measured Data

The plots in the create_mdl setup provide graphical outputs of 
the data acquisition and model generation. Most of the plots are 
of data measured in the main data acquisition. However, Qg and 
Qd are outputs of the model generator, and will be viewed later.

For hardcopy output, black and white can be reversed for faster 
printing and easier reading on paper, as explained in the 
procedure.

If you wish to plot data from a previously stored data set, you 
will need to perform the steps explained under “To Plot an 
Earlier Data Acquisition” on the next page. Otherwise, follow 
these steps:

1 From the Plots tab, select the plot of your choice, and Display 
Plot.

2 You can augment the annotation of a plot by specifying 
header and footer labels you wish to print with the data. 
However, it is essential not to change the Y data input fields.

3 To change a plot’s annotation, go to the Header or Footer 
lines in the plot definition. You can type a label of your choice 
in the header or footer input field (right side of the definition 
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table). Then select Options > Update Annotation, and your label 
is added to the plot.
NOTE Changing the Y Data input fields can cause anomalies in the measurement 
and modeling results.
4 If you wish to exchange the black and white in a plot for 
better hardcopy quality, select Options from the plot menu, 
and Exchange Black-White from the pull-down menu. You can 
also change from colored traces to all black by selecting 
Options > Color. This is particularly useful if one of the traces 
is a light color such as yellow, which may not show well 
against a white background.

5 To get a hardcopy of a plot, from the plot menu select File > 
Print Setup. Enter the name of a printer and make any other 
changes to the printer/plotter setup you wish, then select OK.

6 If you have your printer setup completed, select File > Print.

To Plot an Earlier Data Acquisition

If you wish to view data from a previously stored Agilent 
RootMOS data acquisition, you will need to perform these extra 
steps to bring the data into this model and display the plots.

1 From the IC-CAP main menu select File > Change Directory. 
Type in the path name of the file where your data is stored, 
and select OK.

2 Select the create_mdl setup.

3 From the Plots tab, select the plot of your choice, and Display 
Plot. (The displayed plot window will be blank and an error 
message will be displayed. Ignore the error message and click 
OK.) Now select Display Plot again, and the plotted data will be 
properly displayed. (The first time you selected Display Plot, 
an internal function re-initialized the data from the changed 
directory.)
IC-CAP Nonlinear Devices Models Volume 2



Agilent Root MOSFET Model Generator 4

IC-CAP Nonlinear Devices Models V

 

The Measured Data Plots

The plots listed next illustrate the data measured by the 
data_acquisition transform for an example device.

• Id_vd plots the DC measurement of drain current Id as a 
function of Vds for different values of Vgs. Check this plot to 
see if you are satisfied with the bias range of the 
measurement. If not, go back to “Setting the Variables” on 
page 229 and make appropriate changes in the values of Min 
Vd, Max Vd, Min Vg, and Max Vg.

• Y11i plots the imaginary part of the Y11 admittance data.

• Y12i plots the imaginary part of the Y12 admittance data.

• Y21r plots the real part of the Y21 admittance data.

• Y22r plots the real part of the Y22 admittance data.

• Vd_Vg plots the distribution of test data in the Vgs-Vds plane. 
It shows how the data is taken adaptively depending on the 
device nonlinearities. More test data is taken where the 
device characteristics change rapidly such as at the knees of 
the I-V curves and the onset of breakdown, and less in the 
linear saturation region. 

If you are satisfied with the measured data for your device, 
proceed to the model generation. Be sure the limits of the 
measurement domain are adequate: the domain should extend 
beyond the normal operating range of the device. If the 
measured data does not show the limits of device behavior, you 
may wish to redefine the voltage ranges you set in the 
data_acquisition transform, using values that are less 
conservative, and perform the data_acquisition again.
Generating the Model
This procedure calculates the model parameters from the 
measured data, and generates a corresponding model for the 
device. The model nonlinear functions are calculated by contour 
integration, therefore you must provide the program with a 
starting point for the contour integration. 
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If you are generating a model from a previously stored data set, 
perform the steps listed later in this procedure under 
“Generating a Model from Previously Measured Data” on 
page 241.

Computing the Parasitics for the Model Generation

An earlier part of the procedure calculated the intrinsic 
parasitic resistances of the device and entered them in the file 
Para.data. Now this procedure updates the data and gives you 
the opportunity to override the calculated values and input 
values of your own if you believe they are more appropriate.

Select the main DUT, and the DUT Variables tab. A variable table 
is displayed, showing current values for the intrinsic parasitic 
resistances and inductances, as well as other variable values. 
The following figure illustrates the DUT variables table. Note the 
intrinsic inductances Ls_tot, Ld_tot, and Lg_tot all have default 
values of 1.000f.
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Do not change any of the other variable values in the table 
besides the R and L values. The other variables listed are 
internal functions necessary to the program, and can be 
ignored.

If you have reason to change any of the parasitic values, you can 
change them in this variable table. For example, if you have 
calculated the parasitic values by another method, such as from 
material measurements or by using a different algorithm, you 
may prefer to use those values. Or based on the model 
generation results plotted later in the procedure, you may wish 
to return to this step and modify values, then perform the 
transforms again.

Figure 88 Variable Table of the main DUT, Showing Parasitic Values
NOTE If you make any changes to the parasitic values in the variable table, do 
not perform the compute_para transform.
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If you do not wish to make changes to the parasitic values, 
select the compute_para transform in the create_mdl setup, and 
Execute. You will probably observe changes in the parasitic 
values in the table.
NOTE You can copy the variable table by selecting Detach to display it in a 
separate window. Resize the window and move it to a convenient place 
away from the central work area.
Setting the Starting Point for Contour Integration
NOTE For the modeled nonlinear functions to be valid, contour integration must 
be done in the normal operating range of the device. Outside the range, the 
results will be very different and less accurate. The further from the 
operating range, the less accurate the model will be.
Use the following guidelines to set the starting point of contour 
integration:

1 The starting point should be set at an intersect of Vd and Vg 
that is within the saturated class A operating range of the 
device, where drain voltage is beyond the knee and less than 
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breakdown, and gate voltage is between Vthreshold and Max 
Vg.

2 If you know Vthreshold and Vbreakdown, set:

• Vthreshold < vg_start < vgmax*, and
Vknee < vd_start < Vbreakdown 

or 

• vg_start = Vthreshold/2, and vd_start = Vbreakdown/2

(*vgmax is the approximate gate voltage corresponding to the 
maximum device drain current for a typical drain voltage in 
saturation. vgmax is generally lower in magnitude than Max 
Vg.)

Figure 89 shows an appropriate value for the contour 
integration point of an example device, marked with a + on 
the plot.

Figure 89 Example of Appropriate Contour Integration Starting Point
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Setting the model_generator Variables

1 Select create_mdl > Extract/Optimize > model_generator. The 
table illustrated below is displayed.

2 Enter an appropriate value for vd_start. Note that for a 
PMOS device this will be ≤ 0V.

3 Enter an appropriate value for vg_start. Note that for a PMOS 
device this will be ≤ 0V.

4 Enter an appropriate value for t_dispersion. This is the 
dispersion time constant, and its default value is 1e−17 or 10 
attoseconds, 10.00a. In most cases, t_dispersion is not a 
significant factor although it is used in the model generation 
calculations. However, in a case where you wish to add time 
dispersion effects, you can increase the value.

Executing the Model Generator Transform

1 Select Execute to start the model_generator transform.

2 A dialog box asks you for an MDS file name. The standard file 
generated by the model for interface with MDS is named 
State.mds. If you want to retain this filename select OK or 
press Enter. Otherwise change the name to a new filename 
that associates this model with the device, retaining the 
suffix .mds for compatibility with MDS.

Figure 90 Variables in the model_generator Transform
NOTE If you plan to do a verification, retain the filename State.mds for now, as 
the verification process requires this filename. You will have another 
opportunity to change the filename after the verification process.
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3 The model generation takes a few seconds. A Done! message 
in the UNIX window indicates the model generation is 
complete.

Generating a Model from Previously Measured Data

If you wish to generate a model from a previously stored 
measurement, you will need to perform these additional steps 
to bring the data into this model in the correct form.

1 From the IC-CAP Main window select File > Change Directory. 
Type in the path name of the file where your data is stored, 
and select OK.

2 Select the create_mdl setup.

3 Select compute_para > Execute.

4 Now perform the standard procedures described under 
“Setting the Starting Point for Contour Integration” on 
page 238 and “Executing the Model Generator Transform” on 
page 240.
 

NOTE To plot the data, note the extra steps described under “To Plot an Earlier 
Data Acquisition” on page 234.
Plotting the Generated Data

In the create_mdl setup, the Qg and Qd plots show the 
calculated state function data generated by the 
model_generator transform.
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NOTE The modeled state function data will not be plotted unless the 
init_parameters macro has been executed (see the instructions near the 
beginning of this chapter). The icplotnotes file generated by the 
init_parameters macro provides the x-axis information needed to plot the 
modeled data. IC-CAP will display an error message if you have not 
executed the init_parameters macro.
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1 From the Plots tab, select the plot of your choice, and Display 
Plot.

• Qg is the distribution of charge current under the gate. 
The illustration shows this data for an example device.

• Qd is the distribution of charge current under the drain. 
Other Outputs of the Model Generation Process
The model generation process results in a number of different 
output files to be used for different purposes. These include the 
model file for MDS interface, data on various modeled 
parameters, measured device data, and files for internal use by 
the program.

Some files have default filenames assigned by the program. 
Others may be files you created during the procedure to save 
device-specific information. 
CAUTION In general, the files should NOT be modified, because changing them 
can cause problems that may invalidate the model. It is also important 
that you do not change the names of files created by the model 
generator, with the exception of State.mds.
Following is a list of some files that will be or may be created 
during the modeling process:

• icplotnotes. This is the only file you can safely edit or add 
to. The program appends it as a label to any graphical 
outputs, to identify the device. It includes a device ID string 
and any additional information you choose to add to graphs 
when they are plotted.
IC-CAP Nonlinear Devices Models Volume 2



Agilent Root MOSFET Model Generator 4

IC-CAP Nonlinear Devices Models V

 

• icplotnumbers. This is an internal file used by the program 
to generate a graphical interface. It is related to the 
Max_num and Max_row messages that appear in the variable 
table of the main DUT and in the UNIX window at the end of 
the data acquisition. While these parameters are irrelevant to 
user interaction with the program, they are essential to its 
function, and they must appear on-screen. Do not change 
this file.

• Measured.data. This is the raw measured S-parameter data 
as a function of bias and frequency, produced by the 
create_mdl data acquisition process.

• Para.data. This is the S-parameter vs frequency data with 
the device in an unbiased condition, used by the program to 
calculate parasitic resistance and inductance values.

• State.data. This file is used by the program in plotting 
nonlinear functions such as Qg and Qd. Do not change this 
file.

• State.mds. This is the model file used by the Agilent RF and 
Microwave Design System (MDS) in a circuit simulation. It is 
also used in verifying the model, and needs to retain the 
name State.mds in the verification process in order to 
maintain the MNS simulator link. However, since every 
Agilent RootMOS model initially has this name, you change 
the name to identify the device, either when you execute the 
transform to generate the model (if you are not performing a 
verification), or at a later time as described at the end of this 
chapter.

• Y.data. This file contains the Y-parameters as a function of 
bias, to examine through graphical interface. NO changes can 
be made to the Y.data file, except for adding header and 
footer labels as explained under “Plotting the Measured 
Data” on page 233.

• dc_test.set (or some other name designated by you). If you 
decided to save it, this is the measured DC data generated in 
the idvd_vg DC preverification procedure.

• spar_test.set (or some other name designated by you). If you 
decided to save it, this is the measured S-parameter data 
generated in the s_vgvdf S-parameter (AC) preverification.
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This procedure verifies the model DC data against the DC data 
measured in the idvd_vg preverification setup, using the MNS 
simulator link.
NOTE The simulator used must be MNS. If the SIMULATOR in the model variable 
table is set to another value, change it to mns.

The name of the model file must be State.mds for the purposes of 
verification, to maintain the MNS simulator link.
1 Select the idvd_vg setup. Make sure the output Type is set to B 
for both measured and simulated data.

2 From the Plots tab, select the id_vd plot, and Display Plot.

3 Select Measure/Simulate > Simulate.

4 Check that the simulated data (dotted line) and measured 
data agree. The illustration shows example measured and 
simulated id_vd data.

Figure 91 Example Measured and Simulated id_vd Data
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This procedure verifies the model S-parameter data against the 
S-parameter data measured in the s_vgvdf setup, using the MNS 
simulator link.
NOTE The simulator used must be MNS. If the SIMULATOR in the model variable 
table is set to another value, change it to mns.

The name of the model file must be State.mds for the purposes of 
verification, to maintain the MNS simulator link.
 

1 Select the s_vgvdf setup. Make sure the s output Type is set to 
B. 

2 Select Plots > Display All. Two S-parameter plots are displayed.

• s11_s22 shows example measured and simulated S11 and 
S22 data

• s12_s21 shows example measured and simulated S12 and 
S21 data

3 Select Measure/Simulate > Simulate. Check the agreement 
between the simulated data (dotted lines) and measured 
data. 

4 Close the plots.
Storing Your Model and Interfacing with MDS 
Once you have developed your device model, you can store it in 
a file for future use. You can use it for circuit simulation in the 
Agilent RF and Microwave Design System, inserting it into 
circuits under design to emulate the characteristics of your 
device. It can be used to represent any device with the same 
geometry from the same process, or scaled to represent a 
different-sized device. It will predict the gain, power, gain 
compression, and harmonics performance of the device as a 
component in circuits you design using MDS. It will predict 
large-signal device operation over a range of bias points and 
loading conditions.
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The file generated by the modeling process for interface with 
MDS is called State.mds. You need to change the name to one 
that will identify the device under test, since every Agilent 
RootMOS model file is initially named State.mds.

If you chose not to perform a verification, you may already have 
changed the filename using the dialog box presented before the 
model_generator transform. If not, you can change the filename 
now in UNIX and store the file as follows:

Storing the Model

1 Use the UNIX directory you created at the beginning of the 
procedure, when you first opened the model file.

2 From the IC-CAP Main window select File > Save As.

3 A dialog box is displayed. Select the desired File Type (for 
example, .mdl for a complete model).

4 Select a new filename that associates this model with the 
device.

5 Use the UNIX cp command to copy the file State.mds to the 
new filename, including the path name of the designated 
directory. Select OK.

This completes the example Agilent Root MOSFET 
measurement and model generation procedure. For an 
explanation of how to use IC-CAP model data in MDS, refer to 
Appendix D, “Using IC-CAP Data with MDS.”
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Agilent Root Diode Model Generator

Model Description 248

Getting Started in IC-CAP 249

Using the Agilent Root Diode Model 252

This chapter documents the Agilent 85195A Agilent Root diode 
model generator software. It provides an example procedure 
that takes you step-by-step through a complete data acquisition 
and model generation.

The complete procedure includes all the instructions needed to 
generate a new device model by modifying variable values in 
factory default tables. After you have set these variables, 
subsequent procedures for similar devices are much faster. 
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The Agilent Root diode model software is data-based, rather 
than physical or empirical. It generates a device-specific 
large-signal model directly from measured DC and small-signal 
S-parameter data, that accurately represents the terminal 
characteristics of the device. The model is constructed without 
circuit simulation or optimization (although simulation may be 
used in the verification process). Use of S-parameter as well as 
DC data results in a model that can accurately predict nonlinear 
device performance. The Agilent Root diode model predicts 
device performance as a function of bias, power level, and 
frequency. It allows circuits to be simulated containing devices 
for which measured data exists but for which there are no good 
physical or empirical models. The Agilent Root diode model can 
be used for varactor and Schottky diodes, in a two-port or 
one-port configuration.

Based on device compliances you provide in software, the data 
acquisition system calculates the safe operating range for the 
device. Within this safe operating range, it takes data adaptively 
at multiple bias points, depending on the specific nonlinearities 
of the device under test. Measurements are densely spaced in 
the most nonlinear regions, such as at the onset of breakdown 
and forward conduction, and less densely spaced in the 
reverse-biased region.

The data acquisition system sets the DC bias levels and controls 
the system hardware to take the DC and S-parameter 
measurements, based on your inputs. The model generator 
processes the measured data and generates the lookup table 
required by a circuit simulator. It produces a data file that is 
directly readable by the Agilent RF and Microwave Design 
System (MDS). Both IC-CAP and MDS can be run 
simultaneously in the X Windows environment. During a 
simulation, the tabular state-function data from the generated 
Agilent Root diode model is interpolated using spline functions 
to emulate the terminal characteristics of the device.

The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP.
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This example procedure assumes the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System.”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System.”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename the SMUs to correspond with the diode terminals

Rename a medium-power SMU such as MPSMU1 as VA 
(anode supply)

Rename a high-power SMU such as HPSMU3 as VC (cathode 
supply)
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on opening the IC-CAP software and accessing the model file 
you need. The default pathname and filename for the Agilent 
Root diode model file you will use as a first starting point is:

/examples/model_files/diode/HPDiode.mdl

Then return to this chapter and continue with the procedure.
NOTE Do not install the device yet. The procedure will instruct you to install it 
after extracting the measurement port resistances.
Before you continue with the IC-CAP procedure, make a new 
directory in an appropriate location in the UNIX structure, 
using the mkdir command, to store the data and model files that 
will be generated. Give the directory a name that will associate 
it with the device you are going to model. Use the cd command 
to change to the new directory in UNIX.

MNS Link

The model includes a link to the MNS microwave nonlinear 
simulator, to allow verification of the model in IC-CAP. The link 
is set up for MDS version B.07.00, and will need to be modified 
when MDS is updated. For the link to work, the path and 
environment variables need to be set correctly: this is done at 
the factory for the path and environment of a typical MDS 
B.07.00 system. Only minor changes to reflect unusual MDS 
paths or updated MDS versions are likely to be required. If you 
do need to modify your UNIX files to reset the MNS link, follow 
these steps to set the root MDS directory on your system and 
add $MDSROOT/mdsbin to the path:
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For shell or kshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory to automatically set 
the environment variables:

MDSROOT=/mds_b.07.00 (depending on the version and 
location of MDS)
export MDSROOT
PATH=$MDSROOT/mdsbin: “$PATH”
export PATH

2 Also add a line similar to the following to the usersimulators 
file in /usr/iccap/lib, so that IC-CAP recognizes the MNS 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” 
CANNOT_PIPE

For cshell

1 Add the following lines to .profile (or .vueprofile if you are 
using HP VUE) in your home directory:

#Setup for mns simulator:

setenv MDSROOT /mds_b.07.00
setenv PATH $MDSROOT/mdsbin: “$PATH”

2 Add a line similar to the following to the usersimulators file 
in /usr/iccap/lib, so that IC-CAP recognizes the MNS 
simulator:

mns mns /mds_b.07.00/hp 85150/lib/mns800 “” 
CANNOT_PIPE
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This chapter provides an example procedure that takes you 
step-by-step through a measurement and model generation. 
Much of the data used in this procedure is taken from a diode in 
a two-port configuration, with some reference to a one-port 
configuration also. Values you use in generating your own 
device model will depend on the configuration and the 
particular characteristics and compliance values for your 
device: use its data sheet (if available) as a reference.

This example is provided as a starting point. It is a 
straightforward procedure that uses only a subset of IC-CAP’s 
total capabilities. The complete procedure documented gives all 
the steps necessary to configure IC-CAP with the parameters 
for preverification measurements, ideality and parasitic 
extractions, and the main data acquisition and model 
generation.
 NOTE Although you will modify the variable values in factory default files during 
this procedure, do not under any circumstances change the names of any 
variables or setups. These names are used by the software in the data 
acquisition and model generation process.
The example procedure gives detailed instructions on how to:

• Initialize device parameters.

• Measure and extract the system measurement port series 
resistances.

• Make a DC measurement to preverify device DC 
performance.

• Calibrate the network analyzer.

• Make an S-parameter measurement to preverify device 
performance at high frequencies. 

• Measure and extract the ideality factor.

• Measure and extract the device parasitic resistances and 
inductances.
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• Set up the parameters for the main data acquisition and 
model generation

• Initiate the main data acquisition. Plot the measured data.

• Initiate the model generation. Plot the calculated state 
functions.

• Verify the model against measured data.

• Store the data and model files for circuit simulation in 
Agilent MDS.

Where necessary, other chapters are cross-referenced at 
appropriate points in the procedure, so that you will have the 
information you need for system hardware setup and 
calibration at the proper times.
NOTE Measurement parameters and measured data are specific to individual 
devices. Information and data are provided here as examples and 
guidelines, and are not intended to represent the only correct results.
 
The procedure provides guidelines on setting values to measure 
your device. However, the values you use will be based on your 
knowledge of your device and on information in its data sheet 
(if available), as well as on the guidelines presented here: they 
may or may not correspond with the example values.

The illustrations of plotted data are provided as visual examples 
of possible results. They are not intended to represent a single 
device, nor do they necessarily correspond with the values 
given in the procedure. The plots can be used to check the 
reasonableness of your own data, which should appear similar 
in shape but not necessarily coincident in values.
The DUT and Setups
The Model window is the central access point for the 
measurement and model generation procedures. The Model 
window includes the DUT/Setup panel and the file tabs to 
access the Model Parameters table, the model variable table, 
and other IC-CAP features.
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The illustration shows the DUT/Setup panel for this model. The 
DUTs (for example pre_verify), indicated by the inverted 
triangles, are groupings of similar measurement setups used for 
related measurements, or to extract related model parameters. 
The setups (for example i_vs_v) contain the information used to 
define the inputs and outputs for each measurement, as well as 
their measurement hardware configurations and their 
associated transforms and plots.

The list of macros available from the Macros tab provides access 
to functions that combine certain groups of IC-CAP operations 
into single operations.

Figure 92 Agilent Root Diode DUT/Setup Panel
Initializing Device Parameters
You begin the procedure by giving the device an identifier, and 
entering the configuration (number of ports, two-port or 
one-port) and device current limits. For this you use the init_val 
macro and the model variable table. The model uses the current 
limits to set a safe operating range for the measurements, and 
measures only within that range. When the init_val macro is 
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executed, it also initializes internal program functions that are 
essential in the model generation process, and it provides 
annotations for the data plots.

1 Click the Macros tab to display the names of the macros.

2 In the Select Macro list, select init_val, then Execute. A dialog 
box is displayed, asking you to enter a device identifier.

3 Enter a name to identify the device under test, then select OK 
or press Return.

4 The next dialog box asks you to input the device area (that is, 
the cross-section of the diode) in square meters. The device 
area obviously will be a very tiny value, perhaps in the region 
of 200 um*50 um = 1e−8. This area value is required for 
interface of the finished model with MDS.

5 Another dialog box asks you to enter a directory name. 
Either select OK if you wish to store the model files in the 
directory shown, or backspace over the directory name and 
type in the name of another existing directory.

6 The next dialog box asks you to specify the number of device 
ports. 

• If the device is in a two-port configuration, type 2. 

• If it is one-port, type 1. 

If you try to enter a number other than 2 or 1, a message in 
the IC-CAP/Status window will tell you the number of ports 
must be 1 or 2.

7 The macro is executed, and values you selected are entered 
in the model variable table. Open the model variable table by 
clicking the Model Variables tab.
NOTE Do not edit the init_val macro. It contains executable code.
Setting the Current Limits 

You use the model variable table to set the forward and reverse 
current limits to be used in measuring your device. To edit the 
variable table, move the mouse pointer to the appropriate 
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variable value, click left, and move the pointer over the old 
information to highlight it. Then type in the new value over the 
old.

8 For the value of IFwd, enter the maximum forward 
conducting current for your device. Use the device data 
sheet, if available, to look up the value.

9 For the value of IBrk, enter the maximum diode breakdown 
current value (usually less than 1/10 IFwd).

10 Do not change the other values in the table at this time.

11 You can display the variable table in a separate window by 
selecting Detach. Resize the window and move it to a 
convenient place away from the central work area.

Values in the Parameters Table

The figure below illustrates the Model Parameters table, with 
the initial values for the extrinsic parasitic capacitances, 
inductance, and resistance. The table is presented so that you 
can enter values for these extrinsic parasitics based on your 
knowledge of the device, or on estimates, or on measurements 
of the open fixture. In addition, you can set limits by entering 

Figure 93 Model Variable Table
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minimum and maximum values for each parameter. Parameter 
values that are outside their limits are clamped to their 
minimum or maximum values.

1 To access the Parameters table, click the Model Parameters 
tab.

2 To change a value in the Parameters table, move the mouse 
pointer over the current entry and click left to highlight it, 
then type in a new value.

3 The default for all the c values is 0.000, for both a one-port 
and a two-port configuration. You can change the value of 
cac.c for either a one-port or two-port configuration. For a 
two-port configuration you can also change the values of 
cag.c and ccg.c. However, the program always uses zero 
values for cag and ccg in a one-port configuration, even if you 
manually change the values in the table, since there is no 
parasitic capacitance from anode to ground or from cathode 
to ground.

A reasonable capacitance value to enter for a pad on a wafer 
is 50 fF.

The figure below is a schematic representation of the 
extrinsic capacitances. Note that the cathode must be 
grounded in the one-port configuration.

Figure 94 Model Parameters Table
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4 lext.l is the bond inductance. The default value is 0.000. If 
you know or can estimate the bond inductance for your 
device based on wire length or grid size, enter an appropriate 
value.

5 r.r is not a real resistance, and is not associated with the 
measurement system or the diode. It is an artifact used by 
IC-CAP for verification in a one-port configuration because 
IC-CAP by default recognizes a two-port configuration. It is 
set to an initial default value of 10.00 GΩ for a two-port diode 
configuration. For a one-port configuration, it is set to a very 
small value such as 100.0 pΩ.

Figure 95 Schematic Diagram of Extrinsic Capacitances

cac

one-port configuration

cag

cac

ccg

two-port configuration
Extracting the Measurement Port Series Resistances
This procedure need be performed only following initial 
installation of the system or if changes are made in the system 
hardware.

The procedure measures a short circuit at the normal device 
measurement interface plane. IC-CAP controls the DC 
source/monitor to force a current and monitor the voltage. The 
primary measurement is at port 1, and the port 2 measurement 
is synchronized to the port 1 measurement. You set the 
measurement parameters by defining the instrument state and 
the DC input values, as explained in the next pages.

The software calculates the series resistances from the outputs 
of the bias networks to the inputs of the device under test. The 
resistance values are then incorporated into the model file, and 
their effects are removed from the device response during the 
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modeling process. (The default port resistance for both port 1 
and port 2 is 0Ω.) If the diode under test is in a two-port 
configuration, the series resistance is calculated for both 
measurement ports; for a one-port configuration, only the port 
1 resistance is calculated, and the port 2 resistance is set to 0Ω. 
(The anode must be connected to port 1.)

Note that the first part of the procedure differs for probe station 
and in-fixture measurements.

Setting Up for the Measurement

1 If you are using a probe station, position an impedance 
standard substrate (ISS) on the chuck. For a two-port 
configuration, place both the port 1 and port 2 probes on a 
short circuit standard. For a one-port configuration, the 
placement of the port 2 probe is irrelevant--it need not be 
lowered.

2 If you are using a fixture, insert the short from the in-fixture 
calibration kit.

3 From the DUT/Setup panel select the r_series setup.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System.”

Set Integ Time to M (medium). Then return to this chapter and 
continue.
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Setting the r_series Input Values

Use the following guidelines to set the inputs (most will not 
need to be changed from the factory settings):

• The Unit name must match the name of the SMU connected 
to the device anode (probably VA). This is also the SMU unit 
name you set in the hardware window. Refer to the 
appropriate chapter as follows:

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

• With a current input, compliance refers to voltage. 

Table 30 For the ia input

Set To

Mode I

To Node A (anode)

From Node GROUND

Compliance as 5 to 10V, because the device is not yet connected

Start, Stop current values that define a current range within the limits 
of the bias network

# of Points a value sufficient to make several measurements across the 
current range

The Step Size will be set automatically
CAUTION The bias networks can be destroyed if IC-CAP measurement current 
values are set too high. Be sure you know the maximum current ratings 
of your bias networks, and do not set current values beyond these 
limits. (The standard bias networks for the Agilent 85122A and 85123A 
parameter extraction test systems are rated at 0.5 amp.)
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• The Outputs are factory set, and should not be changed.

Measuring and Extracting

1 Under Measure/Simulate select Measure.

2 When the measurement is complete, the Measuring light on 
the DC source/monitor goes out and the IC-CAP wristwatch 
icon disappears.

3 Select the Extract/Optimize tab.

4 Select compute_rseries > Execute. The transform calculates the 
port series resistances from the measured data and enters 
the values into the model variable table as r1s and r2s.

5 To view a plot of the data, select Plots > r_i > Display Plot. The 
figure illustrates the voltage/current data for a one-port 
diode configuration. The va/ia (port 1) data is plotted across 
the measured bias range. The vc/ic (port 2) data has a zero 
value across the range for a one-port device.

Table 31 For the ic input

Set To

Mode I

To Node C

From Node GROUND

Unit VC

Compliance the same as for ia

Sweep Type SYNC

Ratio Number_of_ports-1, so that for a two-port configuration the 
ratio is 1 and a synchronized ic sweep is measured. For a 
one-port configuration the ratio is 0, therefore no ic sweep 
occurs and the port 2 series resistance retains the default 
value of 0Ω

Offset 0.0

Master Sweep ia, so that the ic sweep is synchronized to the ia sweep
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Figure 96 Example r_i Data for a One-Port Configuration
 

Installing the Device

CAUTION Ground yourself with an antistatic wrist strap to reduce the chance of 
electrostatic discharge. (Note that the Agilent 85122 or 85123 system 
work surface is coated with antistatic material and is connected to 
chassis ground, therefore a static mat is not required.)
Install the diode carefully on the probe chuck or in the fixture. 
To install the diode in a two-port configuration, connect the 
anode to port 1 and the cathode to port 2. To install the diode in 
a one-port configuration, connect the anode to port 1 and the 
cathode to ground. A configuration with the anode grounded is 
NOT supported. Be sure to handle the device as little as 
possible, to avoid damaging it. Once the device is in place, avoid 
bumping the test station.
CAUTION Remove any high-intensity light sources such as microscope light 
before taking a measurement. One simple method of blocking light is to 
place an opaque box on the fixture directly above the device.
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This procedure uses the i_vs_v setup to measure the current 
values with respect to voltage. It is an opportunity to take a first 
look at the device performance and explore its characteristics. 
The procedure starts with conservative values, and iteratively 
expands the voltage range until it sweeps from breakdown to 
the voltage where forward conducting current is maximum. 
This also lets you select the most appropriate measurement 
range for the main data acquisition and other measurements.

This is a quick way to verify that the device DC characteristics 
are good, before starting a complete data acquisition and 
modeling procedure. The data from this measurement can also 
be used for later comparison with data predicted by the 
generated model. It is not necessary to do the preverification 
measurement every time you perform a model generation, 
especially if you are using a data sheet.

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the r_series measurement. 
Use the same settings.

Setting the i_vs_v Input Values

This procedure defines the input signals to be applied to the 
device under test for the DC preverification measurement. 

The actual settings you use will be dependent on your device 
and on the range of measurements you wish to take. 

If you are measuring a series of devices of the same type and 
have already set the input values, go directly to “Measuring 
and Plotting” on page 265. Otherwise, select the i_vs_v setup 
and use the following settings as guidelines:

Table 32 For the va input

Set To

Mode V (voltage)

To Node A (anode)
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From Node GROUND

Compliance See note below.

Sweep Type LIN to provide a linear voltage sweep from start to stop 
voltage values

Start, Stop In setting the range, unless you know the operating voltage 
range of the device, it is best to begin with conservative 
values to let you observe the device response. Begin by 
setting a Start value of 0.0 or a slightly negative value. 
Similarly, begin with a conservative Stop value. If you do 
know the operating range of the device, you may want to 
use less conservative values.

# of Points A value sufficient to clearly display the measurement 
results. 

The Step Size is calculated automatically in software from the start/stop values 
and number of points.

Table 33 For the vc input

Set To

Mode V (voltage)

To Node C

From Node GROUND

Unit VC

Compliance See note below.

Sweep Type CONstant

Value 0 to ground the cathode

Table 32 For the va input

Set To
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• The Unit names must conform to the names you set in the 
hardware window when you configured IC-CAP to recognize 
the system hardware (probably VA and VC). They must also 
correspond with the actual SMU connections from the 
Agilent 4142. 

• You provide Compliance values to limit SMU output voltage 
or current and thus prevent damage to the device under test, 
as well as to the SMUs, bias networks, and probes, if used. 
With a voltage input, compliance refers to current: in general, 
you can set both the va and vc Compliance to IFwd, the 
forward conducting current value you set in the model 
variable table.

However, in setting compliance values, consider this issue: 
compliances are physically different in the forward and 
reverse bias ranges. It is important to make sure the 
compliance is not set too large for breakdown. Although you 
set only one compliance value for a setup, you are actually 
sweeping over two ranges, the negative range and the 
positive range. Two alternatives are possible to overcome this 
issue: either you can run two setups, one for the forward 
measurement using IFwd as the compliance value, and one 
for the reverse measurement using IBrk as the compliance 
value. Or you can run a single setup, making the va Start 
value so slightly negative at the first iteration that it will not 
allow the device to reach breakdown.

• The Outputs are factory set, and should not be changed.

Measuring and Plotting

This procedure triggers the device measurement, controlling the 
DC source/monitor to supply the signals you defined in the 
instrument options window and the inputs, and monitors the 
results.
NOTE Be sure to keep a UNIX window open so that you will see any compliance 
error that may be reported by the DC source/monitor. If so, you may need 
to reduce the value of IFwd you set in the model variable table.
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NOTE Before making the DC measurement, manually put the network analyzer in 
hold sweep mode by pressing STIMULUS > MENU > MORE > HOLD on an 
Agilent 8510, or MENU > TRIGGER MENU > HOLD on an Agilent 8753.
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1 Select Plots > i_v > Display Plot.

2 Select Measure/Simulate > Measure. When the measurement is 
complete, the Measuring light on the DC source/monitor goes 
out, the IC-CAP wristwatch icon disappears, and the 
measured data is displayed in the plot window.

3 Check the plot. The objective of this measurement is to show 
the device response from breakdown to maximum forward 
conducting current, as in the illustration. If your plot shows 
only a partial device response you will need to change the 
inputs and repeat the measurement, as follows:

4 Go back to the inputs. If necessary, change va Start to a lower 
value to measure more of the device breakdown 
characteristics; or change Stop to a higher value to measure 
the forward conducting current. Select Measure again.

5 Iterate as necessary until you have measured a complete 
device response.

Figure 97 Example DC Measurement of Current vs Voltage
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6 If the measured data looks wrong for your device, check the 
probe contacts, the bias connections, and the measuring 
instruments. Make sure the device is oriented properly, with 
the right ports connected to the right terminals (anode to 
port 1, cathode to port 2 for a two-port device; anode to port 
1, cathode to ground for a one-port device). If none of these 
resolves the problem, the device may be defective. 

7 To save the measured data select File > Save As and a filename 
with the suffix .set (for example dc_test.set). Then select OK.

8 Close the plot.
Calibrating the Network Analyzer
 

It is important to calibrate the network analyzer before you 
perform any S-parameter measurements. Good calibration of 
the network analyzer is critical to a good measurement and 
extraction. This procedure uses a frequency list calibration.

Frequency List Mode

Frequency list lets you define an arbitrary list of frequencies in 
one or more segments. During the measurement sweep the 
synthesizer is phase-locked at each frequency point, as in the 
stepped-sweep mode. For the purposes of this model, you will 
define one frequency segment in the list with a frequency range 
at least as wide as the operating range of the device. This 
calibrated swept frequency range will be used for all the 
S-parameter measurements: the AC preverification, parasitics, 
and main data acquisition measurements. The model will be 
generated at one of the calibrated frequencies in the list.

The advantage of frequency list mode for use in a table-based 
model such as this is that it lets you define a smaller number of 
measurement points than for a step or ramp frequency cal. This 
reduces the total measurement time, particularly in the main 
data acquisition where measurements are taken at all the bias 
points at each frequency in the list. A # of Points of 5 to 13 
provides adequate measurement resolution as well as a quite 
fast total measurement time for the main data acquisition.
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Frequency list calibration procedures for an Agilent 8510-based 
system and an Agilent 8753-based system are given in the next 
few pages.

Connecting the Network Analyzer

If you have not already done so, connect the RF cables from the 
network analyzer test ports to the RF inputs of the bias 
networks. When it is time to measure the calibration standard 
devices, connect them to the DC/RF ports of the bias networks.

Frequency List Calibration for an Agilent 8510-Based System

If you are using an Agilent 8510-based system, follow the steps 
below. 

1 On the network analyzer, press LOCAL to gain front panel 
control. Press PRESET to return to a known standard state.

2 To define a linear frequency list, on the network analyzer in 
the STIMULUS area press MENU > MORE > EDIT LIST > 
CLEAR LIST > YES > ADD. A default frequency list segment 
is presented.

3 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
start frequency, ending with one of the terminator keys (such 
as M/µ) at the right of the keypad. Similarly, press STOP and 
set the stop frequency. 
NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys in the STIMULUS area of the front panel.
4 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range, then 
press the x1 terminator key. Keep in mind that the fewer the 
number of points, the less time the measurements take.

5 Press DONE to return to the frequency list menu. The 
segment you just defined is listed on the screen.

6 Press DONE to return to the main stimulus menu. Press 
FREQUENCY LIST > SINGLE SEGMENT to activate the 
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frequency list mode and set the analyzer to sweep the 
segment you defined. 

7 Press MENU > MORE > CONTINUAL to set a continual 
stimulus sweep.

8 Press MENU > POWER MENU and set the desired power 
level, then press the x1 terminator key. In setting the source 
power and attenuation, take care that the power level will not 
be excessive at the device input. Also consider the gain of the 
device, and set a power level that will not saturate the input 
port samplers of the analyzer. If the power level at the 
sampler goes above −8 dBm, an IF OVERLOAD error message is 
displayed and you will need to reduce the source output 
power. The default network analyzer power level is 0 dBm.

9 For a device with power drop-off at higher frequencies, you 
may wish to set a power slope using the stimulus menus. An 
appropriate power slope would be in the region of 
2-3 dB/GHz.

10 In the RESPONSE area, press MENU > AVERAGING 
ON/restart, and enter an averaging factor high enough to 
reduce trace noise and increase dynamic range as 
appropriate for your device measurements. Although the 
default is 256, you may wish to use an averaging factor as low 
as 16 to reduce overall measurement time.

11 If the cal kit constants for your calibration kit are not loaded 
into the network analyzer, load them from disc now by 
pressing DISC > LOAD and specifying the data type and file 
name.

12 If you wish to modify one of the internal cal kit definitions 
(Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”), do so now.

13 Press CAL > CAL1 or CAL2 (depending on your cal kit), and 
perform a two-port calibration, measuring each of the 
standard devices in turn and pressing the softkeys as each 
measurement is complete.
NOTE IC-CAP does not support a one-port cal: therefore you must perform a 
two-port cal for either a two-port or a one-port device. If you try to do a 
one-port cal, IC-CAP will display anomalies and error messages.
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14 At the end of the calibration sequence, the cal set numbers 
are listed in the softkey menu. Press CAL SET 1 to store the 
calibration in cal set #1. (Or use another available cal set.)

CW Calibration Subset for an Agilent 8510-Based System

1 To create a CW frequency subset of the broadband frequency 
list calibration, press CAL > CORRECTION ON > CAL SET 1 
(this turns on the broadband cal you just completed), then 
MORE > MODIFY CAL SET > FREQUENCY SUBSET. Use the 
SUBSET: START and SUBSET: STOP softkeys in the SUBSET 
menu (NOT the front panel keys) to set both start and stop to 
the same frequency.

2 Press CREATE & SAVE, and store this calibration in cal set 
#2 or another available cal set.

3 Note the numbers of the cal sets where you save the 
calibrations: you will need to list one of these numbers as 
part of the instrument state for each of the network analyzer 
measurements.
 

NOTE For more detailed information, refer to the Agilent 8510 Operating and 
Programming Manual.
Frequency List Calibration for an Agilent 8753-Based System

If you are using an Agilent 8753-based system, follow the steps 
below. 

1 On the network analyzer, press LOCAL to gain front panel 
control. Press PRESET to return to a known standard state.

2 If you are using a system with the 6 GHz receiver option and 
you wish to measure in the 3 GHz to 6 GHz range, press 
SYSTEM > FREQ RANGE 3GHz6GHz.

3 To define a linear frequency list, on the network analyzer 
press MENU > SWEEP TYPE MENU > EDIT LIST > CLEAR 
LIST > YES > ADD. A default frequency list segment is 
presented.

4 To change the segment to your chosen frequency range press 
SEGMENT: START, and use the numerical keypad to set the 
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start frequency, ending with one of the terminator keys (such 
as M/µ) at the right side of the keypad. Similarly, press STOP 
and set the stop frequency.
NOTE Use the SEGMENT: START and STOP softkeys, not the START and STOP 
hardkeys on the front panel.
 

5 Press SEGMENT: NUMBER of POINTS, and enter the number 
of frequency points to be measured across the range, then 
press the x1 terminator key. Keep in mind that the fewer the 
number of points, the less time the measurements take.

6 Press DONE to return to the edit list menu. The segment you 
just defined is listed on the screen.

7 Press DONE to return to the sweep type menu. Press LIST 
FREQ > SINGLE SEG SWEEP to activate the frequency list 
mode and set the analyzer to sweep the segment you defined.

8 Press RETURN > RETURN > TRIGGER MENU > 
CONTINUOUS to set a continuous stimulus sweep.

9 Press MENU > POWER and set the desired power level, then 
press the x1 terminator key. In setting the source power and 
attenuation, take care that the power level will not be 
excessive at the device input. Also consider the gain of the 
device, and set a power level that will not saturate the input 
port samplers of the analyzer. If a receiver input is 
overloaded (>+14 dBm), the analyzer automatically reduces 
the output power of the source to −85 dBm and displays the 
error message OVERLOAD ON INPUT (R, A, B) POWER REDUCED. 
In addition, the annotation P↓  appears in the left margin of 
the display to indicate that the power trip function has been 
activated. When this occurs, reset the power to a lower level, 
then toggle the SOURCE PWR on/off softkey to switch on the 
power again.

10 Press AVG > AVERAGING FACTOR, and enter an averaging 
factor high enough to reduce trace noise and increase 
dynamic range as appropriate for your device measurements. 
A good default averaging factor is 256. To speed your 
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measurements, you may find it convenient to set an 
averaging factor as low as 16. Press AVERAGING ON.

11 You can further reduce the noise floor by reducing the 
receiver input bandwidth. Press IF BW in the average menu, 
and enter one of the following allowed values in Hz: 3000, 
1000, 300, 100, 30, or 10. A tenfold reduction in IF bandwidth 
lowers the measurement noise floor by about 10 dB; however, 
the sweep time may be slower. For more information on 
averaging and the different trace noise reduction techniques, 
refer to the Agilent 8753 operating manual.

12 Press CAL > CAL KIT, and select the appropriate default or 
user-defined cal kit for your calibration devices.

13 If you wish to modify an internal calibration kit definition 
(see Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”), do so now.

14 Press CAL > CALIBRATE MENU, and perform a two-port 
calibration at the analyzer front panel, measuring each of the 
standard devices in turn and pressing the softkeys as each 
measurement is complete. A TRL* or LRM* cal is an 
appropriate alternative for in-fixture measurements (see 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”). Omit isolation cal. Press DONE, and save 
the cal in the register number specified in the instrument 
options table. 

15 Detailed procedures for measurements of calibration 
standards are provided in the Agilent 8753 operating 
manual.

CW Calibration for an Agilent 8753-Based System

Refer to Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System” for a CW calibration procedure that 
can be used for a system with an Agilent 8753 or 8720 network 
analyzer.
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This procedure uses the s_vs_f setup to measure the device 
S-parameters across a calibrated frequency range, at several 
bias points in the normal operating range of the device. It can 
use the measured DC preverification data for reference in 
choosing DC bias points of interest to you.

The procedure can be used as a quick check that the device 
performance is good at higher frequencies, before you do a 
complete data acquisition and model generation. It is not 
necessary to do the preverification every time you generate a 
model, especially if you are using data sheet values.

Defining the Instrument States

Select the Instrument Options tab and follow the steps described 
in the appropriate chapter shown next (with the exceptions 
noted below):

• “Instrument States for Swept Measurements” on page 598 
(for an Agilent 8510-based system) in Appendix B, “Using 
IC-CAP with an Agilent 85122A Precision Modeling System”

• “Instrument States for Swept Frequency Measurements” on 
page 624 (Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System.”

Because you used a frequency list cal rather than a swept 
frequency cal, note the following:

• Be sure the instrument states you set for the network 
analyzer correspond to the values you set in your calibration.

• Set Use Fast CW to No.

• Be sure to set the averaging factor the same as in your 
calibration.

• Set Cal Type [SHN] to H for hardware.

• Set Cal Set No to the cal set or register where you stored your 
calibration.

• Set Use Linear List to Yes.

Then return to this chapter and continue.
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Setting the s_vs_f Input Values

This procedure defines the input signals from both the DC 
source/monitor and the network analyzer for this measurement. 

1 Select the s_vs_f setup.

2 Set the vc inputs the same as for the i_vs_v setup.

3 In the va inputs set Sweep Type to LIST, and Sweep Order to 
2.

4 In list sweep mode, IC-CAP lets you specify up to 15 bias 
voltage values for the measurement. Using your measured DC 
preverification data as a reference, choose values of interest 
to you. For example, you might want to view the device 
response at bias points close to breakdown or in the forward 
conducting region.

Be conservative in setting the va Values. Note that the values 
must be monotonic (set in increasing order, not mixed at 
random).

5 The number of Values must equal the number of values you 
enter into the list. (This does not include any 0.000 values at 
the end of the list.)

6 Set the freq Mode to F, Sweep Type to LIN, and Sweep Order 
to 1.
NOTE If you set a MHz value, write MEG in full. IC-CAP is not case-sensitive, and 
assumes that m or M corresponds to milli. If an error message is displayed 
during the measurement that indicates a network analyzer frequency 
value is too low, you may have entered M only.
7 Set the freq Start and Stop values to correspond with the 
frequency range of your calibration.

8 Set the # of Points to correspond with the calibration. The 
step size is set automatically.
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Measuring and Plotting
NOTE Before performing the S-parameter measurements, manually take the 
network analyzer out of hold sweep mode. Press LOCAL. Then in the 
STIMULUS area press MENU > MORE > CONTINUAL on an Agilent 8510; 
or press MENU > TRIGGER MENU > CONTINUOUS on an Agilent 8753, to 
initiate continuous sweep.
 

1 From the Plots tab, select sp > Display Plot.

2 Select Measure/Simulate > Measure. 

3 Check the plot. The S-parameter data displayed should be 
typical for your device. The illustration shows example 
measured S11 data. If your device is in a two-port 
configuration, S22 will also be plotted.

4 If the results are unexpected, recheck the values you set in 
the inputs and instrument options. In particular, be sure the 
instrument states and input stimulus signals match the 
values set in the network analyzer calibration.

Figure 98 Example Measured S11 Data
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5 If you change the inputs or instrument states, repeat the 
measurement. If the data still looks abnormal, the device may 
be defective and may need to be replaced with an acceptable 
one.

6 To save the measured data, select File > Save As, type in an 
appropriate filename (for example spar_test), and select OK.

If you are satisfied with the measured data for your device, 
continue with the procedures. Be sure the limits of the 
measurement domain are adequate: the domain should extend 
beyond the normal operating range of the device to show the 
limits of device behavior. If not, you may wish to redefine the 
voltage range you set in i_vs_v and s_vs_f, using values that are 
less conservative.
Measuring and Extracting the Ideality Factor
Ideality is the coefficient that multiplies Vthermal in the ideal 
diode equation. The diode resistance is approximated by the 
equation:

where n is the ideality factor, Vth is Vthermal (0.025V at room 
temperature), and I is the current.

In this setup, the diode is strongly forward biased. The current 
is swept from a very small positive current value up to 
maximum, to exercise the diode junction to include the region 
of its exponential behavior. 

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the r_series and i_vs_v 
measurements. Use the same settings.

Setting the ideality Input Values

Most of the input values for this measurement are factory 
preset and should not be changed. The current values are based 
on values you set in the model variable table at the beginning of 

Rdiode

nVth
I

------------≈
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the procedure. The other inputs are necessary to set up the 
required device measurement configuration. Select the ideality 
setup and use the following settings as guidelines.

• When the ia Sweep Type is set to LOG, the input table 
automatically includes the fields Dec or Oct and Total Pts in 
place of Step Size.

• The number of points can be entered as either a # of Points 
per decade (as in this example) or a Total Pts across the 
sweep. 

• The vc Compliance value of 1.1*IFwd limits the current to a 
value 10% above IFwd to prevent damage to the device.

• The Outputs are factory set, and should not be changed.

Table 34 For the ia input:

Set To

Compliance around the same value as the va Stop value used in the 
i_vs_v DC preverification or a little higher

Sweep Type LOG scale to allow measurement of the inherently 
exponential distribution of points

Start and Stop The purpose of the Start and Stop settings for ia is to force 
current from ≈0 amps to maximum. Stop is set to IFwd, 
which is the maximum forward conducting current value 
you set in the model variable table. Start is set equal to IFwd 
divided by some large number between 1000 and 10000.

Dec or Oct Refers to a decade or octave log scale for plotted data. The 
correct setting for this measurement is D for decade.

Table 35 For the vc input

Set To

Compliance See the note below.

Sweep Type CONstant 

Value 0.000, to ground the cathode
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Measuring, Extracting, and Interpreting the Results

This procedure makes the measurement and computes the 
ideality factor from the results. The procedure explains how to 
check the measured data and computed ideality, and override 
the computed value if appropriate.

1 From the Plots tab. Select the N_vs_va plot, and Display Plot.

2 Select the Extract/Optimize tab. Select N > Execute. The 
transform calculates the ideality factor from the measured 
data and enters the value into the model variables table.

3 To display the table, select the Model Variables tab.

4 You can copy the model variables table in a separate window 
by selecting Detach. Resize the window and move it to a 
convenient place away from the central work area.

5 You can set the program to recompute the ideality factor 
from only the relatively linear portion of the measured data. 
Note that the linear region of the measurement is the region 
where the Rdiode equation given under “Measuring and 
Extracting the Ideality Factor” on page 276 applies. The next 

Figure 99 Example Plot of Ideality vs Voltage
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steps use the X-low/X-high function to select a linear portion 
of the trace.

• Select Setup Variables. A variable table appears that lists 
X_LOW and X_HIGH with their default value of 0 or 
current values.

• Choose a relatively linear portion of the plotted trace. 
Click the mouse pointer at the lower and upper boundary 
points of the linear portion, to make a box on the trace as 
illustrated below.

• From the plot menu select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values in the table to the 
boundary points you selected.

6 Select Extract/Optimize > N > Execute. The transform 
recalculates the ideality factor as the average of the linear 
data you defined, and enters the new N value into the model 
variable table. The new value should be between 1 and 2.

7 If the N value in the model variable table is <1, and an 
out-of-range warning is displayed in the UNIX window, 
change the limits of the box you defined on the trace and 

Figure 100 Choosing a Linear Portion of the Plotted Trace
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execute the N transform again. Repeat this until the N value 
is >1 and < 2.

8 You can check the N value in the variable table against an 
ideality value on the trace. Put the mouse pointer at a 
selected point on the linear portion of the trace, click the 
middle mouse button, and a readout of the Y-axis value at 
that point will be displayed.

9 If the N_vs_va plot looks significantly different from the 
illustration, it may be necessary to modify the computed 
value, as explained in the following steps.

10 If no measured linear region is shown on the trace, a good 
ideality factor cannot be computed. In this case, you will 
need to manually enter a value of 1 for N. (In the Rdiode 
equation, the NVth term is relatively small compared with I. If 
a good ideality factor cannot be computed, it is best to 
eliminate the contribution of the NVth term by using an N 
value of 1.)

11 To change the N value in the variable table, position the 
pointer over the current entry and click left to highlight it, 
then type the new value. 

12 You may wish to check the linearity of the device response by 
viewing the i_vs_va plot, which displays the device current vs 
voltage on a log scale. The more (log) linear the response, the 
closer the diode is to being ideal. The illustration gives an 
example.
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13 When you are done, close the plots.

Figure 101 Example Log Scale Plot of Current vs Voltage
Measuring and Extracting Parasitic R and L Values
This procedure measures S-parameters vs frequency, with the 
diode forward-biased and a fixed value of forward conducting 
current. The program calculates the intrinsic parasitic 
resistance (r) and inductance (l) values from the measured 
data. The illustration below is a simplified schematic 
representation of the intrinsic r and l values. In calculating r 
and l the program takes into account the extrinsic parasitic 
capacitance, inductance, and resistance values entered in the 
Parameters table at the beginning of the procedure.
olume 2 281



282

5 Agilent Root Diode Model Generator
 

Figure 102 Simplified Schematic Diagram of Intrinsic r and l

ci

•

r

l

NOTE Make sure you have calibrated the network analyzer before you begin this 
procedure. Refer to the instructions earlier in this chapter.
Defining the Instrument States

Perform the same Instrument Options procedure you did for the 
s_vs_f measurement. Pay particular attention to the notes listed 
in that procedure. The instrument states need to be set 
independently for each setup. 

Setting the parasitics Input Values

Most of the input parameters for this measurement are factory 
preset and should not be changed. The current values are based 
on values you set in the model variable table at the beginning of 
the procedure. The other inputs are necessary to set up the 
required device measurement configuration.

1 Select the parasitics setup.

2 Set the ia voltage Compliance to around the same value as 
the a Stop value used in the i_vs_v DC preverification, or 
slightly higher.

3 The ia Sweep Type is set to CONstant with a Value of IFwd to 
drive the diode with a constant maximum forward 
conducting current.
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4 The vc Sweep Type is set to CONstant with a value of 0.000, 
to ground the cathode.

5 The vc Compliance value of 1.1*IFwd limits the current to a 
value 10% above IFwd to prevent damage to the device.

6 The freq inputs set the network analyzer for a linear sweep of 
the calibrated frequency range. Set the freq Start and Stop 
values to correspond with the frequency range of your 
calibration.

7 Set the # of Points to correspond with the calibration.

Measuring, Plotting, and Extracting

1 Select Plots > Display All.

2 Select Measure/Simulate > Measure. The program 
automatically calculates the r and l values vs frequency from 
the measured data and enters them in a file named 
Para.data. (The z transform is automatically executed after 
the measurement.)

The plots display the parasitic r and l as a function of 
frequency. The resistance data displayed is the real part of 
the measured impedance z.m. The inductance data is the 
imaginary part of z.m divided by 2πf. 

The parasitics will be recalculated later at the frequency of 
extraction only.

3 Close the plots.
The Main Data Acquisition
This is the main measurement procedure that takes the data 
from which the model will be generated. The procedure 
measures S-parameters over a calibrated microwave frequency 
range, across a range of bias voltages. It takes adaptive 
measurements, densely spaced in the most nonlinear regions 
such as at the onset of breakdown and the knee of the forward 
conducting curve, and less densely spaced in the reverse-bias 
region (except where the capacitance data changes rapidly). 
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The number of data points measured depends on the nonlinear 
behavior of the device and on the measurement conditions you 
set up. 

Preparing

Some knowledge of the device characteristics is needed in order 
to input valid parameters. Follow the steps below to input 
appropriate values for your device. Do not exceed maximum 
allowable values. (If a data sheet is available for the device, refer 
to it for specifications and compliances.)

Defining the Instrument States

The instrument states for the data acquisition are set in the 
dc_bias and ac_bias setups.
 

CAUTION Do not change the inputs in the dc_bias or ac_bias setups. Their 
function is not the same as in the other setups. They contain 
factory-set information essential to the program, and they must not be 
changed.
1 Select the dc_bias setup. 

2 Select the Instrument Options tab to display the DC 
source/monitor instrument states.

3 Set the Agilent 4142 instrument state the same as for the 
i_vs_v DC preverification and the ideality measurement.

4 Select the ac_bias setup.

5 Set the instrument states the same as for the s_vs_f 
preverification and the parasitics measurement (otherwise 
the calibration will be invalid).

Defining the Voltages and Step Sizes for the Measurement

1 Select the create_mdl setup. 

2 Select Extract/Optimize > acquire_data. The table illustrated 
below is displayed.
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3 Edit the variable values in the transform by entering values 
appropriate for your own device.

4 For the value of Vmax, enter the maximum allowable forward 
voltage.

5 Enter a value for Vmin that corresponds to the reverse 
breakdown voltage.

6 Enter a value you choose for Max step. This defines the 
measurement step size for regions where you expect the data 
to be relatively linear and measurements to be more widely 
spaced.

7 Enter a value you choose for Min step. This defines the step 
size for densely-spaced measurements where the data is most 
nonlinear. 

8 Enter a value for Noise level. This is the current threshold 
value below which the automatic step-size algorithm is not 
used. Set a value below which you do not need closely-spaced 
measurements, as measured currents below this value are 
sampled at the maximum step size.

9 Enter a value for Eps (epsilon). Epsilon is used to predict the 
next point to be measured and thus control automatic data 
acquisition step size. Increasing the value of epsilon 
decreases the sensitivity of the automatic data acquisition. 
Epsilon should generally be between 0.1 and 0.3; the default 
value is 0.1.

10 If you wish to save these transform values for use with 
similar devices, select File > Save As. Then select the File Type 
Transform, type in a filename that conforms to UNIX 

Figure 103 Opened acquire_data Transform in create_mdl Setup
olume 2 285



286

5 Agilent Root Diode Model Generator
 

requirements, and select OK. The file is saved with the suffix 
.xfm for transform.

The create_mdl Inputs

Don’t change the inputs. The create_mdl setup, like the other 
setups, includes an input configuration list. However, the 
function served by this list is not the same as in the other 
setups. It is factory-set internal information used by the 
program, and is essential to its function. 

Performing the Data Acquisition Measurement

This procedure performs the measurement you defined. Once 
you initiate the transform, the data acquisition procedure takes 
approximately 10 to 20 minutes. The data acquisition rate is 
approximately 10 points per minute. The number of data points 
measured depends on the nonlinear behavior of the device and 
on the measurement conditions you set up.

Measuring and Extracting

1 In the create_mdl setup select the Extract/Optimize tab.

2 Select acquire_data > Execute. During the data acquisition 
process, a running message in the UNIX window indicates 
the approximate percentage of completion.
CAUTION Do not perform data acquisition more than once. This will write over 
the existing data, and will use more time and memory.
3 If you do attempt to perform data acquisition after the 
measurement has already been done, a message will ask you 
DO YOU WISH TO OVERRIDE?. You then have several choices: If 
you do not need the data in the current file you can select 
Return or OK to overwrite it. Or you can abort your new 
measurement by selecting Cancel. Or if you wish to save the 
measured data and perform another data acquisition, go to 
the UNIX window, change directories if necessary, and 
rename the file Measured.data with another appropriate 
name, then continue with the data acquisition.
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4 Ignore this message if it occurs: CAUTION: CALSET X STATE MAY 
BE INVALID.

5 When the process is complete, a message similar to the 
following is displayed in the UNIX window:

INITIAL Extraction Results 
Pts_num = 66.00 
Done!

The numbers are part of the internal function of the 
program, and irrelevant in user interaction with the 
program. They are associated with the number of points in 
the measurement.

Plotting the Measured Data

The plots in the create_mdl setup provide graphical outputs of 
the data acquisition and model generation. For hardcopy 
output, black and white can be reversed for faster printing and 
easier reading on paper, as explained in the procedure.

If you wish to plot data from a previously stored data set, you 
will need to perform the steps explained under “To Plot an 
Earlier Measurement” on page 288. Otherwise, follow these 
steps:

Viewing and Printing the Plots

1 From the Plots tab, select the plot of your choice, and Display 
Plot.

2 You can augment the annotation of a plot by specifying 
header and footer labels you wish to print with the data. 
However, it is essential not to change the Y data input fields.

3 To change a plot’s annotation, go to the Header or Footer 
lines in the plot definition. You can type a label of your choice 
in the header or footer input field (right side of the definition 
table). Then select Options > Update Annotation, and your label 
is added to the plot.
NOTE Changing the Y Data n input fields can cause anomalies in the 
measurement and modeling results.
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4 If you wish to exchange the black and white in a plot for 
better hardcopy quality, select Options from the plot menu, 
and Exchange Blk Wht from the pull-down menu. You can also 
change from colored traces to all black by selecting Options > 
Color. This is particularly useful if one of the traces is a light 
color such as yellow, which may not show well against a 
white background.

5 To get a hardcopy of a plot, from the plot menu select File > 
Print Setup. Enter the name of a printer and make any other 
changes to the printer/plotter setup you wish, then select OK. 
Select File > Print.

To Plot an Earlier Measurement

If you wish to view data from a previously stored Agilent Root 
diode measurement, you will need to perform these extra steps 
to bring the data into this model and display the plots.

1 From the IC-CAP main menu select File > Change Directory. 
Type in the pathname of the file where your data is stored, 
and select OK.

2 Select the create_mdl setup and select the Plots tab.

3 Select the plot of your choice, and Display Plot. (The displayed 
plot window will be blank and an error message will be 
displayed.) Ignore the error message and click OK.) Now 
select Display Plot again, and the plotted data will be properly 
displayed. (The first time you selected Display Plot, an 
internal function re-initialized the data from the changed 
directory.)
Generating the Model
This procedure calculates the model parameters from the 
measured data, and generates a corresponding model for the 
device. 

If you are generating a model from a previously stored data set, 
perform the steps listed later in this procedure under “To 
Generate a Model Using Data from an Earlier Measurement.” 
Otherwise, follow these steps:
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Defining the Extraction Frequency

The model is extracted at a single frequency, which should be 
approximately the frequency at which the device will be used. It 
must be one of the measured points from the calibrated 
frequency list. To determine a frequency for the extraction, use 
a calibrated measurement point equal to the start frequency 
plus an integer multiple of the step size. For example:

200 MHz (start freq) + 1 ⋅ 4.45 GHz (step size) = 4.65 GHz

1 In the create_mdl setup select the Setup Variables tab. The 
variables table illustrated is displayed.

2 Manually change the value of Freq to your chosen extraction 
frequency. 

Computing the Parasitics at the Extraction Frequency

1 Select Extract/Optimize > compute_para > Execute. This 
calculates the parasitic r and l values at the extraction 
frequency and enters them in the create_mdl variables table, 

Figure 104 Variable Table of the create_mdl Setup
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in place of the average value of the parasitics over the total 
measured frequency range.

Scaling the i Plot Before Generating the Model

Sometimes excessive noise may be present in the IV 
characteristics near zero, although this is not generally visible 
with standard scaling. To prevent the model generation process 
from interpolating data points in this noisy region, the model 
can smoothly join the data outside this region and connect it 
across the noisy region.

The following steps use the measured data in the i plot to 
determine if there is excess noise near zero, and to curve-fit the 
measured data if necessary. 

1 Select Plots > i > Display Plot.

2 To obtain a closer view of the measured data around the knee 
of the forward conducting current curve, click trace points to 
the left and right of zero to redefine the plot range. Then in 
the plot menu select Options > Rescale to expand the plot to 
the new range.

3 Perform the last step repeatedly until you can see if there is 
low-level noise on the trace. 

If the current appears smooth even at expanded resolution, 
go to “Executing the Transform” on page 292.
IC-CAP Nonlinear Devices Models Volume 2



Agilent Root Diode Model Generator 5

IC-CAP Nonlinear Devices Models V

 
If the current appears noisy at expanded resolution, use the 
X-low/X-high function for curve-fitting, as follows:

• Click the mouse at the left and right boundary points of 
the noisy portion of the trace, to make a box on the trace.

• From the plot menu select Options > Copy to Variables. This 
sets the X-LOW and X-HIGH values in the create_mdl 
setup variable table to the boundary points you selected. It 
also sets the values for LowBound V and HighBound V in 
the diode_mdl transform.

• Note that the value for X-low should be slightly negative 
and for X-high should be slightly positive. An error 
message will be displayed if the values are inappropriate.

• Now when the model is generated, the noisy data will be 
averaged over the X-low/X-high range you defined.

4 Close the i plot.

Figure 105 i Plot Expanded to Show Data Near Zero
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Executing the Transform

1 Select the Extract/Optimize tab.

2 Select diode_mdl > Execute to start generating the model for 
the device under test.

3 A dialog box asks you for an MDS file name. The standard file 
generated by the model for interface with MDS is named 
diode.mds. If you want to retain this filename select OK or 
press Enter. Otherwise change the name to a new filename 
that associates this model with the device, retaining the 
suffix .mds for compatibility with MDS.
NOTE If you plan to do a verification, retain the filename diode.mds for now, as 
the verification process requires this filename. You will have another 
opportunity to change the filename after the verification process.
4 A Done! message in the UNIX window indicates when the 
model generation is complete.

Generating a Model from Previously Measured Data

If you wish to generate a model from a previously stored 
measurement, you will need to perform this additional step to 
bring the measured data into this model.

1 From the IC-CAP main menu select File > Change Directory. 
Type in the pathname of the file where your data is stored, 
and press Return.

2 Now perform the standard procedure, “Generating the 
Model,” described above.
NOTE For plotting the data, note the extra steps described under “To Plot an 
Earlier Measurement” on page 288.
Plotting the Generated Data

1 To view a specific plot select the plot and Display Plot. The c 
plot displays the high-frequency intrinsic capacitance as a 
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function of voltage. The following figure shows capacitance 
data for an example device. The response is properly flat 
below pinch-off for this FET-like diode, with more points 
taken where the capacitance changes faster. The data is 
extrapolated in the forward region where forward bias 
capacitance is not extractable.

Figure 106 Example Capacitance Data
NOTE Capacitance characteristics of different diodes may be extremely different.
2 The compare_i plot displays the agreement between the 
modeled and measured current. When agreement is good, it 
may be difficult to distinguish the extracted data (yellow 
trace) from the measured data (red trace). To expand the 
trace resolution, from the plot menu select Options > Rescale. 
The data illustrated in the following figure shows good 
agreement even with expanded resolution.
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3 Close the plots.

Figure 107 Example compare_i Data
Other Outputs of the Model Generation Process
The model generation process results in a number of different 
output files to be used for different purposes. These include the 
model file for MDS interface, data on various modeled 
parameters, measured device data, and files for internal use by 
the program.

Some files have default filenames assigned by the program. 
Others may be files you created during the procedure to save 
device-specific information. 
CAUTION In general, the files should NOT be modified, because changing them 
can cause problems that may invalidate the model. It is also important 
that you do not change the names of files created by the model 
generator, with the exception of diode.mds.
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Following is a list of some files that will be or may be created 
during the modeling process:

• icplotnotes. This is the only file you can safely edit or add 
to. The program appends it as a label to any graphical 
outputs, to identify the device. It includes a device ID string 
and any additional information you choose to add to graphs 
when they are plotted.

• icplotnumbers. This is an internal file used by the program 
to generate a graphical interface. It is related to the Pts_num 
message that appears in the UNIX window at the end of the 
data acquisition. While the Pts_num parameter is irrelevant 
to user interaction with the program, it is essential to its 
function, and must appear on the screen. Do not change this 
file.

• Measured.data. This is the raw measured S-parameter data 
as a function of bias and frequency, produced by the 
create_mdl data acquisition process.

• Para.data. This is the S-parameter vs frequency data at 
forward bias, used by the program to calculate parasitic 
resistance and inductance values.

• Diode.data. This file is used by the program in plotting 
nonlinear functions. Do not change this file.

• Diode.mds. This is the model file used by the Agilent RF and 
Microwave Design System (MDS) in a circuit simulation. It is 
also used in verifying the model, and needs to retain the 
name Diode.mds in the verification process in order to 
maintain the MNS simulator link. However, since every 
Agilent Root diode model initially has this name, you change 
the name to identify the device, either when you execute the 
transform to generate the model (if you are not performing a 
verification), or at a later time as described at the end of this 
chapter.

• dc_test.set (or some other name designated by you). If you 
decided to save it, this is the measured DC data generated in 
the DC preverification procedure.

• spar_test.set (or some other name designated by you). If you 
decided to save it, this is the measured S-parameter data 
generated in the S-parameter (AC) preverification.
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This procedure verifies the model DC data against the DC data 
measured in the i_vs_v setup, using the MNS simulator link.
NOTE The simulator used must be MNS. If the SIMULATOR in the model variable 
table is set to another value, change it to mns.

The name of the model file must be Diode.mds for purposes of verification, 
to maintain the MNS simulator link.
1 Select the i_vs_v setup. Make sure the output Type is set to B 
for both measured and simulated data. 

2 From the Plots tab, select the i_v plot, and Display Plot.

3 Select Measure/Simulate > Simulate.

4 Check that the simulated data (dotted line) on the plot is in 
good agreement with the measured data. 
 Verifying the Model S-Parameter Data
This procedure verifies the model S-parameter data against the 
S-parameter data measured in the s_vs_f setup, using the MNS 
simulator link.
NOTE The simulator used must be MNS. If SIMULATOR in the model variable 
table is set to another value, change it to mns.

The name of the model file must be Diode.mds for the purposes of 
verification, to maintain the MNS simulator link.
1 Select the s_vs_f setup. Make sure the output Type is set to B.

2 Select Plots > sp > Display Plot.

3 Select Measure/Simulate > Simulate. 

4 Check that the simulated data (dotted lines) on the plot is in 
good agreement with the measured data. 
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You may wish to generate a model at a different frequency, 
which must be another measured point from the calibrated 
frequency list (see “Defining the Extraction Frequency” on 
page 289). (During the data acquisition, data was taken at each 
of the calibrated frequencies in the frequency list.) If so, follow 
these steps:

1 If you are satisfied with the model you have just generated, 
copy the file Diode.mds to another filename. (Be sure to use 
a different name for the new model than you used for the 
first one.)

2 Select the create_mdl setup.

3 Select the Setup Variables tab to open the create_mdl variable 
table.

4 Change the value of Freq to the new calibrated frequency of 
your choice.

5 Select Extract/Optimize > compute_para > Execute to calculate 
the parasitic r and l values at the new extraction frequency.

6 Select diode_mdl > Execute to start generating the new model. 
Unless you wish to perform a verification afterwards, enter 
another filename, possibly one that includes the new 
extraction frequency.

7 When the Done! message appears in the UNIX window, 
observe the plots.

8 If you wish, verify the model against the measured DC and 
S-parameter data using the previous procedures.
Storing Your Model and Interfacing with MDS
Once you have developed your device model, you can store it in 
a file for future use. You can use it for circuit simulation in the 
Agilent RF and Microwave Design System, inserting it into 
circuits under design to emulate the characteristics of your 
device. It can be used to represent any device with the same 
geometry from the same process, or scaled to represent a 
different-sized device. It will predict the gain, power, gain 
compression, and harmonics performance of the device as a 
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component in circuits you design using MDS. It will predict 
large-signal device operation over a range of bias points and 
loading conditions. 

The file generated by the modeling process for interface with 
MDS is called Diode.mds. You need to change the name to one 
that will identify the device under test, since every Agilent Root 
diode model file is initially named Diode.mds. 

If you chose not to perform a verification, you may have already 
changed the filename using the dialog box presented before the 
diode_mdl transform. If not, you can change the filename now 
in UNIX and store the file as follows:

Storing the Model

1 Use the UNIX directory you created at the beginning of the 
procedure, when you first opened the model file.

2 From the IC-CAP Main window select File > Save As.

3 A dialog box is displayed. Select the File Type (.mdl for a 
complete model) by clicking on the corresponding radio 
button.

4 Select a new filename that associates this model with the 
device.

5 Use the UNIX cp command to copy the file Diode.mds to the 
new filename, including the pathname of the designated 
directory. Select OK.

This completes the example Agilent Root diode measurement 
and model generation procedure. For an explanation of how to 
use IC-CAP model data in MDS, refer to Appendix D, “Using 
IC-CAP Data with MDS.”
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The Agilent 85192B EEFET3/EEHEMT1 model is an empirical 
analytic model developed for the purpose of fitting measured 
electrical behavior of GaAsFETs and HEMTs. The model 
equations were developed concurrently with the parameter 
extraction techniques to ensure the model contains only 
parameters that are extractable from measured data. The model 
can be automated with extraction macros, or the parameters 
can be extracted individually from measured data.

The model includes the following features:

• An accurate isothermal drain-source current model that fits 
virtually all processes. 

• Self-heating correction for the drain-source current.

• A charge model that accurately tracks measured capacitance 
values.

• A dispersion model that permits simultaneous fitting of 
high-frequency conductances and DC characteristics.

• A breakdown model that describes gate-drain current as a 
function of both Vgs and Vds.

• The capability to extrapolate outside the measurement range 
used to extract the model.
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The starting point of this tutorial assumes the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter, listed 
below: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename SMU1 (for medium power)

Rename SMU2 (for high power)

Then return to this chapter and continue with the procedures 
here.

/examples/model_files/mesfet/HPEEfet3.mdl
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Before you continue with the IC-CAP procedures, make a new 
directory (using the mkdir command), to store the data and 
model files that will be generated. Give the directory a name 
that will associate it with the devices you are going to model. 
Use the cd command to change to the new directory in UNIX.
 

NOTE The model file HPEEhemt1.mdl is the same model as HPEEfet3.mdl. The 
only difference is that HPEEfet3.mdl includes premeasured device data 
from a MESFET, and HPEEhemt1.mdl includes premeasured device data 
from a HEMT.
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This chapter provides a sequence of example procedures that 
take you step-by-step through a FET or HEMT measurement and 
extraction. The procedures are arranged in the proper sequence 
to allow earlier measured data or extracted parameters to be 
used as a basis for later measurements or extractions. The 
extraction is the same for a FET or a HEMT, except that the 
additional parameters used for a HEMT can be omitted in a FET 
extraction.

A series of different IC-CAP setups are used to measure current, 
voltage, or S-parameters vs. bias under different bias and 
frequency conditions. The model parameters are then extracted 
from the various sets of measured data. 
NOTE These procedures measure the device in a common-source configuration.
Macros automate the modeling procedure so that a series of 
similar devices can be modeled quickly with minimal user 
intervention, although you can execute individual transforms 
for specific measurement and parameter extractions.

The detailed procedures (executing individual transforms) in 
this chapter include instructions for the following:

• Performing a set of device preview measurements and setting 
measurement variable values based on the results.

• Setting the hardware instrument states and input variables 
for each measurement.

• Making the parasitic, DC, and S-parameter measurements: 
qualifying the results.

• Extracting and optimizing the individual model parameters.

• Verifying the extraction results against the measured data.

• Storing the model.
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Where appropriate, other chapters are cross-referenced, so that 
all system hardware setups and calibrations are performed at 
the right times.
NOTE Measurement parameters and measured data are specific to individual 
devices. Information and data are provided here as examples and 
guidelines, and are not intended to represent the only correct method or 
results.
 

The procedures start with example values for the model 
variables. They provide guidelines on setting the values to 
measure your own devices. However, the values you use will be 
based on your knowledge of your FET/HEMT devices or on 
information provided by the device vendors, as well as on the 
guidelines presented here: they may or may not correspond 
with the examples. In some cases, it may be necessary to set the 
variable values for the preview measurements, make a 
measurement, and then reset the variables based on the 
measurement results. The procedures give suggestions on 
judging the applicability of the variable values and the 
measured data.

The illustrations of plotted data are provided as visual examples 
of possible measurement and simulation results. They are not 
intended to represent a sequential measurement and extraction 
of a single device, nor do they necessarily correspond with the 
example measurement inputs and variable values in the 
procedures. The plots can be used to check the reasonableness 
of your own data, which should appear similar in shape but not 
necessarily coincident in values.

In addition, the IC-CAP software itself includes measured data 
for some of the setups. This data shows additional examples of 
possible results. Many, though not all, of the input settings for 
this measured data correspond with the example settings in 
this manual.
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The DUT/Setup panel is part of the Model window, which is the 
central access point for all the individual measurement and 
modeling procedures.The Model window includes tabs to access 
the macros, the Model Parameters table, and other IC-CAP 
features. To open this model, click the Examples button on the 
toolbar and locate /model_files/mesfet/HPEEfet3.mdl.

In the DUT/Setup panel the DUTs (for example 
Preview)—indicated by the inverted triangles—are groupings of 
similar measurement setups used for related measurements and 
extractions. The setups (for example ig_vgs) contain the 

Figure 108 Portion of the Agilent EEFET3/EEHEMT1 DUT/Setup Panel
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information used to define the inputs and outputs for each 
measurement, as well as their measurement hardware 
configurations and their associated transforms and plots.

The measurement and parameter extractions are most easily 
performed with macros. If you use macros, you will not need to 
use the individual setups. However, if you want to extract 
individual parameters or “fine-tune” a parameter, you will use 
the individual setups. (Note that you can also write macros to 
control other repetitive tasks, using IC-CAP’s Parameter 
Extraction Language, PEL.)

ReadMe is not actually a macro, but an abbreviated version of 
the instructions in this chapter. It is most appropriate for users 
who are somewhat familiar with the model. You can view the 
Readme file in a separate window by clicking Detach. You can 
then resize the window and move it away from the central work 
area. Scroll through the text as you work through the model.
Model Parameters
 
The tables in this section describe the various parameters and 
list their default values.

Drain-Source Current Parameters

The drain-source current model was developed through 
examination of Ids, as well as drain-source conductance (Gds) 
and transconductance (Gm), vs. bias plots on a wide class of 
devices from various manufacturers. The model assumes the 
device is symmetrical, and therefore is valid for values of 
Vds < 0.0 V as well as Vds > 0.0 V. The parameters in the 
following table are extracted from drain-source current 
measurements:

Table 36 Drain-Source Current Parameters

Parameter  Description Default (Units)

Vto Zero-bias threshold parameter. −1.5 (V)

Gamma Vds-dependent threshold parameter. 0.05 (1/V)
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Charge Parameters

The gate charge model was developed through examination of 
extracted device capacitances over bias. The capacitance data is 
obtained from measured Y-parameter data in the saturation 
region. 

Vgo Gate-source voltage where 
transconductance is maximum.

−0.5 (V)

Vdelt Parameter that controls linearization 
point for Gm characteristic.

0.0 (V)

Vch (Vchannel) Gate-source voltage where 
Gamma no longer affects the I-V curve.

1.0 (V)

Gmmax Peak transconductance parameter. 70.0e−3 (S)

Vdso Drain voltage where Vds dependency 
disappears from equations.

3.0 (V)

Vsat Drain-source current saturation 
parameter.

1.0 (V)

Kappa Output conductance parameter. 0.0 (1/V)

Peff Channel-to-backside self-heating 
parameter (effective power 
compression).

2.0 (W)

Vtso Subthreshold onset voltage. −10.0 (V)

Table 37 Charge Model Parameters

Parameter Description Default (Units)

C11o Maximum input capacitance for 
Vds=Vdso and Vdso>Deltds.

0.3 (pF)

C11th Minimum (threshold) input 
capacitance for Vds=Vdso.

0.03 (pF)

Table 36 Drain-Source Current Parameters (continued)

Parameter  Description Default (Units)
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Dispersion Parameters

Dispersion parameters are extracted from measured 
S-parameter data, to provide additional accuracy for dispersion 
effects at higher frequencies. The dispersion parameters listed 
in the table below are optimized to measured transconductance 
(Gm) data to model both DC and RF dispersion characteristics. 
Similarly, the dispersion parameters are optimized to measured 
output conductance (Gds) data.

Vinfl Inflection point in C11−Vgs 
characteristic.

−1.0 (V)

Deltgs C11th to C11o transition voltage. 0.5 (V)

Deltds Linear region to saturation region 
transition parameter.

1.0 (V)

Lambda C11−Vds characteristic slope 
parameter.

0.05 (1/V)

C12sat Input transcapacitance for Vgs=Vinfl 
and Vds>Deltds.

0.03 (pF)

Cgdsat Gate-drain capacitance for 
Vds>Deltds. 

0.05 (pF)

Ris Source-end channel resistance. 2.0 (ohms)

Rid Drain-end channel resistance. 0.0 (ohms)

Tau  Source-to-drain charging delay. 1.0 (ps)

Cdso Drain-source inter-electrode 
capacitance.

80.0 (fF)

Table 38 Dispersion Model Parameters

Parameter Description Default (Units)

Rdb Dispersion source output impedance. 1.0e9 (ohms)

Cbs Dispersion source capacitance. 1.6e−13 (F)

Table 37 Charge Model Parameters (continued)

Parameter Description Default (Units)
olume 2 307



308

6 Agilent EEFET3/EEHEMT1 Model
 

HEMT Gm Compression Parameters

Some FETs and almost all HEMTs exhibit transconductance 
compression in which Gm peaks and then decreases. The 
following parameters model these compression effects.

Gdbm Additional d-b branch conductance at 
Vds=Vdsm.

0.0 (S)

Kdb Parameter that controls Vds 
dependence of additional d-b branch 
conductance.

0.0 
(dimensionless)

Vdsm Voltage where additional d-b branch 
conductance becomes constant 
(Gdbm).

1.0 (V)

Gmmaxac Peak transconductance parameter 
(AC).

60.0e−3 (S)

Vdeltac Parameter that controls linearization 
point for Gm characteristic (AC).

0.0 (V)

Vtoac Zero-bias threshold parameter (AC). −1.5 (V)

Gammaac Vds-dependent threshold parameter 
(AC).

0.05 (1/V)

Kappaac Output conductance parameter (AC). 0.0 (1/V)

Peffac Channel-to-backside self-heating 
parameter (AC).

10.0 (W)

Table 39 Additional Parameters Used in EEHEMT1 for Gm Compression

Parameter Description Default (Units)

Vco Voltage where transconductance 
compression begins.

10.0 (V)

Mu Parameter that adds Vds dependence 
to transconductance compression 
onset.

0.0 
(dimensionless)

Table 38 Dispersion Model Parameters (continued)

Parameter Description Default (Units)
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Vba Transconductance compression 
“tail-off” parameter.

1.0 (V) 

Vbc Transconductance roll-off to tail-off 
transition voltage.

1.0 (V)

Deltgm Slope of transconductance 
compression characteristic.

0.0 (S/V)

Alpha Transconductance 
saturation-to-compression transition 
parameter.

1.0e−3 (V)

Table 39 Additional Parameters Used in EEHEMT1 for Gm Compression 

Parameter Description Default (Units)
Calibrating the Network Analyzer
 

All the EEFET3/EEHEMT1 S-parameter measurements require 
only one calibration: a swept broadband calibration across the 
operating frequency range of the device under test. Good 
calibration of the network analyzer is critical to a good 
measurement and extraction.

For step-by-step calibration procedures, refer to:

• Agilent 8510-based system—“Calibrating the Network 
Analyzer” on page 589 in Appendix B, “Using IC-CAP with an 
Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Calibrating the Network 
Analyzer” on page 631 in Appendix C, “Using IC-CAP with an 
Agilent 85123A Device Modeling System”

• Wiltron 360 network analyzer—Refer to the Wiltron 
documentation

Make the following additional setting changes:

• Set the frequency range for the calibration to the range you 
intend to use for your measurements, at least as wide as the 
operating range of the device. 
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• Set the network analyzer START frequency to the lowest 
possible frequency in the range of the network analyzer and 
bias networks: low frequencies allow more accurate AC 
conductances to be extracted. The example procedure in the 
software uses 50 MHz. 

• Set the STOP frequency to the upper limit of the frequency 
range for the device under test. Frequencies up to Ft are 
useful but not required. Good package and charge extractions 
require frequencies high enough to see roll-off and package 
effects clearly. The example procedure uses 3 GHz. 

• Set the NUMBER of POINTS to 51 or 101 to provide clear and 
usable S-parameter plots: more points only add more time 
and memory requirements to the measurement and 
extraction.

Remember these frequency values: you will also need to enter 
them in IC-CAP when instructed. If you do not set these values 
correspondingly, the calibration will be invalid. 

All S-parameter measurements for the EEFET3/EEHEMT1 
model are performed over the same frequency range.
NOTE If you set a MHz value in IC-CAP, write MEG in full. IC-CAP is not 
case-sensitive and assumes that m or M corresponds to milli. If an error 
message is displayed during the measurement that indicates a network 
analyzer frequency value is too low, you may have entered M only.
Remember the number of the network analyzer cal set or 
register where you store the calibration. You will need to use 
this number in the instrument options of each S-parameter 
measurement setup when you define the instrument states.
Using Macros for Measurements and Extractions
Macros automate the modeling procedure so that a series of 
similar devices can be modeled quickly with minimal user 
intervention. As a macro is run, it sets the control and device 
measurement variables in the model variable table usually 
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needed for the extraction procedure being run. The control 
variables are explained in the next pages. These are the macros 
and their purposes:

Table 40 Macro Descriptions

Macro Description

Set_Measurement_Ranges Execute the device preview (including 
Yang_Long_Preview) and initialization steps, 
setting all the control variables.

Package_extraction_only Measure the data from which the package 
parasitics are extracted, and perform the 
extractions.

DC_extraction_only Makes the DC measurements and performs the 
DC extractions.

AC_extraction_only Makes the S-parameter measurements and 
performs the AC extractions.

Measure_all_data Executes all measurements

Extract_all_parameters Extracts model parameters based on existing 
data

Measure_and_Extract_ALL Performs a complete device measurement and 
extraction using the measurement ranges 
recorded in the model variable table

Xtract Performs the parameter extraction procedure. 
Called by all the other macros except 
Set_Measurement_Ranges.
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Macro Sequence

One possible appropriate sequence for performing the macros is 
as follows:

1 Set_Measurement_Ranges 

2 Package_extraction_only

3 DC_extraction_only (and study the results)

4 AC_extraction_only (and study the results)

Control Variable Flags in the Macros

Control variable flags are set to 1 or 0 in the macros to simplify 
operation and customize the macros. Each macro starts with 
default values for the control variables, so they can be used as is 
or modified to meet your needs. For details, refer to “Running 
the Macros” on page 313.

Table 41 Macro Control Variables

Control Variable Set to 1 Set to 0

control_view Displays the plots. Suppresses the plots.

control_measure Performs the 
measurements.

Skips the measurement 
steps. Used with previously- 
stored data.

control_extract Executes the parameter 
extraction.

Skips the parameter 
extraction.

control_package Executes the package 
extraction.

Skips the package 
extraction.

control_dc_model Executes the DC 
measurement and 
extraction.

Skips the DC procedures.

control_ac_model Executes the AC 
measurement and 
extraction.

Skips the AC procedures.

control_save Saves a Series IV 
compatible file.

Does not save a Series IV 
compatible file.
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The control variables can also be set in the variable table, but 
control variable values set in the macros override variable table 
values.

To see more detail on the macro flags, you can select any macro 
to read the contents of the macro.

Running the  Macros

1 In the Model window, select the macro of your choice. 

2 To change control variable flags (see Table 42), use Back 
Space or Delete and replace the current value with a 
different value.
NOTE If you want to see the control variable values change when you execute 
the macro, Detach the model variable table.
 

3 To start the macro, click Execute. The macro will start to run. 
You can see the control variable values change in the model 
variable table if you have modified them in the macro.

4 If you select the Set_Measurement macro, you will be 
prompted to enter values for certain variables. Otherwise the 
variable table default values are used. Note that the variable 
values must be appropriate to the particular device being 
modeled, or the macro results will not be valid.
NOTE You will need to know several things about the device under test to supply 
appropriate values. For example, you will be prompted for the device gate 
width and length. You also need to supply certain voltage or current 
values. Some of these values can be found in the device manufacturer’s 
data sheet. The list of device input variable values later in this chapter also 
lends insight into appropriate values for different variables. Default values 
are also available, and may be appropriate for use in many cases.
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The macro will set numerical values for the control and 
device measurement variables (see Table 42) needed for the 
measurement and extraction procedure being run. Then the 
macro will perform the required measurement and 
extraction procedures.

If you have the control_view flag set to 1, you will see the 
measured and extracted data plotted on the screen.

When the macro is complete, the results of the extraction are 
displayed in the Status window.

Device Input Variable Values

One of the first requirements in performing the 
EEFET3/EEHEMT1 modeling procedures is to set numerical 
values for the model variables. When executing the macros, you 
are prompted for several variable values. Other variables are 
calculated by the software based on your input. The 
Set_Measurement_Ranges macro is especially useful in 
establishing initial settings in preparation for a complete 
extraction. We recommend that you use this macro for 
initialization of the model variable table.

Model Variables

The EEFET3/EEHEMT1 model variables are described in the 
following table.

Table 42 EEFET3/EEHEMT1 Model Variables

Variable Description

CAP_FACTOR Used as a scaling factor in setting charge parameter 
optimzation limits.

CHECK_DATA Used in the macros to control extent of application/user 
interface. Typically opens plots and performs transforms 
for visual inspections.

control_ac_model Used in the macros to control the AC measurement and 
extraction procedures. 1 performs the procedures, 0 does 
not.
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control_dc_model Used in the macros to control the DC measurement and 
extraction procedures. 1 performs the procedures, 0 does 
not.

control_doc Not used in this Model.

control_expert Used to control the level of interaction between the 
application and the user. 1 non verbose, 0 verbose.

control_extract Used in the macros to control the parameter extraction 
steps. 1 executes the extraction, 0 skips the extraction.

control_frequency Used in Set_Measurement Macro to set input responses 
which guide the user in determining whether or not to 
initialize Frequency settings and Instrument Options for 
Network Analyzer (NWA). 1 to guides the user through 
NWA settings, 0 does not.

control_hemt Determines whether the device will be modeled as a FET 
or a HEMT. It is normally set to 1 for a HEMT, and 0 for a 
FET. However, the HEMT setting generally works well with 
standard MESFETs also, providing a better Gm curve fit. In 
particular, it is suggested you use the HEMT setting for a 
device where the Gm curve peaks and then rolls off as Vgs 
becomes more positive.

control_measure Used in the macros to control the measurement steps. 1 
performs the measurements, 0 suppresses the 
measurements.

control_package Used in the macros to control the package parasitics 
measurement and extraction procedures. 1 performs the 
procedures, 0 does not.

control_save Used in the macros to save a Series IV compatible file. 1 
saves the file, 0 does not.

control_view Used in the macros to control display of the plots. 1 
displays the plots, 0 suppresses the plots.

control_YL_method Used in Xtract macro to guide the extraction process. Also 
used in the method for selecting Rs. 1 selects Yang Long 
method, 0 does not.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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FC The frequency at which the charge model is extracted. 
Use a frequency value that gives about 90 degrees of 
rotation of the S-parameters measured.

FG The frequency at which device conductances are 
extracted. Experience has shown that data just above the 
trap effects is the best for extraction of conductances.

FREQ_POINTS The number of points for S-parameter measurements. 
This must be the same as the number of points set for the 
network analyzer calibration. 51 or 101 provides clear and 
usable S-parameter plots: more points only add more time 
and memory requirement to the measurement and 
extraction.

FREQ_START The start frequency of the network analyzer for 
S-parameter measurements. Use the lowest possible 
frequency in the range of the network analyzer and bias 
networks: low frequencies allow more accurate AC 
conductances to be extracted. This must be the same as 
the start frequency set for the network analyzer 
calibration. (See “Calibrating the Network Analyzer,” later 
in this chapter.)

FREQ_STOP The stop frequency of the network analyzer for 
S-parameter measurements. This should be the upper 
limit of the frequency range for the device under test, and 
must be the same as the stop frequency set for the 
network analyzer calibration. Frequencies up to Ft are 
useful but not required. Good package and charge 
extractions require frequencies high enough to see rolloff 
and package effects clearly.

FS The frequency at which Tau and Ri are extracted. It must 
be about where S11 crosses the real axis: this is the point 
where the impact of the device parasitics causes the least 
problem.

I_RES The current resolution of the power supply being used. 
This value is used in macros to help truncate current 
limits to values that do not violate the resolution limits of 
the DC power supplies in use.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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Id_per_Wg_factor An empirical based scaling factor used for preliminary 
determination of Wg (gate Width) or IDSS, 
Set_Measurment Macro.

ID0_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

ID1_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

ID2_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

ID3_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

IDS_FACTOR Use as a scaling factor for setting the optimization range 
of DC-IV equation parameters: gmmax, vgo, vto etc.

IDS_MAX The compliance limit for Ids values. (The Agilent 41420A 
high-power SMU likely to be connected to the device drain 
has a maximum output current of 1.0A. A standard Agilent 
11612A option K10/K20 bias network has a maximum 
input current of 0.5A.)

IDS_NOM The intended Ids of device operation.

IDS_VTO_FACTOR The fraction of the maximum drain current that will define 
the drain current at Vto.

IDS_VTO_MAX Calculated value of Ids a Vto. (2 * IDS_VTO_MAX) 

IDS_VTO_MIN Calculated value of Ids at Vto.

IDS_YL_MAX The upper limit of Ids used to extract Rs. It also will be 
different for every transistor type and size. You will select 
this value from the data plot presented by the 
Yang_Long_Preview measurement. The value must be 
within 10% of IDS_YL_MIN.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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IDS_YL_MIN The lower limit of Ids used to extract Rs. It will be different 
for every transistor type and size. You will select this value 
from the data plot presented by the Yang_Long_Preview 
measurement. The value must be within 10% of 
IDS_YL_MAX. Remember to use values within the 
settability limits of the DC source/monitor.

IDS_YL_PTS The Yang_Long method requires swept measurements of 
two slightly different values of drain current, therefore the 
standard number of Ids points is 2. 

IDSS_ACTUAL Used to store value of Idss from measured data. Also used 
in calculations of other variables. In some cases 
IDSS_ACTUAL is assigned the value IDSS_DATA_SHT.

IDSS_DATA_SHT The Idss value for the device. This may be specified in a 
manufacturer’s data sheet. If you do not know an 
expected value for Idss, you can use the default value.

Ig_density The gate current density of the device, typically 50x106 
A/m2. The software uses the gate width and length 
values, in combination with the gate current density, to 
calculate safe forward gate bias levels.

IG_FWD_IV This is the maximum allowable DC gate current. This 
value is used to measure VG_FWD_IV, which in turn is 
used to set the value of VGS_MAX, the highest Vgs used 
in swept bias measurements.

IG_FWD_MAX This is the gate current at VG_FWD_MAX, and should be 
slightly less than the critical gate current IFwd but high 
enough to reduce the gate diode’s dynamic resistance to a 
few ohms. It is used in the ig_vgs device preview setup.

IG_FWD_MID This is a current about 95% of the value of IG_FWD_MAX. 
It is used to measure VG_FWD_MID.

IG_FWD_MIN This is a current about 95% of the value of IG_FWD_MID. 
It is used to measure VG_FWD_MIN. 

IG_FWD_RATIO The percent reduction of Ig from IG_FWD_MAX to 
IG_FWD_MID to IG_FWD_MIN. It is usually 
approximately 92% to 98% as specified by Dambrine and 
Cappy for their method of extracting Rg and Rd.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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IG_MAX Not used in this model.

IGS_MAX The compliance limit for Igs values. The default value, 
0.100A, is the maximum output current of the Agilent 
41421B medium-power SMU likely to be connected to the 
device gate. You provide compliance values to limit SMU 
output current or voltage and prevent damage to the 
device under test, as well as to the SMUs, bias networks, 
and probes if used.

IGS_YL_MAX Select this value in the linear region of the 
Yang_Long_Preview plot, at the upper end of the region, 
and where the Igs value is between 50 and 100 times 
smaller than the maximum Ids value selected.

IGS_YL_MIN For the Rs extraction Vgs is measured between 
IGS_YL_MIN and _MAX. Like the Ids values, you will 
select the Igs values from the data plot presented by the 
Yang_Long_Preview measurement. Select an 
IGS_YL_MIN value in the linear region of the plot, near the 
lower end, and where the Igs value is between 50 and 100 
times smaller than the minimum Ids value selected.

IGS_YL_PTS The number of Igs points used in the Rs extraction 
measurement. Remember in setting these last three Igs 
values to use limits and number of points values that 
result in steps within the settability limits of the DC 
source/monitor: the steps will be within uA spacing.

Lg The gate length of the device, in microns.

MEASURE_FAST Not used in this model.

model_file_name This is used to define the disk file name.

model_name Current name of model. Used in macro to specify iccap 
path (example: model_name > DUT > Setup > Plot)

Pdiss_MAX Maximum safe power dissipation of the device. This is 
used to check the VDS_MAX value once Idss is known.

RANGE_FACTOR Used to adjusts the limits of optimization for the dynamic 
IV parameter set.

Rch_factor Not used in this model.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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SIMULATOR not used in this model.

TOL_VOLT Not used in this model.

TOL_FUNC Not used in this model.

TRACE_MAX This sets an upper limit for the optimization range of Vds 
for the gm_gds optimization in the AC_all DUT.

TRACE_MIN This sets a lower limit for the optimization range of Vds for 
the gm_gds optimization in the AC_all DUT.

V_RES The voltage resolution of the power supply being used. 
This value is used in macros to help truncate voltage 
limits to values that do not violate the resolution limits of 
the DC power supplies in use. 

V_RES_vto Used to set the correct resolution for Vgs.

VD1_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

VD2_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

VD3_MAX_SUPPLY Used in determining if Power Supply limits have been or 
will be exceeded.

VDELT_FACTOR Used as a scaling factor when scaling the parameter 
EEFET3.vdelt.

VDS_COARSE The number of Vds points used for making DC-biased 
S-parameter measurements. A number between 5 and 15 
results in a good extraction.

VDS_FINE The number of Vds points used in gate characterization 
steps. 51 points is an adequate number.

VDS_MAX The largest safe Vds value for all Vgs values. Be aware of 
the power dissipation limits of your device at high Ids 
levels, to prevent damage to the device.

VDS_MIN The smallest value of Vds. This is usually 0.0V, but may be 
a negative value.

VDS_NOM The intended Vds of device operation. 

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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VDS_YL_LMT The maximum allowable Vds for Rs measurement and 
extraction.

VDS_YL_MAX The Rs extraction must be done at Vds values less than 
0.25V. This guarantees the extraction takes place in the 
region of linear transistor operation. Use a value at the 
upper end of the linear region. These Vds values generally 
will never have to be changed except in the case of a 
device with a very sharp knee.

VDS_YL_MIN This is the lower limit of the Vds range for the Rs 
extraction, which must be done at Vds values less than 
0.25V. Use a value in the linear region, near the low end of 
the region.

VDSO A Vds value just above the knee in full saturation. This is 
the point where the model equations simplify, and is an 
important operating characteristic for most GaAs FETs. 
Manufacturers often specify Idss at values of Vds that 
generally work well as Vdso settings. Vdso=3.0V is a good 
default that will nearly always work.

VG_FWD_IV A measured Vgs value where a normally small forward 
quiescent DC gate current flows for an active bias 
condition. It is used to help determine VGS_MAX for DC 
and AC measurements.

VG_FWD_MAX The upper limit of Vgs at VDS_ZERO for the rg_rd cold fet 
measurement.

VG_FWD_MID VG_FWD_MID is the gate voltage used to produce 
IG_FWD_MID.

VG_FWD_MIN  This is the lower limit of Vgs with Vds at VDS_ZERO, used 
to measure S-parameters at forward gate bias in the 
parasitic resistance measurement.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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VG_FWD_PTS The number of points for the rg_rd measurement. This is 
the number of measurements you wish to make between 
VG_FWD_MIN and VG_FWD_MAX, inclusively. Three 
points are sufficient.

This following series of _YL_ variables are all used in the 
Yang_Long measurements from which the parasitic 
source resistance Rs is extracted. It is highly 
recommended that the initialize transform be used to set 
these values once the Yang_Long_Preview measurement 
is made. The preview measurement is based on voltages 
that are nearly universally applicable. The initialize 
transform extracts the highly device-dependent currents 
needed to use this method of extracting RS. Refer to the 
procedures later in the chapter.

VG_GML_MAX The largest Vgs value used for Gummel measurements. 
Since this data is not used to extract contact resistances, 
use values that yield Igs values ≤ IFwd/2.

Note Remember that the Agilent 4142 DC source/monitor and its SMUs are 
limited in the ability to set and resolve voltage steps. In all cases where a 
measurement will be stepped over a number of points, set values that will make 
the voltage step size equal to an integer multiple of the Agilent 4142 voltage 
resolution. Voltage steps in fractional mV settings are not valid and will not work. 
The “Getting Started” chapter of the Agilent 4142B Operation Manual has more 
information on the voltage resolution of Agilent 4142B SMUs.

VG_GML_MIN The smallest gate characterization voltage, used for 
Gummel measurements. Data taken over this range is 
used in the gate diode and source resistance extractions. 
Values lower than about 0.2V to 0.3V result in Igs data 
that is indistinguishable from noise.

VG_GML_RANGE A minimum difference allowed between VG_GML_MAX 
and VG_GML_MIN, usually 0.5V. It helps to keep the gate 
characterization measurements within a linear, noise-free 
range.

VGO_FACTOR Used to initialize the parameter EEFET3.vgo.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
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VGS_COARSE The number of Vgs points used for making DC-biased 
S-parameter measurements. S-parameters will be 
measured at each of these bias points at every calibrated 
frequency point. If the VGS_COARSE number of points is 
specified too large, more data than necessary will be 
taken and the measurement will take an excessive 
amount of time. A number between 5 and 15 results in a 
good extraction. 

VGS_FINE The number of Vgs points used in gate characterization 
steps. 101 points is an adequate number. Remember that 
voltage steps in fractional mV increments do not work.

VGS_MAX The highest (most positive) Vgs value where the device 
can be operated quiescently at VDS_MAX.

VGS_MIN A Vgs value that gives even, easy-to-use steps and is 
more negative than the device pinchoff voltage at 
VDS_NOM.

VGS_NOM The value of Vgs that gives an Ids value representative of 
actual device operation.

VGS_YL_MAX The Vgs compliance for the Yang_Long_Method. This 
protects the device from overdrive on the gate. A value of 
0.6V will work for nearly all devices used, though 
occasionally it may need to be set to 0.7V.

VTO_FACTOR Not used in this model.

Wg The gate width of the device, in microns.

YL_IdIg_RATIO The factor used to compute acceptable gate currents as a 
function of drain current in Yang and Long’s source 
resistance method. Usually between 50 and 100.

Table 42 EEFET3/EEHEMT1 Model Variables (continued)

Variable Description
Executing Individual Measurement Transforms
While the macros are appropriate for measuring and modeling 
devices for which the device type is well known, you may prefer 
to set the variable values yourself rather than have them set by 
the macros. Or situations may occur where the device is not 
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known and you need to perform the device measurements 
separately and extract the parameters individually from the 
measured data.

When executing individual transforms, you will sometimes be 
prompted to supply variable values. You will also input some 
variable values directly in the model variable table. 

The rest of this chapter explains in detail how to:

• Make preview device measurements and set the model 
variables from the results obtained

• Make the measurements required for specific extractions

• Perform the individual extractions

• Save the resulting model

The Preview DUT

The Preview DUT contains three setups, as shown in the 
following illustration:

These setups are used to obtain a good set of measured DC-IV 
curves on which most of the other measurements will be based. 
In performing these measurements, you set the variable values 
to define the measurement limits. Some values are selected to 
protect a device from damage. Other values cause data to be 
taken over a wide enough range to ensure usable model results, 
or taken in specific regions of interest to you. 

Begin with anticipated reasonable values depending on your 
knowledge of the device under test. Then modify the values as 
necessary until you are satisfied with the measurement results. 
IC-CAP Nonlinear Devices Models Volume 2
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The validity of the later measurements and the accuracy of the 
model are dependent on obtaining a good set of preview 
measurements. Note, however, that when extracting many 
devices of the same type, repeated device preview is not 
necessary. 
NOTE The Set_Measurement_Ranges macro performs all the steps outlined 
here. A thorough understanding of what is done in these steps and how it 
fits into the extraction methodology will make the extraction process go 
more smoothly.
 

Parameter extraction must determine the bounds of a 
transistor’s operation without distorting or destroying the part. 
You need some knowledge of the device’s intended regions of 
operation to perform the device preview steps. The most 
accurate model performance is achieved when the intended use 
of the model is accounted for during measurement and 
extraction. 

The EEFET3/EEHEMT1 model does not test the breakdown 
characteristic of the GaAs FET. That value can be obtained from 
the results of destructive testing. The value of breakdown 
voltage is used by the model to establish the effects of large Vds 
values. It is assumed this value is known.

The device preview measurement procedures following provide 
explanations of setting the new values, and how the screen 
prompts, the variable table, and the input tables interact.
NOTE When you input variable values in the software, in macros or in 
non-automated procedures, they must be in numerical form. If you input 
non-numeric text when IC-CAP is expecting a number, IC-CAP will 
interpret it with a value of 0.0.
Preview / ig_vgs

This setup measures gate and drain voltage as a function of gate 
current. Four specific values of forward gate current are 
applied, with the drain current set to a constant value of 0.0A. 
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The purpose of the setup is to use the gate current density of 
the device, and the gate width and length, to set the proper 
variable values for gate voltage.

This setup determines several gate voltages that will be used in 
later measurements, and sets their values in the variable table. 
These variables are VG_FWD_MAX, VG_FWD_MID, 
VG_FWD_MIN, and VG_FWD_IV.

The input variables you set in the following procedure will 
configure the FET as shown in the following figure.

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Figure 109 FET Bias Configuration for ig_vgs Measurement
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Initializing The Input Variable Values

The inputs control the measurement. The variables listed in the 
inputs use the numerical values from the variable table. You 
define the actual numerical values in response to prompts from 
the software. You generally do not need to change the inputs, 
but they are illustrated and explained for your information.

The values you use will be dependent on your knowledge of your 
device under test. As you observe the results of the preview 
measurements, you can change the variable table values until 
you are satisfied with the measured results.

1 If you have not already connected the device, do so now. 
Observe antistatic precautions.
NOTE Remove any high-intensity light sources such as microscope light before 
taking a measurement. One easy method of blocking light is to place an 
opaque plastic box on the fixture directly above the device.
 
2 Select Preview > ig_vgs.

Notice the inputs ig and id. These are used by the software to 
control the measurement. Note that Mode is set to I to 
provide a current to both ig and id inputs.

Figure 110 Preview / ig_vgs inputs
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The Unit names must conform to the names you set in the 
hardware window (see “Getting Started in IC-CAP” on 
page 300). They must also correspond with the actual plug-in 
SMU connections from the DC source/monitor. SMU1 is the 
gate supply and SMU2 is the drain supply. Since the source is 
grounded, only the gate and drain inputs need to be set.

Compliance values limit SMU output voltage or current and 
prevent damage to the device under test, as well as to the 
SMUs, bias networks, and probes if used. With a current 
input, compliance refers to voltage. In the model variable 
table, set the Value of VGS_YL_MAX to a low value that will 
protect the device from overdrive on the gate. A value of 0.6V 
will work for nearly all devices, though occasionally it may 
need to be set to 0.7V or higher. Be sure to use a value within 
the resolution settability limits of the DC source/monitor.

3 In the model variable table, set the value of VDS_MAX to the 
largest safe Vds value for all Vgs values. Be aware of the 
power dissipation limits of your device at high Ids levels, to 
prevent damage to the device.

The Sweep Type for ig is set to List to allow four specific 
different gate current inputs. In list sweep mode, it is 
possible to specify up to 15 different bias inputs for the 
measurement. This measurement requires inputs of 
IG_FWD_MAX, IG_FWD_MID, IG_FWD_MIN, and 
IG_FWD_IV.

4 In the variable table, locate the values for IG_FWD_MAX, 
IG_FWD_MIN, and IG_FWD_IV.

5 From the Extract/Optimize folder, select the update_ranges 
transform and click Execute. The transform will check for 
data and then update the appropriate variables. 

6 The updated variable values will be listed in the Status 
window. 

Preview / id_vgs_at_vdso

This setup measures drain current as a function of swept gate 
voltage, with drain voltage set to a constant bias value equal to 
Vdso. The gate voltage is swept across the operating range from 
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minimum to maximum. The measurement covers all regions of 
device operation from subthreshold through threshold and high 
current regions.

Vdso is an important operating characteristic for most GaAs 
FETs. The model’s IV equations simplify greatly at Vdso. Setting 
Vdso appropriately helps to ensure that the rest of the IV and 
the dispersion parameters will extract efficiently.

This setup determines several gate and drain voltage and 
current variables, and sets their values in the variable table.

The input variables you set in the following procedure configure 
the FET as shown in the following figure.

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Figure 111 FET Bias Configuration for id_vgs_at_vdso Measurement
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NOTE Use the same settings as you did for the ig_vgs measurement, except set 
Integ Time to L (long) for maximum averaging for this measurement.
330

 

Then return to this chapter and continue.

Initializing the Input Variable Values

1 Select Preview > id_vgs_at_vdso.

Notice the inputs vg and vd (see the following figure). Note 
that Mode is set to V to provide a voltage to both vg and vd 
inputs. With a voltage input, compliance refers to current. 

2 In the model variable table, set the Value of IGS_MAX no 
greater than the maximum allowable gate current for your 
device in amps. Be sure to use a value within the resolution 
settability limits of the DC source/monitor. Also note that the 
maximum output current of the Agilent 41421B 
medium-power SMU likely to be connected to the device gate 
is 0.100 amp.

3 In the model variable table, set the Value of IDS_MAX lower 
than the maximum current for your device. The maximum 
output current of the Agilent 41420A high-power SMU likely 
to be connected to the device drain is 1.0 amp. 

Figure 112 Preview / id_vgs_at_vdso inputs
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• In this model, the compliance for vg is always IGS_MAX 
and the compliance for vd is always IDS_MAX.

• The Sweep Type for vg is set to LIN to provide a linear 
voltage sweep from start to stop gate voltage values. The 
Sweep Type for vd is set to CON for a constant drain 
voltage value equal to Vdso.

4 Set VGS_MAX to the highest (most positive) Vgs value where 
the device can be operated quiescently at VDS_MAX. 
(VDS_MAX is the largest safe Vds value for all Vgs values.)

5 Set VGS_FINE to a fairly large number of points, sufficient to 
display the detail of the measurement across the trace. 
Typically, 101 points is an adequate number. Note that 
voltage steps in fractional mV increments do not work.

6 From the Extract/Optimize folder, select the initialize 
transform and click Execute. The plots will be displayed, and 
screen prompts will ask you to input values for other 
variables needed in this measurement. Use values 
appropriate for your device.

VDSO is one of the most important operating characteristics set 
in the model. Usually a transistor’s static IV curves will peak up 
a little just after the device enters the saturation region. The 
value of Vds at this peak is a perfect value for Vdso. If the device 
shows no hump in the IV curves at about Vds=3.0V, select a Vdso 
value approximately 1V above the knee of the Vgs=0 curve. 
Vdso=3.0V is a good default and will nearly always work. It is 
important that Ids is at its quiescently measured maximum at 
this point. Device manufacturers often specify Idss at a value of 
Vds that is ideal as a setting for Vdso.

When you have responded to all the prompts, the transform 
measures the device and updates the plots. It sets appropriate 
numerical values for the relevant variables, and lists them in 
the model variable table and the Status window. Preliminary 
values for some of the model parameters will also be listed.
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The dc_iv plotted data should resemble the previous figure in 
shape, though the values will be specific to your device. It is 
most important to include data points in the subthreshold 
region. Note that as Vds becomes more positive the device 
threshold will tend to become more negative. If the data 
indicates the device is not operating in the correct range, you 
will need to redo the initialization and change the input variable 
values you set, particularly the VGS_MIN and/or VGS_MAX 
values. 

• If the measured data looks wrong for your device, check the 
probe contacts, the bias connections, and the measuring 
instruments. Make sure the device is oriented properly, with 
the right ports connected to the right terminals. If none of 
these resolves the problem, the device may be defective.

• If you want to save the measured data for later comparison 
with data predicted by the extracted model, choose File > 
Save As. Enter an appropriate filename (for example 
id_vgs_at_vdso), and click OK.

Figure 113 Example dc_iv Plot in the id_vgs_at_vdso Setup
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Preview / id_vds_vgs

This setup measures drain current with respect to drain 
voltage, at several values of gate voltage. The drain voltage is 
swept from 0V to the upper limit of its operating range. The 
measurement covers the overall region of device operation, and 
plots the characteristic IV curves vs. Vds.

The input variable values you set will configure the FET as 
shown in the following figure.

Defining the DC Source/Monitor Instrument State

The instrument states need to be set independently for each 
setup. Use the same settings as you did for the id_vgs_at_vdso 
setup, except that you can set Integ Time to M (medium) to 
allow a faster measurement time: this measurement does not 
require maximum averaging.

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Figure 114 FET Bias Configuration for id_vds_vgs Measurement
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Then return to this chapter and continue.

Initializing the Input Variable Values

1 Select Preview > id_vds_vgs setup and observe the inputs vg 
and vd (see the following figure).

• Notice that for this measurement, both vg and vd are set 
with a Sweep Type of LIN to provide a linear sweep from 
minimum to maximum values.

• Note that the Sweep Order for vd is set to 1, and for vg is 
set to 2.

• The Start and Stop values for vg are set to VGS_MIN and 
VGS_MAX as in the previous measurement. However, # of 
Points is now set to VGS_COARSE. This represents the 
number of separate measurement traces that will be made 
of Id at evenly-stepped Vgs values. In the variable table, set 
the VGS_COARSE value to a fairly low number, between 5 
and 15, so that the separate traces will be distinguishable. 
Remember that fractional mV step values will not work.

2 For VDS_COARSE, set a number sufficient to display the 
measurement clearly across the trace but without the need 
for detail: an arbitrarily large number of data points does not 
increase model accuracy. A VDS_COARSE value between 5 
and 15 will provide enough detail without unduly slowing the 
measurement.

Figure 115 Inputs for id_vds_vgs Measurement
IC-CAP Nonlinear Devices Models Volume 2



Agilent EEFET3/EEHEMT1 Model 6

IC-CAP Nonlinear Devices Models V

 

3 From the Plots folder, select the dc_iv plot and click Display 
Plot. A plot of the device characteristic curves will be 
displayed. 

4 Set VDS_MIN to the smallest value you will use for Vds. This 
is usually 0.0V, but may be a negative value. 

5 Set VDS_MAX to a value in saturation well above Vdso. This 
should be the largest safe Vds value for all Vgs values. Be 
aware of the power dissipation limits of your device at high 
Ids levels, to prevent damage to the device: Pdiss_MAX must 
not exceed VDS_MAX*IDS_MAX.

When you have input all the necessary values, click Measure. 
This measures the device and updates the plot. Review the 
plot and if needed change the necessary variables and 
re-measure.

Figure 116 Example Measured ids_vds_vgs Device Preview Data
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The plotted data should resemble the previous figure. If it 
does not, you may need to change the VDS and/or VGS 
variables. Continue until you have an appropriately nominal 
set of characteristic IV curves displayed, showing good 
coverage of the Vds and Vgs features.

6 Optionally, to save the measured data, choose File > Save As. 
Enter an appropriate filename and press Enter or click OK.

7 Close the plot.

The Source_Resistance DUT

There are many different approaches to the measurement and 
extraction of the common lead resistance in junction FET 
devices. Perhaps the most common is the “end resistance” 
measurement method where the unbiased drain terminal is 
used as a voltage probe to measure the voltage at the top end of 
Rs while a substantial current is forced into the gate. While that 
method is fairly good, it includes inaccuracy due to channel 
resistance effects. The method presented here overcomes the 
problem by correcting for the effect of the open channel 
resistance (see “End Resistance Technique” on page 398). 

Modified End Resistance Measurement Technique

The Yang and Long method computes the value of Rs from the 
change in Vgs due to the application of two drain currents, 
which are 50 to 100 times greater than Ig. The two drain 
currents are chosen to be within the drain’s linear IV region 
(Vds < 0.25 volts).

The data for the computation of Rs is taken by sweeping Ig over 
a range that results in measured Vgs values in the range of 
0.300V to 0.600V. Two separate Ig sweeps are made, with 
current forced at the drain terminal at two levels. The smaller of 
the two Id currents is chosen to be within 10% of the larger.

The current values needed by this method are highly dependent 
on the voltage limits specified. The voltage limits, however, are 
nearly universal and will work with nearly any device. The 
process thus requires Preview to set the voltages, and then uses 
the voltage data to provide the needed current ranges.
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The authors provide derivations for the shift in Vgs that depend 
only on the gate diode’s active resistance and Rs. The form of 
these expressions cannot be reduced to Rs=xxx, so the 
measured and computed delta Vgs values are optimized until a 
suitable Rs is found.

In order for this method to work, the gate diode characteristics 
Is and N must first be known. These are characterized in the 
gate_diode measurement. Thus three setups are required for 
this technique: the Yang_Long_Preview, the gate_diode, and the 
Yang_Long_Method.

Source_Resistance / Yang_Long_Preview

This setup measures both Ig and Id as a function of Vg, and 
displays the results on a log scale. The setup is used to ensure 
that the current input values chosen fall within the limits 
prescribed in the original paper by Yang and Long.

In this setup the values for several Yang_Long method variables 
will be determined and set in the model variable table.

The input variables configure the FET as shown in the following 
figure.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

Figure 117 FET Bias Configuration for Yang_Long_Preview Measure-
ment
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• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements, except set Integ Time to L. Then return to this 
chapter and continue.

Initializing the Input Variable Values

1 Select Source_Resistance > Yang_Long_Preview. and observe the 
inputs vg and vd (see the following figure).

• Both the vg and vd Sweep Type are set to LIN for a linear 
sweep from start to stop values.

• The vg # of Points is set to VGS_FINE to allow clear and 
accurate definition across the trace.

• The vd # of Points is set to 2 to provide Vd measurements 
at two closely spaced values.

2 Select Extract/Optimize folder, select the initialize transform 
and click Execute. The transform selects the appropriate 

Figure 118 Inputs for Yang_Long_Preview Measurement
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current values for the device under test and saves them in 
the variable table.

The VG_GML values should be set to voltages that comply 
with the methods defined by Yang and Long. Usually the 
defaults (0.3V for VG_GML_MIN and 0.6V for VG_GML_MAX) 
are adequate and you will probably not need to change them.

The Rs extraction is done in the linear region of transistor 
operation. Therefore both VDS_YL_MIN and VDS_YL_MAX 
are values in the linear region of Vds, at values less than 
0.25V. Generally, these Vds default values never need to be 
changed except in the case of a device with a very sharp 
knee.

3 Select the log10ig_id_by_vg plot and Display Plot. The plot 
should resemble the following figure, with measured traces 
for both Ig and Id, plotted on a log scale. Sometimes the top 
end of the measured range may show some resistive effects: 
this will be windowed out in the extraction procedure later.

Figure 119 Example Yang_Long_Preview log10ig_id_by_vg Plot
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The data on this plot is used to select current values to be 
used in the Yang_Long_Method setup. You will use the data 
to select the minimum and maximum values for IGS_YL and 
IDS_YL, which are used in the extraction of Rs.

4 Using the measured Ids traces, select lower and upper values 
for Ids that are within ten percent of each other, somewhere 
in the middle of the two traces. Select round numbers that 
are within the settability limits of the DC source/monitor. 
Enter your chosen values in response to the prompts for 
IDS_YL_MIN and IDS_YL_MAX. (The default value for 
IDS_YL_MIN is 0.058 amp, and for IDS_YL_MAX is 0.060 
amp.)

5 To select the values for Igs, pick values in the region of Igs 
where the trace is linear. Choose two values that are 50 to 
100 times smaller than the Ids values you have chosen. Enter 
your chosen values in response to the prompts for 
IGS_YL_MIN and IGS_YL_MAX. (The default value for 
IGS_YL_MIN is 0.5E−4, and for IGS_YL_MAX is 0.5E−5.)

When you have input all the necessary values, the transform 
sets numerical values for the relevant variables, and lists 
them in the model variable table and the UNIX standard 
output window.

6 To save the plotted data, choose File > Save As.

Source_Resistance / gate_diode

This setup measures swept gate current as a function of gate 
voltage, with Vds constant at zero, and displays the results on a 
log scale. This will be used for characterization of the gate diode 
forward conduction parameters Is and N. The dynamic 
resistance attributable to the gate diode formed by the Schottky 
contact is important to the extraction of all contact resistances. 

The FET configuration is illustrated in the following figure.
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.

Setting the Input Variables

1 From the DUT/Setup panel select the gate_diode setup and 
observe the vg and vd inputs. The following figure illustrates 
the inputs used in this measurement. 

Figure 120 FET Bias Configuration for gate_diode Measurement
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• The vg inputs are the same as in the Yang_Long_Preview 
measurement, with the gate voltage set to sweep over the 
voltage range from VG_GML_MIN to VG_GML_MAX.

• vd is set to a CONstant voltage of 0.0.

Measuring and Plotting

1 Select the log_ig_vg plot, and Display Plot. then click Measure. 
The plot should resemble the following figure, with Ig plotted 
on a log scale vs. Vg.

2 The transform to compute the value of Ig will be performed 
in the extraction part of the procedures.

Figure 121 Inputs for gate_diode Measurement
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3 Optionally, to save the plotted data, choose File > Save As.

4 Close the plot.

Source_Resistance / Yang_Long_Method

This procedure uses Ids and Igs values derived from the results 
of the Yang_Long_Preview measurement. The setup drives two 
different relatively small amounts of drain current into the 
device. It sweeps Igs values that are 50 to 100 times smaller 
than Ids, to give measured Vgs values that differ slightly: the 
difference is due to the common lead resistance. 

Device Configuration: The input variables configure the FET as 
shown in the following figure.

Figure 122 Example gate_diode log_ig_vg Plot
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.

The Input Variables

1 To view the input variables for this measurement, from the 
DUT/Setup panel, select the Yang_Long_Method setup and 

Figure 123 FET Bias Configuration for Yang_Long_Method Measure-
ment
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observe the vg and vd inputs. The following figure illustrates 
the inputs used in this measurement.

• Note that for this current-controlled measurement, the 
Compliances are voltage values.

• The ig Sweep Type is set to LIN for a linear gate current 
sweep from IGS_YL_MIN to IGS_YL_MAX. These are the 
extremely small positive voltage values you selected from 
the measured Yang_Long_Preview data. The IGS_YL_PTS 
default value of 11 is adequate.

• The id Sweep Type is set to LIN for a linear sweep 
measured at the IDS_YL_MIN and IDS_YL_MAX values 
you selected from the measured Yang_Long_Preview data. 
The IDS_YL_PTS value is always set to 2 for two swept 
traces.

Figure 124 Inputs for Yang_Long_Method Measurement
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Measuring and Plotting

1 From the Plots folder (for the Yang_Long_Method setup), 
select the delta_m_s plot, and Display Plot, then click Measure. 
The plot should resemble the following figure.

2 Select the opt_rs transform and Execute.

3 Optionally, to save the plotted data, choose File > Save As.

4 Close the plot.

Parasitics Measurements: The cold_fet and package DUTs

The extractions for intrinsic and extrinsic parasitics are 
performed on S-parameter data measured with a calibrated 
network analyzer. These measurements are made in the 
following setups:

• cold_fet/rg_rd

• package/Arnold_Golio

Figure 125 Example Yang_Long_Method delta_m_s Plot
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The cold_fet/rg_rd setup

The Rg and Rd contact resistances are extracted from cold FET 
measurements made with the device strongly forward-biased in 
both the gate-drain and gate-source regions. The method is 
similar to the work described by Dambrine, Cappy, et al.

Successful extraction of certain extrinsic parasitic elements is 
dependent on forcing the active device under test to a bias 
condition where its linear equivalent circuit reduces to a very 
simple form. While the Curtice model uses the “cold FET” 
method (Vds=0.0V, Vgs=0.0V) to optimize the contact resistances 
and parasitic inductances of the bond wires, further 
simplification can be achieved by strongly forward biasing the 
gate-source and gate-drain regions of the FET. This procedure is 
based on this premise.

Under conditions of strong forward gate bias the intrinsic 
charge model of the FET is shunted by small resistances of the 
forward active diode in the gate and the fully open channel 
between the drain and source. Under these circumstances the 
reactive behavior of the device is attributable to the lead 
inductances of the device. Both the drain and gate resistances 
are separable if the value of Rs is known.

This setup is substantially the same as the work of Dambrine 
and Cappy, though it does not exactly track their work (see 
“Contact Parasitic Resistance and Inductance Method” on 
page 398). The FET is forward-biased at three to five points. The 
extrinsic elements are constant while the gate and channel 
characteristics change.

Device Configuration: The following figure illustrates the device 
configuration for this measurement. For S-parameter 
measurements, a DC-biased RF signal is applied to the device 
gate from the network analyzer system source via the bias 
networks.
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Defining the Instrument States

You will need to set the instrument states for both the DC 
source/monitor and the network analyzer.

For the DC source/monitor, use the same settings as you did for 
the device preview measurements. Calibrate the network 
analyzer. In the instrument options for the network analyzer, be 
sure to set the Cal Set No to the cal set or register where you 
save your calibration.

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

You will use these instrument states in all the setups that make 
S-parameter measurements with the network analyzer. Then 
return to this chapter and continue.

Figure 126 FET Bias Configuration for rg_rd Measurement
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Setting the Input Variables

1 Select the rg_rd setup to view the inputs and outputs. Notice 
The frequency input is set to LIN for a linear sweep over the 
calibrated network analyzer frequency range.

2 Click the Model Variables tab and set FREQ_START, 
FREQ_STOP, and FREQ_POINTS to the start frequency, stop 
frequency, and number of frequency points you used for your 
network analyzer calibration.

Notice the input vg is set to sweep at three specific values 
that will heavily forward bias the gate diode. 

Notice the input vd is set to CON for a constant value of 
VDS_ZERO.

Measuring and Plotting

1 In the rg_rd setup select the im_z12 plot, and Display Plot. then 
click Measure. The plot should resemble the following figure. 
The data plotted is the imaginary part of the intrinsic Z12, 
derived from S12, which will be used in the extraction 
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procedures to give preliminary values for the bond 
inductances, as well as the Rg and Rd values.

2 Close the plots.

Package Parasitics: the package DUT

RF parameter extraction and large-signal model generation 
require the reduction of a large number of S-parameter sets into 
an equivalent circuit format. Although numerical optimization 
techniques have often been used for extracting these 
small-signal models, their problems with uniqueness and long 
execution times make them impractical here. Fast techniques 
for extracting complete small-signal models have been described 
previously but all require the additional RF characterization of 
the cold FET in order to extract parasitic inductance. This 
offers preliminary inductance values, but the values are not 
completely accurate since the model has not been derived solely 
from the data it is asked to model.

Figure 127 Example im_z12 Plot in the rg_rd Setup
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The method described here is derived from the work of Arnold 
and Golio et al (see “Extraction of Package Parasitic and 
Intrinsic FET Equivalent Circuit Values” on page 398). It 
requires only RF characterization at the device operating point 
and knowledge of the parasitic resistances. The technique has 
been successfully applied to GaAs FETs and HEMTs. After 
determining the parasitic resistances from DC measurements, 
the remaining elements are computed directly from a single set 
of measured S-parameters. The method is very fast, and its 
results provide an excellent match to measured S-parameters 
throughout the saturation region.

The package/Arnold_Golio setup

The package resistance and inductance parasitics are extracted 
from S-parameter data measured across Vgs with Vds at the 
nominal operating point. It is particularly important to make 
sure the nominal operating conditions are used for extractions 
of contact resistance and parasitic parameters, otherwise 
errors are caused by bias dependencies that are not modeled.

This setup measures S-parameters at values of Vgs from 
pinchoff to Idss at the nominal Vds operating bias point. This 
large range of Vgs values allows the largest intrinsic model 
variations possible. Large variations in the FET element values 
increase the impact of the static package parasitics, making 
them easier to extract in the later procedures. The accuracy of 
this measurement is very dependent on a good network 
analyzer calibration.

Device configuration:
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Defining the Instrument States

Use the same instrument state settings for this procedure as you 
did for the rg_rd measurement, for both the DC source/monitor 
and the network analyzer. The instrument states need to be set 
independently for each setup.

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Then return to this chapter and continue.

Figure 128 FET Bias Configuration for Arnold_Golio Measurement
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Setting the Input Variables

1 Select the Arnold_Golio setup and observe the inputs. The 
following figure illustrates the inputs used in this 
measurement.

• The frequency inputs are set the same as for the rg_rd 
measurement.

• The vg value of VGS_MIN (which you set in the device 
preview measurements) is a value that is more negative 
than the device pinchoff voltage at the nominal operating 
voltage of Vds.

• VGS_MAX (set in device preview) is the highest (most 
positive) Vgs value where the device can be operated 
quiescently at VDS_MAX.

• VGS_COARSE is a number of points between 5 and 15.

Figure 129 Inputs for Arnold_Golio Measurement
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• Vd is set for a CONstant value of VDS_NOM, the nominal 
operating voltage of the device. VDS_NOM has not been 
used in any of the measurements so far, so you may need 
to set the value in the variable table.

Measuring and Plotting

1 From the Arnold_Golio setup, open the Plots folder and 
Display Plots, then click Measure. 

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plots.

The dc_iv DUT

The setups in the dc_iv DUT are used to obtain data for 
extracting DC-IV parameters. The setups used for these 
measurements are:

• ig_Is_N

• id_vgs_at_vdso

• id_vgs

• id_vds

The measurement procedures are straightforward, and in most 
cases are duplicates of measurements you have made in device 
preview or as part of the source resistance measurements. 
Therefore, in the majority of cases, you have already defined the 
measurement input values in the model variable table or in 
response to prompts, and will not need to modify the inputs. 
However, the inputs are illustrated and explained for 
clarification of how each measurement is made. You will need to 
define the instrument states in each setup.

To prevent possible bias oscillation, put the network analyzer in 
hold sweep mode.

dc_iv / ig_Is_N (Measuring)

This is the same measurement made in the gate_diode setup as 
part of the source resistance measurements. It measures swept 
gate current as a function of gate voltage with Vds constant at 
zero, and displays the results on a log scale.
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.
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The Input Variables

1 From the DUT/Setup panel, select the ig_Is_N setup and 
observe the inputs, as illustrated in the following figure.

• The gate voltage is set to sweep over the same Gummel 
range as in the gate_diode measurement.

• The drain voltage is set to VDS_ZERO.

Figure 130 Inputs for ig_Is_N Measurement
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Measuring and Plotting

1 Select the log_ig_vg plot, and Display Plot and then click 
Measure. The plot should resemble the following figure, with 
Ig plotted on a log scale vs. Vg.

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plot.

dc_iv / id_vgs_at_vdso (Measuring)

This is the same as the ids_vgs_at_vdso measurement you made 
as part of the device preview measurements. This measures all 
the values of Vg with Vds at a constant value of Vdso. It covers 
all regions of device operation from subthreshold up to the high 
current region.

Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

Figure 131 Example log_ig_vg Plot in the ig_Is_N Setup
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• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.

The Input Variables

1 From the dc_iv DUT, select the id_vgs_at_vdso setup and 
observe the inputs as illustrated in the following figure.

Figure 132 Inputs for id_vgs_at_vdso Measurement
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• The gate voltage is set to sweep across the device 
operating range from minimum to maximum.

• The drain voltage is set to a constant value equal to Vdso, 
the point where the model equations simplify.

Measuring and Plotting

1 Select the id_vg plot, and Display Plot. then click Measure. The 
plot should resemble the following figure with a single curve 
IV plot.

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plot.

dc_iv / id_vgs (Measuring)

This procedure measures drain current with respect to drain 
voltage at several values of gate voltage. The drain voltage is 
swept from 0V to the upper limit of its operating range.

Figure 133 Example id_vg Plot in the id_vgs_at_vdso Setup
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.

The Input Variables

Select the id_vgs setup and observe the inputs. The following 
figure illustrates the inputs for this measurement.
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• The gate voltage is set to sweep across the device 
operating range from minimum to maximum.

• The drain voltage is set to sweep from its minimum value 
to its maximum safe value.

Figure 134 Inputs for id_vgs Measurement
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Measuring and Plotting

1 Select the id_vg plot, and Display Plot then click Measure. The 
plot should resemble the following figure.

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plots.

dc_iv / id_vds (Measuring)

This is the same as the ids_vds_vgs measurement you made as 
part of the device preview measurements. The drain voltage is 
swept from 0V to the upper limit of its operating range. The 
measurement covers the overall region of device operation, and 
plots the characteristic IV curves vs. Vds. It uses the same 
inputs as the id_vgs measurement, except with the sweep order 
for vg and vd reversed.

Figure 135 Example id_vg Plot in the id_vgs Setup
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Defining the DC Source/Monitor Instrument State

Follow the steps described in the appropriate chapter shown 
next:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same settings as you did for the device preview 
measurements. Then return to this chapter and continue.
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The Input Variables

1 Select the id_vds setup and observe the inputs, as illustrated 
in the following figure.

• The gate and drain voltage values are set the same as for 
the id_vgs measurement.

• Note that the Sweep Order for vg is set to 2, and for vd is 
set to 1 to make the drain voltage the primary sweep.

Figure 136 Inputs for the id_vds Measurement
IC-CAP Nonlinear Devices Models Volume 2



Agilent EEFET3/EEHEMT1 Model 6

IC-CAP Nonlinear Devices Models V

 

Measuring and Plotting

1 From the Plots folder select the id_vd plot, and Display Plot 
then click Measure. The plot should resemble the following 
figure, displaying the device characteristic curves.

2 Optionally, to save the plotted data, choose File > Save As. 

3 Close the plot.

The AC_at_VDSO DUT

This DUT is used for making AC charge and dispersion 
parameter measurements. Two different S-parameter 
measurements are necessary for the extractions of the AC 
charge and dispersion parameters. The first measurement is 
performed with Vds set to a constant bias value of Vdso. The 
second has Vds actively biased across the device operating 
range. It is essential that the measurements be performed in the 
order listed, and that the extractions listed in the same DUT 
groupings with the measurement setups be performed from 

Figure 137 Example id_vd Plot in the id_vds Setup
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those corresponding setups. The extraction procedures later in 
the chapter will make clear which measurement setup is to be 
used for which extraction.

Make sure the network analyzer is in continuous sweep mode.

AC_at_VDSO / Meas_Spars

This setup measures S-parameters at values of Vgs from 
pinchoff to Vgs_max with Vds at Vdso, the point where the 
model equations simplify. The large range of Vgs values allows 
the largest intrinsic model variations possible, increasing the 
impact of the charge parameters and making them easier to 
extract. A good network analyzer calibration is important to the 
accuracy of this measurement and the subsequent charge 
parameter extractions.

Device Configuration: The following figure illustrates the device 
configuration for this measurement. A DC-biased RF signal is 
applied to the device gate from the network analyzer system 
source via the bias networks.

Defining the Instrument States

You need to set the instrument states for both the DC 
source/monitor and the network analyzer.

To define the DC Source/Monitor instrument state, follow these 
instructions:

Figure 138 FET Bias Configuration for the First Meas_Spars Measure-
ment
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• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same instrument state settings for this procedure as you 
did for the rg_rd and Arnold_Golio measurements. Then return 
to this chapter and continue.

The Input Variables

From the AC_at_VDSO DUT, select the Meas_Spars setup and 
observe the inputs. The following figure illustrates the inputs 
used in this measurement.

Figure 139 Inputs for the First Meas_Spars Measurement
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• The frequency inputs are set the same for all S-parameter 
measurements in this model, corresponding with the 
frequency settings of the network analyzer calibration.

• The gate voltage is set to sweep across the device 
operating range from minimum to maximum.

• The vg # of Points is set to VGS_COARSE. This ensures 
that the data taken is the least that will yield good 
measurement results with S-parameter plots that are 
understandable. Using too many measurement points 
causes the extractions to be very time-consuming and the 
plots to be confusing.

• The drain voltage is set to a CONstant value equal to Vdso, 
the point where the model equations simplify.

Measuring and Plotting

1 With the Meas_Spars setup selected, Display Plots then click 
Measure.

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plots.

About the Other Setups in the AC_at_VDSO DUT

Note that no measurements are performed in the other setups 
in this DUT. These setups will be used later, in the extraction 
procedures, based on the data measured in this first 
Meas_Spars setup. However, it is important that the DC input 
variables for vg and vd be set exactly the same as in the first 
Meas_Spars setup, with one exception. The exception is that the 
vg Sweep Order is set to 1 instead of 2, because there is no 
frequency sweep. 

AC_all / Meas_Spars

This setup measures S-parameters at values of Vgs from 
pinchoff to Vgs_max and values of Vds swept across the device 
operating range. Again, a good network analyzer calibration is 
essential: if the calibration is incorrect or has drifted, the 
modeled data will be impossible to fit to the measured data.
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Device Configuration:

Defining the Instrument States

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same DC source/monitor and network analyzer settings 
as you did for the first Meas_Spars and the other S-parameter 
measurements. Then return to this chapter and continue.

The Input Variables

From the AC_all DUT, select the Meas_Spars setup and 
observe the inputs. The following figure illustrates the inputs 
used in this measurement.

Figure 140 FET Bias Configuration for the Second Meas_Spars Measure-
ment
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• The frequency inputs are set the same as for the other 
S-parameter measurements.

• The gate voltage is set to sweep across the device 
operating range from minimum to maximum.

• The drain voltage is set to sweep from its minimum value 
to its maximum safe value.

• The # of POINTS for both vg and vd is set to COARSE to 
allow good measurement results without excessive 
data-taking.

Measuring and Plotting

1 With the Meas_Spars setup selected, Display Plots then click 
Measure.

2 Optionally, to save the plotted data, choose File > Save As.

3 Close the plots.

Figure 141 Inputs for the Second Meas_Spars Measurement
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About the Other Setups in the AC_all DUT

Note that no measurements are performed in the other setups 
in this DUT. They will be used later, in the extraction 
procedures, based on the data measured in the second 
Meas_Spars setup. However, it is important that the DC input 
variables for vg and vd be set exactly the same as in the second 
Meas_Spars setup, with one exception. The exception is the 
Sweep Order, which is set to 1 for vg and 2 for vd, because there 
is no primary frequency sweep.

Storing the Measured Data

This procedure stores the data you measured for this particular 
device. You can then use the data to perform the extractions, to 
compare the simulated data with the measured data, and as a 
measurement record for comparison with other devices.

If you will be measuring large numbers of devices, it is 
worthwhile to organize your directory structure according to 
device type, geometry, and batch or wafer.

1 Decide where in your directory structure you intend to store 
this data file.

2 From the IC-CAP/Main window select Model, then select File 
> Save As from the pulldown menu. A dialog box is displayed.

3 Choose a filename that will clearly identify the measured 
device and the type of information stored, such as 
fet2_meas_12aug95. Type the directory path and the 
filename into the dialog box. 

4 Click OK or press Enter to store the data and close the dialog 
box.

5 When you want to use this data for an extraction at some 
future date, remember to change directories in IC-CAP by 
selecting Windows > Main Window and File > Change Directory... 
(See “Accessing Data from a Previous Measurement” on 
page 569.)

This concludes the measurement procedures. The extraction 
procedures follow.
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Once the measurements have been performed and a complete 
set of data collected for a particular device, the extraction can 
proceed. If you saved the measured data, you can perform an 
extraction at any later time. The Xtract macro can be used for 
an unattended extraction, or each extraction step can be 
processed individually to allow complete process control. The 
procedures in the following pages explain how to extract the 
parameters individually.

Displaying the Parameters Table

If the Parameters table is not already displayed on the screen, 
select Model Parameters from the Model window, and select 
Detach.... Move the Parameters table to a convenient corner of 
the screen: you will be using it throughout the extractions.

Extracting the Source Parasitic Resistance Rs

The Yang and Long method computes the value of Rs from the 
change in Vgs due to the application of two drain currents, 
which are 50 to 100 times greater than Ig. The two drain 
currents are within the drain’s linear IV region (Vds < 0.25 
volts). The smaller of the two Id currents is within 10% of the 
larger. The values were set in the source resistance 
measurement procedures.

The authors Yang and Long provide derivations for the shift in 
Vgs that depend only on the gate diode’s active resistance and 
Rs. The form of these expressions cannot be reduced to Rs=xxx, 
so the measured and computed delta Vgs values are optimized 
until a suitable Rs is found.

In order for this method to work, the gate diode characteristics 
Is and N must first be known. These are extracted from the data 
measured in the gate_diode setup. Thus two setups are required 
for this extraction: the gate_diode and the Yang_Long_Method 
setups.
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Extracting Is and N

1 In the Parameters table, locate the values for EEFET3.rs, Is, 
and n.

2 From the DUT/Setup panel, select the gate_diode setup, and 
select the Plots folder. 

3 From the Plots folder select log_ig_vg, and Display Plot. The 
plot shows Ig plotted on a log scale vs Vg.

4 From the Extract/Optimize folder, select the opt_is_n 
transform.

5 Click the Parameters tab to view the lower and upper 
optimization limits for EEFET3.Is and .n.

6 Click the Inputs tab to view the upper and lower bounds for 
Vgs that should limit the optimization range to the linear 
portion of the IV curve. If for some reason these limits are 
not sufficient, use the next step to establish more restrictive 
limits.

7 Click the Options tab to view the X_LOW, X_HIGH, Y_LOW, 
and Y_HIGH functions. These are optimization limits you can 
set from the data plot to select a portion of the trace for the 
optimization. The gate diode parameters should be optimized 
over only the linear portion of the trace, so use the 
X-low/X-high function as follows:

• Select setup gate_diode, then select Setup Variables folder. A 
variable table will appear, with current values for X-LOW 
and X-HIGH.

• From the plotted data choose a linear portion of the trace, 
along the constant slope.
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• Put the mouse pointer at the low end of the chosen portion 
and click left, then put the pointer at the high end and 
click left, to make a box on the trace, as shown in the 
previous figure.

• From the plot select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values to the lower and 
upper limits you selected on the trace.

8 Click Execute. The transform optimizes the plotted data, using 
the linear portion of the trace you defined with X-low/X-high, 
and enters the optimized values for Is and n in the 
Parameters table.

9 Close the plot.

Optimizing Rs

Driving two different relatively small amounts of drain current 
into a FET and then making swept Vgs measurements vs. Igs 
gives two sets of measured Vgs values that differ slightly. The 

Figure 142 Log Plot of Ig vs. Vg, with X-Low/X-High Values Selected
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difference is due to the common lead resistance. Measured and 
simulated delta_Vgs values are optimized in this procedure to 
yield a reasonable value of the common lead resistance Rs.
NOTE This extraction generally uses current values within the limits prescribed 
in Yang and Long’s original paper. (These are values you set in the 
Yang_Long_Preview measurement procedure.) If you chose values outside 
these limits, warning messages in the extraction phase will alert you to 
that fact. However, the warnings will not prevent the computations from 
completion, as you may have a valid reason not to use the specified limits: 
in this case, ignore the warning messages and use the computed values.
 

1 Select the Yang_Long_Method setup, and Display Plots.

2 From the Extract/Optimize folder, select opt_rs, and Execute. 
Observe the plots as the traces converge. The by_vgs plot 
shows the difference between the measured and simulated 
data.

Figure 143 Example Yang_Long_Method by_vgs Plot
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The opt_rs transform also calls the Vg_delta_m and 
Vg_delta_s transforms, so you need not perform them 
separately. The transforms optimize the measured and 
simulated Vgs shifts for the most accurate source resistance 
extraction.

The difference in measured and simulated Vgs values is used 
for the calculation of Rs. The previous figure illustrates the 
results of the optimization. The difference in Vgs values is 
caused by the common (source) lead resistance. Although the 
traces appear very different, note that the scale is very small 
and the values result in differences of fractions of an ohm.

3 Close the plots.

Extracting the Contact Resistances Rd and Rg

This extraction uses a device setup with the gate-source and 
gate-drain junctions of the FET strongly forward biased. Under 
conditions of strong forward gate bias the intrinsic charge 
model of the FET is shunted by small resistances of the forward 
active diode in the gate and the fully open channel between the 

Figure 144 The Computed Shift in Measured and Simulated Vgs Values
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drain and source. Under these circumstances the reactive 
behavior of the device is attributable to the lead inductances. 
Both the drain and gate resistances are separable if the value of 
Rs is known.

The FET is forward-biased at three to five points. The extrinsic 
elements are constant while the gate and channel 
characteristics change. In this extraction the extrinsic elements 
are optimized while the intrinsic device resistances are allowed 
to shift. The values of the extrinsic inductance elements are 
only initial values that will be refined in a later procedure.

This extraction is based on the S-parameter data you measured 
in the rg_rd setup. A transform in this extraction computes and 
saves a table of linear equivalent circuit parameters based on 
the measured S-parameters. It calculates the contact resistance 
parameters directly from the measured data, and allows you to 
compare the linear model extracted to the measured 
S-parameters.

1 In the Parameters table, locate the values for EEFET3.rg and 
rd.

2 From the DUT/Setup panel, select the rg_rd setup.

3 From the Plots folder, select the im_Z12 plot, and Display Plot. 
The data plotted is the imaginary part of the intrinsic Z12, 
derived from S12.

4 From the Extract/Optimize folder, select the auto_extr 
transform and Execute. This computes the values for the 
parasitic resistances Rg and Rd. It also calculates initial 
values for the parasitic inductances Lg, Ld, and Ls, which 
will be refined in the next procedure. The pad capacitances 
are defaulted to 0.0 for this procedure, and will be extracted 
later.

The calculated values for EEFET3.rg and rd will be entered in 
the Parameters table. Values for Rs, Rd, and Rg, as well as Ls, 
Lg, and Ld, will be displayed in the UNIX standard output 
window. An example of the calculated Z-parameter data is 
illustrated in the following figure.
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5 Close the plot.

Extracting the Package Parasitics

This extraction is based on the S-parameter data you measured 
in the Arnold_Golio setup (S-parameters at values of Vgs from 
pinchoff to Idss at the nominal Vds operating bias point). As the 
device goes through this wide range of measurement variations 
the package parasitic inductances remain constant, allowing 
them to be readily extracted.

A transform in this extraction computes and saves a set of 
linear equivalent circuit parameters based on the measured 
S-parameters. A set of modeled S-parameters are simulated 
based on the linear equivalent circuit. Any differences between 
the simulated and measured S-parameters are due to the 
package parasitics or to defects in the network analyzer 
calibration. (This is why a good network analyzer calibration is 

Figure 145 Example im_Z12 Data in the rg_rd Setup
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essential for success in this extraction.) A second transform 
optimizes the measured and simulated S-parameter data to 
extract the package parasitic inductances.

1 In the Parameters table, locate the values for lg.l, ld.l and ls.l. 

2 From the DUT/Setup panel, select the Arnold_Golio setup, and 
Display Plots.

3 From the Extract/Optimize folder, select mdl, and Execute. 
This computes a set of linear equivalent circuit parameters 
based on the measured S-parameters, and uses them to 
simulate a set of modeled S-parameters.

4 Select the transform opt_pkg, and Execute. This calculates the 
values for the package parasitic inductances.

You will see the traces converge on the plots, and the new 
calculated values for lg.l, ld.l, and ls.l will be entered in the 
Parameters table. Note that these are final values for the 
initial inductances calculated in the last procedure.

5 Optionally, you can change the optimization limits. Select 
Arnold_Golio setup, and Setup Variables. Modify values in the 
table as required.

6 Close the plots.

Extracting DC-IV Parameters

The DC-IV extractions start with preliminary estimates of some 
parameters and begin to establish firm values for some others. 
Four measurement setups and their measured data are used. 
The fourth and last DC extraction finalizes the initial values 
determined in the three previous setups.

Note that the thermal factor Peff has a major impact on the 
performance of nearly all model parameters. Therefore the 
initial value for Peff is set so high that it has no impact on model 
performance.
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dc_iv / ig_Is_N (Extracting)

This procedure uses measured gate current data to extract final 
values for the gate diode characteristics Is and N. (Initial values 
were found in the source resistance extraction using the 
gate_diode setup.)

1 Locate the value for EEFET3.peff in the Parameters table. 
Make sure the Value is set to a high number such as 100, high 
enough that it will have no effect on model performance. 

2 Locate the values for EEFET3.Is and n.

3 From the DUT/Setup panel, select the ig_Is_N setup.

4 From the Plots folder, select log_ig_vg plot, and Display Plot. 
The graph shows Ig plotted on a log scale vs. Vg.

The parameters should be optimized over only the linear 
portion of the trace. The input table contains upper and 
lower bounds for Vgs that should limit the optimization range 
to the linear portion of the IV curves. If for some reason these 
limits are not sufficient, use the X-low/X-high function to 
define the limits for a window of the linear trace.

5 From the Extract/Optimize folder select opt_is_n, and Execute. 
The transform optimizes the plotted data, using the linear 
portion of the trace you defined with X-low/X-high, and 
enters the optimized values for Is and n in the Parameters 
table.

6 Close the plot.

dc_iv / id_vgs_at_vdso (Extracting)

This procedure uses measured Ids data with Vg swept across 
the device operating range and Vd set to a constant value of 
Vdso. Thus it covers all regions of device operation from 
subthreshold up to the high current region, and makes use of 
the fact that the model equations simplify at Vdso.
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This data is used to set the value of Vto and to plot a curve for 
Gm. From these values the procedure extracts initial values for 
Vgo and Vdelt, as well as several other FET and HEMT 
parameters.

1 Leave EEFET3.peff set to a high value.

2 Locate the values for EEFET3.vt and EEFET3.vdelt.

3 From the dc-iv DUT, select the id_vgs_at_vdso setup, and 
Display Plots.

4 From the Extract/Optimize folder, select the initialize 
transform and Execute. This sets up the software to extract 
the device-specific parameters.

5 Select opt_vto_fet3 for a FET, or opt_vto_hemt1 for a HEMT, and 
Execute. The transform optimizes the plotted data, and enters 
the optimized values into the Parameters table.

dc_iv / id_vgs (Extracting)

This procedure is used to calculate an initial value for gamma, 
the parameter that controls the amount Vto shifts with 
increasing Vds. The final value for gamma will be refined in the 
last DC extraction.

The control range set for the data optimization is very 
important in this procedure.

1 Leave EEFET3.peff set to a high value.

2 Locate the value for EEFET3.gamma.

3 From the DUT/Setup panel select the id_vgs setup.

4 From the Plots folder, select id_vg plot, and Display Plot.

5 In the Model window select Setup Variables. Note the default 
values for Y_LOW and Y_HIGH. This control range for the 
data optimized is important: low values of Ids must be used. 
Ids values have to be windowed so that only the first 5% to 
10% of the Ids data is used, usually between 0.0 and a few 
milliamps for each trace. The X values should be left at 0 to 
ensure that all the X-axis data is used in the optimization.

6 From Extract/Optimize folder, select opt_gamma and Execute. 
You will see the low end of the traces converge on the plot, 
and the new calculated value for gamma will be entered in 
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the Parameters table. The following figure shows an example 
of the initial optimized gamma data.

Since this is an initial extraction step, the model fit is not 
ideal. Certain effects will be better modeled in subsequent 
stages.

7 Close the plot.

dc_ic / id_vds (Extracting)

This procedure extracts final values for parameters initially 
extracted in the DC-IV extraction procedures. In addition to 
Vdelt and Gamma, this procedure extracts the parameters 
Kappa, Vsat, and Peff.

1 Locate the values for EEFET3.vdelt, vsat, and vgo in the 
Parameters table.

2 From the DUT/Setup panel, select the id_vds setup and 
display the id_vd plot.

Figure 146 Example Initial Optimized Gamma Data in the id_vgs Setup
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3 From the Extract/Optimize folder, select opt_iv_fet3 or 
opt_iv_hemt1, and Execute. The transform optimizes the 
plotted data, and enters the optimized parameter values in 
the Parameters table.

Use the X-low/X-high function if desired, to select only a 
portion of the data for the optimization. This is appropriate if 
any of the plotted data looks anomalous.

4 Locate the optimized values for EEFET3.gamma, kappa, and 
peff in the Parameters table. You will notice that the value for 
EEFET3.peff has changed significantly. The following figure 
shows an example of the final optimized DC-IV curves.

If you decide to rework the DC-IV extraction phase, make 
sure to reset EEFET3.peff to a high value such as 100.

5 Close the plots.

Extracting Charge and Dispersion Parameters

Charge parameters are divided into two groups:

Figure 147 Example Plot of Final Optimized DC-IV Data
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• The gate charge parameter extraction is based on the 
S-parameter data measured at Vdso in AC_at_VDSO/ 
Meas_Spars.

• The output charge and dispersion parameter extractions are 
based on the S-parameter data measured with active DC bias 
in AC_all/Meas_Spars. 

It is important that the individual extractions are based on the 
correct set of S-parameter data: the data from the same DUTs in 
which the extractions are grouped. If the setups are mixed 
within DUTs or performed in the wrong sequence, the results 
will be wrong.

A transform in each procedure computes a set of linear 
equivalent circuit parameters based on the measured 
S-parameter data. The actual model parameters are extracted 
from this linear equivalent circuit data.

The dispersion parameters are grouped here together with the 
charge parameters because they also are extracted from the 
S-parameter data measured with active bias.

Extracting Gate Charge Parameters

This procedure uses the S-parameter data you measured in the 
first Meas_Spars procedure. Since the model equations simplify 
at Vdso, the charge parameters C11o and C11th, Vinfl, and 
Deltgs can most accurately be extracted with Vds set to a 
constant value of Vdso. These are initial values for C11o and 
C11th.

Extracting the Linear Equivalent Circuit

1 From the AC_at_VDSO DUT, select the Meas_Spars setup and 
Display Plots.

2 From Extract/Optimize folder, select mdl and Execute. This 
computes and saves a set of linear equivalent circuit 
parameters based on the measured S-parameters. Observe 
the changes in the plots. 

3 Close the plots.
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Extracting C11 Capacitance with C11_vgs

This procedure extracts the C11 capacitance looking into the 
gate terminal.

1 Locate the values for EEFET3.c11o, c11th, vinfl, and deltgs 
(near the bottom of the table).

2 Select the setup C11_vgs.

3 From the Plots folder, select the C11 plot, and Display Plot.

4 From the Extract/Optimize folder, select the initialize 
transform, and Execute to establish initial values.

5 Select the transform opt_to_C11 and Execute to calculate the 
final values. You will see the traces converge on the plot, and 
the calculated values for the parameters will be entered in 
the Parameters table. The following figure is a typical plot of 
the input capacitance of a GaAs FET over all Vgs values at 
Vdso.

Figure 148 Example Plot of Gate Input Capacitance Over Vgs at Vdso
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Generally you will not need to change any of the optimization 
limits for these gate charge parameters. However, the limits 
are very important to the correct functionality of the 
optimizer.

Extracting Gm and Gds with ac_gm_gds

This is an initial extraction for Gm and Gds. These parameter 
values will be refined in a later procedure.

1 Locate the values for EEFET3.gmmaxac, gammaac, kappaac, 
peffac, and vtoac in the Parameters table.

2 Select the setup ac_gm_gds, and Display Plots.

3 From Extract/Optimize folder, select Init_dispersion and 
Execute. 

4 Select opt_gm_fet3 or opt_gm_hemt1, and Execute. Observe the 
changes in the plots and the Parameters table values. You 
probably will not need to change the optimization limits.

There may be a slight tradeoff in match between Gm and Gds. 
When the Gds data is well-matched the Gm data may 
degrade. You may like to perform the optimization again to 
see if it improves the match of both Gm and Gds. Or you can 
repeat both the Init_dispersion transform and the opt_gm 
transform.

Note that Gm AC is lower than Gm DC because of trapping 
effects: this is not accounted for in most industry standard 
models.

5 Close the plots.

Extracting Output Charge Parameters

The extraction procedures in the following setups use the 
S-parameter data you measured in the second Meas_Spars 
procedure. It is essential you use that S-parameter data, and not 
jump directly to these extractions using the wrong set of 
S-parameter data.
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These procedures start by extracting the C21 and C22 
capacitances, and then fit Cdso and Tau to the extracted 
C21/C22 data using optimization. The final procedure extracts 
the dispersion parameters.

Extracting the Linear Equivalent Circuit

1 From the AC_all DUT, select the Meas_Spars setup and Display 
Plots.

2 From the Extract/Optimize folder, select mdl and Execute. 
This computes and saves a set of linear equivalent circuit 
parameters based on the S-parameters measured with bias. 
You will see the traces change on the plots, though a large 
amount of data is displayed and it is difficult to distinguish 
the convergence of individual traces.

3 Close the plots.

Extracting Initial Capacitance with Cgd_vgs_vds

This procedure extracts an initial value for the gate-to-drain 
capacitance.

1 Locate the values for deltds, lambda, and c12sat in the 
Parameters table.

2 Select the setup Cgd_vgs_vds.

3 From the Plots folder, select the Cgd plot, and Display Plot.

4 From the Extract/Optimize folder, select the transform 
opt_to_Cgd and Execute. Observe the changes in the plot and in 
the Parameters table values. 

Generally you will not need to change any of the optimization 
limits for these charge parameters. However, the limits are 
very important to the correct functionality of the optimizer.

5 Close the plot.
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Extracting Final Capacitance with Qg_vds_vgs

This procedures extracts final values for the capacitance 
parameters.

1 Locate the values for EEFET3.c11o and c11th in the 
Parameters table.

2 Select the setup Qg_vds_vgs.

3 From the Plots folder, select the C11 plot, and Display Plot.

4 From the Extract/Optimize folder, select the transform 
opt_C11_Cgd and Execute. You will see the traces converge on 
the plot, and the parameter values may change in the table. 
You probably will not need to change any of the optimization 
limits. The following figure illustrates a typical C11 plot.

The C11 plot shows how the input capacitance values trend 
upward vs. Vgs from threshold, spreading as they go toward 
the upper limits.

5 Note the values for EEFET3.c12sat and cgdsat in the 
Parameters table.

Figure 149 Example C11 Device Input Capacitance Plot
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6 Close the plot.

Extracting Tau and Ri with Tau_Ri

The extractions for Tau and Ri are grouped together, even 
though they are independent, because both parameters are 
dependent on good extraction of the extrinsic and package 
parasitics. Tau is the time constant delay of S21. It is hard to 
separate from the transcapacitance Cds, the output capacitance 
with a change in input voltage.

1 Locate the values for EEFET3.tau and cdso in the Parameters 
table.

2 Select the setup Tau_Ri_Cds. 

3 From the Plots folder, select the Tau and Cds plots, and Display 
Plot.

4 From the Extract/Optimize folder, select the opt_Tau 
transform and Execute. This optimizes both Tau and Cds. 
Observe the data change on the trace, and possible 
parameter value changes for EEFET.tau and cdso. The 
following figure illustrates an example of plotted Tau data. 
The spread in data is caused by capacitance effects.

Figure 150 Example Tau Plot
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If the Tau extraction yields a parameter value of zero or less, 
the problem may be in the earlier parasitic extractions. If the 
parasitic extractions look good and the Tau extraction looks 
bad, set a value for Tau manually. A good nominal value is 5.0 
picoseconds for a 0.5 um GaAs FET, scaled approximately 
linearly with gate length for other FETs.

5 Close the Tau and Cds plots. Display the Ri plot.

6 Locate the value for EEFET3.ris in the Parameters table.

7 Select the opt_ri transform and Execute. Observe the data 
change on the trace, and a possible parameter value change 
for EEFET3.ris. The following figure illustrates example Ri 
data.

If the Ri extraction yields a value of zero or less, it indicates 
that the contact resistance Rg was extracted too high. If this 
is the case, you may wish to re-iterate the rg_rd extraction 
for more accurate results. Ri is typically a value of only a few 
ohms, which may erroneously be attributed to Rg. The effect 
may be unimportant if the total of the gate resistances is 

Figure 151 Example Ri Plot
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good. If the fit of total gate resistance to S11 is sufficiently 
good the iteration of the rg_rd contact resistance extraction 
is not necessary.

You can also reset the value of EEFET3.rg in the Parameters 
table a little lower, forcing the remaining resistance to be 
attributed to Ri. If you do this, or if you re-iterate the rg_rd 
contact resistance extraction, you must perform the mdl 
transform in the second Meas_Spars setup again before 
performing the opt_ri transform in this setup. Then check 
the Parameters table values for Ri again.

8 Close the plot.

Extracting Dispersion Parameters

Both Gm and Gds change in GaAs devices due to traps and 
other effects. This procedure adjusts the dispersion parameters 
that model this behavior. The setup used in this extraction is 
tied to the S-parameter measurement and linear equivalent 
model extracted in the second Meas_Spars setup. The mdl 
transform in that setup must be active (that is, no other 
S-parameters must be measured and no other mdl transform 
must be run since the one in the second Meas_Spars setup).

1 If the mdl transform in the second Meas_Spars setup has not 
been run, open that setup and Execute the transform.

2 Scroll the Parameters table to show some of the following 
parameters: EEFET3.gmmaxac, gammaac, kappaac, peffac, 
vdeltac, gdbm, kdb, and vdsm. You will not be able to display 
them all at the same time.

3 Select the setup ac_gm_gds. 

4 From the Plots folder, select Gm plot, and Display Plot.

5 From the Extract/Optimize folder, select the transform 
opt_gm_fet3 or opt_gm_hemt1, and Execute. Observe the traces 
converge on the plot, and the parameter values change in the 
table. The following figure illustrates example Gm data. Some 
dynamic thermal effects may be observed.
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You can use the X-low/X-high function if you want to 

optimize over only a portion of the trace.

6 Scroll the Parameters table to show more of the relevant 
parameters.

7 Display the Gds plot.

8 Select the opt_gds transform, and Execute. Observe the traces 
converge on the plot, and the parameter values change in the 
table. The following figure illustrates example Gds data.

Figure 152 Example Gm Plot in the ac_gm_gds Setup
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In some cases there may be a tradeoff between a good data fit 
at threshold and in the active region of operation.

Verifying the Model Against the Measured Data

This procedure uses the File_Validate setup to verify that 
modeled S-parameter data is comparable to measured data. An 
S-parameter measurement is performed at one bias value—the 
specific bias of expected device operation. This allows a single 
bias condition to be isolated for comparison purposes, which 
cannot be done with the multiple-bias conditions of earlier 
S-parameter measurements.

Defining the Instrument States

To define the DC Source/Monitor instrument state, follow these 
instructions:

• “Defining the DC Source/Monitor Instrument State” on 
page 595 (for an Agilent 8510-based system) in Appendix B, 
“Using IC-CAP with an Agilent 85122A Precision Modeling 
System”

Figure 153 Example Gds Plot in the ac_gm_gds Setup
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• “Defining the DC Source/Monitor Instrument State” on 
page 621 (for an Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”

Use the same DC source/monitor and network analyzer settings 
as you did for the Meas_Spars and other S-parameter 
measurements. Then return to this chapter and continue.

The Input Variables

1 From the Utilities DUT, select the File_Validate setup and 
observe the inputs. The following figure illustrates the inputs 
used in this measurement.

• The frequency inputs are set the same as for the other 
S-parameter measurements.

• The gate voltage is set for a CONstant value of VGS_NOM, 
the value of Vgs that gives an Ids value representative of 
actual device operation.

• The drain voltage is set for a CONstant value equal to the 
intended Vds of device operation.

Figure 154 Inputs for Verification Data
IC-CAP Nonlinear Devices Models Volume 2



Agilent EEFET3/EEHEMT1 Model 6

IC-CAP Nonlinear Devices Models V

 

Measuring and Plotting

1 With the File_Validate setup selected, select Display Plots, 
then click Measure.

2 From the Extract/Optimize folder, select mdl and Execute. 
This embeds the extrinsic elements and makes the model 
parameters comparable with the measured results.

3 Observe the measured and modeled S-parameter data on the 
plots. The plot below illustrates typically well-converged 
data.

Storing the Model

This procedure stores the model in IC-CAP, including all the 
device-specific measured and simulated data. Once you have 
developed the device model, it can be used as a component in 
the Agilent RF and Microwave Design System (MDS). You can 
use it for circuit simulation, inserting it into circuits under 
design to emulate the characteristics of your device.

Figure 155 Measured and Modeled S11 and S22 Data
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If you will be modeling large numbers of devices, it is 
worthwhile to organize your directory structure according to 
device type, geometry, and batch or wafer. 

1 Decide where in your directory structure you intend to store 
this model file.

2 From the IC-CAP/Main window select Model, then select File 
> Save As from the pulldown menu. A dialog box is displayed.

3 Select a new filename that associates this model with the 
device, for example eefet6_9jun95.mdl. Type the full 
directory pathname and the filename into the dialog box.

4 Select OK or press Return to store the data and close the 
dialog box.

Saving the Parameters for Series IV Compatibility

A transform in the File_Validate setup lets you save the model 
parameters in a format that can be used by the Series IV Design 
System.

1 From the DUT/Setup panel select the File_Validate setup.

2 From the Extract/Optimize folder, select the transform 
SaveFile, and Execute.

3 Type a filename for the parameters and click OK. The 
parameters will be saved in a Series IV-compatible format. 
The format is MDIF (measurement data interchange format). 
When the transform is run, a copy of the MDIF file is written 
to the UNIX standard out window.

Saving the Parameters in SPICE Format

You can also save the list of individual model parameters in 
SPICE format for later access. These parameters can be read 
directly into MDS.

1 From the Model window choose File > Export Data > Extracted 
Deck. Select a new filename, for example fet6pars.mdl. Type 
the full pathname and your filename into the dialog box.

2 Click OK or press Enter to store the parameters in SPICE 
format.
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This completes the example high-frequency EEfet3 
measurement and parameter extraction procedure. For an 
explanation of how to use IC-CAP model data in MDS, refer to 
Appendix D, “Using IC-CAP Data with MDS.”
olume 2 397



6 Agilent EEFET3/EEHEMT1 Model
References
398

 

1 End Resistance Technique

New Method to Measure the Source and Drain Resistance of 
the GaAs MESFET. Long Yang and Stephen I. Long. IEEE 
Electron Device Letters Vol. EDL-7, No. 2, February 1986.

2 Contact Parasitic Resistance and Inductance Method

A New Method for Determining the FET Small-Signal 
Equivalent Circuit. Gilles Dambrine, Alain Cappy, Frederic 
Heliodore, and Edouard Playez. IEEE Transactions on 
Microwave Theory and Techniques, Vol. 36, No. 7, July 1988.

3 Extraction of Package Parasitic and Intrinsic FET Equivalent 
Circuit Values

Direct Extraction of GaAs MESFET Intrinsic Element and 
Parasitic Inductance Values. Eric Arnold, Michael Golio, 
Monte Miller, and Bill Beckwith. IEEE MTT-S Digest pp. 
359-362, 1990.
IC-CAP Nonlinear Devices Models Volume 2



Agilent 85190A IC-CAP 2008
Nonlinear Device Models Volume 2

 

7
The Agilent EEBJT2 Model

Getting Started in IC-CAP 400

Using the EEBJT2 Model 402

Validating the Model with the AC_validation DUT 454

References 455

The Agilent EEBJT2 model is a nonlinear bias-dependent 
packaged semiconductor device model for silicon BJTs, based 
on the well-known Gummel-Poon model, with modifications.

The model has been created for automatic parameter extraction 
from measured data including DC and S-parameter 
measurements. It can also be used for non-automated 
extraction or fine tuning of individual parameters. EEBJT2 
provides an accurate reproduction of transistor behavior, with 
DC bias, bias-dependent S-parameters including effects of 
package parasitics, and true nonlinear harmonic output power. 
The model is quasi-static, analytical, and isothermal. The model 
does not scale with area, since parameters are extracted 
directly from measured data and not from layout 
considerations. 
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The starting point of this tutorial assumes the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed as follows, 
based on the instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Rename a medium-power SMU connected to the device base 
as SMU1

Rename a high-power SMU connected to the collector as 
SMU2

Rename the GNDU unit (which must be connected to the 
emitter) as GND
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Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on launching the IC-CAP software and opening the model file 
you need. The EEBJT2 model file is under: 

/examples/model_files/bjt/HPEEbjt2.mdl

Then return to this chapter and continue with the procedures 
here.

Before you continue with the IC-CAP procedures, make a new 
directory in an appropriate location in the UNIX structure, 
using the mkdir command, to store the data and model files that 
will be generated. Give the directory a name that will associate 
it with the devices you are going to model. Use the cd command 
to change to the new directory in UNIX.
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The base-emitter current in the EEBJT2 model has been 
changed from the Gummel-Poon and other earlier models. These 
models assume that the non-leakage base-emitter current is 
related to the collector-emitter current by a simple constant 
known as beta. In EEBJT2, the non-leakage base and collector 
currents are modeled with separate equations. This approach 
simplifies the extraction process and, in some cases, may 
provide a superior fit to the measured data. For more detail 
refer to the IC-CAP Reference manual.

The EEBJT2 model provides the following features:

• High-level accuracy for a wide range of processes and 
operating conditions.

• Extraction of package parasitics, significant at higher 
frequencies.

• A complete set of model parameters that can be acquired 
directly from measurements (without knowledge of process 
information).

• A high level of automation.
The DUTs and Setups
The DUT/Setup panel is part of the Model window, which is the 
central access point for all the measurement and parameter 
extraction procedures you perform. The Model window includes 
tabs to access the macros, the Model Parameters table, and 
other IC-CAP features. To open this model, click the Examples 
button on the toolbar and locate /model_files/bjt/HPEEbjt2.mdl.
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In the DUT/Setup panel, the DUTs (for example 
DC_preview)—indicated by the inverted triangles—are groupings 
of similar measurement setups used to extract related model 
parameters. The setups (for example fgummel_pre) contain the 
information used to define the inputs and outputs for each 
measurement, as well as their measurement hardware 
configurations and their associated transforms and plots.

Figure 156 Agilent EEBJT2 DUT/Setup Panel
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The measurement and parameter extractions are most easily 
performed with macros. If you use macros, you will not need to 
use the individual setups. However, if you want to extract 
individual parameters or “fine-tune” a parameter, you will use 
the individual setups.

README is not actually a macro, but an abbreviated version of 
the instructions in this chapter. It is most appropriate for users 
who are somewhat familiar with the model and with IC-CAP. 
You can view the README file in a separate window by clicking 
Detach. Then resize the window and move it away from the 
central work area. Scroll the window ahead as you work 
through the model.

The EEBJT2 model parameters, with their descriptions and 
default values are shown the following table.

Table 43 EEBJT2 Model Parameters

Parameter Description Default (Units)

NF Forward-current emission coefficient. 1.2 (unitless)

VAF Forward early voltage. 30.0 (V)

IKF Corner for forward beta high-current roll-off. 100 (A)

ISE B-E leakage saturation current. 1.0e–20 (A)

NE B-E leakage emission coefficient. 1.2 (unitless)

NR Reverse-current emission coefficient. 1.2 (unitless)

VAR Reverse early voltage. 3.0 (V)

IKR Corner for reverse beta high-current roll-off. 100 (A)

ISC B-C leakage saturation current. 1.0e–20 (A)

NC B-C leakage emission coefficient. 1.2 (unitless)

RB Base resistance. 1.0 (ohms)

RE Emitter resistance. 1.0 (ohms)

RC Collector resistance. 1.0e–6 (ohms)
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CJE B-E zero-bias depletion capacitance (CJE, 
VJE, and MJE determine nonlinear 
depletion-layer capacitance for B-E junction).

1.0e–12 (F)

VJE B-E junction built-in potential (CJE, VJE, and 
MJE determine nonlinear depletion-layer 
capacitance for B-E junction).

0.75 (V)

MJE B-E junction exponential factor (CJE, VJE, 
and MJE determine nonlinear depletion-layer 
capacitance for B-E junction).

0.33 (unitless)

TF Ideal forward transit time (TR and TF, along 
with the depletion-layer capacitances, model 
base charge storage effects; TF may be 
bias-dependent).

0.0 (seconds)

XTF Coefficient of bias-dependence for TF. 0.0 (unitless)

VTF Voltage dependence of TF on B-C voltage. 0.02 (V)

ITF Parameter for high-current effect on TF. 0.0 (A)

CJC B-C zero-bias depletion capacitance (CJC, 
VJC, and MJC determine nonlinear 
depletion-layer capacitance for B-C junction).

1.0e–12 (F)

VJC B-C junction built-in potential (CJC, VJC, and 
MJC determine nonlinear depletion-layer 
capacitance for B-C junction).

0.75 (V)

MJC B-C junction exponential factor (CJC, VJC, 
and MJC determine nonlinear depletion-layer 
capacitance for B-C junction).

0.33 (unitless)

TR Ideal reverse transit time (TR and TF, along 
with the depletion-layer capacitances, model 
base charge storage effects).

0.0 (seconds)

FC Forward-bias depletion capacitance 
coefficient.

0.5 (unitless)

TYPE Model type--NPN (1) or PNP (2). npn (unitless)

ISF Forward saturation current. 1.0e–20 (A)

Table 43 EEBJT2 Model Parameters (continued)

Parameter Description Default (Units)
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IBIF Forward base saturation current. 1.0e–20 (A)

NBF Forward base emission coefficient. 1.2 (unitless)

ISR Reverse saturation current. 1.0e–20 (A)

IBIR Reverse base saturation current. 1.0e–20 (A)

NBR Reverse base emission coefficient. 1.2 (unitless)

TAMB Ambient temperature of measurement and 
model parameter extraction.

25 (degrees C)

LB Base inductance. 0.0 (H)

LC Collector inductance. 0.0 (H)

LE Emitter inductance. 0.0 (H)

CXBE External base-emitter fringing capacitance. 0.0 (F)

CXBC External base-collector fringing capacitance. 0.0 (F)

CXCE External collector-emitter fringing 
capacitance.

0.0 (F)

Table 43 EEBJT2 Model Parameters (continued)

Parameter Description Default (Units)
Setting the Model Variables
Before you begin the device measurements, it is necessary to set 
numerical values for some of the model variables. Most of these 
variables are set in macros, either automatically or with the aid 
of explanatory prompts. Other variables must be set manually, 
before any macros are run. All variable values are stored in the 
model variable table. They are referenced by mnemonic name 
from the various macros and/or setups throughout the model. 
Using mnemonics eliminates the need to set numerical input 
values for every measurement setup.
NOTE Some variables have fixed values and must not be changed (refer to 
“Variables with Fixed Values” on page 408).
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Entering the DC Supply Resolution Limits

The first set of variables defines the resolution limits of the DC 
current/voltage supply (for example an Agilent 4142B DC 
source/monitor).   These variables are set manually, and must 
be set before any macros are run. When you set start, stop, and 
number of points values for a measurement sweep, the software 
automatic-ally generates the step size. If the step size is beyond 
the resolution of the DC supply, an error message is displayed. 
Presetting these resolution limits can prevent error messages 
from occurring. The resolution limit variables (which are near 
the end of the variable table) are:

Appropriate values for these variables can be found in the 
documentation for the DC supply (for example Agilent 4142B).

Setting Circuit Solver Variables

The transforms that perform a DC analysis include a simple 
circuit solver that implements the EEBJT2 equations directly 
into the transforms. You will normally not see this circuit nor 
need to use it. However, there may be conditions when you 
would like to exercise control over the convergence criteria of 
the solver. The next three variables make this possible:

Table 44

IB_RES Current resolution of SMU connected to input port.

IC_RES Current resolution of SMU connected to output port.

VB_RES Voltage resolution of SMU connected to input port.

VC_RES Voltage resolution of SMU connected to output port.

Table 45

NTRIALS Maximum number of iteration trials used by the 
Newton-Raphson algorithm.

TOL_VOLT The algorithm will exit when the sum of the magnitudes of 
the voltage corrections drops below this value.
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Variables with Fixed Values

The following variables are preset and should remain fixed. Do 
not change them:

Setting Variables in Macros

The remaining variables are set in the variable initialization 
macros—the first three macros in the list after README:

• Data_sheet_vars

• Misc_sweep_vars

• Pre_meas_vars

These macros should be run before any measurements or 
extractions are performed (except that Pre_meas_vars makes 
the DC_preview measurements and sets variables based on the 
results). Perform these initialization macros in the order listed. 
Select the required macro and Execute. Respond to the prompts.

TOL_FUNC The algorithm will exit when the sum of the magnitudes of 
the function corrections drops below this value. The 
algorithm solves for the internal voltages of the device, but 
tries to match the model’s predicted responses to the 
independent port currents or voltages being measured. If 
voltages are being set on both ports, the algorithm tries to 
zero out the functions v1_meas – v1_mod and v2_meas – 
v2_mod.

Table 46

PATH_LOCAL This is used by some transforms to look in the local path for 
data.

INFINITY Preset to the value 1.0e50. It is used in some transforms to 
represent a very large number.

SIMULATOR This should always have the value mns. During the model 
extraction and verification, the simulation is performed 
without the benefit of an external simulator. However, MNS 
can be used for additional verification of device behavior.

Table 45
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Data_sheet_vars Macro

This macro is used to set the following variables:

Values for these variables are commonly available on data 
sheets of packaged parts. These variables are critical to the data 
acquisition in many setups, and they must be set before 
measurement of any device.

Misc_sweep_vars Macro

This macro sets many of the variable values for different sweeps 
used throughout the EEBJT2 model. Most of the default values 
for variables set by this macro are suitable for most devices, so 
you need only run this macro if you want to change any default 
values. Otherwise continue directly to the Pre_meas_vars 
macro. The following variables are included:

Table 47

VEB_MAX Maximum emitter-base voltage.

VCB_MAX Maximum collector-base voltage.

VCE_MAX Maximum collector-emitter voltage.

IC_MAX Maximum collector current.

PT_MAX Maximum total device power dissipation.

Table 48

FGML_START Forward Gummel sweep start voltage.

FGML_PTS Number of data points taken in forward Gummel sweep.

RGML_START Reverse Gummel sweep start voltage.

RGML_PTS Number of data points taken in reverse Gummel sweep.

IB_PRE_PTS Number of data points taken in Ic vs. Ib preview 
measurement.

IB_PTS Number of base current traces in forward and reverse IV 
measurement.
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This macro requests the ambient temperature of the lab where 
the device is being measured. (This is actually the parameter 
TAMB, rather than a measurement variable. It is listed with its 
default value in Table 43.)

Pre_meas_vars Macro

VCE_START Forward IV measurement Vce start value.

VCE_PTS Number of Vce points in forward IV measurement.

VCE_REV_START Reverse IV measurement Vce start value.

VCE_REV_PTS Number of Vce points in reverse IV measurement.

VCE_START_AC Starting value for Vce in forward S-parameter 
measurements.

VCE_PTS_AC Number of Vce points in forward S-parameter 
measurements.

VBE_CAP_PTS Number of Vbe bias points for BE junction S-parameter 
measurements.

VBE_FB_PTS Number of Vbe bias points for forward-bias BE junction 
S-parameter measurements.

VBC_CAP_PTS Number of Vbc bias points for BC junction S-parameter 
measurements.

VJ_ON Approximate junction turn-on voltage.

Table 48
NOTE Do not run the initialization macros if you have existing measured data, as 
the data will be overwritten.
This macro should be run after the Data_sheet_vars macro and 
before performing any of the measurements in the DC_current 
DUT. You can also run the Misc_sweep_vars macro before this 
macro if you wish to change any of the default values in it. The 
Pre_meas_vars macro makes the DC_preview measurements 
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and sets variables based on the results. Therefore you must have 
your test equipment set up and switched on and your device 
ready to measure.

This macro provides a straightforward way to interactively set 
the following variables:

While the macro is executing, it displays the following plots: 

• Forward Gummel

• Reverse Gummel

• Base current vs. collector current at VCE_STOP

Use the plots to visually determine appropriate values for the 
upper limit sweep variables FGML_STOP, RGML_STOP, and 
IB_STOP respectively. The objective is to set the variables as 
high as possible without violating the collector current 
compliance. If the compliance limit is violated, select “n” as 
indicated in the prompt to re-measure, and re-enter a new 
(lower) sweep limit variable.

You can now recall the same set of device variables any time you 
wish to measure and model similar devices. As you input more 
variables into the table in later procedures (particularly the 
macros) you will probably want to save the variable table again, 
overwriting this version.

FGML _STOP Forward Gummel sweep stop voltage.

RGML_STOP Reverse Gummel sweep stop voltage.

VCE_REV_STOP Reverse IV measurement Vce stop value.

VCE_STOP Forward IV measurement Vce stop value.

IC_COMP Collector current compliance limit.

IB_START Forward and reverse IV measurement base current start value.

IB_STOP Forward and reverse IV measurement base current stop value.
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All the EEBJT2 S-parameter measurements require only one 
calibration: a swept broadband calibration across the operating 
frequency range of the device under test. Good calibration of 
the network analyzer is critical to a good measurement and 
extraction.

For step-by-step calibration procedures, refer to:

• Agilent 8510-based system—“Calibrating the Network 
Analyzer” on page 589 in Appendix B, “Using IC-CAP with an 
Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Calibrating the Network 
Analyzer” on page 631 in Appendix C, “Using IC-CAP with an 
Agilent 85123A Device Modeling System”

• Wiltron 360 network analyzer—Refer to the Wiltron 
documentation

Make the following additional setting changes:

• Set the network analyzer START frequency to the lowest 
possible frequency in the range of the network analyzer and 
bias networks: low frequencies allow more accurate AC 
conductances to be extracted. 

• Set the STOP frequency to the upper limit of the frequency 
range for the device under test. Frequencies up to Ft are 
useful but not required. Good package and charge extractions 
require frequencies high enough to see roll-off and package 
effects clearly. 

• Set the NUMBER of POINTS to 51 or 101 to provide clear and 
usable S-parameter plots: more points only add more time 
and memory requirement to the measurement and 
extraction.

Remember these frequency values: you will also need to enter 
them in IC-CAP when instructed. If you do not set these values 
correspondingly, the calibration will be invalid.

All S-parameter measurements for the EEBJT2 model are 
performed over the same frequency range. However, some of the 
extractions are performed at a single frequency point, for 
example in the Extract_extrin macro. These extractions must be 
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performed at a calibrated frequency point. Only the measured 
frequency points in the sweep are calibrated, that is, points 
equal to the start frequency plus an integer multiple of the step 
size. 

In the Extract_extrin macro, a transform takes any arbitrary 
frequencies you may have entered, and moves to the nearest 
calibrated frequency point. 
NOTE If you set a MHz value in IC-CAP, write MEG in full. IC-CAP is not 
case-sensitive and assumes that m or M corresponds to milli. If an error 
message is displayed during the measurement that indicates a network 
analyzer frequency value is too low, you may have entered M only.
Remember the number of the network analyzer cal set or 
register where you store the calibration. You will need to use 
this number in the instrument options of each S-parameter 
measurement when you define the instrument states.
 
Using Macros for Measurements and Extractions
Macros are the easiest and fastest way to perform a complete 
set of measurement and extraction procedures. Macros 
automate the modeling procedure so that a series of similar 
devices can be measured and modeled quite quickly with 
minimal user intervention. As you perform the extraction 
macros, the default values in the Model Parameters table are 
replaced by extracted values.

If individual parameters need to be extracted, or if you want to 
“fine-tune” a particular parameter, you can use the individual 
setups in the Model window instead of the macros. They are 
explained later in the chapter.

The following table describes the EEBJT2 macros and lists the 
setups whose transforms are used to accomplish the same thing 
if you want or need to do it manually. 
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Table 49  EEBJT2 Macros

Run This Macro To Do This Or Do It Manually By

Extract_DC Measure, extract, and optimize DC 
parameters 

Executing the transforms in the following setups 
(DC_current DUT):

fgummel
rgummel
forward_IV
reverse_IV
rev_output

AC_Measure Measure S-parameters Executing the transforms in the following setups 
(AC_extrinsics DUT):

package 
and
(AC_measurements):

meas_spar_vce_ib 
meas_spar_vbe
meas_spar_vbe_fb
meas_spar_vbc

Extract_extrin Extract the parasitic inductances as well 
as the base and emitter resistances

Executing the transforms in the following setups 
(AC_extrinsics DUT):

package
extr_re

Extract_junc_cap Extract the reverse-bias depletion 
capacitance parameters for both the BE 
and BC junctions

Executing the transforms in the following setups 
(AC_charge DUT):

extr_be_cap
extr_bc_cap

Extract_transit Extracts the transit time related 
parameters for the BE junction

Executing the transforms in the following setups 
(AC_charge DUT):

extr_be_delay
extr_vtf
DC Measurements and Extractions

The Extract_DC macro performs the same DC measurements as 
the setups in the DC_current DUT in the Model window. It then 
extracts the DC parameters from the measured data and enters 
them in the Parameters table. The DC measurements should 
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always be performed first, and the DC parameters must be the 
first parameters extracted. Later extractions are dependent on 
a good DC extraction.

To run the DC measurement and extraction macro:

1 Click the Macros tab.

2 Select Extract_DC > Execute. 

The macro displays the DC plots one at a time. As each plot 
appears, one or more dialog boxes appear prompting you to 
input data values. You need to have some knowledge of the 
device to input appropriate values. When the macro is complete, 
the results of the extraction are printed in the Status window, 
and the corresponding values are listed in the Parameters table.

S-Parameter Measurements
 

NOTE The network analyzer must be calibrated before you perform any 
S-parameter measurements; if you have not yet done so, refer to the 
section, “Calibrating the Network Analyzer” on page 412.
The AC_Measure macro performs an S-parameter measurement 
equivalent to the one in the package setup (AC_extrinsics DUT). 
It is a swept-frequency S-parameter measurement at a single DC 
bias point. The macro displays prompts for you to enter the 
frequency start and stop values and number of measurement 
points, and the Ib and Vce bias points. It then performs the 
measurement and plots the results.

• If you are not satisfied with the measurement results, you 
can exit the macro and recalibrate the network analyzer. 

• If you are satisfied with the measurement results, you can 
have the instrument states (options) copied to the other 
S-parameter measurement setups (in the AC_measurements 
DUT).
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NOTE You can enter additional bias variables and the rest of the S-parameter 
measurements are performed automatically. You should do this if you are 
going to perform the AC extraction macros, because the Extract_junc_cap 
and Extract_transit macros use the data from these additional 
S-parameter measurements. These are swept frequency measurements 
with swept DC bias.
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AC Extractions

The AC extractions require running three separate macros:

• Extract_extrin

• Extract_junc_cap

• Extract_transit

These macros do not make measurements, but use the 
S-parameter data collected during the execution of the 
AC_measure macro.

Extract_extrin Macro: Parasitic Extractions

This macro extracts the parasitic inductances as well as the 
base and emitter resistances. It is thus equivalent to the 
package and extr_re setups in the AC_extrinsics DUT. It 
prompts you for extraction frequencies for conductances, 
capacitances, and inductances. If you use arbitrary frequency 
values, a transform in the macro moves the extraction to the 
nearest calibrated frequency point. Calibrated frequency points 
are any points in the calibrated network analyzer frequency 
range that are equal to the start frequency plus an integer 
multiple of the step size. The macro extracts the parasitic 
inductances and the base and emitter resistances, and lists 
their values in the Parameters table. It extracts re by optimizing 
the modeled intrinsic gm to fit the measured intrinsic gm.

Extract_junc_cap Macro: Junction Capacitance Extractions

This macro extracts the reverse-bias depletion capacitance 
parameters for both the BE and BC junctions. It is thus 
equivalent to the extr_be_cap and extr_bc_cap setups under 
AC_charge. It first displays plots of cbe_vs_vbe and cbc_vs_vbc, 
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then performs optimizations and lists the new parameter values 
in the Parameters table. The parameters optimized are cje, vje, 
mje, cjc, vjc, and mjc. No measurements are taken in this macro: 
be sure to run the AC_measure macro first. 

Extract_transit: Transit Time Related Parameter Extractions

This macro is equivalent to the extr_be_delay and extr_vtf 
setups in the AC_charge DUT.   It displays plots of cbe_vs_ic and 
ft_vs_ic. It prompts you for a value for the parameter xtf and 
optimizes tf and itf. It then displays the cbe_vce plot from the 
extr_vtf setup, and extracts vtf. It enters the new parameter 
values in the Parameters table. No measurements are taken in 
this macro: be sure to run the AC_measure macro first. 
Executing Individual Measurement Transforms
 

Though the macros are the fastest and easiest way to perform 
the measurement and extraction procedures, you may 
sometimes want to extract parameters individually, or you may 
want to “fine-tune” a particular parameter.

The rest of this chapter explains in detail how to make preview 
device measurements and set model variables from the results 
obtained; how to make the measurements required for specific 
extractions; how to perform the individual extractions and 
optimizations; and how to save the resulting model.

Note that, among the individual setups, the fgummel and 
rgummel setups each include a macro transform to automate 
the measurement and extraction procedures for those 
particular setups.

Defining the Instrument States

For each of the measurement setups, it is necessary to define 
the instrument states (options) for the measurement 
instruments used in that setup. The instrument states need to 
be defined individually for each setup. With minor exceptions, 
the options must be the same for all setups that use the same 
instruments.
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To set the instrument options for any given setup:

1 Select the setup of interest.

2 Click the Instrument Options tab and the display changes to 
show the options for the instruments used in that 
measurement. 

• In the DC setups, the options for the DC source/monitor 
are displayed.

• In the S-parameter setups, the options for both the DC 
source/monitor and the network analyzer are displayed.

The instrument state settings will be explained in this chapter 
with their corresponding setups.

Making DC Measurements

The easiest and fastest way to make all of the DC measurements 
(and perform the DC extractions) is to use the Extract_DC 
macro, after first running the variable initialization macros 
Data_sheet_vars, Misc_sweep_vars, and Pre_meas_vars. These 
initialization macros set most of the variables needed for the DC 
measurements. Additional variables are set in the Extract_DC 
macro or the individual setups.

Measuring with the DC_preview DUT
NOTE Although measurement instructions are provided here for each setup in 
the DC_preview DUT, it is easier to use the Pre_meas_vars macro to 
automate the DC preview measurements.
The DC_preview DUT setups are used to obtain a good set of 
measured DC-IV curves on which most of the other 
measurements will be based. These setups are:

• fgummel_pre

• rgummel_pre

• ic_vs_ib_pre
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Each of the three setups is designed to give you a quick preview 
of the measurement and, based on the results, set the related 
variables that control the final measurement.

Previewing forward Gummel with fgummel_pre

This setup is used to preview the forward Gummel 
measurements for both the base and collector currents. 

To define the DC Source/Monitor instrument state, follow these 
instructions:

• Agilent 8510-based system—“Defining the DC Source/Monitor 
Instrument State” on page 595 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Defining the DC Source/Monitor 
Instrument State” on page 621 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

These procedures configure IC-CAP with the instrument state 
settings (instrument options) for the Agilent 4142B DC 
source/monitor. Then return to this chapter and continue.

The input values define the device configuration, the sweep 
values that will be used to make the measurement, and the 
compliance limits for the power supply.

To view the fgummel_pre input values:

Select the fgummel_pre setup in the DC_preview DUT. 

• You will not need to change the input values, although you 
may need to change some variable values as a result of the 
measurement. However, the inputs show you what 
measurement is being made and how the measurement 
variables are used.

• Notice that Mode is set to V for all inputs, to provide a voltage 
at all the device terminals.

• The Unit names must conform to the names you set in the 
hardware window (see “Getting Started in IC-CAP” on 
page 400). They must also correspond with the actual plug-in 
SMU connections from the Agilent 4142. The vb unit must be 
set to SMU1 and the vc unit to SMU2. The ve unit must be set 
to GND.
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• Compliance values limit SMU output voltage or current and 
prevent damage to the device under test, as well as to the 
SMUs, bias networks, and probes if used. With a voltage 
input, compliance refers to current. In this model, the 
compliance values are preset. Note that the compliance at the 
collector is set for maximum collector current.

• Notice the input vb is set for a linear voltage sweep from start 
to stop values preset with variables.   The start value is the 
approximate junction turn-on voltage. It may be necessary to 
change the variable value of FGML_STOP after the 
measurement.

• Notice the input ve is grounded. All measurements in this 
model are made with the BJT in a common-emitter 
configuration.

• Notice the input vc is set for a sweep synchronized to the vb 
sweep.

• The outputs are ib (base current) and ic (collector current).

• The output Type is M for measured. The other possibilities 
are S for simulated and B for both.
NOTE In measuring chip devices, remove any high-intensity light sources such 
as microscope light before taking a measurement. This is particularly 
important if currents in the nanoamp range are being measured. One 
simple method of blocking light is to place an opaque plastic box on the 
fixture directly above the device.
The measurement process triggers the device measurement, 
controlling the DC source/monitor to supply the signals defined 
in the instrument options window and the inputs, and monitors 
the results.
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To view the sample fwd_Gummel plot:

1 From the Plots folder, select the fwd_Gummel plot, and click 
Display Plot.

• The lower curve is base current and the upper curve is 
collector current.

• The stop value for the base voltage sweep has been preset 
to a value large enough to drive the device into compliance 
on the collector port to obtain the maximum amount of 
data possible within the compliance range. However, it is 
not required that you drive the device into compliance, so 
you can use a lower value of FGML_STOP if you prefer.

• The recommended approach is to drive the device into 
compliance using the preset FGML_STOP value, then find 
the maximum value of vb below compliance. Set 
FGML_STOP to this value. To do this, go to the variable 
table and find the variable FGML_STOP, then manually 
change its value in the table. Then re-measure and make 
sure the new value does not violate the compliance limit.

Figure 157 Example fgummel_pre Data Plot
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2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.

Previewing Reverse Gummel with rgummel_pre

The rgummel_pre setup is used to preview the reverse Gummel 
measurements for both the base and emitter currents.

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings.

To view the rgummel_pre input values:

Select the rgummel_pre setup.

• Note that in this setup, vb is set to a constant value of 0.0. 

• The input vc is set for a linear voltage sweep from start to 
stop values preset with variables. Note that the start value is 
−VJ_ON for this reverse measurement   It may be necessary 
to change the variable value of RGML_STOP after the 
measurement.

• The compliance at the collector is set for maximum collector 
current, as in the fgummel_pre measurement. The stop value 
for the collector voltage sweep has been preset to a value 
large enough to drive the device into compliance on the 
emitter port.
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To view the sample rev_Gummel plot:

1 From the Plots folder, select the rev_Gummel plot, and click 
Display Plot.

• The lower curve is the base current and the upper curve is 
the emitter current.

• The stop value of the collector voltage sweep has been 
preset to a value large enough to drive the device into 
compliance on the emitter port, to obtain the maximum 
amount of data within compliance.

• Drive the device into compliance using the preset 
RGML_STOP value, then find the maximum value of vc 
below compliance. Set RGML_STOP to this value, and 
perform the measurement again.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.

Figure 158 Example rgummel_pre Data Plot
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Previewing Collector Current with ic_vs_ib_pre

The ic_vs_ib_pre setup is used to preview the collector current 
at VCE_STOP (the stop value for Vce used in the forward_IV 
measurement). The objective of this setup is to find the largest 
value of IB_STOP such that the collector current compliance is 
not violated. Note that it is easier to run the Pre_meas_vars 
macro to automate the DC preview.

To define the DC source/monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings.

To view the ic_vs_ib_pre input values:

Select the ic_vs_ib_pre setup. 

• In this setup, the input on the base is current, therefore the 
ib Mode is set to I. With this current input, the compliance is 
a voltage.

• The input ib is set to sweep from 0.0 to IB_STOP, the base 
current stop value used for the forward_IV and reverse_IV 
measurements. vc is set to a constant value of VCE_STOP.

• You will need to set the values of VCE_STOP and IC_COMP 
manually in the variable table. Set VCE_STOP to a value <= 
VCE_MAX. Set IC_COMP to the lesser of IC_MAX or 
PT_MAX/VCE_STOP.

• You can also set the values for IB_STOP and IB_PRE_PTS in 
the variable table, but the default values are usually adequate 
for most devices.

To view the sample ic_vs_ib plot:

1 From the Plots folder, select the ic_vs_ib plot and click Display 
Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change. If you are not satisfied with the results, 
change the value of IB_STOP in the variable table and 
perform the measurement again.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.
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Measuring with the DC_current DUT
NOTE Do not run the initialization macros if you have existing data in this model 
file, or the data will be overwritten. Do not run the Extract_DC macro if you 
already have acceptable measured DC data.
 

The DC_current DUT makes five DC measurements using the 
following setups:

• fgummel

• rgummel

• forward_IV

• reverse_IV

• rev_output

To prevent possible bias oscillation, put the network analyzer in 
hold sweep mode.

Measuring with the fgummel Setup

This setup measures the operating range of base and collector 
currents with the transistor in forward active mode. It 
measures Ic and Ib with respect to Vbe.

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings except set Integ Time to L (long) to 
slow the measurement and reduce noise at the lower end of 
the curve.

To view the fgummel input values:

From the DC_current DUT, select the fgummel setup.

• The inputs are almost the same as for the fgummel_pre setup, 
except that now the vb Start value is set to FGML_START, the 
forward Gummel sweep start voltage, which you can set in 
the variable table if you wish to make it different from the 
junction turn-on voltage.
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To view the sample fwd_Gummel plot:

1 From the Plots folder, select the fwd_Gummel plot and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.

Measuring with the rgummel Setup

The rgummel setup measures the base and emitter currents 
with the transistor in the reverse active mode. It measures Ib 
and Ie with respect to –Vce.

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings except set Integ Time to L (long).

To view the rgummel input values:

Select the rgummel setup.

• The inputs are almost the same as for the rgummel_pre 
setup, except that now the vc Start value is set to 
RGML_START, the reverse Gummel sweep start voltage, 
which you can set in the variable table if you wish to make it 
different from the inverse value of the junction turn-on 
voltage.

To view the sample rev_Gummel plot:

1 From the Plots folder, select the rev_Gummel plot and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.
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Measuring with forward_IV

The forward_IV setup measures Ic with respect to Vce at several 
values of Ib. 

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings.

To view the forward_IV input values:

Select the forward_IV setup.

• The vc values are set to sweep the collector voltage across the 
operating range of the device.

• The ib values are set to measure several values of base 
current. IB_PTS is set for the number of base current traces.

To view the sample ic_vce plot:

1 From the Plots folder, select the ic_vce plot and click Display 
Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change. If you are not satisfied with your results, you 
can change the values of variables in the variable table. For 
example, if the Ib curves are too low or too high, you can 
change the IB_START or IB_STOP values. If you do change 
any variable values, perform the measurement again.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.

Measuring with reverse_IV

The reverse_IV setup measures Ie with respect to Vce at several 
values of Ib. The Vce values are chosen to measure the device in 
the reverse active mode.

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings.

To view the reverse_IV input values:
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Select the reverse_IV setup.

• The ib values are set the same as for the forward_IV 
measurement. This setup measures the same number of base 
current traces as the forward_IV.

• The vc sweep variables are set to negative voltage values.

To view the sample ie_vce plot:

1 From the Plots folder, select the ie_vce plot and click Display 
Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change. If you are not satisfied with your results, you 
can change the variable table values, as in the forward_IV 
measurement, and perform the measurement again. Do not 
change the number of measurement points for either ib or vc

3 To save the plotted data, select File > Save As and a filename 
with the suffix .pre.

Measuring with rev_output

The rev_output setup measures Ie with respect to Vec, with the 
device in the reverse active mode. The measured data will be 
used later in the procedures to extract the reverse early voltage 
parameter EEBJT2.var. It is important that the Gummel 
measurements are performed first.

To define the DC Source/Monitor instrument state:

Follow the same procedure from the fgummel_pre setup, 
using the same settings except set Integ Time to L (long) to 
reduce noise, because one of the transforms uses a numerical 
derivative, and the extraction will be inaccurate if the data is 
noisy.

To view the rev_output input values:

Select the rev_output setup.
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• You will need to set the variable value for VBC_EARLY 
manually before you make the measurement. VBC_EARLY is 
the Vbc value at which an Ie vs. Vec trace is measured. Scroll 
the variable table until you find VBC_EARLY, and enter a 
value. Select a value in the linear region of the reverse 
Gummel plot, near the high end of the region but below the 
series resistance drop effects.

• The default value for EARLY_PTS is generally acceptable.

To view the sample ie_vec plot:

1 From the Plots folder, select the ie_vec plot and click Display 
Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change. If you are not satisfied with your results, you 
can change the value of VBC_EARLY in the variable table, 
and perform the measurement again.

3 To save the plotted data, select File > Save As and a filename 
with the suffix .set.

Making S-parameter Measurements

The AC_measure macro performs all the S-parameter 
measurements in the model, including copying the instrument 
states and frequency range from the first S-parameter 
measurement setup to all the others. But first you must run the 
variable initialization macros Data_sheet_vars, 
Misc_sweep_vars, and Pre_meas_vars. 
NOTE Do not run the initialization macros if you have existing data in this model 
file, or the data will be overwritten. Do not run the AC_measure macro if 
you already have acceptable measured S-parameter data.
These initialization macros set most of the variables needed for 
the S-parameter measurements; a few additional variables are 
set in the set_bias transform macros in each S-parameter setup. 
If you intend to measure the S-parameters in one setup only, 
you will first need to run the set_bias transform macro in that 
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setup. The macro prompts you for bias values specific to the 
measurement. You will also need to set the sweep parameters 
manually (once for all the measurements).
NOTE The network analyzer must be calibrated before you perform any 
S-parameter measurements. Also make sure the network analyzer is in 
continuous sweep mode. For details see “Calibrating the Network 
Analyzer” on page 412.
Measuring with the AC_extrinsics DUT

The AC_extrinsics DUT contains two setups:

• package—Contains measurement and extraction transforms. 
Measuring is described here; the extraction is described later 
in the extraction section.

• extr_re—Contains extraction transforms only and will be 
described later in the extraction section.

Measuring with package

The package setup measures S-parameters in the typical 
operating region of the device, with constant values of base and 
collector bias. The data measured here will be used to extract 
the extrinsic parasitic base resistance and the extrinsic 
parasitic inductances.

Defining the Instrument States

You will need to set the instrument states for both the DC 
source/monitor and the network analyzer. For details, refer to:

• “Instrument States for Swept Measurements” on page 598 
(for an Agilent 8510-based system) in Appendix B, “Using 
IC-CAP with an Agilent 85122A Precision Modeling System”

• “Instrument States for Swept Frequency Measurements” on 
page 624 (Agilent 8753- or 8720-based system) in 
Appendix C, “Using IC-CAP with an Agilent 85123A Device 
Modeling System”
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measurements. Calibrate the network analyzer. In the instrument options 
for the network analyzer, be sure to set the Cal Set No to the cal set or 
register where you save your calibration.
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You will use these instrument states in all the setups that make 
S-parameter measurements with the network analyzer.

To view the package input values:

Select the package setup.

• Unless you used the AC_measure macro, you need to set the 
frequency sweep variables manually. Scroll the variable table 
to show the values for FREQ_START, FREQ_STOP, and 
FREQ_PTS. Manually enter values for these variables that 
correspond with the sweep values used for the network 
analyzer calibration.

• If you wish, you can also set the bias sweep variables IB_TYP 
and VCE_TYP manually, or you can use the set_bias 
transform macro.

• To do so, select Extract/optimize > set_bias > Execute. Enter 
typical base current and collector voltage values close to the 
intended point of operation.

To view the sample S-parameter plots:

1 From the Plots folder, select each plot of interest and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As.

Measuring with the AC_measurements DUT

The setups in the AC_measurements DUT are used to obtain 
S-parameter data for extractions performed in other setups, as 
shown in the following table.
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Table 50 S-parameter Measurement and Extraction setups

DUT/Setup for Measurement DUT/Setup for Corresponding 
Extraction

AC_measurements/meas_spar_vce_ib AC_extrinsics/extr_re 
AC_charge/extr_vtf

AC_measurements/meas_spar_vbe AC_charge/extr_be_cap

AC_measurements/meas_spar_vbe_fb AC_charge/extr_be_delay

AC_measurements/meas_spar_vbc AC_charge/extr_bc_cap
NOTE The package setup (in the AC_extrinsics DUT) is also used for making AC 
measurements, but unlike those listed in Table 50, the package setup also 
contains the related extraction transforms.
The extractions listed in Table 50 will work only if the 
corresponding AC_measurement setup contains previously 
measured S-parameters. Each of the extraction setups must 
have bias input variables identical to the input variables of the 
corresponding AC_measurement setup. It is important that they 
remain the same: do not change the inputs.

The transform s_mod in each S-parameter measurement setup 
computes the modeled S-parameters of the small-signal 
equivalent circuit for comparison with the measured results.

Measuring with meas_spar_vce_ib

The meas_spar_vce_ib setup measures the device S-parameters 
in the forward active region with Ib and Vce as the control 
variables.

To define the instrument states:

Follow the same procedure you used in the package setup. 
Use the same settings for both the DC source/monitor and 
the network analyzer. (The instrument states need to be set 
independently for each setup, unless you ran the 
AC_measure macro.)
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To view the meas_spar_vce_ib input values:

Select the meas_spar_vce_ib setup.

• The frequency variables FREQ_START, FREQ_STOP, and 
FREQ_PTS must have values in the variable table that 
correspond with the frequency values used in calibrating the 
network analyzer.

• The base current is set to sweep over the same range as in the 
forward_IV DC measurement.

• The vc values are set to sweep the collector voltage across the 
approximate operating range of the device. 

• You can set the VCE_STOP_AC value using the set_bias 
transform macro. Select Extract/Optimize > set_bias > Execute, 
and respond to the prompts.

To view the sample S-parameter plots:

1 From the Plots folder, select each plot of interest and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As.

Measuring with meas_spar_vbe

The meas_spar_vbe setup measures S-parameters with Vbc 
equal to zero and Vbe varying from reverse bias to forward bias. 
This will be used for extraction of parameters associated with 
the BE junction capacitance.

To define the instrument states:

Follow the same procedure you used in the package setup. 
Use the same settings.

To view the meas_spar_vbe input values:

Select the meas_spar_vbe setup.

• The frequency inputs are the same as for the 
meas_spar_vce_ib setup, and are also the same in the other 
S-parameter setups.
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• The input vc is set for a sweep synchronized to the vb sweep.

• The vb values are set to vary the device performance from 
reverse bias to forward bias. VBE_CAP_PTS is a default 
value.

• You can set the vb start and stop values for the measurement 
using the set_bias transform macro. Select Extract/Optimize > 
set_bias > Execute, and respond to the prompts.

To view the sample S-parameter plots:

1 From the Plots folder, select each plot of interest and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As.

Measuring with meas_spar_vbe_fb

The meas_spar_vbe_fb setup measures S-parameters with Vbc 
equal to zero and Vbe forward biased. This measured data will 
also be used for extraction of parameters associated with the 
BE junction capacitance.

To define the instrument states:

Follow the same procedure you used in the package setup. 
Use the same settings.

To view the meas_spar_vbe_fb input values:

Select the meas_spar_vbe_fb setup.

• The frequency inputs are the same as in all the other 
S-parameter setups.

• The input vc is set for a sweep synchronized to the vb sweep.

• The vb values are set to forward bias the device. 
VBE_FB_PTS is a default value.

• You can set the vb start and stop values for the measurement 
using the set_bias transform macro. Select Extract/Optimize > 
set_bias > Execute, and respond to the prompts.
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To view the sample S-parameter plots:

1 From the Plots folder, select each plot of interest and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As.

Measuring with meas_spar_vbc

The meas_spar_vbc setup measures S-parameters, with Vbe 
equal to zero and Vbc varying from reverse bias to forward bias.

To define the instrument states:

Follow the same procedure you used in the package setup. 
Use the same settings.

To view the meas_spar_vbc input values:

Select the meas_spar_vbc setup.

• The frequency inputs are the same as in all the other 
S-parameter setups.

• The vb inputs set the base voltage to zero.

• The vc input values are set to vary the device performance 
from reverse bias to forward bias. VBC_CAP_PTS is a default 
value.

• You can set the vc start and stop values for the measurement 
using the set_bias transform macro. Select Extract/Optimize > 
set_bias > Execute, and follow the prompts.

To view the sample S-parameter plots:

1 From the Plots folder, select each plot of interest and click 
Display Plot.

2 To initiate the measurement process, from the 
Measure/Simulate folder, click Measure and observe the 
plot(s) change.

3 To save the plotted data, select File > Save As.
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Executing Individual Extraction Transforms

NOTE The fastest and easiest way to perform the extractions is to use the 
macros provided. Or you can perform each extraction step individually to 
allow complete process control in case you want to extract parameters 
individually or “fine-tune” a particular parameter. This section explains 
how to extract parameters using the individual transforms; for details on 
using the macros, refer to “Using Macros for Measurements and 
Extractions” on page 413.
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When the measurements are finished and you have a complete 
set of measured data for a particular device, you can begin the 
extractions. If you saved the measured data, you can perform an 
extraction later, at any time. This also offers the opportunity for 
the measurement and extraction to be done by different people.

Extracting with the DC_current DUT

This section describes performing extractions by executing 
individual transforms associated with the DC_current DUT.

Extracting parameters with the fgummel_macro transform

The easiest way to perform the extraction of all the forward 
Gummel parameters is to use the fgummel_macro transform. 
This extracts a number of critical parameters from the data 
measured earlier. If you are not using the macros under the 
Macros tab to automate the extractions, it is important that this 
is the first extraction performed, because effective extractions 
in later setups are dependent on accurate parameters obtained 
in the fgummel and rgummel setups.

1 Select the fgummel setup.

2 Click Extract/Optimize and select fgummel_macro > Execute. 

• The macro displays the measured data on the 
fwd_Gummel plot.

• Screen prompts ask you to input limit values for the 
extraction.
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• Observe the simulated traces converge to the measured 
traces on the plot as the macro optimizes the parameters.

• The Parameters table is updated with the new optimized 
forward Gummel parameters.
NOTE A similar method is available in the rgummel setup, where the 
rgummel_macro transform is the easiest way to perform the extraction of 
all the reverse Gummel parameters.
 

Extracting Parameters with Individual fgummel Transforms

This is the method to use if you need to extract individual 
parameters or “fine-tune” a particular parameter. Use the 
Parameters table, scrolling as necessary, to see the new 
extracted values of the parameters. Because this setup extracts 
a fairly large number of parameters, the procedure is more 
complex than for many setups. The procedures presented in 
this section—for each transform—assume the fgummel setup is 
the active setup.

To compute hfe from the measured data:

From the Extract/Optimize folder, select hfe_fwd_meas > 
Execute. To look at the hfe trace, select Plots > hfe_vs_ic > 
Display Plot.

After setting the variables on which the extractions and 
optimizations depend, you can extract and optimize the base 
current parameters EEBJT2.ibif, nbf, ise, and ne. 

To set the variables:

1 Select Plots > fwd_Gummel > Display Plot.

2 To view a linear portion of the fgummel traces, click the Setup 
Variables tab. The setup variable table appears.

3 From the plotted data, choose a linear portion of the 
collector current trace, excluding any noisy data at the low 
end. Click the mouse pointer at the lower and upper 
boundary points of the linear portion to make a box on the 
trace, as shown in Figure 159.
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4 From the Plot window, select Options > Copy to Variables. This 
changes the X_LOW and X_HIGH values for this plot to the 
boundary points you selected. 

5 In the setup variable table, set VBE_LOW_TR to a value less 
than X_HIGH, where the slope of the base current trace is 
still the same as at X_HIGH.

6 In the setup variable table, set VBE_HIGH_LK to a value 
greater than X_LOW where the slope of the base current 
trace is the same as at X_LOW.

• The region between VBE_LOW_TR and X_HIGH is the 
transport region where the parameters ibif and nbf can be 
estimated.

• The region between X_LOW and VBE_HIGH_LK encloses 
the leakage region where the parameters ise and ne can be 
estimated.

Figure 159 Selecting a Linear Portion of the Ic Trace
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Once these variables are set, the remaining transforms can be 
executed. Many of the transforms rely on these variables, 
therefore the extractions will not work properly unless the 
variables are first set correctly.

To execute the remaining transforms in the fgummel setup:

1 Scroll the Parameters table to display isf and nf. 

2 Select Extract/Optimize.

3 Select extr_isf_nf > Execute. Observe the changes in the 
Parameters table values.
NOTE The values extracted for the parameters isf and nf are a function of both 
the input data and the parameter EEBJT2.var. Therefore, after you extract 
var in the rev_output setup, you will need to return to this setup and 
execute the extr_isf_nf transform again. (Note that this is handled 
automatically in the Extract_DC macro.)
 

4 Select icf_Gummel > Execute. The transform computes the 
simulated forward Gummel collector current.

5 Scroll the Parameters table to display EEBJT2.ibif and nbf. 

6 Select est_ibif_nbf > Execute. Observe the changes in the 
Parameters table values.
NOTE This transform zeroes the parameter EEBJT2.ise so that the effects of 
EEBJT2.ibif and nbf are the only ones visible in simulations immediately 
following the extraction. This makes the quality of the fit easier to 
determine.
7 Select ibf_Gummel > Execute. The transform computes the 
simulated forward Gummel base current, so that the result of 
the ibif and nbf extraction is observable on the plot.

Now you must make a decision based on the results you have 
seen thus far:

• If the Gummel fit in the transport region between 
VBE_LOW_TR and X_HIGH looks good, you can stop the 
extraction at this point. 
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• If you want to extract the leakage parameters ise and ne, 
you can skip the next two transforms (set_opt_vars_fwd, 
Step 1 and opt_ibif_nbf, Step 2) and go directly to 
est_ise_ne (Step 3).

• If you are not satisfied with the Gummel fit in the 
transport region and you do not need to extract the 
leakage parameters, perform the next two transforms 
(set_opt_vars_fwd, Step 1 and opt_ibif_nbf, Step 2) and 
then stop.

1 Select set_opt_vars_fwd > Execute. This sets optimization 
limits for the ibif, nbf, ise, and ne parameters. The limits are 
set to a specific percentage above and below the parameter 
values. The variable PAR_OPT_TOL controls the percentage 
variation.

2 The optimization performed with the opt_ibif_nbf transform 
should only be used if the base current leakage parameters 
are to be neglected. Otherwise, use the opt_ise_ne_ibif_nbf 
transform. If you use the opt_ibif_nbf transform, be sure to 
execute the transform est_ibif_nbf first.

3 Scroll the Parameters table to display EEBJT2.ise and ne. 

4 Select est_ise_ne > Execute. Observe the value changes in the 
Parameters table.

5 Select ibf_Gummel > Execute again so that you can view the 
results of the parameter estimates for ise and ne on the plot.

Check the fit of the Gummel plot again and proceed as follows:

• If the fit looks good, the extraction is done.

• If you think it is necessary to optimize the fit, execute the 
following two transforms (set_opt_vars_fwd, Step 1 and 
opt_ise_ne_ibif_nbf, Step 2).

1 Select set_opt_vars_fwd > Execute.

2 Select opt_ise_ne_ibif_nbf > Execute. This optimizes all the 
parameters ibif, nbf, ise, and ne. You can see the final values 
in the Parameters table.
IC-CAP Nonlinear Devices Models Volume 2



The Agilent EEBJT2 Model 7

IC-CAP Nonlinear Devices Models V

 

Extracting Parameters with Individual rgummel Transforms

Use this method if you need to extract individual parameters or 
“fine-tune” a particular rgummel parameter. Use the 
Parameters table, scrolling as necessary, to see the new 
extracted values of the parameters. The steps presented in this 
section—for each transform—assume the rgummel setup is the 
active setup.

To compute the emitter current (ie):

1 Select the rgummel setup.

2 Select Extract/Optimize.

3 Select ie > Execute. The transform computes the emitter 
current from the measured base and collector currents.

After setting the variables on which the extractions and 
optimizations depend, you can extract and optimize the base 
current parameters EEBJT2.ibir, nbr, isc, and nc. 

To set the variables:

1 Select Plots > rev_Gummel > Display Plot.

2 To view a linear portion of the rgummel traces, click the Setup 
Variables tab. The setup variable table appears.

3 From the plotted data, choose a linear portion of the emitter 
current trace, excluding any noisy data at the low voltage 
end. Click the mouse pointer at the lower and upper 
boundary points of the linear portion of the trace.

4 From the Plot window, select Options > Copy to Variables to 
change the X_LOW and X_HIGH values for this plot to the 
boundary points you selected. 

5 In the setup variable table, set VBC_LOW_TR to a value less 
than X-HIGH, where the slope of the base current trace is still 
the same as at X_HIGH.

6 In the setup variable table, set VBC_HIGH_LK to a value 
greater than X_LOW where the slope of the base current 
trace is the same as at X_LOW.

• The region between VBC_LOW_TR and X_HIGH is the 
transport region where the parameters ibir and nbr can be 
estimated.
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• The region between X_LOW and VBC_HIGH_LK encloses 
the leakage region where the parameters isc and nc can be 
estimated.

Once these variables are set, the remaining transforms can be 
executed. Many of the transforms rely on these variables, 
therefore the extractions will not work properly unless the 
variables are first set correctly.

1 Scroll the Parameters table to display isr and nr. 

2 Select Extract/Optimize.

3 Select extr_isr_nr > Execute. Observe the changes in the 
Parameters table values.
NOTE The values extracted for the parameters isr and nr are a function of both 
the input data and the parameter EEBJT2.vaf. Therefore, after you extract 
vaf in the forward_IV setup, you will need to return to this setup and 
execute the extr_isr_nr transform again. (Note that this is handled 
automatically in the Extract_DC macro.)
4 Select icr_Gummel > Execute. The transform computes the 
simulated reverse Gummel collector current.

5 Scroll the Parameters table to display EEBJT2.ibir and nbr. 

6 Select est_ibir_nbr > Execute. Observe the value changes in the 
Parameters table.
NOTE This transform zeroes the parameter EEBJT2.isc so that the effects of 
EEBJT2.ibir and nbr are the only ones visible in simulations immediately 
following the extraction. This makes the quality of the fit easier to 
determine.
7 Select ibr_Gummel > Execute. The transform computes the 
simulated reverse Gummel base current, so that the result of 
the ibir and nbr extraction is observable on the plot.

Now you must make a decision based on the results you have 
seen thus far:
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• If the Gummel fit in the transport region between 
VBC_LOW_TR and X_HIGH looks good, you can stop the 
extraction at this point. 

• If you want to extract the leakage parameters isc and nc, 
you can skip the next two transforms (set_opt_vars_rev, 
Step 1 and opt_ibir_nbr, Step 2) and go directly to 
est_isc_nc (Step 3).

• If you are not satisfied with the Gummel fit in the 
transport region and you do not need to extract the 
leakage parameters, perform the next two transforms 
(set_opt_vars_rev, Step 1 and opt_ibir_nbr, Step 2) and 
then stop.

1 Select set_opt_vars_rev > Execute. This sets optimization limits 
for the ibir, nbr, isc, and nc parameters. The limits are set to a 
specific percentage above and below the parameter values. 
The variable PAR_OPT_TOL controls the percentage 
variation.

2 The optimization performed with opt_ibir_nbr should only be 
used if the base current leakage parameters are to be 
neglected. Otherwise, use the opt_isc_nc_ibir_nbr transform. 
If you use this opt_ibir_nbr transform, be sure to execute the 
transform est_ibir_nbr first.

3 Scroll the Parameters table to display EEBJT2.isc and nc. 

4 Select est_isc_nc > Execute. Observe the value changes in the 
Parameters table.

5 Select ibr_Gummel > Execute again so that you can view the 
results of the parameter estimates for isc and nc on the plot.

Check the fit of the reverse Gummel plot again.

• If the fit looks good, the extraction is done.

• If you think it is necessary to optimize the fit, perform the 
following two transforms (set_opt_vars_rev, Step 1 and 
opt_isc_nc_ibir_nbr, Step 2).

1 Select set_opt_vars_rev > Execute.

2 Select opt_isc_nc_ibir_nbr > Execute. This optimizes all the 
parameters ibir, nbr, isc, and nc. You can see the final values 
in the Parameters table.
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Extracting Parameters with forward_IV (DC)

The forward_IV setup is used to extract the parameters 
EEBJT2.vaf, ikf, and rc. It is important to understand that this 
extraction will be effective only if the Gummel parameters have 
been properly extracted first.

1 Select the forward_IV setup.

2 Select Plots > ic_vce > Display Plot.

3 Select Extract/Optimize.

4 Select set_limits > Execute. A series of dialog boxes appears, 
prompting you to input minimum and maximum Vce and Ic 
values for the optimization.

5 Select ic_mod > Execute. This computes the modeled 
(simulated) collector current using Ib and Vce as the 
independent variables.

6 Select set_vaf_to_limit > Execute. This sets the parameter 
EEBJT2.vaf to its upper optimization limit VAF_MAX. It is 
useful to perform this transform before opt_ikf, because a 
high value for vaf helps to give a good upper boundary to 
EEBJT2.ikf. 

7 In the Parameters table, set EEBJT2.rc to 0.0 for the ikf 
extraction. 

8 Select opt_ikf > Execute. This performs a random optimization 
on the parameter EEBJT2.ikf. When executed with 
EEBJT2.rc = 0.0 and EEBJT2.vaf set to a large value, this 
optimization gives a good upper bound for EEBJT2.ikf.

9 Select set_ikf_max > Execute. This sets the variable IKF_MAX 
equal to the parameter EEBJT2.ikf, for use in the macro 
Extract_DC.

10 Select opt_vaf_ikf > Execute. This optimizes the parameters 
EEBJT2.vaf and ikf to fit the measured forward IV collector 
current. This optimization should be used only after you 
obtain a reasonable estimate for an upper bound on ikf.

11 Select opt_rc > Execute. This performs a random optimization 
of EEBJT2.rc to the measured forward IV collector current. 
The primary purpose is to get an initial estimate of rc.
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12 Select set_opt_vars_rc > Execute. This sets the optimization 
limit variables for EEBJT2.rc. The limits are set to a specific 
percentage above and below the current values of rc:. The 
variable PAR_OPT_TOL controls the percentage variation. 
The primary purpose of this transform is to set the variables 
to a reasonable window after executing the opt_rc 
optimization and before executing the final opt_vaf_ikf_rc 
optimization. 

13 Select opt_vaf_ikf_rc > Execute. This optimizes all three 
parameters to fit the measured forward IV collector current. 
This transform should be used only after you use the 
previous extraction steps to find reasonable estimates for 
these three parameters. Usually windowing is not necessary, 
but you can use the X-LOW/X-HIGH and Y-LOW/Y-HIGH 
functions if breakdown or self-heating effects are visible at 
high values of Vce, to obtain a linear data trace for the 
optimization. You can see the final values in the Parameters 
table and observe the traces converge on the plot.

14 Now that you have extracted a final value for vaf, go back to 
the rgummel setup and select extr_isr_nr > Execute again.

Extracting Parameters with reverse_IV (DC)

The reverse_IV setup is included for validation and reference 
only; it does not include any extractions.

1 Select the reverse_IV setup. 

2 Select Plots > ie_vce > Display Plot.

3 Select Extract/Optimize.

4 Select ie_meas > Execute. The transform displays the 
measured data on the plot.

5 Select ie_mod > Execute to display the modeled data.

6 Observe the plot to compare the modeled data to the 
measured data.
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Extracting Parameters with rev_output (DC)

The rev_output setup is used to extract and validate the reverse 
early voltage parameter EEBJT2.var. This extraction will be 
effective only if the Gummel parameters have been properly 
extracted first.

1 Select the rev_output setup.

2 Select Plots > ie_vec > Display Plot.

3 Select Extract/Optimize.

4 Select ie > Execute. The transform computes the measured 
emitter current from the measured base and collector 
currents.

5 Select ie_mod > Execute. This computes the modeled 
(simulated) emitter current.

6 Select go > Execute. This computes the derivative of the 
emitter current with respect to the voltage Vec. Scroll the 
Parameters table to display EEBJT2.var.

7 Select est_var > Execute. This computes an approximation of 
EEBJT2.var from a closed-form equation, using a numerical 
derivative based on the measured data to estimate var. The 
method is described in the book “Modeling the Bipolar 
Transistor,” by Ian Getreu (see “Modeling the Bipolar 
Transistor. Ian Getreu. 1976 Tektronix Inc.” on page 455). 
This step should be done before the optimization.

8 Select opt_var > Execute. This optimizes EEBJT2.var to fit the 
modeled ie data to the measured ie. You can observe the 
traces converge on the plot, and the final value for var in the 
Parameters table.

9 Now that you have extracted a final value for var, go back to 
the fgummel setup and select extr_isf_nf > Execute again.

Extracting with the AC_extrinsics DUT

The AC_extrinsics DUT contains two setups:

• package—Contains measurement and extraction transforms. 
The extraction is described here; measuring was described 
earlier in the measurement section.
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• extr_re—Contains extraction transforms only and is 
described here in detail.

Extracting Parameters with package (AC)

The package setup extracts the extrinsic parasitic base 
resistance EEBJT2.rb and the extrinsic parasitic inductances lb, 
lc, and le.

1 Select the package setup. Select Extract/Optimize.

2 Select set_freq_pars > Execute. This transform looks for any 
arbitrary user-specified frequency values that are not 
calibrated, and resets them by moving them to the nearest 
calibrated frequency point. A calibrated frequency point is 
any point in the measured frequency sweep that is equal to 
the start frequency plus an integer multiple of the step size.

3 Select s_mod_int > Execute. This computes the intrinsic 
modeled S-parameters of the small-signal BJT equivalent 
circuit.

4 In the Parameters table find EEBJT2.lb, lc, and le. Set the 
values for these three inductance parameters to 0.000.

5 Select estimate_ind > Execute. This extracts the parasitic 
inductances from the measured data based on the method of 
Arnold et al, documented in “Direct Extraction of GaAs 
MESFET Intrinsic Element and Parasitic Inductance Values” 
(see “Modeling the Bipolar Transistor. Ian Getreu. 1976 
Tektronix Inc.” on page 455).

6 Open the delta_z_im plot and the S-parameter plots not 
suffixed _pre.

7 Select s_mod_int > Execute again. The s_mod and delta_z 
transforms are automatically recomputed and their results 
updated on the S-parameter plots and the delta_z_im plot. 
The modeled S-parameters should fit the measured data 
reasonably well after this step. Slight errors in the S11 fit will 
be accounted for in the next step. The traces in the 
delta_z_im plot should exhibit a linear dependence with 
frequency.

8 Locate EEBJT2.rb in the Parameters table.
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9 Select opt_rb > Execute. This optimizes the parameter 
EEBJT2.rb by minimizing the error between measured and 
modeled S11. This also automatically calls the transform 
s_mod, which computes the modeled extrinsic S-parameters 
of the small-signal BJT equivalent circuit.
NOTE The transform set_bias is actually a macro that was used in the 
measurement procedure for setting the sweep variables IB_TYP and 
VCE_TYP. Do not use it now.
Extracting Parameters with extr_re (AC)

This setup extracts the emitter resistance parameter 
EEBJT2.re. It is important that all the DC_current extractions 
are performed before this one.

This setup uses the measured S-parameter data from the 
meas_spar_vce_ib setup, and will only work if that measured 
S-parameter data exists. Note that this setup and the 
meas_spar_vce_ib setup have identical sets of bias input 
variables. It is important that they remain the same: do not 
change the inputs.

1 Select the extr_re setup.

2 Select Plots > gm_vs_vce > Display Plot.

3 In the Parameters table find EEBJT2.re.

4 Select Extract/Optimize.

5 Select sdta > Execute. This reads the measured data, 
de-embeds the extrinsics, and transforms the intrinsic data 
into a table of bias-dependent small-signal element values. 
This is the data on which the rest of the transforms are 
performed.

6 Select set_limits > Execute. A series of dialog boxes appear 
prompting for you to enter minimum and maximum Vce and 
gm values for the gm optimization.

7 Select gm_int_mod > Execute. This computes the intrinsic 
transconductance of the model.

8 Select opt_re_random > Execute. This uses a random 
optimization to minimize the error between the measured 
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intrinsic gm and the modeled intrinsic gm, thus optimizing 
the emitter resistance re. Observe the re value change in the 
Parameters table.

9 Select opt_re_grad > Execute. This uses a gradient optimization 
to further minimize the error between the measured intrinsic 
gm and the modeled intrinsic gm.

Extracting with the AC_charge DUT

These setups are used for extractions only. For measured data, 
the AC_charge setups rely on the S-parameter measurements 
made in the setups of the AC_measurements DUT. 
NOTE If you do not use the Measure_AC macro to perform the measurements, 
you will need to set the variables FREQ_START, FREQ_STOP, and 
FREQ_PTS manually in the variable table. The values you select must 
correspond with the sweep values used for the network analyzer 
calibration.
 
Extracting Parameters with extr_be_cap (AC)

This setup extracts the base-emitter junction depletion 
capacitance parameters EEBJT2.cje, vje, and mje. It uses the 
measured S-parameter data from the meas_spar_vbe setup, and 
will only work if that measured S-parameter data exists. This 
setup and the meas_spar_vbe setup have identical sets of bias 
input variables. It is important that they remain the same: do 
not change the inputs.

1 Select the extr_be_cap setup. Display the cbe_vs_vbe plot.

2 Select Extract/Optimize.

3 Select sdta > Execute. This reads the measured data, 
de-embeds the extrinsics, and transforms the intrinsic data 
into a table of bias-dependent small-signal element values. 
This is the data on which the rest of the transforms are 
performed.

4 In the Parameters table, set EEBJT.tf, xtf, and itf to 0.000.

5 Scroll the Parameters table to show EEBJT2.cje, vje, and mje.
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6 Select cbe_mod > Execute. This computes the base-emitter 
capacitance for the EEBJT2 model.

7 Select set_cje > Execute. This estimates the zero-bias junction 
capacitance parameter EEBJT2.cje from a direct extraction. 

8 Select cbe_mod > Execute again.

9 Select opt_mje_vje > Execute. This optimizes mje and vje only, 
holding cje constant.

10 Select set_opt_vars > Execute. This sets the optimization limit 
variables for cje and vje.

11 Select opt_cje_mje_vje > Execute. This optimizes the three 
junction capacitance parameters by minimizing the error 
between the measured Cbe and the modeled Cbe. You can see 
the values change in the Parameters table.

Extracting Parameters with extr_bc_cap (AC)

This setup extracts the base-collector junction depletion 
capacitance parameters EEBJT2.cjc, vjc, and mjc. It uses the 
measured S-parameters from the meas_spar_vbc setup, and will 
only work if that measured S-parameter data exists. Note that 
this setup and the meas_spar_vbc setup have identical sets of 
bias input variables. It is important that they remain the same: 
do not change the inputs.

1 Select the extr_bc_cap setup. Display the cbc_vs_vbc plot.

2 Scroll the Parameters table to show EEBJT2.cjc, vjc, and mjc.

3 Select Extract/Optimize.

4 Select sdta > Execute. This reads the measured data, 
de-embeds the extrinsics, and transforms the intrinsic data 
into a table of bias-dependent small-signal element values. 
This is the data on which the rest of the transforms are 
performed.

5 Select cbc_mod > Execute. This computes the base-collector 
capacitance for the EEBJT2 model.

6 Select set_cjc > Execute. This estimates the zero-bias junction 
capacitance parameter EEBJT2.cjc from a direct extraction.

7 Select opt_mjc_vjc > Execute. This optimizes mjc and vjc only, 
holding cjc constant.
IC-CAP Nonlinear Devices Models Volume 2



The Agilent EEBJT2 Model 7

IC-CAP Nonlinear Devices Models V

 

8 Select set_opt_vars > Execute. This sets the optimization limit 
variables for cjc and vjc.

9 Select opt_cjc_mjc_vjc > Execute. This optimizes the three 
junction capacitance parameters by minimizing the error 
between the measured Cbc and the modeled Cbc. You can see 
the values change in the Parameters table. The following 
figure shows an example of the plotted data following 
optimization.

Extracting Parameters with extr_be_delay (AC)

This setup extracts the base-emitter junction transit time 
parameters EEBJT2.tf and itf. It uses the measured 
S-parameters from the meas_spar_vbe_fb setup, and will only 
work if that measured S-parameter data exists. Note that this 

Figure 160 Example cbc_vs_vbc Plot
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setup and the meas_spar_vbe_fb setup have identical sets of 
bias input variables. It is important that they remain the same: 
do not change the inputs.

1 Select the extr_be_delay setup. Display the ft_vs_ic plot. The 
following figure shows an example of ft plotted with respect 
to collector current in the ft_vs_ic plot.

2 Scroll the Parameters table to display EEBJT2.tf and itf. 
(They are not together in the table.)

3 Select Extract/Optimize.

4 Select sdta > Execute. This reads the measured data, 
de-embeds the extrinsics, and transforms the intrinsic data 
into a table of bias-dependent small-signal element values. 
This is the data on which the rest of the transforms are 
performed.

5 Select cbe_mod > Execute. This computes the base-emitter 
capacitance for the EEBJT2 model.

Figure 161 Example ft_vs_ic Plot
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6 Select opt_cbe > Execute. This optimizes the parameters 
EEBJT2.tf and itf by minimizing the error between the 
measured Cbe and the modeled Cbe. The values in the 
Parameters table will probably change by only a small 
amount.

7 Select ft_int_meas > Execute. This computes the intrinsic 
device Ft from the measured gm and Cbe.

8 Select ft_int_mod > Execute. This computes the intrinsic device 
Ft from the modeled gm and Cbe.

Extracting Parameters with extr_vtf (AC)

This setup extracts the base-emitter junction transit time 
parameter EEBJT2.vtf. It uses the measured S-parameters from 
the meas_spar_vce_ib setup, and will only work if that 
measured S-parameter data exists. Note that this extr_vtf setup 
and the meas_spar_vce_ib setup have identical sets of bias 
input variables. It is important that they remain the same: do 
not change the inputs.

1 Select the extr_vtf setup. Display the cbe_vce plot.

2 Scroll the Parameters table to show EEBJT2.vtf (near the 
bottom of the table).

3 Select Extract/Optimize.

4 Select sdta > Execute. This reads the measured data, 
de-embeds the extrinsics, and transforms the intrinsic data 
into a table of bias-dependent small-signal element values. 
This is the data on which the rest of the transforms are 
performed.

5 Select cbe > Execute. This computes the base-emitter 
capacitance for the EEBJT2 model.

6 Select opt_vtf > Execute. This optimizes the parameter 
EEBJT2.vtf by minimizing the error between the measured 
Cbe and the modeled Cbe. The value in the Parameters table 
will probably change by only a small amount.
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The AC_validation DUT contains the setup spars_fwd_active to 
validate the fit of the nonlinear model to S-parameters 
measured over bias. No parameters are extracted in this setup.

The bias inputs are preset using existing variables that 
represent typical bias values. You can alter these bias sweeps in 
order to examine the model fit at any bias. However, you should 
not change the values of existing variables. Instead, use new 
variables or enter numerical values directly into the inputs.

None of the macros is equivalent in any way to this setup.

1 Select the spars_fwd_active setup. Open the plots and arrange 
them on the screen so that you still have access to the Model 
window.

2 Select Extract/Optimize.

3 Select y_int_mod > Execute. This computes the intrinsic 
modeled Y-parameters of the EEBJT2 model over the bias 
range specified by the inputs. It also automatically calls the 
s_mod transform, which converts the intrinsic Y-parameters 
to S-parameters and adds the effects of the extrinsic 
elements to the S-parameters.

4 Observe the modeled data converge to the measured data in 
the plots.

5 If you want to save the parameters in the Parameters table in 
an MDIF (Measurement Data Interchange Format) file for 
compatibility with Libra, Execute the write_pars_to_file 
transform and type your own filename for the parameters. A 
copy of the MDIF file is written to the IC-CAP Status window.
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Mextram 504 Model

Mextram 504 in IC-CAP 458

Additional References for the Mextram Transistor Model 459

A new version of the Philips model for vertical bipolar 
transistor has been developed—Mextram level 504. This model 
provides a better description than Mextram level 503 for first 
and high-order derivatives of the characteristics. Special 
attention was paid to SiGe transistors, and self-heating was 
included in the description. A complete description of the 
Mextram 504 model can be found in the following Philips 
report:

The Mextram Bipolar Transistor Model
level 504
J.C.J. Paasschens, W.J. Kloosterman

This report is available as a pdf file and can be downloaded 
from the following web site:

http://www.semiconductors.philips.com/Philips_Models/ 
bipolar/mextram/
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The IC-CAP example file for the Mextram 504 model extraction 
is located at:

/examples/model_files/bjt/mxt504_npn.mdl

The example file refers to a four-terminal device. The extraction 
procedure and the dedicated IC-CAP transforms used in the 
example file are extensively documented in the following report 
from Philips:

Parameter Extraction for the Bipolar Transistor Model 
Mextram
level 504
J.C.J. Paasschens, W.J. Kloosterman, R.J. Havens

This report is available as a pdf file and can be downloaded 
from the following web site:

http://www.semiconductors.philips.com/Philips_Models/ 
bipolar/mextram/

A list of the IC-CAP transforms used in the Mextram 504 
extraction can also be found in Chapter 8, “IC-CAP Functions,” 
in the IC-CAP Reference manual.
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• Latest information about Philips Models:

http://www.semiconductors.philips.com/Philips_Models/ 
news_flash/

• News about Mextram 504:

http://www.semiconductors.philips.com/Philips_Models/ 
news_flash/archive/#reports/

• Additional reports on Mextram (includes a list of published 
papers and references)

http://www.semiconductors.philips.com/Philips_Models/ 
bipolar/mextram/
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VBIC Model

Getting Started in IC-CAP 464

Using the VBIC Model 467

Storing the Model 560

References 561

The VBIC vertical BJT model has been developed specifically as 
a replacement for the SPICE Gummel-Poon model, by 
representatives of the IC and CAD industries.  The SPICE 
Gummel-Poon model has remained essentially an unchanged 
industry standard for over 20 years.  For devices available until 
recent times it has been an intuitive and physically consistent 
formulation that has generally met the requirements of BJT 
device modeling.

However, improvements in modern device technology have 
increasingly indicated a need for improvements in BJT 
modeling techniques.  Some of the technology changes are 
these:

• Reduced base width.

• Smaller device dimensions and changes in device structure.

• Changes in doping profiles.

• Parasitic substrate transistor.

Reduced base width means that higher-order effects have more 
significance.  The Early effect approximation in the 
Gummel-Poon model is not sufficiently accurate to account for 
these effects.
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Smaller device dimensions increase the importance of parasitic 
overlap capacitances not accounted for by the Gummel-Poon 
model.  As the base width becomes smaller, the response 
becomes more nonlinear.

Changes in doping profiles increase the quasi-saturation effects 
of collector resistance, which is not accounted for in the 
Gummel Poon model.

The parasitic substrate transistor is not included in the 
Gummel-Poon model.  Therefore both DC and AC modeling are 
less accurate than needed in today’s devices.

To overcome these issues,  representatives from the IC and CAD 
industries have collaborated over the last few years to 
recommend an improved standard BJT model for the 
semiconductor industry.  The result is VBIC, a model that is 
now viable and will continue to develop as further 
improvements are made.

VBIC (vertical bipolar inter-company model)  includes improved 
modeling of the Early effect (output conductance), substrate 
current, quasi-saturation, and behavior over temperature: 
information necessary for accurate modeling of current 
state-of-the-art devices.  However, it has additionally been 
defined so that, with default parameters, the model will 
simplify to be as similar as possible to the Gummel-Poon model.

Advantages of VBIC over the Gummel-Poon model include the 
following:

• An Early effect model based on the junction depletion 
charges.

• A modified Kull model for quasi-saturation valid into the 
Kirk regime (the high-injection effect at the collector).

• Inclusion of the parasitic substrate transistor.

• An improved single-piece junction capacitance model for all 
three junction capacitances.

• Improved static temperature scaling.

• First-order modeling of distributed base and emitter AC and 
DC crowding.
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• Overall improved high-level diffusion capacitance modeling 
(including the quasi-saturation charge).

• Inclusion of parasitic overlap capacitances.

• Inclusion of the onset of weak avalanche current for the 
base-collector junction.

• High-order continuity (infinite) in equations.

• A noise model similar to that of the Gummel-Poon model, 
with shot, thermal, and 1/f components.

• A defined self-heating model with hooks included in code: 
the self-heating model itself will be available in a future 
release of VBIC.

The Agilent 85193D VBIC model assumes the device under test 
to be a vertical bipolar NPN transistor, fabricated in a P-type 
substrate.
 

NOTE The example VBIC model is set up to test an NPN transistor. With certain 
modifications, you can use the example model to extract a PNP transistor. 
Set the model variable polarity to PNP, and adjust the bias values in the 
Setups to appropriately bias a PNP device.
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The procedures in this chapter assume the following:

• The system has been set up and switched on according to the 
instructions under:

• Agilent 8510-based system—“Configuring the System 
Hardware” on page 575 in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• Agilent 8753-based system—“Configuring the System 
Hardware” on page 609 in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

• Wiltron 360-based system—Refer to your Wiltron 
documentation

• The calibration standards have been removed from their 
containers to allow them to reach ambient room 
temperature.

• The IC-CAP software has been properly installed on the 
computer.

• IC-CAP has been configured to recognize the system 
hardware, and the SMUs have been renamed (as described in 
“Renaming the SMUs” on page 465), based on the 
instructions in the appropriate chapter: 

• “Performing Hardware Setup in IC-CAP” on page 585 in 
Appendix B, “Using IC-CAP with an Agilent 85122A 
Precision Modeling System”

• “Performing Hardware Setup in IC-CAP” on page 617 in 
Appendix C, “Using IC-CAP with an Agilent 85123A 
Device Modeling System”

Refer to Appendix A, “Agilent 85190A IC-CAP” for instructions 
on launching the IC-CAP software and opening the model file 
you need. The VBIC model file is under: 

/examples/model_files/bjt/vbic_npn.mdl
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Use this procedure to rename the SMUs to match the names 
used in the measurement setups, so that the software can 
control the bias supplies.

When you run IC-CAP, the software initially identifies the 
Agilent 4142B DC source/monitor SMUs according to the 
numbers of the slots in which they are installed.  A 
medium-power SMU occupies one slot.  A high-power SMU 
occupies two slots, and is identified by the higher slot number 
of the two. 

A measurement system can include different combinations of 
SMUs. This model requires the use of four SMUs. 

In configuring IC-CAP to recognize the measurement system, set 
the SMU names in IC-CAP to identify the SMU connections at 
the measurement terminals.  In the VBIC model, the SMUs are 
identified as follows:

To change the SMU names in IC-CAP, select Configure under 
Instrument List in the hardware window.  A window is 
displayed similar to the one in the illustration.

VB Base VE Emitter

VC Collector VS Substrate

Figure 162 Example Configuration of SMUs in the Agilent 4142
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In the Unit Table, change the existing SMU names in the box to 
the names  required by VBIC.  (If you use the GNDU SMU for the 
emitter connection, change its name to VE.)  Select OK when you 
are done.

If you wish to save the hardware configuration, select File > Save 
As, and assign a filename with the suffix .hdw.
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This chapter provides a sequence of example procedures that 
take you step-by-step through a VBIC measurement and 
extraction.  To facilitate the model extraction, the parameters to 
be extracted are divided into subsets, where each subset is 
extractable from a single set of measured data using explicit 
bias conditions.  This speeds the total time of parameter 
extraction.

A series of different IC-CAP DUTs and setups are used to 
measure current, voltage, capacitance, or S-parameters under 
different bias and frequency conditions.

The procedures are documented in the proper sequence to 
allow earlier measured data or extracted parameters to be used 
as a basis for later measurements or extractions.
 

NOTE These procedures measure and model a vertical NPN device.
The procedures in this chapter include instructions for the 
following:

• Getting started in IC-CAP 5.0 and opening the model.

• Configuring IC-CAP to recognize the measurement system.

• Setting hardware instrument states (instrument options).

• Setting the inputs for each measurement.

• Performing the capacitance, DC, and S-parameter 
measurements.

• Storing the measured data.

• Initializing device parameters using a macro.

• Performing a total model extraction using a single macro.

• Performing individual extractions using lesser macros.

• Also provides information on the transforms in the 
individual setups.
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• Storing the model.

The procedures start with example values for the measurement 
inputs.  They provide guidelines on setting the values to 
measure your device.  However, the values you use will be based 
on your knowledge of your device and on information provided 
in its data sheet, as well as on the guidelines provided here: they 
may or may not correspond with the example.  In some cases, it 
may be necessary to set the inputs, make a measurement, and 
then reset the inputs based on the measurement results.  The 
procedures give suggestions on judging the applicability of the 
input values and measured data.

The illustrations of plotted data are provided as visual examples 
of possible results.  They are not intended to represent a 
sequential measurement of a single device, nor do they 
necessarily correspond with the example measurement inputs 
described in the procedures.  The plots can be used to check the 
reasonableness of your own data, which should appear similar 
in shape but not necessarily coincident in values.

In addition, the IC-CAP software itself includes measured data 
for some or all of the setups.  This data shows additional 
examples of possible results.  Many, though not necessarily all, 
of the input settings for this measured data correspond with the 
example settings in this manual.
Model Parameters
The table in the next few pages lists the VBIC model parameters 
and their definitions.

Table 51  VBIC Model Parameters 

Parameter Definition Default Value

TNOM Nominal measurement temperature of 
parameters

2.7E+01

RCX@TNOM Extrinsic collector resistance 0.0

RCI@TNOM Intrinsic collector resistance 0.0

VO@TNOM Epi drift saturation voltage 0.0
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GAMM@TNOM Epi doping parameter 0.0

HRCF High-current RC factor 1.0

RBX@TNOM Extrinsic base resistance 0.0

RBI@TNOM Intrinsic base resistance 0.0

RE@TNOM Emitter resistance 0.0

RS@TNOM Substrate resistance 0.0

RBP@TNOM Parasitic base resistance 0.0

IS@TNOM Transport saturation current 1.0E−16

NF@TNOM Forward emission coefficient 1.0

NR@TNOM Reverse emission coefficient 1.0

FC Forward bias depletion capacitance limit 0.9

CBEO Extrinsic base-emitter overlap capacitance 0.0

CJE@TNOM Base-emitter zero-bias capacitance 0.0

PE@TNOM Base-emitter built-in potential 0.75

ME Base-emitter grading coefficient 0.33

AJE Base-emitter capacitance smoothing factor −0.5

CBCO Extrinsic base-collector overlap capacitance 0.0

CJC@TNOM Base-collector intrinsic zero-bias 
capacitance

0.0

QCO Epi charge parameter 0.0

CJEP@TNOM Base-collector extrinsic zero-bias 
capacitance

0.0

PC@TNOM Base-collector built-in potential 0.75

MC Base-collector grading coefficient 0.33

AJC Base-collector capacitance smoothing factor −0.5

CJCP@TNOM Substrate-collector zero-bias capacitance 0.0

Table 51  VBIC Model Parameters  (continued)

Parameter Definition Default Value
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PS@TNOM Substrate-collector built-in potential 0.75

MS Substrate-collector grading coefficient 0.33

AJS Substrate-collector capacitance smoothing 
factor

−0.5

IBEI@TNOM Ideal base-emitter saturation current 1.0E−18

WBE Portion of IBEI from Vbei, 1−WBE from Vbex 1.0

NEI Ideal base-emitter emission coefficient 1.0

IBEN@TNOM Non-ideal base-emitter saturation current 0.0

NEN Non-ideal base-emitter emission coefficient 2.0

IBCI@TNOM Ideal base-collector saturation current 1.0E−16

NCI Ideal base-collector emission coefficient 1.0

IBCN@TNOM Non-ideal base-collector saturation current 0.0

NCN Non-ideal base-collector emission 
coefficient

2.0

AVC1 Base-collector weak avalanche parameter 1 0.0

AVC2@TNOM Base-collector weak avalanche parameter 2 0.0

ISP@TNOM Parasitic transport saturation current 0.0

WSP Portion of ICCP from Vbep, 1−WSP from Vbci 1.0

NFP Parasitic forward emission coefficient 1.0

IBEIP@TNOM Ideal parasitic base-emitter saturation 
current

0.0

IBENP@TNOM Non-ideal parasitic base-emitter saturation 
current

0.0

IBCIP@TNOM Ideal parasitic base-collector saturation 
current

0.0

NCIP Ideal parasitic base-collector emission 
coefficient

1.0

Table 51  VBIC Model Parameters  (continued)

Parameter Definition Default Value
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IBCNP@TNOM Non-ideal parasitic base-collector saturation 
current

0.0

NCNP Non-ideal parasitic base-collector emission 
coefficient

2.0

VEF Forward Early voltage.  Zero represents 
infinity.

0.0

VER Reverse Early voltage.  Zero represents 
infinity.

0.0

IKF Forward knee current.  Zero represents 
infinity.

0.0

IKR Reverse knee current.  Zero represents 
infinity.

0.0

IKP Parasitic knee current.  Zero represents 
infinity.

0.0

TF Forward transit time 0.0

QTF Variation of TF with base-width modulation 0.0

XTF Coefficient of TF bias dependence 0.0

VTF Coefficient of TF dependence on Vbc 0.0

ITF Coefficient of TF dependence on Ic 0.0

TR Reverse transit time 0.0

TD Forward excess-phase delay time 0.0

KFN Base-emitter flicker noise constant 0.0

AFN Base-emitter flicker noise exponent 1.0

BFN Base-emitter flicker noise 1/f dependence 1.0

XRE Temperature exponent of emitter resistance 0.0

XRB Temperature exponent of base resistance 0.0

XRC Temperature exponent of collector resistance 0.0

Table 51  VBIC Model Parameters  (continued)

Parameter Definition Default Value
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XRS Temperature exponent of substrate 
resistance

0.0

XVO Temperature exponent of VO 0.0

EA Activation energy for IS 1.12

EAIE Activation energy for IBEI 1.12

EAIC Activation energy for IBCI/IBEIP 1.12

EAIS Activation energy for IBCIP 1.12

EANE Activation energy for IBEN 1.12

EANC Activation energy for IBCN/IBENP 1.12

EANS Activation energy for IBCNP 1.12

XIS Temperature exponent of IS 3.0

XII Temperature exponent of IBEI / IBCI / IBEIP 
/IBCIP

3.0

XIN Temperature exponent of IBEN / IBCN  
/IBENP /IBCNP

3.0

TNF Temperature coefficient of NF 0.0

TAVC Temperature coefficient of AVC2 0.0

RTH Thermal resistance 0.0

CTH Thermal capacitance 0.0

Table 51  VBIC Model Parameters  (continued)

Parameter Definition Default Value
The DUTS and Setups
The DUTs and setups are the central focus for the measurement 
and extraction procedures. The DUTs (for example cap), 
indicated by the inverted triangles, are groupings of similar 
measurement setups used to extract related model parameters. 
The setups (for example Cbe) contain the information used to 
define the inputs and outputs for each particular measurement. 
The following figure shows a portion of the DUT/Setup panel.
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The following table summarizes the parameters that will be 
extracted and the IC-CAP DUTs and setups with which they are 
associated.

Figure 163 The DUT/Setup Panel

Table 52 Summary of Setups and Parameters Extracted

DUT Setup Parameters

cap Cbe CJE, PE, ME

Cbc CJC, PC, MC
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Csc CJCP, PS, MS

parasitic Rc_active RCX

Re_flyback RE

Rc_flyback RCX

Rbb RBX, RBI, WBE

Ypads none

early_aval Rev_early CJE, WBE, QBO

Fwd_early VEF, VER, AVC1, AVC2, CJE, CJEP

gummel Forward IS, NF, IBEI, NEI, IBEN, NEN

Reverse NR, IBCI, NCI, IBCN, NCN, ISP, NFP, IKR

output Ic_Vce_vb HRCF, VO, QCO, GAMM, IKF, RCI, RCX

quasi_sat QuasiSat_ac HRCF, VO, QCO, GAMM, IKF, RCI, RCX

QuasiSat_dc HRCF, VO, QCO, GAMM, IKF, RCI, RCX

Ypads none

sparm_cap Cbe CJE, PE, ME

Cbc_Csc CJC, PC, MC, CJCP, PS, MS

Cpads none

delay Ftvsic TF, XTF, ITF, VTF, QTF

Forward_Tau TF, XTF, ITF, VTF, QTF

Reverse_Tau TR, QCO, IKP

Ypads none

Table 52 Summary of Setups and Parameters Extracted (continued)

DUT Setup Parameters
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All the measurements are made before any extractions are 
performed.  It is then possible to extract the parameters 
automatically from the measured data using the macro 
procedures.  This will be explained later in the chapter, 
following the measurement procedures.

Defining the Instrument States

For each of the measurement setups, it is necessary to define 
the instrument states (options) for the measurement 
instruments that will be used in that setup.  The instrument 
states need to be defined individually for each setup.  Different 
setups use different measurement instruments.  However, with 
minor exceptions that will be explained, the instrument states 
for the same measurement type must be used for all the setups 
that use that measurement type.

1 After you have selected a setup, for example gummel 
Forward, the setup window tabs are displayed.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states for all instruments 
used in that measurement.  For example, in the DC 
measurement setups, the instrument states for the DC 
source/monitor will be displayed.  In the CV meter 
capacitance measurement setups, the instrument states for 
the CV meter or LCR meter in use will be displayed.  In the 
S-parameter measurement setups, the instrument states for 
both the DC source/monitor and the network analyzer will be 
displayed.

The instrument state settings will be explained in this chapter 
with their corresponding setups.

Making the cap Cbe Measurement

The cap setups use a CV meter to measure the junction 
capacitances.  This setup measures the base-emitter junction 
capacitance.
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NOTE You need only do one set of capacitance measurements, using either the 
cap setups and a CV meter, or the sparm_cap setups and a network 
analyzer.  The network analyzer measurements provide greater accuracy.  
Also you may find it more convenient to use the network analyzer, since it 
must be calibrated for other measurements anyway.
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Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the CV Meter Instrument State

1 Select the Instrument Options tab, and a window is displayed 
showing the instrument states for the measurement 
instrument used in this setup.

2 Several different CV meters and LCR meters can be used with 
IC-CAP. Refer to Chapter 1, “Supported Instruments,” of the 
IC-CAP Reference manual for specific guidelines on setting 
the instrument states for your CV or LCR meter.

3 Note that IC-CAP provides instrument drivers only for those 
CV meters and LCR meters that are listed in the 
“Measurement” chapter.

The Inputs and Outputs

1 In the cap DUT select the Cbe setup.  The setup inputs and 
outputs are displayed.

• The vbe base-emitter voltage values are set to sweep from 
approximately VBEmax to 0.4V.

• The output is cbe, the base-emitter capacitance.

CJE Base-emitter zero-bias capacitance

PE Base-emitter built-in potential

ME Base-emitter grading coefficient
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Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Cbe_Vbe plot is 
displayed.

2 Select the Measure/Simulate tab, then click Measure.

3 You can save the data using File > Save As and a filename with 
the suffix .set.  Then click OK.

Making the cap Cbc Measurement

This setup measures the base-collector junction capacitance, 
using a CV meter.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the CV Meter Instrument State

Follow the same process you used in the cap Cbe measurement.  
Use the same settings.

The Inputs and Outputs

From the cap DUT, select the Cbc setup.  The setup inputs and 
outputs are displayed.

• The vbc base-collector voltage values are set to sweep from 
approximately VBCmax to 0.4V.

• The output is cbc, the base-collector capacitance.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Cbc_Vbc plot is 
displayed.

2 Select Measure/Simulate > Measure.

CJC Base-collector intrinsic zero-bias capacitance.

PC Base-collector built-in potential.

MC Base-collector grading coefficient.
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3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the cap Csc Measurement

This setup measures the substrate-collector junction 
capacitance, using a CV meter.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the CV Meter Instrument State

Follow the same process you used in the cap Cbe measurement.  
Use the same settings.

The Inputs and Outputs

From the cap DUT, select the Csc setup.  

• The vsc substrate-collector voltage values are set to sweep 
from approximately VBCmax to 0.4V.

• The output is csc, the substrate-collector capacitance.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Csc_Vsc plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

CJCP Substrate-collector zero-bias capacitance

PS Substrate-collector built-in potential

MS Substrate-collector grading coefficient
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Making the parasitic Rc_active Measurement

This uses the fact that the substrate current increases with an 
increasing voltage drop across the constant portion of the 
collector resistor when the device is in either quasi-saturation 
or saturation.  Because the noise level of the substrate current 
is often quite high, the dynamic range of this method may not 
always be sufficient to resolve the bias-independent collector 
resistance adequately.

This method is described in detail in Jorg Berkner’s A Survey of 
DC Methods for Determining the Series Resistance of Bipolar 
Transistors Including the New Delta ISub Method (see 
Bibliography).

Parameters

The data from this measurement will be used to extract this 
parameter:

Defining the DC Source/Monitor Instrument State

This procedure configures IC-CAP with the correct instrument 
state settings (instrument options) to control the DC 
source/monitor.

You will need to set the DC source/monitor instrument state 
separately for each measurement setup that uses it.  However, 
use the same settings for all the measurement setups (with the 
exception of Integ Time, which is explained below).

The settings used here are examples.  Your settings may differ.  
Explanations for the different settings are listed below.

1 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states for the DC 
source/monitor.

2 Set Use User Sweep to No, as it is unnecessary for these 
procedures, and the source/monitor internal sweep is faster.

RCX Extrinsic collector resistance
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3 Hold Time is the delay in seconds before starting a sweep, to 
allow for DC settling.  Generally, no hold time is required.

4 Delay Time is the amount of time in seconds the instrument 
waits before measuring at each step of an internal or user 
sweep.  It can generally be set to 0.0.

5 For Integ Time, M (medium) is a good default choice.  You can 
speed up a measurement by using S (short), but this is not 
recommended because it degrades the dynamic range of the 
measurement.  In measurements where a long integration 
time is needed for noise reduction, use L (long).

6 Set Range to 0 to implement SMU auto-ranging.

7 Power Compliance is used to set the maximum 
current/voltage combination for the DC source/monitor.  
However, in the model, SMU voltage and current compliances 
are set individually in the individual setups.  Therefore the 
value here can be set to 0.000.

8 Set SMU Filters ON to Yes.  This switches in low-pass filters 
on the SMU outputs, to protect the device from voltage spikes 
caused by DAC output changes.
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9 The VBIC model does not use pulsed measurements, 
therefore Pulse Unit can be left blank. All other Pulse settings 
are then irrelevant and can be ignored.

10 Module Control is not used in these procedures.  Leave the 
field blank.

11 Init Command sets the instrument to a mode not supported 
by other fields in this table.  It is not used in this model.  
Leave the field blank.

12 If you wish, refer to the DC source/monitor manual for more 
detail.

The Inputs and Outputs

From the parasitic DUT, select the Rc_active setup. 

Figure 164 Instrument States for the Agilent 4142B DC Source/Monitor
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• The ve emitter voltage is set to sweep from approximately 
−0.4V to −1.2V.  The precise voltage values may vary.  The 
intent is to measure low enough that the non-ideal base 
current effects are visible, and high enough in collector 
current to observe the compression due to high-level 
injection and/or quasi-saturation.

• The vc collector voltage is set to approximately −0.3V, so that 
the parasitic PNP is slightly forward biased.  This is often 
necessary to pull the substrate current Is out of the noise 
floor associated with the substrate.  If the collector 
resistance is too small, its associated voltage drop may be too 
small to adequately bias the parasitic PNP.  The result is that 
the substrate current never becomes large enough to rise 
above the substrate noise floor.

• The vs substrate voltage is usually set at −1V to 
approximately −3V.

• The vb base voltage is set to ground (0.0V).

• The outputs are is, substrate current; ic, collector current; 
and ib, base current; measured with the DC source/monitor. 

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Is_Vbe plot is 
displayed.

2 Select Measure/Simulate > Measure. The measured data 
should resemble the illustration.  The unusual vertical line on 
the trace is caused by the extraction algorithm, and will be 
explained in the extraction section later in this chapter.
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3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the parasitic Re_flyback Measurement

In this procedure a current source drives the base to negate the 
effect of the base parasitic resistance.  The collector is 
open-circuited by setting its SMU current to zero, and the 
emitter is grounded.  The change in collector voltage is 
monitored vs the change in base current.  The collector voltage 
is the base current times the parasitic resistance in the emitter.

Parameters

The data from this measurement will be used to extract this 
parameter:

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

Figure 165 Example Plotted parasitic Rc_active Is_Vbe Data

RE Emitter resistance
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The Inputs and Outputs

Select the Re_flyback setup. 

• The ib base current is set to sweep from approximately 
10 mA to 50 mA (2 mA/um2).

• The ve emitter voltage is set to ground (0.0V).

• The is substrate current is set to 0A, so that only the forced 
base current goes through the emitter.

• The ic collector current is set to 0A, so that the voltage at the 
collector can be measured without any voltage drop across 
the series collector resistance.

• The outputs are vc, collector voltage; ie, emitter current; and 
vb, base voltage.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Vc_Ie plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the parasitic Rc_flyback Measurement

This procedure is similar to the Re_flyback measurement.  A 
current source drives the base to negate the effect of the base 
parasitic resistance.  In this case the emitter is open-circuited 
by setting its SMU current to zero, and the collector is 
grounded.  The change in emitter voltage is monitored vs the 
change in negative collector current.  The emitter voltage is the 
base current times the parasitic resistance in the collector.

Parameters

The data from this measurement will be used to extract this 
parameter:

RCX Extrinsic collector resistance
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Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

The Inputs and Outputs

Select the Rc_flyback setup.

•  The ib base current is set to sweep from approximately 
10 mA to 50 mA (2 mA/um2), the same as in the Re_flyback 
measurement.

• The vc collector voltage is set to ground (0.0V).

• The is substrate current is set to 0A, so that only the forced 
base current goes through the collector.

• The ie emitter current is set to 0A, so that the voltage at the 
emitter can be measured without any voltage drop across the 
series emitter resistance.

• The outputs are ve, emitter voltage; and ic, collector current.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Ve_Ic plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.
Calibrating the Network Analyzer

NOTE This information is presented here because the next measurements, 
parasitic Rbb and Ypads, use S-parameter as well as DC measurements.
It is important to calibrate the network analyzer before you 
perform any S-parameter measurements.  Good calibration of 
the network analyzer is critical to a good measurement and 
extraction.  Without a good calibration, the results of the 
extraction will be inaccurate. 
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The VBIC measurement procedures require a swept broadband 
cal and at least one CW cal.  (One is probably sufficient, but you 
may choose to do certain measurements at different 
frequencies.  The example provided here uses one broadband 
cal and one CW cal frequency.)  The calibrations can be done 
with one set of standards measurements, by making the CW 
frequency cal a subset of the broadband cal.  More than one 
subset CW cal can be done if necessary.

The broadband cal is used for the parasitic Rbb and Ypads 
measurements, described next.  CW cals are used for the 
QuasiSat_ac and quasi_sat Ypads measurements, and the delay 
measurements.  Also, a CW cal is used for the sparm_cap 
measurements if you choose to do the junction capacitance 
measurements with a network analyzer rather than a CV meter.  
It is preferable to use a network analyzer, because it provides 
more accurate capacitance data at higher frequencies, and you 
already need to calibrate the network analyzer for other 
measurements.  If you decide to use a CV meter, you will need to 
set it up and calibrate it in addition to the other hardware 
procedures.

Procedures

For the step-by-step calibration procedures, refer to:

• “Calibrating the Network Analyzer” on page 589 (for an 
Agilent 8510-based system) in Appendix B, “Using IC-CAP 
with an Agilent 85122A Precision Modeling System”

• “Calibrating the Network Analyzer” on page 631 (for an 
Agilent 8753-based system) in Appendix C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System”

Set the frequency range for the parasitic swept broadband 
calibration to cover the operating frequency range of the device 
under test. The start frequency should be as low as possible, 
around 50 to 100 MHz. Set a number of points that will make a 
reasonable number of measurements across the sweep: 11 is 
probably sufficient. 
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For the CW measurements, especially the sparm_cap 
measurements, use a cal frequency as low as possible, 
approximately 50 to 200 MHz. This provides lower parasitics 
and better dynamic range for the junction capacitance 
measurements (for more detailed information, see below).

The frequency of the CW calibration subset or subsets must be 
at a calibrated point in the broadband calibration range.  Use a 
measurement point equal to the start frequency plus an integer 
multiple of the step size.  For example:

50 MHz (start freq) + 10 ⋅ 500 MHz (step size) = 5.05 GHz

Because of the large gain of a BJT device at low frequencies, it is 
important to make sure the input power from the network 
analyzer is not so large as to saturate the device.  In setting the 
attenuation and power level, take care that the power will not 
be excessive at the device input.  Also consider the gain of the 
device, and set a power level that will not saturate the input 
port samplers of the analyzer.  Attenuation and power level 
must be the same for the subset cals as for the broadband cal.

Note the numbers of the cal sets or registers where you save the 
calibrations: you will need to list one of these numbers as part 
of the instrument state for each of the S-parameter 
measurement setups.

After you perform the aforementioned cal procedures, return to 
this chapter and continue.

More on Power Levels and Capacitance Measurements

The primary factor to consider in understanding the available 
range of power is the S-parameter test set, and whether it is 
coupler-based or power-splitter-based. The test set generally 
used in a 26.5 GHz system is the Agilent 8515B, which uses a 
power splitter to couple signals to the detector. The “economy” 
version test set is the Agilent 8514B (20 GHz), which uses a 
directional coupler.

The directional coupler in the Agilent 8514B has a 
−20 dB/decade power rolloff below 500 MHz, with some signal 
loss above that. The result is that in the frequency range 45 MHz 
to 2 GHz the minimum detectable signal of the Agilent 8514B is 
olume 2 487



488

9 VBIC Model
 

only −66 dBm. However, over the same frequency range, the 
minimum detectable signal of the Agilent 8515B is −101 dBm. 
(Above 2 GHz, both test sets can detect at least −95 dBm 
signals.)

The model of synthesizer used does not affect these differences.  
Any potential improvement due to the synthesizer is obscured 
by the effects of the test set.  

Capacitance Junction Measurements

In measuring capacitance junctions, the signal level at the 
device is generally kept below −30 dBm to keep 
nonlinearity-induced errors below 5 percent. Capacitance 
measurements are typically made in the 50 to 100 fF region.

Why is it necessary to keep the signal level below −30 dBm for a 
capacitance measurement? In fact, it is not necessary. The 
device is biased so as not to have any gain, therefore the input 
samplers and the test set are not saturated, nor is the output of 
the device. Additionally, the power level set on the synthesizer 
is not the same as the power level arriving at the device. 
Depending on the frequency range and the test set, there can be 
anywhere from 15 to 30 dB of loss between the source and the 
device.

One method is to solve for the minimum resolvable capacitance, 
given an input power and a dynamic range.  This should be done 
for both S21 (Cbc) and S11 (Cbe), because their respective 
resolutions are different.

Device input power −10 dBm.

Noise Floor −90 dBm.

Dynamic range >80 dB. (80 dB = 1E−04 linear)

S21 Related to Cbc

S21
2 Z0⋅

2 Z0⋅ 1 ωC⁄+( )----------------------------------------- 1 10
04–⋅= =
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= 1.5917E-07/freq

=> minimum C @ 100 MHz = 1.59 fF

S11 Related to Cbe

= 6.36556E-07/freq

=> minimum C @ 100 MHz = 6.37 fF

This analysis verifies the observation that Cbc measurements 
are cleaner than Cbe measurements.

With an Agilent 8515B test set the same capacitance would put 
the signal 40 dB above the noise floor, which would allow 20 dB 
of leeway even as low as 100 MHz.

This verifies the initial statement that it is the S-parameter test 
set that determines the available range of power, and not the 
synthesized sweeper.

C
S21

2 ω Z0 1( S21–⋅ ⋅( ) )
------------------------------------------------------=

S11
1 jωC⁄( ) Z( 0 Z0 )–

1 jωC⁄( ) Z0 Z0+( )---------------------------------------------------= 1 10
04–⋅=

C
2 S11

Z0 ω S11 1+( )⋅------------------------------------------=
Instrument States for Swept S-Parameter Measurements
This procedure configures IC-CAP with the correct instrument 
state settings (instrument options) to control both the DC 
source/monitor and the network analyzer for a swept 
S-parameter measurement.

You need to set the instrument states separately for each 
measurement setup.  However, the parasitic Rbb and Ypads 
setups are the only ones in this model that use a 
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swept-frequency S-parameter measurement.  Other setups use 
CW frequency measurements, which are different and will be 
explained later.

The settings used here are examples.  Your settings may differ.  
Explanations for the different settings are listed below.

Figure 166 Instrument States for Swept S-Parameter Measurements
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1 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states.

2 Set the Agilent 4142 instrument states the same as for the DC 
measurements.

3 Set the Agilent 8510 instrument states according to the 
actual hardware configuration, the calibration used, and the 
device to be measured, following these guidelines.

4 Set Use User Sweep to No, as this is a standard sweep.

5 Hold Time is the time in seconds before the instrument starts 
a sweep, to allow for DC settling.  Generally, no hold time is 
required.

6 Delay Time is the delay in seconds the instrument waits 
before setting each frequency in user sweep mode.  You can 
set a delay, but it is generally not necessary.

7 Set Port 1 Atten and Port 2 Atten to the same levels in dB 
that you set in the network analyzer calibration.  If an IF 
OVERLOAD error message is displayed during the 
measurement you will need to reduce the source output 
power or increase the attenuation, and calibrate again.

8 Set Source Power to the same level as in the network analyzer 
calibration.

9 If you calibrated with a power slope, you can set the 
corresponding value for Power Slope, to better view the 
response of a device with power dropoff at higher 
frequencies.  The units for power slope are dB/GHz; the 
default value is 0.000.  (A network analyzer message will 
caution you that the correction may be invalid, but this can 
be ignored.)

10 Set Fast Sweep (RAMP) to No, because the analyzer is in 
stepped-sweep mode, set previously in the calibration 
procedure.

11 Sweep Time applies only to ramp sweep mode, therefore the 
value set is irrelevant for a stepped-sweep measurement.
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12 Set Use Fast CW to Yes, to minimize repeated switching 
between the test set ports.

13 Set Trim Sweep to 0.  This feature is used only in ramp sweep 
mode.

14 Set Avg Factor to the same averaging factor you set in the 
calibration.  A good default averaging factor is 256.  To speed 
your measurements, you may find it convenient to set an 
averaging factor as low as 16.

15 Set Cal Type (SHN) to H, for hardware.

16 Set Cal Set No to the cal set number in the analyzer where 
you stored your swept broadband frequency calibration.  
This example uses cal set 1.

17 Soft Cal Sequence refers to the sequence of measurements of 
the cal standard devices: load-open-short-thru.

18 Delay for Timeouts can generally be set to the default value of 
0.000.

19 Set Use Linear List to No, because this is a standard 
stepped-frequency measurement.

20 Init Command sets the instrument to a mode not supported 
by other fields in this table.  It is not used in this model.  
Leave the field blank.

21 If necessary, refer to the Agilent 8510C Operating and 
Programming Manual for more detail.

Making the parasitic Rbb Measurement

In this setup the base voltage is swept over a range such that the 
base-emitter junction varies from reverse biased to slightly 
forward biased.  The collector voltage is set high enough to 
avoid saturation and quasi-saturation effects, and low enough to 
avoid breakdown effects.  S-parameters are measured over a 
wide frequency range, in order to observe the distributed 
nature of the base resistance.

Parameters

The data from this measurement will be used to extract these 
parameters:
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Defining the Instrument States

Follow the process described in “Instrument States for Swept 
S-Parameter Measurements” on page 489.

The Inputs and Outputs

Select the Rbb setup.

• The vb base voltage is swept over a range such that the 
base-emitter junction varies from reverse biased to slightly 
forward biased.

• The ve emitter voltage is set to ground (0.0V).

• The vs substrate voltage is set to ground (0.0V).

• The vc collector voltage is set to a value high enough to avoid 
saturation and quasi-saturation effects, and low enough to 
avoid breakdown effects.

• The freq frequency value is swept over a wide range, in order 
to observe the distributed nature of the base resistance.

RBX Extrinsic base resistance

RBI Intrinsic base resistance

WBE The portion of IBEI from Vbei, 1-WBE from 
Vbex
NOTE If you set a MHz value, write MEG in full.  If an error message is displayed, 
you may have entered M only. The outputs are S-parameters (s).
Measuring and Plotting

1 From the Plots tab, select Display All.  All the plots for this 
setup are displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.
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Making the parasitic Ypads Measurement

This setup is used to measure an open dummy structure.  With 
the device disconnected, the S-parameters are measured across 
the same swept frequency range as in the Rbb measurement. 
The data is used to de-embed the device S-parameters. 

Parameters

No parameters are extracted from this data.

Defining the Instrument States

Follow the same process you used for the parasitic Rbb 
measurement, described in “Instrument States for Swept 
S-Parameter Measurements” on page 489. Use the same settings.

The Inputs and Outputs

From the parasitic DUT, select the Ypads setup.

• No voltages are defined or required.

• The frequency range defined in freq must be the same as you 
used in the Rbb setup, with the same number of points.

• The output is S-parameters (s), measured with the network 
analyzer.

Measuring and Plotting

1 Remove the test fixture from the measurement setup, or lift 
the probes of a probe station to present an open circuit.

2 From the Plots tab, select Display Plot.  The Ypads/caps plot is 
displayed.

3 Select Measure/Simulate > Measure. The measured data 
should be constant with frequency, as in the illustration.  If 
not, there may be a problem with the measurement, the 
calibration, or the test structure.
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4 Save the data using File > Save As and a filename with the 
suffix .set.

Making the early_aval Rev_early Measurement

The reverse early measurement models the effect of base-width 
modulation due to variations in the base-emitter depletion 
region.

The data measured in the Rev_early and Fwd_early setups is 
interdependent.  The extracted parameters are derived from the 
results of both measurements.

Parameters

The data from this measurement will be used to extract these 
parameters:

Figure 167 Example Plotted parasitic Ypads Data

CJE Base-emitter zero-bias capacitance

WBE Portion of IBEI from Vbei, 1-WBE from Vbex

QB0 Model variable used in the Init_Parms macro to 
determine initial parameter values
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Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

The Inputs and Outputs

From the early_aval DUT, select the Rev_early setup.

• The vs substrate voltage is usually set at approximately −3V 
to −1V.

• The vb base voltage is set to ground (0.0V).

• The ve emitter voltage should be set high enough that the 
base current just begins to turn negative: this value defines 
VBEmax, which is used in subsequent measurements.  You 
may need to measure several times to determine the proper 
emitter voltage.  Take care during these measurements not to 
break down the base-emitter junction: breakdown of this 
junction can permanently damage the device.

• The vc collector voltage should be around −650 mV. This 
results in a base-collector voltage of 0.65V, which should 
produce emitter current data with few thermal effects.

• The outputs are ib,  ie, and is.

Measuring and Plotting

1 Make sure the device under test is reconnected in a 
measurement configuration.

2 From the Plots tab, select Display All.  The plots for this setup 
are displayed.

3 Select Measure/Simulate > Measure.

4 Save the data using File > Save As and a filename with the 
suffix .set.

Making the early_aval Fwd_early Measurement

The forward early measurement models the effect of base-width 
modulation due to variations in the base-collector depletion 
region. 
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The Fwd_early measurement is performed over a range that 
includes data above avalanche breakdown for extraction of VEF 
and VER, as well as into the weak avalanche region for 
extraction of AVC1 and AVC2. 

Because the Rev_early and Fwd_early setups are 
interdependent in the extraction of parameters, some of the 
measurement inputs are common between them.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

The Inputs and Outputs

Select the Fwd_early setup. 

• The vs substrate voltage is usually set at approximately −3V 
to −1V.

• The vb base voltage is set to ground (0.0V).

• The vc collector voltage should be set high enough that the 
base current just begins to turn negative:  this value defines 
VBCmax, which is used in subsequent measurements.  You 
may need to measure several times to determine the proper 
collector voltage.

VEF Forward early voltage.  Zero represents infinity

VER Reverse early voltage.  Zero represents infinity

AVC1 Base-collector weak avalanche parameter 1

AVC2 Base-collector weak avalanche parameter 2

CJE Base-emitter zero-bias capacitance

CJEP Base-collector extrinsic zero-bias capacitance
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• The ve emitter voltage should be around −650 mV. This 
results in a base-emitter voltage of 0.65V, which should 
produce collector current data with few thermal effects.

• The outputs are ic, collector current; ib, base current; and is, 
substrate current.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Ic_Vc plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the gummel Forward Measurement

This procedure characterizes the operating range of the base 
and collector currents with the transistor in the forward active 
mode.  It measures Ic and Ib with respect to Vbe.  The 
base-emitter voltage is swept across a range large enough that 
both low-level and high-level effects occur.  Some later 
measurements are dependent on the results of the forward 
gummel measurement.

Parameters

The data from this measurement will be used to extract these 
parameters:

IS Transport saturation current

NF Forward emission coefficient

IBEI Ideal base-emitter saturation current

NEI Ideal base-emitter emission coefficient

IBEN Non-ideal base-emitter saturation current

NEN Non-ideal base-emitter emission coefficient
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Defining the DC Source/Monitor Instrument State

Follow the process you used in the Rc_active measurement.  Use 
the same settings, except set Integ Time to L to reduce trace 
noise at low voltage levels.

The Inputs and Outputs

From the gummel DUT, select the Forward setup.

• The vs substrate voltage is usually set at approximately −3V 
to −1V.

• The vb base voltage is set to ground (0.0V).

• The vc collector voltage is also set to ground (0.0V), so that 
the reverse junction (base-collector) is unbiased and will not 
affect the results.

• The ve emitter voltage is set to sweep from approximately 
−0.4V to −1.2V.  The precise voltage values may vary.  The 
intent is to measure low enough that the non-ideal base 
current effects are visible, and high enough in collector 
current to observe the compression due to high-level 
injection and/or quasi-saturation.

• The outputs are ic, collector current; ib, base current; and is, 
substrate current.

Measuring and Plotting

1 From the Plots tab, select Display All.  Several plots are 
displayed.

2 Select Measure/Simulate > Measure. On the Ic_Vbe plot, the 
measured data should resemble the illustration.  The vertical 
line on the trace is caused by the extraction algorithm, and 
will be explained in the extraction section later in this 
chapter.
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3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the gummel Reverse Measurement

This procedure measures Ic and Ib with respect to Vbc.  The 
base-collector voltage is swept across a range approximately the 
same as the base-emitter voltage range in the forward gummel 
measurement. 

Parameters

The data from this measurement will be used to extract these 
parameters:

Figure 168 Example Plotted gummel Forward Ic_Vbe Data

NR Reverse emission coefficient

IBCI Ideal base-collector saturation current

NCI Ideal base-collector emission coefficient

IBCN Non-ideal base-collector saturation current

NCN Non-ideal base-collector emission coefficient

ISP Parasitic transport saturation current
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Defining the DC Source/Monitor Instrument State

Follow the process you used in the Rc_active measurement.  Use 
the same settings, except set Integ Time to L to reduce trace 
noise at low voltage levels.

The Inputs and Outputs

From the gummel DUT, select the Reverse setup.

• The vs substrate voltage is usually set at approximately −3V 
to −1V.

• The vb base voltage is set to ground (0.0V).

• The ve emitter voltage is also set to ground (0.0V), so that the 
reverse junction (base-emitter) is unbiased and will not affect 
the results.

• The vc collector voltage is set to sweep from approximately 
−0.4V to  −1.2V.  The precise voltage values may vary.  The 
intent is to measure low enough that the non-ideal base 
current effects are visible, and high enough in emitter 
current to observe the compression due to high-level 
injection and/or quasi-saturation.

• The outputs are ie, emitter current; ib, base current; and is, 
substrate current.

Measuring and Plotting

1 From the Plots tab, select Display All.  Several plots are 
displayed.

2 Select Measure/Simulate > Measure. The measured data in the 
Ie_Vbc and Ib_Vbc plots should resemble the illustrations.  
The vertical lines are caused by the extraction algorithms, 
and will be explained in the extraction section later.

NFP Parasitic forward emission coefficient

IKR Reverse knee current.  Zero represents infinity
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Figure 169 Example Plotted gummel Reverse Ie_Vbc Data

Figure 170 Example Plotted gummel Reverse Ib_Vbc Data
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Making the output Ic_Vce_vb Measurement

This procedure measures the device over a bias range where it 
exhibits both quasi-saturation behavior (the top one or two 
curves) and non-quasi-saturation behavior (the bottom one or 
two curves), while keeping Vbc < VBCmax where VBCmax 
defines the onset of weak avalanche breakdown.  The data is 
used to extract the parameters related to high-level injection 
and quasi-saturation without avalanche effects.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

The Inputs and Outputs

From the output DUT, select the Ic_Vce_vb setup. 

• The vs substrate voltage is usually set at −3V to −1V.

• The ve emitter voltage is set to ground (0.0V).

• The vb base voltage is set to measure at three points across 
its normal operating range.  

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance
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• The vc collector voltage is swept from 0V to a value large 
enough that the output characteristics exhibit sufficient 
quasi-saturation and/or high-level injection without 
avalanche effects.

• The outputs are ic, collector current; vb, base voltage; and is, 
substrate current.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Ic_Vce plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.
Instrument States for CW S-Parameter Measurements
This information is included here because the first setups to use 
a CW frequency measurement are the setups in the quasi_sat 
DUT.

The instrument states for a CW S-parameter measurement are 
similar to those for a swept measurement, with a few important 
exceptions, listed below.

You will need to set the instrument states separately for each 
CW frequency measurement.  However, use the same settings for 
all the CW measurement setups (except that Integ Time can 
differ among setups).
NOTE Frequencies are set in the setup Inputs, therefore they do not affect 
instrument states even if you choose to use different CW frequencies for 
different measurements, except for the Cal Set No where they are stored.
1 The Agilent 4142 instrument state is the same as for the DC 
and swept S-parameter measurements.

2 Set Use User Sweep to Yes, as CW is a nonstandard sweep.
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3 (Be sure to set Port 1 Atten and Port 2 Atten and Source 
Power to the same levels as you used in the network analyzer 
calibration.)

4 Set Use Fast CW to No.

5 Use the Cal Set No where you stored the CW calibration for 
the quasi_sat measurements.  This must be different from the 
cal set used by the swept broadband calibration, and from 
any CW calibration you make at a different frequency for any 
different measurement.

6 If necessary, refer to the Agilent 8510C Operating and 
Programming Manual for more detail.

Making the quasi_sat QuasiSat_ac Measurement

This procedure measures the device in all of its regions: 
saturated, quasi-saturated, and cut off.  It uses as few 
measurement points as possible, in order to speed up the 
subsequent optimization.  This measures the device with a 
network analyzer at a single relatively low CW measurement 
frequency.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the Instrument States

Follow the process described in “Instrument States for CW 
S-Parameter Measurements” on page 504.

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity.

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance
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The Inputs and Outputs

Select the QuasiSat_ac setup. 

• The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

• The Sweep Type for the vb base voltage is set to LIST.  Three 
values are defined, at low, medium, and high levels of the 
normal base operating range.

• The Sweep Type for vc collector voltage is set to LIST.  The 
values are selected based on the following criteria:

• Two data points in saturation: approximately 0V and just 
before the onset of quasi-saturation.

• One data point at the transition knee between saturation 
and quasi- saturation.

• Two data points in quasi-saturation: just past the onset of 
quasi-saturation and just before the onset of the active 
region.

• One data point at the transition knee between 
quasi-saturation and the active region.

• Two data points in the active region: one just past 
quasi-saturation and one before the onset of avalanche 
effects.

• The freq Sweep Type is set to CON for a single CW frequency. 
The value is typically in the range of approximately 100 to 
200 MHz. This is high enough for adequate measurement 
resolution, yet low enough to avoid series parasitic effects.

• The output is S-parameters (s).

Measuring and Plotting

1 From the Plots tab, select Display All.  Several plots are 
displayed.

2 Select Measure/Simulate > Measure. The plots displayed have 
already been converted to Y-parameters by one of the 
extraction routines. 

3 Save the measured data using File > Save As and a filename 
with the suffix .set.
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Making the quasi_sat QuasiSat_dc Measurement

This procedure makes a DC measurement of the device using 
the same bias values as the QuasiSat_ac measurement.  The 
resulting data is used with the QuasiSat_ac data to optimize the 
relevant parameters.

Parameters

The data from this measurement will be used to extract the 
following parameters (the same parameters as the data from 
QuasiSat_ac):

Defining the DC Source/Monitor Instrument State

Follow the same process you used in the Rc_active 
measurement.  Use the same settings.

The Inputs and Outputs

Select the QuasiSat_dc setup.

• The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

• The Sweep Type for the vb base voltage is set to LIST.  Three 
values are defined, at low, medium, and high levels of the 
normal base operating range.

• The Sweep Type for vc collector voltage is set to LIST.  The 
values are selected based on the following criteria:

• Two data points in saturation: approximately 0V and just 
before the onset of quasi-saturation.

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity.

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance
olume 2 507



508

9 VBIC Model
 

• One data point at the transition knee between saturation 
and quasi- saturation.

• Two data points in quasi-saturation: just past the onset of 
quasi-saturation and just before the onset of the active 
region.

• One data point at the transition knee between 
quasi-saturation and the active region.

• Two data points in the active region: one just past 
quasi-saturation and one before the onset of avalanche 
effects.

• The output is ic, collector current.

Measuring and Plotting

1 From the Plots tab, select Display Plot.  The Ic plot is 
displayed.

2 Select Measure/Simulate > Measure.

3 Save the file using File > Save As and a filename with the 
suffix .set.

Making the quasi_sat Ypads Measurement

This setup is used to measure an open dummy structure.  With 
the device disconnected, S-parameters are measured at the 
same CW frequency as in the QuasiSat_ac measurement.  The 
data is used to de-embed the device S-parameters.  

Parameters

No parameters are extracted from this data.

Defining the Instrument States

Follow the same process you used for the QuasiSat_ac 
measurement, described in “Instrument States for CW 
S-Parameter Measurements” on page 504.
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The Inputs and Outputs

1 Remove the test fixture from the measurement setup, or lift 
the probes of a probe station to present an open circuit.

2 In the quasi_sat DUT select the Ypads setup. 

•  No voltages are defined or required.

• The CW frequency defined in freq must be the same as you 
used in QuasiSat_ac.

• The output is S-parameters (s).

Measuring

1 Remove the device under test from the fixture, or lift the 
probes of a probe station to present an open circuit.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the sparm_cap Cbe Measurement

The sparm_cap DUT measurements are similar to the cap DUT 
measurements, except that network analyzer S-parameter 
measurements are used instead of CV or LCR meter 
measurements.  This can provide greater accuracy at higher 
frequencies.
NOTE You need only do one set of capacitance measurements, using either the 
cap setups and a CV meter, or the sparm_cap setups and a network 
analyzer.  You may find it more convenient to use the network analyzer, 
since it must be calibrated for other measurements anyway.
To effectively extract all three junction capacitances, and 
especially the  substrate-collector capacitance, the substrate 
should be brought up to the top surface of the device and 
connected to a probeable pad, in such a way that the emitter 
and substrate can be RF-shorted through the probe.  This 
provides a clean, clearly-defined collector-substrate path to the 
network analyzer ground, resulting in more accurate 
S-parameter measurements.  If all the parasitic capacitances are 
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properly de-embedded, any capacitance between the collector 
and the RF ground will be completely due to the substrate 
capacitance.

The sparm_cap Cbe setup measures the base-emitter junction 
capacitance.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the Instrument States

Follow the same process you used for the QuasiSat_ac 
measurement, described in “Instrument States for CW 
S-Parameter Measurements” on page 504. Use the same settings, 
except if you used a different frequency be sure to set the 
correct number for the cal set where the calibration is stored.

The Inputs and Outputs

From the sparm_cap DUT, select the Cbe setup.

• The vb values are set to sweep the base voltage from 
approximately VBEmax to 0.5V.

• The vc collector voltage is set to ground (0.0V).

• The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

CJE Base-emitter zero-bias capacitance

PE Base-emitter built-in potential

ME Base-emitter grading coefficient
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• The measurement frequency freq value is a balance 
between two constraints: the lower the frequency the 
smaller the series parasitics; at the same time, the higher 
the frequency the smaller the capacitance value the 
network analyzer can resolve. Typically the frequency 
should be in the range of approximately 100 to 200 MHz. 
Be sure you have stored a network analyzer CW 
calibration at the frequency you choose.

• The output is S-parameters (s).

Measuring and Plotting

1 Make sure the device under test is reconnected in a 
measurement configuration.

2 From the Plots tab, select Display Plot.  The Cbe_Vbe plot is 
displayed.

3 Select Measure/Simulate > Measure.

4 Save the data using File > Save As and a filename with the 
suffix .set.

Making the sparm_cap Cbc_Csc Measurement

This procedure measures the base-collector and 
substrate-collector junction capacitances with the network 
analyzer.

Parameters

The data from this measurement will be used to extract these 
parameters:

CJC Base-collector intrinsic zero-bias capacitance

PC Base-collector built-in potential

MC Base-collector grading coefficient

CJCP Substrate-collector zero-bias capacitance

PS Substrate-collector built-in potential

MS Substrate-collector grading coefficient
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Defining the Instrument States

Follow the same process you used in the sparm_cap Cbe 
measurement.  Use the same settings.

The Inputs and Outputs

Select the Cbc_Csc setup.

• The vc values are set to sweep the collector voltage from 
approximately  −0.5V to VBCmax (7.5V).

• The vb base voltage is set to ground (0.0V).

• The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

• The freq input must be set to the same CW frequency as in 
the Cbe measurement.

• The output is S-parameters (s).

Measuring and Plotting

1 From the Plots tab, select Display All.  Two plots are displayed.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the sparm_cap Cpads Measurement

This setup is used to measure an open dummy structure with 
the network analyzer.  With the device disconnected, 
S-parameters are measured at the same CW frequency as in the 
other sparm_cap measurements.  The data is used to de-embed 
the device S-parameters.

Parameters

No parameters are extracted from this data.

Defining the Instrument States

Follow the same process you used in the sparm_cap Cbe 
measurement.  Use the same settings.
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The Inputs and Outputs

From the sparm_cap DUT, select the Cpads setup. 

• No voltages are defined or required.

• The CW frequency defined in freq must be the same as you 
used in the other sparm_cap measurements.

• The output is S-parameters (s).

Measuring 

1 Remove the test fixture from the measurement setup, or lift 
the probes of a probe station to present an open circuit.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.

Making the delay Ftvsic Measurement

This procedure determines the Ft of the device from 
bias-dependent S-parameters measured with the device in the 
common-emitter configuration.  The S-parameters are 
measured at a single frequency as a function of Vbe and Vce.  
Typically two sets of curves are generated, one for each 
collector voltage value.  The base-emitter voltage is swept over a 
very broad range.

Parameters

The data from this measurement will be used to extract these 
parameters:

TF Forward transit time

XTF Coefficient of TF bias dependence

ITF Coefficient of TF dependence on Ic

VTF Coefficient of TF dependence on Vbc

QTF Variation of TF with base-width modulation
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Defining the Instrument States

Follow the same process you used for the QuasiSat_ac 
measurement, described in “Instrument States for CW 
S-Parameter Measurements” on page 504. Use the same settings, 
except if you are using a different frequency be sure to set the 
correct number for the cal set where the calibration is stored.

The Inputs and Outputs

1 Make sure the device under test is reconnected in a 
measurement configuration.

2 From the delay DUT, select the Ftvsic setup. 

•  The ve emitter voltage is set to ground (0.0V).

• The vs substrate voltage is set to ground (0.0V).

• The vb values are set to sweep the base voltage from a 
value where the depletion charge dominates 
(approximately 0.65V), to a value large enough that the 
decrease in Ft due to high-level injection effects is present 
(approximately 0.9V).

• The vc collector voltage is usually swept from 1V to 
approximately 3−5V.  If the collector voltage values are set 
too high, thermal problems begin to dominate the 
measurements and may cause thermal runaway.  It is not 
uncommon for thermal runaway to occur even at medium 
voltages. 

• The freq frequency should be a value in the 20 dB/decade 
region, between F3dB and Ft. It must be a calibrated 
frequency.

• The outputs are s, S-parameters; and ic, collector current.

Measuring and Plotting

1 Make sure the device under test is reconnected in a 
measurement configuration.

2 From the Plots tab, select Display All.  Several plots are 
displayed.

3 Select Measure/Simulate > Measure.
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4 Save the data using File > Save As and a filename with the 
suffix .set.

Making the delay Forward_Tau Measurement

This procedure measures the device S-parameters, which will 
be converted (after de-embedding) to H-parameters in the 
extraction process.  Transforms will separate the H-parameter 
data to isolate the regions where the effects of specific 
parameters are greatest.  This information is detailed in the 
parameter extraction section later in this chapter.

The measurement uses as few data points as possible to speed 
up the subsequent optimization.  The input values for the base 
voltage and collector voltage are set in stepped mode.

It may be necessary to modify the measurement input bias 
values after the extraction results are seen, then perform the 
measurement and extraction again.

Parameters

The data from this measurement will be used to extract these 
parameters:

Defining the Instrument States

Follow the same process you used in the Ftvsic measurement.  
Use the same settings.

The Inputs and Outputs

Select the Forward_Tau setup.

TF Forward transit time

XTF Coefficient of TF bias dependence

ITF Coefficient of TF dependence on Ic

VTF Coefficient of TF dependence on Vbc

QTF Variation of TF  with base-width modulation

QCO Epi charge parameter
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•  The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

• The freq value should be a frequency approximately 100 to 
200 MHz. This is high enough for adequate measurement 
resolution, yet low enough to avoid series parasitic effects.

• The Sweep Type for the vb base voltage is set to LIST.  A few 
measurement values of interest should be set, between 
approximately 0.65V and 0.9V.  These correspond to the 
sweep range of the base voltage in the Ftvsic measurement.

• The Sweep Type for the vc collector voltage is set to LIST.  
Values are set to step from approximately 1V to 
approximately 3−5V, in as few as two steps.  The values 
correspond to the sweep range of the collector voltage in the 
Ftvsic measurement.

• The outputs are S-parameters (s).

Measuring and Plotting

The plots are of H-parameters, and will probably be of more 
interest in the extraction process.  However, the illustration 
shows the plot of H21 magnitude. 
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1 Select Measure/Simulate > Measure.

2 Save the data using File > Save As and a filename with the 
suffix .set.  

Making the delay Reverse_Tau Measurement

This procedure measures small signal parameters of the device 
with the base-collector junction forward biased.  With this bias, 
the effects of the base-collector diffusion capacitance, the 
epilayer charge, and the forward knee current of the parasitic 
PNP are all large enough to be discernible from the measured 
small signal data using optimization.

Parameters

The data from this measurement will be used to extract these 
parameters:

Figure 171 Example Plotted Forward_Tau magH21 Data

TR Reverse transit time

QCO Epi charge parameter
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Defining the Instrument States

Follow the same process you used in the Ftvsic measurement.  
Use the same settings.

The Inputs and Outputs

Select the Reverse_Tau setup. 

• The vs substrate voltage is set to ground (0.0V).

• The ve emitter voltage is set to ground (0.0V).

• The vc collector voltage is set to ground (0.0V).

• The vb base voltage is set to sweep over a range from low to 
high, for example from 0.65V to 0.75V, using three to five 
measurement points to cover the range.

• freq is set to the same value as in Forward_Tau.

• The outputs are S-parameters (s).

Measuring and Plotting

1 Select Measure/Simulate > Measure.

2 Save the data using File > Save As and a filename with the 
suffix .set.

Making the delay Ypads Measurement

This setup is used to measure an open dummy structure.  With 
the device disconnected, S-parameters are measured at the 
same CW frequency as in the other delay measurements.  The 
data is used to de-embed the device S-parameters. 

Parameters

No parameters are extracted from this data.

IKP Parasitic knee current.  Zero represents 
infinity.
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Defining the Instrument States

Follow the same process you used in the Ftvsic measurement.  
Use the same settings.

The Inputs and Outputs

From the delay DUT, select the Ypads setup.

• No voltages are defined or required.

• The CW frequency defined in freq must be the same as you 
used in the other delay measurements.

• The output is S-parameters (s).

Measuring

1 Remove the test fixture from the measurement setup, or lift 
the probes of a probe station to present an open circuit.

2 Select Measure/Simulate > Measure.

3 Save the data using File > Save As and a filename with the 
suffix .set.
Parameter Extractions
When the measurements are finished and you have a complete 
set of measured data for a particular device, you can begin the 
extractions.
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Displaying the Parameters Table

1 Click the Model Parameters tab.  The table of model 
parameters is displayed, with their current values.  A portion 
of the table is illustrated.

The Parameters table lists all the parameters that will be 
extracted. It initially displays default values. As you perform 
the extraction macros, the default values change to extracted 
values. Throughout the extraction process, you can use the 
Parameters table to read extracted values.

2 To save the Parameters table after your device parameters 
are extracted, select File > Save As. 

Figure 172 Top Portion of the Model Parameters Table
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3 In the dialog box, select the File Type .mps for model 
parameter set.

4 Type a filename or use the default name in the File Name 
box.

5 Click OK.

You can now recall the same set of device parameters any time 
you wish.

Device Input Variable Values

Before the model is run, it is necessary to set values for 
some of the model variables.  Model variables are used in 
different places throughout the model.  Other variables that 
will be set later in the procedures are DUT variables, which 
apply to all the setups within a particular DUT, and setup 
variables, which apply to one particular setup.

Also, some of these variables will be set using the Init_Parms 
macro.

• To open the model variable table, click the Model Variables 
tab.
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You need not set most of the values in the variable table.  
Some of these (for example SIMULATOR: mns) are default 
values that should not be changed.  Some will be set 
automatically by the extraction macros.

VBIC_ERROR_TOL The default is 1E−6.  This is used by the 
internal DC and AC solvers to set the minimum allowable 
solver error.  The smaller the value the more accurate the 
solution, but the slower the simulation. 

VBIC_AUTO_RANGE is set in the Init_Parms macro, and 
described there.

Figure 173 The Model Variable Table
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VBIC_AUTO_SMOOTH is used in conjunction with 
VBIC_AUTO_RANGE (described under Init_Parms on the 
next page).  If it is set to 1 the measured data determined by 
VBIC_AUTO_RANGE is smoothed before analysis. The 
smoothing algorithm returns the average of the current 
point, the next point, and the previous point in the data 
array. This is helpful if the measured data is noisy.

SPARM_CAP is set in the Init_Parms macro, and described 
there.

PLOT is set in the Init_Parms macro, and described there.

VBIC_NUM_ITER The default is 500.  This variable  is used 
by the internal DC and AC solvers to set the maximum 
number of iterations the solvers will perform.  If the number 
of iterations reaches the value set by this variable and the 
error is still larger than the number specified by 
VBIC_ERROR_TOL, the solver will stop and display an error 
message.  Note that the smaller VBIC_ERROR_TOL is, the 
more likely the solver will be unable to converge to a stable 
solution.  

VBIC_AUTO_LIMIT The default is 0.9.  The smaller the 
number, the tighter the limit used for auto ranging.  If it is 
determined that the autoranging algorithm is incorporating 
too much high-level effect in its IS and NF extraction and 
simulation, the value of VBIC_AUTO_LIMIT can be made 
slightly larger than 0.9.  Or if not enough log-linear region is 
being specified VBIC_AUTO_LIMIT can be made slightly 
smaller than 0.9.

Saving the Variable Table

You can store the variable table if you choose:

1 Select File > Save As.

2 In the dialog box, select the File Type .vat for variable table.  
Type in a filename or use the one in the File Name box.  
Select OK.

You can now recall the same set of variable values any time you 
wish to extract a similar device.
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Initializing Device Parameters

Several device parameters need to be entered into the software 
before the extractions are begun.  These include the length and 
width of the device, and certain process and geometry 
parameters.  They also include certain model variables that 
were mentioned under “Device Input Variable Values” in the last 
few pages.  More detailed descriptions are given here.  
(Infrequently used model variables are not set in the Init_Parms 
macro.)

The Init_Parms Macro

This macro is used to enter the required parameters.  The more 
information you provide in this macro, the better the extraction 
will be.

1 Click the macros tab, and a list of macros is displayed.

2 In the Select Macro list, select Init_Parms.  Then select Execute. 
A series of dialog boxes is displayed, asking you to input 
appropriate values for your device under test. The values you 
need to provide (and their units of measure) include:

• epi dope (cm−3)

• maximum base dope (cm−3)

• emitter width (um)

• emitter length (um)

• epi layer thickness (um)

• extraction temperature (degrees C)

• number of base fingers (#)

3 You are then prompted to perform the capacitance 
measurements with network analysis.  

• If you choose y the model variable SPARM_CAP is set to 1, 
and all capacitance extractions are performed using 
network analyzer measurements from the sparm_cap DUT.  

• If you choose n the variable SPARM_CAP is set to 0 and all 
capacitance extractions are performed using the CV 
measurements from the cap DUT.
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4 If you want the plots to be displayed during extraction, 
choose y.  The model variable PLOT will be set to 1.  If not, 
choose n and the variable PLOT will be set to 0.

5 If you want the extractions to use automatic data selection, 
choose y.  The model variable VBIC_AUTO_RANGE will be set 
to 1.  If not, choose n and it will be set to 0.  When 
VBIC_AUTO_RANGE is set to 1,  the autorange algorithm is 
turned on.  This algorithm evaluates the measured data to 
determine the valid range for a given extraction transform, 
based on the parameter field specified in the transform. The 
auto range typically works by looking at the 1st and 2nd 
derivatives of a measured current. When the derivatives 
deviate from the value set by VBIC_AUTO_LIMIT, the output 
of the function is set to 0.

The Automated Macros

Macros automate the modeling procedure so that parameter 
extraction and optimization can be performed with minimal 
user intervention.

The fastest and easiest way to perform the extractions is to use 
the Do_all macro (described below).  Otherwise, the macros can 
be executed separately, each extracting a subset of model 
parameters.

The macros call the transforms necessary to extract the relevant 
parameters.  If the model variable PLOT is set to 1, the 
applicable plot or plots are displayed.  If the model variable 
VBIC_AUTO_RANGE is set to 1, the extractions use automatic 
data selection.

To run a macro, select the macro name and Execute.

Init_Parms This macro sets an initial set of parameter values 
based on device-specific physical data.  Note it is not essential 
that the device or process information be known exactly: 
however, setting initial values, even if estimated, improves the 
extraction process.  This macro also sets the commonly-used 
model variables SPARM_CAP, PLOT, and VBIC_AUTO_RANGE.
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Do_all Executes a complete extraction of the VBIC parameters 
by calling the other macros in the appropriate order.

Cbe Calls the transforms used to extract the base-emitter 
junction capacitance parameters.  If the variable SPARM_CAPS 
= 1 the sparm_caps (network analyzer measurement) data is 
used.  Otherwise the cap (CV meter measurement) data is used.

Cbc Calls the transforms used to extract the base-collector 
junction capacitance parameters.  If SPARM_CAPS = 1 the 
sparm_caps  data is used.  Otherwise the cap data is used.

Csc Calls the transforms used to extract the 
substrate-collector junction capacitance parameters.  If 
SPARM_CAPS = 1 the sparm_caps data is used.  Otherwise the 
cap data is used.

Re Calls the transforms used to extract the emitter series 
resistance parameter RE.

Rcx Calls the transforms used to extract the extrinsic collector 
resistance parameter RCX.

Early Calls the transforms used to extract VEF and VER, and 
partitions the total base-collector capacitance between the 
intrinsic (CJC) and extrinsic (CJEP) portions of the device.

Aval Calls the transforms used to extract the avalanche 
parameters AVC1 and AVC2.

Forward Calls the transforms used to extract the parameters 
IS, NF, IBEI, NEI, IBEN, and NEN.

Reverse Calls the transforms used to extract the parameters 
NR, IBCI, NCI, IBCN, NCN, ISP, NFP, and IKR.

Rbb Calls the transforms used to extract the parameters RBX, 
RBI, and WBE.
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Misc Calls the transforms used to extract the parameters TR, 
QCO, and IKP.

QuasiSat Calls the transforms used to extract the parameters 
IKF, RCI, RCX, GAMM, VO, HRCF, and QCO.

Delay Calls the transforms used to extract the parameters TF, 
QTF, VTF, XTF, ITF, and QCO.

The Transforms

The individual transforms that are called by the macros are 
described in the following pages.  They are grouped according to 
the setups in which they occur.

To see the transforms, select the setup of interest from the 
DUT/Setup panel, then click on the Extract/Optimize tab.  A list of 
the transforms for that setup is displayed.  Click on the name of 
a transform to see its function and description.

To run an individual transform (though you will seldom need 
to), select Execute.

Transforms in the Cbe Setup

The parameters extracted are:

The transforms are:

CJE Base-emitter zero-bias depletion capacitance

PE Base-emitter built-in potential

ME Base-emitter grading coefficient

extr_CJE The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion capacitance 
given vbe and cbe.m.

cbe_calc The function is VBIC_cbe.  The transform 
calculates the depletion capacitance vs bias 
given vbe.
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Transforms in the Cbc Setup

The parameters extracted are:

The transforms are:

Transforms in the Csc Setup

The parameters extracted are:

opt_CJE_PE_MEOptimization.  This optimizes the simulated 
value cbe_calc to obtain the final value for 
cbe.m.  The optimization is performed over the 
full range of the measurement.  All three 
parameters are optimized.

CJC Base-collector intrinsic zero-bias depletion 
capacitance

PC Base-collector built-in potential

MC Base-collector grading coefficient

extr_CJC The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion capacitance 
given vbc and cbc.m.

cbc_calc The function is VBIC_cbc.  The transform 
calculates the depletion capacitance vs bias 
given vbc.

opt_CJC_PC_MC Optimization.  This optimizes the simulated 
value cbc_calc to obtain the final value for 
cbc.m.  The optimization is performed over the 
full range of the measurement.  All three 
parameters are optimized.

CJCP Substrate-collector zero-bias depletion 
capacitance

PS Substrate-collector built-in potential
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The transforms are:

Transforms in the Rc_active Setup

The parameter extracted is:

The transforms are:

MS Substrate-collector grading coefficient

extr_CJCP The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion capacitance 
given vsc and csc.m.

csc_calc The function is VBIC_csc.  The transform 
calculates the depletion capacitance vs bias 
given vsc.

opt_CJCP_PS_MS Optimization.  This optimizes the simulated 
value csc_calc to obtain the final value for 
csc.m.  The optimization is performed over 
the full range of the measurement.  All three 
parameters are optimized.

RCX Extrinsic collector resistance

extr_RCX This transform calculates RCX based on 
Berkner’s method.  This uses the fact that the 
substrate increases with an increasing voltage 
drop across the constant portion of the 
collector resistor when the device is in either 
quasi-saturation or saturation.  Because the 
noise level of the substrate current is often 
quite high, the dynamic range of this method 
may not always be sufficient to resolve the 
bias-independent collector resistance 
adequately.  An additional extraction is 
performed in the Rc_flyback setup.
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The vertical line on the trace is caused by the automatic data 
selection algorithm in the transform (called by the 
VBIC_AUTO_RANGE variable), which chops off the non-valid 
noisy data at the low end of the trace.  RCX is the maximum 
point of the trace.

This method is described in detail in A Survey of DC Methods 
for Determining the Series Resistance of Bipolar Transistors 
Including the New Delta ISub Method (see Bibliography).

Transforms in the Re_flyback Setup

The parameter extracted is:

The transforms are:

Figure 174 Plotted Results of the extr_RCX Transform

RE Emitter resistance

extr_RE Calculates RE given ib and vc.m.
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Transforms in the Rc_flyback Setup

The parameter extracted is :

The transforms are:

Transforms in the Rbb Setup

The parameters extracted are:

The transforms are:

RCX Extrinsic collector resistance

extr_RCX Calculates RCX given ib and ve.m.

RBX Extrinsic base resistance

RBI Intrinsic base resistance

WBE The portion of IBEI from Vbei, 1−WBE from 
vbex.

S_calc The function is VBIC_ac_solver.  This solves for 
the S-parameters, given the four terminal 
voltages.

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the Ypads 
setup from the S-parameters measured in this 
Rbb setup: that is, it removes the parasitic 
capacitance of the pads.  The output of this 
transform should be used for all subsequent 
extractions and optimizations in this setup.
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Transforms in the parasitic Ypads Setup

No parameters are extracted.  The measured data is used to 
de-embed the device S-parameters.

The transforms are:

Transforms in the Rev_early Setup

The parameters extracted are:

opt_RBX_RBI_
WBE

Optimization.  This optimizes the de-embedded 
S-parameters to obtain the value s.m.  The input 
to this transform is deembed_S.m, the 
S-parameter data de-embedded by the 
transform deembed_S.  The optimization is 
performed over the full range of the 
measurement.  All three parameters are 
optimized.

s2y The function is TwoPort.  The transform 
converts the measured S-parameters to 
Y-parameters.

c11 This is a program that takes the output from the 
transform s2y and extracts the input 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c12 This is a program that takes the output from the 
transform s2y and extracts the crossover 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c22 This is a program that takes the output from the 
transform s2y and extracts the output 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

CJE Base-emitter zero-bias capacitance

WBE Portion of IBEI from Vbei, 1−WBE from Vbex
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The transforms are:

Transforms in the Fwd_early Setup

The parameters extracted are:

The transforms are:

QB0 Model variable used to determine initial 
parameter values

ie_calc The function is VBIC_dcv_solver.  The 
transform calculates ie, given the four terminal 
voltages.

ib_calc The function is VBIC_dcv_solver.  The 
transform calculates ib, given the four terminal 
voltages.

extr_qb0 This is a program that calculates the initial 
value of QB0 based on a combination of 
measured data (ie.m and vbe) and extracted 
parameters (CJE and WBE).  Therefore these 
parameters and variable must be determined 
first.  The model variable QB0 is only used in 
the Init_Parms macro to determine initial 
parameter values.

VEF Forward early voltage.  Zero represents infinity

VER Reverse early voltage.  Zero represents infinity

AVC1 Base-collector weak avalanche parameter 1

AVC2 Base-collector weak avalanche parameter 2

CJC Intrinsic base-collector zero-bias capacitance

CJEP Base-collector extrinsic zero-bias capacitance
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If the model variable VBIC_AUTO_RANGE is turned on (set to 
1), the transform requires an additional input, ib (base current).  
The base current is used to monitor avalanche breakdown: once 
avalanche breakdown begins all subsequent data is ignored by 
the transform.

ic_calc The function is VBIC_dcv_solver.  The 
transform calculates ic, given the four terminal 
voltages.

ib_calc The function is VBIC_dcv_solver.  The 
transform calculates ib, given the four terminal 
voltages.

extr_AVC1 The function is VBIC_avc.  The transform 
calculates AVC1 based on the model parameter 
PC.  The calculation is based on the original 
Mextram formulation described in (2) 
(Bibliography).  The VBIC parameter AVC1 is 
equivalent to a constant in the Mextram model:

where:

a = 7.05E05 cm-1b = 2.04E06 V/cm for PNP

b = 1.23E06 V/cm for NPN 1.58E06 cm-1

Pc = b−c grading coefficient

extr_VEF_VER The function is VBIC_vef_ver. The transform 
calculates the forward and reverse early 
voltages, given the collector, base, and emitter 
voltages in the forward and reverse modes, as 
well as the collector current in the forward 
mode and the emitter current in the reverse 
mode. This calculation is based on the method 
described in “Spice Early Model. McAndrew 
and Nagel. IEEE 1994 BCTM.” on page 561.

AVC1 A=( )
b 1 Pc–( )-------------------------------
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The vertical line is caused by the automatic data selection 
algorithm called by VBIC_AUTO_RANGE.  The data below the 
vertical line is invalid for the extraction. 

Transforms in the gummel Forward Setup

The parameters extracted are:

Figure 175 Plotted Fwd_early Data Showing Auto-Range Limits

opt_AVC1_AVC2 Optimization.  This optimizes ib_calc to obtain 
the value ib.m.  The optimization is performed 
over the full range of the measurement.   The 
parameters optimized are the base-collector 
weak avalanche parameters AVC1 and AVC2. 

VBIC_CJEP_CJC This is a program that partitions the total CJC 
into the intrinsic (CJC) and extrinsic (CJEP) 
capacitances, based on the 1−D intrinsic 
equality 

J = CJCint*VEF.
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The transforms are:

The vertical line on the trace is caused by the automatic data 
selection algorithm called by VBIC_AUTO_RANGE.  The 
high-level injection effects above the vertical line are invalid for 
the extraction.

IS Transport saturation current

NF Forward emission coefficient

IBEI Ideal base-emitter saturation current

NEI Ideal base-emitter emission coefficient

IBEN Non-ideal base-emitter saturation current

NEN Non-ideal base-emitter emission coefficient

ic_calc The function is VBIC_dcv_solver.  The 
transform calculates ic, given the four terminal 
voltages.

ib_calc The function is VBIC_dcv_solver.  The 
transform calculates ib, given the four terminal 
voltages.

is_calc The function is VBIC_dcv_solver.  The 
transform calculates is, given the four terminal 
voltages.

ic_nf The function is VBIC_fg_currents.  The transform calculates 
ic over the region dominated by NF, given the four terminal 
voltages.  This transform requires the measured inputs ic.m 
and ib.m.  It also requires that the model variable 
VBIC_AUTO_RANGE is set to 1, and that the parameter NF is 
entered in the parameter field.  Otherwise the simulation will 
be performed over the entire measurement range.
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Figure 176 Plotted ic Data Showing Auto Range Limits

Figure 177 Plotted ib Data Showing Auto Range Limits
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ib_nei The function is VBIC_fg_currents.  The 
transform calculates ib over the region 
dominated by NEI, given the four terminal 
voltages.  This transform requires the measured 
inputs ic.m and ib.m.  It also requires that the 
model variable VBIC_AUTO_RANGE is set to 1, 
and that the parameter NEI is entered in the 
parameter field.  Otherwise the simulation will 
be performed over the entire measurement 
range. 

beta_nen The function is VBIC_fg_currents.  The 
transform calculates beta over the region 
dominated by NEN, given the four terminal 
voltages.  This transform requires the measured 
inputs ic.m and ib.m.  It also requires that the 
model variable VBIC_AUTO_RANGE is set to 1, 
and that the parameter NEN is entered in the 
parameter field.  Otherwise the simulation will 
be performed over the entire measurement 
range.

extr_IS_NF The function is VBIC_is_nf.  The transform 
calculates the parameters IS and NF based on 
the method described in (3) (Bibliography).  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used for 
calculating IS and NF to the log-linear region of 
the collector current.

extr_IBEI_NEI The function is VBIC_ibei_nei.  The transform 
calculates the parameters IBEI and NEI.  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used: 
the limits are from above where the low-level 
effects dominate up to the onset of 
high-injection effects.

opt_IBEN_NEN Optimization.  This optimizes the simulated 
value beta_nen to obtain the value beta.m.  The 
optimization is performed over the full range of 
the measurement.
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Transforms in the gummel Reverse Setup

The parameters extracted are:

The transforms are:

opt_IS_NF Optimization.  This optimizes the simulated 
value log(ic_nf) to obtain the value log(ic.m).  
The optimization is performed over the full 
range of the measurement.

opt_IBEI_NEI Optimization.  This optimizes the simulated 
value log(ib_nei) to obtain the value log(ib.m).  
The optimization is over the full range of the 
measurement.

NR Reverse emission coefficient

IBCI Ideal base-collector saturation current

NCI Ideal base-collector emission coefficient

IBCN Non-ideal base-collector saturation current

NCN Non-ideal base-collector emission coefficient

ISP Parasitic transport saturation current

NFP Parasitic forward emission coefficient

IKR Reverse knee current.  Zero represents infinity.

ie_calc The function is VBIC_dcv_solver.  The 
transform calculates ie, given the four terminal 
voltages.

ib_calc The function is VBIC_dcv_solver.  The 
transform calculates ib, given the four terminal 
voltages.

is_calc The function is VBIC_dcv_solver.  The 
transform calculates is, given the four terminal 
voltages.
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ie_nr, is_ncn, 
beta_ncn, 
is_isp, ib_nci, 
is_nci, ie_ikr, 
ib_ncn

These transforms are used in subsequent 
optimizations.  They all require that the model 
variable VBIC_AUTO_RANGE is set to 1, and 
that the appropriate parameter is entered into 
the parameter field.  They also require the 
measured inputs ie.m, is.m, and ib.m+is.m.  
Otherwise the simulations will be performed 
over the entire measurement range.  

In the IB field of these transforms it is usually 
preferable to enter the sum ib.m+is.m.  The 
substrate current has an opposite polarity 
compared to the base current.  Therefore the 
contribution of the substrate current is 
removed from the base current by adding the 
two quantities.  The result is a better 
approximation of the true intrinsic base 
current.  If the parasitic PNP had an infinite 
beta, the approximation would be exact.

These transforms all use the function 
VBIC_rg_currents.

ie_nr Calculates ie over the region dominated by NR, 
given the four terminal voltages.  The vertical 
lines on the trace are caused by the automatic 
data selection algorithm called by 
VBIC_AUTO_RANGE.  Only the high-level 
injection effects above the vertical lines are 
valid for the extraction.
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Figure 178 Plotted ie Data Showing Auto Range Limits

is_ncn Calculates is over the region dominated by 
NCN, given the four terminal voltages.

beta_ncn Calculates beta over the region dominated by 
NCN, given the four terminal voltages.

is_isp Calculates is over the region dominated by ISP, 
given the four terminal voltages.

ib_nci Calculates ib over the region dominated by NCI 
given the four terminal voltages.
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Figure 179 Plotted ib Data Showing Auto Range Limits

is_nci Calculates is over the region dominated by NCI, 
given the four terminal voltages.

ie_ikr Calculates ie over the region dominated by IKR, 
given the four terminal voltages.

ib_ncn Calculates ib over the region dominated by 
NCN, given the four terminal voltages.

extr_NR The function is VBIC_nr.  The transform 
calculates the parameter NR based on the 
method described in (3) (Bibliography).  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used to 
calculate NR to the log-linear region of the 
emitter current.

extr_IBCI_NCI The function is VBIC_ibci_nci.  The transform 
calculates the parameters IBCI and NCI.  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used: 
the limits are from above where the low-level 
effects dominate, up to the onset of 
high-injection effects.
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Transforms in the Ic_Vce_Vb Setup

The parameters extracted are:

extr_ISP_NFP The function is VBIC_isp_nfp.  The transform 
calculates the parameters ISP and NFP.  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used to 
the log-linear region of the substrate current.

extr_IKR The function is VBIC_ikr.  The transform 
calculates the parameter NR based on the 
method described in (3) (Bibliography).  If 
VBIC_AUTO_RANGE is turned on, the 
transform automatically limits the data used to 
the log-linear region of the emitter current.

opt_IBCN_NCN Optimization.  This optimizes the simulated 
value beta_nen to obtain the value beta.m.  The 
optimization is performed over the full range of 
the measurement.

opt_NR Optimization.  This optimizes the simulated 
value log(ie_nr) to obtain the value log(ie.m).  
The optimization is performed over the full 
range of the measurement.

opt_IBCI_NCI Optimization.  This optimizes the simulated 
value log(ib_nci+is_nci) to obtain the value 
log(ib.m+is.m).  The optimization is performed 
over the full range of the measurement.

opt_ISP_NFP Optimization.  This optimizes the simulated 
value log(is_isp) to obtain the value log(is.m).  
The optimization is performed over the full 
range of the measurement.

opt_IKR Optimization.  This optimizes the simulated 
value log(ie_ikr) to obtain the value log(ie.m).  
The optimization is performed over the full 
range of the measurement.

beta Equation.  This calculates beta as ie/(ib + is).  To 
a first order, this equation removes the effects 
of the parasitic PNP from the beta calculation.
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The same parameters are extracted in the QuasiSat_ac and 
QuasiSat_dc setups.

The transforms are:

Transforms in the QuasiSat_ac Setup

The parameters extracted are:

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity.

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance

ic_calc The function is VBIC_dcv_solver.  The 
transform calculates ic, given the four terminal 
voltages.

opt_ALL Optimization.  This optimizes the simulated 
value log(ic_calc) to obtain the value log(ic.m).  
The optimization is performed over the full 
range of the measurement.  All the parameters 
are optimized (HRCF, VO, QCO, GAMM, IKF, 
RCI, and RCX).

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity.

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance
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The same parameters are extracted in the Ic_Vce_Vb setup and 
the QuasiSat_dc setup.

The transforms are:

s2y The function is TwoPort.  This transform 
converts the de-embedded S-parameters into 
Y-parameters.  The input to this transform is 
deembed_S.m, the S-parameters 
de-embedded by the transform deembed_S.

Y_calc The function is VBIC_ac_solver.  The 
transform solves for the Y-parameters, given 
the four terminal voltages.

deembed_S This program de-embeds the S-parameters 
from the setup.  It subtracts the dummy 
structure data measured in the quasi_sat 
Ypads setup from the S-parameters 
measured in this QuasiSat_ac setup: that is, 
it removes the parasitic capacitance of the 
pads.  The output of this transform should be 
used for all subsequent extractions and 
optimizations in this setup.

opt_IKF_RCI_RCX Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

log(QuasiSat_dc/ic_calc) log(QuasiSat_dc/ic.m)

real(Y_calc.12) real(s2y.m.12)

imag(Y_calc.12) imag(s2y.m.12)

real(Y_calc.22) real(s2y.m.22)

imag(Y_calc.22) imag(s2y.m.22)

The optimization is performed over the full 
range of the measurement.  The parameters 
optimized are IKF, RCI, and RCX.
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opt_GAMM_QCOOptimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

log(QuasiSat_dc/ic_calc) log(QuasiSat_dc/ic.m)

real(Y.calc.12) real(s2y.m.12)

imag(Y_calc.12) imag(s2y.m.12)

real(delay/Reverse_Tau_H/calc.
21) 

real(delay/Reverse_Tau/s2h.m.
21)

imag(delay/Reverse_Tau/H_cal
c.21) 

imag(delay/Reverse_Tau/s2h.m
.21)

The optimization is performed over the full 
range of the measurement.  The parameters 
optimized are GAMM and QCO.

opt_VO_HRCF Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

log(QuasiSat_dc/ic_calc) log(QuasiSat_dc/ic.m)

real(Y_calc.22) real(s2y.m.22)

imag(Y_calc.22) imag(s2y.m.22)

The optimization is performed over the full 
range of the measurement.  The parameters 
optimized are VO and HRCF.

opt_ALL Optimization.  This optimizes the simulated 
value ic_calc to obtain the final value for ic.m.  
The optimization is performed over the full 
range of the measurement.  All the parameters 
for this measurement are optimized.
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Transforms in the QuasiSat_dc Setup

The parameters extracted are:

The same parameters are extracted in the Ic_Vce_Vb setup.

The transforms are:

HRCF High-current RC factor

VO Epi drift saturation voltage

QCO Epi charge parameter

GAMM Epi doping parameter

IKF Forward knee current.  Zero represents infinity.

RCI Intrinsic collector resistance

RCX Extrinsic collector resistance

ic_calc The function is VBIC_dcv_solver.  The 
transform calculates ic, given the four terminal 
voltages.

opt_ALL Optimization.  This optimizes the simulated 
value log(ic_calc) to obtain the final value 
log(ic.m).  The optimization is performed over 
the full range of the measurement.  All the 
parameters listed above are optimized.

init_QS This is a program that performs an analytical 
calculation of an initial guess for the 
quasi-saturation parameters RCI, GAMM, VO, 
and QCO.  This is based on the equations of Kull 
(1985).  The calculation uses the following 
variables:

Nepi Epi doping concentration.

Wepi Epi layer thickness.

Le Emitter length.

He Emitter width.
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Transforms in the quasi_sat Ypads Setup

No parameters are extracted.  The measured data is used to 
de-embed the device S-parameters.

The transforms are:

Transforms in the sparm_cap Cbe Setup

The parameters extracted are:

The transforms are:

s2y The function is TwoPort.  The transform 
converts the measured S-parameters to 
Y-parameters.

c11 This is a program that takes the output from the 
transform s2y and extracts the input 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c12 This is a program that takes the output from the 
transform s2y and extracts the crossover 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c22 This is a program that takes the output from the 
transform s2y and extracts the output 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

CJE Base-emitter zero-bias capacitance

PE Base-emitter built-in potential

ME Base-emitter grading coefficient
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Transforms in the sparm_cap Cbc_Csc Setup

The parameters extracted are:

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the 
sparm_cap Cpads setup from the S-parameters 
measured in this Cbe setup: that is, it removes 
the parasitic capacitance of the pads.  The 
output of this transform should be used for all 
subsequent extractions and optimizations in 
this setup.

cbe The function is BJTCV_stoc.  The transform 
calculates the base-emitter capacitance, given 
the measurement frequency and the 
S-parameters.  The input to this transform is 
the S-parameter data de-embedded by the 
transform deembed_S.  The optimization is 
performed over the full range of the 
measurement.

extr_CJE The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion capacitance 
CJE, given vbe and cbe.m. 

cbe_calc The function is VBIC_cbe.  The transform 
calculates the depletion capacitance vs bias, 
given vbe.

opt_CJE_PE_MEOptimization.  This optimizes the simulated 
value cbe_calc to obtain the final value cbe.m.  
The optimization is performed over the full 
range of the measurement.

CJC Base-collector intrinsic zero-bias capacitance

PC Base-collector built-in potential

MC Base-collector grading coefficient

CJCP Substrate-collector zero-bias capacitance

PS Substrate-collector built-in potential
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The transforms are:

MS Substrate-collector grading coefficient

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the 
sparm_cap Cpads setup from the 
S-parameters measured in this Cbc_Csc 
setup: that is, it removes the parasitic 
capacitance of the pads.  The output of this 
transform should be used for all subsequent 
extractions and optimizations in this setup.

cbc The function is BJTCV_stoc.  The transform 
calculates the base-collector capacitance, 
given the measurement frequency and the 
S-parameters.  The input to this transform is 
the S-parameter data de-embedded by the 
transform deembed_S.  The optimization is 
performed over the full range of the 
measurement.

csc The function is BJTCV_stoc.  The transform 
calculates the substrate-collector 
capacitance, given the measurement 
frequency and the S-parameters.  The input to 
this transform is the S-parameter data 
de-embedded by the transform deembed_S.  
The optimization is performed over the full 
range of the measurement.

extr_CJC The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion 
capacitance, given vbc and cbc.m.

cbc_calc The function is VBIC_cbc.  The transform 
calculates the depletion capacitance vs bias, 
given vbc.
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Transforms in the sparm_cap Cpads Setup

No parameters are extracted.  The measured data is used to 
de-embed the device S-parameters.

The transforms are:

opt_CJC_PC_MC Optimization.  This optimizes the simulated 
value cbc_calc to obtain the final value cbc.m.  
The optimization is performed over the full 
range of the measurement.

extr_CJCP The function is VBIC_cj0.  The transform 
calculates the zero-bias depletion capacitance 
CJCP, given vsc and csc.m.

csc_calc The function is VBIC_csc.  The transform 
calculates the depletion capacitance vs bias, 
given vsc.

opt_CJCP_PS_MS Optimization.  This optimizes the simulated 
value csc_calc to obtain the final value csc.m.  
The optimization is performed over the full 
range of the measurement.

s2y The function is TwoPort.  The transform 
converts the measured S-parameters to 
Y-parameters.

c11 This is a program that takes the output from the 
transform s2y and extracts the input 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c12 This is a program that takes the output from the 
transform s2y and extracts the crossover 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c22 This is a program that takes the output from the 
transform s2y and extracts the output 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.
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Transforms in the Ftvsic Setup

In this setup, the Ft of the device is determined from 
bias-dependent S-parameters measured in the common-emitter 
configuration.  The S-parameters are measured at a single 
frequency as a function of Vbe and Vce.

The parameters extracted are:

The transforms are:

TF Forward transit time

XTF Coefficient of TF bias dependence

ITF Coefficient of TF dependence on Ic

VTF Coefficient of TF dependence on Vbc

QTF Variation of TF with base-width modulation

QCO Epi charge parameter

ic_calc The function is VBIC_dcv_solver.  The 
transform calculates ic, given the four terminal 
voltages.

s2h The function is TwoPort.  The transform 
converts the de-embedded S-parameters to 
H-parameters.

Ft_calc The function is VBIC_ac_solver.  The transform 
solves for the Ft of the device, given the four 
terminal voltages.

H_calc The function is VBIC_ac_solver.  The transform 
solves for the H-parameters, given the four 
terminal voltages.

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the delay 
Ypads setup: that is, it removes the parasitic 
capacitance of the pads.  The output of this 
transform should be used for all subsequent 
extractions and optimizations in this setup.
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Transforms in the Forward_Tau Setup

The parameters extracted are:

This setup uses the standard H21 measurements, but divides 
the measurement data into the specific regions where the effect 
(sensitivity) of different parameters is greatest.  The regions for 
optimization are as follows:

Ft Equation.  This calculates Ft based on the 
measured data freq*mag(H21).  The equation 
assumes operation in the single-pole roll-off 
region (20 db/decade).

init_Delay This is a program that performs an analytical 
calculation of initial guesses for the delay 
parameters TF, XTF, ITF, VTF, and QTF.

TF Forward transit time

XTF Coefficient of TF bias dependence

ITF Coefficient of TF dependence on Ic

VTF Coefficient of TF dependence on Vbc

QTF Variation of TF with base-width modulation

QCO Epi charge parameter

TF High Vce; Vbe range from low to just before 
peak Ft

ITF High Vce; Vbe range from just past peak Ft to a 
high value

XTF Any value Vce; Vbe from just after peak Ft to a 
high value

VTF Any value Vce; Vbe from just after peak Ft to a 
high value

QTF Any value Vce; Vbe medium (including peak Ft 
value)
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For this purpose, several PEL transforms are used within the 
main transforms: TF_Hparm, QTF_Hparm, ITF_Hparm, 
VTF_Hparm, XTF_Hparm, and QCO_Hparm.  As few data points 
as possible are used to speed up optimization.  Each 
optimization point uses the approximation of the last to assist 
in converging to a minimum value.  The bias values and 
subsequently the i, k, and l specified values in the transforms 
will probably need to be modified for the particular device being 
characterized.

The transforms are:

s2h The function is TwoPort.  The transform 
converts the de-embedded S-parameters to 
H-parameters.

H_calc The function is VBIC_ac_solver.  The transform 
solves for the H-parameters, given the four 
terminal voltages.

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the delay 
Ypads setup: that is, it removes the parasitic 
capacitance of the pads.  The output of this 
transform should be used for all subsequent 
extractions and optimizations in this setup.

opt_TF_QTF Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

mag(TF_Hparm.s.21) mag(TF_Hparm.m.21)

ph(TF_Hparm.s.21) ph(TF_Hparm.m.21)

mag(QTF_Hparm.s.21) mag(QTF_Hparm.m.21)

ph(QTF_Hparm.s.21) ph(QTF_Hparm.m.21)

opt_TF Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values.
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Transforms in the Reverse_Tau Setup

The purpose of this setup is to measure the small signal 
parameters of the device with the base-collector junction 
forward biased.  Under this bias, the effects of the base-collector 
diffusion capacitance (TR), epilayer charge (QCO), and forward 
knee current of the parasitic PNP (IKP) are all large enough to 
be discernible from the measured small signal data through 
optimization.

The parameters extracted are:

mag(TF_Hparm.s.21) mag(TF_Hparm.m.21)

ph(TF_Hparm.s.21) ph(TF_Hparm.m.21)

opt_QTF_XTF_VTF_ITF_QCO Optimization.  This optimizes 
the following simulated values 
to obtain the corresponding 
listed final values:

mag(QTF_Hparm.s.21) mag(QTF_Hparm.m.21)

ph(QTF_Hparm.s.21) ph(QTF_Hparm.m.21)

mag(XTF_Hparm.s.21) mag(XTF_Hparm.m.21

ph(XTF_Hparm.s.21) ph(XTF_Hparm.m.21)

mag(VTF_Hparm.s.21) mag(VTF_Hparm.m.21)

ph(VTF_Hparm.s.21) ph(VTF_Hparm.m.21)

mag(ITF_Hparm.s.21) mag(ITF_Hparm.m.21)

ph(ITF_Hparm.s.21) ph(ITF_Hparm.m.21)

mag(QCO_Hparm.s.21) mag(QCO_Hparm.m.21)

ph(QCO_Hparm.s.21) ph(QCO_Hparm.m.21)

TR Base-collector diffusion capacitance (reverse 
transit time)

QCO Epi charge parameter
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The transforms are:

IKP Parasitic knee current.  Zero represents 
infinity.

s2h The function is TwoPort.  The transform 
converts the de-embedded S-parameters to 
H-parameters.

H_calc The function is VBIC_ac_solver.  The transform 
solves for the H-parameters, given the four 
terminal voltages.

deembed_S This is a program that de-embeds the 
S-parameters from the setup.  It subtracts the 
dummy structure data measured in the delay 
Ypads setup: that is, it removes the parasitic 
capacitance of the pads.  The output of this 
transform should be used for all subsequent 
extractions and optimizations in this setup.

opt_TR_QCO Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

real(H_calc.21) real(s2h.m.21)

imag(H_calc.21) imag(s2h.m.21)

The optimization is performed over the full 
measurement range

opt_IKP Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

real(H_calc.11) real(s2h.m.11)

imag(H_calc.11) imag(s2h.m.11)
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The optimization is performed over the full measurement range.

The optimization is performed over the full 
measurement range

opt_TR_QCO_IKP Optimization.  This optimizes the following 
simulated values to obtain the corresponding 
listed final values:

real(H_calc.11) real(s2h.m.11)

imag(H_calc.11) imag(s2h.m.11)

real(H_calc.21) real(s2h.m.21)

imag(H_calc.21) imag(s2h.m.21)

Figure 180 Example Plotted Reverse_Tau magH11 Data
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Figure 181 Example Plotted Reverse_Tau PhH11 Data

Figure 182 Example Plotted Reverse_Tau magH21 Data
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Transforms in the delay Ypads Setup

No parameters are extracted.  The measured data is used to 
de-embed the device S-parameters.

The transforms are:

Figure 183 Example Plotted Reverse_Tau phH21 Data

s2y The function is TwoPort.  The transform 
converts the measured S-parameters to 
Y-parameters.

c11 This is a program that takes the output from the 
transform s2y and extracts the input 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c12 This is a program that takes the output from the 
transform s2y and extracts the crossover 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.

c22 This is a program that takes the output from the 
transform s2y and extracts the output 
capacitance value based on an equivalent pi 
structure for the parasitic capacitance.
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This procedure stores the model in IC-CAP, including all the 
device-specific measured and simulated data.  Once you have 
developed the device model, it can be used as a component in 
the Agilent Microwave and RF Design System (MDS).  You can 
use it for circuit simulation, inserting it into circuits under 
design to emulate the characteristics of your device.

If you are modeling large numbers of devices, it is worthwhile to 
organize your directory structure according to device type, 
geometry, and batch or wafer.

1 Use the UNIX directory you created at the beginning of the 
procedure, when you first opened the vbic_npn.mdl file.

2 From the Main window select File > Save  As.

3 A dialog box is displayed, similar to the one illustrated.

4 Select the File Type (.mdl for a complete model) by clicking 
the corresponding radio button.

5 Type in your chosen directory path and filename. Select OK 
to store the data and close the dialog box.

Figure 184 Save As Dialog Box
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Agilent 85190A IC-CAP

The IC-CAP Framework 564

Making Selections with the Mouse 565

System Shutdown 566

Launching IC-CAP 567

Accessing Data from a Previous Measurement 569

This appendix contains information on the software framework 
on which the high-frequency models are run. 

The last part of this appendix is a procedure for getting started 
using the IC-CAP software, including launching IC-CAP and 
accessing the model file you require.
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Agilent 85190A IC-CAP is the framework on which the model 
software runs. It provides the user interface, measurement 
system control, and simulator interface for the individual 
software models. You can find more information on the 
standard user interface and IC-CAP windows in the User’s 
Guide.
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This manual does not give instructions on how to use the mouse 
in the step-by-step procedures, therefore a summary is provided 
here.

When the terms select, choose and click are used, it means 
position the mouse pointer over the on-screen item and click 
the left mouse button. Sometimes you will be asked to select an 
item from a menu and then another item from a pulldown 
menu. In this case, do not release the mouse button after the 
first selection. Hold down the mouse button and move the 
pointer to the required selection in the pulldown menu, then 
release. A series of mouse selections separated by greater than 
symbols (>) indicates that the selections should be performed in 
sequence. An example is File > Save As.

If you need to get a readout of values at a particular point on the 
data trace, put the mouse pointer at this point and click middle 
to display the x- and y-axis values.

To edit information (such as variable names or values) in 
software, move the mouse pointer to the information to be 
edited. Click left with the mouse and move the pointer over the 
old information to highlight it. Then type in the new 
information over the old, and press Return. Use the Insert and 
Delete keys if necessary.
Software Backup
It is important that you make periodic backups of your system 
disk to guard against accidental loss of data. You can use the 
script /etc/backup or the tar command to make backups. It is 
highly recommended that you make a tape backup of the system 
disk before you begin using the system.
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It is best never to switch your system off without doing a 
shutdown. UNIX systems have a very specific shutdown 
procedure that must be followed prior to switching the power 
off. Failure to follow the shutdown procedure can result in 
irreparable damage to the data on your disks. Refer to the 
documentation for your operating system, or obtain the 
shutdown procedure from your system administrator.
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This assumes that IC-CAP has been properly installed on the 
computer. If you purchased the software together with the 
Hewlett-Packard workstation on which it will run, the software 
will have been installed at the Agilent factory. Otherwise, you 
can follow the installation procedures provided in the 
Installation Guide. Then proceed as follows: 

1 Start IC-CAP from any terminal window by typing iccap and 
pressing Enter. The IC-CAP Main window appears (see the 
following figure).

2 Select File, then select  Examples from the pulldown menu. A 
list of model file types is displayed.

3 Double-click on the model file type you want, for example 
/bjt. A list of model files of that type is displayed.

4 Scroll through the list to find the .mdl file for the model you 
wish to use, and double-click to open it or select it and click 
OK.

Figure 185 IC-CAP Main window
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5 The Model window for the model of your choice is displayed.

6 Before you continue with the IC-CAP procedures, make a 
new directory in an appropriate location in the UNIX 
structure, using the mkdir command, to store the data and 
model files that will be generated. Give the directory a name 
that will associate it with the devices you are going to model.

7 Use the cd command to change to the new directory in UNIX. 

8 To leave IC-CAP, choose File > Exit.
 

NOTE The first time you load the model, warnings may be displayed in the UNIX 
window that the instrument options are stored. This merely indicates that 
the instrument state settings are being returned to default values. Once 
you set the appropriate instrument states for your measurements and save 
them in a file using the procedures in Chapter B, “Using IC-CAP with an 
Agilent 85122A Precision Modeling System or Chapter C, “Using IC-CAP 
with an Agilent 85123A Device Modeling System, you will not need to 
reset them each time you run the procedures.
IC-CAP Nonlinear Devices Models Volume 2



Agilent 85190A IC-CAP A
Accessing Data from a Previous Measurement
IC-CAP Nonlinear Devices Models V

 

If you wish to access data from a previously stored 
measurement or parameter extraction, you will need to perform 
this additional step to let IC-CAP know where to find the data 
and bring it into this model file: 

From the IC-CAP Main menu, select File > Change Directory. 
Type in the pathname of the file where your data is stored. 
Click OK. 
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B
Using IC-CAP with an Agilent 85122A 
Precision Modeling System

Description of the System 573

Configuring the System Hardware 575

Preparing for Calibration 582

Terminating the Input Ports to Prevent Oscillation 583

Installing the Device 584

Performing Hardware Setup in IC-CAP 585

Calibrating the Network Analyzer 589

Defining the DC Source/Monitor Instrument State 595

Defining the Instrument States for S-Parameter Measurements 598

This appendix documents procedures for setup, calibration, and 
control of the Agilent 85122A precision modeling system. Some 
of these are hardware procedures independent of IC-CAP, and 
some are hardware control procedures performed inside 
IC-CAP.
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These procedures are common for the various high-frequency 
IC-CAP models. This is not a sequential set of procedures, but a 
set of separate hardware-related procedures that are used in 
conjunction with any of the device modeling procedures 
documented in the chapters. The procedures in this appendix 
give detailed instructions for the following:

• Configuring the system hardware

• Performing hardware setup in IC-CAP 

• Calibrating the network analyzer

• Defining the instrument states in IC-CAP (for DC, 
capacitance, and S-parameter measurements)

In some cases, you may not need to perform all these 
procedures each time you model a device. The system setup 
procedures are performed rarely. On the other hand, the 
network analyzer calibration must be performed regularly. 
Setting the instrument states is done for each measurement 
setup in each model, and the settings can be stored.
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The Agilent 85122A microwave parameter extraction system is 
specially designed for use with Agilent 85190-series 
high-frequency IC-CAP software (and a compatible controller) 
to measure the DC and high-frequency performance of active 
devices. The software is then used to extract the device model 
parameters. The standard system uses an Agilent 8510C 
network analyzer subsystem for S-parameter device 
characterization from 45 MHz to 20 GHz, and an Agilent 4142B 
DC source/monitor to provide precision DC characterization as 
well as bias for the S-parameter measurements.

The synthesized sweeper in the Agilent 8510 subsystem 
supplies RF signals. The Agilent 4142B DC source/monitor 
provides DC force (supply) and sense (measure) capability from 
its plug-in SMUs (source/monitor units). The DC signals are 
routed via cable feedthrough panels to the Agilent 11612 option 
Kxx external bias networks. The RF signals are also connected 
to the bias networks, and thus RF and DC signals are applied 
together to the device under test. The bias networks have 3.5 
mm (female) connectors for interface to a test fixture or probe 
station.

The system can also be custom-configured to meet individual 
needs, to provide different operating frequency ranges, bias 
power levels, or cabling configurations, for example. Or it may 
include instrumentation for different types of measurements, 
such as power or noise figure measurements.

The system is factory-installed in a rack. A rack-mounted work 
surface is included, for maximum convenience in making 
on-wafer, in-fixture, or coaxial measurements. The work surface 
is coated with antistatic material and is connected to chassis 
ground, therefore a static mat is not required.
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SYNTH

DC SOURC

HP/AGILENT
The following figure shows the general configuration of a typical 
high-frequency modeling system, although the Agilent 85122A 
system is installed in a system rack.

Figure 186 General Configuration of a Typical System
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The Agilent 85122A system is shipped from the factory with all 
rack components and instruments assembled and cabled in the 
system rack cabinet, and installed at your site by the Agilent 
customer engineer.

System hardware configuration need only be done in the 
following circumstances: 

• At initial system setup.

• If changes are made to the system hardware.

• To change the bias connections for a different device type.

Before starting a parameter extraction procedure, make sure 
the GPIB and Agilent 8510 system cables are connected as 
shown in Figure 187, with the GPIB addresses set correctly. 
Note that the synthesizer and the DC source/monitor both use 
address 19: this is not a conflict, because the synthesizer is on 
the Agilent 8510 system bus and the DC source/monitor is on 
the GPIB. Make sure the synthesizer language is set correctly: 
the first three switch positions from the left on the synthesizer’s 
GPIB/language switch must be set to 001 for network analyzer 
language.

Make sure the system RF cables are connected as shown in 
Figure 188.

If you are using a special custom system, refer to its installation 
and user’s guide for custom cabling diagrams. The standard and 
special option Agilent 85122A installation and user’s guides 
also provide any additional information you may need about 
setting up your system components. 

Connect the RF cables from the test set ports to the RF IN ports 
of the bias networks. 

The following provides details of the DC bias connections.
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Figure 187 GPIB and System Interconnections and GPIB Addresses
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• For additional hardware information, refer also to the 
installation and user’s guide for your Agilent 85122A 
microwave parameter extraction test system, and to the 
manuals for the individual instruments in the system. 

• For information on fixtures or probe stations, refer to the 
manufacturer’s documentation.

Figure 188 RF Cabling Interconnections
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Bias current and voltage are supplied to a device under test 
from the plug-in source/monitor units (SMUs) in the Agilent 
4142B DC source/monitor, connected to the device through the 
bias networks and probes or fixture.

Interlock Connection

To prevent electric shock from DC voltages in excess of +/−42V, 
do not close the INTLK (interlock) connection of the Agilent 
4142B DC source/monitor. The high-power SMU output can be 
as high as +/−200V, and the medium-power SMU output can be 
as high as +/−100V. As long as the INTLK connection is open, 
the DC voltage is clamped at +/−42 VDC.

Floating Ground

IC-CAP measurements are normally performed with the device 
in a floating-ground configuration, to prevent ground loop noise 
or, in the case of a BJT, possible damage to a device. A 
floating-ground configuration is accomplished by insulating the 
fixture or probe station from power-line ground, for example 
with an insulator between the wafer under test and the chuck of 
a probe station. If you are measuring in a floating-ground 
configuration, make sure the shorting bar of the Agilent 4142B 
is connected between the CIRCUIT COMMON and CHASSIS 
GROUND terminals on the front of the GNDU plug-in.

If you cannot implement a floating-ground configuration, it may 
be necessary to open the Agilent 4142B shorting bar and 
connect the DUT ground to the circuit common grounds at the 
DUT ends of the SMU and GNDU cables. The circuit common 
grounds are not connected through the bias networks: they are 
available at the input jacks. Refer to the Agilent 4142B 
Operation Manual chapter 3, “Test Device Connections,” and 
read the section titled “If the Test Device Is Externally 
Grounded (Floating Measurement).” This provides detailed 
instructions on making the necessary connections.
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Configuring the SMUs and Bias Networks

WARNING A potential shock hazard exists when the shorting bar is 
disconnected for floating measurements. Do not touch any of the 
Agilent 4142B front panel connectors while a floating-ground 
measurement is in progress.
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Bias current and voltage are supplied to a device under test 
from plug-in source/monitor units (SMUs) in the Agilent 4142 
DC source/monitor, connected to the device through the bias 
networks and probes or fixture. The standard Agilent 85122 
system includes one medium-power SMU and one high-power 
SMU.

The quadraxial cables from the SMUs are routed through a cable 
feedthrough panel in the system rack, around the back of the 
synthesizer and test set, and out to the front of the rack through 
another feedthrough panel.

Bias Connections

The following figure illustrates the connections from the SMUs 
to the bias networks. Connect the FORCE and SENSE 
connectors on the quadraxial cables to the FORCE and SENSE 
connectors on the bias networks. Connect the triaxial cable 
from the GNDU SMU to the ground connector on one of the bias 
networks (usually port 2). Leave the ground connector of the 
other bias network unconnected.
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Figure 189 Connections from DC Source/Monitor to Bias Networks
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 NOTE For in-fixture measurements, the measurement procedures in this manual 
apply to a FET mounted in the fixture in a common-source configuration, or 
a BJT mounted in a common-emitter configuration.
Connect the DC/RF signals from the outputs of the bias 
networks via the semi-rigid cables to the corresponding 
terminals of the fixture or probe station. Set up the angle of the 
cables and bias modules to minimize stress and torque, and 
ensure that the cables are properly supported. Iterate the 
positioning of the cables and bias networks until the connectors 
line up correctly. Use a torque wrench to tighten the 
connections. 

The following figure illustrates the connections for a BJT. The 
connections for a FET are comparable, with the port 1 DC/RF 
signal connected to the gate, the port 2 DC/RF signal connected 
to the drain, and the source grounded.
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Switching on the System
It is important to apply power to the system in the correct 
sequence, so that the network analyzer recognizes the test set 
and synthesizer, and the computer recognizes the network 
analyzer subsystem and the DC source/monitor.

Switch on power to the system instruments in this sequence 
(from bottom to top of the system rack): 

1 DC source/monitor

2 Synthesizer

3 Test set

4 Network analyzer

5 Computer
olume 2
Agilent 
11612A
K10
TO Agilent 41
BIAS
NETWORK
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Preparing for Calibration
582

 

Let the system warm up for at least 1 hour before calibrating the 
network analyzer. The DC measurements can be performed 
during this time.

The calibration standards will need to be at ambient room 
temperature when the measurement calibration is performed. If 
you are using a fixture, open the fixture calibration kit and 
place all the devices on top of the foam so they will reach room 
temperature by the time the system is warmed up. If you are 
using a probe station, place the probed impedance standard 
substrate (ISS) on the probe chuck and allow it to reach 
ambient temperature before use.

The calibration procedure is described in “Calibrating the 
Network Analyzer” on page 589.
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Leave the network analyzer disconnected from the bias 
networks while you perform the DC measurements. Connect 
terminations with >20 dB return loss (such as 10 dB pads) to 
the RF IN connectors of the bias networks, to prevent possible 
bias oscillation. The network analyzer is calibrated later in the 
modeling procedures, immediately before the capacitance and 
S-parameter measurements.

Alternatively, isolate the device from RF power by manually 
setting 90 dB of attenuation at the network analyzer test ports. 
Also put the network analyzer in hold sweep mode by pressing 
STIMULUS > MENU > MORE > HOLD.
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Installing the Device
584
The best time to install the device is immediately before making 
measurements.
CAUTION Ground yourself with an antistatic wrist strap to reduce the chance of 
electrostatic discharge. A ground terminal is provided on the lower left 
corner of the test set front panel for your convenience. (Note that the 
system work surface is coated with antistatic material and is 
connected to chassis ground, therefore a static mat is not required.)
Install the device carefully on the probe chuck or in the fixture. 
Be sure to handle the device as little as possible, to avoid 
damaging it. Once the device is in place, avoid bumping the test 
station.
 NOTE Eliminate direct light sources (such as microscope light) during 
measurement, especially for GaAs devices, as light may influence the 
measurement and cause inaccurate results.
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The measurement system hardware is controlled by the IC-CAP 
software. This procedure configures IC-CAP to recognize the 
system instruments on the GPIB, and the individual 
source/monitor units (SMUs) in the DC source/monitor. The 
complete procedure need only be done after initial system 
installation, or any time the system hardware is changed, to 
establish a system handshake. The second part of the procedure 
(renaming the SMUs) also needs to be done any time you change 
device types, such as from FET to BJT or from BJT to FET. 

For help with launching IC-CAP and opening the model file you 
need, refer to Chapter A, “Agilent 85190A IC-CAP,” then 
continue with these steps:

1 In the IC-CAP Main menu bar select Tools > Hardware Setup. 
The hardware window is displayed. It will vary depending on 
the system hardware used, but will be similar to the following 
figure.

2 Under the Instrument List select Rebuild. This command 
causes IC-CAP to poll all available GPIB addresses and add to 
the Instrument List any newly connected instruments that 

Figure 191 Hardware Window
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are powered up. (It does not affect instruments already on 
the list, whether they are powered up or not.)
Renaming the SMUs
Use this procedure any time you change device types, such as 
from FET to BJT or from BJT to FET, so that the measurement 
setups can properly communicate with the bias supplies.

When you run the IC-CAP software, it initially identifies the 
plug-in SMUs according to the numbers of the Agilent 4142 slots 
in which they are installed. A medium-power SMU occupies one 
slot. A high-power SMU occupies two slots, and is identified by 
the higher slot number of the two. An Agilent 85122 system can 
include different combinations of SMUs: the standard system 
used in the example procedures includes two SMUs, one Agilent 
41421B medium-power SMU and one Agilent 41420A 
high-power SMU. The medium-power SMU is factory-installed in 
slot 1 and is initially identified in the IC-CAP software as 
MPSMU1. The high-power SMU is installed in slots 2 and 3, 
initially identified as HPSMU3. The ground unit is identified as 
GNDU. It is generally more convenient to assign unit names to 
the SMUs that identify their purpose in a device measurement, 
depending on the bias connections at the device terminals and 
the type of device you are modeling. 

In configuring IC-CAP to recognize the system hardware, you 
need to set the SMU names used in software to identify the SMU 
connections at the measurement terminals. In a FET 
measurement, the SMUs are identified as VG (gate supply) and 
VD (drain supply). In a BJT measurement, the SMUs are 
identified as SMU1 and SMU2, corresponding to the network 
analyzer test ports: this helps to facilitate measurement of a 
BJT with only two SMUs, since the port 2 SMU will be used for 
measurements at both the collector and emitter terminals.

The following figure illustrates the SMU unit names for a FET 
measurement and the correspondence to the device terminal 
connections.
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The following figure illustrates the SMU unit names for a BJT 
measurement and the correspondence to the device terminal 
connections

1 In the Instrument List click on HP4142 to highlight it. Select 
Configure and the Configuration of HP4142 window is 
displayed.

2 The Unit Table lists the SMUs. Also listed for each is a unit ID 
(identification) name that can be edited.

In a FET measurement, the medium-power MPSMU1 is 
renamed VG, because it is connected to the gate terminal; 
and the high-power HPSMU3 is renamed VD, because it is 
connected to the drain terminal.

In a BJT measurement, the medium-power MPSMU1 is 
renamed SMU1 because it is the port 1 SMU; and the 
high-power HPSMU3 is renamed SMU2 because it is the port 
2 SMU.

Figure 192 SMU Unit Names for a FET Measurement

Figure 193 SMU Unit Names for a BJT Measurement
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3 To make this change, click left with the mouse and move the 
mouse pointer over the name assigned to MPSMU1 to 
highlight it. Then type in the new name, and press Return. 
Similarly, change MPSMU3’s assigned unit name. Then select 
OK to close the configuration window.

4 You can close the Unit Table tile by clicking middle again.

5 To save this hardware configuration in a file for future use, 
select Hardware, then Write to File. A file filter is displayed, 
showing the pathname of the current directory. Type in an 
appropriate name for the .hdw file you are creating, and 
select OK.

6 Close the hardware window.

After IC-CAP is configured to recognize the system hardware, 
you can proceed to one of the modeling chapters.
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The network analyzer must be calibrated before any 
S-parameter measurements are performed. The system must be 
allowed to warm up for at least 1 hour before calibration, and 
the calibration standards must be at ambient room 
temperature. It is convenient to switch on the analyzer and 
expose the calibration devices to air before you make the DC 
measurements.

Good calibration of the network analyzer system is critical to a 
good high-frequency measurement and extraction. A good 
calibration is dependent on the quality of the calibration kit 
standard devices, the care with which they are maintained, and 
the correctness and repeatability of the device connections. A 
stable ambient temperature (±1°C) is required to maintain a 
good calibration.

For the high-frequency IC-CAP measurement procedures, the 
network analyzer is calibrated over a broadband frequency 
range, to perform the S-parameter measurements for parasitic 
and AC extractions. In addition, one or two subset calibrations 
may be needed at CW frequencies for specific measurement 
setups. This procedure explains how to set up both the 
broadband calibration and one of the CW calibrations with one 
set of standards measurements, making the CW frequency cal a 
subset of the broadband frequency cal. If a third calibration is 
done, its frequency may not be known until some of the 
S-parameter measurements have been made, therefore it cannot 
be performed now. However, when the calibration frequency is 
determined later, the subset cal can be performed using exactly 
the method defined under “CW Frequency Calibration Subset” 
on page 591 without another set of standards measurements.

The instructions given below are very abbreviated: more 
detailed information is available in the Agilent 8510 Operating 
and Programming Manual.
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NOTE It is important that values entered in software correspond with actual 
instrument settings. Be sure to write down the parameters of your 
calibrations, so that they are readily available when you need to enter 
them in IC-CAP.
590

 

To connect the network analyzer:

Disconnect the terminations from the bias networks. Connect 
the RF cables from the network analyzer test ports to the RF 
inputs of the bias networks.
Swept Broadband Calibration 
1 On the network analyzer, press PRESET.

2 To define the frequency range of the calibration and 
measurement, on the network analyzer press STIMULUS > 
START, and use the numerical keypad to set the start 
frequency, ending with one of the terminator keys (such as 
G/n) at the right of the keypad. Similarly, press STOP and set 
the stop frequency. Set a frequency range at least as wide as 
the operating range of the device. 

3 Press STIMULUS > MENU > NUMBER of POINTS, and set the 
number of data points you wish to measure. A reasonable 
number might be 51 or 101 points.

4 Press PRIOR MENU > FREQUENCY > STEP to set the stepped 
frequency mode, which provides greatest measurement 
accuracy by phase-locking the synthesized sweeper at each 
frequency point.

5 Press PRIOR MENU > MORE > CONTINUAL to set a continual 
stimulus sweep.

6 Press PRIOR MENU > POWER MENU, and set the desired 
power level. In setting the source power and attenuation, take 
care that the power level will not be excessive at the device 
input. Also consider the gain of the device, and set a power 
level that will not saturate the input port samplers of the 
analyzer. If the power level at the sampler goes above 
−8 dBm, an IF OVERLOAD error message is displayed and 
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you will need to reduce the source output power. The default 
network analyzer power level is 0 dBm. 

7 For a device with power dropoff at higher frequencies, you 
may wish to set a power slope using the stimulus menus. An 
appropriate power slope would be in the region of 
2-3 dB/GHz.

8 Press RESPONSE > MENU > AVERAGING ON/restart, and 
enter an averaging factor high enough to reduce trace noise 
and increase dynamic range as appropriate for your device 
measurements. The default averaging factor is 256, but as 
little as 16 may be adequate.

9 If the cal kit constants for your calibration kit are not loaded 
into the network analyzer, load them from disk now.

10 If you wish to modify one of the internal calibration kit 
definitions (see below), do so now.

11 Perform a full two-port calibration using 
short-open-load-thru standards. Omit isolation cal. (A TRL or 
LRM calibration would also be an appropriate alternative.)

12 At the end of the calibration sequence, the cal set numbers 
are listed in the softkey menu. Press CAL SET #1 to store this 
calibration in cal set #1. (Or use another available cal set.)
CW Frequency Calibration Subset
In some of the high-frequency models, extraction of certain 
parameters is done at a single CW frequency. The CW frequency 
must be equal to the start frequency plus an integer multiple of 
the step size: the model chapter you use gives more information 
on deciding an appropriate frequency. Once you have 
determined the frequency of the calibrated measurement point, 
use the following procedure to create a CW frequency subset of 
the swept broadband calibration.

1 Press CAL > CORRECTION ON > CAL SET 1 (this turns on 
the swept cal you just completed), then MORE > MODIFY CAL 
SET > FREQUENCY SUBSET. 

2 Use the SUBSET: START and SUBSET: STOP softkeys in the 
SUBSET menu (NOT the front panel keys) to set both start 
and stop to the frequency you selected.
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3 Press CREATE & SAVE, and store this calibration in cal set 
#2 (or another available cal set).

After the network analyzer is calibrated, return to the modeling 
chapter you are using, for the S-parameter measurement 
procedures.
Modifying a Cal Kit Definition
The network analyzer’s internal calibration kit models are 
accurate for most applications, however, you may want to 
modify the internal cal kit definitions in certain situations, for 
example:

• If you are using a probe station and you know the probe 
capacitances, you can enter them into the cal kit definition so 
that their effects can be removed by the measurement 
calibration.

• The impedance of an on-wafer load may not be exactly 50Ω. 
You can characterize the DC impedance of a load exactly with 
a precision ohmmeter measurement, and enter the 
impedance value into the cal kit definition.

The procedure to modify an internal cal kit definition is 
complex, and not to be undertaken without a solid 
understanding of error correction and the system error model. 
It is explained in Product Note 8510-5, Specifying Calibration 
Standards for the Agilent 8510 Network Analyzer (Agilent 
literature number 5954-1559), and in the Agilent 8510C 
Operating and Programming Manual.

More on Power Levels and Capacitance Measurements

The primary factor to consider in understanding the available 
range of power is the S-parameter test set, and whether it is 
coupler-based or power-splitter-based. The test set generally 
used in a 26.5 GHz system is the Agilent 8515B, which uses a 
power splitter to couple signals to the detector. The “economy” 
version test set is the Agilent 8514B (20 GHz), which uses a 
directional coupler.
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The directional coupler in the Agilent 8514B has a 
−20 dB/decade power rolloff below 500 MHz, with some signal 
loss above that. The result is that in the frequency range 45 MHz 
to 2 GHz the minimum detectable signal of the Agilent 8514B is 
only −66 dBm. However, over the same frequency range, the 
minimum detectable signal of the Agilent 8515B is −101 dBm. 
(Above 2 GHz, both test sets can detect at least −95 dBm 
signals.)

The model of synthesizer used does not affect these differences.  
Any potential improvement due to the synthesizer is obscured 
by the effects of the test set.
Capacitance Junction Measurements
 

In measuring capacitance junctions, the signal level at the 
device is generally kept below −30 dBm to keep 
nonlinearity-induced errors below 5 percent. Capacitance 
measurements are typically made in the 50 to 100 fF region.

Why is it necessary to keep the signal level below −30 dBm for a 
capacitance measurement? In fact, it is not necessary! The 
device is biased so as not to have any gain, therefore the input 
samplers and the test set are not saturated, nor is the output of 
the device. Additionally, the power level set on the synthesizer 
is not the same as the power level arriving at the device. 
Depending on the frequency range and the test set, there can be 
anywhere from 15 to 30 dB of loss between the source and the 
device.

One method is to solve for the minimum resolvable capacitance, 
given an input power and a dynamic range.  This should be done 
for both S21 (Cbc) and S11 (Cbe), because their respective 
resolutions are different.

Device input power −10 dBm.

Noise Floor −90 dBm.

Dynamic range >80 dB. (80 dB = 1E−04 linear)
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S21 Related to Cbc

= 1.5917E-07/freq

=> minimum C @ 100 MHz = 1.59 fF

S11 Related to Cbe

=6.36556E-07/freq

=> minimum C @ 100 MHz = 6.37 fF

This analysis verifies the observation that Cbc measurements 
are cleaner than Cbe measurements.

With an Agilent 8515B test set the same capacitance would put 
the signal 40 dB above the noise floor, which would allow 20 dB 
of leeway even as low as 100 MHz.

This verifies the initial statement that it is the S-parameter test 
set that determines the available range of power, and not the 
synthesized sweeper.
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Defining the DC Source/Monitor Instrument State

NOTE For details on IC-CAP instrument options (instrument states) for specific 
instruments, refer to Chapter 1, “Supported Instruments,” in the 
Reference manual.
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IC-CAP provides remote control of the DC source/monitor and 
the network analyzer to measure the device under test. This 
procedure configures IC-CAP with the instrument state settings 
(instrument options) for the DC  source/monitor.

Use this procedure if you have been referred here from one of 
the main device modeling procedures.

You will need to set the DC source/monitor instrument state 
separately for each measurement setup in a modeling 
procedure. However, use the same settings for all the 
measurement setups in one model (except that Integ Time can 
differ among setups, as explained below). Unless you use the 
default settings documented here, it is helpful to write down the 
settings to duplicate in the other setups.
NOTE DC signal levels and other input parameters that differ among 
measurement setups are not set in this procedure, but in the individual 
setup procedures in each model chapter.
This procedure uses the forward gummel setup in the BJT 
measurement as an example. However, the settings used are 
defaults and the explanations are general.

1 In the DUT/Setup panel select a setup, for example fgummel.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states for the DC 
source/monitor, as illustrated in the following figure. 

3 Set each of the DC source/monitor measurement parameters 
according to the actual Agilent 4142 configuration and the 
device to be measured, using the guidelines in the following 
steps.
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• Use User Sweep is normally set to No, to use the 
instrument’s internal sweep, which is faster than a 
user-defined sweep.

• Hold Time is the delay in seconds before the sweep, to 
allow for DC settling. Generally, no hold time is necessary.

• Delay Time is the time in seconds the instrument waits 
before measuring at each step of an internal or user 
sweep. It can generally be set to 0.000.

• For Integ Time, M (medium) is a good default choice. In 
measurements where a long integration time is needed for 
noise reduction, you would use L (long), and you will be 
instructed to do so in certain procedures. An example is 
the forward gummel measurement, which measures very 
low current values. You can speed up a measurement by 
using S (short), but this is not recommended because it 
degrades the dynamic range of the measurement.

4 Set Range to 0 to implement SMU auto-ranging.

Figure 194 Example Agilent 4142 DC Source/Monitor Instrument State
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5 Power Compliance is used to set the maximum 
current/voltage combination for the DC source/monitor. 
However, in the models, SMU voltage and current 
compliances are set individually in the individual setups. 
Therefore the value here can be set to 0.000.

6 SMU Filters ON is set to Yes to switch in low-pass filters on 
the SMU outputs. This protects the device from voltage spikes 
caused by DAC output changes.

7 The IC-CAP models documented here are generally not 
configured for pulsed measurements, therefore Pulse Unit 
can be left blank. All other Pulse settings are then irrelevant 
and can be ignored.

8 Module Control is not used in these procedures: leave the 
field blank.

9 Init Command sets the instrument to a mode not supported 
by other fields in this table. It is not used in these models. 
Leave the field blank.

10 If you wish, refer to the DC source/monitor manual for more 
detail.

11 If the measurement setup you are configuring calls for a DC 
measurement only, close the instrument options window. 
Then return to the modeling procedure.

12 If the measurement setup also calls for a network analyzer 
measurement, continue to “Defining the Instrument States 
for S-Parameter Measurements” on page 598.
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IC-CAP provides remote control of the DC source/monitor and 
the network analyzer to measure the device under test. These 
procedures configure IC-CAP with both the DC source/monitor 
and Agilent 8510 network analyzer instrument states for 
S-parameter measurements. The first procedure sets the 
instrument states for a broadband swept-frequency 
measurement, and the second for a CW frequency 
measurement.
Instrument States for Swept Measurements

NOTE For details on IC-CAP instrument options (instrument states) for specific 
instruments, refer to Chapter 1, “Supported Instruments,” in the 
Reference manual.
You will need to set the instrument states separately for each 
measurement setup in a modeling procedure. However, use the 
same settings for all the swept S-parameter measurement 
setups in one model (except that Integ Time can differ among 
setups, as explained under “Defining the DC Source/Monitor 
Instrument State” on page 595) Unless you use the example 
settings documented here, write down the settings you use, to 
duplicate among setups within one model. 

This procedure uses the sparm_bias setup in the BJT 
measurement as an example, though the explanations here 
apply to all swept-frequency  S-parameter measurements in the 
different device measurement procedures.
NOTE Source parameters such as frequency range are not set in this procedure, 
but in the individual S-parameter setup procedures in each model chapter. 
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settings for a CW measurement are different, and are documented later.
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1 In the DUT/Setup panel select the S-parameter setup you 
need, for example sparm_0v.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states. The following figure 
illustrates example instrument states.

3 Set the Agilent 4142 instrument state the same as for the DC 
measurements.

4 Set the Agilent 8510 instrument state according to the actual 
hardware configuration, the calibration used, and the device 
to be measured, following these guidelines:

Figure 195 Instrument States for Swept Measurements
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5 Set Use User Sweep to No, to use the instrument’s standard 
internal sweep. This is necessary for the network analyzer’s 
calibration to be switched on.

6 Hold Time is the time in seconds before the instrument starts 
a sweep, to allow for DC settling. Generally, no hold time is 
required.

7 Delay Time is the delay in seconds the instrument waits 
before setting each frequency in user sweep mode. The 
default is 100.0m, but the value set will not affect an internal 
sweep.

8 Set Port 1 Atten and Port 2 Atten to the same levels in dB 
that you set in the network analyzer calibration. While the 
default is 0 dB, you may need to add attenuation for 
measurements of amplifiers or high-power devices.

9 Source Power is the RF synthesizer output power. Set it to 
the same value in dB that you set in the network analyzer 
calibration. 

10 Power Slope is used only if you use power slope in the 
network analyzer calibration: if so, set the corresponding 
value here. This is useful to view the response of a device 
with power dropoff at higher frequencies. The units for 
power slope are dB/GHz; the default value is 0.000. (A 
network analyzer message will caution you that the 
correction may be invalid, but this can be ignored.)

11 Set Fast Sweep (RAMP) to No, because the network analyzer 
is in stepped-sweep mode, set earlier in the calibration 
procedure. 

12 Sweep Time applies only to ramp sweep mode, therefore the 
value set is irrelevant for a stepped-sweep measurement.

13 Set Use Fast CW to Yes, to minimize repeated switching 
between the test set ports.

14 Trim Sweep is set to 0. This feature is used only in ramp 
sweep mode.

15 Set Avg Factor to the same averaging factor you set in the 
calibration. The default value is 256, but as little as 16 may be 
adequate.

16 Set Cal Type (SHN) to H, for hardware.
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17 Set Cal Set No to the cal set number in the analyzer where 
you stored your swept calibration, so that IC-CAP can find 
the calibration.

18 Soft Cal Sequence refers to the sequence of measurements of 
the cal standard devices: load-open-short-thru.

19 Delay for Timeouts can generally be set to the default value of 
0.000.

20 Set Use Linear List to No because this is a standard 
stepped-frequency measurement.

21 Init Command sets the instrument to a mode not supported 
by other fields in this table. It is not used in this model. Leave 
the field blank.

22 Close the instrument options window. Then return to the 
modeling procedure.
Instrument States for CW Frequency Measurements
 

The instrument states for a CW S-parameter measurement are 
similar to those for a swept measurement, with a few important 
exceptions, listed below.

You will need to set the instrument states separately for each 
measurement setup in a modeling procedure. However, use the 
same settings for all the CW S-parameter measurements in one 
model (except that Integ Time can differ among setups.) Unless 
you use the default settings documented here, write down the 
settings you use, to duplicate among setups within one model.

This procedure uses the sparm_cje setup in the BJT 
measurement as an example, though the explanations here 
apply to all CW S-parameter measurements in the different 
device measurement procedures.
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instrument states even if you choose to use different CW frequencies for 
different measurements, except for the Cal Set No where they are stored.
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1 In the DUT-Setup panel select the CW S-parameter setup you 
need, for example sparm_cje.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states. Figure 196 
illustrates example instrument states.

3 Set the Agilent 4142 instrument state the same as for the DC 
measurements.

4 Set Use User Sweep to Yes, because CW is a nonstandard 
sweep.

5 (Be sure to set Port 1 Atten and Port 2 Atten and Source 
Power to the same values as you used in the network analyzer 
calibration.)

6 Set Use Fast CW to No.

7 Set Cal Set No to the cal set number in the analyzer where 
you stored your CW subset calibration. This must be different 
from the cal set used by the swept broadband calibration, 
and from any CW calibration you make at a different 
frequency for any different measurement.
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8 If necessary, refer to the Agilent 8510C Operating and 
Programming Manual for more detail.

9 Close the instrument options window. Then return to the 
modeling procedure.

Figure 196 Instrument States for CW Frequency Measurements
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This appendix documents procedures for setup, calibration, and 
control of the Agilent 85123A RF parameter extraction test 
system. Some of these are hardware procedures independent of 
IC-CAP, and some are hardware control procedures performed 
inside IC-CAP.

These procedures are common among the high-frequency 
IC-CAP models. This is not a sequential set of procedures, but a 
set of separate hardware-related procedures used in 
conjunction with any of the device modeling procedures 
documented in the modeling chapters. Use the information in 
this appendix when you are directed here, at the appropriate 
times in the modeling procedures.
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The procedures in this appendix give detailed instructions for 
the following:

• Configuring the system hardware

• Performing hardware setup in IC-CAP 

• Defining the instrument states in IC-CAP (for DC, 
capacitance, and S-parameter measurements)

• Calibrating the network analyzer

The instructions explain when the hardware-related procedures 
are needed and when they are not. In some cases, you may not 
need to perform all these procedures each time you model a 
device. The system setup procedures are performed rarely. 
Setting the instrument states is done for each measurement 
setup in each model, and the settings can be stored for repeated 
use. The network analyzer calibration must be performed 
regularly for accuracy.
 

NOTE The instructions provided in this appendix are for an Agilent 8753 network 
analyzer. The procedures for an Agilent 8720 are very similar. For 
information specific to a different network analyzer, refer to its operating 
manual.
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Description of the System
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The Agilent 85123A RF parameter extraction test system is 
specially designed for use with Agilent 85190-series 
high-frequency IC-CAP software (and a compatible controller) 
to measure the DC and RF performance of active devices. The 
software is then used to extract the device model parameters. 
The standard system uses an Agilent 8753D network analyzer 
subsystem for S-parameter device characterization, and an 
Agilent 4142B DC source/monitor to provide precision DC 
characterization as well as bias for the S-parameter 
measurements. The Agilent 8753D subsystem consists of the 
network analyzer with its integrated synthesizer and 
S-parameter test set, the RF cables, and the calibration kit and 
verification kit if used.

The integrated synthesizer in a standard Agilent 8753D network 
analyzer supplies a swept or CW RF signal in the range of 
30 kHz to 3 GHz. The integrated test set separates the RF signal 
into reference and test signals, and provides RF connections via 
cables and adapters to the external bias networks. The Agilent 
4142B source/monitor provides DC force (supply) and sense 
(measure) capability from its plug-in SMUs (source/monitor 
units). The DC signals are routed via feedthrough panels to the 
bias networks, and thus RF and DC signals are applied together 
to the device under test. The bias networks have 3.5 mm 
(female) connectors for interface to a test fixture or probe 
station. The transmitted and reflected signals from the device 
are measured and displayed by the receiver.

The system can be custom-configured to meet individual needs, 
for example to provide an optional 6 GHz frequency range, 
different bias arrangements, or different cabling configurations. 
The network analyzer can be replaced with an Agilent 8720 
(20 GHz) or 8719 (13.5 GHz). Or the system can include 
instrumentation for different types of measurements, such as 
power or noise figure measurements.
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The system is factory-installed in a rack. A rack-mounted work 
surface is included, for maximum flexibility and convenience in 
making on-wafer, in-fixture, or coaxial measurements. The work 
surface is coated with antistatic material and is connected to 
chassis ground, therefore a static mat is not required.
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Configuring the System Hardware
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The Agilent 85123A system is shipped from the factory with all 
rack components and instruments assembled and cabled in the 
system rack cabinet. 

System hardware configuration need be done only in the 
following circumstances:

• At initial system setup.

• If changes are made to the system hardware.

• To change the bias connections for a different device type.

Before starting a parameter extraction procedure, make sure 
the GPIB cables are connected as shown on the next page, with 
the GPIB addresses set correctly.

If you are using a special custom system, refer to its installation 
and user’s guide for custom cabling diagrams. The standard and 
special option Agilent 85123A installation and user’s guides 
also provide additional information you may need about setting 
up your system components.

Connect the RF cables from the test ports to the RF IN ports of 
the bias networks, using adapters as needed.

The following provides details of the DC bias connections.
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Network Analyzer

DC Source/Monito
Figure 197 GPIB Interconnections and GPIB Addresses

GPIB

To Controller

 (16)

r (19)
DC Bias Safety Considerations
Bias current and voltage are supplied to a device under test 
from the plug-in source/monitor units (SMUs) in the Agilent 
4142B DC source/monitor, connected to the device through the 
bias networks and probes or fixture.

Interlock Connection

To prevent electric shock from DC voltages in excess of +/−42V, 
do not close the INTLK (interlock) connection of the Agilent 
4142B DC source/monitor. The high-power SMU output can be 
as high as +/−200V, and the medium-power SMU output can be 
as high as +/−100V. As long as the INTLK connection is open, 
the DC voltage is clamped at +/−42 VDC.
IC-CAP Nonlinear Devices Models Volume 2



Using IC-CAP with an Agilent 85123A Device Modeling System C

IC-CAP Nonlinear Devices Models V

 

Floating Ground

IC-CAP measurements are normally performed with the device 
in a floating-ground configuration, to prevent ground loop noise 
or, in the case of a BJT, possible damage to a device. A 
floating-ground configuration is accomplished by insulating the 
fixture or probe station from power-line ground, for example 
with an insulator between the wafer under test and the chuck of 
a probe station. If you are measuring in a floating-ground 
configuration, make sure the shorting bar of the Agilent 4142B 
is connected between the CIRCUIT COMMON and CHASSIS 
GROUND terminals on the front of the GNDU plug-in.

If you cannot implement a floating-ground configuration, it may 
be necessary to open the Agilent 4142B shorting bar and 
connect the DUT ground to the circuit common grounds at the 
DUT ends of the SMU and GNDU cables. The circuit common 
grounds are not connected through the bias networks: they are 
available at the input jacks. Refer to the Agilent 4142B 
Operation Manual chapter 3, “Test Device Connections,” and 
read the section titled “If the Test Device Is Externally 
Grounded (Floating Measurement).” This provides detailed 
instructions on making the necessary connections.
Configuring the SMUs and Bias Networks

WARNING A potential shock hazard exists when the shorting bar is 
disconnected for floating measurements. Do not touch any of the 
Agilent 4142B front panel connectors while a floating-ground 
measurement is in progress.
Bias current and voltage are supplied to a device under test 
from plug-in source/monitor units (SMUs) in the Agilent 4142 
DC source/monitor, connected to the device through the bias 
networks and probes or fixture. The standard Agilent 85123A 
system includes one medium-power SMU and one high-power 
SMU.
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The quadraxial cables from the SMUs are routed through a cable 
feedthrough panel to the rear of the system rack, and out to the 
front of the rack above the work surface through another 
feedthrough panel. 

Connect the cables emerging from the upper feedthrough panel 
to the bias networks, as explained in the next paragraphs.

Bias Connections

The following figure illustrates the connections from the SMUs 
to the bias networks. Connect the FORCE and SENSE 
connectors on the quadraxial cables to the FORCE and SENSE 
connectors on the bias networks. Connect the triaxial cable 
from the GNDU SMU to the ground connector on one of the bias 
networks (usually port 2). Leave the ground connector of the 
other bias network unconnected.

Connections from Bias Networks to Device

Figure 198 Connections from DC Source/Monitor to Bias Networks
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NOTE For in-fixture measurements, the measurement procedures in this manual 
apply to a FET mounted in the fixture in a common-source configuration, or 
a BJT mounted in a common-emitter configuration.
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Connect the DC/RF signals from the outputs of the bias 
networks via the semi-rigid cables to the corresponding 
terminals of the fixture or probe station. Set up the angle of the 
cables and bias networks to minimize stress and torque, and 
ensure that the cables are properly supported. Iterate the 
positioning of the cables and bias networks until the connectors 
line up correctly. Use a torque wrench to tighten the 
connections.

The following figure illustrates the connections for a FET. The 
connections for a BJT are comparable, with the port 1 DC/RF 
signal connected to the base, the port 2 DC/RF signal connected 
to the collector, and the emitter grounded.

• For additional hardware information, refer also to the 
installation and user’s guide for your Agilent 85123A RF 
parameter extraction test system, and to the manuals for the 
individual instruments in the system.

• For information on fixtures or probe stations, refer to the 
manufacturer’s documentation.

Figure 199 Connections from Bias Networks to In-Fixture DUT
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Switching on Power to the System
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Be sure to switch on the network analyzer and the DC 
source/monitor before the computer, so that the computer 
recognizes the network analyzer subsystem and the DC 
source/monitor.
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Preparing for Calibration
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Let the system warm up for at least 1 hour before calibrating the 
network analyzer. The DC measurements can be performed 
during this time.

The calibration standards will need to be at ambient room 
temperature when the measurement calibration is performed. If 
you are using a fixture, open the fixture calibration kit and 
place all the devices on top of the foam so they will reach room 
temperature by the time the system is warmed up. If you are 
using a probe station, place the probed impedance standard 
substrate (ISS) on the probe chuck and allow it to reach 
ambient temperature before use.

The calibration procedures can be found in the section “Swept 
Broadband Calibration” on page 632.
Terminating the Input Ports to Prevent Oscillation
 

Leave the network analyzer disconnected from the bias 
networks while you perform the DC measurements. Connect 
terminations with >20 dB return loss (such as 10 dB pads) to 
the RF IN connectors of the bias networks, to prevent possible 
bias oscillation. The network analyzer is calibrated later in the 
modeling procedures, immediately before the capacitance and 
S-parameter measurements.

Alternatively, isolate the device from RF power by manually 
setting 90 dB of attenuation at the network analyzer test ports. 
Also put the network analyzer in hold sweep mode by pressing 
MENU > TRIGGER MENU > HOLD.
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Installing the Device
616
The best time to install the device is immediately before making 
measurements.
CAUTION Ground yourself with an antistatic wrist strap to reduce the chance of 
electrostatic discharge. A ground terminal is provided on the lower left 
corner of the test set front panel for your convenience. (Note that the 
system work surface is coated with antistatic material and is 
connected to chassis ground, therefore a static mat is not required.)
Install the device carefully on the probe chuck or in the fixture. 
Be sure to handle the device as little as possible, to avoid 
damaging it. Once the device is in place, avoid bumping the test 
station.
 NOTE Eliminate direct light sources (such as microscope light) during 
measurement, especially for GaAs devices, as light may influence the 
measurement and cause inaccurate results.
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Performing Hardware Setup in IC-CAP
IC-CAP Nonlinear Devices Models V

 

The measurement system hardware is controlled by the IC-CAP 
software. This procedure configures IC-CAP to recognize the 
system instruments on the  GPIB, and the individual 
source/monitor units (SMUs) in the DC source/monitor. The 
complete procedure need only be done after initial system 
installation, or any time the system hardware is changed, to 
establish a system handshake. The second part of the procedure 
(renaming the SMUs) also needs to be done any time you change 
device types, such as from FET to BJT or from BJT to FET. 

For help with launching IC-CAP and opening the model file you 
need, refer to Chapter A, “Agilent 85190A IC-CAP” then 
continue with these steps:

1 In the IC-CAP Main window, select Tools > Hardware Setup. The 
hardware window is displayed. It will vary depending on the 
system hardware used, but will be similar to the following 
figure.

2 Under the Instrument List select Rebuild. This command 
causes IC-CAP to poll all available GPIB addresses, and add 
to the Instrument List any newly connected instruments that 

Figure 200 Hardware Window
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are powered up. (It does not affect instruments already on 
the list, whether they are powered up or not.) 
Renaming the SMUs
Use this procedure any time you change device types, such as 
from FET to BJT or from BJT to FET, so that the measurement 
setups can properly communicate with the bias supplies.

When you run the IC-CAP software, it initially identifies the 
plug-in SMUs according to the numbers of the Agilent 4142 slots 
in which they are installed. A medium-power SMU occupies one 
slot. A high-power SMU occupies two slots, and is identified by 
the higher slot number of the two. An Agilent 85123 system can 
include different combinations of SMUs: the standard system 
includes two SMUs, one Agilent 41421B medium-power SMU 
and one Agilent 41420A high-power SMU. The medium-power 
SMU is factory-installed in slot 1 and is initially identified in the 
IC-CAP software as MPSMU1. The high-power SMU is installed 
in slots 2 and 3, initially identified as HPSMU3. The ground unit 
is identified as GNDU. It is generally more convenient to assign 
unit names to the SMUs that identify their purpose in a device 
measurement, depending on the bias connections at the device 
terminals and the type of device you are modeling. 

In configuring IC-CAP to recognize the system hardware, you 
need to set the SMU names used in software to identify the SMU 
connections at the measurement terminals. In a FET 
measurement, the SMUs are identified as VG (gate supply) and 
VD (drain supply). In a BJT measurement, the SMUs are 
identified as SMU1 and SMU2, corresponding to the network 
analyzer test ports: this helps to facilitate measurement of a 
BJT with only two SMUs, since the port 2 SMU is used for 
measurements at both the collector and emitter terminals. 
Some models use more than two SMUs: their SMU names are 
defined in their respective chapters.

The following figure illustrates the SMU unit names for a FET 
measurement and the correspondence to the device terminal 
connections.
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The following figure illustrates the SMU unit names for a 
Gummel-Poon BJT measurement and the correspondence to the 
device terminal connections

1 In the Instrument List click on HP4142 to highlight it. Select 
Configure and the Configuration of HP4142 window is 
displayed.

2 The Unit Table lists the SMUs. Also listed for each is a unit ID 
(identification) name that can be edited.

• In a FET measurement, the medium-power MPSMU1 is 
renamed VG, because it is connected to the gate terminal; 
and the high-power HPSMU3 is renamed VD, because it is 
connected to the drain terminal.

• In a Gummel-Poon BJT measurement, the medium-power 
MPSMU1 is renamed SMU1 because it is the port 1 SMU; 
and the high-power HPSMU3 is renamed SMU2 because it 
is the port 2 SMU.

Figure 201 SMU Unit Names for a FET Measurement

Figure 202 SMU Unit Names for a BJT Measurement
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3 To make this change, click left with the mouse and move the 
mouse pointer over the name assigned to MPSMU1 to 
highlight it. Then type in the new name, and press Return. 
Similarly, change MPSMU3’s assigned unit name. Then select 
OK to close the configuration window. 

4 To save this hardware configuration in a file for future use, 
select File > Save. A file filter is displayed, showing the 
pathname of the current directory. Type in an appropriate 
name for the .hdw file you are creating, and select OK.

5 Close the hardware window.

After IC-CAP is configured to recognize the system hardware, 
you can proceed to one of the modeling chapters.
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Defining the DC Source/Monitor Instrument State

NOTE For details on IC-CAP instrument options (instrument states) for specific 
instruments, refer to Chapter 1, “Supported Instruments,” in the 
Reference manual.
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IC-CAP provides remote control of the DC source/monitor and 
the network analyzer to measure the device under test. This 
procedure configures IC-CAP with the instrument state settings 
(instrument options) for the DC source/monitor.

Use this procedure if you have been referred here from one of 
the device modeling procedures.

You will need to set the DC source/monitor instrument state 
separately for each DC or DC-biased measurement setup in a 
modeling procedure. However, use the same settings for all the 
measurement setups in one model (except that Integ Time can 
differ among setups). Unless you use the default settings 
documented here, it is helpful to write down the settings to 
duplicate in the other setups.
NOTE DC signal levels and other input parameters that differ among 
measurement setups are not set in this procedure, but in the individual 
setup procedures in each model chapter.
The settings used in this procedure are defaults and the 
explanations are general.

1 Select the DC measurement setup of your choice.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states for the DC 
source/monitor. Figure 203 illustrates example DC 
source/monitor instrument states. 

3 Set each of the DC source/monitor measurement parameters 
according to the actual Agilent 4142 configuration and the 
device to be measured, using the guidelines in the following 
steps.
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4 Set Use User Sweep to No, as it is unnecessary for these 

procedures, and the source/monitor internal sweep is faster.

5 Hold Time is the delay in seconds before starting a sweep, to 
allow for DC settling. Generally, no hold time is required.

6 Delay Time is the time in seconds the instrument waits 
before taking a measurement at each step of a sweep. 
Generally no delay time is needed.

7 For Integ Time, M (medium) is a good default choice. In 
measurements where a long integration time is needed for 
noise reduction, you would use L (long), and you will be 
instructed to do so in certain procedures. You can speed up a 
measurement by using S (short), but this is not 
recommended because it degrades the dynamic range of the 
measurement.

8 Set Range to 0 to implement SMU autoranging.

9 Power Compliance is used to set the maximum 
current/voltage combination for the DC source/monitor. 
However, in the models, SMU voltage and current 
compliances are set individually in the individual setups. 
Therefore the value here can be set to 0.000.

Figure 203 Example Agilent 4142 DC Source/Monitor Instrument State
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10 Set SMU Filters ON to Yes. This switches in low-pass filters 
on the SMU outputs, to protect the device from voltage spikes 
caused by DAC output changes.

11 High-frequency IC-CAP is not generally configured for pulsed 
measurements, therefore Pulse Unit can be left blank. All 
other Pulse settings are then irrelevant and can be ignored.

12 Module Control is not used in these procedures: leave the 
field blank.

13 Init Command sets the instrument to a mode not supported 
by other fields in this table. It is not generally used in these 
models. Leave the field blank unless instructed otherwise.

14 If you wish, refer to the DC source/monitor manual for more 
detail.

15 If the measurement setup you are configuring calls for a DC 
measurement only, close the instrument options window. 
Then return to the modeling procedure.

16 If the setup also calls for a network analyzer measurement, 
continue to “Defining the Instrument States for S-Parameter 
Measurements” on page 624.
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Defining the Instrument States for S-Parameter Measurements

NOTE For details on IC-CAP instrument options (instrument states) for specific 
instruments, refer to Chapter 1, “Supported Instruments,” in the 
Reference manual.
624

 

IC-CAP provides remote control of the DC source/monitor and 
the network analyzer to measure the device under test. These 
procedures configure IC-CAP with both the DC source/monitor 
and the Agilent 8753 network analyzer instrument states for 
S-parameter measurements. The first procedure sets the 
instrument states for a broadband swept-frequency 
measurement, and the second for a CW measurement.
Instrument States for Swept Frequency Measurements 
Use this procedure if you have been referred here from one of 
the device modeling chapters.

You will need to set the instrument states separately for each 
measurement setup in a modeling procedure. However, use the 
same settings for all the swept S-parameter measurement 
setups in one model (except that Integ Time can differ among 
setups). Unless you use the example settings documented here, 
write down the settings you use, to duplicate among setups 
within one model. 

The settings used here are examples. Your settings may differ. 
Explanations here apply to all swept-frequency S-parameter 
measurements in the different device measurement procedures.
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NOTE Source parameters such as frequency range are not set in this procedure, 
but in the individual S-parameter setup procedures in each model chapter.

Do not use these settings for a CW S-parameter measurement. The 
settings for a CW measurement are slightly different, and are documented 
following this procedure.
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1 Select the swept S-parameter setup of your choice.

2 Select the Instrument Options tab, and a window will be 
displayed showing the instrument states. The following figure 
shows an example.

3 Set the Agilent 4142 instrument state the same as for the DC 
measurements.

Figure 204 Instrument States for Swept Frequency Measurements with 
Agilent 8753D
olume 2 625



626

C Using IC-CAP with an Agilent 85123A Device Modeling System
 

4 Set the Agilent 8753 instrument state according to the actual 
hardware configuration, the calibration used, and the device 
to be measured, following these guidelines:

5 Set Use User Sweep to No, because this is a standard internal 
sweep.

6 Hold Time is the time in seconds before the instrument starts 
a sweep, to allow for DC settling. Generally, no hold time is 
required.

7 Delay Time is the delay in seconds the instrument waits 
before setting each frequency. No delay is needed here, but 
the default is 100 ms.

8 Port 1 Source Power and Port 2 Source Power are used with 
an analyzer that has an integrated test set. Set the power to 
the same level as in the network analyzer calibration. Take 
care that the power level will not be excessive at the device 
input or at the input port samplers of the analyzer. The 
default is -10 dBm.

9 Port 1 Power Range and Port 2 Power Range are used with an 
analyzer that has an integrated test set. The synthesized 
source in the analyzer contains a programmable step 
attenuator with eight power ranges. This lets you determine 
which range is used: the default is 0.

10 Port 1 and Port 2 Auto Power Range are used with an 
analyzer that has an integrated test set. These settings enable 
an autoranging power level and attenuation capability. The 
default IC-CAP setting is No.

11 Coupled Port Power is used with an analyzer that has an 
integrated test set. It couples port 2 to the port 1 power 
settings, ignoring the settings for port 2. The default is Yes, to 
couple the ports together.

12 If you calibrate with a power slope, set the corresponding 
value for Power Slope here, to better view the response of a 
device with power drop-off at higher frequencies. The units 
for power slope are dB/GHz; the default value is 0.000. (A 
network analyzer message will caution you that the 
correction may be invalid, but this can be ignored.)

13 Set the same Sweep Time as in the network analyzer 
calibration. You can check this on the network analyzer in 
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LOCAL mode by pressing MENU > SWEEP TIME. If you set a 
reduced IF bandwidth for calibration, the sweep time may 
have been slowed down automatically.

14 Set IF Bandwidth to the same value as in the calibration. The 
noise floor can be reduced by reducing the receiver input 
bandwidth.

15 Set Use Fast CW to No, because fast CW is not compatible 
with the instrument calibration.

16 Set Avg Factor to the same averaging factor you set in the 
calibration. 

17 Set Cal Type to H (hardware) so that IC-CAP will recognize 
calibration device measurements at the network analyzer 
front panel.

18 Cal Set No must be set to the analyzer register number where 
you store your swept broadband calibration. Do not use 
register 6, which stores the active instrument state.

19 Soft Cal Sequence refers to the sequence of measurements of 
the cal standard devices: load-open-short-thru. You can set a 
different sequence if you prefer.

20 Delay for Timeouts increases the timeout and wait times. It 
can generally be set to the default value of 0.000.

21 If you define a specific number of points for the 
measurement calibration, set Use Linear List to No, the 
normal setting for a swept measurement. The setting would 
be Yes for a log or list sweep.

22 If necessary, refer to the “Application and Operation 
Concepts” chapter of the Agilent 8753C Operating Manual 
for more detail.

23 Close the instrument options window. Then return to the 
modeling procedure.
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Different Settings for Agilent 8753 with External Test Set

An Agilent 8753 with an external test set uses different settings 
for power level and attenuation. Also, these analyzers do not 
have the power autoranging or coupled port power functions. 
These are the different settings:

1 Port 1 Atten and Port 2 Atten must be set to the same level of 
attenuation you set in the network analyzer calibration. The 
default is 20 dB.

2 Source Power must be set to the same level as in the network 
analyzer calibration. The default is −10 dBm.
Instrument States for CW Frequency Measurements
Use this procedure if you have been referred here from one of 
the device modeling chapters.

You will need to set the instrument states separately for each 
measurement setup in a modeling procedure. However, use the 
same settings for all the CW S-parameter measurement setups 
in one model (except that Integ Time can differ among setups). 
Unless you use the settings documented here, write down the 
settings you use, to duplicate among setups within one model.

The settings used here are examples. Your settings may differ. 
Explanations here apply to all CW S-parameter measurements 
in the different device measurement procedures.

1 Select the CW S-parameter setup of your choice.

2 Select the Instrument Options tab and a window will be 
displayed showing the instrument states. The following figure 
shows an example.
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3 Set the Agilent 4142 instrument states the same as for the DC 
measurements.

Figure 205 Instrument States for CW Frequency Measurements with 
Agilent 8753D
NOTE The network analyzer instrument state settings for a CW-frequency 
S-parameter measurement are the same as for a swept S-parameter 
measurement, with the following exceptions:
4 Set Use User Sweep to Yes because CW is a nonstandard 
sweep.

5 Be sure to set the source power and attenuation levels the 
same as in the network analyzer calibration.
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6 Set Cal Set No to the analyzer register number where you 
stored your CW calibration. This must be different from the 
register used by the swept broadband calibration, and from 
any other CW calibration you make at a different frequency 
for any different measurement.

7 You can set Use Linear List to either Yes or No. This setting is 
ignored by IC-CAP for a CW measurement.

8 Close the instrument options window. Then return to the 
modeling procedure.
 

NOTE For more information about IC-CAP instrument options (instrument 
states), refer to Chapter 1, “Supported Instruments,” in the Reference 
manual.
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Calibrating the Network Analyzer
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The network analyzer must be calibrated before any 
S-parameter measurements are performed. The system must be 
allowed to warm up for at least 1 hour before calibration, and 
the calibration standards must be at ambient room 
temperature. It is a good practice to switch on the analyzer and 
expose the calibration devices to air before you make the DC 
measurements.

Good calibration of the network analyzer system is critical to a 
good high-frequency measurement and extraction. A good 
calibration is dependent on the quality of the calibration kit 
standard devices, the care with which they are maintained, and 
the correctness and repeatability of the device connections. A 
stable ambient temperature (±1°C) is required to maintain a 
good calibration.

For the high-frequency IC-CAP measurement procedures, the 
network analyzer is calibrated over a broadband frequency 
range, to perform the S-parameter measurements for AC and 
parasitic extractions. In addition, one or two calibrations may 
be needed at CW frequencies for specific measurement setups. 
These procedures explain how to set up a broadband calibration 
and a separate CW calibration. For the Agilent 8753 and 8720 
systems, IC-CAP does not support the subset calibration 
technique used for an Agilent 8510 system.

The instructions given here are very abbreviated: more detailed 
information is available in the Agilent 8753 operating manual.
NOTE It is important that values entered in software correspond with actual 
instrument settings. Be sure to write down the parameters of your 
calibrations, so that they are readily available when you need to enter 
them in IC-CAP.
olume 2 631



632

C Using IC-CAP with an Agilent 85123A Device Modeling System
 

To connect the network analyzer:

Disconnect the terminations from the bias networks. Connect 
the RF cables from the network analyzer test ports to the RF 
inputs of the bias networks.
Swept Broadband Calibration
1 In the IC-CAP model, select the S-parameter setup of your 
choice.

2 In the measurement setup, set the instrument options 
appropriately for your measurement. (See “Defining the 
Instrument States for S-Parameter Measurements” on 
page 624.)

3 You can set the network analyzer manually from its front 
panel, or use the IC-CAP Calibrate command in the setup 
menu to download the instrument options into the network 
analyzer. In either case, you perform the cal standards 
measurements at the analyzer front panel.

4 The following steps explain how to perform a manual 
network analyzer front panel calibration.

5 On the network analyzer, press LOCAL to gain front panel 
control. Press PRESET to return to a known standard state.

6 If you are using a system with the 6 GHz receiver option and 
you wish to measure in the 3 MHz to 6 GHz range, press 
SYSTEM > FREQ RANGE 3GHz6GHz.

7 To define the frequency range of the calibration and 
measurement, press START, and use the numerical keypad to 
set the start frequency, ending with one of the terminator 
keys (such as G/n) at the right of the keypad. Similarly, press 
STOP and set the stop frequency. Set a frequency range at 
least as wide as the operating range of the device.

8 Press MENU > NUMBER OF POINTS, and enter the number of 
points to be measured across the range. Allow enough points 
to provide good measurement resolution: at least 51 points 
are recommended. 

9 Press MENU > TRIGGER MENU > CONTINUOUS to set a 
continuous stimulus sweep.
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10 Press MENU > POWER, and set the desired power level. In 
setting the source power and test set attenuation, take care 
that the power level will not be excessive at the device input. 
Also consider the gain of the device, and set a power level 
that will not saturate the input port samplers of the analyzer. 
If a receiver input is overloaded (>+14 dBm), the analyzer 
automatically reduces the output power of the source to 
−85 dBm and displays the error message OVERLOAD ON INPUT 
(R, A, B) POWER REDUCED. In addition, the annotation P↓  
appears in the left margin of the display to indicate that the 
power trip function has been activated. When this occurs, 
reset the power to a lower level, then toggle the SOURCE 
PWR on/OFF softkey to switch on the power again.

11 For a device with power dropoff at higher frequencies, you 
may wish to set a power slope using the SLOPE ON/off 
softkey. An appropriate power slope would be in the region 
of 2-3 dB/GHz.

12 Press AVG > AVERAGING FACTOR, and enter an averaging 
factor high enough to reduce trace noise and increase 
dynamic range as appropriate for your device measurements. 
A good default averaging factor is 256. To speed your 
measurements, you may find it convenient to set an 
averaging factor as low as 16. Press AVERAGING ON.

13 You can further reduce the noise floor by reducing the 
receiver input bandwidth. Press IF BW, and enter one of the 
following allowed values in Hz: 3000, 1000, 300, 100, 30, or 
10. A tenfold reduction in IF bandwidth lowers the 
measurement noise floor by about 10 dB; however, the sweep 
time may be slower. For more information on averaging and 
the different trace noise reduction techniques, refer to the 
Agilent 8753 operating manual.

14 Press CAL > CAL KIT, and select the appropriate default or 
user-defined cal kit for your calibration devices.

15 If you wish to modify an internal calibration kit definition 
(see below), do so now.

16 Press CAL > CALIBRATE MENU, and perform the calibration 
of your choice at the analyzer front panel, measuring each of 
the standard devices in turn and pressing the softkeys as 
each measurement is complete. A full two-port cal provides 
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the greatest accuracy. A TRL* or LRM* cal is an appropriate 
alternative for in-fixture measurements. Omit isolation cal. 
Press DONE, and save the cal in the register number 
specified in the instrument options table. This must be a 
different register than you use for any CW cal.

17 Detailed procedures for measurements of calibration 
standards are provided in the Agilent 8753 operating 
manual.
CW Frequency Calibration

NOTE A CW frequency calibration is similar to a broadband calibration with some 
exceptions. Repeat the procedure used for a broadband calibration, with 
these changes.
1 To set the CW frequency, press MENU > CW on the analyzer, 
and enter the frequency using the numerical keypad and one 
of the terminator keys.

2 Make a separate set of standards measurements.

3 When you save the calibration, use the cal register number 
specified in the instrument options table for this CW cal. This 
must be a different register than you used for the swept cal or 
any other CW cal.
NOTE You can store instrument states and calibration data to an external disk, 
and restore them to the internal instrument registers as needed. Refer to 
“Memory Allocation” or “Saving Instrument States” in the Agilent 8753 
operating manual for more information.
After the network analyzer is calibrated, return to the modeling 
chapter you are using for the S-parameter measurement 
procedures.
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Alternatively, you can use the IC-CAP Calibrate command for a 
broadband or CW calibration. This downloads the instrument 
states from IC-CAP to the network analyzer before you perform 
a calibration with the analyzer. This helps to avoid errors in 
matching values set in the analyzer and in IC-CAP.

1 In the IC-CAP model, select the S-parameter setup of your 
choice.

2 In the measurement setup, set the instrument options 
appropriately for your measurement.

3 From the setup menu select Calibrate. The instrument options 
are downloaded into the analyzer, together with the 
frequency stimulus values set in the Inputs.

4 The message Calibrate HP8753.7.16 before measuring is 
displayed. Select OK and perform the cal standards 
measurements from the analyzer front panel. Save the cal in 
the register specified in the instrument options.
 
Modifying a Cal Kit Definition
The network analyzer’s internal calibration kit models are 
accurate for use with the standard coaxial calibration kits 
defined for use with the Agilent 8753. In certain circumstances, 
however, you may need a user-defined kit for compatibility with 
your calibration standards. Some possible cases might be these:

• If you are using a probe station and you know the probe 
capacitances, you can enter them into the cal kit definition so 
that their effects can be removed by the measurement 
calibration.

• The impedance of an on-wafer load may not be exactly 50Ω. 
You can characterize the DC impedance of a load exactly with 
a precision ohmmeter measurement, and enter the 
impedance value into the cal kit definition.

The procedure to modify an internal cal kit definition is 
complex, and not to be undertaken without a solid 
understanding of error correction and the system error model. 
It is explained in detail in Product Note 8510-5, Specifying 
Calibration Standards for the Agilent 8510 Network Analyzer 
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(Agilent literature number 5954-1559). For information specific 
to the Agilent 8753 network analyzer, including an example 
procedure, refer to the Agilent 8753 operating manual.

For information on the characteristics of calibration standards 
used with a fixture or probe station, refer to the manufacturer’s 
device data sheets or other documentation.
TRL* Calibration Under IC-CAP Control
The Agilent 8753D network analyzer has the capability to 
perform a TRL* or LRM* calibration using internal firmware. 
TRL* (TRL-star) is an implementation of TRL that has been 
adapted for three-sampler network analyzers for use in fixtured 
measurement environments. (Note that this requires that you 
modify a user cal kit definition: see above.)

Earlier models of the Agilent 8753 do not have the internal 
TRL* calibration capability. The IC-CAP procedure described in 
the following pages allows you to perform a similar Agilent 
8753C calibration using TRL cal standards compatible with 
your fixture. IC-CAP calculates the error coefficients and 
downloads them into the network analyzer. The procedure can 
be used for either a TRL* (thru-reflect-line) or TRM* 
(thru-reflect-match) calibration. 

When the calibration is complete, the reference plane is defined 
at the middle of the thru standard, or at the interface to the 
DUT when it is installed in the compatible carrier.

For more information about TRL* calibration, refer to Product 
Note 8720-2, In-fixture microstrip device measurements using 
TRL* calibration, Agilent literature number 5091-1943E.
NOTE The network analyzer GPIB address must be set to 16. It is recommended 
that you connect 10 dB pads at the RF IN connectors of both bias 
networks to improve the effective source and load match of the 
measurement setup.
The IC-CAP software for the TRL* calibration is in the model 
file TRLCAL.mdl. Find the TRL* calibration model under:
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/examples/model_files/misc/TRLCAL.mdl

The message WARNING: HP8753.7.16 Options saved in 
TRLCAL/cal/short (or another filename) may be displayed. In this 
case, you will need to perform a Rebuild, as explained under 
“Performing Hardware Setup in IC-CAP” on page 617.

The TRL* Calibration DUTs and Setups

The following figure illustrates the DUTs and setups for 
TRLCAL.mdl. 

The SETUPs are used to collect the measured raw S-parameters 
of various TRL (or TRM) standards, using variable values 
defined by you in the macros. IC-CAP computes the required 
error coefficients from this raw S-parameter data.

The TRL* calibration uses separate setups for a swept frequency 
cal (cal_sw) and a CW frequency cal (cal_cw), which are both 
required in some modeling procedures. For the Agilent 8753 
and 8720 systems, IC-CAP does not support the subset 
calibration technique used for an Agilent 8510 system, therefore 

Figure 206 TRLCAL DUT/Setup Panel
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two sets of standards measurements are required. IC-CAP 
stores measured data in the setups for both the swept and CW 
cals.

The README macro provides an abbreviated set of instructions 
for the TRL* calibration procedure. The other macros provide 
interactive prompts for defining the instrument states and 
calibration frequencies, and for performing the calibration.

Definitions: Standards and Measurement Setups

The IC-CAP TRL* calibration requires measurements of three or 
more standard devices: a short, a thru, and at least one line 
standard (for TRL*) or match standard (for TRM*). The 
performance characteristics of the standards must be specified 
over the frequency range of the calibration. Therefore it may be 
necessary to use as many as three line standards to cover the 
total frequency range for a swept frequency cal. If so, you will 
need to define the transition frequencies between the line 
standards.
 

CAUTION Some confusion can arise concerning the transition frequencies 
between the line standards, because the setup names do not 
necessarily correspond with the actual line standard names. Read the 
explanations in this and the following two pages to prevent possible 
problems in the way IC-CAP processes the calibration data.
Measurement Setups

The setups in the TRLCAL model measure the calibration 
standards, and store the measured raw S-parameter data in 
files with the same names as the setups. Each standard is 
measured over the full frequency range of the calibration. 
However, if multiple line standards are used, IC-CAP processes 
only the data delimited by the transition frequencies to 
compute the error coefficients of each. For a CW cal, IC-CAP 
processes only the data measured at the CW frequency you 
specify. The setups are used as follows:
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Short: Measures the short standard and stores the measured 
data.

Thru: Measures the thru standard and stores the measured 
data.

LineA: Measures the first (lowest frequency) line standard and 
stores the measured data. In calculating the error coefficients 
for a swept frequency cal, IC-CAP uses only the data from the 
start frequency to the first transition frequency, or to the stop 
frequency if an above-range or zero-value first transition is 
defined. (You will define the calibration range and the 
transition frequencies later in the procedure.) The lineA 
standard can be represented either by a length of transmission 
line for a TRL* cal, or by a matched load for a TRM* cal.

LineB: Measures the second line standard (if any) and stores 
the measured data. In calculating the error coefficients for a 
swept frequency cal, IC-CAP uses only the data from the first 
transition frequency to the second transition frequency, or to 
the stop frequency if an above-range or zero-value second 
transition is defined. Typically the standard measured is a 
length of transmission line different from either the thru or 
lineA standards.

LineC: Measures the third line standard (if any) and stores the 
measured data. In calculating the error coefficients for a swept 
frequency cal, IC-CAP uses only the data from the second 
transition frequency to the stop frequency. Typically the 
standard measured is a length of transmission line different 
from either the thru, lineA, or lineB standards.

Transition Frequencies of Line Standards

Your calibration kit may have only one line (or match) standard, 
or it may have more than one line standard, each specified over 
a portion of the total specified cal kit frequency range. Refer to 
the data sheet for your calibration kit to determine the specified 
frequency ranges of each of the devices. For the RF frequency 
range you wish to measure, you may need to measure all the 
line standards, or you may need to measure only one or two. If 
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you measure more than one line standard, the specified upper 
frequency limit for the first line standard is the first transition 
frequency. Similarly, the specified upper frequency limit for the 
second line standard is the second transition frequency.

For example, if your total measurement frequency range is 
300 kHz to 6 GHz and your first line standard is specified from 
300 kHz to 1 GHz, then your first transition frequency is 1 GHz. 
If your second line standard is specified from 1 GHz to 5 GHz, 
then your second transition frequency is 5 GHz.

The TRLCAL.mdl file provides for measurements of up to three 
line standards for a swept frequency cal. If you use only one or 
two, you can define transition frequencies above the range of 
the calibration, and IC-CAP defaults to the start and/or stop 
frequencies. For example, if your total measurement frequency 
range is 300 kHz to 3 GHz and your second line standard is 
specified from 1 GHz to 5 GHz, you can set the second transition 
frequency to 5 GHz (or 0), and IC-CAP will measure the second 
line from 1 GHz to 3 GHz.

Measurement Setup Names vs. Actual Standards Names

The measurement setup names may not correspond with the 
names of the standards in your calibration kit. It is important to 
understand that the setup names are only filenames for the 
measured data. The actual fixtured standards you use for the 
line measurements will depend on the frequency range of your 
calibration, not on the names of the setups.

You must use the lineA setup for your lowest frequency line (or 
match) measurement, even if the cal standard you use is not 
line 1 in your calibration kit. This is because IC-CAP processes 
measured data from the setup files in the sequence they are 
shown in the model editor window. If a file is left empty (for 
example lineA), IC-CAP will stop processing data, even if there 
is measured data in lineB or lineC. 

For example, you may have a calibration kit with a frequency 
range of 300 kHz to 6 GHz, and you may be calibrating for device 
measurements over a range of only 5 GHz to 6 GHz, using a 
short, a thru, and a single line (or match) standard. In this case, 
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you will use the lineA setup to measure your line or match 
standard that is specified for performance over the 5 GHz to 
6 GHz frequency range, no matter how it is labeled.

If you are performing a CW cal alone, you must use the lineA 
setup for your line or match measurement. 
Defining the IC-CAP TRL* Cal Instrument States
 

IC-CAP controls the network analyzer in measuring the 
calibration standards. These procedures configure IC-CAP with 
the required network analyzer instrument states to measure the 
TRL* calibration standards for the swept frequency and CW 
frequency cals for both the Agilent 8753D and earlier-model 
Agilent 8753s. (Instrument states are similar for Agilent 
8720-family instruments, and are explained in Chapter 1, 
“Supported Instruments,” in the IC-CAP Reference manual.) 
The Instr_opts macro lets you define the instrument state once 
for each cal and load it into all the corresponding measurement 
setups.

1 Select the Macros tab. Select the Instr_opts macro, and Execute. 
The instrument options window illustrated in the following 
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figure is for the short setup for a swept frequency cal using 
an Agilent 8753D. 

2 In the dialog box, select OK as prompted, then make any 
instrument state changes required for your calibration and 
measurements, using the illustrations and the following 
instructions for guidance. The illustrated values are typical 
defaults for a TRL* calibration used for measuring BJTs. The 
settings you use may be different, depending on the 
characteristics of the devices you intend to measure and 
model.

Figure 207 TRL* Cal Instrument States for Swept Measurements with 
Agilent 8753D
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Swept Measurements with Agilent 8753D

1 For swept measurements, set Use User Sweep to No because 
this is a standard internal sweep.

2 Set the source power level in dBm to 0.000 for measurements 
below 3 GHz. For measurements above 3 GHz, 20.00 is 
appropriate. The power levels are tied to the frequency range 
set in Init Command, below.

3 1000 Hz is a good default value for IF bandwidth. Reducing 
the IF bandwidth lowers the noise floor, at the cost of slowing 
the sweep speed. Allowed IF bandwidth values in hertz are 
3000, 1000, 300, 100, 30, and 10.

4 Set Use Fast CW to Yes for a swept frequency measurement, 
to minimize repeated switching between the test set ports.

5 Cal Type (SHN) refers to software/hardware/none. Set it to N 
for “none.” This is because the measurements you will make 
in this cal procedure are uncalibrated measurements. The 
finished calibration set will be used in your later 
measurement and modeling procedures.

6 Set Cal Set No to cal_reg, a variable used by the program.

7 The setting you use for Soft Cal Sequence is irrelevant, since 
Cal Type is set to None.

8 Set Use Linear List to No, otherwise the Agilent 8753 will be 
set to frequency list mode.

9 Set Init Command to FREQRANG3GHZ if you are using a 
standard Agilent 8753 network analyzer. (If you are using an 
Agilent 8753 with the 6 GHz extended frequency option and 
measuring above 3 GHz, enter FREQRANG6GHZ.)

Swept Measurements with Earlier-Model Agilent 8753

The window illustrated in the following figure is for the short 
setup for a swept frequency cal using an earlier-model Agilent 
8753.
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We recommend you use the same attenuator settings at port 1 
and port 2, since the earlier Agilent 8753 analyzer uses the 
same attenuator for both ports. In setting power levels, you will 
need to set a source power sufficient to maintain phase lock, 
while taking care not to saturate the device output. Settings of 
10 to 20 dB attenuation at both ports with a source power level 
of 0 dBm are appropriate for many devices with gain.

Figure 208 TRL* Cal Instrument States for Swept Measurements with 
Earlier-Model Agilent 8753 (>3 GHz)
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CW Measurements

1 Some of the instrument state settings for the TRL* CW cal are 
the same as for the swept frequency cal. The following 
settings are different, as illustrated:

2 For CW measurements, set Use User Sweep to Yes.

3 You may not need to set attenuation for CW measurements, 
since gain may not be a factor. The CW measurements are 
usually used to determine the junction capacitance of a 
device. For this purpose the device is biased in such a way 
that it has loss rather than gain.

4 Set Use Fast CW to No.

Figure 209 TRL* Cal Instrument States for CW Measurements with Agi-
lent 8753D
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5 When you have completed the settings, select the Instr_dupl 
macro, and Execute. This macro loads the short instrument 
options for the swept frequency cal into the other cal_sw 
setups; and the short options for the CW cal into the other 
cal_cw setups (thru, lineA, lineB, lineC).

Figure 210 TRL* Cal Instrument States for CW Measurements, Earlier 
Agilent 8753
NOTE When you execute the Instr_dupl macro, the macro must write files to 
disk. If the instrument options do not load down, your working directory 
probably does not have write permission set. To correct this, from your 
working directory type, chmod 644 <directory_name> and press 
Enter.
6 A message in the UNIX window will tell you when the 
instrument options are duplicated in all the setups. Ignore 
any does not cascade warnings.
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You define the values for frequency range, number of 
measurement points, and transition frequencies between line 
standards in the Cal_freqs macro, as follows:

1 Select the Cal_freqs macro, and Execute. A dialog box will be 
displayed. 

2 Enter the start frequency for your swept frequency 
calibration as prompted, and select OK.

3 Enter the stop frequency and select OK. The stop frequency 
must be greater than the start frequency.

4 At the prompt to enter the number of frequency points, use 
one of the following Agilent 8753 allowable values:

5 If you are doing a CW cal along with the swept cal, enter the 
CW frequency. If not, enter 0. (If you are doing a CW cal 
alone, refer to the Note below.) Select OK.

6 If you are using more than one line/match standard, enter 
the transition frequency for the first line (between lineA and 
lineB). Select OK.

7 If you are using three line standards, enter the transition 
frequency for the second line (between lineB and lineC). 
Select OK.

8 If you are using only one or two line standards, enter 
above-range or zero-value transition frequencies for the 
setups that do not apply. IC-CAP will measure only from the 
start to the stop frequency.

Refer to the paragraphs under “Definitions: Standards and 
Measurement Setups” on page 638 for explanations of 
transition frequencies and the difference between the 

3 11 26 51

101 201  401 801

1601
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software setup names and the hardware standards names. 
The information there can prevent possible problems in the 
way IC-CAP processes the data.

9 When you have defined all the calibration frequencies, the 
UNIX window will list them, and will conclude with the 
message Completed.
Performing the Calibration

NOTE If you are doing a CW cal alone (instead of with a swept cal), enter a value 
of 0 to the prompts for start frequency, stop frequency, and number of 
points. Remember to use the lineA setup for your line/match 
measurement. The Calibration macro will subsequently provide only 
prompts that apply to a CW cal.
The Calibration macro provides a series of prompts to guide you 
through the standards measurements. In this part of the 
procedure, you follow the prompts to connect the defined 
standards, and instruct IC-CAP to measure them. You then 
specify network analyzer registers to store the swept and CW 
calibrations, and IC-CAP calculates the error coefficients from 
the measured raw  S-parameter data, then downloads them into 
the analyzer registers.

1 Select the Calibration macro, and Execute.

2 IC-CAP displays a dialog box, prompting you to perform the 
standards measurements you have defined. In each case, 
first connect the standard, then respond to the prompt by 
entering s for short, t for thru, A for the lineA setup, B for 
the lineB setup, and C for the lineC setup. Each time you 
enter a single letter, press Return. A message in the UNIX 
window tells you the standard is measured. 
CAUTION Be sure to connect the calibration devices that correspond with the 
frequencies you defined in the Cal_freqs macro. Otherwise your 
calibration may be compromised. For more information, refer to 
“Definitions: Standards and Measurement Setups” on page 638.
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3 Following this prompt sequence, a dialog box asks you Done? 
[y/n]. If all the necessary cal standards have been measured, 
type y and select OK. (If you want to remeasure a standard, 
type n, reconnect the device, and type the appropriate 
character for the device setup. IC-CAP will remeasure, and 
replace the old data with the new.)

4 The next dialog box asks you to enter the calibration storage 
register for the swept cal. Type in a number between 1 and 4, 
and select OK. (Do not use register 5, because IC-CAP 
reserves it for temporary storage.) IC-CAP calculates the 
error coefficients, downloads them into the network 
analyzer, and turns on the analyzer calibration.

5 Next enter a different register number for the CW calibration, 
and select OK. IC-CAP performs the CW cal and downloads it.

6 The instrument state and calibration are saved in the 
analyzer’s short-term non-volatile memory (that is, even if 
the instrument is switched off for as long as 72 hours).

7 Whenever you use these swept and CW TRL* calibrations for 
a modeling procedure, enter the corresponding register 
numbers in the Cal Set No field of the IC-CAP instrument 
options window. Also set the Cal Type (SHN) field to H for 
hardware.

If you wish to verify the calibration, you can return the network 
analyzer to local operation and make a calibrated thru 
measurement.
Saving the Calibration Data in IC-CAP
When the calibration is complete, save the model file with the 
measured standards data in it, so that you can always quickly 
retrieve the error coefficients and re-enter them into the 
network analyzer:

1 Select File > Save As.

2 In the dialog box that appears, type in an appropriate 
pathname and filename. Examples of possible filenames 
might include the calibration date or frequency, such as 
TRLCAL_101597.mdl or TRLCAL_6GHz.mdl. Select OK. First 
the CW cal is saved in one analyzer register using the variable 
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cal_reg_cw; then the swept cal is saved in another register 
using the variable cal_reg_sw.

3 When you want to retrieve the error coefficients at some 
future time, read in the .mdl file you saved. Select the thru 
setup for either the swept or CW cal. Make sure the Agilent 
8753 instrument state corresponds exactly to the instrument 
options in the thru setup. Select the CalHP8753 transform, and 
Execute. IC-CAP will calculate the error coefficients, 
download them into the network analyzer, and turn on the 
analyzer calibration. 

Press LOCAL on the analyzer to return it to front panel 
control, then press SAVE and a register softkey to save the cal 
in one of the analyzer’s memory registers.

This ends the procedures for TRL* calibration under IC-CAP 
control.
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This appendix provides information on using IC-CAP model 
data in the Agilent RF and Microwave Design System (MDS).
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It is important that model data is saved correctly at the end of a 
parameter extraction or model generation procedure. Refer to 
the information on storing the model provided at the end of 
each of the model chapters. Note that the procedures are not 
necessarily the same in all cases.
IC-CAP Nonlinear Devices Models Volume 2



Using IC-CAP Data with MDS D
Reading IC-CAP Data into MDS
IC-CAP Nonlinear Devices Models V

 

Measured, simulated, and transformed IC-CAP data can be read 
into datasets in the Agilent RF and Microwave Design System 
(MDS). The standard compatible files are model, DUT, and setup 
files suffixed .mdl, .dut, and .set. However, these suffixes are not 
required: if the data is in the correct format, any file name or 
extension can be used.

When you are using MDS and wish to access an IC-CAP model, 
follow these steps:

1 Make the screen environment, a file icon, or any other 
collector environment active.

2 Use the menu command INSERT > DATASET and the mouse to 
insert a dataset icon. Rename the icon if desired.

3 Open the dataset icon.

4 When the index page appears, choose the menu command 
PERFORM > READ > ICCAP FILE (see the following figure).

Figure 211 Reading IC-CAP Data
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5 When the message appears at the top of the screen, type the 
name of the file that contains the IC-CAP data. If the data file 
is not in the current directory, type the full path name as well 
as the file name. Press Enter.

When the IC-CAP data file has been read, data packages are 
listed on the index page of the dataset. These correspond to 
setup names in the IC-CAP data file. The following figure shows 
an example.

Figure 212 IC-CAP Data Packages in MDS Dataset
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IC-CAP data files can be translated into HP CITIfile format 
using the program iccap2citi in the UNIX operating system 
environment. This is often convenient when many files are to be 
translated.

The program is located in:

$MDSROOT/hp85150/bin/iccap2citi

IC-CAP includes the most current version of the iccap2citi 
program in:

$ICCAP_ROOT/bin/iccap2citi

This version should be copied to the MDS directory, or be 
referenced via the MDS aliasing mechanism as described in 
the MDS documentation.

.iccap2citi
usage: iccap2citi [-msx] [file1] [file2]
or: iccap2citi [-ivmsx] file1 file2 
-p output model parameters only 
-l output model parameters only, in lib format 
-m skip MEAS data 
-s skip SIMU data 
-x skip XFORM data
-i interactively select data 
-v print names of all packages translated

On the command line, file1 is the file to be translated (the input 
file), and file2 is the file that results (the output file). These 
names are optional, however.

If no name is specified for the output file file2, the output goes 
to standard out. If neither an input file name file1 nor an output 
file name file2 is specified, the input is taken from standard in 
and the output is sent to standard out.

The file that results is in HP CITIfile format, and can be read 
into a dataset in MDS using the menu command PERFORM > 
READ > CITIFILE on the index page in the dataset.
olume 2 655



D Using IC-CAP Data with MDS
Reading Extracted Parameters from IC-CAP to MDS
656

 

You can access the individual model parameters saved in a 
SPICE deck, and read them directly into device models in the 
Agilent RF and Microwave Design System. This is done using 
the DDL script geticcap.ddl. Note that the model parameters 
must have been saved using the IC-CAP Save Extracted Deck 
function. Follow these steps:

1 On the MDS circuit page, insert the model or model form 
element: for example, BJTMODEL or BJTMODELFORM.

2 Choose the menu command PERFORM/DDL.

3 When the message appears asking for the name of the DDL 
command file (script), type geticcap.ddl. Then press 
Enter.

4 When the next message appears, type the name of the IC-CAP 
file that contains the extracted parameter values (the SPICE 
deck for the desired model). Press Enter.

5 When the next message appears, type the name of the model 
or model form component into which the extracted IC-CAP 
values will be read. For example, type CMP2. Press Enter.

The IC-CAP parameters will be read in and the model 
identification field MODEL will have the name that is used as 
the subcircuit name in the parameter file.

If the collector mounting capacitance appears in the parameter 
file, it is reported but is not used.
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Special considerations must be taken into account in reading 
the parameters from a SPICE deck using geticcap.ddl, for two 
reasons. First, the extrinsic parasitic elements are not part of 
the MOSFET device or model card and must be added by the 
user. Second, only one device can be inserted into MDS at a 
time, but the scalable level 3 MOS model measures three 
devices. Explanations follow.
Adding Extrinsic Parasitic Elements
 

The extrinsic parasitic elements RG, LGG, LDD, and LSS that 
appear below the .SUBCKT line in the SPICE deck are not part 
of the MOSFET device or of the model card. (The intrinsic 
resistance elements RS and RD are part of both the device and 
the model card.) In order to include these elements as part of 
your MDS circuit, you need to add them as separate devices 
connected appropriately to the model element, using the 
extracted values given in the SPICE deck.
Setting the Geometry Parameters
In addition to the extrinsic parasitics listed above, certain 
device geometry parameters listed above the .MODEL line in the 
deck are not part of the model card. The geometry parameters 
L, W, AD, PD, AS, and PS must be entered for the specific device 
you intend to simulate. In a scalable MOSFET extraction, three 
devices are measured (large, short, and narrow). However, when 
you insert a device into MDS you will use only one of the devices 
measured in the extraction, or a device of a different size. 
Decide which device you will simulate and enter the 
corresponding geometry values for that device into the deck, 
using PERFORM > EDIT COMPONENT. (If you use the 
nonscalable MOS model with measurements of only one device, 
you will of course use the geometry parameters for that device.

These are the descriptions and default values for the geometry 
parameters:
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AS, PD, and PS are used in the equations describing the 
junctions. The reverse current can be input either as IS (in A) or 
as JS in (A/m2). Whereas the first is an absolute value, the 
second is multiplied by AD and AS to give the reverse current of 
the drain and source junctions respectively. The same idea 
applies also to the zero-bias junction capacitances CBD and 
CBS (in F) on the one hand, and CJ (in F/m2) on the other. PD 
and PS multiply CJSW (in F/m) to obtain the perimeter 
capacitance. 

Table 53 MOSFET Level 3 Geometry Parameters

Parameter Description Default Value

L Channel length in meters. 100 µm

W Channel width in meters. 100 µm

AD Area of drain diffusion in square meters. 0.0

AS Area of source diffusion in square meters. 0.0

PD Perimeter of drain junction in meters. 0.0

PS Perimeter of source junction in meters. 0.0
Example SPICE Deck for MOSFET Level 3
The following is an example of an extracted SPICE deck for a 
high-frequency MOSFET level 3 model:
.SUBCKT mos3_nhfs 1 2 3 4
RG 22 12 7.061
LGG 2 22 1.694E−10
LDD 1 11 3.538E−10
LSS 3 13 3.591E−11
M1 11 12 13 4
+ NMOS
+ L = 1.5E−06
+ W = 0.000352
+ AD = 1.936E−09
+ PD = 0.000176
+ AS = 1.936E−09
+ PS = 0.000176
.MODEL NMOS NMOS
+ LEVEL = 3
+ NSUB = 1.898E+16
+ UO = 1390
+ VTO = 0.5171
+ TPG = 1
+ NFS = 7.547E+12
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+ TOX = 2.063E−08
+ NSS = 1E+10
+ VMAX = 1.546E+05
+ RS = 4.22
+ RD = 11.8
+ CBD = 5.518E−13
+ CJ = 0.000285
+ MJ = 0.2024
+ CJSW = 1.291E−15
+ MJSW = 0.1
+ IS = 1E−14
+ PB = 0.2972
+ FC = 0.5
+ XJ = 2.675E−07
+ LD = 1E−09
+ DELTA = 0.002
+ THETA = 1E−06
+ ETA = 0.2
+ KAPPA = 1E−06
+ CGSO = 2.113E−10
+ CGDO = 1.674E−10
+ CGBO = 0
+ XQC = 1
.ENDS
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You can use extracted IC-CAP parameter values to create 
devices in the Agilent RF and Microwave Design System, using 
the DDL script addiccap.ddl. Follow these steps:

1 In MDS, insert and open a file icon for the device to be 
created.

2 Open the file icon for the system microwave library mwlib 
and in it open the partition COMPONENTS and, in turn, the 
partition mns_only.

3 Use the menu command COPY and the mouse to copy the 
design icon for the device from the partition mns_only to the 
new file icon window. For example, copy the design icon 
BJTMODEL or BJTMODELFORM.

4 Rename this design icon, to avoid creating two devices with 
the same name. For example, add a number to the name, as 
in BJTMODEL8.

5 In the file icon window, choose the menu command PERFORM 
> DDL.

6 When the message appears asking for the name of the DDL 
command file (script), type addiccap.ddl. Then press 
Enter.

7 When the next message appears, type the name of the IC-CAP 
file that contains the extracted parameter values (the SPICE 
deck). Press Enter.

8 When the next message appears, type the name of the model 
or model form component into which the extracted IC-CAP 
values will be read. For example, type BJTMODEL8. Press 
Enter.

The IC-CAP parameters will be used to create a scion of the 
IC-CAP device in the MNS design icon, using the filename of the 
IC-CAP parameters. Devices with this name (and the individual 
device parameters) can now be used like other MDS model 
elements to create circuit schematics.
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For detailed information on the functions of the Agilent RF and 
Microwave Design System, refer to its documentation. 
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