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Introduction to SDR and GNU Radio

Introduction

Modern wireless communication systems process
signals as sampled digitized signals rather than as
analog signals. This is known as “Digital Signal Pro-
cessing” (DSP) and is used because of the lower cost
and lower power consumption of digital compared to
analog electronics.
Exceptions include the Analog Front End (AFE)

that converts between digital baseband signals and
the passband RF signal, RF power amplifiers and DC
power supplies, all of which are necessarily analog.
Most DSP basebands are implemented using

application-specific digital circuits to minimize costs
and power consumption. However, a sufficiently-fast
computer can also implement the baseband signal
processing. This is known as “Software Defined Ra-
dio” (SDR):
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GNURadio is an open-source project that develops
software for SDR systems. GNU Radio Companion
(GRC) is a graphical design tool that lets a user create
GNU Radio software without having to write code.
Blocks representing signal processing functions are
added to a diagram, configured, and interconnected
using a graphical user interface. This “flowgraph” is
then turned into an executable script that executes
the processing blocks in the required order to process
the samples. In this lab we will use GRC to configure
and run SDR software.
The advantages of GNU Radio and similar tools

such as MathWorks’s Simulink and National Instru-
ment’s LabView are that they don’t require pro-
gramming and that the flowgraphs can be self-
documenting. However, many users prefer program-
ming languages such as Matlab (e.g. using the Com-
munications Toolbox), because they are more flexi-
ble.
GNURadio and similar tools are also used to simu-

late communication systems. The simulations can be

used to optimize designs and to generate test vectors
for verification of DSP hardware.
AGNURadio flowgraph can send/receive samples

to/from radio hardware, files, network connections
and other GNU Radio flowgraphs1.
An example of a flowgraph created by GRC is

shown in Figure 1.

Dataflow Flowgraphs

It may appear from the flowgraph that the blocks op-
erate in parallel (simultaneously). However, since
the blocks are implemented in software they must
execute sequentially. This “dataflow” architecture
means that blocks execute only when they have data
to process. The order in which blocks are executed is
determined by a scheduler that examines the amount
of data available on the input ports of each block.
For efficiency reasons there are buffers between

blocks that allow blocks to process multiple sam-
ples each time the block is executed. However, this
buffering increases latency and can prevent proper
operation of certain delay-sensitive applications such
as those using feedback control (e.g. PLLs). Many
blocks allow themaximumbuffer sizes to be adjusted
to minimize latency.

Complex Baseband Representation

It is possible to down-convert a real bandpass signal
centered around a carrier frequency into a complex
baseband signal centered about zero (DC). The com-
plex baseband signal is centered on zero and, unlike
real signals, the frequency components are not con-
strained to have even (or odd) symmetry.
The complex baseband architecture reduces im-

plementation costs because receivers and transmit-
ters can be implemented using only low-pass filters
that can be integrated into ICs. This reduces costs by
reducing parts count and board space.

1Including those written in programming languages such as
Python, C++ and Matlab.
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Figure 1: GNU Radio Companion flowgraph for PRBS-modulated BPSK (2-QAM).

The baseband interface of the SDR hardware uses
sampled complex baseband signals in I/Q (real/imag-
inary) format and most of the signal processing oper-
ates on these complex signals.
As an example, in this lab we will translate the fre-

quency of signal by multiplying it by a complex sinu-
soid. GNU Radio also includes blocks that convert
between signal of different types (e.g. byte, float and
complex).

ML PRBS

In evaluating, testing and implementing communi-
cation systems we often need a signal that has statis-
tics similar to that of a random binary source but
which is deterministic. This is called a pseudo-
random bit sequence (PRBS).
The most common type of PRBS is the Maximal-

Length PRBS (ML-PRBS) which has certain desirable
properties, including having the maximum possible
period for a given generator complexity.
AnML-PRBS can be generated using flip-flops and

exclusive-or gates to compute feedback in a circuit
called a linear-feedback shift register (LFSR).

Filters

The radio spectrum is divided into bands which are
allocated to different uses (broadcasting, cellular,
radio-navigation, etc.). Each band is typically divided
into smaller ranges, called channels with each chan-
nel allocated to a different set of users.

Filtering is an important part of most communica-
tion systems. Transmitters use them to limit out-of-
band power that might interfere with users of other
channels and receivers use them to reject signals
present on other channels.
Low-pass filters are also used when changing the

sampling rate of digitized signals. Increasing (“inter-
polation”) or decreasing (“decimation”) the sampling
rate requires post- or pre-filtering the signal to avoid
aliasing.
There aremany digital filter types (IIR, FIR), archi-

tectures (parallel, cascade, FFT) and design methods
(window, mini-max). In this lab we will use a simple
window-based design of an FIR filter to interpolate
a low-bandwidth baseband signal’s sampling rate to
the higher rate required by the SDR transmitter.

Variables and GUI Widgets

A GNU Radio flowgraph is actually a Python script.
This allows us to embed variables (using the “Vari-
able” block) and arbitrary Python code into a flow-
graph.
It’s also possible to include blocks that create

user interface components (“widgets”) that are active
while the block is running. These can be used to dis-
play waveforms or frequency spectra and to change
values of variables 2. These variables can be used in
expressions that configure the operation of blocks.

2Parameters whose names are underlined in a block’s prop-
erties dialog box can be updated during flowgraph execution.
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Procedure

In this lab youwill use GNU radio to build a transmit-
ter that incorporates some typical blocks. The flow-
graph generates a ML-PRBS, multiplies it by a com-
plex exponential to shift the frequency and then in-
terpolates to increase the sampling rate.
The diagram in Figure 1 shows the flowgraph.

Using GRC

Start GRC. Under the View menu enable the Block
Tree Panel, Console Panel and Variable Editor. Make
sure ‘Hide Variables’ is not checked.
The easiest way to add a block is to search for it by

name. Click on themagnifying glass icon ( ) on the
menu bar or type Control-F. Type part of the block
name and double-click on the desired block name.
This adds it to the flowgraph. You can then move the
block by dragging it (any connections will follow).
To connect block outputs to inputs click on the out-

put port and then click on the input port you want to
connect it to.
As in any diagram, the blocks should be arranged

so that the logical flow is left-to-right and top-to-
bottom whenever possible.
Samples flowing between blocks can be of differ-

ent types. Bits are typically transferred in the least-
significant bit of a Byte type and signal samples are
typically Float or Complex types. In GRC the color
of the input and output connectors reflects the signal
type (e.g. orange for floats, blue for complex).
If there is a mismatch between the signal types the

connector will be drawn in red.
You can double-click on a block to open up its

properties dialog box. This allows you to configure
the input and output types and other aspects of the
block’s operation. The block’s title and some of the
block’s properties are displayed inside the block in
the flowgraph.
Some blocks define data structures rather than

process samples. An example isVariable blocks that
set the value of a variable. This variable can be used
when configuring other blocks. By default a variable,
samp_rate, is included in a new flowgraph.

Configure the Flowgraph

Use the File ▶ Open menu item to start a new QT
GUI flowgraph. Then add, configure and connect the
following blocks:
Variable Add a second variable with ID interp.

This will be used to set the interpolation ratio
between baseband samples and RF samples.
Add a third variable with ID bb_rate that has
the value samp_rate/interp. Note that the
value of a variable can be set to an arbitrary
Python expression. The code generated for each
block is shown in the “Generated Code” tab.

GLFSR Source This block (Galois LFSR) generates
a PRBS. Configure this block as follows:

Degree, 𝑁, is the number of bits in the shift reg-
ister. The PRBS period is 2𝑁 − 1 bits. Configure
𝑁 = 3 which will generate a PRBS with a pe-
riod 7 bits. Mask defines the LFSR taps. If speci-
fied as 0 a suitable generator polynomial for the
specified degree will be chosen. Note that float
outputs have values ±1 while byte outputs have
values 0 or 1.

Type Conversions Type conversions are some-
times required. For example, the GLFSR
Source above is configured to output floats but
these need to be converted to Complex values.
Add a Float To Complex block that sets the
imaginary component to zero by connecting a
Constant Source with value 0.

Signal Source Add a [Co-]Sinusoidal signal source
with a Complex output whose amplitude is
1 and whose frequency is set by the variable
f_offset. It is configured as follows:
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Rational Resampler Add an interpolator block
configured as follows:

This interpolates by a factor interp and the
low-pass anti-aliasing filter is set to the follow-
ing expression:

filter.firdes.low_pass_2(1,samp_rate,
0.5*samp_rate/interp,0.02*samp_rate,60)

This Python expression computes the FIR filter
taps for a low-pass filter. The function parame-
ters specify the gain, sampling frequency, -6 dB
cutoff frequency, width of transition band and
required stopband attenuation (in dB).

Multiplier This block does a complex multiplica-
tion of two inputs.

QT GUI Frequency Sink This block is similar to a
spectrum analyzer and shows the power spec-
trum when the flowgraph is running.

QT GUI Time Sink This block is similar to an oscil-
loscope and shows the real and imaginary com-
ponents versus time when the flowgraph is run-
ning.

QT GUI Range This block defines a GUI interface
item that allows run-time changes to variables
when the flowgraph is run. Set ID to f_offset
to allow run-time control of the frequency of
the complex [co]sinusoidal signal source block
added above.

The GUI blocks have configuration options for
how they should be displayed in the window
that is created when the flowgraph executes. In
addition to input types, ranges, labels, etc, the
GUIHint provides some control over the position-
ing of the GUI elements (and use of tabs). For
example, a hint of [1,2] means to place that
GUI element on the first row, second column.

osmocom Sink This block represents the interface
to the transmit portion of the SDR hardware. It
is configured as follows:

The Device Arguments driver=lime,soapy=0
selects a driver, a Sample Rate of samp_rate
sets the DAC sample rate, the Ch0 Frequency
sets the RF center frequency3, the Gain values
set the gains of the digital and analog portions
of the transmitter, Ch0 Antenna selects one of
RF matching networks on the PCB, Ch0 Band-
width selects the (two-sided) baseband band-
width. Note that in this case we’ve set the band-
width and the sampling rate to be the same
(5 MHz) which is appropriate for complex base-
band signals.

Measurements

The LimeSDR Mini SDR board’s USB interface will
have been connected to one of the lab PC’s USB 3.0
ports and it’s RF output to the RF in port of the spec-
trum analyzer as shown below:

3This covers an amateur radio band although we will not be
transmitting “over the air” in this lab.
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Select Run ▶ Execute, press F6, or press on the
run ( ) icon. This will convert the flowgraph to a
Python script and run it.

View the RF Spectrum

Run the fixperm.bat utility and the Anritsu MST
(Master Software Tools). Select the LAN interface
with IP address 192.168.1.10 and open the Remote
Access Tool:

This will bring up an interface the replicates the
front panel (although with an even slower interface
than the actual front panel). Configure the spec-
trum analyzer for a center frequency of 222.5 MHz,
a span of 5 MHz, reference level of 10 dBm and reso-
lution/video bandwidths of 10 kHz and 3 kHz respec-
tively.
Capture the baseband spectrum shown on the

GNU Radio Companion run-time window (“Top
Block”) and the RF spectrum as displayed on the
spectrum analyzer using theWindows Snipping Tool
(or similar, don’t use your phone!):

Additional Test Cases

Predict the effect of each of the following changes.
Make the change and capture the resulting baseband
signal and RF spectrum to check your predictions.
Make each change independently (revert back to the
original settings between each change).

• shift the signal up in frequency by 1 MHz using
the GUI slider

• change the PRBS period from 7 to 255 bits

• change the filter Taps to [1] to disable the inter-
polator’s anti-aliasing filter

Lab Report

Submit a report in PDF format to the appropriate
dropbox on the course web site.
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Your report should include the four GUI and spec-
trum analyzer captures and answers to the following
questions:

• What is the result of multiplying 𝑒−𝑗𝜔1𝑡

by 𝑒−𝑗𝜔2𝑡? What is/are the resulting fre-
quency(ies)? How does this differ from
multiplying two real sinusoids?

• How does the baseband spectrum shown in the
frequency sink GUI differ from the one shown
by the spectrum analyzer?

• What is the period of the PRBS sequence for𝑁 =
3? What is the spacing of the frequency compo-
nents? What are the period and frequency spac-
ing for 𝑁 = 8?

• What happens when you disable the interpola-
tor’s low-pass filtering? What is the name of this
effect?

Troubleshooting

• Check that Device Manager shows an “FTDI
FT601 USB 3.0 Bridge Device” to verify that the
SDR board is connected:

• Run the LimeSuite utility and select Options >
Connection Settings and check that a LimeSDR
Mini is detected:

• Click on the line with the device name to high-
light it and click on “Connect”. Click on “Cal-
ibrate All” and verify there are no errors (the I
and Q gains should change from the default val-
ues).

• Download Lime100cw.grc from the course
web site and run it. The message window
should show something like:

with no errors.

• Run theAnritsuMST (Master Software Tools) as
described above and set the center frequency to
100 MHz. You should see a carrier in the center
of the display:
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